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Important Information

Except as otherwise expressly stated in the License that accompanies a program, Texas
Instruments makes no warranty, either express or implied, including but not limited to
any implied warranties of merchantability and fitness for a particular purpose,
regarding any programs or book materials and makes such materials available solely
on an "as-is" basis. In no event shall Texas Instruments be liable to anyone for special,
collateral, incidental, or consequential damages in connection with or arising out of the
purchase or use of these materials, and the sole and exclusive liability of Texas
Instruments, regardless of the form of action, shall not exceed the amount set forth in
the license for the program. Moreover, Texas Instruments shall not be liable for any
claim of any kind whatsoever against the use of these materials by any other party.

License

Please see the complete license installed in C:\Program Files\TI Education\<TI-Nspire™
Product Name>\license.

Adobe®, Adobe® Flash®, Apple®, Blackboard™, Chrome®, Excel®, Google®, Firefox®,
Internet Explorer®, Java™, JavaScript®, Mac®, Microsoft®, Mozilla®, OS X®,
PowerPoint®, Safari®, Vernier DataQuest™, Vernier EasyLink®, Vernier EasyTemp®,
Vernier Go!Link®, Vernier Go!Motion®, Vernier Go!Temp®, Windows®, and Windows®
XP are trademarks of their respective owners.

© 2006 - 2017 Texas Instruments Incorporated
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Getting Started with TI-Nspire™ CX Student Software
TI-Nspire™ software enables students to use PC and Mac® computers to perform the
same functions as on a handheld. This document covers TI-Nspire™ CX Student
Software and TI-Nspire™ CX CAS Student Software.

Using the Welcome Screen

By default, the Welcome Screen opens the first time you start the software after
installation is complete. To begin working with documents, click an icon or link, or
close this screen manually. Actions that take place automatically, such as upgrade
prompts or the ability to begin using connected handhelds, are available after you close
the Welcome Screen.

Note: Depending on how your software was installed, you might see a Product
Improvement screen the first time you start the software.

À TI-Nspire™ applications. Click one of these icons to create a new document with the
selected application active. The applications are Calculator, Graphs, Geometry,
Lists & Spreadsheet, Data & Statistics, Notes, and the Vernier DataQuest™
application. When you click an icon, the Welcome Screen closes and the selected
application opens.

Á Quick Start links. Click one of these options to:

• Open an existing document.

• Select a document from a list of recently opened documents.

Â Always show this at startup. Clear this check box to skip this screen when you open
your software.
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2 Getting Started with TI-Nspire™ CX Student Software

Closing the Welcome Screen

To access the default workspace and begin working with documents, click to close
the Welcome Screen. To open the Welcome screen again, click Help > Welcome Screen.

Exploring the Documents Workspace

Note: Although not labeled, the Documents Workspace is the default workspace in the
TI-Nspire™ CX Student Software. Throughout the documentation and help, the area
where you work with documents is referred to as the Documents Workspace.

Use the menu options and toolbar options in the workspace to create or edit
TI-Nspire™ and PublishView™ documents and work with applications and problems.
The tools in the workspace are specific to working with open documents.

À Toolbar. Contains shortcuts to frequently performed tasks such as creating new
documents, opening existing documents, saving documents, inserting
applications, inserting variables, and capturing screens. The cut, copy, and
paste icons are also located in the toolbar. At the right side, a Document
Preview button lets you select Handheld or Computer preview.

Á Documents Toolbox. Contains tools needed to work with TI-Nspire™ and
PublishView™ documents. Use these tools to open the application menus, use
the page sorter to view TI-Nspire™ documents, open the TI-SmartView™
emulator, open Content Explorer, insert utilities such as math templates and
the symbols from the catalog, and insert text and images into PublishView™
documents. Click each icon to access the available tools.

Â Toolbox pane. Options for the selected tool are displayed in this area. For
example, click the Document Tools icon to access tools needed to work with



the active application.

Ã Work area. Shows the current page of the active (selected) document. Lets you
perform calculations, add applications, and add problems and pages. Only one
document at a time is active. Multiple documents appear as tabs.

Ä Status bar. Provides information about the active document.

Understanding the Status Bar

The status bar provides information about the current document, and provides options
that enable you to toggle between Handheld and Computer view and adjust how the
document appears in the work area.

À Page Size. Shows the document's page size as Handheld or Computer. You can
use the TI-Nspire™ File menu to convert a document from one page size to the
other.

Á Problem/Page counter. The first value represents the problem number of the
active page, and the second value tells you the page number within the
problem. In the example, the counter reads 1.2, indicating Problem 1, Page 2.

Â Settings. Double-click to view or change the Document Settings for the active
document or to change the default Document Settings.

Ã Zoom. Enabled in Handheld preview only (click Document Preview on the
toolbar and select Handheld). Click▼ and select a magnification value for the
preview.

Ä Boldness. Enabled in Computer preview only (click Document Preview on the
toolbar and select Computer). Click▼ and select a value to increase or
decrease the boldness of text and other items.

Changing Language

Use this option to select a preferred language. You must restart the software for the
language to take effect.

1. Click File > Settings > Change Language.

The Choose a Language dialog box opens.
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4 Getting Started with TI-Nspire™ CX Student Software

2. Click¤ to open the Choose language drop-down list.

3. Select the desired language.

4. Click Quit Now to close the software immediately. You will be prompted to save
any open documents. When you restart the software, the language change is
effective.

—or—

Click Quit Later to continue your work. The language change is not applied until you
close and restart the software at a later time.

Note: If you select Simplified Chinese or Traditional Chinese as the language in the
TI-Nspire™ software, you should see Chinese characters in the menus and dialogs. If
your computer uses the Windows® XP operating system and you do not see Chinese
characters, you may need to install the Windows® XP East Asian Language Support
package.



Using the Documents Workspace
Use this workspace to create, modify, and view TI-Nspire™ and PublishView™
documents, and to demonstrate mathematical concepts.

Exploring the Documents Workspace

À Documents Toolbox. Contains tools such as the Document Tools menu, Page
Sorter, TI-SmartView™ emulator, Utilities, and Content Explorer. Click each
icon to access the available tools. When you are working in a TI-Nspire™
document, the tools available are specific to that document. When you are
working in a PublishView™ document, the tools are specific to that document
type.

Á Toolbox pane. Options for the selected tool are displayed in this area. For
example, click the Document Tools icon to access tools needed to work with
the active application.
Note: In the TI-Nspire™ CX Teacher Software, the tool for configuring questions
opens in this space when you insert a question. For more information, see
Using Question in the Teacher Software.

Â Work area. Shows the current document and enables you to perform
calculations, add applications, and add pages and problems. Only one document
at a time is active (selected). Multiple documents appear as tabs.

Ã Document information. Shows the names of all open documents. When there
too many open documents to list, click the forward and backward arrows to
scroll through the open documents.

Using the Documents Toolbox

The Documents Toolbox, located on the left side of the workspace, contains tools
needed for working with both TI-Nspire™ documents and PublishView™ documents.
When you click a toolbox icon, the associated tools appear in the Toolbox pane.
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6 Using the Documents Workspace

Exploring Document Tools
In the following example, the Document Tools menu is open showing the options for the
Calculator application. In TI-Nspire™ documents, the Document Tools menu contains tools
available for working with an application. The tools are specific to the active application.

In PublishView™ documents, the Document Tools menu contains tools needed to insert
TI-Nspire™ applications and TI-Nspire™ documents, as well as multimedia objects such
as text boxes, images, and links to websites and files. For more information, see
Working with PublishView™ Documents.

À The Documents Toolbox menu.

Á Tools available for the Calculator application. Click ¢ to open the submenu for
each option.

Â
Click to close and click to open Document Tools.

Exploring the Page Sorter

The following example shows the Documents Toolbox with the Page Sorter open. Use
the Page Sorter to:

• See the number of problems in your document and where you are.

• Move from one page to another by clicking the page you want.



• Add, cut, copy, and paste pages and problems within the same document or
between documents.

Note: When you are working in a PublishView™ document, the Page Sorter is not
available in the Documents Toolbox.

À The Documents Toolbox menu.

Á Click the minus sign to collapse the view. Click the + sign to open the view and
show pages in the document.

Â Scroll bar. The scroll bar is only active when there are too many pages to show
in the pane.

Exploring the TI-SmartView™ Feature
The TI-SmartView™ feature emulates how a handheld works. In the teacher software, the
emulated handheld facilitates classroom presentations. In the student software, the
emulated keypad gives students the ability to drive the software as if using a handheld.
Note: Content is displayed on the TI-SmartView™ small screen only when the document is
in Handheld view.
When working in a PublishView™ document, TI-SmartView™ emulator is not available.
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8 Using the Documents Workspace

Note: The following illustration shows the TI-SmartView™ panel in the teacher
software. In the Student Software, only the keypad is shown. For more information,
see Using the TI-SmartView™ Emulator.

À The Documents Toolbox menu.

Á Handheld Selector. Click¤ to select which handheld to show in the pane:

• TI-Nspire™ CX or TI-Nspire™ CX CAS

Then, select how to show the handheld:

• Normal

• High contrast

• Outline
Â View selector. In the teacher software, click¤ to select the handheld view:



• Handheld only

• Keypad plus side screen

• Handheld plus side screen

Note: You can also change these options in the TI-SmartView™ Options
window. Click File > Settings > TI-Smartview™ Options to open the window.
Note: The view selector is not available in the student software.
When the Handheld Only display is active, select Always in Front to keep the
display in front of all other open applications. (Teacher software only.)

Exploring Utilities

Utilities provides access to the math templates and operators, special symbols, catalog
items, and libraries that you need when working with documents. In the following
example, the Math templates tab is open.

À The Documents Toolbox menu.

Á Math Templates are open. Double-click a template to add it to a document.
Click the Math Template tab to close the template view.
To open the Symbols, Catalog, Math Operators, and Libraries, click the tab.

Â Wizards On check box. Select this option to use a wizard to enter function
arguments.
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10 Using the Documents Workspace

Ã Tabs for opening views where you can select and add symbols, catalog items,
math operators, and library items to a document. Click the tab to open the
view.

Exploring Content Explorer

Use Content Explorer to:

• See a list of files on your computer.

• Create and manage lesson bundles.

• If using software that supports connected handhelds, you can:

- See a list of files on any connected handheld.
- Update the OS on connected handhelds.
- Transfer files between a computer and connected handhelds.

Note: If you are using TI-Nspire™ software that does not support connected handhelds,
the Connected Handheld heading is not shown in the Content Explorer pane.



À The Documents Toolbox menu.

Á Shows files on your computer and the name of the folder where the files are
located. Click¤ to navigate to another folder on the computer.

Â The list of folders and files within the folder named in the Look In: field. Right-click
on a highlighted file or folder to open the context menu listing available actions for
that file or folder.

Ã
Click to close the list of files. Click to open the list of files.

Ä Options menu. Click¤ to open the menu of actions you can perform on a
selected file:

• Open an existing file or folder.
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12 Using the Documents Workspace

• Move (navigate) up one level in the folder hierarchy.

• Create a new folder.

• Create a new lesson bundle.

• Rename a file or folder.

• Copy selected file or folder.

• Paste file or folder copied to Clipboard.

• Delete selected file or folder.

• Select all files in a folder.

• Package lesson bundles.

• Refresh the view.

• Install OS.

Å Connected handhelds. Lists the connected handhelds. Multiple handhelds are listed
if more than one handheld is connected to the computer or when using the
TI-Nspire™ Docking Stations.

Æ The name of the connected handheld. To show the folders and files on a handheld,
double-click the name.
Click¤ to navigate to another folder on the handheld.

Using the Work Area

The space on the right side of the workspace provides an area for creating and working
with TI-Nspire™ and PublishView™ documents. This work area provides a view of the
document so that you can add pages, add applications, and perform all work. Only one
document at a time is active.

When you create a document, you specify its page size as Handheld or Computer. This
is how the page is displayed in the work area.

• Handheld page size is optimized for the smaller screen of a handheld. This page
size can be viewed on handhelds, computer screens, and tablets. The content is
scaled when viewed on a larger screen.

• Computer page size takes advantage of the larger space of a computer screen.
These documents can show details with less scrolling required. The content is not
scaled when viewed on a handheld.

You can change the page preview to see how the document will look in a different
page size.



▶ To change the page preview, click Document Preview on the toolbar, and then click
Handheld or Computer.

For more information on page size and document preview, see Working with
TI-Nspire™ Documents.

Changing Document Settings

Document settings control how all numbers, including elements or matrices and lists,
are displayed in TI-Nspire™ and PublishView™ documents. You can change the default
settings at anytime and you can specify settings for a specific document.

Changing Document Settings

1. Create a new document or open an existing document.

2. From the TI-Nspire™ File menu, select Settings > Document Settings.

The Document Settings dialog box opens.

When you open Document Settings the first time, the default settings are
displayed.

3. Press Tab or use your mouse to move through the list of settings. Click¤ to open
the drop-down list to view the available values for each setting.

Field Value

Display
Digits

• Float
• Float1 - Float12
• Fix0 - Fix12

Angle • Radian
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Field Value

• Degree
• Gradian

Exponential
Format

• Normal
• Scientific
• Engineering

Real or
Complex
Format

• Real
• Rectangular
• Polar

Calculation
Mode

• Auto
• CAS: Exact
• Approximate

Note: Auto mode shows an answer that is not a whole number
as a fraction except when a decimal is used in the problem.
Exact mode (CAS) shows an answer that is not a whole number
as a fraction or in symbolic form, except when a decimal is used
in the problem.

Vector
Format

• Rectangular
• Cylindrical
• Spherical

Base • Decimal
• Hex
• Binary

Unit System
(CAS)

• SI
• Eng/U.S.

4. Click the desired setting.

5. Choose one of the following options:

• To apply the customized settings to ALL documents, clickMake Default.
• To apply the settings to the open document only, click OK.
• To restore default settings, click Restore.
• Click Cancel to close the dialog box without making changes.

Changing Graphs & Geometry Settings

Graphs & Geometry settings control how information is displayed in open problems
and in subsequent new problems. When you change the Graphs & Geometry settings,
the selections become the default settings for all work in these applications.



Complete the following steps to customize the application settings for graphs and
geometry.

1. Create a new graphs and geometry document or open an existing document.

2. In the Documents Toolbox, click to open the Graphs & Geometry application
menu.

3. Click Settings > Settings.

The Graphs & Geometry Settings dialog box opens.

4. Press Tab or use your mouse to move through the list of settings. Click ¢ to open
the drop-down list to view the available values for each setting.

Field Values
Display Digits • Auto

• Float
• Float1 -

Float12
• Fix0 - Fix12

Graphing Angle • Auto
• Radian
• Degree
• Gradian

Geometry Angle • Auto
• Radian
• Degree
• Gradian
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5. Select the desired setting.

6. Select a check box to enable an option or clear a check box to disable an option.

Check box Operation when selected

Automatically hide
plot labels

Plot labels are displayed only when selected, grabbed,
or hovered.

Show axis end values A numeric label is displayed at the least and greatest
values visible on an axis

Show tool tips for
function manipulation

Shows helpful information as you manipulate function
graphs

Automatically find a
point of interest

Shows zeros, minima, and maxima for graphed functions
and objects while tracing function graphs.

7. Choose one of the following options:

• To apply the customized settings to ALL graphs and geometry documents, click
Make Default.

• To apply the settings to the open document only, click OK.
• To restore default settings, click Restore.
• Click Cancel to close the dialog box without making changes.



Working with Connected Handhelds
The TI-Nspire™ software enables you to view content, manage files, and install
operating system updates on handhelds connected to the computer.

To use the features described in this chapter, handhelds must be turned on and
connected by one of these means:

• TI-Nspire™ Docking Station or TI-Nspire™ CX Docking Station

• TI-Nspire™ Navigator™ Cradle and access point

• TI-Nspire™ CX Wireless Network Adapter and access point

• TI-Nspire™ CX Wireless Network Adapter - v2 and access point

• A direct connection through a standard USB cable

Note: The tasks in this section can only be performed using TI-Nspire™ handhelds. In
order to enable wireless connectivity, the TI-Nspire™ Navigator™ Teacher Software and
the OS installed on the TI-Nspire™ handhelds must be version 3.9 or later.

Managing Files on a Connected Handheld

When working with files on connected handhelds in the Content Workspace, use the
Options menu or the context menu to manage files.

Note: If you select a file type that is not supported on the handheld, some selections in
Options menu are not active.

Option How it Works

Open Open a file on a connected handheld:

• Click the file you want to open.

• Click Open. The document opens in the Documents Workspace.

Save to
Computer

Save a copy of the selected file on your computer:

• Click the file you want to save.

• Click Save to Computer. The Save Selected Files dialog box
opens.

• Navigate to the folder where you want to save the file.

• Click Save.

Copy/Paste Create a copy of a file:
• Click the file you want to copy.
• Click Options > Copy to copy the file to the Clipboard.
• To paste the file in another location, navigate to the new location,

and then click Options > Paste.
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Option How it Works

Note: If you don’t select a new location, the copied file is pasted
with a new name "Copy of ..."

Delete Delete a file on a connected handheld:
• Click the file you want to delete.
• Click Delete.
• Click Yes when the Warning dialog box opens. Click No to cancel.

Refresh To refresh the list of files, click Options > Refresh.

Rename To rename a file on a connected handheld:
• Click the file you want to rename.
• Click Options > Rename.
• Type the new name and press Enter.

Up a Level Go up a level in the folder hierarchy. This option is available when you
select a file inside a folder.

New Folder Create a new folder:

• Click New Folder.

• Type a name for the new folder.

• Press Enter.

Opening Documents on a Connected Handheld

To open a document on a connected handheld in the TI-Nspire™ software:

1. Ensure the handheld is connected to your computer.

2. Click to open Content Explorer.

The connected handheld name is listed in the Connected Handhelds pane.

3. Double-click the handheld name.

The folders and documents on the handheld are listed.

4. Navigate to the document you want to open, and then double-click the file name.

The document opens in the Documents Workspace.

Saving Files to a Connected Handheld

When you save a file from your computer to a handheld, files are converted to
TI-Nspire™ documents (.tns files). (See Sending Files to Handhelds)

To save a file on your computer to a connected handheld:



1. Ensure the handheld is connected to your computer.

2. Click to open Content Explorer.

The folders and files on your computer are listed in the Computer pane.

3. Navigate to the folder or file you want to save to the handheld.

4. Click the file to select it.

5. Drag the file to a connected handheld listed in the Connected Handheld pane.

The file is saved to the connected handheld.

Note: To save the file in a folder on the handheld, double-click the handheld name
to list the folders and files, and then drag the file to a folder on the handheld.

If the file already exists on the handheld, a dialog box opens asking if you want to
replace the file. Click Replace to overwrite the existing file. Click No or Cancel to
abandon the save.

Checking for an OS Update

When handhelds are connected, you can check for OS updates from the Content
Workspace or from the Documents Workspace.

Note: Your computer must be connected to the Internet.

1. Show all connected handhelds.

• In the Content Workspace, click Connected Handhelds in the Resources pane.
• In the Documents Workspace, open the Content Explorer and click Connected

Handhelds.

2. Click the handheld you want to check, and then right-click and select Check for
OS Update.

• If the operating system is current, the Check for Handheld OS Update dialog
box opens indicating that the operating system on the handheld is current.

• If the operating system is not current, the TI-Nspire™ software prompts you to
install the latest OS now, with the option to download the OS to your
computer.
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3. Click Close to close the dialog box, or click Continue and follow the prompts to
install the OS on the handheld.

Installing an OS Update

Note: To avoid losing unsaved data, close all documents on the handheld before
updating its operating system (OS). Updating the OS does not replace or remove
previously saved documents.

The OS on a new handheld comes bundled with the installer, which places the OS in a
default location such as: C:\mydocuments\TI-Nspire\downloads.

Go to education.ti.com/latest to download the latest OS files.

Note: You can install OS updates on connected handhelds from the Content Workspace
at any time.

Updating the OS on a Single Handheld

1. Ensure that your computer is connected to the internet.

2. Show all connected handhelds by clicking the arrow next to TI-Nspire™ Connected
Handhelds in the Resources pane.

Note: Anattention symbol next to a

handheldnamemeans:

The handheldneeds anOS update.
—or—
The handheldhas a newer OS than the
teacher's.

https://education.ti.com/latest


3. Hover your mouse over the TI-Nspire™ handheld you want to update, and then
right-click.

4. Click Check for OS Update.

The Check for OS Update dialog box opens.

5. Click Close to cancel the installation, or click Continue and follow the prompts to
install the OS on the handheld.

When the update is complete, the handheld restarts automatically.

Updating the OS on Multiple Handhelds 

Note: To avoid losing unsaved data, close all documents on the handheld before
updating its operating system (OS). Updating the OS does not replace or remove
previously saved documents.

1. Click TI-Nspire™ Connected Handhelds in the Resources pane.

2. Select all handhelds you want to update in the Content Pane.

3. Click Tools > Install OS.

The OS Installation dialog box opens.
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4. Click Add OS file.

The Add to Transfer List dialog box opens.

5. Select the applicable OS files.

• To upgrade a TI-Nspire™ CX handheld, select TI-Nspire.tco.

• To upgrade a TI-Nspire™ CX CAS handheld, select TI-Nspire.tcc.

• To upgrade a TI-Nspire™ handheld, select TI-Nspire.tno.



• To upgrade a TI-Nspire™ CAS handheld, select TI-Nspire.tnc.

6. Click Select.

The OS Installation redisplays with your selected OS files.

7. Click Install OS.

The OS version information updates, and the Select OS Handheld File dialog
redisplays for further selection.
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Working with TI-Nspire™ Documents
All work that you create and save using TI-Nspire™ applications is stored as a
document, which you can share with others using TI-Nspire™ software and with those
using handhelds. There are two types of documents:

• TI-Nspire™ document (.tns file)

• PublishView™ document (.tnsp file)

TI-Nspire™ Documents

A TI-Nspire™ document consists of one or more problems. Each problem can contain
one or more pages. A single page is displayed in the work area. All work occurs in the
applications within pages.

Because the TI-Nspire™ software and handhelds share the same functionality, you can
transfer TI-Nspire™ documents between computers and handhelds. When you create a
document, you select one of two page sizes.

• Handheld. Size: 320 × 217 pixels. This size allows documents to be viewed on all
platforms. The content will be scaled when viewed on a tablet or larger screen.

• Computer. Size: 640 × 434 pixels. The content will not be scaled when viewed on
smaller platforms. Some content may not be visible on a handheld device.

You can convert a document from one page size to the other anytime.

PublishView™ Documents

PublishView™ documents can be printed on a standard piece of paper or published to a
website or blog. PublishView™ documents can include formatted text, images, and
hyperlinks as well as all TI-Nspire™ applications.

For more information, see Working with PublishView™ Documents.

Creating a New TI-Nspire™ Document

When you open the software, the Documents Workspace opens with a blank document
containing one problem. You can add applications and content to this problem to
create a document.

Note: The Welcome Screen is displayed when you open the software if the "always
show this at startup" option is selected. Click an application icon to add a problem with
an active application to a new document.

To create a new document, complete the following steps:

1. On the TI-Nspire™ File menu,

• Select New TI-Nspire™ Document - Handheld Page Size.

—or—

• Select New TI-Nspire™ Document - Computer Page Size.
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The new document opens in the Documents Workspace, and you are prompted to
select an application.

2. Select an application to add a problem to the document.

The problem is added to the document.

Opening an Existing Document

To open an existing document:

1. Click File > Open Document.

—or—

Click .

The Open dialog box opens.



2. Use the file browser to locate the file you want to open and click the file to select
it.

3. Click Open.

The document opens in the work area.

Note: To select from your 10 most recent documents, click File > Recent Documents
and select a document from the drop-down list.

Saving TI-Nspire™ Documents

To save a new document:

1. Click File > Save Document or click .

The Save TI-Nspire™ Document dialog box opens.
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2. Navigate to the folder where you want to save the document or create a folder in
which to store the document.

3. Type a name for the new document.

4. Click Save to save the document.

The document closes and is saved with the extension .tns.

Note: When you save a file, the software looks in the same folder the next time you
open a file.

Saving a Document with a New Name

To save a previously saved document in a new folder and/or with a new name:

1. Click File > Save As.

The Save TI-Nspire™ Document dialog box opens.

2. Navigate to the folder where you want to save the document or create a folder in
which to store the document.

3. Type a new name for the document.

4. Click Save to save the document with a new name.

Deleting Documents

File deletions on your computer are sent to the Recycle bin and can be retrieved if the
Recycle bin has not been emptied.

Note: File deletions on the handheld are permanent and cannot be undone, so be sure
that you want to delete the file that you select.

1. Select the document you want to delete.

2. Click Edit > Delete or press Delete.

The Warning dialog box opens.

3. Click Yes to confirm the delete.

The document is deleted.

Closing Documents

▶ To close a document, click File > Close or click the Close icon on the document tab
at the bottom of the document.

▶ If working in tiled view, click the Close icon in the upper right corner of the
document window.



Formatting Text in Documents

Use the text formatting tools to format text in TI-Nspire™ applications that allow
formatted text, and to format text in PublishView™ documents. By default, the text
formatting toolbar opens in the area above an active document. Options on the toolbar
are enabled or disabled depending on the active application.

Option Function

Click¤ to open the menu for the active
application. This tool enables you to open an
application menu regardless of the option
selected in the Documents Toolbox.

Click¤ to select a background color for
highlighting text or choose a fill color for a
selected cell.

Click¤ to select the line color for an object. For
example, in Graphs & Geometry, you can choose a
color for a selected shape.

Click¤ to select a color for selected text.

Use these tools to choose a font and set the size
of the font.

• Click¤ to select a different font from the
drop-down box.

• To select as specific font size, click¤ to
select a size from the drop-down box.

• Click to increase the font size or click

to decrease the font size incrementally.

Click the appropriate tool to apply bolding, italics,
or underlining; apply superscript or subscript; or
strike out text.

In a PublishView™ document, use these tools to
position text within the header or footer, or in

text box. Clicking opens the Hyperlink dialog
box.
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Option Function

For more information, see Working with
PublishView™ Documents.

Hiding and Showing the Formatting Toolbar

▶ When the formatting toolbar is visible, click£ (located under the toolbar) to hide
the toolbar.

▶ Click¤ to show the toolbar when the formatting toolbar is hidden.

Using Colors in Documents

In the TI-Nspire™ applications that allow formatting, you can use color in filled areas of
an object, or in lines or text, depending on the application you are using and how you
have selected the item. If the icon or menu item that you want to use is not available
(dimmed) after you have selected an item, color is not an option for the selected item.

Colors appear in documents opened on your computer and on the TI-Nspire™ CX
handheld. If a document containing color is opened on a TI-Nspire™ handheld, colors
are displayed in shades of gray.

Note: For more information about using color in a TI-Nspire™ application, see the
chapter for that application.

Adding Color from a List

To add color to a fill area, line, or text, complete the following steps:

1. Select the item.

2. Click Edit > Color or select where you want to add color (fill, line, or text).

3. Select the color from the list.

Adding Color from a Palette

To add color using the palette, complete the following steps:

1. Select the object.

2. Click the appropriate toolbar icon.

3. Select the color from the palette.

Setting Page Size and Document Preview

When you ceate a document, you specify its page size as Handheld or Computer,
depending on how you expect the document to be used. Documents of both page sizes
can be opened on either platform, and you can convert the page size anytime.



• Handheld. Size: 320 × 217 pixels, fixed. Handheld documents can be viewed on all
platforms. You can magnify (zoom) the content when viewing it on a tablet or
larger screen.

• Computer. Size: 640 × 434 pixels, minimum. Computer documents scale up
automatically to take advantage of higher resolution screens. The minimum size is
640 × 434, so some content may be clipped on handheld devices.

Note: You can view documents of either page size using Handheld or Computer
preview.

Converting the Current Document's Page Size

▶ On the main TI-Nspire™ File menu, select Convert to, and then select the page size.

The software saves the current document and creates a copy that uses the
requested page size.

Viewing the Document in Handheld Preview

1. On the application toolbar, click Document Preview, and select Handheld.

The preview changes. This does not change the document's underlying page size.

2. (Optional) Adjust the viewing magnification:

- Click the Zoom tool beneath the work area, and select a magnification value.

—or—

- Click the Zoom to Fit button to make the handheld preview adjust
automatically to the window size.

Viewing the Document in Computer Preview

1. On the application toolbar, click Document Preview, and select Computer.

The preview changes. This does not change the document's underlying page size.

2. (Optional) Click the Boldness tool beneath the work area, and select a value to
increase or decrease the boldness of text and other items.

Setting the Default Page Size for New Documents

1. On the main TI-Nspire™ File menu, select Settings > Page Size Settings.

2. Select a default page size, either Handheld or Computer.
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The new size applies to documents that you create (Windows®: Ctrl+C, Mac®:
Cmd+C) after setting the default, including the blank document created
automatically each time you open the software. Changing the default setting does
not convert any currently open documents or other existing documents.

Setting a Default Preview

By default, when you open a document, it is automatically displayed using the preview
that matches its page size. You can override this rule and specify a preview that you
prefer.

1. On the main TI-Nspire™ File menu, select Settings > Preview Settings.

2. Select the preview that you want documents to use when you open them.

Working with Multiple Documents

When multiple documents are open, document names are listed in tabs at the bottom
of the work area. Only one document is active at a time, and only the active document
is affected by commands from menus or tools.

To switch between documents:

À Click the tab to show a document in the work area. This document
becomes the active document. If the Show Documents in Tiles view is
open, these tabs are not shown.

Á Use the right and left arrows to scroll through the list of documents.
These arrows are active only when there are too many documents to fit
in the window.

Â Click the Show List icon to list all open documents. This is useful when
you have a large number of documents open and documents names on
the tabs may be truncated.

Working with Multiple Documents in Tiled View

When multiple documents are open, you can view thumbnails of the documents in the
work area. To change the view:

▶ ClickWindow > Show Documents in Tiles.

Open documents are shown as thumbnails in the work area, and the scroll bar
becomes active.



The status bar remains available; however, document names now appear in the
thumbnail view. Click Select Window > Show Documents in Tabs to view one document
at a time in the work area.

Working with Applications

When you first open a new document or add a new problem to a document, you select
an application from a menu.

The following illustration shows how a document containing the Lists & Spreadsheet
application appears in the work area.
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À Document name. Tabs show the names of open documents. Click a name to make it
the active document.

Á Page Size. Shows the document's page size as Handheld or Computer. You can use
the TI-Nspire™ File menu to convert a document from one page size to the other.

Â Problem/Page counter. Labels the problem number and page number of the active
page. For example, a label of 1.2 identifies Problem 1, Page 2.

Ã Settings. Double-click to view or change the Document Settings for the active
document or to change the default Document Settings.

Ä Angle Mode. Shows an abbreviation of the angle mode (Degrees, Radians, or
Gradians) in effect. Hover the pointer over the indicator to see the full name.

Å Zoom. Enabled in Handheld preview only (click Document Preview on the toolbar
and select Handheld). Click▼ and select a magnification value, or click the zoom-to-
fit button to make the preview adapt automatically to window size.

Æ Boldness. Enabled in Computer preview only (click Document Preview on the
toolbar and select Computer). Click▼ and select a value to increase or decrease the
boldness of text and other items.



Working with Multiple Applications on a Page

You can add up to four applications to a page. When you have multiple applications on
a page, the menu for the active application is displayed in the Documents Toolbox.
Using multiple applications involves two steps:

• Changing the page layout to accommodate multiple applications.

• Adding the applications.

You can add multiple applications to a page even if an application is already active.

Adding Multiple Applications to a Page

By default, each page contains space to add one application. To add additional
applications to the page, complete the following steps.

1. Click Edit > Page Layout > Select Layout.

—or—

Click .

The page layout menu opens.

There are eight page layout options available. If an option is already selected, it is
dimmed.

2. Highlight the layout you want to add to the problem or page, and then click to
select it.

The new layout is displayed with the first application active.
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3. In Handheld preview, click Press menu to select an application for each new section
in the problem or page. In Computer view, select Click here to add an application.

Swapping Applications

To change the position of applications on a page with multiple applications, “swap“ 
the positions of two applications.

1. Click Edit > Page Layout > Swap Application.

Note: The last active application you worked on is automatically selected as the
first application to be swapped.

2. Click the second application to swap.

This action performs the swap.

Note: When there are only two work areas, the selected application automatically
swaps position with the other application in the work area.

To cancel a swap, press Esc.

Selecting and Moving Pages

As you add problems and pages to a document, you can take advantage of features for
managing the parts.



À Page Sorter. Lists the problems you have inserted in your document and shows
thumbnail images of the pages in each problem. The Page Sorter lets you rearrange,
copy, and move both problems and pages. It also lets you rename problems.

Á Active page. Indicates the current page by highlighting its thumbnail image.
Thumbnails let you easily scan the pages in a document and select a specific page to
work with.

Â Problem/Page counter. Displays the problem number and page number of the
currently selected page.

Selecting Pages

Use any of these methods to move from page to page.

▶ On the Viewmenu, select Previous Page or Next Page.

▶ On the keyboard, press Ctrl+PgUp or Ctrl+PgDn.
(Mac®: Press Fn+Up Arrow or Fn+Down Arrow).

▶ Click the Previous Page or Next Page button on the main toolbar.

▶ Click the Page Sorter tool in the Documents Toolbox, and then click the
thumbnail of the page you want to work with.

Tip: To expand or collapse the list of thumbnails for a problem, double-click the
name of the problem.

Rearranging Pages with the Page Sorter

The Page Sorter makes it easy to reorder pages within a problem.
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1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. In the Page Sorter, drag the thumbnail image of the page to the desired position.

Copying a Page

You can copy a page within the same problem or copy it to a different problem or
document.

1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. Select the thumbnail of the page to be copied.

3. On the Edit menu, click Copy.

4. Click the location at which you want to insert the copy.

5. On the Edit menu, click Paste.

Moving a Page

You can move a page within the same problem or move it to a different problem or
document.

1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. Select the thumbnail of the page to be moved.

3. On the Edit menu, click Cut.

4. Click the new location of the page.

5. On the Edit menu, click Paste.

Deleting a Page

1. Select the page in the work area or in the Page Sorter.

2. Click Edit > Delete.

Grouping Applications on a Page

You can combine as many as four consecutive application pages into a single page.

1. Select the first page in the series.

2. Click Edit > Page Layout > Group.

The next page is grouped with the first page. The page layout automatically adjusts
to display all the pages in the group.



Ungrouping Applications into Separate Pages

1. Select the grouped page.

2. Click Edit > Page Layout > Ungroup.

The applications are divided into individual pages.

Deleting an Application from a Page

1. Click the application to be deleted.

2. Click Edit > Page Layout > Delete Application.

Tip: To undo the delete, press Ctrl + Z (Mac®: “+ Z).

Working with Problems and Pages

When you create a new document, it consists of a single problem with a single page.
You can insert new problems and add pages to each problem.

Adding a Problem to a Document

A document can contain up to 30 problems. Each problem's variables are unaffected by
the variables in other problems.

▶ On the Insert menu, select Problem.
—or—
Click the Insert tool on the main toolbar, and select Problem.

A new problem with an empty page is added to your document.

Adding a Page to the Current Problem

Each problem can contain up to 50 pages. Each page has a work area, where you can
perform calculations, create graphs, collect and plot data, or add notes and
instructions.

1. Click Insert > Page.
—or—
Click the Insert tool on the main toolbar, and select Page.

An empty page is added to the current problem, and you are prompted to choose
an application for the page.

2. Select an application to add to the page.
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Renaming a Problem

New problems are named automatically as Problem 1, Problem 2, and so on. To
rename a problem:

1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. Click the problem name to select it.

3. On the Edit menu, click Rename.

4. Type the new name.

Rearranging Problems with the Page Sorter

The Page Sorter lets you reorder problems within a document. If you move a problem
that you have not renamed, the numeric part of the default name changes to reflect
the new position.

1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. In the Page Sorter, arrange the problems by dragging each problem name to its
new position.

Tip: To collapse a problem's list of page thumbnails, double-click the name of the
problem.

Copying a Problem

You can copy a problem within the same document or copy it to a different document.

1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. Click the problem name to select it.

3. On the Edit menu, click Copy.

4. Click the location at which you want to insert the copy.

5. On the Edit menu, click Paste.

Moving a Problem

You can move a problem within the same document or move it to a different
document.

1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. Click the problem name to select it.



3. On the Edit menu, click Cut.

4. Click the new location of the problem.

5. On the Edit menu, click Paste.

Deleting a Problem

To delete a problem and its pages from the document:

1. If necessary, click the Page Sorter tool in the Documents Toolbox.

2. Click the problem name to select it.

3. On the Edit menu, click Delete.

Printing Documents
1. Click File > Print.

The Print dialog box opens.

2. Set options for the print job.

• Printer — Select from your list of available printers
• Print What:

- Print All — prints each page on a separate sheet
- Viewable Screen — prints selected pages with additional layout options

(see Layout, below)
• Print Range — Click All Pages, or click Page range and set the starting and

ending pages.
• Layout:

- Orientation (portrait or landscape)
- The number of TI-Nspire™ pages (1, 2, 4, or 8) to be printed on each sheet

(available in Viewable Screen option only). The default is 2 pages per
sheet.

- Whether to allow space below each printed TI-Nspire™ page for comments
(available in Viewable Screen option only)

- Margins (from .25 inches to 2 inches). The default margin is .5 inches on all
edges.

• Documentation information to include:
- Problem name, including the option to group the pages physically by

problem
- Page label (such as 1.1 or 1.2) under each page
- Page header (up to two lines)
- Document name in the footer

3. Click Print, or click Save As PDF.
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Note: To restore the Print defaults, click Reset.

Using Print Preview

• Click the Preview check box to toggle the preview pane.

• Click the arrows at the bottom of the preview pane to page through the preview.

Viewing Document Properties and Copyright Information

Note: Most of these instructions apply only to the Teacher Software.

Checking Page Size

1. In the Teacher Software, go to the TI-Nspire™ File menu and select Document
Properties.

2. Click the Page Size tab.

3. A checkmark indicates the document's current page size.

Viewing Copyright Information

The Teacher Software and Student Software let you view copyright information that
has been added to a document.

1. On the TI-Nspire™ File menu, select View Copyright Information.

The Copyright Information dialog box opens.

2. Click OK to close the dialog box.



Adding Copyright Information to a Document

Using the Teacher Software, you can add copyright information to individual
documents that you create, or you can apply the same copyright information to all new
documents.

1. Open the document.

2. On the TI-Nspire™ File menu, select Document Properties.

3. Click the Copyright tab.

4. Edit the following fields to define the copyright details:

• Author

• Copyright (select Public Domain or Copyright).

• Year (disabled if you selected Public Domain)

• Owner (disabled if you selected Public Domain)

• Comments

5. To add the supplied information to all new documents from this point forward,
select Apply this copyright to all new documents.

6. Click OK to apply the copyright information to the document.

Protecting a Document (making a document read-only)

Teachers can protect documents to create a document for distribution to your students
or for other use. A student who receives a read-only document and makes changes to it
will be prompted to save the document as a new file.

1. Open the document.

2. On the TI-Nspire™ File menu, select Document Properties.

3. Click the Protection tab.

4. Select the Make this document Read Only check box.

5. Click OK.
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Working with PublishView™ Documents
Use the PublishView™ feature to create and share interactive documents with teachers
and students. You can create documents that include formatted text, TI-Nspire™
applications, images, hyperlinks, links to videos, and embedded videos in a format that
is suitable for printing on a standard piece of paper, publishing to a website or blog, or
for use as an interactive worksheet.

PublishView™ features provide layout and editing features for presenting math and
science concepts in a document where TI-Nspire™ applications can be interactively and
dynamically linked with supporting media, enabling you to bring the document to life.
Using the PublishView™ feature:

• Teachers can create interactive activities and assessments used on screen.

• Teachers can create printed materials to complement documents used on
TI-Nspire™ handhelds.

• When working with lesson plans, teachers can:

- Create lesson plans from existing handheld documents or convert lesson plans
to handheld documents.

- Link to related lesson plans or documents.
- Embed explanatory text, images, video, and links to web resources.
- Build or interact with TI-Nspire™ applications directly from the lesson plan.

• Students can create reports or projects such as lab reports containing data
playback, curve fits, pictures, and video—all on the same sheet.

• Students can print and turn in assignments on a standard piece of paper.

• Students taking exams can use one tool to create a document that contains: all
problems on the exam, text, images, hyperlinks, or videos, interactive TI-Nspire™
applications, screen shots, and layout options needed to print a document.

Note: PublishView™ documents can be exchanged using the TI-Nspire™ Navigator™ NC
system. PublishView™ documents can reside in the Portfolio Workspace, and TI-
Nspire™ questions within a PublishView™ document can be automatically graded by
the TI-Nspire™ Navigator™ system.

Creating a New PublishView™ Document
1. From the Documents Workspace, click File > New PublishView™ Document.

—or—

Click , and then click New PublishView™ Document.

• A blank letter-size document opens in the Documents Workspace. The
orientation is portrait, which cannot be changed.

• The default margin settings for the top and bottom margins are one-inch.
There are no settings for side margins.

• By default, a problem is added to the document.
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• By default, the document contains the page number in a # of # format at the
bottom of the sheet.

• The scroll bars on the right side of the screen and at the bottom of the screen
are active.

2. Add TI-Nspire™ applications and PublishView™ objects as needed to complete the
document.

About PublishView™ Documents

When working with PublishView™ documents, it is important to keep the following
points in mind:

• PublishView™ documents are saved as .tnsp files, which distinguishes them from
TI-Nspire™ documents (.tns files).

• When inserting PublishView™ objects into a document, the text, image, hyperlink,
or embedded video are contained in boxes that can be moved and resized.

• When you insert TI-Nspire™ applications, they work the same way as pages in a
TI-Nspire™ document.

• In a PublishView™ document, objects can overlap each other and you can control
which object is on top or bottom.

• Objects can be placed and positioned in a PublishView™ document in a free-form
fashion.

• You can convert an existing TI-Nspire™ document to a PublishView™ document
(.tnsp file).



• When you convert a PublishView™ document to a TI-Nspire™ document (.tns file),
TI-Nspire™ applications are converted. PublishView™ objects containing text,
hyperlinks, videos, and images are not converted.

• You cannot create or open a PublishView™ document on a handheld. You must
convert a PublishView™ document to a TI-Nspire™ document before sending it to a
handheld.

Exploring a PublishView™ Document

The following example shows how you might use TI-Nspire™ applications and
PublishView™ objects to build a PublishView™ document. In this example, borders are
turned on to show the boundaries around the objects. Showing borders enables you to
work with objects easily while building a document. When you are ready to print or
publish the document to the web, you can select to the hide borders.

À Header. In this example, the header contains the title of the document. When the
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header area is active, you can type and format text as needed.

Á Problem break and name. In PublishView™ documents, use problem breaks to
control the page layout. You can select to hide or show problem breaks. Deleting a
problem removes the contents of the problem and removes the space between
problems when there are multiple problems. Problem breaks also enable you to use
variables in PublishView™ documents. Variables that have the same name are
independent of one another if they are used in different problems.

Â Text boxes. In this example, the introduction text and the text in boxes 1, 2, 3, and
4 is contained in text boxes. You can insert text and hyperlinks into a PublishView™
document using a text box. Text boxes can be resized and positioned as needed.
PublishView™ text boxes are not retained when you convert a PublishView™
document to a TI-Nspire™ document.

Ã TI-Nspire™ applications. In this example, the author uses Graphs & Geometry to
show the math functions. When a TI-Nspire™ application is active in a PublishView™
document, the appropriate application menu opens in the Documents Toolbox. You
can work in a TI-Nspire™ application just as you would in a TI-Nspire™ document.
When you convert a PublishView™ document to a TI-Nspire™ document, applications
are retained.

Ä Notes application. You can also use the TI-Nspire™ Notes application to add text to a
PublishView™ document. Because Notes is a TI-Nspire™ application, it will be
retained when you convert the PublishView™ document to a TI-Nspire™ document.
Using the Notes application enables you to use an equation editor and can contain
TI-Nspire™ math templates and symbols.

Å Video. This is an example of a video that is embedded in a PublishView™ document
within a frame. Users can start and stop the video using the controls. Frames
containing videos and images can be resized and positioned in the document as
needed.

Æ Footer. By default, the footer area contains the page number, which cannot be
edited. You can add other text above the page number if needed. Like the header,
you can format text as needed.

Using the Status Bar in a PublishView™ Document

When a PublishView™ document is open, options on the status bar are different than
when working in a TI-Nspire™ document.



À Document names are displayed in tabs. If multiple documents are open, the
document names are listed. You can have TI-Nspire™ and PublishView™ documents
open at the same time. In this example, Document 1 is an inactive TI-Nspire™
document ( ). Document 2 is the active PublishView™ document ( ). Click the X to

close a document.

Á Page Size. Shows the document's page size as Handheld or Computer. You can use
the TI-Nspire™ File menu to convert a document from one page size to the other.

Â Click Settings to change Document Settings. You can specify settings that are specific
to an active document or set default settings for all PublishView™ documents. When
you convert a TI-Nspire™ document into a PublishView™ document, the settings in
the TI-Nspire™ document convert to the settings defined for PublishView™
documents.

Ã Use the Zoom scale to zoom the active document in or out from 10% to 500%. To set
a zoom, type a specific number, use the + and - buttons to increase or decrease by
increments of 10%, or use the drop-down box to choose preset percentages.

Ä In TI-Nspire™ applications, use the Boldness scale to increase or decrease the
boldness of text and line thickness within applications. To set the boldness, type a
specific number, use the + and - buttons to increase or decrease by increments of
10%, or use the drop-down box to choose preset percentages.

For PublishView™ objects, boldness is used to match text within TI-Nspire™
applications to other text on the PublishView™ sheet. It can also be used to increase
the visibility of TI-Nspire™ applications when presenting a document to a class.

Å When there are too many open document names to show in the status bar, click the

forward and backward arrows ( ) to move through the documents.

Æ Click to see a list of all open documents.

Saving PublishView™ Documents

Saving a New Document

1. Click File > Save Document.
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—or—

Click .

The Save TI-Nspire™ Document dialog box opens.

2. Navigate to the folder in which you want to save the document.

—or—

Create a folder in which to store the document.

3. Type a name for the new document.

4. Click Save.

The document closes and is saved with the extension .tnsp.

Note: When you save a file, the software first looks in the same folder the next time
you open a file.

Saving a Document with a New Name

To save a previously saved document in a new folder and/or with a new name:

1. Click File > Save As from the menu.

The Save TI-Nspire™ Document dialog box opens.

2. Navigate to the folder in which you want to save the document.

—or—



Create a folder in which to store the document.

3. Type a new name for the document.

4. Click Save to save the document with a new name.

Note: You can also use the Save As option to convert documents from TI-Nspire™ files
to PublishView™ files or convert PublishView™ files to TI-Nspire™ files.

Exploring the Documents Workspace

When you create or open a PublishView™ document, it opens in the Documents
Workspace. Use the menu options and the toolbar just as you would when working
with a TI-Nspire™ document to:

• Navigate to existing folders and documents using Content Explorer

• Open existing documents

• Save documents

• Use the copy, paste, undo, and redo options

• Delete documents

• Access TI-Nspire™ application-specific menus

• Open the Variables menu in TI-Nspire™ applications that allow variables

• Access and insert math templates, symbols, catalog items, and library items into a
PublishView™ document

Note: For more information, see Using the Documents Workspace.

Exploring the Documents Toolbox

When a PublishView™ document is active, the Documents Toolbox contains tools
needed for working with PublishView™ documents. You can add TI-Nspire™
applications to a problem, insert parts of existing TI-Nspire™ documents into a
problem, and add PublishView™ objects.

The Documents Toolbox opens when you create a new PublishView™ document or
open an existing PublishView™ document. When working in a PublishView™ document,
Page Sorter and TI-SmartView™ emulator are not available.
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À In a PublishView™ document:

• Click to open the application menu and tools needed to work with
TI-Nspire™ applications and PublishView™ objects.

• Click to open the Utilities panel where you can access Math Templates,
Symbols, the Catalog, Math Operators, and Libraries.

• Click to open Content Explorer.

Note: For more information, see Using the Documents Workspace.

Á
Click to collapse a pane containing a menu. Click to expand a pane.

Â TI-Nspire™ applications. Move an icon to a problem to insert an application:



Calculator

Graph

Geometry

Lists & Spreadsheet

Data & Statistics

Notes

Vernier DataQuest™

Question (Available in TI-Nspire™ CX Teacher Software, TI-Nspire™ CX

Navigator™ Teacher Software, and TI-Nspire™ Navigator™ NC Teacher Software).

Ã TI-Nspire™ Documents. Use this tool to locate and insert existing TI-Nspire™
documents (.tns files) into a problem.

Ä PublishView™ Objects. Use this tool to move the following objects into a problem:

Image

Video

Text box

Hyperlink

Using Menus and the Toolbar

When working in a PublishView™ document, select options from the menus or the
toolbar in the Documents Workspace to work with content and objects. When you
insert an object into a PublishView™ document, you can manipulate it using the same
tools as you would when working with a TI-Nspire™ document. In PublishView™
documents, you can:
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• Right-click on an object to open a context menu, which displays the actions that
can be performed on that object.

• Use add, insert, and paste to add objects to a PublishView™ document.

• Use delete and cut to remove objects from a PublishView™ document.

• Move objects from one place to another within a PublishView™ document.

• Copy objects from one document and paste them into another PublishView™
document.

• Resize and scale objects such as text boxes and images.

• Change the font face and size and apply formatting such as italics, bold, underline,
and color to text.

Note: For more information, see Using the Documents Workspace.

Using Context Menus

In TI-Nspire™ applications and in PublishView™ documents, context menus provide a
list of options specific to the task you are working on. For example, when you right-
click a cell while working in the TI-Nspire™ Lists & Spreadsheet application, a context
menu opens providing a list of actions that you can perform on that cell. When you
right-click the border of a text box in a PublishView™ document, the context menu
provides actions that can be performed on the text box.

Context Menus in TI-Nspire™ Applications

When you insert a TI-Nspire™ application into a PublishView™ document, the
application menu and the context menus associated with that application are available
and work the same way they work in a TI-Nspire™ document.

Context Menus in PublishView™ Documents

In PublishView™ documents, context menus provide shortcuts to frequently performed
tasks. Context menus are specific to an object or area:

• The Sheet context menu provides options for working with the layout of the sheet
and document.

• Object context menus provide options for manipulating the object.

• Content-sensitive context menus provide options for working with the content
inside the object such as text or a video.



Working with PublishView™ Objects

In a PublishView™ document, text, hyperlinks, images, and videos are contained in
PublishView™ objects. You can move, resize, copy and paste, and delete an object
within a PublishView™ document. Objects can also be positioned so that one overlaps
the other.

Within a document, PublishView™ objects can exist in three states: unselected,
selected, and interactive.

State Description

Unselected When unselected, an object
does not have handles for
repositioning and sizing. To
deselect an object, left-click or
right-click outside the object.
In this example, borders
around the object are
showing.

Selected When selected, an object will
have eight square handles
framing the object. To select
an object, click the object’s
border. When selected,
objects can be moved and
resized.

• To move an object, click a
border and drag the
object to its new location.

• To resize an object, grab
a handle.

• Right-click the border to
open a context menu
with options for
manipulating the object.
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State Description

Interactive An interactive state is
indicated by a blue frame
around the object. To enter
interactive state, left-click or
right-click anywhere in the
body of the object. When in
an interactive state, you can
work with the contents of the
object. For example, you can
add or edit text in a text box
or complete math functions in
a TI-Nspire™ application.
When in an interactive state,
context menus contain options
specific to the contents of an
object.

Inserting an Object

1. In the Documents Toolbox, ensure the PublishView™ Objects menu is open.

2. Use your mouse to click an icon and drag it to the document.

3. Release the mouse button to drop the object into the document.



Selected text boxes and frames
canbe resized, moved, copied,
pasted, anddeleted.

4. Using the mouse, grab the handles to resize the object and drag it to position the
object in the document as needed.

Opening Object Context Menus

▶ Right-click the border of any object in a PublishView™ document.

The context menu opens to provide access to delete, copy/paste, cut, and bring to
front/send to back actions.
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Resizing an Object

1. Click any border around the object to select it. The border becomes a bold blue line
and the handles are active.

2. Move your mouse over one of the handles to activate the resizing tool.

3. Grab one of the handles and drag in the direction needed to make the object larger
or smaller.

4. Click outside the object to save the new size.

Moving an Object

To move an object to another location on the page:

1. Click any border around the object to select it. The border becomes a bold blue line
and the handles are active.

2. Move your cursor over one of the borders to activate the positioning tool .

3. Click to grab the object. The horizontal and vertical alignment guides are activated
at the top and bottom of the object. Use the grid lines to position the object on the
page.



À vertical alignment guide

Á horizontal alignment
guide

4. Drag the object to a new location on the page.

5. Release the mouse button to drop the object in its new location.

Overlapping Objects

You can position objects so that one is on top of another. You can control the stacking
order to specify which object is positioned in front or behind the other. Overlapping
objects have many practical uses when presenting information in the classroom. For
example, you can create a "curtain control" by placing an empty text box over other
objects. Then, you can move the text box to reveal the items below it one at a time.
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To change the position of an object in the stacking order:

1. Click the border of the object you want to position to select it, and then right-click
to open the context menu.

2. Click Send to back or Bring to front to move the selected object to the desired
position.

Deleting an Object

To delete an object from a sheet:



1. Click any border of the object to select it. When an object is selected, the border is
blue and the handles are active.

2. Press the Delete key to delete the text box.

—or—

Right-click a border, and then click Delete from the context menu.

Choosing a Working Folder for PublishView™ Objects

Use the Choose Your Working Folder field in the PublishView™ Objects pane to select a
folder for storing PublishView™ documents and related files.

1. Ensure the PublishView™ Objects pane is open.

2. Click .

The Choose Your Working Folder dialog box opens.
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3. Navigate to the folder where you want to store video and image files.

4. Click Open to choose the working folder.

The selected folder becomes the working folder and the folder name is displayed in
the Choose your working folder field. Previews of supported images and video files
in the folder are shown in the PublishView™ objects pane.

5. To add an image or video file to a PublishView™ document, select the file and
move it onto the active sheet.

Working with TI-Nspire™ Applications

Note: For more information, see the appropriate chapter in this guidebook.

Adding an Application to a Problem

To add a TI-Nspire™ application to a problem in a PublishView™ document:

1. Choose one of the following actions to select an application:



• From the TI-Nspire™ Applications pane in the Documents Toolbox, use the
mouse pointer to point to the application and drag it to the problem.

• From the menu bar, click Insert and choose an application from the drop-down
menu.

• Right-click inside the sheet to open the context menu, click Insert and choose
an application from the menu.

The application is added to the sheet.

2. Using your mouse, grab the handles to resize or position the application object as
needed.

3. Click outside the application frame to accept the dimensions.

4. To open the menu for the active TI-Nspire™ application, click inside the application.

The menu opens in the Documents Toolbox above the TI-Nspire™ Applications
pane.

Right-click on an application element, such as a cell or function to open the context
menu for that item.
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5. To work in the application, click an option from the application menu. Click to
collapse the application menu pane.

Adding Existing TI-Nspire™ Documents

Use the TI-Nspire™ Documents pane to open an existing TI-Nspire™ document to add
to a PublishView™ document. When you open an existing TI-Nspire™ document, all
pages of the document appear in the preview pane. You can move complete problems
or individual pages onto the PublishView™ sheet.

Choosing a Working TI-Nspire™ Document

To choose a working document:

1. In the Documents Toolbox, ensure the TI-Nspire™ Documents pane is open.



2. Click .

The Choose Your Working Document dialog box opens.

3. Navigate to the folder in which the TI-Nspire™ document is stored:

• Click¤ in the Look in: field to use a file browser to locate a folder.

• From an open folder, click to move up a level in the folder hierarchy

• Click to return to the default home folder

• Click to add a new folder to open folder on your computer.

• Click to list folders and files. To show details, click .

4. Select the file, and then click Open.

The TI-Nspire™ document opens in the TI-Nspire™ Documents pane.
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5. To add the TI-Nspire™ document to the PublishView™ document, move one page at
a time or one problem at a time to the PublishView™ sheet.

If you are adding a problem with multiple pages, the pages are stacked on top of
each other on the PublishView™ sheet. Move the top page to see the other pages.

Working with Problems

Like a TI-Nspire™ document, a PublishView™ document consists of one or more
problems.

Problems are used to control the layout of a PublishView™ document so that you can
isolate variables. When variables with the same name are used in multiple problems,
variables can have different values. To add problems to PublishView™ documents,
open the Sheet context menu or use the options on the Insert menu in the Documents
Workspace. When adding problems, keep the following guidelines in mind:

• By default, a new PublishView™ document contains one problem.

• You can insert a problem after any existing problem.

• You cannot insert a problem in the middle of an existing problem.

• A new problem break is always inserted after the selected problem.

• Inserting a problem break adds empty space below the break.

• Any object between two problem breaks is part of the problem above the break.

• The last problem includes all sheets and objects below the last problem break.



• Problem breaks are not relative to any object, which lets you move objects within a
problem without affecting the problem break location.

Adding a Problem

To add a problem to an open PublishView™ document:

1. Right-click anywhere on the sheet, and then click Insert > Problem.

The problem is added to the document below any existing problems. The problem
break provides a visible divider between problems.

2. To name the problem, highlight the default text, type a name, and then click
outside the text box to save the name.

The problem break is saved.

If a document has multiple problems, use the scroll bar on the right side of the
document to move up and down through the problems.

Managing Problem Breaks

Problem breaks are used to separate problems and variable sets.

• Every problem has a problem break.

• A problem break becomes visible when a problem is added to a document.

• A problem break is represented by a dashed line with the name of the problem
positioned on the left side of the sheet.

• By default, the problem name is shown as <Name of problem>. Highlight the
default text to type a new name for the problem.

• Problem names do not have be unique. Two problems can have the same name.

Hiding and Showing Problem Breaks

You can select to hide or show problem breaks in a PublishView™ document. By
default, problem breaks are shown.

1. Right-click in any blank area of the document (outside of any object) to open the
sheet context menu.

2. Click Layout Options.
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The Show/Hide Options dialog box opens.

Note: You can also click View > PublishView™ Layout Options.

3. Clear the Show problem breaks option to hide problem breaks in the document.
Select the option to return to the default setting and show the problem breaks.

4. Click OK to close the dialog box.

Renaming a Problem

1. Click the existing problem name on the problem break line.

2. Type a new name for the problem.

3. Click outside the text box to save the new name.

Deleting a Problem

To delete a problem, complete one of the following actions:

▶ Select the problem break and click on the right side of the break.

▶ Click Edit > Delete.

▶ Right-click the problem break and click Delete.

▶ Select the problem break and press the Delete or Backspace key.

When you delete a problem, all objects contained in the problem are removed and the
space between the selected problem break and the next problem break is removed.

Organizing PublishView™ Sheets

A PublishView™ document can have multiple sheets. A single sheet is displayed in the
workspace on your screen. All work occurs in the PublishView™ objects and TI-Nspire™
applications within sheets.



Adding Sheets to a Document

To add a sheet to a document:

▶ Click Insert > Sheet.

The sheet is added to the document and the numbering increments by one.

Opening the Sheet Context Menu

▶ Right-click in any blank area (outside of any object) in a PublishView™ sheet.

A context menu opens with options for inserting problems, pages, applications, and
PublishView™ objects, edit options for removing space or deleting a page, and
options for hiding and showing problem breaks and object borders.

Page Numbering

In a PublishView™ document, page numbering is displayed in the bottom margin
(footer). By default, numbering is placed in the center of the PublishView™ sheet in a #
of # format. You cannot edit or delete page numbering.

Working with Headers and Footers

PublishView™ documents contain space at the top and bottom of a sheet to add a
header or a footer. Headers and footers can contain the date, the document name, the
lesson plan name, the class name, your school’s name, or any other information
needed to identify a document.

By default, headers and footers do not contain content and boundaries for the header
and footer are hidden. To activate a header or footer for editing, click inside the top or
bottom margin. When activated, a text box with a light gray border is displayed.

Inserting and Editing Text in Headers and Footers

1. Click inside the top or bottom margin.
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The text box borders in the margin become visible and the object space is disabled.
The cursor is placed in the header or footer space and the formatting toolbar
becomes active.

2. Type the text.

• The default font is TI-Nspire™ true type, 12 pt, normal.

• By default, text is centered horizontally and vertically.

• Text can be aligned: left, center, right, or justified.

• Text that does not fit within the text box horizontally will wrap to the next line.

• Text that does not fit within the text box vertically will not be shown, but text is
retained. (If you delete text, the hidden text will appear.)

3. Complete one of the following actions to save the text:

• Single-click anywhere outside the header or footer text box to save the text.

• Press Esc to save the text.

The PublishView™ sheet becomes active and the formatting menu closes.

Showing and Hiding Borders

By default, borders are displayed when you insert an object into a problem. When you
select to hide borders, the selection applies to all objects in the document and to
objects that you add to the document. To hide the border:

1. Right-click in any blank area of the sheet (outside of any object) to open the
context menu.

2. Click Layout Options.

The Layout Options dialog box opens.

Note: You can also click View > PublishView™ Layout Options.



3. Clear the Show object borders option to hide the borders around the objects in the
problem. Select the option to return to the default setting and show borders.

4. Click OK to close the dialog box.

Adding and Removing Space

To manage how PublishView™ objects appear on a sheet, you may need to add or
delete space between objects.

Note: You can add and remove vertical space between objects using this method. To
add or remove horizontal space between objects, move the object.

Adding Space

1. Right-click in the area outside of any object where you want to add space. The
context menu opens.

2. Click Edit > Add/Remove Space. The Add/Remove Space tool becomes active.
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Add/Remove Space
tool

3. Use your mouse to position the tool to the exact place where you want to add
space.

4. Click the tool, and then drag down to select the amount of space you want to add.
As you select the amount of space to be added, it is indicated in green.



5. Press the Enter key to add the space in between the objects. You can adjust the
amount of space by dragging up and down before you press Enter.

Removing Space

1. Right-click in the area outside of any object where you want to remove space.

The context menu opens.

2. Click Edit > Add/Remove Space.

The Add/Remove Space tool becomes active.
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Add/Remove Space
tool

3. Use your mouse to position the tool to the exact place where you want to remove
space.

4. Click the tool, and then drag up to select the amount of space you want to remove.
As you select the amount of space to be removed, it is indicated in red.

5. Press the Enter key to remove the space in between the objects. You can adjust the
amount of space by dragging up and down before you press Enter.



Note: If there is not enough space on the sheet to accommodate the objects, the
objects won’t be moved when space is removed.

Deleting Blank Sheets from Problems

You can delete a sheet that does not contain any TI-Nspire™ applications or
PublishView™ objects from a problem. To delete a blank sheet from a problem:

1. Delete any TI-Nspire™ applications, PublishView™ objects, move or delete any
problem breaks from the sheet.

2. Place your cursor inside the sheet you want to delete.

3. Right-click inside the blank sheet to open the context menu.

4. Click Edit > Delete Sheet.

The blank sheet is removed from the problem.

Using Zoom

The zoom feature lets you zoom in on any object or area on the PublishView™
document for discussion, and zoom out to see an overview of the lesson. The zoom
uses the center point of the viewable area to zoom in.

The default zoom setting is 100%.

▶ To change the zoom percentage, do one of the following:

• Type the number in the box and press Enter.
• Use the - and + buttons to decrease or increase the percentage in 10%

increments.
• Use the drop-down arrow to choose a preset percentage.

The zoom settings are retained when you save the document.

Adding Text to a PublishView™ Document

In a PublishView™ document, there are three ways to add text:

• Insert a PublishView™ text box to enter free-form text or copy text from other
sources into the document. For example, you can place a PublishView™ text box
next to an image and type a description in a text box. You can also copy and paste
text from .doc, .txt, and .rtf files. Use PublishView™ text boxes when you need
options for emphasizing and formatting text. PublishView™ text boxes are not
converted when you convert a PublishView™ document to a TI-Nspire™ document.
You may want to use a PublishView™ text box to add text that you don’t want
handheld users to see.

• Use the TI-Nspire™ Notes application. You should use the Notes application when
you need an advanced equation editor and when you need to use TI-Nspire™ math
templates and symbols. Superscript and subscript are also easier to use in the
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Notes application. You should also use Notes when you are planning to convert the
PublishView™ document to a TI-Nspire™ document for use on a handheld and you
want handheld users to see the text.

• Add text in TI-Nspire™ applications that allow text just as you would in a
TI-Nspire™ document.

Inserting Text into a Text Box

1. Ensure the PublishView™ Objects pane is open.

2. Use your mouse to click and drag it to the problem.

3. Release the mouse button to drop the text box into the problem.

4. Using the mouse, grab the handles to resize the text box or position in the problem
as needed.

5. Click outside the text box to save the size and position.

6. Click "Type your text here."

The formatting toolbar becomes active. The text box is in an interactive state for
adding or editing text.



7. Type the new text.

—or—

Copy and paste text from another file.

8. Apply formatting as needed.

9. Click outside the text box to save the text.

Formatting and Editing Text

The options for editing and formatting text are located on a formatting toolbar at the
top of the active document. Formatting options for editing text include:

• Changing the font, font size, and font color.

• Applying bold, italics, and underline formatting.

• Applying the following text horizontal alignment options: left, right, centered, and
justified.

• Inserting hyperlinks.

Launching Edit Mode

▶ Click inside a text box to launch edit mode.

• The formatting menu opens.

• The text is selectable for editing.

Opening the Content Context Menu

▶ Right-click inside a text box containing text or a hyperlink.

The formatting menu and context menu open providing shortcuts to cut, copy, and
paste.

Using Hyperlinks in PublishView™ Documents

In PublishView™ documents, use hyperlinks to:
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• Link to a file

• Link to a website on the Internet

You can add a hyperlink to an open document or you can convert any text within a text
box to a hyperlink. When a hyperlink is added, the formatting of the text is underlined
and the font color is blue. You can change the formatting of the hyperlinked text
without losing the hyperlink.

If a link is broken, an error message is displayed when you click the link:

• Cannot open the specified file

• Cannot open the specified web page

PublishView™ text boxes support both absolute and relative links.

Absolute links contain the complete location of the linked file and do not depend on the
location of the main document.

Relative links contain the location of the linked file relative to the main document. If
you have multiple lessons in a single folder and they are all linked using relative
addressing, you can move the folder to any other location (another local folder,
datashare, flash drive, online) without breaking the links. The links also stay intact if
you bundle the documents into a lesson bundle or zip them into a zip file and share
them.

Note: The PublishView™ document must be saved before you can insert a relative
hyperlink.

Linking to a File

You can link to any file on your computer. If the file type is associated with an
application on your computer, it will launch when you click the link. There are two ways
to link to a file; by typing or pasting a file address into the Address field, or by browsing
to a file.

Linking to a File by Using an Address

1. Ensure the PublishView™ Objects pane is open.



2. Drag the hyperlink icon onto the document.

The Hyperlink dialog box opens.

3. Type the name of the link in the Text field. For example, this can be the name of
the document.

4. Copy the location of the file path you want to link to, and paste it in the Address
field.

—or—

Type the location of the file in the Address field.

Note: Type ../ to designate parent directories. For example:
../../lessons/mathlesson2.tns

5. Click OK to insert the link.

A text box containing the hyperlink is added to the PublishView™ document.
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Linking to a File by Browsing

1. Ensure the PublishView™ Objects pane is open.

2. Drag the hyperlink icon onto the document.

The Hyperlink dialog box opens.

3. Type the name of the link in the Text field. For example, this can be the name of
the document.

4. Click to select Link to a file on your computer or network drive.

The Select file to insert as hyperlink dialog box opens.



5. Navigate to and select the file you want to link to, and then click Insert.

The path name is inserted into the Address field in the Hyperlink dialog box.

If the software is unable to determine if the link is a relative or absolute address,
the Hyperlink dialog box opens with an option to change the type of link.

To change the link, click the appropriate option:

• Change to absolute address.

• Change to relative address.

6. Click OK to insert the link.

—or—

Click Start Over to go back to the Hyperlink dialog box and choose a different file to
link, or to edit the Text or Address fields.

A text box containing the hyperlink is added to the PublishView™ document.
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7. Using the mouse, grab the handles to resize the text box.

—or—

Grab any border to position the text box in the document as needed.

Linking to a Website

There are two ways to link to a website; by typing or pasting the URL into the Address
field, or by browsing to a file.

Linking to a Website by Using an Address

1. Ensure the PublishView™ Objects menu is open.

2. Drag the hyperlink icon onto the document to open the Hyperlink dialog
box.

3. Type or paste the URL you want to link to in the Address field.

4. Click OK.

A text box containing the hyperlink is added to the PublishView™ document.

Linking to a Website by Browsing

1. Ensure the PublishView™ Objects menu is open.



2. Drag the hyperlink icon onto the document to open the Hyperlink dialog
box.

3. Click to select Link to an Internet resource.

The browser opens to your default website.

4. Navigate to the website or file on a website that you want to link to.

5. Copy the URL, and then paste it in the Address field in the Hyperlink dialog box.

—or—

Type the URL in the Address field.

6. Click OK.

A text box containing the hyperlink is added to the PublishView™ document.

7. Using the mouse, grab the handles to resize the text box.

—or—

Grab any border to position the text box in the document as needed.
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Editing a Hyperlink

To change the name of a hyperlink, change the path, or change the URL, complete the
following steps.

1. Using your mouse, right-click the hyperlink text, and then click Edit hyperlink.

The Hyperlink dialog box opens.

2. Make corrections as needed:

• Type corrections to the hyperlink name in the Text field.

• Click to open the Select a file to add as a hyperlink dialog box and use the

file browser to navigate to the folder where the file is located.

• Click to open a browser and navigate to a website to copy and paste the

correct the URL in the Address field.

3. Click OK to save the changes.

Converting Existing Text to a Hyperlink

1. Click inside the text box to activate edit mode and open the formatting menu.

2. Select the text you want to convert to a hyperlink.

3. Click .

The Hyperlink dialog box opens with the selected text in the Text field.

4. Click to create a link to a file.

—or—



Click to create a link to page on a website.

Removing a Hyperlink

Use this process to remove a link from text inside a text box. The text remains in the
document.

1. Using your mouse, right-click the hyperlink text.

2. Click Remove hyperlink.

The hyperlink formatting is removed from the text and the text is no longer
clickable.

Note: To remove both the text and hyperlink, delete the text. If a text box contains only
the linked text, delete the text box.

Working with Images

Images can be added to PublishView™ documents as PublishView™ objects or can be
added inside TI-Nspire™ applications that support images. Supported files types are
.bmp, .jpg, and .png files.

Note: If a TI-Nspire™ application is active in the PublishView™ document, the image is
added to the TI-Nspire™ page if you click Insert > Image from the menu bar or context
menu. If there is no TI-Nspire™ document active, the image is added as a
PublishView™ object. Only images inside TI-Nspire™ applications convert to TI-Nspire™
documents (.tns files).

Inserting an Image

1. Ensure the PublishView™ Objects pane is open.
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2. Click , and then drag the icon to the document.

The Choose an image to insert into PublishView™ dialog box opens.

Note: By default, the Texas Instruments preloaded images folder is displayed.

3. Navigate to the folder where the image file you want to insert is located, and then
highlight the file name.

4. Click Insert image.

The image is added to the PublishView™ sheet.

5. Using the mouse, grab the handles to resize the text box,

—or—



Grab any border to position the text box in the document as needed.

Moving Images

1. Click the frame containing the image to select it.

2. Move your cursor over the edge of the image to activate the positioning tool.

3. Move the image to its new location on the PublishView™ sheet.

Note: Objects can overlap each other on a PublishView™ sheet.

Resizing Images

1. Click the frame containing the image to select it.

2. Move your cursor over one of the blue handles to activate the resizing tool.

3. Drag the handle to make the image smaller or bigger.

Deleting Images

▶ Click the image to select it, and then press the Delete key.

—or—

▶ Right-click a handle to open the context menu, and then click Delete.

Working with Video Files

You can embed video files in a PublishView™ document and play the videos directly
from the PublishView™ document. Supported video formats include:

• Flash® (.flv) video files with VP6 video and MP3 audio.

• MP4 (MPEG-4 multimedia container) with H264/AVC (Advanced Video Coding)
video compression and AAC audio.

Note: You can also insert a link to a video that will launch in a new browser window or
media player window. For more information, see Working with Hyperlinks.

Inserting a Video

1. Ensure the PublishView™ Objects pane is open.

2. Click , and then drag the icon to the document.

The Choose a video to insert into PublishView™ dialog box opens.
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3. Navigate to the folder where the video file you want to insert is located, and select
the file name.

4. Click Insert video.

An object containing the embedded video is added to the PublishView™ sheet. By
default, the resizing and positioning handles are active.

5. Using the mouse, grab the handles to resize the object or grab any border to
position the object in the document as needed. For example, you may want to
position the object containing the video above or below a text box that contains
text introducing the video.

6. To play the video, click the forward arrow, or click anywhere in the viewing
window.

Using the Video Console

The video console lets users control the video.



À Starts or stops the video.

Á Shows the elapsed time as the video plays.

Â Mutes or unmutes the audio.

Converting Documents

You can convert PublishView™ documents (.tnsp files) to TI-Nspire™ documents (.tns
files) for display on handhelds. You can also convert TI-Nspire™ documents to
PublishView™ documents.

Converting a document creates a new document—the original document remains
intact and is not linked to the new document. If you make changes to one document,
the changes are not reflected in the other document.

Converting PublishView™ Documents to TI-Nspire™ Documents

You cannot open a PublishView™ document (.tnsp file) on a handheld. However, you
can convert the PublishView™ document to a TI-Nspire™ document that can be
transferred to and opened on a handheld. When you convert a PublishView™ document
to a TI-Nspire™ document:

• Only the TI-Nspire™ applications become part of the TI-Nspire™ document.

• PublishView™ objects such as text boxes, images, hyperlinks, and videos are not
converted.

• Text contained in PublishView™ text boxes is not converted; however, text in a
TI-Nspire™ Notes application is converted.

• If images are contained in a TI-Nspire™ application, they are converted; however,
images contained in PublishView™ objects are not converted.

Complete the following steps to convert a PublishView™ document (.tnsp file) to a TI-
Nspire™ document (.tns file).

1. Open the PublishView™ document to be converted.

2. Click File > Convert to > TI-Nspire™ Document.

• The new TI-Nspire™ document opens in the Documents Workspace.
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• All supported TI-Nspire™ applications are part of the new TI-Nspire™
document.

• Starting from top to bottom, and then left to right, the layout of the TI-Nspire™
document is based on the order of the TI-Nspire™ applications in the
PublishView™ document.

- Every TI-Nspire™ application in a PublishView™ document will appear as a
page in the converted TI-Nspire™ document. The order of the pages in the
TI-Nspire™ document is based on the layout of the TI-Nspire™ applications
in the PublishView™ document.

- If two or more problems are at the same level, the order is left to right.

• Problem breaks are maintained.

• The new TI-Nspire™ document is not linked to the PublishView™ document.

3. When work in the document is complete, click to save the document in the

current folder.

—or—

Click File > Save As to save the document in a different folder.

Note: If the document has never been saved, both the Save and Save as options
allow saving in a different folder.

Note: You can also use the Save as option to convert a PublishView™ document to a
TI-Nspire™ document.

Note: If you try to convert a PublishView™ document that does not contain TI-Nspire™
pages or applications, an error message is displayed.

Converting TI-Nspire™ Documents to PublishView™ Documents

You can convert existing TI-Nspire™ documents to PublishView™ documents, which
enables you to take advantage of the richer layout and editing features for printing,
generating student reports, creating worksheets and assessments, and publishing
documents to a website or blog.

Complete the following steps to convert a TI-Nspire™ document to a PublishView™
document:

1. Open the TI-Nspire™ document you want to convert.

2. Click File > Convert to > PublishView™ Document.

• The new PublishView™ document opens in the Documents Workspace.



• By default, there are six objects per page.

• When converted, each problem from the TI-Nspire™ document will start a new
sheet in the PublishView™ document.

• Problem breaks are maintained.

3. When work in the document is complete, click to save the document in the

current folder.

—or—

Click File > Save As to save the document in a different folder.

Note: You can also use the Save as option to save a TI-Nspire™ document as a
PublishView™ document.

Printing PublishView™ Documents

You can print reports, worksheets, and assessments created using the PublishView™
feature. To print a document:

1. Click File > Print.

The Print dialog box opens. A preview of the document is shown on the right side
of the dialog box.

2. Select a printer from the menu.

Note: The Print what field is disabled.

3. Select Paper Size from the menu. Options are:

• Letter (8.5 x 11 inches)
• Legal (8.5 x 14 inches)
• A4 (210 x 297 mm)

4. Select or type the number of Copies you want to print.

5. In the Print Range area, select to print all sheets in the document, a range of
sheets, or the current sheet only.

Note: By default, top and bottom margins are set to one-inch and are maintained
when printing a PublishView™ document. There are no side margins. PublishView™
sheets print just as they appear in the workspace.

6. If needed, select or clear the boxes to:

• Print problem breaks and names.
• Print headers
• Print footers
• Print object borders

7. Click Print, or click Save As PDF.
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Working with Lesson Bundles
Many lessons or activities contain multiple files. For example, teachers usually have a
teacher version of a file, a student version, assessments, and sometimes supporting
files. A lesson bundle is a container that enables teachers to group all files needed for
a lesson together. Lesson bundles are used to:

• Add any type of file (.tns, .tnsp, .doc, .pdf, .ppt) to a lesson bundle.

• Send lesson bundles to connected handhelds or laptops; however, only the .tns files
are sent to the handheld.

• View all the files in a lesson bundle using the TI-Nspire™ software.

• Group all files associated with one lesson in one place.

• Email one lesson bundle file to teachers or students instead of looking for and
attaching multiple files.

Creating a New Lesson Bundle

Teachers and students can create new lesson bundles in the Documents Workspace.
Teachers can also create new lesson bundles in the Content Workspace.

Creating a Lesson Bundle in the Documents Workspace

Complete the following steps to create a new lesson bundle. By default, the new
lesson bundle does not contain files.

1. Click in the Documents Toolbox to open the Content Explorer.

2. Navigate to the folder where you want to save the lesson bundle file.

3. Click to open the menu, and then click New Lesson Bundle.

The new lesson bundle file is created with a default name and placed in your list of
files.

4. Type a name for your lesson bundle.

5. Press Enter to save the file.

Creating Lesson Bundles in the Content Workspace

In the Content Workspace, teachers have two options for creating lesson bundles:

• When files needed for a lesson bundle are located in different folders, create an
empty lesson bundle, and then add files to the lesson bundle.
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• If all needed files are located in the same folder, create a lesson bundle with
selected files.

Creating an Empty Lesson Bundle

Complete the following steps to create a lesson bundle that does not contain files.

1. Navigate to the folder on your computer where you want to save the lesson bundle.

Note: If you are using the software for the first time, you may need to create a
folder on your computer before creating a lesson bundle.

2. Click or click File > New Lesson Bundle.

The new lesson bundle file is created with a default name and placed in the list of
files.

3. Type a name for the lesson bundle and press Enter.

The lesson bundle is saved with the new name and details are shown in the
Preview pane.

Creating a Lesson Bundle Containing Files

You can select multiple files within a folder, and then create the lesson bundle. You
cannot add a folder to a lesson bundle.

1. Navigate to the folder that contains the files you want to bundle.

2. Select the files. To select multiple files, select the first file then hold down Shift
and click the last file in the list. To select random files, select the first file, and
then hold down Ctrl and click the other files to select them.

3. Click , and then click Lesson Bundles > Create New Lesson Bundle from

selected.

A new lesson bundle is created and placed in the open folder. The lesson bundle
contains copies of the selected files.

4. Type a name for the lesson bundle and press Enter.

The lesson bundle is saved in the open folder and the details are shown in the
Preview pane.

Adding Files to a Lesson Bundle

Use any of the following methods to add files to a lesson bundle:



• Drag any file into a selected lesson bundle. This method moves the file to the
lesson bundle. If you delete the lesson bundle, the file is deleted from your
computer. You can recover the file from the Recycle Bin.

• Copy and paste any file into a selected lesson bundle.

• Use the "Add files to lesson bundle" option. This method copies the selected files
into the lesson bundle. The file is not moved from its original location.

Using the Add Files to Lesson Bundle Option

Use this option to add files to an empty lesson bundle or add more files to an existing
lesson bundle.

1. Use one of the following options to select the lesson bundle file.

• When working in the Documents Workspace, open the Content Explorer, and
then double-click the lesson bundle file name.

• When working in the Content Workspace, double-click the lesson bundle name.

Note: In the Content Workspace, you can also click the lesson bundle name to
open the Files dialog box in the Preview pane. The Add Files to Lesson Bundle
option is available from the Files dialog box. If the lesson bundle already
contains files, the first file in bundle is shown in the Files dialog box.

The lesson bundle dialog box opens. The name reflects the name of the lesson
bundle.

2. Click Add Files to Lesson Bundle.

The Add dialog box opens.
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3. Navigate to and select the file you want to add to the lesson bundle.

• You can select multiple files at one time if they are located in the same folder.
• If files are located in different folders, you can add them one at a time.
• You cannot create a folder within a lesson bundle or add a folder to a lesson

bundle.

4. Click Add to add the file to the bundle.

The file is added to the bundle and is now listed in the lesson bundle dialog box.

5. Repeat this process until all needed files are added to the lesson bundle.

Opening a Lesson Bundle

To view and work with files within a lesson bundle, complete one of the following
steps to open the lesson bundle file.

▶ Double-click the lesson bundle name.

▶ Select the lesson bundle, and then right-click and click Open.

▶ Select the lesson bundle, click , and then click Open.

▶ Select the lesson bundle, and then press Ctrl + O. (Mac®: “ + O).

When you open a lesson bundle, the files in the bundle are displayed in a separate
dialog box.



Note: You cannot open a lesson bundle outside of the TI-Nspire™ software. For
example, if you open the folder using the file manager on your computer and double-
click the lesson bundle name, it does not automatically launch the TI-Nspire™
software.

Opening Files Within a Lesson Bundle

You can open any file within a lesson bundle on your computer if you have the program
associated with the file type.

• When you open a .tns or .tnsp file, the file opens in the Documents Workspace in
the TI-Nspire™ software.

• When you open another file type, it launches the application or program associated
with that file. For example, if you open a .doc file, it opens in Microsoft® Word.

Use one of the following options to open a file within a lesson bundle:

▶ Double-click the lesson bundle, and then double-click a file within the lesson
bundle.

▶ Within a lesson bundle, select the file, and then click ¢ or right-click the file name
and select Open.

Managing Files in a Lesson Bundle

You can open, copy/paste, delete, and rename files in an existing lesson bundle. To
locate and work with files in an existing lesson bundle:

1. Choose one of the following options to locate an existing lesson bundle.

• When working in the Documents Workspace, open the Content Explorer (click
in the Documents Toolbox), and then navigate to the folder where the

lesson bundle is located.
• When working in the Content Workspace, navigate to the folder where the

lesson bundle is located in Content pane.

Note: When you click a lesson bundle name in the Content pane, the Files
dialog box opens in the Preview pane. Select a file and right-click to open the
context menu.
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2. Double-click the lesson bundle name to open the Lesson Bundle dialog box.

3. Select the file you want to work with and click ¢ to open the context menu.

4. Click the action you want to perform:

• Click Open. TI-Nspire™ and PublishView™ documents open in the Documents
Workspace. When you open another file type, it launches the application or
program associated with that file.

• Click Copy to place the file in the Clipboard.



• Navigate to a folder on your computer or select a connected handheld or
laptop, and then right-click and click Paste to place the copied file in a new
location.

• Click Delete to delete a file from the lesson bundle. Use caution when deleting
a file from a lesson bundle. You should ensure files contained in the bundle are
backed up if you need the files for future use.

• Click Rename to give the file a new name. To cancel this action, press Esc.
• Click Add Files to Lesson Bundle to select and add files to the bundle.
• Click Refresh to update the list of files in the bundle.
• Click Package Lesson Bundle to create a .tilb file
• Click Send to Connected Handhelds to open the Transfer Tool and send the

selected file to connected handhelds. You can send .tns files and OS files.

Note: This option is not available in the TI-Nspire™ Navigator™ NC Teacher
Software.

5. When finished, click Close to close the dialog box.

Managing Lesson Bundles

Use the options menu or the context menu to copy, delete, rename, or send a lesson
bundle to connected handhelds or laptops. You cannot add a folder to a lesson bundle.

Managing Lesson Bundles in the Documents Workspace

1. Open the Content Explorer, and then right-click the lesson bundle name or click
to open the context menu.
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2. Click the action you want to perform. If an action is not available, it is dimmed.

• Click Open to open the lesson bundle.

• Click Up One Level to navigate up a level in the folder hierarchy.

• You cannot add a folder to a lesson bundle. If you click New Folder, a new
folder is added to the folder where the lesson bundle is stored.

• Click New Lesson Bundle to create a new lesson bundle. The new lesson bundle
is not added to the existing lesson bundle—it is created in the same folder as
the existing lesson bundle.

• Click Rename to change the name of the lesson bundle. Press Esc to cancel this
action.

• Click Copy to copy the lesson bundle to the Clipboard.

• Navigate to another folder, and then click Paste to copy the lesson bundle in
another location.

• Click Delete to delete the lesson bundle. Use caution when deleting a lesson
bundle. You should ensure files contained in the bundle are backed up if you
need the files for future use.

• Select All highlights all files in the open folder. This action does not apply to
lesson bundles.



• Click Package Lesson to create a .tilb file.

• Click Refresh to update the list of files in the open folder.

Managing Lesson Bundles in the Content Workspace

1. Click Computer Content in the Resources pane.

2. In the Content pane, navigate to the lesson bundle you want to work with, and then
right-click to open the context menu or click to open the menu of options.

3. Select the action you want to perform:

• Click Open to open the lesson bundle.

• Click Copy to place the lesson bundle file in the Clipboard.

• Navigate to a folder on your computer or select a connected handheld, and
then right-click and click Paste to place the copied file in a new location.

• Click Delete to delete the lesson bundle. Use caution when deleting a lesson
bundle. You should ensure files contained in the bundle are backed up if you
need the files for future use.

• Click Refresh to update the list of files in the bundle.

• Click Rename to give the lesson bundle a new name. To cancel this action,
press Esc.

• To move up a level in the folder hierarchy, click Up a Level.

• To add the lesson bundle to the list of shortcuts in Local Content, click Create
Shortcut.
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• To add more files to the lesson bundle, click Lesson Bundles > Add Files to
Lesson Bundle.

• Click Lesson Bundles >Package Lesson Bundle to create a .tilb file.

• Click Send to Connected Handhelds to open the Transfer Tool and send the
lesson bundle to connected handhelds. (This option is not available in the
TI-Nspire™ Navigator™ NC Teacher Software.)

Packaging Lesson Bundles

Packaging lesson bundles creates a "package" folder with a .tilb file. This file contains
all files contained in the lesson bundle. You must package the lesson before you can
email the lesson bundle (.tilb file) to colleagues or students. By default, the lesson
bundle is saved in the following folder:
...\TI-Nspire\New Lesson Bundle1.tilb\package\...

Packaging a Lesson in the Documents Workspace

1. Open the Content Explorer.

2. Navigate to the folder where the lesson bundle is saved.

3. Select the lesson bundle you want to package.

4. Right-click to open the context menu, and then click Package Lesson.

The Lesson Bundle dialog box opens confirming that the .tilb file was created and
the lesson bundle was successfully packaged.

5. Click Yes to open the folder where the lesson package is stored. Click No to close
the dialog box.

Packaging a Lesson in the Contents Workspace

1. In ComputerContent, navigate to the folder that contains the lesson bundle you
want to package.

2. Click the lesson bundle in the Content pane. The Lesson Bundle details are
displayed in the Preview pane.

3. Use one of the following methods to create the package:

• From the Preview pane, click ¢ in the Files dialog box, and then click Package
Lesson Bundle.



• From the Content pane, right-click the lesson bundle name, and then click
Lesson Bundles > Package Lesson Bundle.

The Lesson Bundle dialog box opens confirming that the lesson bundle was
created.

4. Click Yes to open the folder where the lesson package is stored. Click No to close
the dialog box.

Emailing a Lesson Bundle

After a lesson bundle is packaged, you can email the .tilb file to other teachers or
students. To attach the lesson bundle to an email:

1. In your email client, select the option needed to attach a file, and then navigate to
the .tilb folder.

2. Make sure you open the folder and select the .tilb file to attach to the email. You
cannot email the .tilb folder.

Sending Lesson Bundles to Connected Handhelds

Note: This option is not available in TI-Nspire™ Navigator™ NC Teacher Software.

1. Complete one of the following actions to select a lesson bundle:

• In the Documents Workspace, open the Content Explorer, and then select the
lesson bundle you want to send.

• In the Content Workspace, navigate to the lesson you want to send in the
Content pane.

2. Drag the lesson bundle file to a connected handheld. You can also copy the lesson
bundle, and then paste it to a connected handheld.

The lesson bundle is transferred to the handheld as a folder with the same name. Only
.tns files are transferred to the handheld.
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Capturing Screens
Screen Capture enables you to:

• Capture Page

- Capture the active page in a TI-Nspire™ document from the software or from
the TI-SmartView™ emulator as an image.

- Save captured images as .jpg, .gif, .png, or .tif files, which can be inserted into
TI-Nspire™ applications that allow images.

- Copy and paste images into another application such as Microsoft® Word.

• Capture Selected Handheld

- Capture the current screen on a connected handheld as an image.
- Save captured images as .jpg, .gif, .png, or .tif files, which can be inserted into

TI-Nspire™ applications that allow images.
- Copy and paste images into another application such as Microsoft® Word.

• Capture Images in Handheld Mode

- In the Documents Workspace, use the DragScreen feature to capture the
emulator screen or side screen when the TI-SmartView™ Emulator is active.

- Teachers can use this feature to drag and paste an image to presentation tools
such as SMART® Notebook, Promethean’s Flipchart, and Microsoft® Office
applications including Word and PowerPoint®.

Accessing Screen Capture

The Screen Capture tool is available from all workspaces. To access Screen Capture:

▶ From the menu bar, click Tools > Screen Capture.

▶ From the toolbar, click .

Using Capture Page

Use the Capture Page option to capture an image of an active page in a TI-Nspire™
document. You can save images in the following file formats: .jpg, .gif, .png, and .tif.
Saved images can be inserted into TI-Nspire™ applications that allow images. The
image is also copied to the Clipboard and can be pasted into other applications such as
Microsoft® Word or PowerPoint.

Capturing a Page

Complete the following steps to capture an image of an active page.

1. In the Documents Workspace, open a document and navigate to the page you want
to capture to make it active.

2. Click , and then click Capture Page.
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The image of the active page is copied to the Clipboard and to the Screen Capture

window. The dialog box opens in the lower
right corner of your desktop when the screen capture is complete.

3. Click View it.

The Screen Capture window opens.

You can also clickWindow > Screen Capture Window to open the Screen Capture
window.

4. To capture additional pages, move to another page in the current document or
open a new document to select a page.

As you capture additional pages, the images are copied to the Screen Capture
window, which holds multiple images. The last page captured replaces the
contents of the Clipboard.

Using Capture Selected Handheld

Use the Capture Selected Handheld option to capture the active screen on a connected
handheld.

1. On a connected handheld, navigate to the menu or to a page in a document you
want to capture.

2. In the software, select the connected handheld:



• In the Content Workspace, select the handheld from the list of Connected
Handhelds in the Resources pane.

• In the Documents Workspace, open Content Explorer from the Documents
Toolbox, and then select the handheld from the list of Connected Handhelds.

• In the Class Workspace, select a logged in student.

3. Click , and then click Capture Selected Handheld.

—or—

Click , and then click Capture Selected Handheld.

The screen is copied to the Clipboard and to the TI-Nspire™ Screen Capture

window. The dialog box opens in the lower right corner of
your desktop when the screen capture is complete.

4. Click View it.

The Screen Capture window opens.

You can capture additional screens from an open document on a connected
handheld or open another document on a connected handheld to capture screens
from that document.

As you capture additional screens, the images are copied to the Screen Capture
window, which holds multiple images. The last screen captured replaces the
contents of the Clipboard.

Viewing Captured Screens

When you capture a page or screen, it is copied to the Screen Capture window.
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Zooming the View of Captured Screens

In the Screen Capture window, use the zoom in and zoom out options to increase or
decrease the size of the captured screens.

▶ From the toolbar, click to increase the size of the screens in the view. You can
also click View > Zoom In from the menu.

▶ From the toolbar, click to decrease the size of the screens in the view. You can
also click View > Zoom Out from the menu.

Saving Captured Pages and Screens

You can save captured pages and screens captured as images for use in other
TI-Nspire™ documents that allow images or for use in other applications such as
Microsoft® Word. You can save one image at a time, select multiple images to save, or
save all captured images.

Saving Selected Screens

1. In the Screen Capture window, select the screen image you want to save.

2. Click File > Save Selected Screen(s).

Note: From the Screen Capture window, you can also click .

The Save as dialog box opens.



3. Navigate to the folder on your computer where you want to save the file.

4. Type a name for the file.

Note: The default file name is MM-DD-YYYY Image ###.

5. Select the file type for the image file. The default format is .jpg. Click ¤ to select
another format: .gif, .tif, or .png.

6. Click Save.

The file is saved in the designated folder.

Saving Multiple Screens

1. In the Screen Capture window, select the screens you want to save.

To select multiple consecutive screens, click the first image, and then hold down
the Shift key and click the additional images. To select screens in random order,
press Ctrl (Mac®: “) and click each image you want to save.

2. Click or select File > Save Selected Screen(s). To save all captured screens, select
File > Save All Screens.

Note: The "Save All Screens" option is not available when using Capture Class.

The Save as dialog box opens.

3. In the Save In field, navigate to the folder where you want to save the images.

4. In the File Name field, type a new folder name. The default folder name is MM-
DD-YYYY Image, where MM-DD-YYYY is the current date.
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5. Select the file type for the image files. The default format is .jpg. Click ¤ to select
another format: .gif, .tif, or .png.

6. Click Save.

The images are saved in the specified folder with system-assigned names
reflecting the current date and a sequence number. For example, MM-DD-YYYY
Image 001.jpg, MM-DD-YYYY Image 002.jpg and so on.

Copying and Pasting a Screen

You can select a captured screen and copy it to the Clipboard for inclusion into other
documents or applications. You can also print copied screens. Copied screens are
captured at 100% zoom level, and they are copied in the order of selection.

Copying a Screen

1. Select the screen to copy.

2. Click or Edit > Copy.

The selected screen is copied to the Clipboard.

Pasting a Screen

Depending on the application you are pasting to, click Edit > Paste.

Note: You can also drag a screen capture to another application. This functions as a
copy and paste.

Capturing Images in Handheld Mode

In the Documents Workspace, use the DragScreen feature to capture the emulator
screen or side screen when the TI-SmartView™ Emulator is active.

Teachers can use this feature to drag and paste an image to presentation tools such as
SMART® Notebook, Promethean’s Flipchart, and Microsoft® Office applications
including Word and PowerPoint®.

Capturing Images Using the DragScreen Feature

Complete the following steps to capture an image and copy it to a third-party
application.

1. From the Documents Workspace, click , which is located in the Documents
Toolbox.

The TI-SmartView™ Emulator opens.

• If the display selected is Handheld + SideScreen, the current document is shown
in the emulator and in the side screen.

• If the display selected is Keypad + SideScreen, the current document is shown in
the side screen.



2. To start the screen capture, click the area above the emulator screen or above the
keypad. In the Handheld + Sidescreen display, you can also click the area around the
emulator screen.

Do not release the mouse button. If the cursor is active or if you click inside the
emulator window, the screen capture is not started.

InHandheld + SideScreen view, click the area
above the emulator, click the area around the
emulator, or click the border of the emulator
screen to start the screen capture.

In Keypad+ SideScreen view, click the area
above the keypad to start the screen capture.

3. Without releasing the mouse, drag the image.

A ghost image of the captured screen opens. The ghost image remains visible until
you release the mouse button.

The in the corner of the ghost image indicates you cannot paste the image in
that location.
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4. Drag the image to an open third-party application. When the image is on top of the
third-party application, the indicates you can drop the image.

5. Release the mouse button to drop the image into the selected application.

The image is also copied to the Clipboard and to the TI-Nspire™ Screen Capture
window.

To view captured images in the Screen Capture window, clickWindow > Screen
Capture Window.

You can capture additional screens as needed. As you capture additional screens,
the images are copied to the Screen Capture window, which holds multiple
images. The last screen captured replaces the contents of the Clipboard.



Working with Images
Images can be used in TI-Nspire™ applications for reference, assessment, and
instructional purposes. You can add images to the following TI-Nspire™ applications:

• Graphs & Geometry

• Data & Statistics

• Notes

• Question, including Quick Poll

In the Graphs & Geometry and Data & Statistics applications, images are set in the
background behind the axis and other objects. In the Notes and Question applications,
the image is set at the cursor location inline with the text (in the foreground).

You can insert the following image file types: .jpg, .png, or .bmp.

Note: The transparency feature of a .png file type is not supported. Transparent
backgrounds are displayed as white.

Working with Images in the Software

When working in the TI-Nspire™ software, you can insert, copy, move, and delete
images.

Inserting Images

In the Notes and Question applications, and in Quick Poll, you can insert more than one
image on a page. You can only insert one image on a page in the Graphs & Geometry
and Data & Statistics applications.

1. Open the document where you want to add an image.

2. Click Insert > Image.

The Insert Image dialog box opens.

Working with Images 113



114 Working with Images

3. Navigate to the folder where the image is located and select the image.

4. Click Open.

• In the Graphs & Geometry and Data & Statistics applications, the image is
inserted in the background behind the axis.

• In Notes, Question, and Quick Poll, the image is inserted at the cursor location.
You can type text above or below the image, and you can move the image up or
down on the page.

Note: You can also insert images by copying an image to the Clipboard and pasting it
into the application.

Moving Images

In applications such as Notes and Question where the image is set at the cursor
location, you can reposition the image by moving the image to a new line or blank
space, or by placing the image within a line of text. In the Graphs & Geometry and
Data & Statistics applications, images can be moved to any position on the page.

1. Select the image.

• In the Notes and Question applications, click the image to select it.

• In the Graphs & Geometry and Data & Statistics applications, right-click the
image, and then click Select > Image.

2. Click the selected image and hold the mouse button.



• If an image is in the foreground, the cursor changes to  .

• If an image is in the background, the cursor changes to  .

3. Drag the image to the new location and release the mouse button to place the
image.

If an image is in the foreground, the cursor changes to when you hover your
mouse pointer over a location where there is a new line or space. Images in the
background can be moved and placed anywhere on the page.

Resizing Images

To retain the aspect ratio of an image, resize by grabbing the image at one of the four
corners.

1. Select the image.

• In the Notes and Question applications, click the image to select it.

• In the Graphs & Geometry and Data & Statistics applications, right-click the
image, and then click Select > Image.

2. Move the cursor to one of the corners of the image.

The cursor changes to (a four-sided directional arrow).

Note: If you drag the cursor to an edge of the image, the cursor changes to (a
two-sided directional arrow). If you drag an image from one of its edges to resize
it, the image becomes distorted.

3. Click the corner or edge of the image.

The tool is enabled.

4. Drag in to make the image smaller or drag out to make the image larger.

5. Release the mouse when the image size is correct.

Deleting Images

To delete an image from an open document, complete the following steps.

1. Select the image.

• If an image is in the foreground, click the image to select it.

• If an image is in the background, right-click the image, and then click Select >
Image.
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2. Press Delete.

The image is removed.



Responding to Questions
The teacher may send you several different question types. This section shows you how
to answer the different question types.

Understanding the Question Toolbar

When you open a document with a question, a toolbar is available with four options.
Access the toolbar using the following method.

▶ In the Documents Toolbox, click .

Handheld: pressb.

Tool name Tool function

Clear
Answers

Lets you clear the answers in the current question or in the
document.

Check
Answer

If the teacher enabled Self-Check mode for the question, click
here to view the correct answer.

Insert Lets you insert a math expression box or chemical equation box
in your answer.

Format Click this tool to format the selected text in your answer as
subscript or superscript. (The chemical equation box uses its own
formatting tool, so this Format tool does not work in the
chemical equation box.)

Types of Questions

There are several types of questions you may be asked. There may be variations in a
type, but how you answer the question is basically the same for each type.

• Multiple Choice

- Custom
- ABCD
- True/False
- Yes/No
- Always/Sometimes/Never
- Agree/Disagree
- Strongly Agree...Strongly Disagree
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• Open response

- Explanation (not auto-graded)
- Text Match (auto-graded)

• Equations and Expressions

- y=
- f(x)=
- Expression

• Coordinate Points and Lists

- (x,y) numerical input
- Drop Point(s)
- List(s)

• Image

- Label
- Point on

• Chemistry

Responding to Quick Poll Questions

When teachers send quick polls during class, the question opens as a new document on
top of any document you may currently have open. You can access other applications to
perform calculations, and check or clear answers before submitting your answer to the
question or quick poll.

Note: On TI-Nspire™ CX or TI-Nspire™ CX CAS handhelds, questions appear in color if
the teacher applied color when writing the question. Although you can see color in the
questions you receive, you cannot add color to the responses you submit.

Accessing Other Applications

If the teacher gives permission, the Quick Poll tool allows you to temporarily exit the
question to perform calculations or access other documents to determine the answer
to the question. For example, you can access the Scratchpad to perform a calculation,
or you can access the Lists & Spreadsheet application and copy data from there to a
List question type. In a List question, you can link to variables from the Vernier
DataQuest™ or Lists & Spreadsheet applications.

To access other applications while in the Quick Poll screen:

1. Open a new document.

Handheld: Pressc to open the Home screen.

2. Choose an application.

Handheld: To return to the Quick Poll without accessing any documents, choose
C: Quick Poll.



3. When you are finished, click the Quick Poll icon.

When you respond to a poll, your response is immediately sent to the teacher’s
computer and teachers can track student responses in real time.

Showing Your Work

The teacher may request you to show work for your response. If so, the response area
has sections for you to write your starting point, your steps, and the final answer.

Responding to Different Question Types

▶ For Multiple Choice questions, press Tab to navigate to a response. Press Enter to
mark a response.

▶ For Open Response questions, type a response.

▶ For Equation questions, type a response. If a graph is included in a question, the
graph updates when you press Enter. Any functions entered show up on the graph,
and the cursor remains in the answer box. You cannot manipulate the graph itself.

▶ For Expression questions, type a response. If the response type is Number, your
response must be in the form of a number. If the response type is Expression, your
response must be in the form of an expression. For example, x+1.

▶ For Coordinate Points: (x,y) questions, type an answer in the x-field box, and press
Tab to move to the y-field box. Type an answer.

If a graph is included with the question, the graph is updated when you enter a
function and press Enter.

You can access the Window and Zoom functions while you are working on the
graph.

▶ For Coordinate Points: Drop Points questions, press Tab to move the cursor to a
point on the graph. Press Enter to drop a point at that location.

To delete a point, press Ctrl + Z to undo the action.

▶ For Lists questions, press Tab if necessary to move the cursor to the first cell of the
list. Type an answer, and press Tab to move to the next cell. Type an answer.

To link a column to an existing variable, select the column and then click var. Click
Link To, and then click the variable you want to link to.

The behavior in a Lists question closely matches the behavior of the Lists &
Spreadsheet application, with the following exceptions. In a Lists question, you
cannot:

• Add, insert, or delete columns.
• Change the header row.
• Enter formulas.
• Switch to Table.
• Create plots.
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▶ For Chemistry questions, type a response.

▶ For Image: Label questions, press Tab to move the cursor to a label on the image.
Type a response in the label field.

▶ For Image: Point on questions, press Tab to move the cursor to a point on the
image. Press Enter to mark a response.

Checking Answers

If the teacher enables self-check on the question, the Check Answer option is available.

1. Click .

Handheld: Pressb.

2. Click Check Answer.

Clearing Answers

After you answer a quick poll, you may decide you want to change the answer before
you submit it.

▶ ClickMenu > Clear Answers > Current Question or Document.

• Current Question clears answers for the active question.
• Document clears answers for all questions contained in the active document.

—or—

If you answered the question, you still have time to clear the answer before you submit
it to your teacher.

▶ Click Clear Answer to clear your answer and try again.

Handheld: Press~ and choose Clear Answer.

Submitting Responses

To send a final answer to the teacher:

▶ Click Submit Response.

Handheld: Press~ and choose Submit.

The response is sent to the teacher and the last screen you used is displayed.

Your response appears on the teacher’s computer. Your teacher may have set the poll
to allow you to submit more than one answer. If so, you can continue to respond to the
poll and submit answers until the teacher stops the poll.



Calculator Application
The Calculator application lets you:

• Enter and evaluate math expressions

• Define variables, functions, and programs that become available to any TI-Nspire™
application—such as the Graphs application—residing in the same problem.

• Define library objects, such as variables, functions, and programs, which are
accessible from any problem of any document. For information on creating library
objects, see Libraries.

Adding a Calculator Page

▶ To start a new document with a blank Calculator page:

From the main File menu, click New Document, and then click Add Calculator.

Handheld: Pressc, and select Calculator .

▶ To add a Calculator page in the current problem of an existing document:

From the toolbar, click Insert > Calculator.

Handheld: Press~ and select Insert > Calculator.

À Calculator menu. This menu is available anytime you are in the Calculator work area
using the Normal view mode. The menu in this screen snapshot may not exactly
match the menu on your screen.

Á Calculator work area

• Enter a math expression on the entry line, and then press Enter to evaluate the
expression.

• Expressions are displayed in standard mathematical notation as you enter
them.

• Entered expressions and results show in the Calculator history.
Â Example of Calculator variables used in another application.
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Entering and Evaluating Math Expressions

Entering Simple Math Expressions

Note: To enter a negative number on the handheld, pressv. To enter a negative
number on a computer keyboard, press the hyphen key (-).

Suppose you want to evaluate

1. Select the entry line in the Calculator work area.

2. Type 2^8 to begin the expression.

3. Press ► to return the cursor to the baseline.

4. Complete the expression:

Type *43/12.

Handheld: Typer 43p 12.

5. Press Enter to evaluate the expression.

The expression is displayed in standard mathematical notation, and the result is
displayed on the right side of the Calculator.

Note: If a result does not fit on the same line with the expression, it is displayed on the
next line.

Controlling the Form of a Result

You might expect to see a decimal result instead of 2752 ⁄ 3 in the preceding example.
A close decimal equivalent is 917.33333..., but that’s only an approximation.

By default, Calculator retains the more precise form: 2752 ⁄ 3. Any result that is not a
whole number is shown in a fractional or (CAS) symbolic form. This reduces rounding
errors that could be introduced by intermediate results in chained calculations.



You can force a decimal approximation in a result:

• By pressing shortcut keys.

Windows®: Press Ctrl +Enter to evaluate the expression.

Mac®: Press “+Enter to evaluate the expression.

Handheld: Press/· instead of· to evaluate the expression.

Pressing/· forces the approximate result.

• By including a decimal in the expression (for example, 43. instead of 43).

• By wrapping the expression in the approx() function.

• By changing the document’s Auto or Approximate mode setting to Approximate.

From the File menu, click Settings > Document Settings.

Handheld: Press~ to display the File menu.

Note that this method forces all results in all of the document’s problems to
approximate.

Inserting Items from the Catalog

You can use the Catalog to insert system functions and commands, symbols, and
expression templates into the Calculator entry line.

1. Click the Utilities tab, and then click to open the Catalog.

Handheld: Pressk1.
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Note: Some functions have a wizard that prompts you for each argument. Those
functions are shown with an indicator. To receive the prompts, select Wizards On.

2. If the item you are inserting is visible in the list, select it and press Enter to insert
it.

3. If the item is not visible:

a) Click inside the list of functions, and then press a letter key to jump to the
entries that begin with that letter.

b) Press ▲ or ▼ as necessary to highlight the item you are inserting.

Help, such as syntax information or a short description of the selected item,
appears at the bottom of the Catalog.

c) Press Enter to insert the item into the entry line.



Using an Expression Template

The Calculator has templates for entering matrices, piecewise functions, systems of
equations, integrals, derivatives, products, and other math expressions.

For example, suppose you want to evaluate

1. On the Utilities tab, click to open the templates.

Handheld: Presst.

2. Click to insert the algebraic sum template.

The template appears on the entry line with small blocks representing elements
that you can enter. A cursor appears next to one of the elements to show that you
can type a value for that element.

3. Use the arrow keys to move the cursor to each element’s position, and type a value
or expression for each element.

4. Press Enter to evaluate the expression.
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Creating Matrices

1. On the Utilities tab, click to open the templates.

Handheld: Presst.

2. Click .

The Create a Matrix dialog box opens.

3. Type the Number of rows.

4. Type the Number of columns, and then click OK.

Calculator opens a template with spaces for the rows and columns.

Note: If you create a matrix with a large number of rows and columns, it may take
a few moments to appear.

5. Type the matrix values into the template, and then press Enter to define the
matrix.

Inserting a Row or Column into a Matrix

▶ To insert a new row, hold down Alt and press Enter.

▶ To insert a new column, hold down Shift and press Enter.

Handheld:

▶ To insert a new row, press@.

▶ To insert a new column, press Shift+Enter.

Inserting Expressions Using a Wizard

You can use a wizard to simplify entering some expressions. The wizard contains
labeled boxes to help you enter the arguments in the expression.



For example, suppose you want to fit a y = mx + b linear regression model to the
following two lists:

{1,2,3,4,5}
{5,8,11,14,17}

1. On the Utilities tab, click to open the Catalog.

Handheld: Pressk 1.

2. Click an entry in the Catalog, and then press L to jump to the entries that begin
with “L.”

3. Press ▼ as necessary to highlight LinRegMx.

4. Select the Wizards On option, if it is not already selected:

Handheld: Press Tab Tab to highlight Wizards On, press Enter to change the setting,
and then press Tab Tab to highlight LinRegMx again.

5. Press Enter.

A wizard opens, giving you a labeled box to type each argument.

6. Type {1,2,3,4,5} as X List.

7. Press Tab to move to the Y List box.

8. Type {5,8,11,14,17} as Y List.

9. If you want to store the regression equation in a specific variable, press Tab, and
then replace Save RegEqn To with the name of the variable.

10. Click OK to close the wizard and insert the expression into the entry line.
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Calculator inserts the expression and adds statements to copy the regression
equation and show the variable stat.results, which will contain the results.

LinRegMx {1,2,3,4,5},{5,8,11,14,17},1: CopyVar stat.RegEqn,f2: stat.results

Calculator then shows the stat.results variables.

Note: You can copy values from the stat.results variables and paste them into the
entry line.

Creating a Piecewise Function

1. Begin the function definition. For example, type the following expression:

Define f(x,y)=

2. On the Utilities tab, click to open the templates.

Handheld: Presst.

3. Click .

The Create Piecewise Function dialog box opens.

4. Type the Number of Function Pieces, and click OK.

Calculator opens a template with spaces for the pieces.

5. Type the expressions into the template, and press Enter to define the function.



6. Enter an expression to evaluate or graph the function. For example, type the
expression f(1,2) on the Calculator entry line.

Creating a System of Equations

1. On the Utilities tab, click to open the templates.

Handheld: Presst.

2. Click .

The Create a System of Equations dialog box opens.

3. Type the Number of Equations, and click OK.

Calculator opens a template with spaces for the equations.

4. Type the equations into the template, and press Enter to define the system of
equations.

Entering Multiple Statements on the Entry Line

To enter several statements on a single line, separate them with a colon (“:”). Only the
result of the last expression is shown.

CAS: Working with Measurement Units

A list of pre-defined constants and measurement units is available in the Catalog. You
can also create your own units.

Note: If you know a unit’s name, you can type the unit directly. For example, you can
type _qt to specify quarts. To type the underscore symbol on the handheld, press
/_.
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CAS: Converting Between Measurement Units

You can convert a value between any two units within the same category (such as
length).

Example: Using the Catalog, convert 12 meters to feet. The desired expression is 12•_
m►_ft.

1. Type 12 on the entry line.

2. On the Utilities tab, click to show the unit conversions.

Handheld: Pressk 3.

3. Click the Length category to expand the list of pre-defined length units.

Handheld: Scroll to the Length category, and press Enter.

4. Scroll tometer.

Handheld: Scroll to _m (noting the meter hint in the Help window).



5. Press Enter to paste _m to the entry line.

6. Click the Conversion Operator (►) at the top of the Units list, and press Enter to
paste it to the entry line.

7. Select _ft from the Length category, and press Enter.

8. Press Enter to evaluate the expression.

CAS: Creating a User-defined Unit

As with the pre-defined units, user-defined unit names must begin with an underscore
symbol.

Example: Using the pre-defined units _ft and _min, define a unit named _fpm that lets
you enter velocity values in feet per minute and convert velocity results to feet per
minute.

Now you can use the new velocity unit _fpm.
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Using the Unit Conversion Assistant

In any application where math input is allowed, you can generate unit conversions
using the Unit Conversion Assistant. This can help reduce syntax errors by
automatically entering the units for you.

Example: Convert 528 minutes to hours. The desired expression is 528•_min►_hr.

1. Type 528 on the entry line.

2. On the Utilities tab, click the Unit Conversions bar.

Handheld: Pressk3.

3. Click the Open button next to Conversion Assistant.

Handheld: Press·.

The Unit Conversion Assistant dialog box displays:

4. Click the Category list and select Time.

Handheld: Scroll to the Time category and press·.



5. Click the From list and select min (minute).

Handheld: Scroll tomin (minute) and press·.

Note: You can select Use existing unit at the bottom of the list if you have already
entered a unit. In this example, you might have already entered 528•_min.

6. Click the To list and select hr (hour).

Handheld: Scroll to hr (hour) and press·.

7. Click OK to paste _min►_hr to the entry line.

8. Press Enter to evaluate the expression.

Handheld: Press·.
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Note:

• The last Category, From, and To selections will be retained until:

- the software is closed and re-opened (Desktop)
- the device is reset (Handheld)
- the language is changed, or the app is uninstalled or upgraded (iPad)

• Inserting a conversion into a Notes text field will automatically create a Math Box.

• Inserting a conversion into an empty line in the Calculator will automatically insert
Ans before the conversion.

Conversion Categories and Units

The following table lists categories and their respective units that are available in the
Unit Conversion Assistant. When the units are pasted to the entry line, underscores (_)
are added before the name of each unit to differentiate them from other variables. For
example:

• _cm►_m

• _km/_hr►_m/_s

• _¡C►_¡F

Category Units

Length Å (Angstrom)
au (astronomical unit)
cm (centimeter)
dm (decimeter)
fath (fathom)
fm (fermi)
ft (foot)
in (inch)
km (kilometer)
ltyr (light-year)



Category Units

m (meter)
mm (micron)
mi (mile)
mil (1/1000 inch)
mm (millimeter)
nm (nanometer)
Nmi (nautical mile)
pc (parsec)
rod (rod)
yd (yard)

Area acre (acre)
cm2

dm2

ft2

ha (hectare)
in2

km2

m2

mi2

mm2

yd2

Volume cm3

cup (cup)
dm3

ft3

floz (US fluid ounce)
flozUK (British fluid ounce)
gal (US gallon)
galUK (British gallon)
in3

l (liter)
m3

ml (milliliter)
pt (pint)
qt (quart)
tbsp (tablespoon)
tsp (teaspoon)
yd3

Calculator Application 135



136 Calculator Application

Category Units

Time day (day)
hr (hour)
min (minute)
ms (millisecond)
ms (microsecond)
ns (nanosecond)
s (second)
week (week)
yr (year)

Velocity ft/min
ft/s
knot (knot)
km/h
km/min
km/s
m/s
mi/h
mi/min
mi/s

Temperature ¡C (Celsius)
¡F (Fahrenheit)
K (kelvin)
¡R (Rankine)

Mass amu (atomic mass unit)
gm (gram)
kg (kilogram)
lb (pound)
mg (milligram)
mton (metric ton)
oz (ounce)
slug (slug)
ton (ton)
tonUK (long ton)

Force dyne (dyne)
kgf (kilogram force)
lbf (pound force)
N (newton)
tonf (ton force)



Category Units

Energy BTU (British thermal unit)
cal (calorie)
erg (erg)
eV (electron volt)
ftlb (foot-pound)
J (joule)
kcal (kilocalorie)
kJ (kilojoule)
kgf*m
kWh (kilowatt-hour)
latm (liter-atmosphere)

Power hp (horsepower)
kW (kilowatt)
PS (metric horsepower)
W (watt)

Pressure atm (atmosphere)
bar (bar)
inH

2
O (inches of water)

inHg (inches of mercury)
kPa (kilopascal)
kgf/cm2

lbf/in2

mbar (millibar)
mmH

2
O (millimeters of water)

mmHg (millimeters of mercury)
N/m2

Pa (pascal)
psi (pounds per square inch)
torr (millimeters of mercury)

Working with Variables

When you first store a value in a variable, you give the variable a name.

• If the variable does not already exist, Calculator creates it.

• If the variable already exists, Calculator updates it.

Variables within a problem are shared by TI-Nspire™ applications. For example, you
can create a variable in Calculator and then use or modify it in Graphs & Geometry or
Lists & Spreadsheet within the same problem.

For more information, see Using Variables.
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Creating User-defined Functions and Programs

You can use the Define command to create your own functions and programs. You can
create them in the Calculator application or in the Program Editor and then use them in
other TI-Nspire™ applications.

For more information, see Overview of the Program Editor and Libraries.

Defining a Single-line Function

Suppose you want to define a function named cube() that calculates the cube of a
number or variable.

1. On the Calculator entry line, type Define cube(x)=x^3 and press Enter.

The message “Done” confirms that the function has been defined.

2. Type cube(2) and press Enter to test the function.

Defining a Multiple-line Function Using Templates

You can define a function consisting of multiple statements entered on separate lines.
A multiple-line function may be easier to read than one with multiple statements
separated by colons.

Note: You can create multiple-line functions only by using the Define command. You
cannot use the := or→ operators to create multiple-line definitions. The
Func...EndFunc template serves as a container for the statements.

As an example, define a function named g(x,y) that compares two arguments x and y.
If argument x > argument y, the function should return the value of x. Otherwise, it
should return the value of y.

1. On the Calculator entry line, type Define g(x,y)=. Do not press Enter yet.

2. Insert the Func...EndFunc template.

From the Functions & Programs menu, select Func...EndFunc.

Calculator inserts the template.



3. Insert the If...Then...Else...EndIf template.

From the Functions & Programs menu, select Control, and then select
If...Then...Else...EndIf.

Calculator inserts the template.

4. Type the remaining parts of the function, using the arrow keys to move the cursor
from line to line.

5. Press Enter to complete the definition.

6. Evaluate g(3,-7) to test the function.

Defining a Multiple-line Function Manually

Within a multi-line template such as Func...EndFunc or If...EndIf, you can start a new
line without completing the definition.

• Handheld: Press@ instead of·.

• Windows®: Hold Alt and press Enter.

• Macintosh®: Hold Option and press Enter.

As an example, define a function sumIntegers(x) that calculates the cumulative sum of
integers from 1 through x.
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1. On the Calculator entry line, type Define sumIntegers(x)=. Do not press
Enter yet.

2. Insert the Func...EndFunc template.

From the Functions & Programs menu, select Func...EndFunc.

Calculator inserts the template.

3. Type the following lines, pressing@ or Alt+Enter at the end of each line.

4. After typing Return tmpsum, press Enter to complete the definition.

5. Evaluate sumIntegers(5) to test the function.

Defining a Program

Defining a program is similar to defining a multiple-line function. The Prgm...EndPrgm
template serves as a container for the program statements.

As an example, create a program named g(x,y) that compares two arguments. Based
on the comparison, the program should show the text “x>y” or “x≤y” (showing the
values of x and y in the text).

1. On the Calculator entry line, type Define prog1(x,y)=. Do not press Enter
yet.

2. Insert the Prgm...EndPrgm template.

From the Functions & Programs menu, select Prgm...EndPrgm.



3. Insert the If...Then...Else...EndIf template.

From the Functions & Programs menu, select Control, and then select
If...Then...Else...EndIf.

4. Type the remaining parts of the function, using the arrow keys to move the cursor
from line to line. Use the Symbol Palette to select the "≤“ symbol.

5. Press Enter to complete the definition.

6. Execute prog1(3,-7)to test the program.

Recalling a Function or Program Definition

You might want to reuse or modify a function or program that you have defined.

1. Show the list of defined functions.

From the Actions menu, select Recall Definition.

2. Select the name from the list.

The definition (for example, Define f(x)=1/x+3) is pasted into the entry line
for editing.
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Editing Calculator Expressions

Although you cannot edit an expression in the Calculator history, you can copy all or
part of an expression from the history and paste it to the entry line. You can then edit
the entry line.

Positioning the Cursor in an Expression

▶ Press Tab,◄,►,▲, or▼ to move the cursor through the expression. The cursor
moves to the closest valid position in the direction that you press.

Note: An expression template may force the cursor to move through its parameters,
even though some parameters may not be exactly in the path of the cursor movement.
For example, moving upward from the main argument of an integral always moves the
cursor to the top limit.

Inserting into an Expression in the Entry Line

1. Position the cursor at the point where you want to insert additional elements.

2. Type the elements that you want to insert.

Note: When you insert an open parenthesis, Calculator adds a temporary close
parenthesis, displayed in gray. You can override the temporary parenthesis by typing
the same parenthesis manually or by entering something past the temporary
parenthesis (thereby implicitly validating its position in the expression). After you
override the temporary gray parenthesis, it is replaced with a black parenthesis.

Selecting Part of an Expression

1. Position the cursor at the starting point in the expression.

Handheld: Press ◄,►,▲, or▼ to move the cursor.

2. Press and hold Shift, and then press ◄,►,▲, or▼ to select.

Deleting all or part of an expression on the entry line

1. Select the part of the expression to delete.

2. Press Del.

Financial Calculations

Several TI-Nspire™ functions provide financial calculations, such as time value of
money, amortization calculations, and return on investment calculations.

The Calculator application also includes a Finance Solver. It lets you dynamically solve
several types of problems, such as loans and investments.



Using the Finance Solver

1. Open the Finance Solver.

From the Finance menu, click Finance Solver.

The Finance Solver displays its default values (or previous values, if you have
already used the solver in the current problem).

2. Enter each known value, using Tab to cycle through the items.

• The help information at the bottom of the Finance Solver describes each item.
• You might need to temporarily skip the value that you want to calculate.
• Make sure to set PpY, CpY, and PmtAt to the correct settings (12, 12, and END

in this example).

3. Press Tab as necessary to select the item that you want to calculate, and then
press Enter.

The Finance Solver calculates the value and stores all the values in “tvm.”
variables, such as tvm.n and tvm.pmt. These variables are accessible to all
TI-Nspire™ applications within the same problem.
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Finance Functions Included

In addition to the Finance Solver, TI-Nspire™ built-in finance functions include:

• TVM functions for calculating future value, present value, number of payments,
interest rate, and payment amount.

• Amortization information such as amortization tables, balance, sum of interest
payments, and sum of principal payments.

• Net present value, internal rate of return, and modified rate of return.

• Conversions between nominal and effective interest rates, and calculation of days
between dates.

Notes:

• Finance functions do not automatically store their argument values or results to
the TVM variables.

• For a complete list of TI-Nspire™ functions, see the Reference Guide.

Working with the Calculator History

As you enter and evaluate expressions in the Calculator application, each entry/result
pair is saved in the Calculator history. The history gives you a way to review your
calculations, repeat a set of calculations, and copy expressions for reuse in other pages
or documents.

Viewing the Calculator History

Note: You may notice a processing slowdown when the history contains a large
number of entries.

▶ Press ▲ or▼ to scroll through the history.



Copying a Calculator History Item to the Entry Line

You can quickly copy an expression, subexpression, or result from the history into the
entry line.

1. Press ▲ or▼ to move through the history and select the item that you want to
copy.

—or—

Select part of the expression or result by using Shift in combination with the arrow
keys.

Note: The float setting for the current document may limit the number of decimal
places displayed in a result. To capture the result in its full precision, select it
either by scrolling with the up and down arrow keys or by triple-clicking it.

2. Press Enter to copy the selection and insert it into the entry line.

Copying a History Item to Another Application

1. Press ▲ or▼ to move through the history and select the item that you want to
copy.

2. Optionally, select part of the expression or result by pressing Shift in combination
with the arrow keys.

3. Use the standard key shortcut for copying a selection.
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Windows®: Press Ctrl+C.

Mac®: Press “+C.

Handheld: Press/C.

4. Place the cursor at the location where you want the copy.

5. Paste the copy.

Windows®: Press Ctrl+V.

Mac®: Press “+V.

Handheld: Press/V.

Note: If you copy an expression that uses variables into a different problem, the values
of those variables are not copied. You must define the variables in the problem where
you paste the expression.

Deleting an Expression from the History

When you delete an expression, all variables and functions defined in the expression
retain their current values.

1. Drag or use the arrow keys to select the expression.

Handheld: Use the arrow keys.

2. Press Del.

The expression and its result are removed.

Clearing the Calculator History

When you clear the history, all variables and functions defined in the history retain
their current values. If you clear the history by mistake, use the undo feature.

▶ From the Actions menu, select Clear History.

All expressions and results are removed from the history.



Using Variables
A variable is a defined value that can be used multiple times in a problem. You can
define a value or function as a variable within each application. Within a problem,
variables are shared by TI-Nspire™ applications. For example, you can create a variable
in Calculator, and then use or modify it in Graphs & Geometry or Lists & Spreadsheet
within the same problem.

Each variable has a name and a definition and the definition can be changed. When
you change the definition, all occurrences of the variable in the problem are updated to
use the new definition. In the TI-Nspire™ software, a variable has four attributes:

• Name - User-defined name assigned when the variable is created.

• Location - Variables are stored in memory.

• Value - Number, text, mathematical expression, or function.

• Type - Type of data that can be stored as a variable.

Note: Variables created with the Local command within a user-defined function or
program are not accessible outside that function or program.

Linking Values on Pages

Values and functions created or defined in one application can interact with other
applications (within the same problem) to share data.

When using linked items, keep in mind:

• Values can be linked between applications on one page or between different pages
of the same problem.

• All applications are linked to the same data.

• If the linked value is changed in the original application, the change is reflected in
all linked usages.

Defining a variable is the first step in linking values.

Creating Variables

Any portion or attribute of an object or function created within an application can be
stored as a variable. Examples of attributes that can become variables are the area of
a rectangle, the radius of a circle, the value contained in a spreadsheet cell or the
contents of a row or column, or a function expression. When you create a variable, it is
stored in memory.

Types of Variables

You can store the following data types as variables:
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Data type Examples

Expression

2.54   1.25E6   2p xmin/10       2+3i (xN2)2

List {2, 4, 6, 8} {1, 1, 2} {"red", "blue", "green"}

Matrix
This can be entered as:
[1,2,3;3,6,9]

Character string “Hello”      “xmin/10”            “The answer is:”

Function, program myfunc( arg )                 ellipse( x, y, r1, r2 )

Measurement area, perimeter, length, slope, angle

When you click or pressh on a handheld to open the list of stored variables, a
symbol indicates the type.

Creating a Variable from a Calculator Value

This example shows how to create a variable using a handheld. Complete the following
steps to create a variable named num and store the result of the expression 5+83 in
that variable.

1. On the Calculator entry line, type the expression 5+8^3.

2. Press ¢ to expand the cursor to the baseline.

3. Press/h and then type the variable name num.



This means: Calculate 5+83 and store the result as a variable named num.

4. Press·.

Calculator creates the variable num and stores the result there.

Creating a Variable in the Computer Software

When creating a variable in the computer software, use the following conventions. As
alternatives to using & (store), you can use “:=” or the Define command. All of the
following statements are equivalent.

5+83 & num
num := 5+83

Define num=5+83

Checking a Variable’s Value

You can check the value of an existing variable by entering its name on the Calculator
entry line. When you type the name of a stored variable, it appears in bold type.

▶ On the Calculator entry line, type the variable name num and press·.

The value most recently stored in num is displayed as the result.

Automatically Creating Variables in Graphs & Geometry

In the Graphs and Geometry applications, functions defined on the entry line are
automatically stored as variables.

In this example, f1(x)=x3 is a variable definition, which allows it to be displayed in
other applications including a table in the Lists & Spreadsheet application.
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Creating a Variable from a Graphs & Geometry Value

1. Click the value to store as a variable.

2. Click .
Handheld: Pressh.

The Variables options are displayed with Store Var highlighted.

3. Press·. VAR := appears before the selected value. This is the default name.

4. Replace the default name VAR with the variable name you want to give the value.

5. When the variable name is typed, press·.



The value is saved to that variable name, and the stored value or its name appears
in bold text to indicate it is a stored value.

Note: You can also share a Graphs & Geometry axis end value with other applications.
If necessary, click Actions, Show/Hide Axes End Values to display the end values on the
horizontal and vertical axes. Click the number for an end value to highlight it in the
entry field. Name the variable and store it for use with other applications by using any
method described in Step 2.

Automatically Creating Variables in Lists & Spreadsheet

Naming a list at the top of a Lists & Spreadsheet column automatically stores that
value as a list variable. This variable can be used in other applications including Data &
Statistics.

Creating a Variable from a Lists & Spreadsheet Cell Value

You can share a cell value with other applications. When defining or referring to a
shared cell in Lists & Spreadsheet, precede the name with an apostrophe (‘).

1. Click the cell that you want to share.

2. Click to open the Variables menu.

Handheld: Pressh.
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3. Click Store Var.

A formula is inserted into the cell with var as a placeholder for a variable name.

4. Replace the letters “var” with a name for the variable, and press·.

The value is now available as a variable to other applications within the same
problem.

Note: If a variable with the name you specified already exists in the current problem
space, Lists & Spreadsheet displays an error message.

Using (Linking) Variables

Sharing, or linking, the variables you create is a powerful tool for math exploration. The
display of linked variables is automatically updated when the variable’s value changes.

Linking to Shared Variables

To use a stored variable:

1. Display the page and select the location or object to which you want to link a
variable.

2. Select the Variables toolh.

The Variables options are displayed. The software knows which types of variables
will work in the location or with the object selected and will only display those
variables.

3. Use 9 and : to scroll the list.

—or—

Type part of the variable name.



As you type, the system displays a list of variables that begin with the letters you
typed. Typing part of the name enables you to locate a variable more quickly if the
list is long.

4. When you locate and highlight the name of the variable you want to use, click the
name.

—or—

Press·.

The selected variable value is linked.

Linking a Lists & Spreadsheet Cell to a Variable

When you link a cell to a variable, Lists & Spreadsheet keeps the cell value updated to
reflect the current value of the variable. The variable can be any variable in the current
problem and can be defined in Graphs & Geometry, Calculator, or any instance of Lists
& Spreadsheet.

Note: Do not link to a system variable. Doing so could prevent the variable from being
updated by the system. System variables include ans, StatMatrix, and statistics results
(such as RegEqn, dfError, and Resid).

1. Click the cell that you want to link to the variable.

2. Open the VarLink menu:

- Click , and then click Cell.

- Handheld: Pressh.

The VarLink menu is displayed.

3. Under Link To, scroll to the name of the variable and click it.

The cell shows the value of the variable.
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Using a Variable in a Calculation

After storing a value in a variable, you can use the variable name in an expression as a
substitute for the stored value.

1. Enter the expression:

- Type 4*25*num^2 on the entry line, and press Enter.

- Handheld: Type 4r 25r numq on the entry line, and press·.

Calculator substitutes 517, the value currently assigned to num, and evaluates the
expression.

2. Enter the expression:

- Type 4*25*nonum^2, and press Enter.

- Handheld: Type 4r 25r nonumq on the entry line, and press·.

CAS: Because the variable nonum has not been defined, it is treated algebraically in
the result.

Because the variable nonum has not been defined, the expression returns an error
message.

Naming Variables

Variable and function names that you create must meet the following naming rules.

Note: In the unlikely event that you create a variable with the same name as one used
for statistical analysis or by the Finance Solver, an error condition could occur. If you
begin entering a variable name that is already in use in the current problem, the
software shows the entry in bold to let you know.

• Variable names must be in one of the forms xxx or xxx.yyy. The xxx part can have
1 to 16 characters. The yyy part, if used, can have 1 to 15 characters. If you use the
xxx.yyy form, both xxx and yyy are required; you cannot start or end a variable
name with a period “.”.



• Characters can consist of letters, digits, and the underscore character (_). Letters
can be U.S. or Greek letters (but not Π or p), accented letters, and international
letters.

• Do not use c or n from the symbol palette to construct a variable name such as c1
or n12. These may appear to be letters, but they are treated internally as special
symbols.

• You can use uppercase or lowercase letters. The names AB22, Ab22, aB22, and
ab22 all refer to the same variable.

• You cannot use a digit as the first character of xxx or yyy.
• You can use digits 0 through 9, U.S. letters, a - z, Latin and Greek letters (but not p)

as subscripts (for example, a
2
, q

a
, or h

2
o). To enter a subscript while typing a

variable name, select in the Math Templates or on the formatting toolbar.

• Do not use spaces.

• If you want a variable to be treated as a complex number, use an underscore as the
last character of the name.

• CAS: If you want a variable to be treated as a type of unit (such as _m or _ft), use
an underscore as the first character of the name. You cannot use subsequent
underscores in the name.

• You cannot use an underscore as the first character of the name.

• You cannot use a preassigned variable, function, or command name, such as Ans,
min, or tan.

Note: For more information about TI-Nspire™ functions, see the Reference Guide.

• Library documents and library objects are subject to additional naming restrictions.
For more information, see Libraries.

Here are some examples:

Variable names Valid?

Myvar, my.var Yes

My var, list 1 No. Contains a space.

a, b, b12, b12, c, d Yes. Note that variables b12 and b
12

are distinct.

Log, Ans No. Preassigned to a system function or variable.

Log1, list1.a, list1.b Yes

3rdTotal, list1.1 No. xxx or yyy starts with a digit.
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Adjusting Variable Values with a Slider

A slider control lets you interactively adjust or animate the value of a numeric variable.
You can insert sliders in the Graphs, Geometry, Notes, and Data & Statistics
applications.

Horizontal slider for adjusting variable v1.
Minimized vertical slider for adjusting variable v2.

Note: TI-Nspire™ version 4.2 or higher is required for opening .tns files containing
sliders on Notes pages.

Inserting a Slider Manually

1. From a Graphs, Geometry, or Data & Statistics page, select Actions > Insert Slider.
—or—
From a Notes page, make sure the cursor is not in a math box or chem box, and
then select Insert > Insert Slider.

The Slider Settings screen opens.



2. Enter the desired values, and click OK.

The slider is displayed. On a Graphs, Geometry, or Data & Statistics page, handles
are displayed to let you move or stretch the slider.

To remove the handles and use the slider, click an empty
space in the work area. You can show the handles anytime by
selectingMove from the slider's context menu.

3. To adjust the variable, slide the pointer (or click the arrows on a minimized slider).

- You can use the Tab key to move the focus to a slider or to move from one
slider to the next. The color of the slider changes to show you when it has the
focus.

- When a slider has the focus, you can use the arrow keys to change the value of
the variable.

Working with the Slider

Use the options on the context menu to move or delete the slider, and to start or stop
its animation. You can also change the slider's settings.

1. Display the slider's context menu.
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2. Click an option to select it.

Automatic Sliders in Graphs

Sliders can be created for you automatically in the Graphs application and in the
analytic window of the Geometry application. You are offered automatic sliders when
you define certain functions, equations, or sequences that refer to undefined variables.

Locking and Unlocking Variables

Locking lets you protect variables from modification or deletion. Locking prevents
unintended changes to a variable.

Time and altitude lists can be locked to ensure problem
fidelity.



Reference function f1 can be locked to prevent
unintended change.

Variables you Cannot Lock

• System variable Ans
• stat. and tvm. variable groups

Important Information About Locked Variables

• To lock variables, use the Lock command.

• To modify or delete a locked variable, you must first unlock the item.

• Locked variables display a lock icon on the variable menu list.

• The Lock command clears the Redo/Undo history when applied to unlocked
variables.

Examples of Locking

Lock a,b,c Locks variables a, b, and c from the Calculator application.
Lock mystats. Locks all members of variable group mystats.
UnLock func2 Unlocks variable func2.
lm:=getLockInf 
(var2)

Retrieves the current lock status of var2 and assigns that value to
lm in the Calculator application.

For more information, see the Reference Guide.

Updating a Variable

If you want to update a variable with the result of a calculation, you must store the
result explicitly.

Entry Result Comment

a := 2 2

a3 8 Result not stored in variable a.

a 2
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Entry Result Comment

a := a3 8 Variable a updated with result.

a 8

a2& a 64 Variable a updated with result.

a 64

Reusing the Last Answer

Each instance of Calculator automatically stores the last calculated result as a variable
named Ans. You can use Ans to create a chain of calculations.

Note: Do not link to Ans or any system variable. Doing so could prevent the variable
from being updated by the system. System variables include statistics results (such as
Stat.RegEqn, Stat.dfError, and Stat.Resid) and Finance Solver variables (such as
tvm.n, tvm.pmt, and tvm.fv).

Example 1

As an example of using Ans, calculate the area of a garden plot that is 1.7 meters by
4.2 meters. Then use the area to calculate the yield per square meter if the plot
produces a total of 147 tomatoes.

1. Calculate the area:

- On the Calculator entry line, type 1.7*4.2, and press Enter.

- Handheld: On the Calculator entry line, type 1.7r 4.2, and press·.

2. Reuse the last answer to calculate the yield per square meter:

- Type 147/ans and press Enter to find the yield.

- Handheld: Type 147p ans, and press· to find the yield.

Example 2

As a second example, calculate and then add 2*log(45).

1. Type 3.76/(-7.9+sqrt(5)), and press Enter.

Handheld: Type 3.76p (v7.9+sqrt(5)), and press·.



2. Type ans+2*log(45), and press Enter.

Handheld: Type ans+2r log(45), and press·.

Temporarily Substituting a Value for a Variable

Use the “|” (such that) operator to assign a value to a variable for just a single
execution of the expression.

Removing a Linked Variable
1. Select the linked variable.

2. Pressh.

The Variables options are displayed.

3. Select Unlink.

The link is removed from the value, and the value is displayed without any bold
formatting.
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Graphs Application
The Graphs application lets you:

• Graph and explore functions and other relations, such as inequalities, parametrics,
polars, sequences, differential equation solutions, and conics.

• Animate points on objects or graphs and explore their behavior.

• Link to data created by other applications.

Adding a Graphs Page

▶ To start a new document with a blank Graphs page:

From the main File menu, click New Document, and then click Add Graphs.

Handheld: Pressc, and select Graphs .

▶ To add a Graphs page in the current problem of an existing document:

From the toolbar, click Insert > Graphs.

Handheld: Press~ and select Insert > Graphs.

Graphs & Geometry menu. Contains tools for defining, viewing, and investigating
relations.

Entry line. Lets you define the relations that you want to graph. The default graph
type is Function, so the form f1(x)= is displayed initially. You can define multiple
relations for each of several graph types.

Graphs Work Area

• Shows graphs of relations that you define on the entry line.

• Shows points, lines, and shapes that you create with geometry tools.

• Drag the area to pan (affects only those objects created in the Graphs
application).
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What You Must Know

Changing the Graphs and Geometry Settings

1. From the Settings menu in the Documents Toolbox, select Settings.

2. Select the settings that you want to use.

- Display Digits. Sets the display format for numbers as Floating or Fixed
decimal.

- Graphing Angle. Sets the angle unit for all Graphs and 3D Graphing applications
in the current docuument. The default setting is Radian. Set this to Auto if you
want graphing angles to follow the Angle setting in the main File > Settings
menu. An angle mode indicator shows the resulting mode in Graphs and 3D
Graphing applications.

- Geometry Angle. Sets the angle unit for all Geometry applications in the current
document. The default setting is Degree. Set this to Auto if you want geometry
angles to follow the Angle setting in the main File > Settings menu. An angle
mode indicator shows the resulting mode in Geometry applications.

- Automatically hide plot labels. In the Graphs application, hides the label that
normally appears next to a graphed relation.

- Show axis end values. Applies only in the Graphs application.

- Show tool tips for function manipulation. Applies only in the Graphs application.

- Automatically find points of interest. In the Graphs application, shows zeros,
minima, and maxima while tracing function graphs.

- Force Geometric Triangle Angles to Integers. Restricts the angles of a triangle to
integer values as you create or edit the triangle. This setting applies only in the
Geometry View with the Geometry Angle unit set to Degree or Gradian. It does
not apply to analytic triangles in Graphing View or to analytic triangles in the
Analytic Window of the Geometry View. This setting does not affect existing
angles, and it does not apply when constructing a triangle based on previously
inserted points. By default, this setting is deselected.

- Automatically Label Points. Applies labels (A, B, ..., Z, A
1
, B

1
, and so on) to

points, lines, and vertices of geometric shapes as you draw them. The labeling
sequence starts at A for each page in a document. By default, this setting is
deselected.

Note: If you create a new object that uses existing unlabeled points, those
point are not automatically labeled in the completed object.

- Click Restore to restore all settings to their factory defaults.



- ClickMake Default to apply the current settings to the open document and save
them as the default for new Graphs and Geometry documents.

Using Context Menus

Context menus provide quick access to commonly used commands and tools that apply
to a specific object. For example, you can use a context menu to change an object's
line color or to group a set of selected objects.

▶ Display the context menu for an object in one of the following ways.

- Windows®: Right-click the object.

- Mac®: Hold “ and click the object.

- Handheld: Move the pointer to the object, and then press/b.

Finding Hidden Objects in the Graphs or Geometry Application

You can hide and show individual graphs, geometric objects, text, labels,
measurements, and axis end-values.

To temporarily view hidden graphs or objects or to restore them as shown objects:

1. From the Actions menu, select Hide/Show.

The Hide/Show tool appears in the work area, and all hidden objects become
visible in dimmed colors.

2. Click a graph or object to toggle its Hide/Show state.

3. To apply the changes and close the Hide/Show tool, press ESC.

Inserting a Background Image

You can insert an image as a background for a Graphs or Geometry page. The file
format of the image can be .bmp, .jpg, or .png.

1. From the Insert menu, click Image.

2. Navigate to the image you want to insert, select it, and then click Open.

For information on moving, resizing, and deleting a background image, see Working
with Images in the Software.

Adding Text to the Graphs or Geometry Work Area

1. From the Actions menu, select Text.
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The Text tool appears in the work area.

2. Click the location for the text.

3. Type the text in the box that appears, and then press Enter.

4. To close the Text tool, press ESC.

5. To edit the text, double-click it.

Deleting a Relation and its Graph

1. Select the relation by clicking its graph.

2. Press Backspace or DEL.

The graph is removed from both the work area and the graph history.

Graphing Functions
1. From the Graph Entry/Edit menu, select Function.

2. Type an expression for the function.

3. Press Enter to graph the function.



Manipulating Functions by Dragging

Some types of functions can be translated, stretched, and/or rotated by dragging parts
of the graph. As you drag, the expression for the graph updates to reflect the change.

Drag graph from the ends to rotate.

Drag graph near the middle to translate.

Manipulating a Linear Function

▶ To translate, grab near the middle of the graph, and then drag.
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▶ To rotate, grab near the ends of the graph, and then drag.

Manipulating a Quadratic Function

▶ To translate, grab near the vertex of the graph, and then drag.

▶ To stretch, grab away from the vertex of the graph, and then drag.



Manipulating a Sine or Cosine Function

▶ To translate, grab near the axis of vertical symmetry of the graph, and then drag.

▶ To stretch, grab away from the axis of vertical symmetry of the graph, and then
drag.

Specifying a Function with Domain Restrictions

You can use the entry line or the Calculator application to specify a function with
domain restrictions. For multiple domain restrictions on a function, use the piecewise()
function.

In the following example, a function with a domain that is less than 2 and greater than
-2 is specified on the entry line:

1. From the Graph Entry/Edit menu, select Function.
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2. Type the following on the entry line, using spaces to separate the "and" operator:

piecewise(3,x>-2 and x<2)

3. Tap Enter to graph the function.

Finding Points of Interest on a Function Graph

The Graphs application helps you find zeros, minimums, maximums, intersections,
derivatives (dy/dx), or integrals. For Graphs defined as conic sections, you can also find
foci, directrix, and other points.

(CAS): You can also find the point of inflection.

Identifying Points of Interest by Dragging a Point

▶ To quickly identify maximums, minimums, and zeros, create a point on the graph
and then drag the point.

Temporary signposts appear as you drag through points of interest.



Identifying Points of Interest with Analysis Tools

This example illustrates using the Minimum tool. Other analysis tools operate
similarly.

1. From the Analyze Graph menu, select Minimum.

The Minimum icon is displayed at the top left on the work area, and a graph?
prompt appears in the work area.

2. Click the graph on which you want to find the minimum.

A dotted line appears, representing the lower bound of the range to search.
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3. Drag the line or click a location to set the lower bound and display a proposed
upper bound.

4. Drag the line representing the upper bound, or click a location to set it.

The minimum is displayed, along with a text object showing its coordinates.



Graphing a Family of Functions

In a family of functions, each member has its own value for one or more of the
parameters. By entering the parameters as lists, you can use a single expression to
graph a family of up to 16 functions.

For example, the expression f1(x) = {-1,0,1,2} • x + {2,4,6,8} denotes the following four
functions:
f1_1(x) = -1 • x + 2
f1_2(x) = 0 • x + 4
f1_3(x) = 1 • x + 6
f1_4(x) = 2 • x + 8

To Graph a Family of Functions

1. From the Graph Entry/Edit menu, select Function.

2. Type the expression, using lists to represent the members of the family.

3. Press Enter to graph the functions.

Each member is labeled separately (f1_1, f1_2, and so on) to indicate its sequence
in the expression.

Note: You cannot edit a single function graph to change it to a family of functions.
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Graphing Equations
1. From the Graph Entry/Edit menu, select Equation.

2. Click the type of equation (Line, Parabola, Circle, Ellipse, Hyperbola, or Conic).

3. Click the specific template for the equation. For example, tap y=a•x2+b•x+c to
define a parabola.

The entry line includes a symbol to indicate the type of equation.

4. Type the coefficients into the equation template.

5. Press Enter.

Graphing Conic Sections

The Graphing view lets you graph and explore linear and conic equations analytically in
a two-dimensional coordinate system. You can create and analyze lines, circles,
ellipses, parabolas, hyperbolas, and general conic equations.

The entry line makes it easy to enter the equation by displaying a template for the type
of equation you choose.

Example: Creating a conic ellipse

1. From the Graph Entry/Edit menu, select Equation > Ellipse, and tap the
equation type.



2. Type initial values for the coefficients in the provided spaces. Use the arrow keys to
move among the coefficients.

3. Press Enter to graph the equation.

Exploring the sample ellipse

1. Drag the ellipse from its center to explore the effect of translation on the equation.
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2. Use the analysis tools, such as Analyze Graph > Analyze Conics > Foci to further
explore the graph.

Note: The type of conic determines which analysis tools you can use. In the case of
the ellipse, you can obtain its center, vertices, foci, axes of symmetry, directrices,
eccentricity, and latera recta.



3. To explore translation and dilation interactively, define a conic ellipse that uses
variables for the h, k, a, and b coefficients. Insert sliders to vary the parameters.

Graphing Relations

Relation graphing is available on Graphs pages and in the Analytic Window of
Geometry pages.
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You can define relations using ≤, <, =, >, or ≥. The inequality operator (≠) is not
supported in relation graphing.

Relation type Examples

Equations and inequalities
equivalent to y = f(x)

• y = sqrt(x)
• y-sqrt(x) = 1/2
• -2*y-sqrt(x) = 1/2
• y-sqrt(x) ≥ 1/2
• -2*y-sqrt(x) ≥ 1/2

Equations and inequalities
equivalent to x = g(y)

• x = sin(y)
• x-sin(y) = 1/2
• x-sin(y) ≥ 1/2

Polynomial equations and
inequalities

• x^2+y^2 = 5
• x^2-y^2 ≥ 1/2+y
• x3+y3-6*x*y=0

The above relations on domains
restricted by rectangles

• y=sin(x) and -2π<x≤2π
• y≤x2|y≥-2 and 0≤x≤3
• {x2+y2≤3, y≥0 and x≤0

Note: Restrictions imposed by an active Press-to-Test session may limit the types of
relations you can graph.

To Graph a Relation:

1. From the Graph Entry/Edit menu, select Relation.

2. Type an expression for the relation.

3. Press Enter to graph the relation.



Tips for Graphing Relations

▶ You can quickly define a relation from the Function entry line. Position the cursor to
the immediate right of the = sign, and then press the Backspace key. A small menu
appears with the relation operators and a Relation option. Choosing from the menu
places the cursor in the Relation entry line.

▶ You can type a relation as text on a Graphs page and then drag the text object over
either axis. The relation is graphed and added to the relation history.

Warning and Error Message

Error Condition Additional Information

Relation input not supported Relation input not supported
Note: The following relation inputs are
supported:
• Relations using ≤, <, =, >, or ≥.
• Polynomial relations in x and y
• Relations equivalent to y=f(x) or x=g(y)

or corresponding inequalities
• The above relations on domains

restricted by rectangles

Domain Restrictions not supported
for certain classes of relations
equivalent to y=f(x) or x=g(y) or
corresponding inequalities.

• Relations equivalent to y=f(x) and
corresponding inequalities can only
have constraints on x

• For example: y=√(x) and 0≤x≤1 will
work but y=√(x) and 0≤y≤1 will not

• Relations equivalent to x=g(y) and
corresponding inequalities can only
have constraints on y

• For example: x=sin(y)|−1≤y≤1 will work
but x=sin(y)|−1≤x≤1 will not
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Graphing Parametric Equations
1. From the Graph Entry/Edit menu, select Parametric.

Use the up and down arrow keys to move among the fields in the Parametric entry
line.

2. Type expressions for xn(t) and yn(t).

3. (Optional) Edit the default values for tmin, tmax, and tstep.
4. Press Enter.

Graphing Polar Equations
1. From the Graph Entry/Edit menu, select Polar.

2. Type an expression for rn(θ).
3. (Optional) Edit the default values for θmin, θmax, and θstep.



4. Press Enter.

Using the Text Tool to Graph Equations

You can graph an "x=" or "y=" equation by typing it into a text box and dragging the
text to an axis. You can edit the equation text (for example, change it to an inequality),
but you cannot change it between x= and y=.

Graphing a Trigonometry Relation from Text

1. From the Actions menu, select Text.

2. Click the work area to place the text box.

3. Type the equation for the trigonometry relation, such as x=sin(y)*2.
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4. Press Enter to complete the text object.

5. Drag the text object to either axis to graph the equation.

Graphing a Vertical or Horizontal Line from Text

1. From the Actions menu, select Text.

2. Click the work area to place the text box.

3. Type the equation for a vertical line, such as x=4, or a horizontal line, such as
y=-2. Click Enter to complete it.

4. Drag the text object to either axis to graph the equation.

After plotting a line, you can drag to translate or rotate it.



Graphing an Inequality from Text

You can graph inequalities that use the >, <, ≤, or ≥ operators. Areas that satisfy the
inequality are shown with shading. If the shaded areas of two or more inequalities
overlap, the area of overlap is shaded darker.

1. From the Actions menu, select Text.

2. Click the work area to place the text box.

3. Type the inequality expression, such as x<2*sin(y). Click Enter to complete it.

4. Drag the text object to either axis to graph the inequality.

Graphing Scatter Plots
1. (Optional) Create two predefined list variables containing the x and y values to

plot. You can use the Lists & Spreadsheet, Calculator, or Notes application to create
the lists.

2. From the Graph Entry/Edit menu, select Scatter Plot.
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Use the up and down arrow keys to move between the x and y fields.

3. Use one of the following methods to specify lists to plot as x and y.

- Click to select names of the predefined list variables.

- Type the names of the variables, such as v1.
- Type lists as comma-separated elements enclosed within brackets, for

example: {1,2,3}.

4. Press Enter to plot the data, and then zoom the work area to view the plotted data.

Plotting Sequences

The Graphs application lets you plot two types of sequences. Each type has a separate
template for defining the sequence.

Defining a Sequence

1. From the Graph Entry/Edit menu, select Sequence > Sequence.

2. Type the expression to define the sequence. Update the independent variable field
to m+1, m+2, etc., if necessary.



3. Type an initial term. If the sequence expression references more than one prior
term, such as u1(n-1) and u1(n-2), (or u1(n) and u1(n+1)), separate the terms with
commas.

4. Press Enter.

Defining a Custom Sequence

A custom sequence plot shows the relationship between two sequences by plotting
one on the x axis and the other on the y axis.

This example simulates the Predator-Prey model from biology.

1. Use the relations shown here to define two sequences: one for a rabbit population,
and another for a fox population. Replace the default sequence names with rabbit
and fox.

.05 = the growth rate of rabbits if there are no foxes

.001 = the rate at which foxes can kill rabbits

.0002 = the growth rate of foxes if there are rabbits

.03 = the death rate of foxes if there are no rabbits

Note: If you want to see the plots of the two sequences, zoom the window to the
Zoom - Fit setting.
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2. From the Graph Entry/Edit menu, select Sequence > Custom.

3. Specify the rabbit and fox sequences to plot on the x and y axes, respectively.

4. Press Enter to create the custom plot.

5. Zoom the window to the Zoom - Fit setting.

6. Explore the custom plot by dragging the point that represents the initial term.

Graphing Differential Equations

You can study linear and non-linear differential equations and systems of ordinary
differential equations (ODEs), including logistic models and Lotka-Volterra equations
(predator-prey models). You can also plot slope and direction fields with interactive
implementations of Euler and Runge-Kutta methods.



ODE entry line:
• y1 ODE identifier
• Expression k·y1 defines the relation
• Fields (1,1) for specifying initial condition
• Buttons for adding initial conditions and setting plot parameters

Slider to vary coefficient k of the ODE

Slope field

A solution curve passing through the initial condition

To Graph a Differential Equation:

1. From the Graph Entry/Edit menu, select Diff Eq.

The ODE is automatically assigned an identifier, such as “y1.”

2. Move to the relation field and enter the expression that defines the relation. For
example, you might enter -y1+0.1*y1*y2.

3. Enter the initial condition for the independent value x
0
and for y1

0
.

Note: The x
0
value(s) are common to all the ODEs in a problem but can be entered

or modified only in the first ODE.
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4. (Optional) To study multiple initial conditions for the current ODE, click Add Initial

Conditions and enter the conditions.

5. Tap Edit Parameters to set the plot parameters. Select a numerical Solution
Method, and then set any additional parameters. You can change these parameters
anytime.

6. Click OK.



7. To enter additional ODEs, press the down arrow to display the next ODE edit field.

As you move among defined ODEs, the graph is updated to reflect any changes.
One solution to the ODE is graphed for each IC specified for each shown ODE
(selected by check box).

Summary of Differential Equation Settings

Solution
Method

Selects Euler or Runge-Kutta as the numerical solution method.

Iterations
Between
Plot Step

Computational accuracy for Euler solution method only. Must be an
integer value >0. To restore the default, select the down-arrow and
select Default.

Error
Tolerance

Computational accuracy for Runge-Kutta solution method only. Must be a
floating-point value |1×10-14. To restore the default, select the down-
arrow and select Default.

Field None - No field is plotted. Available for any number of ODEs, but
required if three or more 1st-order ODEs are active. Graphs a
combination of the solution and/or values of one or more ODEs
(according to user-configured Axes settings).
Slope - Plots a field representing the family of solutions to a single 1st-
order ODE. Exactly one ODE must be active. Sets Axes to Default 
(x and y). Sets Horizontal axis to x (the independent variable). Sets
Vertical axis to y (the solution to the ODE).
Direction - Graphs a field in the phase plane representing the relationship
between a solution and/or values of a system of two 1st-order ODEs (as
specified by the CustomAxes setting). Exactly two ODEs must be active.

Axes Default (x and y) - Plots x on the x axis and y (the solutions to the active
differential equations) on the y axis.
Custom - Lets you select the values to be plotted on the x and y axes
respectively. Valid entries include:
• x (the independent variable)
• y1, y2, and any identifiers defined in the ODE editor
• y1’, y2’, and any derivatives defined in the ODE editor

Plot Start Sets the independent variable value at which the solution plot starts.

Plot End Sets the independent variable value at which the solution plot stops.

Plot Step Sets the increment of the independent variable at which values are
plotted.

Field
Resolution

Sets the number of columns of field rendering elements (line segments)
used to draw a slope or direction field. You can change this parameter
only if Field = Direction or Slope.

Direction
Field at x=

Sets the independent variable value at which a direction field is drawn
when plotting non-autonomous equations (those that refer to x). Ignored
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when plotting autonomous equations. You can change this parameter
only if Field = Direction.

Viewing Tables from the Graphs Application

You can show a table of values for any relation defined in the current problem.

Note: For details about using tables and instructions for accessing tables from the
Lists & Spreadsheet application, see Working with Tables.

Showing a Table

▶ From the Table menu, select Split-screen Table.

The table is displayed with columns of values for the currently defined relations.

To change which relation is displayed in a column, click the arrow in the top cell of
the column, and then select the relation name.

Hiding the Table

▶ From the Table menu, select Remove Table.

Editing Relations
1. Double-click the graph to show its expression in the entry line.

—or—
Display the graph’s context menu, and then click Edit Relation.



2. Modify the expression as needed.

3. Press· to graph the revised function.

Renaming a Relation

Each relation type has a default naming convention. For example, the default name for
functions is fn(x). (The number represented by n increases as you create more
functions.) You can replace the default name with a name of your choice.

Note: If you want to use a custom name as a convention, you must enter it manually
for each function.

1. In the entry line, delete the existing name. For example, delete the "f1" from "f1
(x)". You can use the right and left arrow keys to position the cursor.

2. Type the replacement name.
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3. If you are defining a new relation, position the cursor after the = sign and type the
expression.

4. Press Enter to graph the relation with its new name.

Accessing the Graph History

For each problem, the software stores a history of relations defined in the Graphs
application and 3D Graphing view, such as function graphs f1 through f99 and 3D
function graphs z1 through z99. You can view and edit these items using a button on
the entry line.

Viewing the History

1. Press Ctrl+G to show the entry line.

2. Click the History Menu button   on the entry line.

The menu is displayed. As you point to the name of each item, its expression
appears in the entry line.

3. Select the name of the relation you want to view or edit.

4. (Optional) From the entry line, use the up and down arrow keys to scroll through
the defined relations of the same type.

Viewing the History of Specific Relation Types

Use this method if you want to view or edit a defined relation that does not appear in
the History menu.



1. On the Graph Entry/Edit menu, click the relation type. For example, click Polar to
show the entry line for the next available Polar relation.

2. Click the History Menu button  , or use the up and down arrow keys to scroll
through the defined relations of the same type.

Zooming/Rescaling the Graphs Work Area

Rescaling in the Graphs application affects only the graphs, plots, and objects that
reside in the Graphing view. It has no effect on objects in the underlying Plane
Geometry view.

Rescaling by Dragging Along an Axis

▶ To rescale the x and y axes proportionally, drag a tic mark on either axis.

▶ To rescale only one axis, hold down Shift and drag a tic mark on the axis.

Zooming Using a Zoom Tool

▶ From the Window / Zoommenu, select one of the tools.

- Zoom - Box (Click two corners of a box to define the area to show.)
- Zoom - In

- Zoom - Out

Zooming to Predefined Settings

▶ From the Window / Zoommenu, select one of the predefined Zoom settings.

- Zoom - Standard

- Zoom - Quadrant 1

- Zoom - Standard User

- Zoom - Standard Trig

- Zoom - Standard Data

- Zoom - Fit

Entering Custom Window Settings

1. From the Window / Zoommenu, select Window Settings.

2. Enter a value for each setting. You can use expressions for exact input, as shown
below.
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OnTI-Nspire™products, fractional input is preserved as-is. Other exact inputs are replacedwith
the evaluated result.

On TI-Nspire™CAS products, fractional and other exact inputs are preserved.

Customizing the Graphs Work Area

Inserting a Background Image

You can insert an image as a background for any Graphs or Geometry page.

1. From the Insert menu, click Image.

2. Navigate to the image you want to insert, select it, and then click Open.

Adding a Text Object to the Work Area

Use the Text tool to add numeric values, formulas, observations, or other explanatory
information to the Graphs work area. You can graph an equation entered as text (such
as "x=3").

1. From the Actions menu, select Text.



2. Click the location for the text.

3. Type the text in the box that appears, and then press Enter.

To move a text object, drag it. To edit the text, double-click it. To delete a text object,
display its context menu, and select Delete.

Changing the Attributes of Numeric Text

If you enter a numeric value as text, you can lock it or set its format and displayed
precision.

1. From the Actions menu, select Attributes.

2. Click the numeric text to display its list of attributes.

3. Press ▲ and ▼ to move through the list.

4. At each attribute icon, press◄ or ► to move through the options. For example,
select 0 through 9 as the precision.

5. Press Enter to apply the changes.

6. Press Esc to close the Attributes tool.

Displaying the Grid

By default, the grid is not displayed. You can choose to display it as dots or lines.

▶ From the Viewmenu, select Grid, and then select Dot Grid, Lined Grid, or No Grid.

Changing the Grid Color

1. From the Actions menu, choose Select > Grid (available only when the grid is
displayed).

The grid flashes to show it is selected.

2. Click the down arrow next to the Color button, and select a color for the grid.
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Changing the Appearance of the Graph Axes

1. From the Actions menu, click Attributes.

2. Click either axis.

3. Press ▲ and ▼ to move to the desired attribute, and then press ◄ and ► to
choose the option to apply.

Note: To hide the axes or selectively hide or show an individual axis end-value, use the
Hide/Show tool.

Hiding and Showing Items in the Graphs Application

The Hide/Show tool reveals objects you have previously selected as hidden and lets you
select which objects to show or hide.

Note: If you hide a graph, its expression is automatically marked as hidden in the graph
history.

1. From the Actions menu, select Hide/Show.

The Hide/Show tool appears at the top of the work area, and currently hidden
items (if any) are shown dimmed.

2. Click objects to toggle their hide/show status. You can hide graphs, geometric
objects, text, labels, measurements, and individual axis end-values.

3. Press Esc to complete your selections and close the tool.

All objects you selected as hidden objects disappear.



4. To view the hidden objects temporarily or restore them as shown objects, open the
Hide/Show tool.

Conditional Attributes

You can cause objects to hide, show, and change color dynamically, based on specified
conditions such as "r1<r2" or "sin(a1)>=cos(a2)."

For example, you might want to hide an object based on a changing measurement that
you have assigned to a variable, or you might want an object’s color to change based
on a "Calculate" result assigned to a variable.

Conditional behaviors can be assigned to objects or groups in the Graphing, Plane
Geometry, and 3D Graphing views.

Setting Conditional Attributes of an Object

You can set conditions of a selected object either by using its context menu or by
activating the Set Conditions tool from the Actions menu and then selecting the object.
These instructions describe using the context menu.

1. Select the object or group.

2. Display the object’s context menu, and click Conditions.

The conditional attributes are displayed.

For 2Dobjects For 3Dobjects
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3. (Optional) In the ShowWhen field, enter an expression specifying the conditions
during which the object will be shown. Anytime the condition is not satisfied, the
object will be hidden.

You can specify tolerance by using compound conditionals in the ShowWhen input
field. For example, area>=4 and area<=6.

Note: If you need to see conditionally hidden objects temporarily, click
Actions > Hide/Show. To return to normal viewing, press ESC.

4. (Optional) Enter numbers or expressions that evaluate to numbers in the applicable
color fields, such as Line Color orMesh Color. To see a map of color values, click
the Colors button.

Mapof conditional color values

5. Click OK in the Conditional Attributes dialog box to apply the conditions.

Calculating a Bounded Area

Note: To avoid unexpected results when using this feature, make sure the
document setting for "Real or Complex Format" is set to Real.

When you calculate the area between curves, each curve must be:

• A function with respect to x.

- or -

• An equation in the form y=, including y= equations defined through a text box or a
conic equation template.

Defining and Shading the Area

1. From the Analyze Graph menu, select Bounded Area.

If exactly two appropriate curves are available, they are selected automatically,
and you can skip to step 3. Otherwise, you are prompted to select two curves.

2. Click two curves to select them.
– or –
Click one curve and the x axis.

You are prompted to set the lower and upper bounds.



3. Click two points to define the bounds. Optionally, you can type numeric values.

The area becomes shaded, and the area value is displayed. The value is always
non-negative, regardless of the interval direction.

Working with Shaded Areas

As you change the bounds or redefine the curves, the shading and the area value are
updated .

• To change the lower or upper bound, drag it or type new coordinates for it. You
cannot move a bound that resides on an intersection. However, the point moves
automatically as you edit or manipulate the curves.

• To redefine a curve, either manipulate it by dragging or edit its expression in the
entry line.

If an endpoint resided originally on an intersection, and the redefined functions no
longer intersect, the shading and area value disappear. If you redefine the function
(s) so that there is an intersection point, the shading and area value reappear.

• To delete or hide the shaded area, or to change its color and other attributes,
display its context menu.

- Windows®: Right-click the shaded area.
- Mac®: Hold “ and click the shaded area.
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- Handheld: Move the pointer to the shaded area and press/x.

Tracing Graphs or Plots

Graph Trace lets you move a trace cursor over the points of a graph or plot and displays
value information.

Tracing Specific Graphs

1. From the Trace menu, select Graph Trace.

The Graph Trace tool appears at the top of the work area, the trace cursor appears,
and the cursor coordinates are displayed in the lower right corner.

2. Explore a graph or plot:

- Point to a position on a graph or plot to move the trace cursor to that point.

- Press ◄ or► to step the cursor along the current graph or plot. The screen
pans automatically to keep the cursor in view.

- Press ▲ or▼ to cycle among the displayed graphs.

- Click the trace cursor to create a persistent point. Optionally, enter a specific
independent value to move the trace cursor to that value.

3. To stop tracing, press Esc.

Tracing All Graphs

The Trace All tool allows tracing multiple functions simultaneously. With several
functions graphed on the work area, perform the following steps:



Note: The Trace All tool traces only function graphs, not plots of other relations (polar,
parametric, scatter, sequence).

1. From the Trace menu, select Trace All.

The Trace All tool appears in the work area, a vertical line indicates the x value of
the trace, and the coordinates for each traced point are displayed in the lower right
corner.

2. Explore the graphs:

- Click a point on the x axis to move all the trace points to that x value.

- Press ◄ or► to step the trace points along all the graphs.

3. To stop tracing, press Esc.

Changing the Trace Step

1. From the Trace menu, select Trace Step.

2. Choose Automatic or enter a specific step size for tracing.
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Introduction to Geometric Objects

Geometry tools are accessible in both the Graphs and Geometry applications. You can
use these tools to draw and investigate objects such as points, lines, and shapes.

• The Graphing view shows the Graphs work area superimposed on the Geometry
work area. You can select, measure, and alter objects in both work areas.

• The Plane Geometry view shows only the objects created in the Geometry
application.

Objects Created in the Graphs Application

Points, lines, and shapes created in the Graphs application are analytic objects.

• All points that define these objects reside on the x,y graph plane. Objects created
here are visible only in the Graphs application. Changing the axes scale affects the
appearance of the objects.

• You can display and edit the coordinates of any point on an object.

• You can display the equation of a line, tangent line, circle shape, or geometric conic
created in the Graphs application.

The circle arc andpolygonwere created in the Geometry application. The sinewave and conic
were created in the Graphs application.



Objects Created in the Geometry Application

Points, lines, and shapes created in the Geometry application are not analytic objects.

• Points that define these objects do not reside on the graph plane. Objects created
here are visible in both the Graphs and Geometry applications, but they are
unaffected by changes to the Graphs x,y axes.

• You cannot obtain the coordinates of an object’s points.

• You cannot display the equation of a geometric object created in the Geometry
application

Creating Points and Lines
As you create an object, a tool appears in the work area (for example, Segment ). To
cancel, press ESC. To enable automatic labeling of certain objects, see What You Must
Know in this chapter.

Creating a Point on the Work Area

1. From the Points and Lines menu, select Point. (In the Graphs application, click
Geometry > Points and Lines > Point.)

2. Click a location to create the point.

3. (Optional) Label the point.

4. To move a point, drag it.
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Creating a Point on a Graph or Object

You can create a point on a line, segment, ray, axis, vector, circle, graph, or axis.

1. From the Points and Lines menu, select Point On. (In the Graphs application, click
Geometry > Points and Lines > Point On.)

2. Click the graph or object on which you want to create the point.

3. Click a location on the object to place the point.

Identifying Points of Intersection

1. From the Points and Lines menu, select Intersection Points. (In the Graphs
application, click Geometry > Points and Lines > Intersection Points.)

2. Click two intersecting objects to add points at their intersections.

Creating a Line

1. From the Points and Lines menu, select Line. (In the Graphs application, click
Geometry > Points and Lines > Line.)

2. Click a location to define one point on the line.



3. Click a second location to define the direction of the line and the length of its
visible portion.

4. To move a line, drag its identifying point. To rotate it, drag any point except the
identifying point or ends. To extend its visible portion, drag from either end.

Creating a Segment

1. From the Points and Lines menu, select Segment. (In the Graphs application, click
Geometry > Points and Lines > Segment.)

2. Click two locations to define the endpoints of the segment.

3. To move a segment, drag any point other than an endpoint. To manipulate the
direction or length, drag either endpoint.

Creating a Ray

1. From the Points and Lines menu, select Ray. (In the Graphs application, click
Geometry > Points and Lines > Ray.)

2. Click a location to define the endpoint of the ray.

3. Click a second location to define the direction.
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To move a ray, drag its identifying point. To rotate it, drag any point except the
identifying point or end. To extend its visible portion, drag from the end.

Creating a Tangent

You can create a tangent line at a specific point on a geometric object or function
graph.

1. From the Points and Lines menu, select Tangent. (In the Graphs application, click
Geometry > Points and Lines > Tangent.)

2. Click the object to select it.

3. Click a location on the object to create the tangent.

4. To move a tangent, drag it. It remains attached to the object or graph.

Creating a Vector

1. From the Points and Lines menu, select Vector. (In the Graphs application, click
Geometry > Points and Lines > Vector.)



2. Click a location to establish the vector's initial point.

3. Click a second location to specify direction and magnitude and complete the vector.

4. To move a vector, drag any point other than the endpoints. To manipulate the
magnitude and/or direction, drag either end point.

Note: If you create an endpoint on an axis or another object, you can move the
endpoint only along that object.

Creating a Circle Arc

1. From the Points and Lines menu, select Circle Arc. (In the Graphs application, click
Geometry > Points and Lines > Circle Arc.)

2. Click a location or point to establish the starting point of the arc.

3. Click a second point to establish an intermediate point through which the arc will
pass.

4. Click a third point to set the ending point and complete the arc.

5. To move an arc, drag its perimeter. To manipulate it, drag any of its three defining
points.

Creating Geometric Shapes

The Shape tools let you explore circles, polygons, conics, and other geometric objects.
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As you create a shape, a tool appears in the work area (for example, Circle ). To
cancel the shape, press ESC. To enable automatic labeling of certain objects, see What
You Must Know, in this chapter.

Creating a Circle

1. From the Shapes menu, select Circle. (In the Graphs application, click Geometry >
Shapes > Circle.)

2. Click a location or point to position the circle’s center point.

3. Click a location or point to establish the radius and complete the circle.

4. To resize a circle, drag its perimeter. To move it, drag its center point.

Creating a Triangle

Note: To ensure that the sum of the angles of a triangle equals 180° or 200 gradians,
you can force integer angles in the Geometry view. Refer toWhat You Must Know, in
this chapter.

1. From the Shapes menu, select Triangle. (In the Graphs application, click Geometry >
Shapes > Triangle.)

2. Click three locations to establish the vertices of the triangle.



3. To manipulate a triangle, drag any point. To move it, drag any side.

Creating a Rectangle

1. From the Shapes menu, select Rectangle. (In the Graphs application, click Geometry
> Shapes > Rectangle.)

2. Click a location or point to establish the first corner of the rectangle.

3. Click a location for the second corner.

One side of the rectangle is displayed.

4. Click to establish the distance to the opposite side and complete the rectangle.

5. To rotate a rectangle, drag one of its first two points. To extend it, drag one of the
last two points. To move it, drag any side.

Creating a Polygon

1. From the Shapes menu, select Polygon. (In the Graphs application, click Geometry >
Shapes > Polygon.)

2. Click a location or point to establish the first vertex of the polygon.

3. Click to establish each additional vertex.

4. To complete the polygon, click the first vertex.

5. To manipulate a polygon, drag any vertex. To move it, drag any side.
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Creating a Regular Polygon

1. From the Shapes menu, select Regular Polygon. (In the Graphs application, click
Geometry > Shapes > Regular Polygon.)

2. Click once on the work area to establish the center point.

3. Click a second location to establish the first vertex and radius.

A 16-sided regular polygon is formed. The number of sides is displayed in brackets;
for example, {16}.

4. Drag any vertex in a circular motion to set the number of sides.

- Drag clockwise to reduce the number of sides.

- Drag counterclockwise to add diagonals.

5. To resize or rotate a regular polygon, drag any of its points. To move it, drag any
side.

Creating an Ellipse

1. From the Shapes menu, select Ellipse. (In the Graphs application, click Geometry >
Shapes > Ellipse.)

2. Click two locations or points to establish the foci.

3. Click to establish a point on the ellipse and complete the shape.



4. To manipulate an ellipse, drag any of its three defining points. To move it, drag its
perimeter.

Creating a Parabola (from focus and vertex)

1. From the Shapes menu, select Parabola. (In the Graphs application, click Geometry
> Shapes > Parabola.)

2. Click a location to establish the focus.

3. Click a location to establish the vertex and complete the parabola.

4. To manipulate a parabola, drag its focus or its vertex. To move it, drag it from any
other point.

Creating a Parabola (from focus and directrix)

1. Create a line to serve as the directrix.

2. From the Shapes menu, select Parabola. (In the Graphs application, click Geometry
> Shapes > Parabola.)

3. Click a location to establish the focus.

4. Click the line to establish it as the directrix.
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5. To manipulate a parabola, rotate or move its directrix or drag its focus. To move it,
select both the directrix and the focus, and then drag either object.

Creating a Hyperbola

1. From the Shapes menu, select Hyperbola. (In the Graphs application, click
Geometry > Shapes > Hyperbola.)

2. Click two locations to establish the foci.

3. Click a third location to complete the hyperbola.

4. To manipulate a hyperbola, drag any of its three defining points. To move it, drag it
from any other place on the shape.

Creating a Conic by Five Points

1. From the Shapes menu, select Conic by Five Points. (In the Graphs application, click
Geometry > Shapes > Conic by Five Points.)

2. Click five locations to establish the five points on the shape.

Depending on the pattern of the points, the conic can be a hyperbola or an ellipse.



3. To manipulate a conic, drag any of its five defining points. To move it, drag it from
any other place on the shape.

Creating Shapes Using Gestures (MathDraw)

The MathDraw tool lets you use touchscreen or mouse gestures to create points, lines,
circles, and other shapes.

MathDraw is available in:

• Geometry view without the analytic window displayed.

• Graphing view when the x scale and y scale are identical. This avoids non-circular
ellipses and non-square rectangles appearing as circles and squares.

MathDraw is not available in the 3D Graphing view or in the Geometry view with the
analytic window displayed.

Activating MathDraw

1. If using the Geometry view with the analytic window visible, use the Viewmenu to
hide the window.

2. On the Actions menu, select MathDraw.

The MathDraw icon appears. You can begin using the tool.

Canceling MathDraw

▶ When you have finished using the MathDraw tool, press Esc.

The tool also closes if you select a different tool or change views.

Creating Points

To create a labeled point, tap or click in an open area.

• If the point is close to an existing line, segment, ray, geometric conic (including
circles), or polygon, the point snaps to that object. You can also place a point on the
intersection of any two of those types of objects.
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• If the point is close to a visible grid location in a Graphs view or the analytic
window of a Geometry view, it snaps to the grid.

Drawing Lines and Segments

To create a line or segment, touch or click the initial position, and then drag to the end
position.

• If the drawn line passes near an existing point, the line snaps to the point.

• If the drawn line starts close to an existing point and ends next to another existing
point , it becomes a segment defined by those points.

• If the drawn line is nearly parallel or perpendicular to an existing line, segment, or
side of a polygon, it aligns to that object.

Note: The default tolerance for detecting parallel/perpendicular lines is 12.5
degrees. This tolerance can be redefined using a variable named ti_gg_fd.angle_tol.
You can change the tolerance in the current problem by setting this variable in the
calculator app to a value in the range 0 through 45 (0=no parallel/perpendicular
detection).

Drawing Circles and Ellipses

To create a circle or ellipse, use the touchscreen or mouse to draw the approximate
shape.

• If the drawn shape is sufficiently circular, a circle is created.

• If the shape is elongated, an ellipse is created.

• If the virtual center of the drawn shape is near an existing point, the circle or
ellipse is centered on that point.

Drawing Triangles

To create a triangle, draw a triangle-like shape.

• If a drawn vertex is close to an existing point, the vertex snaps to the point.

Drawing Rectangles and Squares

To create a rectangle or square, use the touchscreen or mouse to draw the perimeter.

• If the drawn shape is nearly square, a square is created.

• If the drawn shape is elongated, a rectangle is created.



• If the center of a square is close to an existing point, the square snaps to that
point.

Drawing Polygons

To create a polygon, tap or click a succession of existing points, ending on the first
point you tapped.

Using MathDraw to Create Equations

In the Graphs view, MathDraw attempts to recognize certain gestures as functions for
analytic parabolas.

Note: The default step value for quantization of the parabola coefficients is 1/32. The
denominator of this fraction can be redefined using a variable named ti_gg_fd.par_
quant. You can change the step value in the current problem by setting this variable to
a value greater or equal to 2. A value of 2, for example, produces a step value of 0.5.

Using MathDraw to Measure an Angle

To measure the angle between two existing lines, use the touchscreen or mouse to
draw a circle arc from one of the lines to the other.

• If the intersection point between the two lines does not exist, it is created and
labeled.

• The angle is not a directed angle.

Using MathDraw to Find a Mid-point

To create a point midway between two points, tap or click point 1, point 2, and then
point 1 again.

Using MathDraw to Erase

To erase objects, use the touchscreen or mouse to drag left and right, similar to the
motion of erasing a whiteboard.

• The erasure area is the bounding rectangle of the erasure gesture.

• All point objects and their dependents inside the erasure area are removed.
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Basics of Working with Objects

Selecting and Deselecting Objects

You can select an individual object or multiple objects. Select multiple objects when
you want to quickly move, color, or delete them together.

1. Click an object or graph to select it.

The object flashes to indicate selection.

2. Click any additional objects to add them to the selection.

3. Perform the operation (such as moving or setting color).

4. To deselect all objects, click an empty space in the work area.

Grouping and Ungrouping Geometric Objects

Grouping objects gives you a way to reselect them as a set, even after you have
deselected them to work with other objects.

1. Click each object to add it to the current selection.

The selected objects flash.

2. Display a context menu of the selected object or objects.

3. Click Group. You can now select all the items in the group by clicking any of its
members.

4. To split a group into individual objects, display a context menu of any of its
member objects, and click Ungroup.

Deleting Objects

1. Display the context menu of the object or objects.

2. Click Delete.

You cannot delete the origin, the axes, or points representing locked variables, even
if those items are included in the selection.

Moving Objects

You can move an object, group, or combination of selected objects and groups.



Note: If an immovable object (such as the graph axes or a point with locked
coordinates) is included in a selection or group, you cannot move any of the objects.
You must cancel the selection and then select only movable items.

To move this... Drag this

A multiple-object
selection or group

Any of its objects

A point The point

A segment or
vector

Any point other than an endpoint

A line or ray The identifying point

A circle The center point

Other geometric
shapes

Any position on the object except one of its defining points. For
example, move a polygon by dragging any of its sides.

Constraining Object Movement

Holding down the SHIFT key before dragging lets you constrain how certain objects are
drawn, moved, or manipulated.

Use the constraint feature to:

• Rescale only a single axis in the Graphs application.

• Pan the work area horizontally or vertically, depending on which direction you drag
initially.

• Limit object movement to horizontal or vertical.

• Limit point placement to 15° increments as you draw a triangle, rectangle, or
polygon.

• Limit angle manipulations to 15° increments.

• Limit the radius of a resized circle to integer values.
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Pinning Objects

Pinning objects prevents accidental changes as you move or manipulate other objects.

You can pin graphed functions, geometric objects, text objects, the graph axes, and the
background.

1. Select the object or objects to pin, or click an empty area if you are pinning the
background.

2. Display the context menu, and select Pin.

A pinned object displays a pin icon when you point to it.

3. To unpin an object, display its context menu, and select Unpin.

Notes:

• Although you cannot drag a pinned point, you can reposition it by editing its x and y
coordinates.

• You cannot pan the work area while the background is pinned.

Changing the Line or Fill Color of an Object

Color changes made in the software are displayed in shades of gray when you work on
documents using a TI-Nspire™ handheld that does not support color. Color is preserved
when you move documents back to the software.

1. Select the object or objects.

2. Display the object’s context menu, click Color, and then click Line Color or Fill Color.

3. Select the color to apply to the objects.

Changing the Appearance of an Object

1. From the Actions menu, select Attributes.

2. Click the object that you want to change. You can change shapes, lines, graphs, or
graph axes.

The list of the attributes for the selected object are displayed.

3. Press 9 and : to move through the list of attributes.

4. At each attribute icon, press 7 or 8 to move through the options. For example,
select Thick, Thin, or Medium for the Line Weight attribute.

5. Press Enter to apply the changes.



6. Press ESC to close the Attributes tool.

Labeling Points, Geometric Lines, and Shapes

1. Display the context menu of the object.

2. Click Label.

3. Type the text of the label, and then press Enter.

The label attaches itself to the object and follows the object as you move it. The
label's color matches the object's color.

Measuring Objects

Measurement values update automatically as you manipulate the measured object.

Note: Measurements of objects created in the Graphs application are displayed in
generic units named u. Measurements of objects created in the Geometry application
are displayed in centimeters (cm).

Measuring Length of a Segment, Circle Arc, or Vector

1. From the Measurement menu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click the object to display its length.
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Measuring Distance Between Two Points, a Point and a Line, or a Point and a Circle

1. From the Measurement menu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click the first point.

3. Click the second point or a point on the line or circle.

In this example, length is measured from the center of the
circle to the upper left vertex of the polygon.

Measuring Circumference of a Circle or Ellipse or the Perimeter of a Polygon,
Rectangle, or Triangle

1. From the Measurement menu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click the object to display its circumference or perimeter.



Measuring a Side of a Triangle, Rectangle, or Polygon

1. From the Measurement menu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click two points on the object that form the side you want to measure.

Note: You must click two points to measure a side. Clicking the side measures the
entire length of the object's perimeter.

Measuring Area of a Circle, Ellipse, Polygon, Rectangle, or Triangle

Note: You cannot measure the area of a polygon constructed using the Segment tool.

1. From the Measurement menu, select Area. (In the Graphs application, click
Geometry > Measurement > Area.)

2. Click the object to display its area.
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Measuring Slope of a Line, Ray, Segment, or Vector

1. From the Measurement menu, select Slope. (In the Graphs application, click
Geometry > Measurement > Slope.)

2. Click the object to display its slope.

The value is updated automatically when you manipulate the object.

Measuring Angles

Measured angles in the Geometry application range from 0° to 180°. Measured angles
in the Graphs application range from 0 radians to π radians. To change the angle unit,
use the Settings menu.

1. From the Measurement menu, select Angle. (In the Graphs application, click
Geometry > Measurement > Angle.)

2. Click three locations or points to define the angle. The second click defines the
vertex.



Measuring Angles using the Directed Angle Tool

1. From the Measurement menu, select Directed Angle. (In the Graphs application,
click Geometry > Measurement > Directed Angle.)

2. Click three locations or existing points to define the angle. The second click defines
the vertex.

3. To reverse the measurement orientation,

a) On the Actions menu, select Attributes.

b) Click the angle text. For example, click 300°.

c) Select the orientation attribute, and use the right or left arrow key to change it.

d) Press Esc to close the Attributes tool.
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Moving a Measured Value

▶ Drag the measurement to the desired location.

Note: If you move a measurement too far from its object, it stops following the
object. However, its value continues to be updated as you manipulate the object.

Editing a Measured Length

You can set the length of a side of a Triangle, Rectangle, or Polygon by editing its
measured value.

▶ Double-click the measurement, and then enter the new value.

Storing a Measured Value as a Variable

Use this method to create a variable and assign a measured value to it.

1. Display the item's context menu, and select Store.

2. Type a variable name for the stored measurement.

Linking a Measured Length to an Existing Variable

Use this method to assign a measured length value to an existing variable.

1. Display the measurement's context menu, and select Variables > Link to.

The menu shows the list of currently defined variables.

2. Click the name of the variable you want to link to.

Deleting a Measurement

▶ Display the measurement's context menu, and select Delete.



Locking or Unlocking a Measurement

1. Display the measurement's context menu, and select Attributes.

2. Use the up/down arrow keys to highlight the Lock attribute.

3. Use the left/right arrow keys to close or open the lock.

As long as the value remains locked, manipulations are not allowed that would
require the measurement to change.

Transforming Objects

You can apply transformations to drawn objects in both the Graphs and Geometry
applications. If the object's points are labeled, the corresponding points in the
transformed object are labeled using prime notation (A → A'). To enable automatic
labeling of certain objects, see What You Must Know in this chapter.

Exploring Symmetry

1. From the Transformation menu, select Symmetry. (In the Graphs application, click
Geometry > Transformation > Symmetry.)

2. Click the object whose symmetry you want to explore.

3. Click a location or existing point to establish the point of symmetry.

A symmetrical image of the object is displayed.

4. Manipulate the original object or the point of symmetry to explore the symmetry.

Exploring Reflection

1. Create a line or segment to predefine the line about which the object will be
reflected.

2. From the Transformation menu, select Reflection. (In the Graphs application, click
Geometry > Transformation > Reflection.)

3. Click the object whose reflection you want to explore.
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4. Click the predefined reflection line or segment.

A reflected image of the object is displayed.

5. Manipulate the original object or the line of symmetry to explore the reflection.

Exploring Translation

1. (Optional) Create a vector to predefine the distance and direction of translation.

2. From the Transformation menu, select Translation. (In the Graphs application, click
Geometry > Transformation > Translation.)

3. Click the object whose translation you want to explore.

4. Click the predefined vector.
—or—
Click two locations on the work area to indicate the direction and distance of
translation.

A translated image of the object is displayed.

5. Manipulate the original object or the vector to explore the translation.

Exploring Rotation

1. (Optional) Create an angle measurement to serve as a predefined angle of
rotation.



2. From the Transformation menu, select Rotation. (In the Graphs application, click
Geometry > Transformation > Rotation.)

3. Click the object whose rotation you want to explore.

4. Click a location or point to define the point of rotation.

5. Click the points of the predefined angle.
—or—
Click three locations to define an angle of rotation.

A rotated image of the object is displayed.

6. Manipulate the original object or the point of rotation to explore the rotation.

Exploring Dilation

1. Create a Text object containing a numeric value to serve as a predefined dilation
factor.

Note: You can also use a measured length value as the dilation factor. Keep in
mind that if you use a large value, you may have to pan the display to view the
dilated object.

2. From the Transformation menu, select Dilation. (In the Graphs application, click
Geometry > Transformation > Dilation.)

3. Click the object whose dilation you want to explore.

4. Click a location or existing point to define the center point of dilation.

5. Click the Text object or measurement that defines the dilation factor.

A dilated image of the object is displayed.
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6. Manipulate the original object or the center point of dilation to explore the dilation.
You can also edit the dilation factor.

Exploring with Geometric Construction Tools
While a construction is in progress, a tool appears in the work area (for example,
Parallel ). To cancel, press ESC.

Creating a Midpoint

This tool lets you bisect a segment or define a midpoint between any two points. The
points can be on a single object, on separate objects, or on the work area.

1. From the Construction menu, select Midpoint. (In the Graphs application, click
Geometry > Construction > Midpoint.)

2. Click a point or location to define the first point.

3. Click a second point or location to complete the midpoint.



Creating a Parallel Line

This tool creates a parallel line with respect to any existing line. The existing line can
be a Graphs axis or any side of a triangle, square, rectangle, or polygon.

1. From the Construction menu, select Parallel. (In the Graphs application, click
Geometry > Construction > Parallel.)

2. Click the object that will serve as the reference line.

3. Click a location to create the parallel line.

You can drag the parallel line to move it. If you manipulate the reference object,
the line remains parallel.

Creating a Perpendicular Line

You can create a line that is perpendicular to a reference line. The reference can be an
axis, an existing line, a segment, or one side of a triangle, rectangle, or polygon.

1. From the Construction menu, select Perpendicular. (In the Graphs application, click
Geometry > Construction > Perpendicular.)

2. Click a location or existing point through which the perpendicular line should pass.

3. Click the item that will serve as the reference line.
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You can drag the intersection point to move the perpendicular. If you manipulate
the reference object, the line remains perpendicular.

Creating a Perpendicular Bisector

You can create a perpendicular bisector on a segment, on one side of a triangle,
rectangle, or polygon, or between any two points.

1. From the Construction menu, select Perpendicular Bisector. (In the Graphs
application, click Geometry > Construction > Perpendicular Bisector.)

2. Click the item that will serve as the reference line.
—or—
Click two points to create a perpendicular bisector between them.

Bisecting an Angle

This tool creates an angle bisector. The points of the angle can be on existing objects,
or they can be locations on the work area.

1. From the Construction menu, select Angle Bisector. (In the Graphs application, click
Geometry > Construction > Angle Bisector.)

2. Click three locations or points to define the angle. The second click defines the
vertex of the angle.



The angle bisector adjusts automatically as you manipulate its defining points.

Creating a Locus

The Locus tool enables you to explore the range of motion of one object with respect to
another object as constrained by a shared point.

1. Create a segment, line, or circle.

2. Create a point on the segment, line, or circle.

3. Create another object that uses the point created in the previous step.
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Circle created to use the definedpoint on
the segment.

4. From the Construction menu, select Locus. (In the Graphs application, click
Geometry > Construction > Locus.)

5. Click the point shared by the objects.

6. Click the object defined to share the point (this is the object to vary).

The continuous locus is displayed.

Creating a Compass

This tool operates similarly to a geometric compass used for drawing circles on paper.

1. From the Construction menu, select Compass. (In the Graphs application, click
Geometry > Construction > Compass.)

2. To set the width (radius) of the compass:

Click a segment.
—or—
Click any side of a triangle, rectangle, polygon, or regular polygon.



—or—
Click any two existing points or locations on the work area.

3. Click a location to establish the center of the circle and complete the construction.

The radius adjusts automatically as you manipulate the original segment, side, or
points used to define the radius.

Animating Points on Objects

You can animate any point created as a point on an object or graph. Multiple points can
be animated simultaneously.

Animating a Point

1. From the Actions menu, select Attributes.

2. Click the point to display its attributes.

3. Press ▼ to select the animation attributes.

4. Press ◄ or ► to choose either unidirectional or alternating animation.

5. Type a value to set the animation speed. Any nonzero speed begins the animation.
To reverse the direction, enter a negative value.

6. Press Enter to display the animation controls  .

7. Press ESC to close the Attributes tool.

Pausing and Resuming All Animations

▶ To pause all animations on a page, click Pause .

▶ To resume all animations, click Play .
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Resetting All Animations

Resetting pauses all animations and returns all animated points to the positions they
occupied when they were first animated.

▶ To reset animation, click Reset .

Changing or Stopping the Animation of a Point

1. Click Reset to stop all animation.

2. From the Actions menu, select Attributes.

3. Click the point to display its attributes.

4. Select the animation attribute, and type a new animation speed. To stop the
point’s animation, enter zero.

Note: If other animated points exist, the animation controls remain in the work
area.

Adjusting Variable Values with a Slider

A slider control lets you interactively adjust or animate the value of a numeric variable.
You can insert sliders in the Graphs, Geometry, Notes, and Data & Statistics
applications.

Horizontal slider for adjusting variable v1.
Minimized vertical slider for adjusting variable v2.



Note: TI-Nspire™ version 4.2 or higher is required for opening .tns files containing
sliders on Notes pages.

Inserting a Slider Manually

1. From a Graphs, Geometry, or Data & Statistics page, select Actions > Insert Slider.
—or—
From a Notes page, make sure the cursor is not in a math box or chem box, and
then select Insert > Insert Slider.

The Slider Settings screen opens.

2. Enter the desired values, and click OK.

The slider is displayed. On a Graphs, Geometry, or Data & Statistics page, handles
are displayed to let you move or stretch the slider.

To remove the handles and use the slider, click an empty
space in the work area. You can show the handles anytime by
selectingMove from the slider's context menu.

3. To adjust the variable, slide the pointer (or click the arrows on a minimized slider).

- You can use the Tab key to move the focus to a slider or to move from one
slider to the next. The color of the slider changes to show you when it has the
focus.

- When a slider has the focus, you can use the arrow keys to change the value of
the variable.

Working with the Slider

Use the options on the context menu to move or delete the slider, and to start or stop
its animation. You can also change the slider's settings.
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1. Display the slider's context menu.

2. Click an option to select it.

Automatic Sliders in Graphs

Sliders can be created for you automatically in the Graphs application and in the
analytic window of the Geometry application. You are offered automatic sliders when
you define certain functions, equations, or sequences that refer to undefined variables.

Labeling (Identifying) the Coordinates of a Point

The Graphs application can identify and label the coordinates of any existing point,
provided the point was created in the Graphs application.

1. From the Actions menu, select Coordinates and Equations.

The tool appears at the top of the work area

2. Tap the point whose coordinates you want to show.



3. Press Esc to close the tool.

If you later move the point to a different location, the coordinates follow the point and
update automatically.

Displaying the Equation of a Geometric Object

You can display the equation of a line, tangent line, circle shape, or geometric conic,
provided the object was constructed in the Graphing View or within the Analytic
Window of the Plane Geometry View.

Note: Due to differences in the numerical representations of analytic and geometric
conics, the capability to convert a geometric conic to an analytic template may
sometimes be unavailable. This is done in order to avoid a situation where the
template-based conic would be different from the geometric one.

1. From the Actions menu, click Coordinates and Equations.

2. Move the pointer to the object.

The equation for the object appears.

Note: If you approach a defined point on the line or the center point of a circle, the
coordinates of that point are displayed instead of the equation. Move the pointer
away from the defined point to obtain the equation of the object.

3. Click to attach the equation to the pointer.

4. Move the equation to the desired location, and click to anchor it.
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5. Press Esc to exit the tool.

Using the Calculate Tool

The Calculate tool is available in the Graphs and Geometry applications. It lets you
evaluate a math expression you have entered as a text object.

The following example uses the Calculate tool to sum the measured angles of a
triangle.

1. Using the Shapes menu, create a triangle, and then measure its angles.

Tip: You can enable options to automatically label points and to force geometric
triangle angles to integers. For more information, see What You Must Know, in this
chapter.

2. From the Actions menu, click Text.

3. Click a location for the text, and type the formula for the calculation.

In this example, the formula sums three terms.



4. From the Actions menu, click Calculate.

5. Click the formula you created.

You are prompted to select a value for each term in the formula.

6. Click each angle measurement when prompted.

Note: If you have stored a measurement as a variable, you can select it when
prompted by clicking . If the name of a stored measurement matches a term in
the formula, you can press “L” when prompted for that term.

After you have selected the third term, the calculation result attaches itself to the
pointer.

7. Position the result, and press Enter to anchor it as a new text object.
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3D Graphs
The 3D Graphing view lets you create and explore three-dimensional graphs of:

• 3D functions of the form z(x,y)

• 3D parametric plots

Selecting the 3D Graphing View

The 3D Graphing View is available on any Graphs page   or Geometry page 

.

▶ From the Viewmenu, select 3D Graphing.

3D Graphs Menu

Entry line. Lets you define 3D graphs. The default graph type is 3D Function,
indicated by z1(x,y)=.
3D Graphs Work Area. Shows a 3D box containing graphs that you define. Drag to
rotate the box.

Graphing 3D Functions
1. In the 3D Graphing view, select 3D Graph Entry/Edit > Function.

The entry line appears.

2. Enter the expression that defines the graph. You can type the expression or build it
using expression templates.
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3. Press Enter to create the graph and hide the entry line. You can show or hide the
entry line anytime by pressing Ctrl+G.

Graphing 3D Parametric Equations
1. In the 3D Graphing view, select 3D Graph Entry/Edit > Parametric.

The entry line appears.

2. Type the equations that define the graph.

3. Press Enter to draw the graph and hide the entry line and keyboard. You can show
or hide the entry line anytime by pressing Ctrl+G.



4. To set the graphing parameters tmin, tmax, umin, and umax, display the graph's
context menu, and select Edit Parameters.

Rotating the 3D View

Rotating Manually

1. Press R to activate the Rotation tool (required only for the TI-Nspire™ handheld
with Clickpad).

2. Press any of the four arrow keys to rotate the graph.

Rotating Automatically

Auto rotation is equivalent to holding down the right arrow key.

1. Press A.

The Auto Rotation icon appears, and the graph rotates.

2. (Optional) Use the up and down arrow keys to explore the rotating graph.

3. To stop the rotation and return to the Pointer tool, press Esc.

Viewing from Specific Orientations

1. If necessary, press Esc to return to the Pointer tool.

2. Use letter keys to select the orientation:

- Press Z, Y, or X to view along the z, y, or x axis.

3D Graphs 243



244 3D Graphs

- Press letter O to view from the default orientation.

Editing a 3D Graph
1. Double-click the graph to show its expression in the entry line.

—or—
Display the graph’s context menu, and then click Edit Relation.

2. Modify the existing expression, or type a new expression in the entry line.

3. Press Enter.

Accessing the Graph History

For each problem, the software stores a history of relations defined in the Graphs
application and 3D Graphing view, such as function graphs f1 through f99 and 3D
function graphs z1 through z99. You can view and edit these items using a button on
the entry line.

Viewing the History

1. Press Ctrl+G to show the entry line.

2. Click the History Menu button   on the entry line.

The menu is displayed. As you point to the name of each item, its expression
appears in the entry line.

3. Select the name of the relation you want to view or edit.

4. (Optional) From the entry line, use the up and down arrow keys to scroll through
the defined relations of the same type.

Viewing the History of Specific Relation Types

Use this method if you want to view or edit a defined relation that does not appear in
the History menu.

1. On the Graph Entry/Edit menu, click the relation type. For example, click Polar to
show the entry line for the next available Polar relation.

2. Click the History Menu button  , or use the up and down arrow keys to scroll
through the defined relations of the same type.



Changing the Appearance of a 3D Graph

Setting Wire and Surface Color:

1. Display the graph’s context menu, click Color, and then click Line Color or Fill Color.

2. Click a color swatch to apply it.

Setting Custom Plot Colors:

You can assign different colors to a graph's top and bottom surfaces or choose to have
the graph colored automatically, based on height or steepness. You can also set the
wire color.

1. Display the graph’s context menu, and then click Color > Custom Plot Color.

2. Select one of the three Surface color options: Top/bottom color, Vary color by
height, or Vary color by steepness.

- If you choose Top/bottom color, click the color swatches to select colors for the
top and bottom surfaces.

- If you choose to vary color by height or steepness, colors are determined
automatically.

3. To set the Wire color, click the color swatch and select a color.

Setting Other Attributes of a Graph:

1. Display the graph’s context menu, and then click Attributes. You can set the
following attributes for the selected graph.

- format: surface+wire, surface only, or wire only
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- x resolution (enter a value in range 2-200*, default=21)

- y resolution (enter a value in range 2-200*, default=21)

- transparency (enter a value in range 0-100, default=30)

* Handhelds are limited to a maximum display resolution of 21, regardless of the
value entered.

2. Set the attributes as you like, and then press Enter to accept the changes.

Showing or Hiding a Graph’s Label

▶ Display the graph’s context menu, and then click Hide Label or Show Label.

Showing and Hiding 3D Graphs
1. In the 3D Graphing view, select Actions > Hide/Show.

The Hide/Show tool appears, and all hidden items are displayed in gray.

2. Tap a graph to change its hide/show state.

3. To apply the changes and dismiss the tool, press Esc.

Note: If you want to show or hide only the graph's label, see Showing or Hiding a
Graph’s Label.

Customizing the 3D Viewing Environment

Setting the Background Color

▶ Display the context menu for the work area, and then click Background Color.

Showing or Hiding Specific View Elements

▶ From the Viewmenu, click the item to show or hide. You can choose items such as
the 3D box, axes, box end values, and legend.

Changing the 3D Projection

▶ From the Viewmenu, click Orthographic Projection or Perspective View.



Orthographic Projection
(default)

Perspective View

Setting the Visual Attributes of the Box and Axes

1. Display the context menu for the box, and then click Attributes. You can set the
following attributes.

- Show or hide tic labels

- Show or hide end values

- Show or hide arrows on axes

- Show 3D or 2D arrow heads

2. Set the attributes as you like, and then press Enter to accept the changes.

Shrinking or Magnifying the 3D View

▶ From the Range/Zoommenu, click Shrink Box orMagnify Box.

Changing the 3D Aspect Ratio

1. From the Range/Zoommenu, click Aspect Ratio.

2. Enter values for the x, y, and z axes. The default value for each axis is 1.

Changing the Range Settings

▶ On the Range/Zoommenu, click Range Settings. You can set the following
parameters.

- XMin (default=-5)
XMax (default=5)
XScale (default=Auto) You can enter a numeric value.
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- YMin (default=-5)
YMax (default=5)
YScale (default=Auto) You can enter a numeric value.

- ZMin (default=-5)
ZMax (default=5)
ZScale (default=Auto) You can enter a numeric value.

- eye q¡ (default=35)
eye f¡ (default=160)
eye distance (default=11)

Tracing in the 3D View
1. From the Trace menu, select z Trace.

The z Trace icon and the trace plane appear, along with a text line showing the
current "z=" trace value.

2. To move the trace, hold down Shift and press the up or down arrow key.

The "z=" text is updated as you move.

3. (Optional) Use the four arrow keys to rotate the view and see how the trace plane
and the graph intersect.

4. To stop tracing and return to the Pointer tool, press Esc.

Changing the Trace Settings

1. From the Trace menu, select Trace Setup.

The 3D Trace Setup dialog box opens.



2. Enter or select the settings, and click OK to apply them.

3. If you are not already tracing, your new settings take effect the next time you
trace.

Example: Creating an Animated 3D Graph
1. Insert a new problem and select the 3D Graphing view.

2. From the Actions menu, select Insert Slider, click to position it, and type time as
the variable name.

3. Display the slider’s context menu, click Settings, and enter the following values.

Value: 3.8
Minimum: 3.2
Maximum: 4.4
Step Size: 0.1

4. In the entry line, define the function shown here:

5. Drag the slider thumb to see the effect of varying time.

6. Add visual interest. For example:
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- Change the background color of the work area.
- Hide the box, axes, or legend.
- Automatically rotate the graph.
- Change the graph's fill color and hide its lines.
- Change the graph’s transparency and shading.

7. To animate the graph, display the slider’s context menu, and click Animate. (To
stop, click Stop Animate from the context menu.)

You can combine manual or auto rotation with the slider animation. Experiment
with the x and y resolution to balance curve definition against animation
smoothness.



Geometry Application
The Geometry application lets you:

• Create and explore geometric objects and constructions.

• Manipulate and measure geometric objects.

• Animate points on objects and explore their behavior.

• Explore object transformations.

Adding a Geometry Page

▶ To start a new document with a blank Geometry page:

From the main File menu, click New Document, and then click Add Geometry.

Handheld: Pressc, and select Geometry .

▶ To add a Geometry page in the current problem of an existing document:

From the toolbar, click Insert > Geometry.

Handheld: Press~ and select Insert > Geometry.

À Geometry menu – Available anytime you are viewing a Geometry page.

Á Geometry work area -- The drawing area where you create and explore geometric
objects.

What You Must Know

Changing the Graphs and Geometry Settings

1. From the Settings menu in the Documents Toolbox, select Settings.

2. Select the settings that you want to use.
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- Display Digits. Sets the display format for numbers as Floating or Fixed
decimal.

- Graphing Angle. Sets the angle unit for all Graphs and 3D Graphing applications
in the current docuument. The default setting is Radian. Set this to Auto if you
want graphing angles to follow the Angle setting in the main File > Settings
menu. An angle mode indicator shows the resulting mode in Graphs and 3D
Graphing applications.

- Geometry Angle. Sets the angle unit for all Geometry applications in the current
document. The default setting is Degree. Set this to Auto if you want geometry
angles to follow the Angle setting in the main File > Settings menu. An angle
mode indicator shows the resulting mode in Geometry applications.

- Automatically hide plot labels. In the Graphs application, hides the label that
normally appears next to a graphed relation.

- Show axis end values. Applies only in the Graphs application.

- Show tool tips for function manipulation. Applies only in the Graphs application.

- Automatically find points of interest. In the Graphs application, shows zeros,
minima, and maxima while tracing function graphs.

- Force Geometric Triangle Angles to Integers. Restricts the angles of a triangle to
integer values as you create or edit the triangle. This setting applies only in the
Geometry View with the Geometry Angle unit set to Degree or Gradian. It does
not apply to analytic triangles in Graphing View or to analytic triangles in the
Analytic Window of the Geometry View. This setting does not affect existing
angles, and it does not apply when constructing a triangle based on previously
inserted points. By default, this setting is deselected.

- Automatically Label Points. Applies labels (A, B, ..., Z, A
1
, B

1
, and so on) to

points, lines, and vertices of geometric shapes as you draw them. The labeling
sequence starts at A for each page in a document. By default, this setting is
deselected.

Note: If you create a new object that uses existing unlabeled points, those
point are not automatically labeled in the completed object.

- Click Restore to restore all settings to their factory defaults.

- ClickMake Default to apply the current settings to the open document and save
them as the default for new Graphs and Geometry documents.



Using Context Menus

Context menus provide quick access to commonly used commands and tools that apply
to a specific object. For example, you can use a context menu to change an object's
line color or to group a set of selected objects.

▶ Display the context menu for an object in one of the following ways.

- Windows®: Right-click the object.

- Mac®: Hold “ and click the object.

- Handheld: Move the pointer to the object, and then press/b.

Finding Hidden Objects in the Graphs or Geometry Application

You can hide and show individual graphs, geometric objects, text, labels,
measurements, and axis end-values.

To temporarily view hidden graphs or objects or to restore them as shown objects:

1. From the Actions menu, select Hide/Show.

The Hide/Show tool appears in the work area, and all hidden objects become
visible in dimmed colors.

2. Click a graph or object to toggle its Hide/Show state.

3. To apply the changes and close the Hide/Show tool, press ESC.

Inserting a Background Image

You can insert an image as a background for a Graphs or Geometry page. The file
format of the image can be .bmp, .jpg, or .png.

1. From the Insert menu, click Image.

2. Navigate to the image you want to insert, select it, and then click Open.

For information on moving, resizing, and deleting a background image, see Working
with Images in the Software.

Adding Text to the Graphs or Geometry Work Area

1. From the Actions menu, select Text.

The Text tool appears in the work area.

2. Click the location for the text.
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3. Type the text in the box that appears, and then press Enter.

4. To close the Text tool, press ESC.

5. To edit the text, double-click it.

Deleting a Relation and its Graph

1. Select the relation by clicking its graph.

2. Press Backspace or DEL.

The graph is removed from both the work area and the graph history.

Introduction to Geometric Objects

Geometry tools are accessible in both the Graphs and Geometry applications. You can
use these tools to draw and investigate objects such as points, lines, and shapes.

• The Graphing view shows the Graphs work area superimposed on the Geometry
work area. You can select, measure, and alter objects in both work areas.

• The Plane Geometry view shows only the objects created in the Geometry
application.

Objects Created in the Graphs Application

Points, lines, and shapes created in the Graphs application are analytic objects.

• All points that define these objects reside on the x,y graph plane. Objects created
here are visible only in the Graphs application. Changing the axes scale affects the
appearance of the objects.

• You can display and edit the coordinates of any point on an object.

• You can display the equation of a line, tangent line, circle shape, or geometric conic
created in the Graphs application.



The circle arc andpolygonwere created in the Geometry application. The sinewave and conic
were created in the Graphs application.

Objects Created in the Geometry Application

Points, lines, and shapes created in the Geometry application are not analytic objects.

• Points that define these objects do not reside on the graph plane. Objects created
here are visible in both the Graphs and Geometry applications, but they are
unaffected by changes to the Graphs x,y axes.

• You cannot obtain the coordinates of an object’s points.

• You cannot display the equation of a geometric object created in the Geometry
application
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Creating Points and Lines
As you create an object, a tool appears in the work area (for example, Segment ). To
cancel, press ESC. To enable automatic labeling of certain objects, see What You Must
Know in this chapter.

Creating a Point on the Work Area

1. From the Points and Lines menu, select Point. (In the Graphs application, click
Geometry > Points and Lines > Point.)

2. Click a location to create the point.

3. (Optional) Label the point.

4. To move a point, drag it.

Creating a Point on a Graph or Object

You can create a point on a line, segment, ray, axis, vector, circle, graph, or axis.

1. From the Points and Lines menu, select Point On. (In the Graphs application, click
Geometry > Points and Lines > Point On.)

2. Click the graph or object on which you want to create the point.

3. Click a location on the object to place the point.



Identifying Points of Intersection

1. From the Points and Lines menu, select Intersection Points. (In the Graphs
application, click Geometry > Points and Lines > Intersection Points.)

2. Click two intersecting objects to add points at their intersections.

Creating a Line

1. From the Points and Lines menu, select Line. (In the Graphs application, click
Geometry > Points and Lines > Line.)

2. Click a location to define one point on the line.

3. Click a second location to define the direction of the line and the length of its
visible portion.
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4. To move a line, drag its identifying point. To rotate it, drag any point except the
identifying point or ends. To extend its visible portion, drag from either end.

Creating a Segment

1. From the Points and Lines menu, select Segment. (In the Graphs application, click
Geometry > Points and Lines > Segment.)

2. Click two locations to define the endpoints of the segment.

3. To move a segment, drag any point other than an endpoint. To manipulate the
direction or length, drag either endpoint.

Creating a Ray

1. From the Points and Lines menu, select Ray. (In the Graphs application, click
Geometry > Points and Lines > Ray.)

2. Click a location to define the endpoint of the ray.

3. Click a second location to define the direction.



To move a ray, drag its identifying point. To rotate it, drag any point except the
identifying point or end. To extend its visible portion, drag from the end.

Creating a Tangent

You can create a tangent line at a specific point on a geometric object or function
graph.

1. From the Points and Lines menu, select Tangent. (In the Graphs application, click
Geometry > Points and Lines > Tangent.)

2. Click the object to select it.

3. Click a location on the object to create the tangent.

4. To move a tangent, drag it. It remains attached to the object or graph.

Creating a Vector

1. From the Points and Lines menu, select Vector. (In the Graphs application, click
Geometry > Points and Lines > Vector.)
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2. Click a location to establish the vector's initial point.

3. Click a second location to specify direction and magnitude and complete the vector.

4. To move a vector, drag any point other than the endpoints. To manipulate the
magnitude and/or direction, drag either end point.

Note: If you create an endpoint on an axis or another object, you can move the
endpoint only along that object.

Creating a Circle Arc

1. From the Points and Lines menu, select Circle Arc. (In the Graphs application, click
Geometry > Points and Lines > Circle Arc.)

2. Click a location or point to establish the starting point of the arc.

3. Click a second point to establish an intermediate point through which the arc will
pass.

4. Click a third point to set the ending point and complete the arc.

5. To move an arc, drag its perimeter. To manipulate it, drag any of its three defining
points.

Creating Geometric Shapes

The Shape tools let you explore circles, polygons, conics, and other geometric objects.



As you create a shape, a tool appears in the work area (for example, Circle ). To
cancel the shape, press ESC. To enable automatic labeling of certain objects, see What
You Must Know, in this chapter.

Creating a Circle

1. From the Shapes menu, select Circle. (In the Graphs application, click Geometry >
Shapes > Circle.)

2. Click a location or point to position the circle’s center point.

3. Click a location or point to establish the radius and complete the circle.

4. To resize a circle, drag its perimeter. To move it, drag its center point.

Creating a Triangle

Note: To ensure that the sum of the angles of a triangle equals 180° or 200 gradians,
you can force integer angles in the Geometry view. Refer toWhat You Must Know, in
this chapter.

1. From the Shapes menu, select Triangle. (In the Graphs application, click Geometry >
Shapes > Triangle.)

2. Click three locations to establish the vertices of the triangle.
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3. To manipulate a triangle, drag any point. To move it, drag any side.

Creating a Rectangle

1. From the Shapes menu, select Rectangle. (In the Graphs application, click Geometry
> Shapes > Rectangle.)

2. Click a location or point to establish the first corner of the rectangle.

3. Click a location for the second corner.

One side of the rectangle is displayed.

4. Click to establish the distance to the opposite side and complete the rectangle.

5. To rotate a rectangle, drag one of its first two points. To extend it, drag one of the
last two points. To move it, drag any side.

Creating a Polygon

1. From the Shapes menu, select Polygon. (In the Graphs application, click Geometry >
Shapes > Polygon.)

2. Click a location or point to establish the first vertex of the polygon.

3. Click to establish each additional vertex.

4. To complete the polygon, click the first vertex.

5. To manipulate a polygon, drag any vertex. To move it, drag any side.



Creating a Regular Polygon

1. From the Shapes menu, select Regular Polygon. (In the Graphs application, click
Geometry > Shapes > Regular Polygon.)

2. Click once on the work area to establish the center point.

3. Click a second location to establish the first vertex and radius.

A 16-sided regular polygon is formed. The number of sides is displayed in brackets;
for example, {16}.

4. Drag any vertex in a circular motion to set the number of sides.

- Drag clockwise to reduce the number of sides.

- Drag counterclockwise to add diagonals.

5. To resize or rotate a regular polygon, drag any of its points. To move it, drag any
side.

Creating an Ellipse

1. From the Shapes menu, select Ellipse. (In the Graphs application, click Geometry >
Shapes > Ellipse.)

2. Click two locations or points to establish the foci.

3. Click to establish a point on the ellipse and complete the shape.
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4. To manipulate an ellipse, drag any of its three defining points. To move it, drag its
perimeter.

Creating a Parabola (from focus and vertex)

1. From the Shapes menu, select Parabola. (In the Graphs application, click Geometry
> Shapes > Parabola.)

2. Click a location to establish the focus.

3. Click a location to establish the vertex and complete the parabola.

4. To manipulate a parabola, drag its focus or its vertex. To move it, drag it from any
other point.

Creating a Parabola (from focus and directrix)

1. Create a line to serve as the directrix.

2. From the Shapes menu, select Parabola. (In the Graphs application, click Geometry
> Shapes > Parabola.)

3. Click a location to establish the focus.

4. Click the line to establish it as the directrix.



5. To manipulate a parabola, rotate or move its directrix or drag its focus. To move it,
select both the directrix and the focus, and then drag either object.

Creating a Hyperbola

1. From the Shapes menu, select Hyperbola. (In the Graphs application, click
Geometry > Shapes > Hyperbola.)

2. Click two locations to establish the foci.

3. Click a third location to complete the hyperbola.

4. To manipulate a hyperbola, drag any of its three defining points. To move it, drag it
from any other place on the shape.

Creating a Conic by Five Points

1. From the Shapes menu, select Conic by Five Points. (In the Graphs application, click
Geometry > Shapes > Conic by Five Points.)

2. Click five locations to establish the five points on the shape.

Depending on the pattern of the points, the conic can be a hyperbola or an ellipse.
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3. To manipulate a conic, drag any of its five defining points. To move it, drag it from
any other place on the shape.

Creating Shapes Using Gestures (MathDraw)

The MathDraw tool lets you use touchscreen or mouse gestures to create points, lines,
circles, and other shapes.

MathDraw is available in:

• Geometry view without the analytic window displayed.

• Graphing view when the x scale and y scale are identical. This avoids non-circular
ellipses and non-square rectangles appearing as circles and squares.

MathDraw is not available in the 3D Graphing view or in the Geometry view with the
analytic window displayed.

Activating MathDraw

1. If using the Geometry view with the analytic window visible, use the Viewmenu to
hide the window.

2. On the Actions menu, select MathDraw.

The MathDraw icon appears. You can begin using the tool.

Canceling MathDraw

▶ When you have finished using the MathDraw tool, press Esc.

The tool also closes if you select a different tool or change views.

Creating Points

To create a labeled point, tap or click in an open area.

• If the point is close to an existing line, segment, ray, geometric conic (including
circles), or polygon, the point snaps to that object. You can also place a point on the
intersection of any two of those types of objects.



• If the point is close to a visible grid location in a Graphs view or the analytic
window of a Geometry view, it snaps to the grid.

Drawing Lines and Segments

To create a line or segment, touch or click the initial position, and then drag to the end
position.

• If the drawn line passes near an existing point, the line snaps to the point.

• If the drawn line starts close to an existing point and ends next to another existing
point , it becomes a segment defined by those points.

• If the drawn line is nearly parallel or perpendicular to an existing line, segment, or
side of a polygon, it aligns to that object.

Note: The default tolerance for detecting parallel/perpendicular lines is 12.5
degrees. This tolerance can be redefined using a variable named ti_gg_fd.angle_tol.
You can change the tolerance in the current problem by setting this variable in the
calculator app to a value in the range 0 through 45 (0=no parallel/perpendicular
detection).

Drawing Circles and Ellipses

To create a circle or ellipse, use the touchscreen or mouse to draw the approximate
shape.

• If the drawn shape is sufficiently circular, a circle is created.

• If the shape is elongated, an ellipse is created.

• If the virtual center of the drawn shape is near an existing point, the circle or
ellipse is centered on that point.

Drawing Triangles

To create a triangle, draw a triangle-like shape.

• If a drawn vertex is close to an existing point, the vertex snaps to the point.

Drawing Rectangles and Squares

To create a rectangle or square, use the touchscreen or mouse to draw the perimeter.

• If the drawn shape is nearly square, a square is created.

• If the drawn shape is elongated, a rectangle is created.
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• If the center of a square is close to an existing point, the square snaps to that
point.

Drawing Polygons

To create a polygon, tap or click a succession of existing points, ending on the first
point you tapped.

Using MathDraw to Create Equations

In the Graphs view, MathDraw attempts to recognize certain gestures as functions for
analytic parabolas.

Note: The default step value for quantization of the parabola coefficients is 1/32. The
denominator of this fraction can be redefined using a variable named ti_gg_fd.par_
quant. You can change the step value in the current problem by setting this variable to
a value greater or equal to 2. A value of 2, for example, produces a step value of 0.5.

Using MathDraw to Measure an Angle

To measure the angle between two existing lines, use the touchscreen or mouse to
draw a circle arc from one of the lines to the other.

• If the intersection point between the two lines does not exist, it is created and
labeled.

• The angle is not a directed angle.

Using MathDraw to Find a Mid-point

To create a point midway between two points, tap or click point 1, point 2, and then
point 1 again.

Using MathDraw to Erase

To erase objects, use the touchscreen or mouse to drag left and right, similar to the
motion of erasing a whiteboard.

• The erasure area is the bounding rectangle of the erasure gesture.

• All point objects and their dependents inside the erasure area are removed.



Basics of Working with Objects

Selecting and Deselecting Objects

You can select an individual object or multiple objects. Select multiple objects when
you want to quickly move, color, or delete them together.

1. Click an object or graph to select it.

The object flashes to indicate selection.

2. Click any additional objects to add them to the selection.

3. Perform the operation (such as moving or setting color).

4. To deselect all objects, click an empty space in the work area.

Grouping and Ungrouping Geometric Objects

Grouping objects gives you a way to reselect them as a set, even after you have
deselected them to work with other objects.

1. Click each object to add it to the current selection.

The selected objects flash.

2. Display a context menu of the selected object or objects.

3. Click Group. You can now select all the items in the group by clicking any of its
members.

4. To split a group into individual objects, display a context menu of any of its
member objects, and click Ungroup.

Deleting Objects

1. Display the context menu of the object or objects.

2. Click Delete.

You cannot delete the origin, the axes, or points representing locked variables, even
if those items are included in the selection.

Moving Objects

You can move an object, group, or combination of selected objects and groups.
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Note: If an immovable object (such as the graph axes or a point with locked
coordinates) is included in a selection or group, you cannot move any of the objects.
You must cancel the selection and then select only movable items.

To move this... Drag this

A multiple-object
selection or group

Any of its objects

A point The point

A segment or
vector

Any point other than an endpoint

A line or ray The identifying point

A circle The center point

Other geometric
shapes

Any position on the object except one of its defining points. For
example, move a polygon by dragging any of its sides.

Constraining Object Movement

Holding down the SHIFT key before dragging lets you constrain how certain objects are
drawn, moved, or manipulated.

Use the constraint feature to:

• Rescale only a single axis in the Graphs application.

• Pan the work area horizontally or vertically, depending on which direction you drag
initially.

• Limit object movement to horizontal or vertical.

• Limit point placement to 15° increments as you draw a triangle, rectangle, or
polygon.

• Limit angle manipulations to 15° increments.

• Limit the radius of a resized circle to integer values.



Pinning Objects

Pinning objects prevents accidental changes as you move or manipulate other objects.

You can pin graphed functions, geometric objects, text objects, the graph axes, and the
background.

1. Select the object or objects to pin, or click an empty area if you are pinning the
background.

2. Display the context menu, and select Pin.

A pinned object displays a pin icon when you point to it.

3. To unpin an object, display its context menu, and select Unpin.

Notes:

• Although you cannot drag a pinned point, you can reposition it by editing its x and y
coordinates.

• You cannot pan the work area while the background is pinned.

Changing the Line or Fill Color of an Object

Color changes made in the software are displayed in shades of gray when you work on
documents using a TI-Nspire™ handheld that does not support color. Color is preserved
when you move documents back to the software.

1. Select the object or objects.

2. Display the object’s context menu, click Color, and then click Line Color or Fill Color.

3. Select the color to apply to the objects.

Changing the Appearance of an Object

1. From the Actions menu, select Attributes.

2. Click the object that you want to change. You can change shapes, lines, graphs, or
graph axes.

The list of the attributes for the selected object are displayed.

3. Press 9 and : to move through the list of attributes.

4. At each attribute icon, press 7 or 8 to move through the options. For example,
select Thick, Thin, or Medium for the Line Weight attribute.

5. Press Enter to apply the changes.
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6. Press ESC to close the Attributes tool.

Labeling Points, Geometric Lines, and Shapes

1. Display the context menu of the object.

2. Click Label.

3. Type the text of the label, and then press Enter.

The label attaches itself to the object and follows the object as you move it. The
label's color matches the object's color.

Measuring Objects

Measurement values update automatically as you manipulate the measured object.

Note: Measurements of objects created in the Graphs application are displayed in
generic units named u. Measurements of objects created in the Geometry application
are displayed in centimeters (cm).

Measuring Length of a Segment, Circle Arc, or Vector

1. From the Measurement menu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click the object to display its length.



Measuring Distance Between Two Points, a Point and a Line, or a Point and a Circle

1. From the Measurement menu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click the first point.

3. Click the second point or a point on the line or circle.

In this example, length is measured from the center of the
circle to the upper left vertex of the polygon.

Measuring Circumference of a Circle or Ellipse or the Perimeter of a Polygon,
Rectangle, or Triangle

1. From the Measurement menu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click the object to display its circumference or perimeter.
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Measuring a Side of a Triangle, Rectangle, or Polygon

1. From the Measurement menu, select Length. (In the Graphs application, click
Geometry > Measurement > Length.)

2. Click two points on the object that form the side you want to measure.

Note: You must click two points to measure a side. Clicking the side measures the
entire length of the object's perimeter.

Measuring Area of a Circle, Ellipse, Polygon, Rectangle, or Triangle

Note: You cannot measure the area of a polygon constructed using the Segment tool.

1. From the Measurement menu, select Area. (In the Graphs application, click
Geometry > Measurement > Area.)

2. Click the object to display its area.



Measuring Slope of a Line, Ray, Segment, or Vector

1. From the Measurement menu, select Slope. (In the Graphs application, click
Geometry > Measurement > Slope.)

2. Click the object to display its slope.

The value is updated automatically when you manipulate the object.

Measuring Angles

Measured angles in the Geometry application range from 0° to 180°. Measured angles
in the Graphs application range from 0 radians to π radians. To change the angle unit,
use the Settings menu.

1. From the Measurement menu, select Angle. (In the Graphs application, click
Geometry > Measurement > Angle.)

2. Click three locations or points to define the angle. The second click defines the
vertex.
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Measuring Angles using the Directed Angle Tool

1. From the Measurement menu, select Directed Angle. (In the Graphs application,
click Geometry > Measurement > Directed Angle.)

2. Click three locations or existing points to define the angle. The second click defines
the vertex.

3. To reverse the measurement orientation,

a) On the Actions menu, select Attributes.

b) Click the angle text. For example, click 300°.

c) Select the orientation attribute, and use the right or left arrow key to change it.

d) Press Esc to close the Attributes tool.



Moving a Measured Value

▶ Drag the measurement to the desired location.

Note: If you move a measurement too far from its object, it stops following the
object. However, its value continues to be updated as you manipulate the object.

Editing a Measured Length

You can set the length of a side of a Triangle, Rectangle, or Polygon by editing its
measured value.

▶ Double-click the measurement, and then enter the new value.

Storing a Measured Value as a Variable

Use this method to create a variable and assign a measured value to it.

1. Display the item's context menu, and select Store.

2. Type a variable name for the stored measurement.

Linking a Measured Length to an Existing Variable

Use this method to assign a measured length value to an existing variable.

1. Display the measurement's context menu, and select Variables > Link to.

The menu shows the list of currently defined variables.

2. Click the name of the variable you want to link to.

Deleting a Measurement

▶ Display the measurement's context menu, and select Delete.
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Locking or Unlocking a Measurement

1. Display the measurement's context menu, and select Attributes.

2. Use the up/down arrow keys to highlight the Lock attribute.

3. Use the left/right arrow keys to close or open the lock.

As long as the value remains locked, manipulations are not allowed that would
require the measurement to change.

Transforming Objects

You can apply transformations to drawn objects in both the Graphs and Geometry
applications. If the object's points are labeled, the corresponding points in the
transformed object are labeled using prime notation (A → A'). To enable automatic
labeling of certain objects, see What You Must Know in this chapter.

Exploring Symmetry

1. From the Transformation menu, select Symmetry. (In the Graphs application, click
Geometry > Transformation > Symmetry.)

2. Click the object whose symmetry you want to explore.

3. Click a location or existing point to establish the point of symmetry.

A symmetrical image of the object is displayed.

4. Manipulate the original object or the point of symmetry to explore the symmetry.

Exploring Reflection

1. Create a line or segment to predefine the line about which the object will be
reflected.

2. From the Transformation menu, select Reflection. (In the Graphs application, click
Geometry > Transformation > Reflection.)

3. Click the object whose reflection you want to explore.



4. Click the predefined reflection line or segment.

A reflected image of the object is displayed.

5. Manipulate the original object or the line of symmetry to explore the reflection.

Exploring Translation

1. (Optional) Create a vector to predefine the distance and direction of translation.

2. From the Transformation menu, select Translation. (In the Graphs application, click
Geometry > Transformation > Translation.)

3. Click the object whose translation you want to explore.

4. Click the predefined vector.
—or—
Click two locations on the work area to indicate the direction and distance of
translation.

A translated image of the object is displayed.

5. Manipulate the original object or the vector to explore the translation.

Exploring Rotation

1. (Optional) Create an angle measurement to serve as a predefined angle of
rotation.
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2. From the Transformation menu, select Rotation. (In the Graphs application, click
Geometry > Transformation > Rotation.)

3. Click the object whose rotation you want to explore.

4. Click a location or point to define the point of rotation.

5. Click the points of the predefined angle.
—or—
Click three locations to define an angle of rotation.

A rotated image of the object is displayed.

6. Manipulate the original object or the point of rotation to explore the rotation.

Exploring Dilation

1. Create a Text object containing a numeric value to serve as a predefined dilation
factor.

Note: You can also use a measured length value as the dilation factor. Keep in
mind that if you use a large value, you may have to pan the display to view the
dilated object.

2. From the Transformation menu, select Dilation. (In the Graphs application, click
Geometry > Transformation > Dilation.)

3. Click the object whose dilation you want to explore.

4. Click a location or existing point to define the center point of dilation.

5. Click the Text object or measurement that defines the dilation factor.

A dilated image of the object is displayed.



6. Manipulate the original object or the center point of dilation to explore the dilation.
You can also edit the dilation factor.

Exploring with Geometric Construction Tools
While a construction is in progress, a tool appears in the work area (for example,
Parallel ). To cancel, press ESC.

Creating a Midpoint

This tool lets you bisect a segment or define a midpoint between any two points. The
points can be on a single object, on separate objects, or on the work area.

1. From the Construction menu, select Midpoint. (In the Graphs application, click
Geometry > Construction > Midpoint.)

2. Click a point or location to define the first point.

3. Click a second point or location to complete the midpoint.
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Creating a Parallel Line

This tool creates a parallel line with respect to any existing line. The existing line can
be a Graphs axis or any side of a triangle, square, rectangle, or polygon.

1. From the Construction menu, select Parallel. (In the Graphs application, click
Geometry > Construction > Parallel.)

2. Click the object that will serve as the reference line.

3. Click a location to create the parallel line.

You can drag the parallel line to move it. If you manipulate the reference object,
the line remains parallel.

Creating a Perpendicular Line

You can create a line that is perpendicular to a reference line. The reference can be an
axis, an existing line, a segment, or one side of a triangle, rectangle, or polygon.

1. From the Construction menu, select Perpendicular. (In the Graphs application, click
Geometry > Construction > Perpendicular.)

2. Click a location or existing point through which the perpendicular line should pass.

3. Click the item that will serve as the reference line.



You can drag the intersection point to move the perpendicular. If you manipulate
the reference object, the line remains perpendicular.

Creating a Perpendicular Bisector

You can create a perpendicular bisector on a segment, on one side of a triangle,
rectangle, or polygon, or between any two points.

1. From the Construction menu, select Perpendicular Bisector. (In the Graphs
application, click Geometry > Construction > Perpendicular Bisector.)

2. Click the item that will serve as the reference line.
—or—
Click two points to create a perpendicular bisector between them.

Bisecting an Angle

This tool creates an angle bisector. The points of the angle can be on existing objects,
or they can be locations on the work area.

1. From the Construction menu, select Angle Bisector. (In the Graphs application, click
Geometry > Construction > Angle Bisector.)

2. Click three locations or points to define the angle. The second click defines the
vertex of the angle.
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The angle bisector adjusts automatically as you manipulate its defining points.

Creating a Locus

The Locus tool enables you to explore the range of motion of one object with respect to
another object as constrained by a shared point.

1. Create a segment, line, or circle.

2. Create a point on the segment, line, or circle.

3. Create another object that uses the point created in the previous step.



Circle created to use the definedpoint on
the segment.

4. From the Construction menu, select Locus. (In the Graphs application, click
Geometry > Construction > Locus.)

5. Click the point shared by the objects.

6. Click the object defined to share the point (this is the object to vary).

The continuous locus is displayed.

Creating a Compass

This tool operates similarly to a geometric compass used for drawing circles on paper.

1. From the Construction menu, select Compass. (In the Graphs application, click
Geometry > Construction > Compass.)

2. To set the width (radius) of the compass:

Click a segment.
—or—
Click any side of a triangle, rectangle, polygon, or regular polygon.
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—or—
Click any two existing points or locations on the work area.

3. Click a location to establish the center of the circle and complete the construction.

The radius adjusts automatically as you manipulate the original segment, side, or
points used to define the radius.

Using Geometry Trace

The Geometry Trace tool leaves a visible trail of a geometric object or function graph
as it is moved or manipulated. The movement can be done manually or by using
animation. This tool is accessible in both the Graphs and Geometry applications.

1. From the Trace menu, select Geometry Trace.

The Geometry Trace tool appears.

2. Click the object or function that you want to trace to select it.

3. Drag the object, or play the animation.

This example shows traces of a graphed function manipulated by dragging and a
triangle manipulated by animation.



Note: You cannot select or manipulate the trace trail.

4. To erase all trails, select Erase Geometry Trace from the Trace menu.

5. To stop tracing, press Esc.

Conditional Attributes

You can cause objects to hide, show, and change color dynamically, based on specified
conditions such as "r1<r2" or "sin(a1)>=cos(a2)."

For example, you might want to hide an object based on a changing measurement that
you have assigned to a variable, or you might want an object’s color to change based
on a "Calculate" result assigned to a variable.

Conditional behaviors can be assigned to objects or groups in the Graphing, Plane
Geometry, and 3D Graphing views.

Setting Conditional Attributes of an Object

You can set conditions of a selected object either by using its context menu or by
activating the Set Conditions tool from the Actions menu and then selecting the object.
These instructions describe using the context menu.

1. Select the object or group.

2. Display the object’s context menu, and click Conditions.

The conditional attributes are displayed.
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For 2Dobjects For 3Dobjects

3. (Optional) In the ShowWhen field, enter an expression specifying the conditions
during which the object will be shown. Anytime the condition is not satisfied, the
object will be hidden.

You can specify tolerance by using compound conditionals in the ShowWhen input
field. For example, area>=4 and area<=6.

Note: If you need to see conditionally hidden objects temporarily, click
Actions > Hide/Show. To return to normal viewing, press ESC.

4. (Optional) Enter numbers or expressions that evaluate to numbers in the applicable
color fields, such as Line Color orMesh Color. To see a map of color values, click
the Colors button.

Mapof conditional color values

5. Click OK in the Conditional Attributes dialog box to apply the conditions.

Hiding Objects in the Geometry Application

The Hide/Show tool reveals objects you have previously selected as hidden and lets you
select which objects to show or hide.

1. From the Actions menu, select Hide/Show.

The Hide/Show tool appears, and currently hidden items (if any) are shown
dimmed.



2. Click objects to toggle their hide/show status.

3. Press Esc to complete your selections and close the tool.

All objects you selected as hidden objects disappear.

4. To view the hidden objects temporarily or restore them as shown objects, open the
Hide/Show tool.

Customizing the Geometry Work Area

Inserting a Background Image

You can insert an image as a background for any Graphs or Geometry page.

1. From the Insert menu, click Image.

2. Navigate to the image you want to insert, select it, and then click Open.

Adding a Text Object to the Work Area

Use the Text tool to add numeric values, formulas, observations, or other explanatory
information to the Geometry work area.

1. From the Actions menu, select Text.

2. Click the location for the text.

3. Type the text in the box that appears, and then press Enter.
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To move a text object, drag it. To edit the text, double-click it. To delete a text object,
display its context menu, and select Delete.

Changing the Attributes of Numeric Text

If you enter a numeric value as text, you can lock it or set its format and displayed
precision.

1. From the Actions menu, select Attributes.

2. Click the numeric text to display its list of attributes.

3. Press 9 and : to move through the list.

4. At each attribute icon, press 7 or 8 to move through the options. For example,
select 0 through 9 as the precision.

5. Press Enter to apply the changes.

6. Press Esc to close the Attributes tool.

Animating Points on Objects

You can animate any point created as a point on an object or graph. Multiple points can
be animated simultaneously.

Animating a Point

1. From the Actions menu, select Attributes.

2. Click the point to display its attributes.

3. Press ▼ to select the animation attributes.

4. Press ◄ or ► to choose either unidirectional or alternating animation.

5. Type a value to set the animation speed. Any nonzero speed begins the animation.
To reverse the direction, enter a negative value.

6. Press Enter to display the animation controls  .

7. Press ESC to close the Attributes tool.



Pausing and Resuming All Animations

▶ To pause all animations on a page, click Pause .

▶ To resume all animations, click Play .

Resetting All Animations

Resetting pauses all animations and returns all animated points to the positions they
occupied when they were first animated.

▶ To reset animation, click Reset .

Changing or Stopping the Animation of a Point

1. Click Reset to stop all animation.

2. From the Actions menu, select Attributes.

3. Click the point to display its attributes.

4. Select the animation attribute, and type a new animation speed. To stop the
point’s animation, enter zero.

Note: If other animated points exist, the animation controls remain in the work
area.

Adjusting Variable Values with a Slider

A slider control lets you interactively adjust or animate the value of a numeric variable.
You can insert sliders in the Graphs, Geometry, Notes, and Data & Statistics
applications.
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Horizontal slider for adjusting variable v1.
Minimized vertical slider for adjusting variable v2.

Note: TI-Nspire™ version 4.2 or higher is required for opening .tns files containing
sliders on Notes pages.

Inserting a Slider Manually

1. From a Graphs, Geometry, or Data & Statistics page, select Actions > Insert Slider.
—or—
From a Notes page, make sure the cursor is not in a math box or chem box, and
then select Insert > Insert Slider.

The Slider Settings screen opens.

2. Enter the desired values, and click OK.

The slider is displayed. On a Graphs, Geometry, or Data & Statistics page, handles
are displayed to let you move or stretch the slider.

To remove the handles and use the slider, click an empty
space in the work area. You can show the handles anytime by
selectingMove from the slider's context menu.

3. To adjust the variable, slide the pointer (or click the arrows on a minimized slider).

- You can use the Tab key to move the focus to a slider or to move from one
slider to the next. The color of the slider changes to show you when it has the
focus.

- When a slider has the focus, you can use the arrow keys to change the value of
the variable.



Working with the Slider

Use the options on the context menu to move or delete the slider, and to start or stop
its animation. You can also change the slider's settings.

1. Display the slider's context menu.

2. Click an option to select it.

Automatic Sliders in Graphs

Sliders can be created for you automatically in the Graphs application and in the
analytic window of the Geometry application. You are offered automatic sliders when
you define certain functions, equations, or sequences that refer to undefined variables.

Using the Calculate Tool

The Calculate tool is available in the Graphs and Geometry applications. It lets you
evaluate a math expression you have entered as a text object.

The following example uses the Calculate tool to sum the measured angles of a
triangle.

1. Using the Shapes menu, create a triangle, and then measure its angles.
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Tip: You can enable options to automatically label points and to force geometric
triangle angles to integers. For more information, see What You Must Know, in this
chapter.

2. From the Actions menu, click Text.

3. Click a location for the text, and type the formula for the calculation.

In this example, the formula sums three terms.

4. From the Actions menu, click Calculate.

5. Click the formula you created.

You are prompted to select a value for each term in the formula.

6. Click each angle measurement when prompted.

Note: If you have stored a measurement as a variable, you can select it when
prompted by clicking . If the name of a stored measurement matches a term in
the formula, you can press “L” when prompted for that term.

After you have selected the third term, the calculation result attaches itself to the
pointer.



7. Position the result, and press Enter to anchor it as a new text object.
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Lists & Spreadsheet Application
The Lists & Spreadsheet application gives you a place to work with tabular data. It lets
you:

• Store numeric data, text, or math expressions.

• Define a table cell in terms of the contents of other cells.

• Define an entire column based on the contents of another column.

• Share columns of data as list variables with other TI-Nspire™ applications. Also
share individual cells as variables.

• Work with variables created in the Graphs & Geometry and Calculator applications.

• Collect tables of real-world data from sensors.

• Generate columns of data-based sequences that you define.

• Plot table data using the Data & Statistics application.

• Generate a table of values for a function.

• Copy and paste table data from the Lists & Spreadsheet application to other
computer applications, such as TI Connect™ software and Excel® spreadsheet
software.

• Perform statistical analysis on lists of data.

Adding a Lists & Spreadsheet Page

▶ To start a new document with a blank Lists & Spreadsheet page:

From the main File menu, click New Document, and then click Lists & Spreadsheet.

Handheld: Pressc, and select Lists & Spreadsheet .

▶ To add a Lists & Spreadsheet page in the current problem of an existing document:

From the toolbar, click Insert > Lists & Spreadsheet.

Handheld: Press~ and select Insert >Lists & Spreadsheet.
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À Lists & Spreadsheet tools (available when a Lists & Spreadsheet work area is
active)

Á Sample Lists & Spreadsheet work area

Â Lists & Spreadsheet entry line

Ã Lists & Spreadsheet data plotted in the Data & Statistics application

Creating and Sharing Spreadsheet Data as Lists

You can define a column as a named list of elements of the same type of data. After
defining a list, you can link to it from the Graphs & Geometry, Calculator, or
Data & Statistics applications, and from other instances of the Lists & Spreadsheet
application within the current problem.

Note: Lists & Spreadsheet can display a maximum of 2500 elements in a list.

Sharing a Spreadsheet Column as a List Variable

You share a column of data by naming it as a list variable.

Note: Avoid defining variables that use the same names as those used for statistical
analysis. In some cases, an error condition could occur.

Variable names used for statistical analysis are listed in the TI-Nspire™ Reference
Guide, under the stat.results entry.

1. Click the cell to move to the column’s name cell (the top cell of the column).

—or—

Press ▲ as necessary.

2. Type a name for the list variable, and press Enter.

The column is now available as a list variable to other TI-Nspire™ applications.

3. Create elements in the list the same as you would create data in spreadsheet cells.
For example, you can type the data into each cell or use a formula to generate a
column of data.

Notes:

• If a variable with the name you specified already exists in the current problem,
Lists & Spreadsheet displays an error message.

• When you select the column formula cell of a list, it displays the list name in an
expression similar to width:=.

• Lists can contain empty elements (denoted by “_”) .



• You can refer to a specific element in a named list from the Calculator application.
Use the list name and the element’s position within the list. In a list named
Heights, for example, refer to the first element as Heights[1]. The expression
Heights[2] refers to the second element, and so on.

Linking to an Existing List Variable

Linking a column to an existing list variable lets you easily view and edit the values in
the list. The list can be any shared list in the current problem and can be defined in
Graphs & Geometry, Calculator, or any instance of Lists & Spreadsheet.

After you link a column to a list, Lists & Spreadsheet automatically shows any changes
that you make to the list with other TI-Nspire™ applications.

1. Click the column formula cell (the second cell from the top) of the column that you
want to link to the variable.

2. Type the name of the list variable you want to link to.

—or—

Click on the toolbar (pressh on the handheld), click Link To, and click the
variable you want to link to.

3. Press Enter.

The column shows the list elements.

Notes:

• You cannot link to the same variable multiple times on the same page.

• Use caution if you link to a system variable. Doing so could prevent the variable
from being updated by the system. System variables include ans and statistics
results (such as stat.results, stat.RegEqn, and stat.Resid).

Inserting an Element in a List

When you insert an element in a list, the remaining elements shift downward to
create space. No other columns are affected.

▶ Click Insert > Insert Cell.
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Deleting an Element from a List

When you delete an element, the remaining list elements shift upward to close the
gap. The upward shift affects only the selected column.

1. Click the cell of the element to delete.

2. Open the context menu for the cell, and click Delete Cell.

Note: If you press Del or Backspace to clear the contents of the cell instead of
deleting the list element, the element is assigned a value of 0 (zero). The
remaining list elements do not shift.

Creating Spreadsheet Data

You can type numeric values, text, or formulas into body cells. Column formula cells
can contain formulas only. (For more information, see Generating Columns of Data.)

Data Examples

Entry Remarks

1.234 Simple numeric entry

“Green” Text - Enclose categorical data (such as the names of colors used in a
study) within quotes to distinguish them from variable names.

Handheld: Press/r to enter quoted data.

=a3*length Formula - Consists of an “=” symbol followed by an expression.
You can type the expression or use the Catalog and expression
templates to build it. For more information, see the Calculator section.
To ensure a decimal result instead of a fraction, type one of the integers
in the expression as a decimal. For example, type 1.0 instead of 1.

Typing a Math Expression, Text, or Spreadsheet Formula

1. Double-click the cell to select it and put it in edit mode.

Note: If the cell is already selected, you can press Enter or click the entry line.

2. Type the expression, text, or formula. Be sure to enclose text entries in quotes and
start formula entries with an “=” symbol.

As you type the data, it appears in the cell and on the entry line simultaneously.

3. Press Enter to complete the entry and move down to the next cell.



—or—

Press Tab to complete the entry and move right to the next cell.

The Lists & Spreadsheet application automatically recalculates any cells that are
dependent on the cell you entered. If you have shared the cell, and other
TI-Nspire™ applications are linked to the cell, the other applications are also
updated.

Note: Empty cells in a spreadsheet display as a void represented by an underscore
(_). The underscore is automatically added to empty cells when a list is named or
when an empty cell is referenced in a formula. When you plan to perform
calculations on a range of cells, be sure to notice the location of void cells. Cells
without a value can affect calculations. For example, if you include a void cell in
the range for a sum such as “=b2+c2,” the result of the calculation is void (_).

Inserting a Cell Range into a Formula

The Select Range feature lets you insert a cell range (such as a1:b3) into a formula by
selecting the range instead of typing cell addresses into an argument.

Suppose you want to calculate the mean of a range of cells.

1. Select the cell that will contain the result.

2. From the Data menu, click List Math > Mean.

An editable formula appears in the cell.

3. Click Actions > Select > Select Formula Range.

4. Drag a selection rectangle around the range of values for which you want to
calculate the mean.

Handheld: Move to the first cell in the range, holdg, and press the arrow keys.
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The formula is updated as you select the cells.

5. Press Enter to complete the formula and display the result.

Navigating in a Spreadsheet

A spreadsheet includes a column letter at the top of each column and a row number on
the left of each row. The top two rows and the row numbers remain in place as you
scroll. You can name a column of data to make it available as a list variable in
TI-Nspire™ applications.

À Column reference letter

Á Column name cell for defining a column as a list variable

Â Column formula cell for generating a column of data

Ã Row reference number

Ä Body Cells - Any empty (void) element in a list is displayed as an underscore (“_”).



Any value that cannot fit in a cell’s width is truncated (143489...). Hover over the
cell to display the complete value.

Å Entry line (includes cell reference for current cell)

You can select any cell to view or edit its contents. When a spreadsheet is larger than
the Lists & Spreadsheet work area, you can move to different parts of the spreadsheet
by using the Tab key and by pressing shortcut keys.

▶ Press Tab to move between the body of the spreadsheet (data zone) and the
column names and formulas (naming zone).

▶ Press ◄,►,▲, and▼ to move through the spreadsheet one cell at a time (move
between cells within a zone). The arrow keys move the cursor from cell to cell and
scroll as necessary to keep the selected cell in view.

▶ Move across several cells at a time by pressing Page up, Page Dn, Home, and End.

Handheld: Press/9(Page up),/3 (Page Dn),/7 (Home), and
/1 (End) keys.

▶ Use the Go To command on the Actions menu to select a specific cell. Type the
cell’s column letter and row number (such as G16).

▶ Press Enter to put the selected cell in Edit mode.

▶ Drag the scroll bar to move vertically without changing the cell or block of cells
selected.

Working with Cells

Working with Color

The Lists & Spreadsheet application displays black text and cells with a white
background by default. You can change the color of cells and text to emphasize or
distinguish data. The colors and the order in which color is assigned is based on the
TI-Nspire™ color palette.

Changing the Fill Color of Cells

1. Select the cells to fill with color. You can choose one or more cells in any adjacent
cells, columns, or rows.

2. Access the context menu and click Color > Fill Color.

3. Click the color to apply to the cells.

Note: If you combine color text and color cells, choose colors carefully to ensure
visibility as you work with documents in the software and on the handheld.

Lists & Spreadsheet Application 303



304 Lists & Spreadsheet Application

Changing the Color of Text

1. Select the cells that contain the text to change. You can choose one or more cells in
any adjacent cells, columns, or rows.

2. Access the context menu and click Color > Text Color.

3. Click the color to apply to the text. Empty cells in the selection area show the color
change when text is added.

Understanding Cell References in Formulas

Use a cell reference to use data from a cell or range of cells in a formula. The
calculation results update automatically when values in cells change.

Relative references include only the cell’s column letter and row number (for example,
E7). A relative reference describes where a cell is in relation to other cells of the
spreadsheet. The Lists & Spreadsheet application keeps track of relative cell references
and adjusts the reference automatically when surrounding cells shift (because of
actions you perform, such as column deletions or cell insertions).

Follow these guidelines to specify cell references:

• Include a column letter and row number in a relative reference.

• Include the $ symbol before both the column letter and the row number to specify
an absolute reference.

• Include a colon (:) between a two cell reference to specify a range of cells.

Absolute references include the $ symbol before the column letter and before the row
number (for example, $B$16). Absolute references always refer to the cell in a specific
position in the spreadsheet. The application does not automatically adjust the cell
reference when cell positions change.

Typing a Cell Reference in a Formula

1. Double-click the cell and type the formula. For more information, see the
Calculator section.

2. Move to the appropriate position in the formula and type the cell reference. Use
the format for a relative reference (B3), absolute reference ($B$2), or range of
cells (A1:A4).

Note: You can click Recalculate on the Actions menu to update all references and
formula results in a spreadsheet.



Deleting the Contents of Cells

1. Click a cell to select it.

—or—

Use the arrow keys to move to the cell.

Note: If you are deleting a range of cells, select a cell at one end or corner of the
range, and then use Shift with the arrow keys to select the remaining cells in the
range.

2. Press Del.

Note: Any cell that uses a formula with an absolute reference to deleted data
shows an error. A cell that uses a formula with a relative reference to deleted data
is updated to use the data currently in the referenced position.

Copying Cells

When you copy cells, any formulas in the original cells are copied to the destination
cells.

1. Click the cell to copy.

—or—

Use the arrow keys to move to the cell.

Note: If you are copying a range of cells, select a cell at one end or corner of the
range, and then use Shift with the arrow keys to select the remaining cells in the
range.

2. Use the standard key shortcut for copying a selection.

Windows®: Press Ctrl+C.

Mac®: Press “+C.

Handheld: Press/C.

3. Click the cell where you want to duplicate the copied cell. If you are copying a block
of data, click the cell that will become the upper left corner of the copied block.

4. Paste the selected cells:

Windows®: Press Ctrl+V.

Mac®: Press “+V.
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Handheld: Press/V.

Important: Paste copied data into a cell that is in the same mode as the cell from
which the data was originally copied. Otherwise, a formula could paste as a string
enclosed in quotes instead of a formula.

Filling Adjacent Cells

You can repeat a cell’s formula or value throughout adjacent cells within the row or
column. You can also repeat a range of cells horizontally or vertically. If you fill from a
range that contains a simple sequence (such as 2, 4, 6), the sequence continues in the
filled cells.

1. Click the cell that contains the value or formula to repeat.

Note: If you are repeating a range of cells, drag to select the range, or select a cell
at one end of the range, and then use Shift with the arrow keys to select the
remaining cells.

2. Click Data > Fill.

3. Use the arrow keys, or drag to select the range that will hold the repetitions.

4. Press Enter.

The value, formula, or pattern that you selected for duplication is repeated over the
selected range.

Sharing a Cell Value as a Variable

You can share the value of a cell with other TI-Nspire™ applications by storing it as a
variable. When you define or refer to a shared cell or variable in Lists & Spreadsheet,
the name is preceded with an apostrophe (‘).

1. Click the cell that you want to share.

2. Click on the toolbar, and click Store Var to store the cell’s value.

Handheld: Press/h or pressh and select Store Var).

A formula is inserted into the cell with var as a placeholder for a variable name.

3. Type over the letters “var” with a name for the variable, and press Enter. Use a
variable name that does not exist in the current problem.

The value is shown in bold to indicate that it is now available as a variable to other
TI-Nspire™ applications.



Linking a Cell to a Variable

When you link a cell to a variable, Lists & Spreadsheet keeps the cell value updated to
reflect the current value of the variable. The variable can be any variable in the current
problem and can be defined in Graphs & Geometry, Calculator, Data & Statistics, or
any instance of Lists & Spreadsheet.

1. Click the cell that you want to link to a variable.

2. Click on the toolbar, and click Link to.

Handheld: Press/h or pressh and select Link to.

The VarLink menu opens.

3. Under Link To, press ▲, and▼ to scroll to the name of the variable.

4. Press Enter.

The cell shows the value of the variable.

Note: Use caution if you link to a system variable. Linking could prevent the variable
from being updated by the system. System variables include statistics results (such as
Stat.RegEqn, Stat.dfError, and Stat.Resid) and finance-solver variables (such as
tvm.n, tvm.pmt, and tvm.fv).

Working with Rows and Columns of Data

Selecting a row or column

▶ To select a column, move to the top of the column and click the column reference
letter. To select a row, move to the leftmost cell of the row and click the row
reference number. Press Esc to cancel the selection.

Handheld: Hold down▲ to move past the top cell, or hold down◄ to move past
the leftmost cell.

▶ To extend a selection to adjacent rows or columns, hold down Shift and press ◄,
►,▲, or▼.

Resizing a Row or Column

1. Click the row or column that you want to resize.

2. From the Actions menu, select Resize, and then select an option.

3. Choose a resizing option for a column or row.
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- For a column, choose Resize Column Width, Maximize Column Width, or
Minimize Column Width.

- For a row, you can choose Resize Row Height.

The tools that minimize and maximize the column width work automatically. You
must manually adjust the size to use the Resize Column Width and Resize Row
Height tools.

4. To resize manually, use◄ and► to resize the column, or use▲ and▼ to resize
the row, and then press Enter.

Inserting an Empty Row or Column

1. Click a column or row where you want to insert the new data.

2. From the Insert menu, select either Row or Column.

- If you are inserting a row, the remaining rows shift down to create space for
the new row.

- If you are inserting a column, the remaining columns shift right to create
space.

Note: If other cells contain formulas with relative references to a displaced row or
column, those references adjust accordingly.

Deleting Entire Rows or Columns

You can delete a row, column, group of rows, or group of columns. When you delete a
row or column, the remaining rows or columns move up or left to fill the gap.

1. Click the column or row that you want to delete.

2. (Optional) To select adjacent rows or columns to delete, hold down Shift and press
◄,►,▲, or▼.

3. Display the context menu.

- Windows®: Right-click the selected row.

- Mac®: Hold the “ key, and click the selected row.

- Handheld: Press/b.

4. On the context menu, select Delete Row.

The selected rows or columns are deleted.



Note: If other cells contain formulas that refer to the deleted row or column, those
cells show an error. Relative references to cells whose positions have changed
because of a deletion adjust accordingly.

Copying Rows or Columns

1. Click the row number to copy a row, or click the column letter to copy a column.

2. (Optional) To select adjacent rows or columns to copy, hold down Shift and press
◄,►,▲, or▼.

3. Copy the row or column:

Windows®: Press Ctrl+C.

Mac®: Press “+C.

Handheld: Press/C.

4. Move to any cell in the row or column where you want to place the copied items.

5. Paste the row or column:

Windows®: Press Ctrl+V.

Mac®: Press “+V.

Handheld: Press/V.

The copied row or column is pasted in place, replacing the previous contents.

Note: If you copy a named column, it is pasted with the name removed to prevent
a variable conflict.

Moving a Column

1. Click the column that you want to move.

2. From the Actions menu, select Move Column.

An insertion bar appears.

3. Press ◄ and► to place the insertion bar at the column’s new position, and then
press Enter.

Note: Relative references to any cell in a position is affected by the move adjust
accordingly.
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Displaying Results as Exact or Approximate

You can choose to display a column’s calculated results in Exact (fraction) or
Approximate (decimal) form. This affects only the values calculated from a formula.

1. Select the column by clicking the reference letter at the top of the column.

Handheld: Hold down▲ to move past the top cell.

2. Display the context menu for the column.

3. On the context menu, click either Data > Exact or Data > Approximate.

Note: To restore the column results to the document’s default setting, select the
column and click Data > Restore Document Setting.

Clearing Column Data

The Clear Data command lets you remove the data from selected columns. Clear Data
does not delete the column, and it does not clear a column’s name or formula.

After clearing the data, Lists & Spreadsheet recalculates column formulas for the
selected columns. This makes Clear Data useful for capturing a fresh set of data from
another application or selectively generating a fresh column of random numbers.

1. Click the column or columns that you want to clear.

2. From the Data menu, select Clear Data.

Note: If a recalculated formula produces the same data as before, it may appear
that the Clear Data command has failed.

Sorting Data

You can sort a selected area of the spreadsheet in ascending or descending order. You
select which column in the selected area will be used as the key for the sort. When the
sort moves data up or down in the key column, the corresponding data in the other
selected columns is also moved up or down. This preserves the integrity of each row.

Note: Sorting is based on numeric values. If you select a key column that contains text,
you could get unexpected results.

1. Select the range of cells.



2. From the Actions menu, select Sort.

The Sort dialog box opens.

3. Click the column letter to use for ordering.

4. Click Descending or Ascending as the sort method, and then click OK.

Note: Sorting a column that is defined by a formula will remove the formula, because
it may not be valid after the sort.

Generating Columns of Data

You can create a column of values based on the contents of another column. You can
also create a column based on any of several types of sequential data.

Entering a formula in a column’s formula cell tells the Lists & Spreadsheet application
that you want to apply the formula to all cells in the column, not just to a single cell.
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À Column formula based on a variable

Á Column formula based on another column (column A)

Â Column formula that generates a sequence

Notes:

• If you generate data in a column that already contains one or more cell values,
Lists & Spreadsheet asks for confirmation before replacing the existing values.
Proceeding removes all of the existing values in the column.

• If you edit a cell manually in a column of generated data, Lists & Spreadsheet asks
for confirmation before replacing the generated data. Proceeding removes the
generated data for the entire column.

Creating Column Values Based on Another Column

1. Click the column formula cell (the second cell from the top) of the column where
you want to use a formula.

Lists & Spreadsheet inserts the leading equal sign (=) for the formula. If the
column is a named list, Lists & Spreadsheet inserts listname:= followed by the
cursor.

2. Type the expression for the formula after the = and press Enter Use brackets ([])
after any column letter you include in the formula. For example, type =a[]^2 to
create a column of values in which each cell is the square of the corresponding cell
of column A.

Lists & Spreadsheet shows the formula in the formula cell and fills the column
with the results.



Generating a Column of Random Numbers

This example generates a column of 20 random integers in the range 1 through 6.

1. Click the column formula cell (the second cell from the top) of the column.

Lists & Spreadsheet inserts the leading equal sign (=) for the formula. If the
column is a named list, Lists & Spreadsheet inserts listname:= followed by the
cursor.

2. After the equal sign, type RandInt(1,6,20).

Note: You can also use the Catalog or click Data > Random > Integer to insert the
RandInt() function.

3. Press Enter to generate the numbers.

4. Generate (Recalculate) a new set of random numbers:

Windows®: Press Ctrl+R.

Mac®: Press “+R.

Handheld: Press/R.
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Generating a Numerical Sequence

1. Click any cell in the column in which you want to generate the sequence.

2. From the Data menu, select Generate Sequence.

The Sequence dialog box opens.

3. Type the Formula that will be applied to the column values.

4. Type any Initial Terms required by the sequence. Separate them with commas.

5. Type a starting value for the independent variable (n0).

6. Type a maximum number of values to be generated (nMax).

7. Type the step value (nStep).

8. (Optional) Type a maximum value for the sequence in the Ceiling Value field.

9. Click OK.

Lists & Spreadsheet shows the formula in the formula cell and fills the column
with the results.



Graphing Spreadsheet Data

You can graph the data in a spreadsheet using Quick Graph or Summary Plot.
Lists & Spreadsheet cells that contain no data are not represented by data points on
graphs.

Using Quick Graph

You can easily create a dot plot of the data in one column or a scatter plot of two
adjacent columns by using the Quick Graph feature. This feature displays the graphed
data using the Data & Statistics application.

To create a scatter plot:

1. Name both of the columns to declare them as lists.

2. Select both columns.

3. From the Data menu, select Quick Graph.

A Data & Statistics application is added to the page with the plotted data. The
leftmost of the two lists is plotted on the x axis, and the other list is plotted on the
y axis.
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4. (Optional) Use the Data & Statistics features to analyze or visually enhance the
graph.

Note: For more information, see Using Data and Statistics.

Creating a Summary Plot from a Summary Table

In this example, you create a summary table from raw data, and then use the table to
generate a summary plot. For more information, see Using Data & Statistics.

rawdata summary table for eye color basedon rawdata



A summary table contains an X (or Y) List and a Summary List.

• The X (or Y) List contains numeric or string values (such as 1999 or “color”).
Numeric values result in a histogram. String values identify the categories for a bar
chart.

• The Summary List contains numeric values (such as count, frequency, or
probability) for each element in the other list.

To Create a Summary Plot:

Note: For situations in which you already have a summary table, you can skip the first
two steps.

1. Create a list that holds the category identifiers. For this example, name the list
“color” and type strings for eye color. Enclose category names in quotes to prevent
them from being interpreted as variables.

2. Create the summary list. For this example, name the list “counts” and type the
total count for each of the eye colors.

3. Select either list by clicking the top cell of the column and pressing ▲.

4. From the Data menu, select Summary Plot.

The Summary Plot dialog box opens.
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5. If necessary, use Tab and the arrow keys to select the correct lists for X List and
Summary List.

6. In the Display On field, select how to display the summary plot in the
Data & Statistics application.

• Select Split Page to place the chart on half of the current page.

• Select New Page to add the chart on a new page.

The summary plot is displayed with the list names along the axes and a summary
plot symbol in the lower left corner of the chart window.

Note: In this example, the X List contains string data, so the summary plot displays
as a bar chart. The category strings from the list display beneath the bars.

Exchanging Data with Other Computer Software

You can use the TI-Nspire™ desktop software to copy table data to and from software
outside the TI-Nspire™ applications, such as TI DataEditor (in the TI Connect™
software) and Excel® spreadsheet software.

For example, you can copy:

• The values of individual cells, a range of cells, or an entire list from TI DataEditor.

• The values (not the underlying formulas) of individual cells, a range of cells, or an
entire column from an Excel® spreadsheet.

• A number from TI DataEditor.

• The value of a matrix from TI DataEditor.

Example - Copying Data from TI DataEditor

1. Open the TI Connect™ software.

2. Display the TI DataEditor.

3. If necessary, open the file containing the number, list, or matrix that you want to
copy.



4. Drag to select the values that you want to copy. To copy an entire list, click the top
cell in the list.

5. Click Edit > Copy.

6. In Lists & Spreadsheet, click the cell where you want the data to be pasted.

If you have copied a range of cells, they will be pasted so that the upper-left corner
of the range is positioned at the selected cell. Any data in those cells will be
overwritten.

7. Click Edit > Paste.

Copying Cells from an Excel® Spreadsheet

You can copy up to 26 columns and 2500 rows from an Excel® spreadsheet to a
Lists & Spreadsheet application.
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1. Drag to select the values that you want to copy from the Excel® spreadsheet. To
copy an entire column, click the column identifier at the top of the column.

Note: If you select non-contiguous columns in the Excel® spreadsheet, they will be
pasted as contiguous columns in Lists & Spreadsheet.

2. Use the standard key shortcut for copying a selection.

Windows®: Press Ctrl+C.

Mac®: Press “+C.

3. In Lists & Spreadsheet, click the cells where you want the data to be pasted.

If you are copying a range of cells, they will be pasted so that the upper-left corner
of the range is positioned at the selected cell. Any data in those cells in will be
overwritten.

4. Paste the data.

Windows®: Press Ctrl+V.

Mac®: Press “+V.

Handheld: Press/V.

Note: Categorical data must be enclosed in quotes (“ “) after the data is pasted.

Capturing Data from Graphs & Geometry

You can use Lists & Spreadsheet application to capture information about objects in
the Graphs & Geometry application. For example, you could track changes in the area
of a triangle as you change the length of a side in the Graphs & Geometry application.

Captured values replace values in the column. If you prefer, you can remove all data
from a column before starting a new capture by clicking Clear Data on the Data menu.

Capturing Data Manually

1. Make sure the data value that you want to capture is linked to a variable name.

2. Click the column formula cell (the second cell from the top) of the column in which
you want to capture the values.

Note: Captured values replace values in the column.

3. Click Data > Data Capture >Manual.



A capture expression is inserted into the column formula cell with var as a
placeholder for the name of the variable you are capturing.

4. Replace the letters “var” with the name of the variable to capture from
Graphs & Geometry. For example, type area.

The formula cell now contains an expression similar to =capture(area,0).

Note: The argument “0” tells Lists & Spreadsheet that you want to trigger each
capture manually.

5. Press Enter.

6. From the Graphs & Geometry application, change the object with a measured
value stored as the variable (area, in this example) referenced in the data capture
expression.

7. Each time you are ready to capture the current value of area, press the capture
keys.

Windows®: Press Ctrl+. (the period key).

Mac®: Hold down “ and press . (the period key).

Handheld: Press/^.

The current area value is added to the end of the list as a list element.

Capturing Data Automatically

When you capture data automatically, you can specify that you want the captures to be
triggered by:
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• Changes in the captured variable only.

• Changes in the captured variable or additional variables.

This lets you set up multiple columns of synchronized captures, such as the x and y
coordinates of a moving object.

1. Clear all columns that you will be using for the captured data.

2. Make sure any data values that you want to capture are linked to variable names.

3. Click the column formula cell (the second cell from the top) of the column in which
you want to capture the values.

4. Click Data >Data Capture >Automatic.

A capture expression is inserted into the column formula cell with var as a
placeholder for the name of the variable you are capturing.

5. Replace the letters “var” with the name of the variable to capture. For example,
type objpathX. Alternatively, you can select the variable name from the
Variables menu.

The formula cell now contains an expression similar to =capture
(objpathX,1).

Note: The argument “1” tells Lists & Spreadsheet that you want the captures to be
triggered by the variable change.

6. If you want the capture to also be triggered by changes in an additional variable or
variables, type a comma after the 1, and then type the variable name or the name
of a list that itemizes the variables.



The formula cell will contain an expression similar to =capture
(objpathX,1,objpathY).

7. Press Enter to complete the formula.

8. If you are capturing multiple columns of synchronized data, set up the additional
columns. For example, you might set up a second capture variable using
=capture(objpathY,1,objpathX).

9. When you are ready to capture the values, begin moving the object or start the
animation that affects it in Graphs & Geometry.

Each captured value is added to the end of the list.

Using Table Data for Statistical Analysis

Tools on the Statistics menu provide access to wizards that help you perform statistical
analyses on the data in table columns. You specify the location of the data, and
Lists & Spreadsheet stores the results in two columns: one for the result names, and
one for the corresponding values.

Plotting Statistical Data

Some statistics wizards include a Draw check box. By default, the box is not selected.
Selecting this box creates a Data & Statistics work area on the page, displays the
calculated results in Lists & Spreadsheet, and draws the results of the statistical
analysis in the Data & Statistics work area.

Note: For functions that support the Draw option, the option is available only if you
type the function in a column formula cell.

Draw check box (as shown in the z Test wizard).

Statistics Input Descriptions

The following table describes the different inputs used in Lists & Spreadsheet wizards.
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Input Description

m
0 Hypothesized value of the population mean that you are testing.

s The known population standard deviation; must be a real
number > 0.

List The name of the list containing the data you are testing.

Frequency List The name of the list containing the frequency values for the
data in List. Default=1. All elements must be integers | 0. The
frequency values can also be typed as a list, in the format {1, 1,
3, 2}.

v, Sx, n Summary statistics (mean, standard deviation, and sample size)
for the one-sample tests and intervals.

s1 The known population standard deviation from the first
population for the two-sample tests and intervals. Must be a
real number > 0.

s2 The known population standard deviation from the second
population for the two-sample tests and intervals. Must be a
real number > 0.

List 1, List 2 The names of the lists containing the data you are testing for
the two-sample tests and intervals.

Frequency 1,
Frequency 2

The names of the lists containing the frequencies for the data in
List 1 and List 2 for the two-sample tests and intervals.
Defaults=1. All elements must be integers | 0.

v1, Sx1, n1,
v2, Sx2, n2

Summary statistics (mean, standard deviation, and sample size)
for sample one and sample two in two-sample tests and
intervals.

Pooled Specifies whether variances are to be pooled for
2-Sample t Test and 2-Sample t Interval.

p
0

The expected sample proportion for 1-Prop z Test. Must be a
real number, such that 0 < p

0
 < 1.

x The count of successes in the sample for the 1-Prop z Test and
1-Prop z Interval. Must be an integer | 0.

n The count of observations in the sample for the 1-Prop z Test
and 1-Prop z Interval. Must be an integer > 0.



Input Description

x1 The count of successes from sample one for the 2-Prop z Test
and 2-Prop z Interval. Must be an integer | 0.

x2 The count of successes from sample two for the 2-Prop z Test
and 2-Prop z Interval. Must be an integer | 0.

n1 The count of observations in sample one for the 2-Prop z Test
and 2-Prop z Interval. Must be an integer > 0.

n2 The count of observations in sample two for the 2-Prop z Test
and 2-Prop z Interval. Must be an integer > 0.

C-Level The confidence level for the interval instructions. Must be | 0
and < 100. If it is | 1, it is assumed to be given as a percent and
is divided by 100. Default=0.95.

RegEQ The prompt for the name of the function where the calculated
regression equation is to be stored.

Statistical Calculations

Performing a Statistical Calculation

You can perform statistical calculations to analyze data. The following example fits a
y=mx+b linear regression model to the two lists in columns A and B.

1. From the Statistics menu, select Stat Calculation > LinearRegression (mx+b) to
choose the regression model.

The Linear Regression (mx+b) dialog box opens.

2. Type a[] as the column for the X List.

3. Type b[] as the column for the Y List.

4. To store the regression equation in a specified variable, replace Save RegEqn To
with the name of the variable.

5. Type c[] as the column for the 1st Result.
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6. Click OK.

Lists & Spreadsheet inserts two columns: one containing the names of the results,
and one containing the corresponding values.

Note: The results are linked to the source data. For example, if you change a value
in column A, the regression equation is updated automatically.

Storing Statistical Results

Lists & Spreadsheet stores statistical results using a variable-group name with the
format stat.nnn, where nnn is the result name (for example, stat.RegEqn and
stat.Resid). The use of standard names for variables makes it easier to identify and use
the statistical variables later. If you want to use a custom variable group instead of the
standard name, you can edit the formula in the column formula cell.

You could use the following formula to store the results in the variable groupMystatsB.



=LinRegMx(a[],b[],1 ): CopyVar Stat., MystatsB.

Later, you could view the results by entering the following expression in the Calculator
application or in another column of the Lists & Spreadsheet application:

MystatsB.results

Supported Statistical Calculations

The Stat Calculations menu lets you select from the calculations described below. For
more information, see the TI-Nspire™ Reference Guide.

One-Variable Statistics (OneVar)

Analyzes data with one measured variable. You can specify an optional frequency list.
The statistical data returned using this analysis technique are:

• Sample mean, x

• Sum of the data, Gx

• Sum of the squared data, Gx2

• Sample standard deviation, sx

• Population standard deviation, sx

• Sample size, n

• X-min

• First quartile, Q
1

• Median

• Third quartile, Q
3

• X-max

• Sum of squared deviations, SSx = G(x Nx)2

Two-Variable Statistics (TwoVar)

Analyzes paired data. List 1 is the independent variable. List 2 is the dependent
variable. You can specify an optional frequency list. The statistical data returned using
this analysis technique are:

For each list:

• Sample mean, x or y

• Sum of the data, Gx or Gy
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• Sum of the squared data, Gx2 or Gy2

• Sample standard deviation, sx = s
n-1

x or sy = s
n-1

y

• Population standard deviation, sx = s
n
x or sy = s

n
y

• X-min or Y-min

• First quartile, Q
1
X or Q

1
Y

• Median

• Third quartile, Q
3
X or Q

3
Y

• X-max or Y-max

• Sum of squared deviations, SSx = G(x Nx)2 or SSy = G(y Ny)2

Additional data:

• Sample size for each data set, n

• Gxy

• Correlation coefficient, R.

Linear Regression (mx+b) (LinRegMx)

Fits the model equation y=ax+b to the data using a least-squares fit. It displays values
for m (slope) and b (y-intercept).

Linear Regression (a+bx) (LinRegBx)

Fits the model equation y=a+bx to the data using a least-squares fit. It displays values
for a (y-intercept), b (slope), r2, and r.

Median-Median Line (MedMed)

Fits the model equation y=mx+b to the data using the median-median line (resistant
line) technique, calculating the summary points x1, y1, x2, y2, x3, and y3.
Median-Median Line displays values for m (slope) and b (y-intercept).

Quadratic Regression (QuadReg)

Fits the second-degree polynomial y=ax2+bx+c to the data. It displays values for a, b, c,
and R2. For three data points, the equation is a polynomial fit; for four or more, it is a
polynomial regression. At least three data points are required.



Cubic Regression (CubicReg)

Fits the third-degree polynomial y=ax3+bx2+cx+d to the data. It displays values for a, b,
c, d, and R2. For four points, the equation is a polynomial fit; for five or more, it is a
polynomial regression. At least four points are required.

Quartic Regression (QuartReg)

Fits the fourth-degree polynomial y=ax4+bx3+cx2+dx+e to the data. It displays values
for a, b, c, d, e, and R2. For five points, the equation is a polynomial fit; for six or more,
it is a polynomial regression. At least five points are required.

Power Regression (PowerReg)

Fits the model equation y=axb to the data using a least-squares fit on transformed
values ln(x) and ln(y). It displays values for a, b, r2, and r.

Exponential Regression (ExpReg)

Fits the model equation y=abx to the data using a least-squares fit on transformed
values x and ln(y). It displays values for a, b, r2, and r.

Logarithmic Regression (LogReg)

Fits the model equation y=a+b ln(x) to the data using a least-squares fit on
transformed values ln(x) and y. It displays values for a, b, r2, and r.

Sinusoidal Regression (SinReg)

Fits the model equation y=a sin(bx+c)+d to the data using an iterative least-squares fit.
It displays values for a, b, c, and d. At least four data points are required. At least two
data points per cycle are required to avoid aliased frequency estimates.

Note: The output of SinReg is always in radians, regardless of the Radian/Degree mode
setting.

Logistic Regression (d=0) (Logistic)

Fits the model equation y=c/(1+a*e⁻bx) to the data using an iterative least-squares fit.
It displays values for a, b, and c.

Logistic Regression (dƒ0) (LogisticD)

Fits the model equation y=c(1+a*e(⁻bx))+d to the data using an iterative least-squares
fit. It displays values for a, b, c and d.

Multiple Linear Regression (MultReg)

Calculates multiple linear regression of list Y on lists X1, X2, …, X10.
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Distributions

Calculating a Distribution

Example: Calculate a distribution to fit the Normal Pdf distribution model.

1. Click the column formula cell (second cell from the top) in column A.

2. Click Statistics > Distributions > Normal Pdf to choose the Distribution model.

The Normal Pdf dialog box opens and displays fields for typing or selecting the
arguments for the calculation.

3. Press Tab as necessary to move from field to field and provide each argument. You
can type values, or select them from the drop down list:

- X Value: Click the drop-down arrow to choose any list in the problem to provide
the x values for the calculation.

- Mean: Type a value for the mean or click the drop-down arrow to choose a
variable that contains the mean.

- Standard Deviation: Type a value for the standard deviation or choose a variable
that contains the standard deviation.

4. Click the Draw check box to see the distribution plotted in Data & Statistics.

Note: The Draw option is not available for all distributions.

5. Click OK.

Lists & Spreadsheet inserts two columns: one containing the names of the results,
and one containing the corresponding values. The results are plotted in
Data & Statistics.



Note: The results are linked to the source data. For example, you can change a
value in Column A, and the equation updates automatically.

Supported Distribution Functions

The following distributions are available from the Lists & Spreadsheet application. For
more information regarding these functions, see the TI-Nspire™ Reference Guide.

• To return a single distribution result based on a single value, type the function in a
single cell.

• To return a list of distribution results based on a list of values, type the function in
a column formula cell. In this case, you specify a list (column) that contains the
values. For each value in the list, the distribution returns a corresponding result.

Note: For distribution functions that support the draw option (normPDF, t PDF,
χ² Pdf, and F Pdf), the option is available only if you type the distribution function
in a formula cell.

Normal Pdf (normPdf)

Computes the probability density function (pdf) for the normal distribution at a
specified x value. The defaults are mean μ=0 and standard deviation σ=1. The
probability density function (pdf) is:

This distribution is used to determine the probability of the occurrence of a certain
value in a normal distribution. The draw option is available when Normal PDF is
invoked from a formula cell.

When you access distributions from the formula cell, you must select a valid list from
the drop-down list to avoid unexpected results. If accessed from a cell, you must
specify a number for the x-value. The distribution returns the probability that the value
you specify will occur.

Normal Cdf (normCdf)

Computes the normal distribution probability between Lower Bound and
Upper Bound for the specified mean, μ (default=0) and the standard deviation, s

(default=1). You can click the Draw (Shade area) check box to shade the area between
the lower and upper bounds. Changes to the initial Lower Bound andUpper Bound
automatically update the distribution.
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This distribution is useful in determining the probability of an occurrence of any value
between the lower and upper bounds in the normal distribution. It is equivalent to
finding the area under the specified normal curve between the bounds.

Inverse Normal (invNorm)

Computes the inverse cumulative normal distribution function for a given area under
the normal distribution curve specified by mean, μ, and standard deviation, s.

This distribution is useful in determining the x-value of data in the area from 0 to x<1
when the percentile is known.

t Pdf (tPdf)

Computes the probability density function (pdf) for the t-distribution at a specified x
value. df (degrees of freedom) must be > 0. The probability density function (pdf) is:

This distribution is useful in determining the probability of the occurrence of a value
when the population standard deviation is not known and the sample size is small. The
draw option is available when t Pdf is invoked from a formula cell.

t Cdf (tCdf)

Computes the Student-t distribution probability between Lower Bound and
Upper Bound for the specified df (degrees of freedom). You can click the Draw (Shade
area) check box to shade the area between the bounds. Changes to the initial
Lower Bound andUpper Bound automatically update the distribution.

This distribution is useful in determining the probability of the occurrence of a value
within an interval defined by the lower and upper bound for a normally distributed
population when the population standard deviation is not known.

Inverse t (invt)

Computes the inverse cumulative t-distribution probability function specified by
Degrees of Freedom, df, for a given area under the curve.

This distribution is useful in determining the probability of an occurrence of data in the
area from 0 to x<1. This function is used when the population mean and/or population
standard deviation is not known.



c2 Pdf (c2 Pdf())

Computes the probability density function (pdf) for the c2 (chi-square) distribution at a
specified x value. df (degrees of freedom) must be an integer > 0. The probability
density function (pdf) is:

This distribution is useful in determining the probability of the occurrence of a given
value from a population with a c2 distribution. The draw option is available when c2

Pdf is invoked from a formula cell.

c2 Cdf (c2 Cdf())

Computes the c2 (chi-square) distribution probability between lowBound and upBound
for the specified df (degrees of freedom). You can click the Draw Shade area check box
to shade the area between the lower and upper bounds. Changes to the initial
lowBound and upBound automatically update the distribution.

This distribution is useful in determining the probability of the occurrence of value
within given boundaries of a population with a c2 distribution.

F Pdf (F Pdf())

Computes the probability density function (pdf) for the F distribution at a specified x
value. numerator df (degrees of freedom) and denominator df must be integers > 0.
The probability density function (pdf) is:

where n = numerator degrees of freedom
d = denominator degrees of freedom

This distribution is useful in determining the probability that two samples have the
same variance. The draw option is available when F Pdf is invoked from a formula
cell.

F Cdf (F Cdf())

Computes the F distribution probability between lowBound and upBound for the
specified dfnumer (degrees of freedom) and dfDenom. You can click the Draw (Shade
area) check box to shade the area between the lower and upper bounds. Changes to
the initial lowBound and upBound automatically update the distribution.
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This distribution is useful in determining the probability that a single observation falls
within the range between the lower bound and upper bound.

Binomial Pdf (binomPdf())

Computes a probability at x for the discrete binomial distribution with the specified
numtrials and probability of success (p) on each trial. The x parameter can be an
integer or a list of integers. 0{p{1 must be true. numtrials must be an integer > 0. If
you do not specify x, a list of probabilities from 0 to numtrials is returned. The
probability density function (pdf) is:

where n = numtrials

This distribution is useful in determining the probability of success in a success/failure
trial, at trial n. For example, you could use this distribution to predict the probability of
getting heads in a coin toss on the fifth toss.

Binomial Cdf (binomCdf())

Computes a cumulative probability for the discrete binomial distribution with n number
of trials and probability p of success on each trial.

This distribution is useful in determining the probability of a success on one trial before
all trials are completed. For example, if heads is a successful coin toss and you plan to
toss the coin 10 times, this distribution would predict the chance of obtaining heads at
least once in the 10 tosses.

Inverse Binomial (invBinom())

• Given the number of trials (NumTrials) and the probability of success of each trial
(Prob), this function returns the minimum number of successes, k, such that the
cumulative probability of k successes is greater than or equal to the given
cumulative probability (CumulativeProb).

Inverse Binomial with respect to N (invBinomN())

Given the probability of success of each trial (Prob), and the number of successes
(NumSuccess), this function returns the minimum number of trials, N, such that the
cumulative probability of x successes is less than or equal to the given cumulative
probability (CumulativeProb).



Poisson Pdf (poissPdf())

Computes a probability at x for the discrete Poisson distribution with the specified
mean, μ, which must be a real number > 0. x can be an integer or a list of integers.
The probability density function (pdf) is:

This distribution is useful in determining the probability of obtaining a certain number
of successes before a trial begins. For example, you could use this calculation to
predict the number of heads that would occur in eight tosses of a coin.

Poisson Cdf (poissCdf())

Computes a cumulative probability for the discrete Poisson distribution with specified
mean, x.

This distribution is useful in determining the probability that a certain number of
successes occur between the upper and lower bounds of a trial. For example, you could
use this calculation to predict the number of heads displayed between coin toss #3 and
toss #8.

Geometric Pdf (geomPdf())

Computes a probability at x, the number of the trial on which the first success occurs,
for the discrete geometric distribution with the specified probability of success p. 0{p
{1 must be true. x can be an integer or a list of integers. The probability density
function (pdf) is:

This distribution is useful in determining the likeliest number of trials before a success
is obtained. For example, you could use this calculation to predict the number of coin
tosses that would be made before a heads resulted.

Geometric Cdf (geomCdf())

Computes a cumulative geometric probability from lowBound to upBound with the
specified probability of success, p.

This distribution is useful in determining the probability associated with the first
success occurring during trials 1 through n. For example, you could use this calculation
to determine the probability that heads display on toss #1, #2, #3, ..., #n.
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Confidence Intervals

Supported Confidence Intervals

The following confidence intervals are available from the Lists & Spreadsheets
application. For more information regarding these functions, see the TI-Nspire™
Reference Guide.

z Interval (zInterval)

Computes a confidence interval for an unknown population mean, m, when the
population standard deviation, s, is known. The computed confidence interval depends
on the user-specified confidence level.

This test is useful in determining how far from a population mean a sample mean can
get before indicating a significant deviation.

t Interval (tInterval)

Computes a confidence interval for an unknown population mean, m, when the
population standard deviation, s, is unknown. The computed confidence interval
depends on the user-specified confidence level.

This test is useful in examining whether the confidence interval associated with a
confidence level contains the value assumed in the hypothesis. Like the z Interval, this
test helps you determine how far from a population mean a sample mean can get
before indicating a significant deviation when the population mean is unknown.

2-Sample z Interval (zInterval_2Samp)

Computes a confidence interval for the difference between two population means
(m1Nm2) when both population standard deviations (s1 and s2) are known. The
computed confidence interval depends on the user-specified confidence level.

This test is useful in determining if there is statistical significance between the means
of two samples from the same population. For example, this test could determine
whether there is significance between the mean college entrance test score of female
students and the mean of college entrance test score of male students at the same
school.

2-Sample t Interval (tInterval_2Samp)

Computes a confidence interval for the difference between two population means
(m1Nm2) when both population standard deviations (s1 and s2) are unknown. The
computed confidence interval depends on the user-specified confidence level.

This test is useful in determining if there is statistical significance between the means
of two samples from the same population. It is used instead of the 2-sample z
confidence interval in situations where the population is too large to measure to
determine the standard deviation.



1-Prop z Interval (zInterval_1Prop)

Computes a confidence interval for an unknown proportion of successes. It takes as
input the count of successes in the sample x and the count of observations in the
sample n. The computed confidence interval depends on the user-specified confidence
level.

This test is useful in determining the probability of a given number of successes that
can be expected for a given number of trials. For instance, casino examiners would use
this test to determine if observed payouts for one slot machine demonstrate a
consistent pay out rate.

2-Prop z Interval (zInterval_2Prop)

Computes a confidence interval for the difference between the proportion of successes
in two populations (p

1
-p

2
). It takes as input the count of successes in each sample

(x1 and x2) and the count of observations in each sample (n1 and n2). The computed
confidence interval depends on the user-specified confidence level.

This test is useful in determining if two rates of success differ because of something
other than sampling error and standard deviation. For example, a bettor could use this
test to determine if there is an advantage in the long run by playing one game or
machine versus playing another game or machine.

Linear Reg t Intervals (LinRegtIntervals)

Computes a linear regression t confidence interval for the slope coefficient b. If the
confidence interval contains 0, this is insufficient evidence to indicate that the data
exhibits a linear relationship.

Multiple Reg Intervals (MultRegIntervals)

Computes multiple regression prediction confidence interval for the calculated y and a
confidence for y.

Stat Tests

Supported Statistical Tests

Hypothesis tests are available from the Lists & Spreadsheets application. For more
information regarding these functions, see the TI-Nspire™ Reference Guide.

Some of the wizards for Stat Tests display a Draw check box. By default, the box is not
selected. Selecting the box creates a Data & Statistics work area on the page and plots
the results in that work area.

z test (zTest)

Performs a hypothesis test for a single unknown population mean, m, when the
population standard deviation, s, is known. It tests the null hypothesis H

0
: m=m0against one of the alternatives below.

• H
a
: mƒm0

• H
a
: m<m0
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• H
a
: m>m0

This test is used for large populations that are normally distributed. The standard
deviation must be known.

This test is useful in determining if the difference between a sample mean and a
population mean is statistically significant when you know the true deviation for a
population.

t test (tTest)

Performs a hypothesis test for a single unknown population mean, m, when the
population standard deviation, s, is unknown. It tests the null hypothesis H

0
: m=m0against one of the alternatives below.

• H
a
: mƒm0

• H
a
: m<m0

• H
a
: m>m0

This test is similar to a z-test, but is used when the population is small and normally
distributed. This test is used more frequently than the z-test because small sample
populations are more frequently encountered in statistics than are large populations.

This test is useful in determining if two normally distributed populations have equal
means, or when you need to determine if a sample mean differs from a population
mean significantly and the population standard deviation is unknown.

2-Sample z Test (zTest_2Samp)

Tests the equality of the means of two populations (m1 and m2) based on independent
samples when both population standard deviations (s1 and s2) are known. The null
hypothesis H

0
: m1=m2 is tested against one of the alternatives below.

• H
a
: m1ƒm2

• H
a
: m1<m2

• H
a
: m1>m2

2-Sample t Test (tTest_2Samp)

Tests the equality of the means of two populations (m1 and m2) based on independent
samples when neither population standard deviation (s1 or s2) is known. The null
hypothesis H

0
: m1=m2 is tested against one of the alternatives below.

• H
a
: m1ƒm2

• H
a
: m1<m2

• H
a
: m1>m2

1-Prop z Test (zTest_1Prop)

Computes a test for an unknown proportion of successes (prop). It takes as input the
count of successes in the sample x and the count of observations in the sample n.



1-Prop z Test tests the null hypothesis H
0
: prop=p

0
against one of the alternatives

below.

• H
a
: propƒp

0
• H

a
: prop<p

0
• H

a
: prop>p

0
This test is useful in determining if the probability of the success seen in a sample is
significantly different from the probability of the population or if it is due to sampling
error, deviation, or other factors.

2-Prop z Test (zTest_2Prop)

Computes a test to compare the proportion of successes (p
1
and p

2
) from two

populations. It takes as input the count of successes in each sample (x1 and x2) and
the count of observations in each sample (n1 and n2). 2-Prop z Test tests the null
hypothesis H

0
: p

1
=p

2
(using the pooled sample proportionÇ) against one of the

alternatives below.

• H
a
: p

1
ƒp

2
• H

a
: p

1
<p

2
• H

a
: p

1
>p

2
This test is useful in determining if the probability of success seen in two samples is
equal.

c2GOF (c2GOF)
Performs a test to confirm that sample data is from a population that conforms to a
specified distribution. For example, c2 GOF can confirm that the sample data came
from a normal distribution.

c2 2-way Test (c22way)

Computes a chi-square test for association on the two-way table of counts in the
specifiedObservedmatrix. The null hypothesis H

0
for a two-way table is: no

association exists between row variables and column variables. The alternative
hypothesis is: the variables are related.

2-Sample FTest (FTest_2Samp)

Computes an F-test to compare two normal population standard deviations (s1 and
s2). The population means and standard deviations are all unknown. 2-Sample FTest,
which uses the ratio of sample variances Sx12/Sx22, tests the null hypothesis
H
0
: s1=s2 against one of the alternatives below.

• H
a
: s1ƒs2

• H
a
: s1<s2

• H
a
: s1>s2

Below is the definition for the 2-Sample FTest.
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Sx1, Sx2 = Sample standard deviations having n
1

N1 and n
2

N1 degrees of
freedom df, respectively.

F =
F-statistic =

df(x, n
1

N1,
n
2

N1)
= Fpdf( ) with degrees of freedom df, n

1
N1, and n

2
N1

p = reported p value

2-Sample FTest for the alternative hypothesis s1 > s2.

2-Sample FTest for the alternative hypothesis s1 < s2.

2-Sample FTest for the alternative hypothesis s
1

ƒs
2
. Limits must satisfy the following:

where: [Lbnd,Ubnd]=lower and upper limits

The F-statistic is used as the bound producing the smallest integral. The remaining
bound is selected to achieve the preceding integral’s equality relationship.

Linear Reg t Test (LinRegtTest)

Computes a linear regression on the given data and a t test on the value of slope b and
the correlation coefficient r for the equation y=a+bx. It tests the null hypothesis
H
0
: b=0 (equivalently, r=0) against one of the alternatives below.

• H
a
: bƒ0 and rƒ0

• H
a
: b<0 and r<0

• H
a
: b>0 and r>0

Multiple Reg Tests (MultRegTest)

Computes a linear regression on the given data, and provides the F test statistic for
linearity.

For more information, see the TI-Nspire™ Reference Guide.



ANOVA (ANOVA)

Computes a one-way analysis of variance for comparing the means of 2 to 20
populations. The ANOVA procedure for comparing these means involves analysis of the
variation in the sample data. The null hypothesis H

0
: m1=m2=...=mk is tested against the

alternative H
a
: not all m1...mk are equal.

The ANOVA test is a method of determining if there is a significant difference
between the groups as compared to the difference occurring within each group.

This test is useful in determining if the variation of data from sample-to-sample shows
a statistically significant influence of some factor other than the variation within the
data sets themselves. For example, a box buyer for a shipping firm wants to evaluate
three different box manufacturers. He obtains sample boxes from all three suppliers.
ANOVA can help him determine if the differences between each sample group are
significant as compared to the differences within each sample group.

ANOVA 2-Way (ANOVA2way)

Computes a two-way analysis of variance for comparing the means of two to 20
populations. A summary of results is stored in the stat.results variable.

The two-way ANOVA analysis of variance examines the effects of two independent
variables and helps to determine if these interact with respect to the dependent
variable. (In other words, if the two independent variables do interact, their combined
effect can be greater than or less than the impact of either independent variable
additively.)

This test is useful in evaluating differences similar to the ANOVA analysis but with the
addition of another potential influence. To continue with the ANOVA box example, the
two-way ANOVA might examine the influence of box material on the differences seen.

Selecting an Alternative Hypothesis (ƒ < >)

Most of the inferential stat editors for the hypothesis tests prompt you to select one of
three alternative hypotheses.

• The first is a ƒ alternative hypothesis, such as mƒm0 for the z Test.

• The second is a < alternative hypothesis, such as m1<m2 for the 2-Sample t Test.

• The third is a > alternative hypothesis, such as p1>p2 for the 2-Prop z Test.

To select an alternative hypothesis, move the cursor to the appropriate alternative, and
then press Enter.

Selecting the Pooled Option

Pooled (2-Sample t Test and 2-Sample t Interval only) specifies whether the variances
are to be pooled for the calculation.

• Select No if you do not want the variances pooled. Population variances can be
unequal.

• Select Yes if you want the variances pooled. Population variances are assumed to
be equal.
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To select the Pooled option, select Yes from the drop-down list.

Working with Function Tables

The Lists & Spreadsheet application lets you show a table of function values for any
function in the current problem. You can change the settings for the table, delete
columns, add values for multiple functions, and edit the expression that defines a
function without leaving the Lists & Spreadsheet application.

Switching to a Table

1. While working in the Lists & Spreadsheet application:

Windows: Press Ctrl+T.

Mac®: Press “+T.

Handheld: Press/T.

The Lists & Spreadsheet application disappears and an empty table is displayed
with a list of the functions that are available in the problem.

Note: If you have previously shown a table for a function from the
Lists & Spreadsheet application, the table includes that function by default.

2. Choose the name of the function for which you want to display values.

Values for the function you selected are displayed in the first column of the table.

3. To move through adjacent cells of the table, press ▲ or▼. Press Tab to move
from the body of the table (cells) to the top two rows (cells for column names and
formulas).

4. To hide the table of values and return to the Lists & Spreadsheet application,
repeat Step 1.

Making Changes from a Table

You can change the table of function values using the tools on the Table menu.

▶ To remove a column from the table, click any cell and click Delete Column.

▶ To display the list of functions, click a cell in a column and click Choose. Select a
cell in an empty column unless you are replacing values already displayed. Click a
function in the list to add its values to the column.

Note: You can also click the drop-down arrow on the top cell of a column to display
the list of functions in the problem.



▶ To change the expression that defines a function, click Edit Expression. You can also
edit the expression directly on the entry line beneath the table.

Note: When you edit the expression for a function, that function automatically
changes in the application used to define the function. For example, if you edit a
Graphs & Geometry function in the table, the table values and graph of the
function are both updated.

▶ To change the default table settings, choose Edit Table Settings.

The Table dialog box opens. Press Tab to move from field to field and type or select
new values for the default table settings:

- Table Start: Type the value to use as the first value in the table of values.

- Table Step: Type a value for the interval between values.

- Independent and Dependent: Click the drop-down arrow to choose Auto or Ask
as the method for populating a column with the values of the independent and
dependent variables. Auto populates the table starting at the defined table
start value and displays an independent and dependent value for each step. Ask
lets you select a cell and press Enter to generate a value for a cell.
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Data & Statistics Application
The Data & Statistics application provides tools to:

• Visualize sets of data in different types of plots.

• Directly manipulate variables to explore and visualize data relationships. Data
changes in one application are dynamically applied to all linked applications.

• Explore central tendency and other statistical summary techniques.

• Fit functions to data.

• Create regression lines for scatter plots.

• Graph hypothesis tests and results (z- and t-tests) based on summary statistics
definitions or data.

Adding a Data & Statistics Page

▶ To start a new document with a blank Data & Statistics page:

From the main File menu, click New Document, and then click Add
Data & Statistics.

Handheld: Pressc, and select Data & Statistics .

▶ To add a Data & Statistics page in the current problem of an existing document:

From the toolbar, click Insert > Data & Statistics.

Handheld: Press~ and select Insert > Data & Statistics.

À Data & Statistics menu

Á Work area

Â Add Variable regions on x-axis and y-axis
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Ã Normal Probability Plot with expression

Ä Data point with coordinates

Basic Operations in Data & Statistics

The Data & Statistics application lets you explore and visualize data and graph
inferential statistics. The Lists & Spreadsheet application can work in conjunction with
the Data & Statistics application. The Lists & Spreadsheet Summary Plot and Quick
Graph tools automatically add a Data & Statistics application to show plots. A list that
you create in a problem (using the Lists & Spreadsheet or Calculator applications) can
be accessed as a variable in any TI-Nspire™ application in that problem.

Changing Data & Statistics Settings

1. From the Settings menu, select Settings.

2. Select the settings that you want to use.

• Display Digits. Lets you select the display format for numeric labels in the
current document. Select Auto to automatically follow the setting in the
Document Settings dialog box.

• Diagnostics. Displays the value of the r2 or R2 statistic (when available) under
certain regression equations.

- r2 is displayed for Linear (mx+b), Linear (a+bx), Power, Exponential, and
Logarithmic regressions.

- R2 is displayed for Quadratic, Cubic, and Quartic regressions.

Using the Default Caseplot

The Data & Statistics application plots numeric and string (categorical) data from
variables. When you add a Data & Statistics application to a problem that includes
lists, a default caseplot displays on the work area.

The caseplot is like having a stack of cards with information on them and scattering
the cards randomly on a table. You can click a dot to see the information on that
“card.” You can drag a dot to “group” the “cards” by the caption variable.



▶ Click the variable name displayed after Caption to use the caseplot.

- Choose <None> to remove the default caseplot.

- Choose the name of a variable to have it replace the current caseplot variable.

- Hover over any data point to see the summary information.

- Drag any data point toward an axis to see how the points group.

- Activate the Graph Trace tool and press ◄ or ► to move across points.

When you add a variable to either axis, the plot for that variable replaces the default
caseplot. The default caseplot redisplays if you remove the plotted variable from each
axis.

Using the Context Menu

The context menu provides access to the tools most commonly used with the selected
object. The context menu displays different options depending on the active object and
the task you are performing.

▶ To open the context menu for an object.

Windows®: Right-click the object.

Mac®: Hold “ and click the object.

Handheld: Point to the object and press/b.

The context menu includes the Color option. You can use the Color option to change the
data to the color of your choice.
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Other options that are appropriate for various plots also appear on the context menu.

Selecting Data and Displaying Summary Information

When you hover over part of a plot, the Data & Statistics application displays summary
information for the data it represents.

1. Hover at an area of interest in a plot to display data values or summary
information. For example, you can hover over the center of a box plot to display the
median summary data.

2. Click once to select a representation of data in a plot.

Data points are shown with a bold outline to indicate selection. You can click a
point a second time to deselect it, or click additional points to add to the selection.

Plotting Variables

To plot variables, start with a problem that includes a Data & Statistics application and
lists created in the Lists & Spreadsheet application or the Calculator application.

1. Click the Add Variable region near the center of an axis.

If no variable is plotted on the axis, the tooltip Click or Enter to add variable
displays.

2. Click the tooltip Click or Enter to add variable.

A list displays the names of available variables.

3. Click the name of the variable to plot.

Note: By convention, the independent variable is shown on the x-axis.

The default plot for one variable is a dot chart. The data points in the default
caseplot reposition to represent the elements of the selected variable in a dot
chart.

4. (Optional) Click the Add Variable region near the center of the remaining axis to
plot a second variable.



The default plot for two variables is a scatter plot. The data points shift to
represent the elements of both variables as a scatter plot.

5. (Optional) Repeat Steps 1-3 to choose additional variables to plot on the vertical
axis.

The name of each variable that you add is appended to the label on the axis. The
default data point shape changes to help you distinguish data, and a legend is
displayed to identify the shapes.

6. Change, analyze, or explore the plotted data.

- Remove or change the variable on an axis by clicking the Add Variable region
again.

- View the plotted data in another supported plot type by selecting a tool from
the Plot Types menu.

- Choose the Graph Trace tool on the Analyze menu and press ◄ or ► to move
across the data points in the plot.

- The lists that you plot as variables can include incomplete or missing cases. (A
case is the data contained in a row of cells in the Lists & Spreadsheet
application.) The Lists & Spreadsheet application displays a void as an
underscore (“_”), and Data & Statistics plots no data point for a void cell.

Manipulating Plotted Data

You can manipulate data points on the Data & Statistics work area to explore their
effects. For example, you could explore how a specific group of values affects the
median.
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You can move a data point only in directions allowed by its definition. If a list is defined
with a formula in Lists & Spreadsheet, the points in Data & Statistics may not move
because of the formula’s restrictions. For example, you can manipulate a plot that
represents the result of y=x, but you can only move along a line.

You cannot move points that represent data in a locked variable or data that represents
a categorical value.

1. On the Data & Statistics work area, click a representation of data—such as a
histogram bin or a whisker of a box plot—that is not locked or restricted by a
formula.

The pointer changes to an open hand to show that the data can be moved.

2. Drag the selection to explore how different values of the point affect the plot.

Handheld: Press/a to grab, and then swipe or use the arrow keys to drag.

As you drag, the changing value displays on the work area.

Overview of Raw and Summary Data

You can create plots directly from raw data or from a summary table.



Rawdata Summary table for eye color based on rawdata

• Raw data consists of a single list, such as a list of eye colors. When you create a
plot of raw data, Data & Statistics counts the occurrences for you. Plotting raw
data directly gives you flexibility in analyzing it.

• A summary table consists of two lists, such as eye colors (the X or Y List) and
counts of eye-color occurrences (the Summary List). For more information, see
Using Lists & Spreadsheet chapter.

Working with Numeric Plot Types

Plots can represent the data from a variable in a variety of ways. Choosing the
appropriate plot can help you visualize the data. For example, you may be able to
observe the shape and spread of the data in one plot type and another type may be
useful for determining the best method for statistically evaluating data.

Creating Dot Plots

Dot plots, also known as dot-frequency plots, represent one-variable data. Dot plots are
the default plot type for numeric data. When you plot a variable as a dot plot, one dot
represents each value in the list. Each dot displays on the axis at a point that
correspond to the value.

1. To create a dot plot, click the Add Variable region in the center of an axis and click
the name of a numeric variable. For more information, see Plotting Variables.

2. (Optional) To split a dot plot by category, click the Add Variable region on the other
axis and choose the list that contains the corresponding category data.

3. (Optional) To plot multiple dot plots, choose Add X Variable on the Plot Properties
menu and click a numeric variable from the list that displays.

A second dot plot appears on the work area and the name of the plotted variable is
added to both axis labels.

4. Explore the plotted data.

- Hover over a data point to display data values.
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- Drag a dot to move it. As you move a point, the values associated with it
change on the work area display and in the list for the variable.

- Activate the Graph Trace tool and press ◄ or ► to move across the data
points in the plot in list order. Points enlarge and display a bold outline as you
move across them in Trace mode.

Creating Box Plots

The Box Plot Tool plots one-variable data in a modified box plot. “Whiskers” extend
from each end of the box, either to 1.5 times the interquartile range or to the end of
the data, whichever comes first. Points that are a width of 1.5 * Interquartile Range
past the quartiles plot individually, beyond the whiskers. These points are the potential
outliers. When no outliers exist, x-min and x-max are the prompt for the end of each
whisker.

Box plots are useful for comparing two or more sets of data that use the same scale. If
a dataset is large, a box plot can also be useful in exploring data distribution.

1. Click the Add Variable region in the center of an axis. The default plot for one
numeric variable is a dot plot. For more information, see Plotting Variables.

Note: If two variables are plotted in the work area, you can create a dot plot by
removing one variable. Choose Remove X Variable or Remove Y Variable from the
Plot Types menu.

2. On the Plot Types menu, click Box Plot.



A modified box plot displays on the Data & Statistics work area.

Note: You can split a box plot by category by adding a list that contains
corresponding categorical data to the y-axis.

3. (Optional) To add additional variables for comparing box plots on the same axis,
click Add X Variable on the Plot Properties menu.

For example, you can use multiple box plots to compare the distributions of sample
proportions. In the example, true proportion is .5 and sample size varies from n=20
to n=40 to n=90.

Notes:
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- You can create a box plot with frequency by choosing Add X Variable or Add Y
Variable on the Plot Properties menu.

- You can specify a variable multiple times as you choose variables to plot as box
plots.

- The variable used to provide frequency information is added to the label on the
horizontal axis in the format: x_variablename{frequencylist_name}.

4. Point and click the regions of the box plot to explore and analyze the data it
represents.

- Hover over a region or over a whisker to display the details for the portion of
the plot that interests you. The label for the quartile that corresponds to your
selection is displayed.

- Click a region of the box plot to select the data points or whiskers. Click again
to remove the selection.

- You can select any box plot that does not include frequency data and choose
Dot Plot on the context menu to change the plot type.

- Drag a selection to move it and explore other possibilities for the data.

- Use the arrow keys to move a data point one pixel at a time.

- Activate the Graph Trace tool and press ◄ or ► to move across dots and
regions of the plot. As the trace cursor moves, the values for Q1, the median,
Q3, and whisker ends/outliers are displayed.

5. Change the plot from a modified box plot to a standard box plot by choosing Extend
Box Plot Whiskers on the Plot Properties menu.

The box plot is redrawn as a standard box plot with extended whiskers.

The standard box plot’s whiskers use the minimum and maximum points in the
variable and outliers are not identified. The whiskers on the plot extend from the
minimum data point in the set (x-min) to the first quartile (Q1) and from the third
quartile (Q3) to the maximum point (x-max). The box is defined by Q1, Med
(median), and Q3.

Note: You can click Show Box Plot Outliers on the Plot Properties menu to return to
the modified box plot.



Plotting Histograms

A histogram plots one-variable data and depicts the distribution of data. The number
of bins displayed depends on the number of data points and the distribution of these
points. A value that occurs on the edge of a bin is counted in the bin to the right.

Creating a Histogram from Raw Data

1. Create the list that you want to plot as a histogram. For example, you can enter or
collect data as a named list on a Lists & Spreadsheet page.

2. On a Data & Statistics page, click the x or y axis, and select your list as the data to
plot.

3. From the Plot Types menu, click Histogram.

The data forms the bins of a histogram, with Frequency plotted by default on the
unselected axis.

Data & Statistics Application 355



356 Data & Statistics Application

4. Explore the data.

- Hover over a bin to see the information for that bin.

- Click a bin to select it. Click the bin again to deselect it.

- Drag the side of a bin to adjust bin width and number of bins.

Note: The bins are not adjustable in categorical plots or plots in which you
choose variable bin widths.

- On the Analyze menu, click Graph Trace and press ◄ or ► to cycle through the
bins and display their values.

Adjusting the Histogram Scale of Raw Data

1. On the Plot Properties menu, click Histogram Properties and choose Histogram
Scale.

2. Choose the format for the scale of the histogram.

- Frequency - displays data based upon the number of values that occur within
each bin. This is the default data representation.

- Percent - displays data in the histogram by each group’s percent value of the
whole data set.

- Density - displays data based upon the density of each group within the data
set.



Creating a Histogram with Frequency or Summary Data

1. On a Lists & Spreadsheet page, create two lists: one containing the “bins,” such as
heights in a population (ht), and the other containing the frequencies of those
heights (freq).

2. On a Data & Statistics page, access the context menu on the x axis, and click Add X
Variable with Summary List.

3. Select ht as the X List and freq as the Summary List.

Note: It is up to you to set the data and bins in a meaningful way when using
summary data.
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Setting Equal Bin Widths

By default, bin widths are set to equal. You can specify the width and alignment of
equal-width bins.

1. On the Plot Properties menu, click Histogram Properties > Bin Settings, and choose
Equal Bin Width.

The Equal Bin Width Settings dialog box opens.

2. Type values to set Width and Alignment of the bins.

3. Click OK to apply the changes and redraw the bins.

Both the data represented by the bins and the value you type for the alignment
affect the placement of bins on the scale.

Setting Variable Bin Widths

You can set variable bin widths based on a list of bin boundaries.

1. Create a named list containing boundary values.

For example, a boundary list defined as {60,70,100,110} will create bins at 60 to
70, 70 to 100, and 100 to 110.

Note: The data must fall within the specified bin widths. For example, a data point
of 115 would be outside the bins in the above list, and you would receive a
Data/Bin Location Mismatch error.

2. On the Plot Properties menu, click Histogram Properties > Bin Settings, and choose
Variable Bin Width.



The Variable Bin Width Settings dialog box opens.

3. Select your boundary list as the List of Bin Boundaries.

4. Click OK to apply the changes and redraw the bins.

Note: You cannot change variable bin widths by dragging their boundaries; you
must edit the list of boundaries or restore equal-width bins.

Creating a Normal Probability Plot

A normal probability plot shows one set of data against the corresponding quartile (z)
of the standard normal distribution. You can use normal probability plots to judge the
appropriateness of the normal model for your data.

1. Choose or create the data you want to use for a normal probability plot. Use a
named list from Lists & Spreadsheet or Calculator.

2. Plot the data in one of the following ways:

- Create a dot plot by selecting a column and choosing Quick Graph.

- Add a Data & Statistics work area. Click the Add Variable region on an axis and
click the data list name to plot the variable.

3. On the Plot Types menu, click Normal Probability Plot.

The data graphs in the Data & Statistics work area. You can examine the graph to
compare the normal variable against the quartile.

4. Explore the data represented in the normal probability plot.

- Hover over a data point to display its value.
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- Click to select a data point. Click again to deselect it.

- Click multiple data points to select them.

- Activate the Graph Trace tool and press ◄ or ► to move across the data
points and display values.

Creating a Scatter Plot

A scatter plot shows the relationship between two sets of data. You can also plot a
scatter plot by using the Quick Graph tool in the Lists & Spreadsheet application.

1. In the Data & Statistics work area, click the Add Variable region and select the
variable that contains the data you want to see represented on an axis.

The plot of the selected variable displays on the axis.

2. Click the Add Variable region of the other axis and select the variable containing
the data you want to plot.

The data points shift to represent the data in the selected variable.

3. Analyze and explore the data in the plot.

- Click a point to select it.

- Hover over a data point to view the summary data.

- Work with the data using the available tools on the Analyze menu. For
example, choose the Graph Trace tool and press ◄ or ► to move across the
plot.



4. Optional: To plot additional lists against the x-axis, right-click the y-axis and click
Add Variable.

Creating an X-Y Line Plot

An X-Y line plot is a scatter plot in which the data points are plotted and connected in
order of appearance in the two variables. Like scatter plots, these plots depict the
relationship between two sets of data.

By convention, the left-most column of data is represented on the horizontal axis.

1. Create a scatter plot. For more information, see Creating a Scatter Plot.

2. On the Plot Types menu, click the XY Line Plot tool.

The data points within each set are connected to each other by a line.

Note: The dots are connected in the order that they appear in the list variable on
the horizontal axis. To change the order, use the sort tool in Lists & Spreadsheet.

3. Analyze and explore the data in the plot.

- Hover over a data point to view the summary data.

- Work with the data using the available tools on the Analyze menu. For
example, choose the Graph Trace tool and press the arrow keys to move across
the dots in the plot and view the values.

Working with Categorical Plot Types

You can sort and group data using the categorical plot types:

• Dot Chart
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• Bar Chart

• Pie Chart

The categorical plot types can be used to compare the representations of data across
different plots. When the same variable (list) is used for a dot chart and a bar chart or
pie chart in a problem, selecting a data point or segment in one of the plots selects the
corresponding data point, segment, or bar in all other plots that include the variable.

Creating a Dot Chart

The default plot type for categorical data is the dot chart.

When one variable is plotted, the value of each cell is represented as one dot, and the
dots are stacked at the point on the axis that corresponds to the cell value.

1. In Lists & Spreadsheet, create a spreadsheet that includes at least one column of
string values that can be used as categories for data.

Note: To type a string in Lists & Spreadsheet, enclose the characters in quotes.

2. Add a Data & Statistics page to the problem.

Notes:

- You can also use the Lists & Spreadsheet Quick Graph tool to automatically add
a Data & Statistics page and plot the selected column.

- The new Data & Statistic work area displays a default caseplot with a caption,
variable name, and unplotted data points for the variable. You can click the
variable name in the caption to choose another variable for previewing, or drag
a default data point toward an axis to plot the current variable.



3. Move near the center of either axis and click the Add List region. The list of
variables displays.

4. Click the list that contains the categories you want to use for sorting data.

A dot chart plots in the work area. The application labels the axis with the variable
name and shows a dot for each instance of a category.

5. Explore the plotted data.

- Hover over a dot in the plot to display data values.

- Click a dot to select it. Click the dot a second time to deselect it or remove it
from a selection of multiple dots.

- Activate the Graph Trace tool and press ◄ or► to move across the points in
list order. Dots display a bold outline as you move across them in Trace mode.

Creating a Bar Chart

Like dot charts, bar charts display categorical data. The length of a bar represents the
number of cases in the category.
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1. Click the Add Variable region of either axis and choose the name of a categorical
variable. For more information, see Creating a Dot Chart.

2. On the Plot Types menu, click Bar Chart.

The dot chart changes to a bar representation of the data.

3. Explore the data in the plot.

- Hover over a bar to see a category summary (the number of cases and
percentage among all categories).

- Activate the Graph Trace tool and press ◄ or►move across the bars and
view summary information.

Creating a Bar Chart from a Frequency Table or Summary Data

1. On a new Data & Statistics page, create a bar chart with frequency or summary
data by choosing Add X Variable on the Plot Properties menu.

Note: You can also create a bar chart with frequency by selecting Add Variable with
Summary List from the context menu of the Add Variable region of an axis.

2. Select the desired variable from the pop-up choices.

3. Set the height of the bars with the summary variable by selecting Add Summary
List from the Plot Properties menu.

4. Select the summary list from the pop-up choices.

The bar chart plots on the work area. The icon in the lower left corner indicates
that this plot was generated from summary data.



5. Hover over a bar to see a category summary, or use the Graph Trace tool on the
Analyze menu to move across all of the bars displaying the summaries.

6. (Optional) Add summary lists to create a comparative bar chart.

Creating a Pie Chart

A pie chart represents categorical data in a circular layout and uses an appropriately
proportioned segment for each category.

1. Create a dot chart on the work area.

2. On the Plot Types menu, click Pie Chart.

The dots move by category into the segments of the pie chart.
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3. Hover over a segment to see the summary for the category, or use the Graph Trace
tool on the Analyze menu to move across each segment displaying all of the
summaries. The summary shows the number of cases for the category and the
percentage among all cases.

Note: You can switch to a pie chart from a bar chart generated from summary data.

Creating a Comparative Bar Chart

This might be used to explore data in a two-way table.

1. Type the raw data on a Lists & Spreadsheet page.

2. From the Insert menu in the toolbar, click Data & Statistics.



Note: Your screen may differ, depending on the data you entered.

3. Select the Click to add variable field, and select eyecolor as the variable for the x
axis.

4. On the Plot Type menu, click Bar Chart.

The frequency of the eyecolor data is plotted.

5. To split the eyecolor data by gender, click the Plot Properties menu, click Split
Categories by Variable, and then click gender.

Data & Statistics Application 367



368 Data & Statistics Application

Splitting a Numeric Plot by Categories

You can use a categorical split to sort the values plotted on an axis.

1. Open a problem that includes a Lists & Spreadsheet page, or create data to be
plotted in the Lists & Spreadsheet application.

In this example, lists contain dog breed and daily walk information.

2. Click column letter (B).

3. On the Lists & Spreadsheet Data menu, click the Quick Graph tool.



The Quick Graph tool adds a Data & Statistics page. Data & Statistics plots the
variable and labels the horizontal axis.

4. To plot the numeric data for each category, hover on the Add Variable region near
the center of the vertical axis and click the tooltip Click or Enter to add variable.

The list of available variables displays.

5. On the list of variables, click the name of the category variable.

Data & Statistics labels the vertical axis and plots the numeric data for each
category.
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Exploring Data

You can manipulate and explore plotted data.

Moving Points or Bins of Data

1. Click and hold the desired point or bin.

The pointer changes to an open hand÷.

2. Drag the point or bar to the new location and release it. Moving the point changes
the values for x and y.

If you are working with data from Lists & Spreadsheet, the data that corresponds
to the original point or bar automatically updates in the original column(s) in
Lists & Spreadsheet as you move the point.



You can also move points or bins by changing the numbers in the
Lists & Spreadsheet or Calculator applications. Data will update in all of the
representations.

Moving Multiple Points

1. Position the pointer over each data point that you want to select. When the pointer
changes to an open hand÷, click to add the point to the selection.

Alternatively, you can drag a selection rectangle around the points to select them.

2. Drag any of the selected points to move them all.

Note: When a list is defined in Lists & Spreadsheet as a formula, the movement of
points is restricted to positions that satisfy the formula.

Sorting Plotted Categories

You can sort plotted categories in list order, value order, or alphabetically by category
name.

1. Click the work area that contains the plotted data.
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2. On the Actions menu, click Sort, and then click the type of sort.

Months listed chronologically but sorted by value (amount of rainfall)

Note: You can customize the order of the categories by clicking a label and dragging it.

Plotting a Value

You can plot a value on an existing plot. It displays as a vertical line in the work area.

1. From the Analyze menu, click Plot Value.

A text box with a default expression opens in the work area.

2. Type the value you want to plot, and press Enter. In this example, the value is v1:=
mean(cost).

The line is drawn at that value, perpendicular to the axis. If you have multiple plots
on the work area, a plot value segment displays for each plot.



Note: If you use a frequency table to generate a histogram, reference the
frequency list in your expression. For example, type the expression "v1:= mean(List,
FreqList)" in the plot value entry box.

3. Click the line to display the value.

Note: Double-click the value to edit the expression.

Plot value with value displayed

You can use Plot value for a single number or any expression that evaluates to a
number. If the value is dependent on the data, like mean, when you drag a point or
make changes in the Lists & Spreadsheet application, the line updates to reflect
the change, allowing for investigation of the influence of points on the calculation.

Removing a Plotted Value

1. Select the plotted value line.

2. From the Actions menu, click Remove Plotted Value.

Changing the Plot Type

You can change the plot type, to view different representations of data.

▶ On the Plot Type menu, click a new plot type. Only the supported plot types are
available. For example, only univariate plot types are available when a single
variable plotted on an axis.

The data representation changes to the new plot format.

Note: Options are unavailable on the menu if the plotted data cannot be
represented by the plot type. For example, if a scatter plot is displayed in the work
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area, you cannot create a box plot without first removing the variable from the y-
axis.

Rescaling a Graph

You can change the scale of the axes by using Translation and Dilation. The pointer
changes to indicate whether Translation (ö) or Dilation (ô) is available in zones on the
axes.

Translation

A translation slides a set of axes a fixed distance in a given direction. The original axes
have the same shape and size.

1. Position the pointer over a tic mark or label in the middle third of the axis. The
pointer changes toö.

2. Click to grab. The pointer changes to a grasping handù. Drag to the desired
position and release.

Dilation

Dilation retains the shape of the axes, but enlarges or reduces the size.

1. Position the pointer over a tic mark or label near the ends of the axis. The pointer
changes to ó on the vertical axis or ô on the horizontal axis.



2. Click to grab. The pointer changes to an open hand÷. Drag to the desired position
and release.

Adding a Movable Line

You can add a movable line to a plot. Moving and rotating the line on the work area
changes the function that describes it.

▶ From the Analyze menu, click Add Movable Line.

The movable line displays and is labeled with a function that describes it. For this
example, Data & Statistics stores the expression for the movable line in the
variable m1.

Rotating a Movable Line

1. Click and grab either end of the line.

The pointer changes toé.

2. Drag to rotate and change the slope of the line.
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The function m1(x) is updated for the changes in the position of the movable line.

Changing the Intercept

1. Click in the middle of the movable line.

The pointer changes toö.

2. Drag to change the intercept.

The number at the end of the equation changes to show the change in the
intercept.

Note: The movable line is stored as a function that can be used for prediction in the
Calculator application.

Locking the Intercept at Zero

You can lock the intercept of the movable line at zero.

▶ From the Analyze menu, click Lock Intercept at Zero.



You can unlock the intercept by choosing Unlock Movable Line Intercept on the
Analyze menu.

Tracing a Movable Line

You can trace a movable line to predict and analyze values.

1. Click the line.

The pointer changes.

2. From the Analyze menu, click Graph Trace to enable Trace mode for the line.
Rotation of the line is not supported in Trace mode.

3. Press ◄ or ► (left or right arrow keys) to trace the movable line.

If the plotted variables change, points on the graph and the line are updated
automatically.

Showing a Line of Regression

You can show a line of regression when you have a scatter plot or an X-Y line plot on
the work area. Studying the line of regression can help you understand the relationship
between two variables.

1. With a scatter plot or X-Y line plot of two variables on the work area, click the
Analyze menu, choose Regression and view the list of regressions.

2. Click the type of regression line to show. For example, choose Show Linear (mx+b)
to plot a linear regression line as shown in the following example.

When the line of regression is selected, the expression for the line displays.
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Showing Residual Squares

You can display residual squares on a plot. Residual squares can help you assess the
appropriateness of the model for your data.

Note: This tool is only available when a regression or movable line is present in the
work area.

▶ From the Analyze menu, click Residuals > Show Residual Squares.

The sum of squares is updated as the line or data changes.

Showing a Residual Plot

You can show a residual plot to determine how well a line fits data. The work area
must include a scatter plot and one or more movable lines, regressions, or plotted
functions for Show Residual Plot to be available.

▶ With a scatter plot, line of regression, and/or movable line in the work area, click
the Analyze menu, and click Show Residual Plot > Residuals.



Notes:

• With multiple regressions or functions and movable lines plotted, you can select
each by clicking the line to show its residual plot.

• Click and hold a dot on the residual plot to see the residual.

• The residual plot for the selected regression or function displays in the work area.

• For consistency in comparing sets of data, residual plots do not rescale when you
move from one function or regression to another.

• Select a function or regression before a showing residual plot. If no function or
regression is selected and there are several plotted, Data & Statistics arbitrarily
selects the function or regression for showing the residual plot.

• Axes can be adjusted by clicking and dragging.

Removing a Residual Plot

▶ With a scatter plot, line of regression, and/or movable line in the work area, click
the Analyze menu, and click Hide Residual Plot.

Using Window/Zoom Tools

Use the Window/Zoom tools to redefine the graph to better view points of interest.
The Window/Zoom tools include:

• Window Settings: displays a Window Settings dialog box that lets you type the
x-min, x-max, y-min, and y-max values for the axes.

• Zoom - Data: adjusts the zoom factor to display all plotted data.

• Zoom - In: lets you define the center point of the zoom in location. The Zoom In
factor is approximately 2.

• Zoom - Out: lets you define the center point of the zoom out location. The Zoom
Out factor is approximately 2.

Using the Window Settings Tool

1. On the Window/Zoommenu, clickWindow Settings.

The Window Settings dialog box opens. The current values for x-min, x-max, y-min,
and y-max are displayed in the fields.

Note: Only the appropriate boxes are editable, depending on whether there are one
or two axes in the work area.

2. Type the new values over the old values.

3. Click OK to apply the changes and redraw the plot.
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Using the Zoom Data Tool

▶ On the Window/Zoommenu, click Zoom Data.

The work area rescales to display all plotted data.

Using the Zoom In Tool

1. On the Window/Zoommenu, click Zoom In.

2. In the work area, click the center point of the area of interest. This will be the
center of the zoom in action.

The plot redraws to focus and enlarge the portion of the plot centered about the
point you selected in the previous step.

Using the Zoom Out Tool

1. On the Window/Zoommenu, click Zoom Out.

2. In the work area, click the center point of the area of interest. This will be the
center of the zoom out action.

The plot redraws to display a larger portion of the plot, centered about the point
you selected in the previous step.

Graphing Functions

You can graph functions by typing them in Data & Statistics, or you can graph functions
defined in other applications.

Graphing Functions Using the Plot Function Tool

You can use the Plot Function tool to plot functions in a work area that already includes
a plot on the axes. Plot Function lets you specify and graph a function for comparison
to an existing plot.

To use the Plot Function tool:

1. Create or open a problem that includes variables (from Lists & Spreadsheet) that
are plotted on a Data & Statistics work area. Ensure that your work area contains
both a horizontal axis and a vertical axis scale.

2. From the Analyze menu, click Plot Function.

A function entry field displays in the work area.



Note: You can edit the function’s expression typed in the entry field. However, the
function graphed in Data & Statistics cannot be manipulated or moved around the
work area. To do that, use Graphs & Geometry.

3. Type the function in the entry field, and press Enter.

Note: You can rename the function by typing over f1(x): with another name, if you
choose.

The function graphs in the work area and is saved as a variable for use in other
applications.
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Entering Functions from Other Applications

You can enter a function that has been defined as a variable in another application,
such as Lists & Spreadsheet, Graphs & Geometry, or Calculator.

1. Add a variable to each axis. You can access any variables defined in a
Lists & Spreadsheet or Calculator application in your problem from the variable list.

2. From the Analyze menu, click Plot Function.

A function entry field displays in the work area.

3. Click on the toolbar.

Handheld: Pressh.

A list of variables available in the problem displays.

4. Click to select the variable containing the function you want to plot.

In the example below, the variable a contains the function f(x)=x2.

5. Press Enter.

The function plots in the work area.



Editing a Function

You can edit a function and update it in the work area.

1. You can edit a function by double-clicking the equation and then making changes as
required.

2. Press Enter after making all changes and the updates are displayed in the work
area.

Using Data & Statistics Functions in other Applications

Data & Statistics functions are stored as variables, and may be used in other
applications, in the same manner as any other variable. Support for all function types is
included.

Note: Function numbers increment to use the next available. If you have defined f1(x)
and f2(x) in Graphs & Geometry, the first function you create in Data & Statistics will
be f3(x).

Using Show Normal PDF

You can approximate data plotted in the Data & Statistics work area against the
normal probability density function. The tool overlays the normal probability density
function using the mean and the standard deviation of the data in the histogram.

To show the normal probability density function for plotted data:

1. Add a variable to the x-axis.
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2. On the Plot Types menu, click Histogram.

Note:Show Normal PDF is available only when histogram is the plot type.

3. From the Analyze menu, click Show Normal PDF.

The normal PDF for the graph plots in the work area. The expression used to
calculate the PDF displays when selected.

You can click Hide Normal PDF on the Analyze menu to remove the PDF.



Using Shade Under Function

Use Shade Under Function to find the area of a selected region under a function
graphed in the work area.

1. Select any function graphed in the Data & Statistics work area. For example, select
a previously graphed normal PDF.

2. From the Analyze menu, click Shade Under Function.

The pointer becomes a dotted vertical line and the boundary +/- ˆ displays when
you position the mouse near the boundary on the left or right. You can click when ˆ

displays to set it as a boundary.

3. Select a point on the curve and click to indicate where to start shading under the
function. The direction in which you move next determines whether the region
shaded is on the left, right, or center of the curve.

4. Select a point on the curve and click to indicate the end boundary of the shaded
area. A region under the function is shaded based on the points you selected.

You can work with Shade Under Function in the following ways:

• Select the region to display the values for data points in the shaded area.

• To remove the shading, right-click or Ctrl-click the shaded region and choose
Remove Shaded Region.

• To change the fill color of the shaded area, right-click or Ctrl-click the shaded
region, choose Color, choose Fill, and click a color.
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• Use plot value to set the boundary to an exact number. When a boundary for
shading is set to a plotted value, you can change the plotted value to update
the shading.

• Edit a shaded region by clicking and dragging the edge at the starting or ending
boundary.

Using Graph Trace

Graph Trace lets you move from one point on a graph to another to analyze variations
in the data. You can use Graph Trace mode to explore the data for the following
graphs.

• Graphs from Plot Function and Show Normal PDF

• Distribution curves (created in the Lists & Spreadsheet application)

• Movable Lines

• Regressions

• Caseplots

• Dot plots

• Scatter plots and X-Y line plots

• Box plots

• Histograms

• Bar charts

• Pie charts

To use Graph Trace

1. From the Analyze menu, click Graph Trace.

2. Press ◄ or ► to move across the plot.

The data representations enlarge and appear with a bold outline as you move
across them in Trace mode.

Customizing Your Workspace

Working with Color

All data points for a plotted variable display in the same color to distinguish them from
the data points of other variables. Data plotted by category and split plots are
automatically displayed in different colors to help you distinguish the data.

To emphasize or distinguish certain parts of your work, you can change the default
color for a variable’s data.



• Apply fill colors to objects, such as shading, or change the color for a variable’s
data points.

• Apply color to plotted lines (such as lines of regression) or movable lines.

Inserting a Background Image

When using the computer software, you can insert an image as a background for a
Data & Statistics page. The file format of the image can be .bmp, .jpg, or .png.

1. From the Insert menu, click Image.

2. Navigate to the image that you want to insert.

3. Select it, and then click Open.

The image is inserted as a background.

For more information, see the Working with Images chapter.

Working with Text

The Insert Text tool lets you type text to describe details related to plots on the work
area.

1. From the Actions menu, click Insert Text.

A text box opens.

2. Type notes or descriptions in the text box.

3. Customize the text to suit your needs.

• Move the pointer over the edges of the text box to drag the borders and change
the width or height.

• Click and grab the text box to move it near objects that relate to the text.
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• Scroll to view additional text in a box by clicking the arrows at the top and
bottom edge.

• Click outside of the text entry box to exit the Text tool.

• Hide text by clicking the Actions menu and clicking Hide Text.

• Change the color of text.

Adjusting Variable Values with a Slider

A slider control lets you interactively adjust or animate the value of a numeric variable.
You can insert sliders in the Graphs, Geometry, Notes, and Data & Statistics
applications.

Horizontal slider for adjusting variable v1.
Minimized vertical slider for adjusting variable v2.

Note: TI-Nspire™ version 4.2 or higher is required for opening .tns files containing
sliders on Notes pages.

Inserting a Slider Manually

1. From a Graphs, Geometry, or Data & Statistics page, select Actions > Insert Slider.
—or—
From a Notes page, make sure the cursor is not in a math box or chem box, and
then select Insert > Insert Slider.

The Slider Settings screen opens.



2. Enter the desired values, and click OK.

The slider is displayed. On a Graphs, Geometry, or Data & Statistics page, handles
are displayed to let you move or stretch the slider.

To remove the handles and use the slider, click an empty
space in the work area. You can show the handles anytime by
selectingMove from the slider's context menu.

3. To adjust the variable, slide the pointer (or click the arrows on a minimized slider).

- You can use the Tab key to move the focus to a slider or to move from one
slider to the next. The color of the slider changes to show you when it has the
focus.

- When a slider has the focus, you can use the arrow keys to change the value of
the variable.

Working with the Slider

Use the options on the context menu to move or delete the slider, and to start or stop
its animation. You can also change the slider's settings.

1. Display the slider's context menu.
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2. Click an option to select it.

Automatic Sliders in Graphs

Sliders can be created for you automatically in the Graphs application and in the
analytic window of the Geometry application. You are offered automatic sliders when
you define certain functions, equations, or sequences that refer to undefined variables.

Inferential Statistics

You can explore hypothesis tests and probability distributions in the Data & Statistics
application after entering the data on a Lists & Spreadsheet page.

Drawing Inferential Statistics Plots

The following example uses the Draw option of the normCdf() function to plot a
distribution model.

1. On a Lists & Spreadsheet page, select the column-formula cell (second cell from
the top) in column A.

2. From the Statistics menu, click Distributions, and click Normal Cdf.



3. Type the plot parameters into the Normal Cdf wizard.

4. Select the Draw check box to see the distribution plotted and shaded in
Data & Statistics.

Note: The Draw option is not available for all distributions.

5. Click OK.

Exploring Inferential Statistics Plots

After drawing the plot in the previous example, you can explore the effect of changing
the upper bound.

▶ On the Data & Statistics plot, drag the vertical line that represents the upper bound
toward the left or right.

As you drag, the formula is updated and the shaded area is recalculated.
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Notes Application
The Notes application lets you create and share text documents using the TI-Nspire™
handheld and computer software. Use Notes to:

• Create study notes to reinforce learning, demonstrate your understanding of
classroom concepts, and to review for exams.

• Edit collaboratively by assigning different roles to individuals using your document
so that any edits appear in a different text format.

• Create and evaluate math expressions.

• Create correctly formatted chemical formulas and equations.

Adding a Notes Page

▶ To start a new document with a blank Notes page:

From the main File menu, click New Document, and then click Add Notes.

Handheld: Pressc, and select Notes .

▶ To add a Notes page in the current problem of an existing document:

From the toolbar, click Insert > Notes.

Handheld: Press~ and select Insert > Notes.

À Notes tools – Available anytime you are in the Notes work area.

Á Text formatting toolbar -- Lets you change size, color, bold, and other text
properties.

Â Notes work area -- The area where you type and format text.
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Using Templates in Notes

Use the options on the Templates menu to select a format for your Notes page.

Menu Option Function

 2: Templates

 1: Q&A
Creates a template to enter question and answer
text.

 2: Proof
Creates a template to enter statement and reason
text.

 3: Default Lets you type freeform text.

 4:Hide Answer
(Q&A)

Toggles to show or hide the Answer in a Q&A
format.

Selecting a Template

Complete the following steps to select and apply a template:

1. From the Notes menu, click .

2. From the menu, click the template you want to apply.

Handheld: From the Notes work area, pressb, and then press ► to display the
menu options.

The Notes page is displayed in the format you selected.

Using the Q&A Template

Use the Q&A template to create questions and answers. You can show or hide the
answer so you can create questions for review and hide the answers. When you use
the document as a study aid, you can verify that your answers are correct.

Press Tab to move the text cursor between the Question and Answer areas of the
template.

Using the Proof Template

The proof template provides an outline structure for statements and corresponding



reasons.

Press Tab to move the text cursor between the Statements and Reasons areas of the
template.

Formatting Text in Notes

Text formatting lets you apply visual properties, such as bold and italic, to your text.

• Ordinary text. Apply most combinations of bold, italic, underline, superscript,
subscript, and strikethrough formatting. Select font and font size for any character.

• Text in a math expression box. Apply formatting and enter math exponents and
math subscripts for variable names. Select font and font size. Font size affects all
text in the box.

• Text in a chemical equation box. Apply formatting. Select font and font size. Font
size affects all text in the box. Superscript and subscript are handled automatically.

Selecting Text

▶ Drag from the starting point to the ending point to select the text.

Handheld: If you are using the Q&A or Proof template, presse to place the
cursor in the area containing the text. Use the Touchpad to place the cursor at the
start or end of the text to be selected. Hold downg, and use the Touchpad to
select the text.

Applying a Text Format

1. Select the text that you want to format.

2. On the formatting toolbar, click the formatting icons (such as for bold) to toggle
them, or click to select a font and font size.

Handheld: Clickb, and then select Format > Format Text.
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The changes are applied to the text as you make selections.

Note: The toolbar shows only the icons that are applicable to the type of text
selected. For example, superscript ( ) and subscript ( ) are shown only for
ordinary text.

Using Color in Notes

When working in the Notes application on a desktop, use the (fill color) or the
(text color) options on the Documents Workspace toolbar to emphasize words,
calculations, and formulas.

You can also apply color to text when working in the Notes application on the
TI-Nspire™ CX handheld.

Changing Text Colors

1. Select the text you want to change to another color. You can select a sentence,
phrase, word, or a single letter. You can also select a math expression box, a
chemical equation box, or individual characters in a calculation, formula, chemical
equation, or math template.

2. From the Documents Workspace toolbar, click .

Handheld: Press~, and then click Edit > Text Color.

The Text Color palette opens.

3. Click a color to apply it to the selected text.

Applying a Background Color

You can apply a background color to highlight selected characters in ordinary text, text
in a math expression, or text in a chemical equation box.

1. Select the text.



2. From the Documents Workspace toolbar, click the arrow next to .

Handheld: Press~, and then press Edit > Fill Color.

The Fill Color palette opens.

3. Click a color to apply it to the selected text.

Inserting Images

When working in the Notes application on a desktop, use the Images option on the
Insert menu to add an image to a Notes page.

Note: The option for inserting an image is not available when working on a handheld.
However, you can transfer a file containing an image from your computer to a
TI-Nspire™ CX handheld.

1. Click Insert > Image from the Documents Toolbar.

The Insert Image window opens.

2. Navigate to the folder where the image is located.

3. Select the image, and then click Open to insert the image into the Notes work
area. Valid files types are .jpg, .png, or .bmp.

4. To type text around the image, place the cursor in front of the image or after the
image, and then type the text.

Resizing an Image

Complete the following steps to resize an image.

1. Click the image to select it.

2. Move the pointer to the edge of the image.

The pointer changes to a left-right arrow symbol.

3. Drag the image to make it smaller or larger.

For more information, see Working with Images.

Inserting Items on a Notes Page

When working with the Notes application, open the Insert menu to insert a math
expression, chemical equation, shape symbol, or a comment.

Menu
Name

Menu Option Function

 3: Insert
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Menu
Name

Menu Option Function

 1: Math Box
-/ M

Lets you insert a math expression.

 2: Chem box
-/ E

Lets you insert a chemical formula or equation.

 2: Shape
Marks the selected text as an angle, triangle, circle,
line, segment, ray, or vector.

 3:
Comment

Lets you type text that is italicized and prefaced with
Teacher or Reviewer.

Inserting Comments in Notes Text

You can insert Teacher or Reviewer comments into a Notes application. Comments are
easy to distinguish from the original text.

1. Define the type of comments you are inserting (Teacher or Reviewer):

• PC: From the Insert menu, click Comment, and then click Teacher or Reviewer.

• Handheld: While in the Notes work area, pressb to display the Notes
menu. Press Insert > Comment, and then select either Teacher or Reviewer.

2. Type your text.

Text that you type appears in italics.



Inserting Geometric Shape Symbols

You can use geometric shape symbols to designate selected text as geometric objects,
such as an angle, circle, or line segment.

To insert a shape symbol, position the cursor where you want it, and then do the
following:

• PC: From the Insert menu, click Shapes, and then select the shape to apply.

• Handheld: Pressb to display the Notes menu. On the Insert menu, click Shapes,
and then select the shape to apply.

Entering Math Expressions in Notes Text

You can include math expressions in Notes text, using the same tools as in other
TI-Nspire™ applications.

Math expression boxes have attributes that allow you to control how the expression is
displayed.

Menu
Name

Menu
Option

Function

5: Math Box

Options

 1:
Math Box
Attributes

When a math box is selected, this option opens a dialog box
allowing you to customize the math box. You can hide or show
input or output, turn off calculation for the box, insert symbols,
change display and angle settings, and allow or disallow the
wrapping of expressions and the display of warning indicator
after they have been dismissed. You can change the attributes
of multiple selected math boxes at the same time.
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Menu
Name

Menu
Option

Function

 2:
Show
Warning
Info

Displays a warning indicator after the warning has been
dismissed.

 3:
Show
Error

Displays an error after the error has been dismissed.

Entering an Expression

1. In the Notes work area, position the cursor where you want the expression.

2. From the Insert menu, select Math Box.
—or—
Press Ctrl + M (Mac®: Press “+ M).

An empty math expression box is displayed.

3. Type the expression in the box. You can use the Catalog, if necessary, to insert a
function, command, symbol, or expression template.

4. To exit the math box, click anywhere outside it.

Evaluating and Approximating Math Expressions

You can evaluate or approximate one or more expressions and display the results. You
can also convert selected text and multiple math expression boxes into a single math
expression box. Notes automatically updates expressions and any variables used.

Menu
Name

Menu Option Function

1: Actions

1: Evaluate -· Evaluates the expression.

 2: Approximate
/·

Approximates the expression.

3: Evaluate and
replace

Replaces the selected part of the expression
with the result.



Menu
Name

Menu Option Function

 4: Deactivate
Deactivates the current or selected item (box
or boxes)

5: Deactivate All Deactivates all boxes in the current Notes
application.

6: Activate Activates the current or selected previously
deactivated item.

 7: Activate All Activates all boxes in the current Notes
application.

Evaluating or Approximating an Expression

To evaluate or approximate an expression, place the cursor anywhere in the math
expression box and then do the following:

• Windows®: On the Actions menu, click Evaluate or Approximate. You can also use
Enter to evaluate or Ctrl + Enter to approximate.

• Mac®: Press “ + Enter to approximate.

• Handheld: Pressb to display the Notes menu. On the Actions menu, select
Evaluate.

The result replaces the expression.

Evaluating Part of an Expression

To evaluate part of an expression, select the text or part of the math expression. Then
do the following:

▶ On the Actions menu, click Evaluate and Replace.

Handheld: Pressb to open the Notes menu. Select Actions, and then select
Evaluate Selection.

The result replaces the selected part only.
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Breaking Long Calculations

Some calculations may take a long time. Notes indicates that the handheld is
performing a long calculation by displaying a busy icon. If a calculation is taking more
time than you want to spend, you can end the calculation.

To stop the function or program in progress, do the following:

• Windows®: Hold down the F12 key and press Enter repeatedly.

• Mac®: Hold down the F5 key and press Enter repeatedly.

• Handheld: Hold down thec key and press· repeatedly.

Showing Warnings and Errors

If a calculation in Notes results in a warning or error, you can view the warning or error
again even after you have dismissed the dialog box.

To display a warning or error in Notes after you have dismissed the dialog box, do one
of the following:

• Windows®: Right-click and select Show warning info or Show error.

• Mac®: “ + click and select Show warning info or Show error.

Note: You can change your settings so that warnings do not appear at all. The showing
of warning indicators is controlled by the Math Box Attributes dialog box. See Changing
the Attributes of Math Expression Boxes.

Converting Selected Items to Math Expression Boxes

To convert items to math expression boxes:

1. Select the text, or combination of text and existing math expression box, that you
want to evaluate.

2. From the Actions menu, click Convert to Math Expression Box.

Using Math Actions 

Math Actions are available on Notes, Scratchpad, and Calculator pages.

When you display the context menu for a selected expression or equation, the menu
may include a Math Actions submenu that lists the available actions. Each action might
prompt you for any needed parameters.

The specific math actions listed depend on:

• The type of expression or relation.



• The operating system in use (numeric or CAS).

• Any restrictions imposed by an active Press-to-Test session.

Example of Math Actions in Notes

1. Insert a math box, and type the equation x2+3x+1=0, but don't press Enter yet.

Numeric OS CAS OS

2. Display the context menu of the equation, and select Math Actions.
Windows®: Right-click the equation.
Mac®: Hold “, and click the equation.
Handheld: Point to the equation, and press/b.

Numeric OS CAS OS

3. Select the action to perform:

- Solve Numerically for numeric OS.
- Solve for CAS OS.

You are prompted to enter parameters. For example, Numeric Solve prompts for
the variable of interest, initial guess, lower bound, and upper bound.

4. Type a value for each parameter. When options are available, you can click an
arrow to make a selection.

Numeric OS CAS OS

5. Click OK to construct the completed expression and place it in the math box.

Numeric OS CAS OS

6. Press Enter to complete the action.
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Numeric OS CAS OS

7. As a further exploration, drag through the math box to select x2+3·x+1. Do not
include the "=0" portion.

Numeric OS CAS OS

8. Display the context menu for the selected text, select Math Actions >
Find Roots of Polynomial, and press Enter to complete the action.

The action and its result are shown in a new math box.

Numeric OS CAS OS

Tips for Using Math Actions in Notes

▶ For a previously evaluated expression, click in the expression and then display its
context menu.

When you select an action, it replaces the expression.

▶ For a displayed result, click in the result and then display its context menu.

When you select an action, it appears in a new math box.

▶ For a portion of an expression or result, select the portion, and then display the
context menu.

When you select an action, it appears in a new math box.

Graphing from Notes and Calculator 

You can graph a function or relation directly from its context menu. This feature is
available for many functions and relations on Notes, Scratchpad, and Calculator pages.



If page layout options allow, the graph appears on the same page as the function or
relation. Otherwise, the graph appears on a separate Graphs page.

The type of graph created depends on:

• The type of function or relation.

• Any restrictions imposed by an active Press-to-Test session.

Example of Graphing from Notes

This example uses a Notes page to explore a quadratic function interactively.

1. Insert a math box on a new Notes page, and enter the following function
definition:

Define f1(x)=x2-1·x-4

2. Display the context menu of the Define statement.
Windows®: Right-click the statement.
Mac®: Hold “, and click the statement.
Handheld: Point to the statement, and press/b.

3. Select Graph from the context menu.

The graph appears. The graph and the math box are linked so that any adjustment
to one affects the other.
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4. Explore the relationship between the defined function and its graph:

- Drag the ends or center of the graph to manipulate it, and observe the changes
to the function definition.

—or—

- Edit the defined function in the math box, and observe the changes to the
graph.

Inserting Chemical Equations in Notes

Chemical equation boxes (chem boxes) make it easy to type chemical formulas and
equations, such as .

As you type in a chem box, most of the formatting work is handled automatically:

• Correct capitalization of most element symbols, such as Ag and Cl, is automatic.

• Leading digits are treated as coefficients and are shown at full size. Numbers that
follow an element or a closed parenthesis are converted to subscripts.

• The equals “=” symbol is converted to a yields “&” symbol.

Notes:

• Equations in a chem box cannot be evaluated or balanced.

• Element capitalization may not work in every situation. For example, to enter
carbon dioxide, CO

2
, you must manually capitalize the O. Otherwise, typing “co”

would result in“Co,” the symbol for cobalt.

Entering a chemical equation

1. In the Notes work area, position the cursor where you want the equation.



2. From the Insert menu, select Chem Box.
—or—
Press Ctrl + E (Mac®: Press “+ E).

An empty chemical equation box is displayed.

3. Type the equation in the box. For example, to represent sulphuric acid, type
h2sO4, capitalizing the O manually.

The chem box automatically formats the text as you type:

4. If you need superscripts for ionic equations, type a caret symbol (^) and then the
text.

5. Use parentheses to indicate whether a compound is solid (s), liquid (l), gas (g), or
aqueous (aq).

6. To exit the chem box, click anywhere outside it.

Deactivating Math Expression Boxes

Calculations are by default activated, which means that results automatically update
when you evaluate or approximate an expression. If you don’t want results to
automatically update, you can deactivate a math expression box, group of boxes, or the
entire application.

Deactivating a Box or a Group of Boxes

To deactivate a box or a group of boxes:

1. Select the box or boxes that you want to deactivate.

2. Deactivate the selected box or boxes:

• Windows®: Click Actions > Deactivate (or right-click and then click Actions >
Deactivate).

• Mac®: Click Actions > Deactivate (or “ + click and then click Actions >
Deactivate).

• Handheld: Pressb to open the Notes menu. From the Actions menu, select
Deactivate.
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Note: You can manually update a deactivated box or boxes by selecting the box or
boxes and using the process described in Evaluating and Approximating Math
Expressions.

Deactivating All Boxes in the Notes Application

To deactivate all boxes in the Notes application:

▶ With a document open, place your cursor in the Notes application that you want to
deactivate and select Deactivate All.

• Windows®: Click Actions > Deactivate All or right-click and click Actions >
Deactivate All.

• Mac®: Click Actions > Deactivate or “+ click and click Actions > Deactivate.

• Handheld: Pressb to display the Notes menu. On the Actions menu, click
Deactivate.

Note: When you use this option in Q&A and Proof templates, Deactivate All
deactivates only the math boxes in the current work area.

Changing the Attributes of Math Expression Boxes

You can change attributes in one or more math expression boxes at the same time.
Controlling the attributes in math expression boxes allows you to do the following:

• Show or hide the input or output, or prevent calculation in the box.

• Select a symbol separator using Insert Symbol.

• Choose the number of digits to display in the output of a math expression.

• Select angle settings so you can use a combination of radian, degree, and gradian
angle measures in the same Notes application.

• Select whether to allow math expressions to wrap.

• Select whether to show or hide warning indicators.

To change the attributes of one or more boxes, do the following:

1. Select the box or boxes that you want to change.

2. On the Math Box Options menu, clickMath Box Attributes.

3. Use the menus or selection boxes to make your selections.

4. Click OK to save or Cancel to abandon the change.

Note: Math expression boxes recalculate automatically after you have made attribute
changes and saved the changes.

Undoing Changes to Math Expression Boxes

▶ To undo changes you have made to a math expression box, press Ctrl+Z.



Using Calculations in Notes

In the Notes application, the options on the Calculations menu enable you to perform
calculations. The calculations are described in the following table.

Important Information to Know

• Notes does not support editing programs. Use Program Editor instead.

• Notes does not support executing Lock or Unlock commands. Use Calculator
instead.

• Notes does not display intermediate results obtained using the "Disp" command.
Use Calculator instead.

• Notes does not support user-defined dialog boxes obtained using the "Request,"
"RequestStr," or "Text" commands. Use Calculator instead.

• Notes does not support the execution of multiple statistics commands that produce
stat. variables.

Menu
Name

Menu
Option

Function

6: Calculations

 1:
Define
Variables

Define a variable in a Note using the Calculator application.

 2:
Number

Use tools from the Calculator Number menu, including Convert
to Decimal, Approximate to Fraction, Factor, Least Common
Multiple, Greatest Common Divisor, Remainder, Fraction
Tools, Number Tools, and Complex Number Tools.

 3:
Algebra

Use tools from the Calculator Algebra menu, including
Numerical Solve, Solve System of Linear Equations, Polynomial
Tools.

 4:
Calculus

Use tools from the Calculus menu including Numerical
Derivative at a Point, Numerical Definite Integral, Sum,
Product, Numerical Function Minimum, and Numerical
Function Maximum.

 3
(CAS):
Algebra

Use tools from the Calculator Algebra menu, including Solve,
Factor, Expand, Zeros, Numerical Solve, Solve System of
Equations, Polynomial Tools, Fraction Tools, Convert
Expressions, Trigonometry, Complex, and Extract.

 4
Use tools from the Calculus menu including Derivative,
Derivative at a Point, Integral, Limit, Sum, Product, Function
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Menu
Name

Menu
Option

Function

(CAS):
Calculus

Minimum, Function Maximum, Tangent Line, Normal Line, Arc
Length, Series, Differential Equation Solver, Implicit
Differentiation, and Numerical Calculations

 5:
Probability

Use tools from the Calculator Probability menu, including
Factorial, Permutations, Combinations, Random, and
Distributions.

 6:
Statistics

Use tools from the Calculator Statistics menu, including Stat
Calculations, Stat Results, List Math, List Operations, and
others.

 7:
Matrix &
Vector

Use tools from the Calculator Matrix & Vector menu, including
Create, Transpose, Determinant, Row-Echelon Form, Reduced
Row-Echelon Form, Simultaneous, and others.

 8:
Finance

Use tools from the Calculator Finance menu, including Finance
Solver, TVM Functions, Amortization, Cash Flows, Interest
Conversions, and Days between Dates.

Note: For more information, see the Calculator chapter.

Exploring Notes with Examples

This section shows you how the Notes application works with other applications to
automatically update results.

Example #1: Using Notes to Explore Roots of a Quadratic Function

1. Open a new document and select the Notes application.

2. Define a function in a math box, evaluate, and hide the output using the Math Box
attributes.



3. Type some more text; for example: Real Roots of f1(x) are:

4. In a new math box, type: polyRoots(f1(x),x).

5. Press Enter and hide the input of this math box by using the Math Box attributes
dialog box.

6. Use the Page Layout toolbar icon to select the split layout.

7. Add the Graph application and plot f1(x).

See how the roots of f1 change when the function is modified in Graph.
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Example #2: Using Notes to Explore Data Sampling

This example shows how to create a sampling distribution of sample means drawn
from a given population. We will be able to watch the sampling distribution take shape
for a given sample size and describe its characteristics. You can change the population
and the sample size.

1. Set up the population and the sample size.

a) Type Create sample data:

b) Insert a math expression box and define the population. For example, type
population:=seq(n,n,1,50).

c) Press Enter and hide the output using the Math Expression Box Attributes
dialog box.

d) Insert a math expression box and define the sample size. For example, type
size:=5.

e) Press Enter and hide the output using the Math Expression Box Attributes
dialog box.

2. Set up the initialization.

a) Type Start taking samples:

b) Insert a math expression box and set the initial values for the number of
samples (num) and the list of sample means (sampmeans). Type:

num:=0:sampmeans:={}

c) Press Enter and hide the output using the Math Expression Box Attributes
dialog box.



d) Deactivate the math expression box using Actions > Deactivate. The
deactivation will prevent the content of that math box from being overwritten
when the values for num and sampmeans change. The deactivated math box
will be shown with the light color background.

3. Set up Data & Statistics for the sampling.

a) Change the page layout and insert Data & Statistics.

b) Click on the horizontal axis and add sampmeans list.

c) Change the window setting: XMins=1 and XMax = 50.

d) You can also set up the plot of the mean of sample means using Analyze > Plot
Value.

4. Enter the instructions to add data.

a) Type Create new samples:

b) Insert a math expression to define the sample (sample) and update the
number of samples and the list of sample means. Type:

num:=num+1:sample:=randsamp(population,size):
sampmeans:=augment(sampmeans,{mean(sample)})

c) Press Enter, hide the output, and turn off the expression wrapping using the
Math Expression Box Attributes dialog box.
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d) Deactivate the math expression box using Actions > Deactivate to prevent the
contents of the math box from changing when num and sampmeans values are
reinitialized.

e) Create math expression boxes that display the current number of experiments
(num), sample (sample), and the list of sample means (sampmeans).

5. Now you are ready to explore. Add more samples by simply pressing Enter when
you are in the math expression box in the "Create new samples" section.

Note: You can also automate the sampling process by using a For ... EndFor loop.



You can also change the sample size and restart the sampling.
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Data Collection
The Vernier DataQuest™ application is built into the TI-Nspire™ software and the
operating system (OS) for handhelds. The application lets you:

• Capture, view, and analyze real-world data using a TI-Nspire™ handheld, a
Windows® computer, or a Mac® computer.

• Collect data from up to five connected sensors (three analog and two digital) using
the TI-Nspire™ Lab Cradle.

Important: The TI-Nspire™ CM-C Handheld is not compatible with the Lab Cradle
and only supports the use of a single sensor at a time.

• Collect data either in the classroom or at remote locations using collection modes
such as time-based or event-based.

• Collect several data runs for comparison.

• Create a graphical hypothesis using the Draw Prediction feature.

• Play back the data set to compare the outcome to the hypothesis.

• Analyze data using functions such as interpolation, tangential rate, or modeling.

• Send collected data to other TI-Nspire™ applications.

• Access sensor data from all connected sensor probes through your TI-Basic
program.

Adding a Vernier DataQuest™ Page

Note: The application is launched automatically when you connect a sensor.

Starting a new document or problem for each new experiment ensures that the
Vernier DataQuest™ application is set to its default values.

▶ To start a new document containing a data collection page:

From the main File menu, click New Document, and then click Add Vernier
DataQuest™.

Handheld: Pressc, and select Vernier DataQuest™ .

▶ To insert a new problem with a data collection page into an existing document:

From the toolbar, click Insert > Problem>Vernier DataQuest™.

Handheld: Press~ and select Insert > Problem > Vernier DataQuest™.
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À Vernier DataQuest™ Menu. Contains menu items for setup, collection, and
analysis of sensor data.

Á Details view. Contains buttons for starting data collection  , changing
collection settings  , marking collected data  , storing data sets  , and
tabs for managing multiple data runs.
View selection buttons let you choose from Meter view  , Graph view ,
or Table view .

Â Data work area. The information displayed here depends on the view.
Meter. Displays a list of sensors that are currently connected or set up in
advance.
Graph. Displays collected data in a graphical representation, or displays the
prediction before a data collection run.
Table. Displays collected data in columns and rows.

What You Must Know

Basic Steps in Performing an Experiment

These basic steps are the same no matter which type of experiment you perform.

1. Start the Vernier DataQuest™ Application.

2. Connect sensors.

3. Modify sensor settings.

4. Select the collection mode and collection parameters.

5. Collect data.

6. Stop collecting data.

7. Store the data set.

8. Save the document to save all data sets in the experiment.

9. Analyze the data.



Sending Collected Data to Other TI-Nspire™ Applications

You can send collected data to the Graphs, Lists & Spreadsheet, and Data & Statistics
applications.

▶ From the Send To menu, click the name of the application.

A new page showing the data is added to the current problem.

About Collection Devices

You can select from a variety of sensors and interfaces to collect data while running
the Vernier DataQuest™ application with TI-Nspire™ software.

Multi-Channel Sensor Interfaces

Multi-channel sensor interfaces let you connect more than one sensor at a time.

Sensor Interface Description

Texas
Instruments
TI-Nspire™ Lab
Cradle

This sensor can be used with a handheld, a computer, or as a
stand-alone sensor.
The sensor interface allows you to connect and use one to five
sensors at the same time. It can be used in the lab or at a
remote collection location.
The Lab Cradle supports two digital sensors and three analog
sensors.
The Lab Cradle also supports high-sample data collection
sensors, such as a hand-grip heart rate or a blood pressure
monitor.
After using the Lab Cradle as a remote sensor, you can download
data to either a handheld or computer.

Single-Channel Sensor Interfaces

Single-channel sensor interfaces can only connect to one sensor at a time. These
sensors have either a mini-USB connector for a handheld or a standard USB connector
for a computer. For a complete list of compatible sensors, see Compatible Sensors.
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Sensor Interface Description

Vernier EasyLink®

This sensor interface is used with handhelds. It has a
mini-USB connector so it can be plugged directly into
the handheld.
Connect sensors to Vernier EasyLink® to:

• Measure barometric pressure.

• Measure the salinity of a solution.

• Investigate the relationship between pressure
and volume (Boyles’ Law).

Vernier Go!Link®

This sensor interface is used with computers. It has a
standard connector so it can be plugged into a
Windows® or Mac® computer.
Connect sensors to Vernier GoLink® to:

• Measure the acidity or alkalinity of a solution.

• Monitor greenhouse gases.

• Measure sound level in decibels.

Types of Sensors

• Analog sensors. Temperature, light, pH, and voltage sensors are analog sensors and
require a sensor interface.

• Digital sensors. Photogates, radiation monitors, and drop counters are digital
sensors. These sensors can only be used with the TI-Nspire™ Lab Cradle.

• Direct-connect USB sensors. These sensors connect directly to a handheld or
computer and do not require a sensor interface.

Sensors for Handhelds

The following lists some sensors you can use with a handheld.

Sensor Description

Texas Instruments

This analog sensor connects directly to TI-Nspire™
handhelds through the mini-USB port. It is used to explore
and graph motion.
This sensor automatically launches the Vernier DataQuest™
application when you connect it to a handheld. Data
collection begins when you select the Motion Match
function.
This sensor collects up to 200 samples per second.
Use this sensor to:

• Measure position and speed of a person or object.



Sensor Description

CBR 2™ • Measure the acceleration of an object.

Vernier EasyTemp®
temperature sensor

This analog sensor connects directly to TI-Nspire™
handhelds through the mini-USB port and is used to collect
temperature ranges. You can design experiments to:

• Collect weather data.

• Record temperature changes due to chemical
reactions.

• Perform heat fusion studies.

Sensors for Computers

The following table lists some sensors you can use with a computer.

Sensor Description

Vernier Go!Temp®
temperature sensor

This analog sensor connects to the computer’s USB
port and is used to collect temperature ranges.
You can use this sensor to:

• Collect weather data.

• Record temperature changes due to chemical
reactions.

• Perform heat fusion studies.

Vernier Go!Motion® motion
detector

This analog sensor connects to the computer’s USB
port and is used to measure acceleration, speed, and
velocity.
Use this sensor to:
• Measure position and speed of a person or

object.
• Measure the acceleration of an object.

Compatible Sensors

The following sensors can be used with the Vernier DataQuest™ application.

• 25-g Accelerometer

• 30-Volt Voltage Probe
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• 3-Axis Accelerometer

• Low-g Accelerometer

• CBR 2™ - Connects directly to handheld USB port

• Go!Motion® - Connects directly to computer USB port

• Extra Long Temperature Probe

• Stainless Steel Temperature Probe

• Surface Temperature Sensor

• Ammonium Ion-Selective Electrode

• Anemometer

• Barometer

• Blood Pressure Sensor

• C02 Gas Sensor

• Calcium Ion-Selective Electrode

• Charge Sensor

• Chloride Ion-Selective Electrode

• Colorimeter

• Conductivity Probe

• High Current Sensor

• Current Probe

• Differential Voltage Probe

• Digital Radiation Monitor

• Dissolved Oxygen Sensor

• Dual-Range Force Sensor

• EasyTemp® - Connects directly to handheld USB port

• EKG Sensor

• Electrode Amplifier

• Flow Rate Sensor

• Force Plate

• Gas Pressure Sensor

• Go!Temp® - Connects directly to computer USB port

• Hand Dynamometer

• Hand-Grip Heart Rate Monitor

• Instrumentation Amplifier

• Light Sensor

• Magnetic Field Sensor



• Melt Station

• Microphone

• Nitrate Ion-Selective Electrode

• O2 Gas Sensor

• ORP Sensor

• pH Sensor

• Relative Humidity Sensor

• Respiration Monitor Belt (Requires Gas Pressure Sensor)

• Rotary Motion Sensor

• Salinity Sensor

• Soil Moisture Sensor

• Sound Level Meter

• Spirometer

• Thermocouple

• TI-Light - Sold only with the CBL 2™

• TI-Temp - Sold only with the CBL 2™

• TI-Voltage - Sold only with the CBL 2™

• Tris-Compatible Flat pH Sensor

• Turbidity Sensor

• UVA Sensor

• UVB Sensor

• Vernier Constant Current System

• Vernier Drop Counter

• Vernier Infrared Thermometer

• Vernier Motion Detector

• Vernier Photogate

• Voltage Probe

• Wide-Range Temperature Probe

Connecting Sensors

Direct-connect USB sensors, such as the Vernier Go!Temp® temperature sensor (for
computers) or the Vernier EasyLink® temperature sensor (for handhelds), connect
directly to the computer or handheld and do not need a sensor interface.

Other sensors require a sensor interface such as the TI-Nspire™ Lab Cradle.
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Connecting Directly

▶ Attach the cable on the sensor directly to the computer's USB port or to an
appropriate port on the handheld.

Connecting through a Sensor Interface

1. Attach the sensor to the sensor interface using either the mini-USB, USB, or BT
connector and the appropriate cable.

2. Attach the interface to a computer or handheld using the appropriate connector
and cable.

Note: To attach a handheld to a TI-Nspire™ Lab Cradle, slide the handheld into the
connector at the bottom of the Lab Cradle.

Setting Up an Offline Sensor

You can predefine meter settings for a sensor that is not currently attached to a
computer or handheld.

You cannot use the sensor offline, but you can prepare the experiment for it and then
attach it when ready to collect the data. This option makes it faster to share a sensor
during a lesson or lab in which there are not enough sensors for everyone.

1. From the Experiment menu, select Advanced Set Up > Configure Sensor > Add
Offline Sensor.

The Select Sensor dialog box opens.

2. Select a sensor from the list.

3. Click the Meter View tab .

4. Click the sensor you have added, and modify its settings.

The settings will be applied when you attach the sensor.

Removing an offline sensor

1. From the Experiment menu, select Advanced Setup > Configure Sensor.



2. Select the name of the offline sensor to remove.

3. Click Remove.

Modifying Sensor Settings

You can modify how the sensor values are displayed and stored. For example, when
using a temperature sensor, you can change the unit of measure from Centigrade to
Fahrenheit.

Changing Sensor Measurement Units

Measurement units depend on the selected sensor. For example, units for the Vernier
Go!Temp® Temperature sensor are Fahrenheit, Celsius, and Kelvin. Units for the
Vernier Hand Dynamometer (a specialized force sensor) are Newton, Pound, and
Kilogram.

You can change the units before or after you collect data. The collected data reflects
the new measurement unit.

1. Click Meter view  to display the connected and offline sensors.

2. Click the sensor whose units you want to change.

3. In the Meter Settings dialog box, select the unit type from the Measurement Units
menu.
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Calibrating a Sensor

When the software or handheld detects a sensor, the calibration for that sensor
automatically loads. You can calibrate some sensors manually. Other sensors, such as
the Colorimeter and the Dissolved Oxygen Sensor, must be calibrated to provide useful
data.

There are three options for calibrating a sensor:

• Manual Entry

• Two Point

• Single Point

Refer to the sensor’s documentation for specific calibration values and procedures.

Setting a Sensor to Zero

You can set the standing value of some sensors to zero. You cannot set sensors in
which relative measurements such as force, motion, and pressure are common to zero.
Sensors designed to measure specific environmental conditions, such as Temperature,
pH, and CO

2
also cannot be set to zero.

1. Click Meter view  to display the connected and offline sensors.

2. Click the sensor that you want to set to zero.

3. In the Meter Settings dialog box, click Zero.

Reversing a Sensor's Readings

By default, pulling with a force sensor produces a positive force and pushing produces
a negative force. Reversing the sensor allows you to display pushing as a positive force.

1. Click Meter view  to display the connected and offline sensors.

2. Click the sensor that you want to reverse.

3. In the Meter Settings dialog box, click Reverse Readings.

The sensor display is now reversed. In Meter View, the reverse indicator
appears after the sensor name.



Collecting Data

Collecting Time-Based Data

The Time Based collection mode captures sensor data automatically at regular time
intervals.

1. Connect the sensor or sensors.

Sensor names are added to the sensor list automatically.

2. From the Experiment menu, select New Experiment.

This removes all data and restores all meter settings to their defaults.

3. From the Experiment menu, select Collection Mode > Time Based.

a) Select Rate or Interval from the drop-down list, and then type the Rate
(samples/second) or Interval (seconds/sample).

b) Type the Duration of the collection.

The Number of points is calculated and displayed, based on rate and duration.
Note that collecting too many data points can slow system performance.

c) Select Strip Chart if you want to collect samples continuously, retaining only the
last n samples. (where “n” is the number shown in the Number of points field.)

4. Modify sensor settings as necessary.

5. Click Start Collection .

6. After the data has been collected, click Stop Collection .

The data set run is complete.

Collecting Selected Events

Use the Selected Events collection mode to capture samples manually. In this mode,
each sample is automatically assigned an event number.

1. Connect the sensor or sensors.

Data Collection 427



428 Data Collection

Sensor names are added to the sensor list automatically.

2. From the Experiment menu, select New Experiment.

This removes all data and restores all meter settings to their defaults.

3. From the Experiment menu, select Collection Mode > Selected Events.

The Selected Events Setup dialog box opens.

- Name. This text is visible in the Meter View. Its first letter is displayed as the
independent variable in the Graph view.

- Units. This text is displayed in Graph view alongside the Name.

- Average over 10 s. This option averages ten seconds of data for each point.

4. Modify sensor settings as necessary.

5. Click Start Collection .

The Keep Current Reading icon becomes active. The current sensor value

appears in the center of the graph.

6. Click Keep Current Reading to capture each sample.

The data point is plotted, and the current sensor value appears in the center of the
graph.

Note: If you selected the Averaging option, a countdown timer appears. When the
counter reaches zero, the system plots the average.

7. Continue capturing until you collect all of the desired data points.

8. Click Stop Collection .

The data set run is complete.

Collecting Events with Entry

Use the Events with Entry collection mode to capture samples manually. In this mode,
you define the independent value for each point you collect.

1. Connect the sensor or sensors.

Sensor names are added to the sensor list automatically.

2. From the Experiment menu, select New Experiment.

This removes all data and restores all meter settings to their defaults.



3. From the Experiment menu, select Collection Mode > Events with Entry.

The Events with Entry Setup dialog box opens.

- Name. This text is visible in the Meter View. Its first letter is displayed as the
independent variable in the Graph view.

- Units. This text is displayed in Graph view alongside the Name.

- Average over 10 s. This option averages ten seconds of data for each point.

4. Modify sensor settings as necessary.

5. Click Start Collection .

The Keep Current Reading icon becomes active. The current sensor value

appears in the center of the graph.

6. Click Keep Current Reading to capture a sample.

The Events with Entry dialog box opens.

7. Type a value for the independent variable.

8. Click OK.

The data point is plotted, and the current sensor value appears in the center of the
graph.

Note: If you selected the Averaging option, a countdown timer appears. When the
counter reaches zero, the system plots the average.

9. Repeat steps 6 through 8 until you collect all of the desired data points.

10. Click Stop Collection .

The data set run is complete.
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Collecting Photogate Timing Data

The Photogate Timing collection mode is available only when using the Vernier
Photogate sensor. This sensor can time objects that pass through the gates or objects
that pass outside of the gates.

1. Connect the Photogate sensor or sensors.

Sensor names are added to the sensor list automatically.

2. From the Experiment menu, select New Experiment.

This removes all data and restores all meter settings to their defaults.

3. From the Experiment menu, select Collection Mode > Photogate Timing.

4. Set the collection options.

5. Modify sensor settings as necessary.

6. Click Start Collection .

7. After the data has been collected, click Stop Collection .

The data set run is complete.

Collecting Drop Counter Data

The Drop Counting collection mode is available only when using the Vernier Drop
Counter optical sensor. This sensor can count the number of drops or record the
amount of liquid added during an experiment.

1. Connect the Drop Counter sensor or sensors.

Sensor names are added to the sensor list automatically.

2. From the Experiment menu, select New Experiment.

This removes all data and restores all meter settings to their defaults.

3. From the Experiment menu, select Collection Mode > Drop Counting.

4. Set the collection options.

5. Modify sensor settings as necessary.

6. Click Start Collection .

7. After the data has been collected, click Stop Collection .

The data set run is complete.



Using Data Markers to Annotate Data

Data markers give you a way to emphasize specific data points, such as when you
change a condition. For example, you might mark a point at which a chemical is added
to a solution or when heat is applied or removed. You can add a marker with or
without a comment, and you can hide a comment.

Twodatamarkers, one with a comment displayed

Marker shownas red triangle in Table view

Adding a Marker During Data Collection

▶ Click Add Data Marker to place a marker at the current data point.

Adding a Marker After Collecting Data

1. In Graph or Table view, click the point at which you want a marker.

2. Click Add Data Marker .
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3. Complete the items in the dialog box.

Adding a Comment to an Existing Marker

1. In the Detail view, click to expand the list of markers for the data set.

2. Click the entry for the marker that you want to change, and complete the items in
the dialog box.

Repositioning a Data Marker

1. Click to expand the list of markers in the Detail view.



2. Click the entry for the marker that you want to change.

3. In the dialog box, type a new value forMark Value at.

Moving a Data Marker's Comment in the Graph View

▶ Drag the comment to move it. The connecting line remains attached to the data
point.

Hiding/Showing a Data Marker's Comment

▶ Hide a comment by clicking the X at the end of the comment.

▶ To restore a hidden comment:

a) Click to expand the list of markers in the Detail view.

b) Click the entry for the marker that you want to change, and check
Show Comment on Graph.

Removing a Data Marker

1. Click to expand the list of markers in the Detail view.

2. In the dialog box, click Remove.

Collecting Data Using a Remote Collection Unit

To collect information from a sensor while it is disconnected, you can set it up as a
remote sensor. Only the TI-Nspire™ Lab Cradle, TI CBR 2™, and Vernier Go!Motion®
support remote data collection.

You can set up a remote collection unit to start collecting:

• When you press a manual trigger on the unit, as on the TI-Nspire™ Lab Cradle
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• When a delay countdown expires on a unit that supports a delayed start

Setting Up for Remote Collection

1. Save and close any open documents, and start with a new document.

2. Connect the remote collection unit to the computer or handheld.

3. Modifying Sensor Settings.

4. Click the Collection Setup button .

5. On the Collection Setup screen, check Enable Remote Collection.

6. Select the remote collection unit from the Devices list.

7. Specify the method for starting the collection:

• To start automatically after a specified delay (on supported units), type the
delay value.

• To start when you press the manual trigger (on supported units), type a delay
value of 0. When you use a delay, the manual trigger button on the TI-Nspire™
Lab Cradle has no effect on the start of the collection.

8. Click OK.

A message confirms that the unit is ready.



9. Disconnect the unit.

Depending on the device, LED lights may indicate its status.

Red. The system is not ready.

Amber. The system is ready but not collecting data.

Green. The system is collecting data.

10. If you are starting collection manually, press the trigger when ready. If you are
starting based on a delay, the collection will start automatically when the
countdown is complete.

Retrieving the Remote Data

After collecting data remotely, you transfer it to the computer or handheld for analysis.

1. Open the Vernier DataQuest™ application.

2. Attach the TI-Nspire™ Lab Cradle to the handheld or computer.

The Remote Data Detected dialog box opens.

3. Click Import.

The data transfers to the Vernier DataQuest™ application.

Setting Up a Sensor for Automatic Triggering

To start data collection automatically based on a specific sensor reading, the
TI-Nspire™ Lab Cradle and sensor must be connected.
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1. Connect the sensor.

2. Click Experiment > Advanced Set up > Triggering > Set Up.

The Configure Trigger dialog box opens.

3. Select the sensor from the Select the sensor to use as trigger drop-down list.

Note: The menu displays the sensors connected to the TI-Nspire™ Lab Cradle.

4. Select one of the following from the Select the type of trigger to use drop-down
list.

• Increasing through threshold. Use to trigger on increasing values.
• Decreasing through threshold. Use to trigger on decreasing values.

5. Type the appropriate value in the Enter the trigger threshold in units of the selected
sensor field.

When entering the trigger value, enter a value within the range of the sensor.

If you change the unit type after setting the threshold, the value automatically
updates.

For example, if you use the Vernier Gas Pressure sensor with the units set as atm
and you later change the units to kPa, the settings are updated.

6. Type the number of data points to keep before the trigger value occurs.

7. Click OK.

The trigger is now set and enabled if values were entered.

8. (Optional) Select Experiment > Advanced Set up > Triggering to verify the active
indicator is set to Enabled.



Important: When the trigger is enabled, it stays active until it is disabled or you
start a new experiment.

Enabling a Disabled Trigger

If you set the trigger values in the current experiment, and then disable them, you can
enable the triggers again.

To enable a trigger:

▶ Click Experiment > Advanced Set Up > Triggering > Enable.

Disabling an Enabled Trigger

To disable the active trigger.

▶ Click Experiment > Advanced Set Up > Triggering > Disable.

Collecting and Managing Data Sets

By default, the Start Collection button  overwrites collected data with data from
the next run. To preserve each run, you can store it as a data set. After collecting
multiple data sets, you can superimpose any combination of them on the Graph View.

Important: Stored data sets are lost if you close the document without saving it. If you
want stored data to be available later, make sure to save the document.

Storing Data as Sets

1. Collect the data from the first run. (See Collecting Data.)

2. Click the Store Data Set button .

The data is stored as run1. A new data set, run2, is created for collecting the next
run.

3. Click Start Collection to collect data for run2.
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Comparing Data Sets

1. Click the Graph View icon to show the graph.

2. Click the Data Set Selector (near the top of the Detail View) to expand the list of
data sets.

À Data Set Selector lets you expand or collapse the list.

Á Expanded list shows available data sets. Scroll buttons appear as necessary
to let you scroll the list.

3. Choose which data sets to view by selecting or clearing the check boxes.

The graph is rescaled as necessary to show all selected data.



Tip: To quickly select a single data set, hold down Shift while clicking its name in
the list. The graph shows only the selected set, and the list is collapsed
automatically to help you view details of the data.

Renaming a Data Set

By default, data sets are named run1, run2, and so on. The name of each data set is
displayed in the Table view.

1. Click the Table View icon to show the table.

2. Display the context menu for the table view, and select Data Set Options > [current
name].

3. Type the new Name.

Note: The maximum character limit is 30. The name cannot contain commas.

4. (Optional) Type Notes about the data.

Deleting a Data Set

1. Click the Graph View icon to show the graph.

2. Click the Data Set Selector (near the top of the Detail View) to expand the list of
data sets.

3. Scroll the list as necessary, and then click the Delete symbol (X) next to the name
of the data set.
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4. Click OK on the confirmation message.

Expanding the View Details Area

▶ Drag the boundary at the right edge of the Details area to increase or decrease its
width.

Using Sensor Data in ProgramsI

You can access sensor data from all connected sensor probes through your TI-Basic
program by using this command:

RefreshProbeVars statusVar
• You must first launch the Vernier DataQuest™ application, or you will receive an

error.

Note: The Vernier DataQuest™ application will auto-launch when you connect a
sensor or a lab cradle to the TI-Nspire™ software or handheld.

• The RefreshProbeVars command will be valid only when Vernier DataQuest™ is in

'meter' mode.
• statusVar is an optional parameter that indicates the status of the command.

These are the statusVar values:

StatusVar
Value

Status

statusVar
=0

Normal (continue with the program)

statusVa
r=1

The Vernier DataQuest™ application is in data collection mode.
Note: The Vernier DataQuest™ application must be in meter mode for

this command to work.

statusVar
=2

The Vernier DataQuest™ application is not launched.



StatusVar
Value

Status

statusVar
=3

The Vernier DataQuest™ application is launched, but you have not
connected any probes.

• Your TI-Basic program will read directly from Vernier DataQuest™ variables in the
symbol table.

• The meter.time variable shows the last value of the variable; it does not update
automatically. If no data collection has occurred, meter.time will be 0 (zero).

• Use of variable names without corresponding probes being physically attached will
result in a "Variable not defined" error.

Collecting Sensor Data using RefreshProbeVars
1. Launch the Vernier DataQuest™ application.

2. Connect the sensor(s) you need to collect the data.

3. Run the program you wish to use to collect data in the calculator application.

4. Manipulate the sensors and collect the data.

Note: You may create a program to interact with the TI-Innovator Hub usingb > Hub
> Send. (See Example 2, below.) This is optional.

Example 1

Define temp()=
Prgm
© Check if system is ready
RefreshProbeVars status
If status=0 Then
Disp "ready"
For n,1,50
RefreshProbeVars status
temperature:=meter.temperature
Disp "Temperature: ",temperature
If temperature>30 Then
Disp "Too hot"
EndIf
© Wait for 1 second between samples
Wait 1
EndFor
Else
Disp "Not ready. Try again later"
EndIf
EndPrgm

Example 2- with TI-Innovator™ Hub

Define tempwithhub()=
Prgm
© Check if system is ready
RefreshProbeVars status
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If status=0 Then
Disp "ready"
For n,1,50
RefreshProbeVars status
temperature:=meter.temperature
Disp "Temperature: ",temperature
If temperature>30 Then
Disp "Too hot"
© Play a tone on the Hub
Send "SET SOUND 440 TIME 2"
EndIf
© Wait for 1 second between samples
Wait 1
EndFor
Else
Disp "Not ready. Try again later"
EndIf
EndPrgm

Analyzing Collected Data

In the Vernier DataQuest™ application, use Graph View to analyze data. Start by
setting up graphs, and then use analysis tools such as integral, statistics, and curve fit
to investigate the mathematical nature of the data.

Important: The Graph menu and Analyze menu items are only available when working
in Graph View.

Finding the Area Under a Data Plot

Use Integral to determine the area under a data plot. You can find the area under all of
the data or a selected region of the data.

To find the area under a data plot:

1. Leave the graph unselected to examine all the data, or select a range to examine a
specific area.

2. Click Analyze > Integral.

3. Select the plotted column name if you have more than a single column.

The data plot area is displayed in the View Details area.

Finding the Slope

Tangent displays a measure of the rate at which the data is changing at the point you
are examining. The value is labeled “Slope.”

To find the slope:



1. Click Analyze > Tangent.

A check mark appears in the menu next to the option.

2. Click the graph.

The examine indicator is drawn to the nearest data point.

The values of the plotted data are shown in the View details area and the All
Details for Graph dialog box.

You can move the examine line by dragging, clicking another point, or using the
arrow keys.

Interpolating the Value Between Two Data Points

Use Interpolate to estimate the value between two data points and to determine the
value of a Curve Fit between and beyond these data points.

The examine line moves from data point to data point. When Interpolate is on, the
examine line moves between and beyond data points.

To use Interpolate:

1. Click Analyze > Interpolate.

A check mark appears in the menu next to the option.

2. Click the graph.

The examine indicator is drawn to the nearest data point.

The values of the plotted data are shown in the View Details area.

You can shift the examine line by moving the cursor with the arrow keys or by
clicking on another data point.

Generating Statistics

You can generate statistics (minimum, maximum, mean, standard deviation, and
number of samples) for all the collected data or for a selected region. You can also
generate a curve fit based on one of several standard models or on a model that you
define.

1. Leave the graph unselected to examine all the data, or select a range to examine a
specific area.

2. Click Analyze > Statistics.
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3. Select the plotted column name if you have more than a single column. For
example, run1.Pressure.

The Stats dialog box opens.

4. Review the data.

5. Click OK.

For information on clearing the Statistics analysis, see Removing Analysis Options.

Generating a Curve Fit

Use Curve Fit to find the best curve fit to match the data. Select all of the data or a
selected region of data. The curve is drawn on the graph.

1. Leave the graph unselected to examine all the data, or select a range to examine a
specific area.

2. Click Analyze > Curve Fit.

3. Select a curve fit option.

Curve Fit option Calculated in the form:

Linear y = m*x + b

Quadratic y = a*x^2 + b*x + c

Cubic y = a*x^3 + b*x^2 + c*x + d

Quartic y = a*x^4 + b*x^3 + c*x^2 + d*x + e



Curve Fit option Calculated in the form:

Power (ax^b) y = a*x^b

Exponential (ab^x) y =  a*b^x

Logarithmic y = a + b*ln(x)

Sinusoidal y = a*sin(b*x + c) + d

Logistic (d 0) y = c/(1 + a*e^(-bx)) + d

Natural Exponential y = a*e^(-c*x)

Proportional y = a*x

The Fit Linear dialog box opens.

4. Click OK.

5. Review the data.

For information on clearing the Curve Fit analysis, see Removing Analysis Options.

Plotting a Standard or User-Defined Model

This option provides a manual method for plotting a function to fit data. Use one of the
predefined models or enter your own.

You can also set the spin increment to use in the View Details dialog box. Spin
increment is the value by which the coefficient changes when you click the spin buttons
in the View Details dialog box.
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For example, if you set m1=1 as the spin increment, when you click the up spin button
the value changes to 1.1, 1.2, 1.3 and so on. If you click the down spin button, the value
changes to 0.9, 0.8, 0.7, and so on.

1. Click Analyze > Model.

The Model dialog box opens.

2. Type your own function.

—or—

Click to select a value from the drop-down list.

3. Click OK.

The Set Coefficient Values dialog box opens.



4. Type the value for the variables.

5. Type the change in value in the Spin Increment fields.

6. Click OK.

Note: These values are the initial values. You can also adjust these values in the
View Details area.

The model is shown on the graph with adjustment options in the View Details area
and in the All Details for Graph dialog box.

7. (Optional) Adjust the window setting for minimum and maximum axis values. For
more information, see Setting the Axis for One Graph.

For information on clearing the Model analysis, see Removing Analysis Options.

8. Click to make any desired adjustments to the coefficients.

—or—

Click the value in the View Details area.

This graphic is an example of a model with adjusted values.

Removing Analysis Options

1. Click Analyze > Remove.

2. Select the data display you want to remove.
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The display you selected is removed from the graph and the View Details area.

Displaying Collected Data in Graph View

When you collect data, it is written in both the Graph and Table views. Use the Graph
view to examine the plotted data.

Important: The Graph menu and Analyze menu items are only active when working in
Graph View.

Selecting the Graph View

▶ Click the Graph View tab .

Viewing Multiple Graphs

Use the Show Graph menu to show separate graphs when using:

• A sensor that plots more than one column of data.

• Multiple sensors with different defined units at the same time.

In this example, two sensors (the Gas Pressure sensor and the Hand Dynamometer)
were used in the same run. The following image shows the columns Time, Force, and
Pressure in the Table view to illustrate why two graphs are shown.

Displaying One of Two Graphs

When two graphs are displayed, the top graph is Graph 1 and the bottom graph is
Graph 2.

To display only Graph 1:

▶ Select Graph > Show Graph > Graph 1.

Only Graph1 is displayed.

To display only Graph 2:

▶ Select Graph > Show Graph > Graph 2.

Only Graph 2 is displayed.

Displaying Both Graphs

To display both Graph 1 and Graph 2 together:

▶ Select Graph > Show Graph > Both.



Graph1 and Graph 2 are displayed.

Displaying Graphs in the Page Layout View

Use the Page layout view when Show Graph is not the appropriate solution for
showing more than one graph.

The Show Graph option is not applicable for:

• Multiple runs using a single sensor.

• Two or more of the same sensors.

• Multiple sensors that use the same column(s) of data.

To use Page Layout:

1. Open the original data set you want to see in two graph windows.

2. Click Edit > Page Layout > Select Layout.

3. Select the type of page layout you want to use.

4. Click Click here to add an application.

5. Select Add Vernier DataQuest™.

The Vernier DataQuest™ application is added to the second view.

6. To see separate views, click the view you want to change, and then select View >
Table.

The new view is displayed.

7. To show the same view, click the view to change.

8. Click View > Graph.

The new view is displayed.

Displaying Collected Data in Table View

Table view provides another way to sort and view collected data.

Selecting the Table View

▶ Click the Table View tab .
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Defining Column Options

You can name columns and define the decimal points and the precision you want to
use.

1. from the Data menu, select Column Options.

Note: You can be in the Meter, Graph, or Table view and still click these menu
options. The results will still be visible.

2. Click the name of the column you want to define.

The Column Options dialog box opens.

3. Type the long name for the column in the Name field.

4. Type the abbreviated name in the Short Name field.

Note: This name is displayed if the column cannot expand to display the full name.

5. Type the number of units in the Units field.

6. From the Displayed Precision drop-down list, select the precision value.

Note: The default precision is related to the precision of the sensor.

7. Select Link to list to link to the symbol table and make this information available to
other TI-Nspire™ applications.

Note: Linking is the default for most sensors.



Important: Heart rate and blood pressure sensors require a tremendous amount of
data to be useful, and the default for these sensors is to be unlinked to improve
system performance.

8. Select Apply changes to all Data Sets to apply these settings to all data sets.

9. Click OK.

The column settings are now defined with the new values.

Creating a Column of Manually Entered Values

To enter data manually, add a new column. Sensor columns cannot be modified, but
data entered manually can be edited.

1. Click Data > NewManual Column.

The Column Options dialog box opens.

2. Type the long name for the column in the Name field.

3. Type the abbreviated name in the Short Name field.

Note: This name is displayed if the column cannot expand to display the full name.

4. Type the units to be used.

5. From the Displayed Precision drop-down list, select the precision value.

Note: The default precision is related to the precision of the sensor.
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6. (Optional) Select Apply changes to all Data Sets to apply these settings to all data
sets.

7. (Optional) Select Generate Values to automatically populate the rows.

If you select this option, complete these steps:

a) Type a starting value in the Start field.

b) Type an ending value in the End field.

c) Type the increase in value in the Increment field.

The number of points is calculated and shown in the Number of Points field.

8. Select Link from list to link to data in another TI-Nspire™ application.

Note: This list only populates when data exists in the other application and includes
a column label.

9. Select Link to list to link to the symbol table and make this information available to
other TI-Nspire™ applications.

Note: Linking is the default for most sensors.

Important: Heart rate and blood pressure sensors require a tremendous amount of
data to be useful, and the default for these sensors is to be unlinked to improve
system performance.

10. Click OK.

A new column is added to the table. This column can be edited.

Creating a Column of Calculated Values

You can add an additional column to the data set in which the values are calculated
from an expression using at least one of the existing columns.

Use a calculated column when finding the derivative for pH data. For more
information, see Adjusting Derivative Settings.

1. Click Data > New Calculated Column.

The Column Options dialog box opens.



2. Type the long name for the column in the Name field.

3. Type the abbreviated name in the Short Name field.

Note: This name is displayed if the column cannot expand to display the full name.

4. Type the units to be used.

5. From the Displayed Precision drop-down list, select the precision value.

Note: The default precision is related to the precision of the sensor.

6. Type a calculation including one of the column names in the Expression field.

Note: The system-provided column names are dependent on the sensor(s) selected
and any changes made to the name field in Column Options.

Important: The Expression field is case-sensitive. (Example: “Pressure” is not the
same as “pressure.”)

7. Select Link to list to link to the symbol table and make this information available to
other TI-Nspire™ applications.

Note: Linking is the default for most sensors.

Important: Heart rate and blood pressure sensors require a tremendous amount of
data to be useful, and the default for these sensors is to be unlinked to improve
system performance.

8. Click OK.

The new calculated column is created.
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Customizing the Graph of Collected Data

You can customize the Graph view by adding a title, changing colors, and setting
ranges for the axis.

Adding a Title

When you add a title to a graph, the title is displayed in the View Details area. When
you print the graph, the title prints on the graph.

1. Click Graph > Graph Title.

The Graph Title dialog box opens.

If there are two graphs in the work area, the dialog box has two title options.

2. Type the name of the graph in the Title field.

—or—

a) Type the name of the first graph in the Graph 1 field.

b) Type the name of the second graph in the Graph 2 field.

3. Select Enable to show the title.

Note: Use the Enable option to hide or show the graph title as needed.

4. Click OK.



The title is shown.

Setting Axis Ranges

Setting Axis Ranges for One Graph

To modify the minimum and maximum range for the x and y axis:

1. Click Graph > Window Settings.

The Window Settings dialog box opens.

2. Type the new values in one or more of these fields:

- X Min

- X Max

- Y Min

- Y Max

3. Click OK.

The application uses the new values for the graph visual range until you modify the
range or change data sets.

Setting Axis Ranges for Two Graphs

When working with two graphs, enter two y axis minimum and maximum values, but
only one set of minimum and maximum values for the x axis.

1. Click Graph > Window Setting.

The Window Setting dialog box opens.

Data Collection 455



456 Data Collection

2. Type the new values in one or more of these fields:

- X Min

- X Max

- Graph 1: Y Min

- Y Max

- Graph 2: Y Min

- Y Max

3. Click OK.

The application uses the new values for the graph visual range until you modify the
range or change data sets.

Setting the Axis Range on the Graph Screen

You can modify the minimum and maximum range for the x and y axes directly on the
graph screen.

▶ Select the axis value that you want to change, and type a new value.

The graph is redrawn to reflect the change.

Selecting which Data Sets to Plot

1. In the Detail view on the left, click the tab immediately below the view selection
buttons.



2. The Detail view shows a list of available data sets.

3. Use the check boxes to select the data sets to plot.

Autoscaling a Graph

Use the autoscale option to show all the points plotted. Autoscale Now is useful after
you change the x and y axis range or zoom in or out of a graph. You can also define the
automatic autoscale setting to use during and after a collection.

Autoscale Now Using the Application Menu

▶ Click Graph > Autoscale Now.

The graph now displays all the points plotted.

Autoscale Now Using the Context Menu

1. Open the context menu in the graph area.

2. ClickWindow/Zoom > Autoscale Now.

The graph now displays all the points plotted.
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Defining Autoscale During a Collection

There are two options for using the automatic autoscaling that occurs during a
collection. To choose an option:

1. Click Options > Autoscale Settings.

The Autoscale Settings dialog box opens.

2. Click► to open the During Collection drop-down list.

3. Select one of these options:

• Autoscale Larger - Expands the graph as needed to show all points as you
collect them.

• Do Not Autoscale - The graph is not changed during a collection.

4. Click OK to save the setting.

Defining Autoscale After a Collection

You have three options for setting the automatic autoscaling that occurs after a
collection. To set your choice:

1. Click Options > Autoscale Settings.

The Autoscale Settings dialog box opens.

2. Click► to open the After Collection drop-down list.

3. Select one of these options:

• Autoscale to Data. Expands the graph to show all data points. This option is the
default mode.

• Autoscale From Zero. Modifies the graph so all data points including the origin
point are displayed.

• Do Not Autoscale. The graph settings are not changed.



4. Click OK to save the setting.

Selecting a Range of Data

Selecting a range of data on the graph is useful in several situations, such as when
zooming in or out, striking and unstriking data, and examining settings.

To select a range:

1. Drag across the graph.

The selected area is indicated by gray shading.

2. Perform one of these actions.

• Zoom in or out

• Strike or unstrike data

• Examine settings

To deselect a range:

▶ Press the Esc key as necessary to remove the shading and the vertical trace line.

Zooming In on a Graph

You can zoom in on a subset of the collected points. You can also zoom out from a
previous zoom or expand the graph window beyond the data points collected.

To zoom in on a graph:

1. Select the area you want to zoom into, or use the current view.

2. Click Graph > Zoom In.

The graph adjusts to display only the area you selected.

The x range selected is used as the new x range. The y range autoscales to show all
graphed data points in the selected range.

Zooming Out of a Graph

▶ Select Graph > Zoom Out.

The graph is now expanded.
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If a Zoom In precedes a Zoom Out, the graph displays the original settings prior to
the Zoom In.

For example, if you Zoomed In twice, the first Zoom Out would display the window
of the first Zoom In. To display the full graph with all data points from multiple
zoom ins, use Autoscale Now.

Setting Point Options

To indicate how often marks show on the graph and whether to use a connecting line:

1. Click Options > Point Options.

The Point Options dialog box opens.

2. Select a Mark option from the drop-down list.

• None. No point protectors.

• Regional. Periodic point protectors.

• All. Every data point as a point protector.

3. Select Connect Data Points to display a line between points.

—or—

Clear Connect Data Points to remove the line between points.

The following graphics show examples of some of the Point Mark options.



Changing a Graph's Color

1. Click the point indicator for the graph whose color you want to change.

2. In the Column Options dialog box, select the new Color.

Selecting Point Markers

1. Right-click in the graph to open the menu.

2. Click Point Marker.

Note: If there is only one dependent variable column, the Point Marker option is
preceded by the data set name and column name. Otherwise, the Point Marker
option has a menu.

3. Select the column variable to change.

4. Select the point marker to set.

The Point Marker changes to the option selected.
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Selecting an Independent Variable Column

Use the option Select X-axis Column to select the column used as the independent
variable when graphing the data. This column is used for all graphs.

1. Click Graph > Select X-axis Column.

2. Select the variable you want to change.

The x-axis label on the graph changes and the graph is reordered using the new
independent variable for graphing the data.

Selecting a Dependent Variable Column

Use the option Select Y-axis Column to select which dependent variable columns to
plot on the displayed graph(s).

1. Click Graph > Select Y-axis Column.

2. Select one of the following:

• A variable from the list. The list is a combination of dependent variables and
the number of data sets.

• More. Selecting More opens the Select dialog box. Use this when you want to
select a combination of data set variables to graph.

Showing and Hiding Details

You can hide or show the Details view on the left side of the screen.

▶ Click Options > Hide Details or Options > Show Details.



Striking and Restoring Data

Striking data omits it temporarily from the Graph view and from the analysis tools.

1. Open the data run that contains the data to be struck.

2. Click Table View .

3. Select the region by dragging from the starting row to the ending point.

The screen scrolls so you can see the selection.

4. Click Data > Strike Data.

5. Select one of the following:

• In Selected Region. Strike the data from the area you selected.
• Outside Selected Region. Strike all data except the area you selected.

The selected data is marked as struck in the table and is removed from the graph
view.

Restoring Struck Data

1. Select the range of data to restore or if restoring all struck data, start at step two.

2. Click Data > Restore Data.

3. Select one of the following:

• In Selected Region - Restore data in the selected area.
• Outside Selected Region - Restore data outside the selected area.
• All Data - Restore all data. No data selection necessary.

The data is restored.

Replaying the Data Collection

Use the Replay option to playback the data collection. This option lets you:

• Select the data set you want to replay.

• Pause the playback.

• Advance the playback by one point at a time.

• Adjust the playback rate.

• Repeat the playback.

Selecting the Data Set to Replay

You can replay one data set at a time. By default, the latest data set plays using the
first column as the base column (example: time reference).

Data Collection 463



464 Data Collection

If you have multiple data sets, and want a different data set or base column than the
default, you can select the data set to replay and the base column.

To select the data set to replay:

1. Click Experiment > Replay > Advanced Settings.

The Advanced Replay Settings dialog box opens.

2. Select the data set to replay from the Data Set drop-down list.

Note: Changing the run in the Data Set selection tool does not affect the playback
choice. You must specify which data set in Experiment > Replay > Advance Settings.

3. (Optional) Select a new value from the Base Column drop-down list.

The selected column acts as the “Time” column for the replay.

Note: The base column should be a strictly increasing list of numbers.

4. Click Start to start the playback and save the settings.

Note: Data Set and Base Column options are based on the number of stored runs
and the sensor type used.

Starting and Controlling the Playback

▶ Select Experiment > Replay > Start Playback.

Playback begins, and the Data Collection Control buttons change to:

Pause

Resume

Stop

Advance by One Point (enabled only during pause)



Adjusting the Playback Rate

To adjust the playback rate:

1. Select Experiment > Replay > Playback Rate.

The Playback Rate dialog box opens.

2. In the Playback Rate field, click▼ to open the drop-down list.

3. Select the rate at which the playback will play.

Normal speed is 1.00. A higher value is faster, and a lower value is slower.

4. Select one of the following options:

• Click Start to start the playback and save the settings.

• Click OK to save the settings for use on the next playback.

Repeating the Playback

1. Select Experiment > Replay > Start Playback.

2. Click Start to start the playback and save the settings.

Adjusting Derivative Settings

Use this option to select the number of points to use in derivative calculations. This
value affects the tangent tool, velocity, and acceleration values.

Find pH derivative settings using a calculated column.

The Vernier DataQuest™ application can determine a numeric derivative from a list of
data with respect to another list of data. The data can be collected using sensors, input
manually, or linked with other applications. The numerical derivative is found using a
calculated column.

To determine the numerical 1st derivative of List B with respect to List A, enter the
following expression in the Column Options dialog:

derivative(B,A,1,0) or derivative(B,A,1,1)
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To determine the numerical 2nd derivative of List B with respect to List A, enter the
following express:

derivative(B,A,2,0) or derivative (B,A,2,1)

The last parameter is either 0 or 1 depending on the method you are using. When it is
0, a weighted average is used. When it is 1, a time shifted derivative method is used.

Note: The first derivative calculation (weighted average) is what the Tangent tool uses
to display the slope at a data point when examining data. (Analyze > Tangent).

Note: The derivative calculation is completely row based. It is recommended that your
List A data be sorted in ascending order.

1. Click Options > Derivative Settings.

The Settings dialog box opens.

2. Select the number of points from the drop-down list.

3. Click OK.

Drawing a Predictive Plot

Use this option to add points to the graph to predict the outcome of an experiment.

1. Click the Graph View tab .

2. From the Analyze menu, select Draw Prediction > Draw.

3. Click each area in which you want to place a point.

4. Press Esc to release the drawing tool.

5. To clear the drawn prediction, click Analyze > Draw Prediction > Clear.



Using Motion Match
Use this option to create a randomly generated plot when creating position-versus-time or
velocity-versus-time graphs.
This feature is only available when using a motion detector such as the CBR 2™ sensor or
the Go!Motion® sensor.

Generating a Motion Match Plot

To generate a plot:

1. Attach the motion detector.

2. Click View > Graph.

3. Click Analyze > Motion Match.

4. Select one of the following options:

• New Position Match. Generates a random position plot.
• New Velocity Match. Generates a random velocity plot.

Note: Continue selecting a new position or a new velocity match to generate a new
random plot without removing the existing plot.

Removing a Motion Match Plot

To remove the generated plot:

▶ Click Analyze > Motion Match > Remove Match.

Printing Collected Data

You can only print from the computer. You can print any single displayed active view, or
with the Print All option:

• One data view.

• All of the data views.

• A combination of the data views.

The Print All option has no effect on applications outside of the Vernier DataQuest™
application.

Printing Data Views

To print a data view:

1. On the main menu (top of the window), click File > Print.

The Print dialog box opens.
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2. Select Print All from the Print what drop-down list.

3. Select additional options, if needed.

4. Click Print to send the document to the printer.

Setting Options for the Print All Feature

1. Click Options > Print All Settings.

The Print All Settings dialog box opens.

2. Select the views you want to print.

• Print Current View. The current view is sent to the printer.

• Print All Views. All three views (Meter, Graph, and Table) are sent to the
printer.

• More. Only the views you select are sent to the printer.



3. Click OK.

The Print All Settings are now complete and can be used when printing.
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Widgets
All work that you create and save using TI-Nspire™ applications is stored as a
document, which you can share with others using TI-Nspire™ software, a TI-Nspire™
handheld, or the TI-Nspire™ App for iPad®. You save these TI-Nspire™ documents as
.tns files.

A Widget is a .tns document that is stored in your MyWidgets folder.

You can use Widgets to:

• Easily access text files

• Insert and run scripts (such as the pre-loaded widget example: Stopwatch.tns)

• Quickly insert a saved problem into a document

When you add a Widget, TI-Inspire™ CX extracts only the first page of the selected .tns
file, and inserts it into your open document.

Creating a Widget

A document is regarded as a Widget when it is saved or copied to the designated
MyWidgets folder. The default location is:

• Windows®: My Documents\TI-Nspire\MyWidgets.

• Mac®: Documents/TI-Nspire/MyWidgets.

• Handheld: MyWidgets

• TI-Nspire™ App for iPad® and TI-Nspire™ CAS App for iPad®: MyWidgets

If the MyWidget folder has been inadvertently deleted, you must create it before
attempting to use a Widget.

Note: When you add a Widget, TI-Inspire™ CX extracts only the first page of the
selected .tns file, and inserts it into your open document.

Adding a Widget

Adding a Widget to a New Document

1. Open a new document.
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2. Click Add Widget.

3. Scroll to select a .tns file from the box.

4. Click Add.

Note: Stopwatch is a preloaded .tns file. Any saved .tns file will show up in this list.



Adding a Widget to an Existing Document

1. Click the ¤ on Doc¤ > Insert > Widget.

2. Click Add.

Note: You can also add a Widget to a new or existing document using the Insert menu.
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Saving a Widget

1. Click .
2. Navigate to MyDocuments > MyWidgets.

3. Type in a name for your Widget.

4. Click Save.



Libraries
A library is a TI-Nspire™ document that contains a collection of variables, functions,
and/or programs that have been defined as library objects.

Unlike ordinary variables, functions, and programs, which can be used only within a
single problem (the problem in which they are defined), library objects are accessible
from any document. You can even create public library objects that appear in the
TI-Nspire™ Catalog.

For example, suppose you have created library document matrix containing public
library function diagwithtrace() and a private library function errmsg().

Function diagwithtrace() displays the diagonal of a square matrix and calculates the
trace of the matrix. If its input is not a square matrix, the function calls errmsg(), which
should then return an appropriate error string.

You could then use the following syntax to display the diagonal and calculate the trace
of matrix m defined in the current problem:

matrix\diagwithtrace(m)

Creating Libraries and Library Objects

A document is regarded as a library when it is saved or copied to the designated library
folder. The default location is:

• Windows®: My Documents\TI-Nspire\MyLib.

• Mac®: Documents/TI-Nspire/MyLib.

• Handheld: MyLib
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If the folder has been inadvertently deleted, you must create it before attempting to
use libraries.

You can define library objects using either the Program Editor or the Calculator
application. Library objects must be defined with a Define command and must reside
in the first problem of a library document.

Note: If you use the Program Editor to define a library function or program, you must
store the object and also save the document. Saving the document does not
automatically store the object. For more information, see Programming.

Naming restrictions apply to library documents and library objects.

• A library document name must be a valid variable name between 1 and 16
characters long, and it must not contain a period or begin with an underscore.

• A library object name must be a valid variable name between 1 and 15 characters
long. It must not contain a period and must not begin with an underscore.

Private and Public Library Objects

When you define a library object, you designate it as private (LibPriv) or public (LibPub).

Define a=5
    a is not a library object.

Define LibPriv b={1,2,3}
    b is a private library object.

Define LibPub func1(x)=x^2 - 1
    func1 is a public library object.

A Private library object does not appear in the Catalog, but you can access it by typing
its name. Private objects serve well as building blocks that perform basic, low-level
tasks. Typically, private library objects are called upon by the public functions and
programs.

A Public library object appears in the Catalog’s library tab after you refresh the
libraries. You can access a public library object through the Catalog or by typing its
name.

Mac® only: In version 1.4 of the software, a library document name cannot contain
extended characters, such as Ö, á, or ñ.

Note: In library programs and functions defined as public, a comment line (©)
immediately following the Prgm or Func line is automatically displayed as help in the
Catalog. You could, for example, show a syntax reminder there.



Using Short and Long Names

Anytime you are in the same problem where an object is defined, you can access it by
entering its short name (the name given in the object’s Define command). This is the
case for all defined objects, including private, public, and non-library objects.

You can access a library object from any document by typing the object’s long name. A
long name consists of the name of the object’s library document followed by a
backslash “\” followed by the name of the object. For example, the long name of the
object defined as func1 in the library document lib1 is lib1\func1. To type the “\”
character on the handheld, pressgp.

Note: If you cannot remember the exact name or the order of arguments required for a
private library object, you can open the library document or use the Program Editor to
view the object. You also can use getVarInfo to view a list of objects in a library.

Using Library Objects

Before using a library variable, function, or program, make sure that these steps have
been followed:

• The object has been defined with the Define command, and the command
specifies either the LibPriv or LibPub attribute.

• The object resides in the first problem of a library document. The document must
reside in the designated library folder and must meet the naming requirements.

• If you defined the object using the Program Editor, it has been stored using Check
Syntax & Store from the Program Editor menu.

• The libraries have been refreshed.

Refreshing the Libraries

▶ Refresh libraries to make the library objects available to your documents.

- From the Tools menu, click Refresh Libraries.

Handheld: Press/b and click Refresh Libraries.

Using a Public Library Object

1. Refresh the libraries.

2. Open the TI-Nspire™ application in which you want to use the variable, function or
program.

Note: All applications can evaluate functions, but only the Calculator and Notes
applications can run programs.

3. Open the Catalog and use the library tab to find and insert the object.

4. If arguments are required, type them inside the parentheses.

Using a Private Library Object

1. Refresh the libraries.
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2. Open the TI-Nspire™ application in which you want to use the variable, function, or
program.

Note: All applications can evaluate functions, but only the Calculator and Notes
applications can run programs.

3. Type the name of the object, such as lib1\func1().

In case of a function or program, always follow the name with parentheses. To
type the “\” character on the handheld, pressgp.

4. If arguments are required, type them inside the parentheses.

Creating Shortcuts to Library Objects

You can make the objects in a library more easily accessible by using libShortcut() to
create shortcuts to them. This creates a variable group in the current problem that
contains references to all the objects in the specified library document. You can choose
to include or exclude the private library objects.

For example, suppose the library document linalg contains functions named clearmat,
cofactor, gausstep, help, inversestep, kernelbasis, rank, and simultstep. Executing
libShortcut(“linalg”,“la”) would create a variable group containing the following
members:

la.clearmat
la.cofactor
la.gausstep
la.help
la.inversestep
la.kernelbasis
la.rank
la.simultstep

You can refer to those library objects from within the current problem by typing their
variable names or by selecting them from the Variables menu.

For more details about using libShortcut(), see the Reference Guide.

Included Libraries

To help you get started with libraries, the TI-Nspire™ Software installation includes a
library document with useful Linear Algebra functions. The library is named linalg or
linalgCAS and is installed in the designated library folder.

Note: Updating the handheld’s operating system or reinstalling the computer software
places all included libraries in the default folder. If you have edited an object in an
included library or replaced an included library with your own document of the same
name, updating or reinstalling will overwrite your changes. This could also happen
after batteries are replaced or the handheld system is reset.



Restoring an Included Library

If you inadvertently delete or overwrite an included library, you can restore it from the
installation DVD.

1. Open the DVD, and navigate to the libs folder.

2. Identify the library file to restore, such as linalg.tns or linalgCAS.tns for the linear
algebra library.

3. Copy the file.

- Windows®: Copy the file to your designated library folder. The default location
is My Documents\TI-Nspire\MyLib.

- Mac®: Copy the file to your designated library folder. The default location is
Documents/TI-Nspire/MyLib.

- Handheld: Connect the handheld to your computer, open the TI-Nspire™
software, and copy the library file to the handheld’s MyLib folder.

4. Activate the new library objects.

- From the TI-Nspire™ Software Tools menu, click Refresh Libraries.

Handheld: Press/b, and click Refresh Libraries.
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Getting Started with the Program Editor
You can create user-defined functions or programs by typing definition statements on
the Calculator entry line or by using the Program Editor. The Program Editor offers
some advantages, and it is covered in this section. For more information, see
Calculator.

• The editor has programming templates and dialog boxes to help you define
functions and programs using correct syntax.

• The editor lets you enter multiple-line programming statements without requiring
a special key sequence to add each line.

• You can easily create private and public library objects (variables, functions, and
programs). For more information, see Libraries.

Launching the Program Editor

▶ To add a new Program Editor page in the current problem:

From the toolbar, click Insert > Program Editor > New.

Handheld: Press~ and select Insert > Program Editor > New.

Note: The editor is also accessible from the Functions & Programs menu of a
Calculator page.

À Program Editor menu – This menu is available anytime you are in the Program Editor
work area using the Normal view mode.

Á Program Editor work area

Â Status line shows line-number information and the name of the function or program
being edited. An asterisk (*) indicates that this function is “dirty,” which means that
it has changed since the last time its syntax has been checked and it has been stored.
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Defining a Program or Function

Starting a new Program Editor

1. Make sure you are in the document and problem in which you want to create the
program or function.

2. Click Insert button on the application toolbar, and select Program Editor > New.
(On the handheld, press~ and select Insert > Program Editor > New.)

3. Type a name for the function or program you are defining.

4. Select the Type (Program or Function).

5. Set the Library Access:

- To use the function or program only from the current document and problem,
select None.

- To make the function or program accessible from any document but not visible
in the Catalog, select LibPriv.

- To make the function or program accessible from any document and also
visible in the Catalog, select LibPub (Show in Catalog). For more information,
see Libraries.

6. Click OK.

A new instance of the Program Editor opens, with a template matching the
selections you made.

Entering Lines into a Function or Program

The Program Editor does not execute the commands or evaluate expressions as you
type them. They are executed only when you evaluate the function or run the program.

1. If your function or program will require the user to supply arguments, type
parameter names in the parentheses that follow the name. Separate parameters
with a comma.



2. Between the Func and EndFunc (or Prgm and EndPrgm) lines, type the lines of
statements that make up your function or program.

- You can either type the names of functions and commands or insert them from
the Catalog.

- A line can be longer than the width of the screen; if so, you might have to scroll
to view the entire statement.

- After typing each line, press Enter. This inserts a new blank line and lets you
continue entering another line.

- Use the◄,►,▲, and▼ arrow keys to scroll through the function or program
for entering or editing commands.

Inserting Comments

A comment symbol (©) lets you enter a remark. Comments can be useful to someone
viewing or editing the program. Comments are not displayed when the program runs,
and they have no effect on program flow.

Define LibPub volcyl(ht,r) =
Prgm
©volcyl(ht,r) => volume of cylinder  À
  Disp “Volume =”, approx(p ¦ r2 ¦ ht)
©This is another comment.
EndPrgm

À Comment showing required syntax. Because this library object is public and this
comment is the first line in a Func or Prgm block, the comment is displayed in the
Catalog as help. For more information, see Libraries.

To insert a comment:

1. Position the cursor at the end of the line in which you want to insert a comment.

2. From the Actions menu, click Insert Comment.
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3. Type the text of the comment after the © symbol.

Checking Syntax

The Program Editor lets you check the function or program for correct syntax.

▶ From the Check Syntax & Store menu, click Check Syntax.

If the syntax checker finds any syntax errors, it displays an error message and tries
to position the cursor near the first error so you can correct it.

Storing the Function or Program

You must store your function or program to make it accessible. The Program Editor
automatically checks the syntax before storing.

An asterisk (*) is displayed in the upper left corner of the Program Editor to indicate
that the function or program has not been stored.

▶ From the Check Syntax & Store menu, click Check Syntax & Store.

If the syntax checker finds any syntax errors, it displays an error message and tries
to position the cursor near the first error.

If no syntax errors are found, the message “Stored successfully“is displayed in the
status line at the top of the Program Editor.

Note: If the function or program is defined as a library object, you must also save the
document in the designated library folder and refresh libraries to make the object
accessible to other documents. For more information, see Libraries.

Viewing a Program or Function
1. From the Actions menu, click View.



2. If the function or program is a library object, select its library from the Location list.

3. Select the function or program name from the Name list.

The function or program is displayed in a viewer.

4. Use the arrow keys to view the function or program.

5. If you want to edit the program, click Edit.

Handheld: Presse to highlight Edit, and then press·.

Note: The Edit selection is available only for functions and programs defined in the
current problem. To edit a library object, you must first open its library document.

Opening a Function or Program for Editing

You can open a function or program from the current problem only.

Note: You cannot modify a locked program or function. To unlock the object, go to a
Calculator page and use the unLock command.

1. Display the list of available functions and programs.

- From the Actions menu, click Open.

2. Click the item to open.

Importing a Program from a Library

You can import a function or program defined as a library object into a Program Editor
within the current problem. The imported copy is not locked, even if the original is
locked.

1. From the Actions menu, click Import.
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2. Select the Library Name.

3. Select the Name of the object.

4. If you want the imported object to have a different name, type the name under
Import As.

Creating a Copy of a Function or Program

When creating a new function or program, you might find it easier to start with a copy
of the current one. The copy that you create is not locked, even if the original is locked.

1. From the Actions menu, click Create Copy.

2. Type a new name, or click OK to accept the proposed name.

3. If you want to change the access level, select Library Access, and select a new
level.

Renaming a Program or Function

You can rename and (optionally) change the access level of the current function or
program.

1. From the Actions menu, click Rename.

2. Type a new name, or click OK to accept the proposed name.

3. If you want to change the access level, select Library Access, and select a new
level.



Changing the Library Access Level
1. From the Actions menu, click Change Library Access.

2. Select the Library Access:

- To use the function or program only from the current Calculator problem, select
None.

- To make function or program accessible from any document but not visible in
the Catalog, select LibPriv.

- To make the function or program accessible from any document and also
visible in the Catalog, select LibPub.

Finding Text
1. From the Actions menu, click Find.

2. Type the text that you want to find, and click OK.

- If the text is found, it is highlighted in the program.
- If the text is not found, a notification message is displayed.

Finding and Replacing Text
1. From the Actions menu, click Find and Replace.

2. Type the text that you want to find.
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3. Type the replacement text.

4. Click Replace to replace the first occurrence after the cursor position.
—or—
Click Replace All to replace every occurrence.

Note: If the text is found in a math template, a message is displayed to warn you
that your replacement text will replace the whole template—not just the found
text.

Closing the Current Function or Program

▶ From the Actions menu, click Close.

If the function or program has unstored changes, you are prompted to check syntax
and store before closing.

Running Programs and Evaluating Functions

After defining and storing a program or function, you can use it from an application. All
the applications can evaluate functions, but only the Calculator and Notes applications
can run programs.

The program statements are executed in sequential order (although some commands
alter the program flow). The output, if any, is displayed in the application’s work area.

• Program execution continues until it reaches the last statement or a Stop
command.

• Function execution continues until it reaches a Return command.

Running a Program or Function from the Program Editor

1. Make sure you have defined a program or function and the Program Editor is the
active pane (computer) or page (handheld).

2. On the toolbar, click the Document Tools button and select Check Syntax &
Store > Run.
—or—
Press Ctrl+R.

Handheld: Pressb23, or press/R.



This will automatically:

• check the syntax and store the program or function,
• paste the program or function name on the first available line of the Calculator

application immediately following the Program Editor. If no Calculator exists in
that position, a new one is inserted.

3. If the program or function requires you to supply one or more arguments, type the
values or variable names inside the parentheses.

4. Press·.

Note: You can also run a program or function in Calculator or Notes applications by
typing the name of the program with parentheses and any required arguments and
pressing·.

Using Short and Long Names

Anytime you are in the same problem where an object is defined, you can access it by
entering its short name (the name given in the object’s Define command). This is the
case for all defined objects, including private, public, and non-library objects.

You can access a library object from any document by typing the object’s long name. A
long name consists of the name of the object’s library document followed by a
backslash “\” followed by the name of the object. For example, the long name of the
object defined as func1 in the library document lib1 is lib1\func1. To type the “\”
character on the handheld, pressgp.

Note: If you cannot remember the exact name or the order of arguments required for a
private library object, you can open the library document or use the Program Editor to
view the object. You also can use getVarInfo to view a list of objects in a library.

Using a Public Library Program or Function

1. Make sure you have defined the object in the document’s first problem, stored the
object, saved the library document in the MyLib folder, and refreshed the libraries.

2. Open the TI-Nspire™ application in which you want to use the program or function.
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Note: All applications can evaluate functions, but only the Calculator and Notes
applications can run programs.

3. Open the Catalog and use the library tab to find and insert the object.
—or—
Type the name of the object. In the case of a program or function, always follow
the name with parentheses.

libs2\func1()

4. If the program or function requires you to supply one or more arguments, type the
values or variable names inside the parentheses.

libs2\func1(34,power)

5. Press·.

Using a Private Library Program or Function

To use a Private library object, you must know its long name. For example, the long
name of the object defined as func1 in the library document lib1 is lib1\func1.

Note: If you cannot remember the exact name or the order of arguments required for a
private library object, you can open the library document or use the Program Editor to
view the object.

1. Make sure you have defined the object in the document’s first problem, stored the
object, saved the library document in the MyLib folder, and refreshed the libraries.

2. Open the TI-Nspire™ application in which you want to use the program or function.

Note: All applications can evaluate functions, but only the Calculator and Notes
applications can run programs.

3. Type the name of the object. In the case of a program or function, always follow
the name with parentheses.

libs2\func1()

4. If the object requires you to supply one or more arguments, type the values or
variable names inside the parentheses.

libs2\func1(34,power)

5. Press·.

Interrupting a Running Program or Function

While a program or function is running, the busy pointer} is displayed.

▶ To stop the program or function,

- Windows®: Hold down the F12 key and press Enter repeatedly.
- Mac®: Hold down the F5 key and press Enter repeatedly.



- Handheld: Hold down thec key and press· repeatedly.

A message is displayed. To edit the program or function in the Program Editor,
select Go To. The cursor appears at the command where the break occurred.

Getting Values into a Program

You can choose from several methods to supply the values that a function or program
uses in calculations.

Embedding the Values Within the Program or Function

This method is useful primarily for values that must be the same each time the
program or function is used.

1. Define the program.

Define calculatearea()=
Prgm
w:=3
h:=23.64
area:=w*h
EndPrgm

2. Run the program.

calculatearea() :area                           70.92

Letting the User Assign the Values to Variables

A program or function can refer to variables created beforehand. This method requires
users to remember the variable names and to assign values to them before using the
object.

1. Define the program.

Define calculatearea()=
Prgm
area:=w*h
EndPrgm

2. Supply the variables, and then run the program.

w:=3 : h:=23.64
calculatearea() :area                           70.92

Letting the User Supply the Values as Arguments

This method lets users pass one or more values as arguments within the expression
that calls the program or function.

The following program, volcyl, calculates the volume of a cylinder. It requires the user
to supply two values: height and radius of the cylinder.
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1. Define the volcyl program.

Definevolcyl(height,radius) =
Prgm
Disp "Volume =", approx(p ¦ radius2 ¦ height)
EndPrgm

2. Run the program to display the volume of a cylinder with a height of 34 mm and a
radius of 5 mm.

volcyl(34,5)               Volume = 534.071

Note: You do not have to use the parameter names when you run the volcyl
program, but you must supply two arguments (as values, variables, or expressions).
The first must represent the height, and the second must represent the radius.

Requesting the Values from the User (Programs Only)

You can use the Request and RequestStr commands in a program to make the program
pause and display a dialog box prompting the user for information. This method does
not require users to remember variable names or the order in which they are needed.

You cannot use the Request or RequestStr command in a function.

1. Define the program.

Define calculatearea()=
Prgm
Request "Width: ",w
Request "Height: ",h
area:=w*h
EndPrgm

2. Run the program and respond to the requests.

calculatearea() : area 
Width: 3 (3 entered as a response)
Height: 23.64  (23.64 entered as a response)

70.92

Use RequestStr instead of Request when you want the program to interpret the user’s
response as a character string rather than a math expression. This avoids requiring the
user to enclose the response in quotation marks (““).

Displaying Information from a Function or Program

A running function or program does not display intermediate calculated results unless
you include a command to display them. This is an important difference between
performing a calculation on the entry line and performing it in a function or program.

The following calculations, for example, do not display a result in a function or
program (although they do from the entry line).



©
x:=12•6
cos(π/4)
©

Displaying Information in the History

You can use the Disp command in a program or function to display information,
including intermediate results, in the history.

©
Disp 12•6
Disp "Result:",cos(π/4)
©

Displaying Information in a Dialog Box

You can use the Text command to pause a running program and display information in
a dialog box. The user clicks OK to continue or clicks Cancel to stop the program.

You cannot use the Text command in a function.

©
Text "Area=" & area
©

Note: Displaying a result with Disp or Text does not store that result. If you expect to
refer later to a result, store it to a global variable.

©
cos(π/4)→maximum
Disp maximum
©

Using Local Variables

A local variable is a temporary variable that exists only while a user-defined function is
being evaluated or a user-defined program is running.

Example of a Local Variable

The following program segment shows a For...EndFor loop (which is discussed later in this
module). The variable i is the loop counter. In most cases, the variable i is used only while
the program is running.

Local i  À
For i,0,5,1
  Disp i
EndFor
Disp i

À Declares variable i as local.
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Note: When possible, declare as local any variable that is used only within the program
and does not need to be available after the program stops.

What Causes an Undefined Variable Error Message?

An Undefined variable error message is displayed when you evaluate a user-defined
function or run a user-defined program that references a local variable that is not
initialized (assigned a value).

For example:

Define fact(n)=Func
  Local m  À
  While n>1
    n¦m&m: n–1&n
  EndWhile
  Return m
EndFunc

À Local variable m is not assigned an initial value.

Initialize Local Variables

All local variables must be assigned an initial value before they are referenced.

Define fact(n)=Func
  Local m: 1&m  À
  While n>1
    n¦m&m: n–1&n
  EndWhile
  Return m
  EndFunc

À 1 is stored as the initial value for m.

Note (CAS): Functions and programs cannot use a local variable to perform symbolic
calculations.

CAS: Performing Symbolic Calculations

If you want a function or program to perform symbolic calculations, you must use a
global variable instead of a local. However, you must be certain that the global variable
does not already exist outside of the program. The following methods can help.

• Refer to a global variable name, typically with two or more characters, that is not
likely to exist outside of the function or program.

• Include DelVar within a program to delete the global variable, if it exists, before
referring to it. (DelVar does not delete locked or linked variables.)



Differences Between Functions and Programs

A function defined in the Program Editor is similar to the functions built into the
TI-Nspire™ Software.

• Functions must return a result, which can be graphed or entered in a table.
Programs do not return a result.

• You can use a function (but not a program) within an expression. For example: 3 ¦
func1(3) is valid, but not 3 ¦ prog1(3).

• You can run programs from Calculator and Notes applications only. However, you
can evaluate functions in Calculator, Notes, Lists & Spreadsheet, Graphs &
Geometry, and Data & Statistics.

• A function can refer to any variable; however, it can store a value to a local variable
only. Programs can store to local and global variables.

Note: Arguments used to pass values to a function are treated as local variables
automatically. If you want to store to any other variables, you must declare them
as Local from within the function.

• A function cannot call a program as a subroutine, but it can call another user-
defined function.

• You cannot define a program within a function.

• A function cannot define a global function, but it can define a local function.

Calling One Program from Another

One program can call another program as a subroutine. The subroutine can be external
(a separate program) or internal (included in the main program). Subroutines are
useful when a program needs to repeat the same group of commands at several
different places.

Calling a Separate Program

To call a separate program, use the same syntax that you use to run the program from
the entry line.

Defining and Calling an Internal Subroutine

To define an internal subroutine, use the Define command with Prgm...EndPrgm.
Because a subroutine must be defined before it can be called, it is a good practice to
define subroutines at the beginning of the main program.
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An internal subroutine is called and executed in the same way as a separate program.

Define subtest1()=
  Prgm
  local subtest2  À
  Define subtest2(x,y)=  Á
  Prgm
    Disp x,y
  EndPrgm
  ©Beginning of main program
  For i,1,4,1
    subtest2(i,I*1000) Â
  EndFor
  EndPrgm

À Declares the subroutine as a local variable.

Á Defines the subroutine.

Â Calls the subroutine.

Note: Use the Program Editor’s Var menu to enter the Define and Prgm...EndPrgm
commands.

Notes about Using Subroutines

At the end of a subroutine, execution returns to the calling program. To exit a
subroutine at any other time, use Return with no argument.

A subroutine cannot access local variables declared in the calling program. Likewise,
the calling program cannot access local variables declared in a subroutine.

Lbl commands are local to the programs in which they are located. Therefore, a Goto
command in the calling program cannot branch to a label in a subroutine or vice versa.

Avoiding Circular-Definition Errors

When evaluating a user-defined function or running a program, you can specify an
argument that includes the same variable that was used to define the function or
create the program. However, to avoid circular-definition errors, you must assign a
value for variables that are used in evaluating the function or running the program.
For example:

x+1&x  À

– or –

For i,i,10,1
  Disp i  À
EndFor



À Causes a Circular definition error message if x or i does not have a value. The error
does not occur if x or i has already been assigned a value.

Controlling the Flow of a Function or Program

When you run a program or evaluate a function, the program lines are executed in
sequential order. However, some commands alter the program flow. For example:

• Control structures such as If...EndIf commands use a conditional test to decide
which part of a program to execute.

• Loop commands such as For...EndFor repeat a group of commands.

Using If, Lbl, and Goto to Control Program Flow

The If command and several If...EndIf structures let you execute a statement or block
of statements conditionally, that is, based on the result of a test (such as x>5). Lbl
(label) and Goto commands let you branch, or jump, from one place to another in a
function or program.

The If command and several If...EndIf structures reside on the Program Editor’s Control
menu.

When you insert a structure such as If...Then...EndIf, a template is inserted at the
cursor location. The cursor is positioned so that you can enter a conditional test.

If Command

To execute a single command when a conditional test is true, use the general form:

If x>5
  Disp "x is greater than 5"  À
Disp x  Á

À Executed only if x>5; otherwise, skipped.

Á Always displays the value of x.

In this example, you must store a value to x before executing the If command.

If...Then...EndIf Structures

To execute one group of commands if a conditional test is true, use the structure:

If x>5 Then
  Disp "x is greater than 5"  À
  2¦x&x  À
EndIf
Disp x  Á

À Executed only if x>5.
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Á Displays the value of:
  2x if x>5
  x if x{5

Note: EndIf marks the end of the Then block that is executed if the condition is true.

If...Then...Else...EndIf Structures

To execute one group of commands if a conditional test is true and a different group if
the condition is false, use this structure:

If x>5 Then
  Disp "x is greater than 5"  À
  2¦x&x  À
Else
  Disp "x is less than or equal to 5"  Á
  5¦x&x  Á
EndIf
Disp x  Â

À Executed only if x>5.

Á Executed only if x{5.

Â Displays value of:
  2x if x>5
  5x if x{5

If...Then...ElseIf... EndIf Structures

A more complex form of the If command lets you test for multiple conditions. Suppose
you want a program to test a user-supplied argument that signifies one of four
options.

To test for each option (If Choice=1, If Choice=2, and so on), use the
If...Then...ElseIf...EndIf structure.

Lbl and Goto Commands

You can also control the flow by using Lbl (label) and Goto commands. These
commands reside on the Program Editor’s Transfers menu.

Use the Lbl command to label (assign a name to) a particular location in the function
or program.

Lbl labelName name to assign to this location (use the same
naming convention as a variable name)

You can then use the Goto command at any point in the function or program to branch
to the location that corresponds to the specified label.



Goto labelName specifies which Lbl command to branch to

Because a Goto command is unconditional (it always branches to the specified label),
it is often used with an If command so that you can specify a conditional test. For
example:

If x>5
  Goto GT5  À
Disp x
--------
-------- Á
Lbl GT5
Disp "The number was > 5"

À If x>5, branches directly to label GT5.

Á For this example, the program must include commands (such as Stop) that prevent
Lbl GT5 from being executed if x{5.

Using Loops to Repeat a Group of Commands

To repeat the same group of commands successively, use one of the loop structures.
Several types of loops are available. Each type gives you a different way to exit the
loop, based on a conditional test.

Loop and loop-related commands reside on the Program Editor’s Control and Transfers
menus.

When you insert one of the loop structures, its template is inserted at the cursor
location. You can then begin entering the commands that will be executed within the
loop.

For...EndFor Loops

A For...EndFor loop uses a counter to control the number of times the loop is repeated.
The syntax of the For command is:

For variable,
À

begin,
Á

end,
Â

increment
Ã

À Name of a variable to be used as a counter

Á Value assigned to variable when the For loop begins.

Â Value compared to the current value of variable at each iteration of the loop. The
loop exits when variable exceeds end.

Ã Value added to variable at each iteration of the loop (This argument is optional. The
default increment is 1.)
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At each iteration of the For loop, the variable value is compared to the end value. If
variable does not exceed end, the commands within the For...EndFor loop are executed
and the loop repeats; otherwise, control jumps to the command following EndFor.

Note: The For command automatically increments the counter variable so that the
function or program can exit the loop after a certain number of repetitions.

At the end of the loop (EndFor), control loops back to the For command, where the
counter variable is incremented and compared to end.

For example:

For i,0,5,1
  Disp i  À
EndFor
Disp i  Á

À Displays 0, 1, 2, 3, 4, and 5.

Á Displays 6. When variable increments to 6, the loop is not executed.

Notes:

• You can declare variable as local if it does not need to be saved after the function
or program stops.

• You can set end to a value less than begin, provided you also set increment to a
negative value.

While...EndWhile Loops

A While...EndWhile loop repeats a block of commands as long as a specified condition
is true. The syntax of the While command is:

While condition

WhenWhile is executed, condition is evaluated. If condition is true, the loop is
executed; otherwise, control jumps to the command following EndWhile.



Note: The While command does not automatically change the condition. You must
include commands that allow the function or program to exit the loop.

At the end of the loop (EndWhile), control jumps back to the While command, where
condition is re-evaluated.

To execute the loop the first time, the condition must initially be true.

• Any variables referenced in the condition must be set before the While command.
(You can build the values into the function or program, or you can prompt the user
to enter the values.)

• The loop must contain commands that change the values in the condition,
eventually causing it to be false. Otherwise, the condition is always true and the
function or program cannot exit the loop (called an infinite loop).

For example:

0&x  À
While x<5
  Disp x  Á
  x+1&x  Â
EndWhile
Disp x  Ã

À Initially sets x.

Á Displays 0, 1, 2, 3, and 4.

Â Increments x.

Ã Displays 5. When x increments to 5, the loop is not executed.

Loop...EndLoop Loops

A Loop...EndLoop creates an infinite loop, which is repeated endlessly. The Loop
command does not have any arguments.

Typically, you insert commands in the loop that let the program exit from the loop.
Commonly used commands are: If, Exit, Goto, and Lbl (label). For example:

0&x
Loop
  Disp x
  x+1&x
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  If x>5  À
    Exit
EndLoop
Disp x    Á

À An If command checks the condition.

Á Exits the loop and jumps to here when x increments to 6.

Note: The Exit command exits from the current loop.

In this example, the If command can be anywhere in the loop.

When the If command is: The loop is:

At the beginning of the
loop

Executed only if the condition is true.

At the end of the loop Executed at least once and repeated only if the condition
is true.

The If command could also use a Goto command to transfer program control to a
specified Lbl (label) command.

Repeating a Loop Immediately

The Cycle command immediately transfers program control to the next iteration of a
loop (before the current iteration is complete). This command works with For...EndFor,
While...EndWhile, and Loop...EndLoop.

Lbl and Goto Loops

Although the Lbl (label) and Goto commands are not strictly loop commands, they can
be used to create an infinite loop. For example:

As with Loop...EndLoop, the loop should contain commands that let the function or
program exit from the loop.

Changing Mode Settings

Functions and programs can use the setMode() function to temporarily set specific
calculation or result modes. The Program Editor’s Mode menu makes it easy to enter
the correct syntax without requiring you to memorize numeric codes.



Note: Mode changes made within a function or program definition do not persist
outside the function or program.

Setting a Mode

1. Position the cursor where you want to insert the setMode function.

2. From the Mode menu, click the mode to change, and click the new setting.

The correct syntax is inserted at the cursor location. For example:

setMode(1,3)

Debugging Programs and Handling Errors

After you write a function or program, you can use several techniques to find and
correct errors. You can also build an error-handling command into the function or
program itself.

If your function or program allows the user to select from several options, be sure to
run it and test each option.

Techniques for Debugging

Run-time error messages can locate syntax errors but not errors in program logic. The
following techniques may be useful.

• Temporarily insert Disp commands to display the values of critical variables.

• To confirm that a loop is executed the correct number of times, use Disp to display
the counter variable or the values in the conditional test.

• To confirm that a subroutine is executed, use Disp to display messages such as
“Entering subroutine” and “Exiting subroutine” at the beginning and end of the
subroutine.

• To stop a program or function manually,

- Windows®: Hold down the F12 key and press Enter repeatedly.
- Mac®: Hold down the F5 key and press Enter repeatedly.

- Handheld: Hold down thec key and press· repeatedly.

Error-handling Commands

Command Description

Try...EndTry Defines a block that lets a function or program execute a command
and, if necessary, recover from an error generated by that command.

ClrErr Clears the error status and sets system variable errCode to zero. For an
example of using errCode, see the Try command in the Reference
Guide.
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Command Description

PassErr Passes an error to the next level of the Try...EndTry block.



Using the TI-SmartView™ Emulator
With three layout options to choose from, teachers will find that the emulator
facilitates classroom presentations. In the teacher software, layout options are:

• Handheld only

• Keypad plus side screen

• Handheld plus side screen

In the student software, the TI-SmartView™ emulates the keypad, which along with
the handheld view, gives students the ability to drive the software as if using a
handheld.

Opening the TI-SmartView™ Emulator

The TI-SmartView™ emulator is located in the Documents Workspace. To open the
emulator view:

1. Open the Documents Workspace.

2. Click , which is located in the Documents Toolbox.

In the teacher software, the handheld is displayed with Handheld and SideScreen
panels open in computer mode as shown in the following illustration. You can use
the keypad on the emulated handheld, but the document won’t appear on the
emulated handheld screen until you switch to Handheld mode.

In the student software, the TI-Nspire™ CX keypad is displayed with the side screen
open in computer mode. You can use the keypad on the emulated handheld to work
with the document in the side screen in either computer mode or handheld mode.

Using the TI-SmartView™ Emulator 505



506 Using the TI-SmartView™ Emulator

3. Click View > Handheld.

—or—

Click in the status bar to switch to handheld mode.

Choosing a Keypad

An open document is not affected by changing the keypad. You can switch between
keypads anytime you want. To select a keypad:

1. In the emulator panel, click to open the menu and select one of the following

options:

• TI-Nspire™ CX
• TI-Nspire™ with Touchpad
• TI-Nspire™ with Clickpad

2. Click ¢ to select a faceplate option:

• Normal
• High Contrast
• Outline

Choosing Display Options

In the teacher software, use this option to choose how to display the emulator in the
software window.



1. In the emulator panel, click .
—or—
Click File > Settings > TI-SmartView™.

2. Select one of the following options:

• Handheld Only. Displays the emulated handheld and hides the workspace and
other panels.

Note: To keep the Handheld Only display in front of other application windows,
click Always in Front at the top right of the TI-SmartView™ panel.

• Keypad + SideScreen. Opens a larger view of the keypad along with the side
screen.

• Handheld + SideScreen. Opens the entire emulated handheld along with the
side screen.

Changing the Width of the TI-SmartView™ Panel

To change the width of the TI-SmartView™ emulator panel:

▶ Click the right edge of the panel and drag it until it is the width you want.

Changing the Size of the Screen in the Workspace

When in handheld mode, use the Scale to change the size of the screen.

▶ Drag the slider to the appropriate scale percentage. The scale slider is located on
the far right side of the status bar, at the bottom of the TI-Nspire™ window. Scale
percentages range from 100% to 200%. The default scale is 150%.

Note: If computer mode is selected, you cannot change the size of the workspace.

Working with the Emulated Handheld

To input data and work with files on the emulator, you can use the computer keyboard,
TI-SmartView™ keypad, TI-Nspire™ menus and icons, or any combination of these.

Note: Within one command, you cannot use a combination of both the keypad and the
keyboard. For example, you cannot press Ctrl on the keyboard and clickb on the
emulator to open a context menu.

For the most part, you can perform any function in the TI-SmartView™ emulator that
you can perform on the handheld. Keys and applications operate the same way.

Note: If you switch to Computer mode, you can still use most of the keys on the
emulated handheld or keypad and all keystrokes are reflected in the workspace.
However, some key combinations may only work in Handheld mode.
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As you click keys on the emulator or press keys on the keyboard that activate keys on
the emulator, those keys change color, making it easy for your audience to follow
along. The last key selected stays highlighted.

In the teacher software, the emulator screen and the side screen are both interactive.
You can click on icons and menu items on both screens. You can also right-click to
display menus on both screens.

All handheld shortcuts and arrow functionality work from the computer keyboard. For
example, to save a document, you can click/S on the emulator keypad or you can
press Ctrl + S on the computer keyboard. When using a Mac®, press “ + S.

Using the Touchpad

You can operate the Touchpad on the TI-Nspire™ Touchpad keypad using either the
touchpad on a laptop or by using the mouse to click the Touchpad. Areas of the
Touchpad are highlighted as you click the arrow zones.

Anarrow is highlightedwhen you press or tap it.

• Clicking the ¡, ¢,£, or¤ keys on the Touchpad moves through menus one item at
a time.

• Clicking and holding down an arrow on the Touchpad causes continual movement
in the selected direction.

• Clicking and sliding the mouse across the Touchpad area enables you to move the
mouse pointer.

• Clicking the middle of the Touchpad selects the highlighted menu option.

Using the Clickpad

You can use the Clickpad on the TI-Nspire™ Clickpad keypad using either the touchpad
on a laptop or by using the mouse to click the Clickpad. Areas of the Clickpad are
highlighted as you click the arrow zones.



• Clicking the ¡, ¢,£, or¤ keys on the Clickpad moves through menus one item at a
time.

• Clicking and holding down an arrow on the Clickpad causes continual movement in
the selected direction.

• Clicking the middle of the Clickpad selects the highlighted menu option.

Using Settings and Status

When working with the TI-SmartView™ emulator, you can change General Settings
and Document Settings. For more information, see Using the Documents Workspace.

You can view all other settings, but you cannot change them in the TI-SmartView™
emulator. However, the ability to view these options provides teachers with an
instructional tool when they need to show students how to set up a handheld.

To view settings and status:

1. Clickc to access the Home screen.

2. Click Settings.

Setting or
Settings

Description

Language You can open the languages menu and select a language, but you cannot
save changes. To change the language, use the TI-Nspire™ menu File >
Settings > Change Language option.

Handheld
Setup

You can open the menus and select items to demonstrate which items to
choose, but you cannot save any changes.

Handheld
Status

You can access the screen. The # symbol replaces any numeric values that
would be displayed on the handheld.

About You can open the About screen and view the software version. Other
information that pertains only to the handheld hardware is marked as
"Not Applicable."

Login You can display the Login to Class screen and type in the User Name and
Password fields. Login is not available.

Changing TI-SmartView™ Options

You can change the emulator options, even when the emulator panel is closed.

1. In the teacher software, click File > Settings > TI-SmartView™ Options.

The TI-SmartView™ Options dialog box opens.
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In the student software, click File > Settings > Keypad Options.

The Keypad Options dialog box opens.

2. Click Browse to change the folder where documents are saved and accessed in the
My Documents folder when using the emulator.

Important: If you change the TI-SmartView™ location, you must also copy or move
the MyLib folder and paste it to the new location to see library objects.

The default location of MyLib is:

• Windows®: Documents\TI-Nspire\MyLib.
• Mac®: Documents/TI-Nspire/MyLib.

Note: Close and reopen the TI-Nspire™ application for the libraries to reflect the
change.

3. Click¤ to open the menu and select a keypad.

4. Click¤ to open the menu and select a faceplate.

5. In the teacher software, click¤ to open the menu and select a view. If selecting
Handheld only, select Always in Front to keep this window on top of all other open
applications.

6. Click OK to save the settings.



Working with Documents

You can open multiple documents in the workspace by selecting File > Open Document
from the menu or using keyboard shortcuts. When you switch between these
documents, the emulated handheld shows only the current document. You can insert
pages and problems using either the TI-Nspire™ menus or icons, keyboard shortcuts, or
TI-SmartView™menus or shortcuts.

Note: You cannot work with PublishView™ documents using the TI-SmartView™
emulator. When you create or open a PublishView™ document, the document opens in
Computer mode.

Opening a Document

You can open a document by navigating to it on the emulator, the same way you open
a document on the handheld, or you click File > Open Document.

When you open a document using the emulator, you can only open documents that are
in the folder displayed on the emulator (usually the My Documents folder, unless you
specified a different folder in your TI-SmartView™ settings). When you open a
document using the menu path, you can browse to find any TI-Nspire™ document on
your computer or network. If you open a document using the emulated handheld, it
replaces the document that was previously open.

Note: If the number of characters in the document’s file path name exceeds 256
characters, the document cannot be opened and an error message is displayed. To
avoid this error, keep file and folder names short or move files up in the file path.

Saving a Document

When you save a document using the File > Save Document menu or icon, keyboard
shortcuts, keypad shortcuts, or emulator menus, the document is saved in the same
location where the file was opened. To save the file in another location or with a
different name, click File > Save As.

Using Screen Capture

To capture the current page, press Ctrl + J (Mac®: ì“ + J) on your keyboard or on the
emulated handheld. The image is automatically placed in the Clipboard and in the
TI-Nspire™ Screen Capture window. You can paste the image into another application
without having to take additional steps. This feature is only available when the
TI-SmartView™ panel is active and the workspace is in Handheld mode.

All other screen capture features work the same way they do in other areas of
TI-Nspire™ software. For more information, see Capturing Screens.
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Writing Lua Scripts
The Script Editor allows you to create and deliver dynamically linked simulations,
powerful and flexible utilities, and other educational content for exploring math and
science concepts. When you open a document containing a script, the script runs
automatically as programmed. To see the running script application, the page
containing the script application must be active.

The Script Editor is directed toward teachers and other authors who are comfortable
working in a Lua scripting environment. Lua is a powerful, fast, lightweight scripting
language that is fully supported in TI-Nspire™ and PublishView™ documents.
Documents containing script applications can be opened on TI-Nspire™ handhelds. The
script application runs on a handheld, but you cannot view or edit the script.

Note these resources for using the Script Editor and creating scripts:

• Press F1 to access the TI-Nspire™ help, which includes the Script Editor help.

• Press F2 for additional TI-Nspire™ resources such as scripting samples and a link to
the TI-Nspire™ Scripting API library. (This information is also available at
education.ti.com/nspire/scripting.)

• Go to lua.org for more information about Lua.

Overview of the Script Editor

With the Script Editor, you can insert, edit, save, run, and debug script applications
in TI-Nspire™ (.tns files) and Publishview™ (.tnsp files) documents.

• Script applications function within documents, problems, and pages the same way
that other TI-Nspire™ applications do.

• When you create a new document or open an existing document, you can insert or
edit a script application within a page or within a work area of a split page.

• In a split page layout, you can add a script application to each work area of a page.
A page can be split into a maximum of four quadrants.

• Images can be added to script applications. See the Inserting Images section.

• All work done in the Script Editor is lost if you close the TI-Nspire™ or
PublishView™ document without saving it.

Exploring the Script Editor Interface

The Script Editor window opens when you insert a new script application or edit an
existing script application in a TI-Nspire™ or PublishView™ document.

Select options for creating new scripts or editing scripts from the Insert menu in the
Documents Workspace when a document is open.

Note: Although not labeled, the Documents Workspace is the default workspace in the
TI-Nspire™ CX Student Software and TI-Nspire™ CX CAS Student Software.

The following figure shows the Script Editor with an existing script.
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Menu bar. Contains options for working with the Script Editor.

Toolbar. Provides tools for common Script Editor functions. See Using the Toolbar .

Script title. Shows script title. Right-click the title to change it or by clicking Edit >
Set Script Title.

Text box. Provides a space to type script text.

Tools panel. Shows script data. See Using the Tools Panel.

Status bar. Displays the operational state of the script. See Using the Status Bar.

Using the Toolbar

The following table describes the toolbar options.

Tool name Tool function

Suspend
Script

Pauses the script execution.

Resume
Script

Resumes the script execution.
While debugging, the script continues to execute until the
next breakpoint or the end of the script.

Set Script Starts the script execution.



Tool name Tool function

Focus
Script

Sets the focus to the page in the document where the script
application is attached:

• In a TI-Nspire™ document, sets the focus to the page.

• In a PublishView™ document, sets the focus to the
frame on the page.

Step Into While debugging, executes the current statement. If the
statement calls any functions, the debugger stops at the first
line of each function.

Step Over While debugging, executes the current statement.
If the statement calls any functions, the debugger does not
stop within the function unless the function contains a
breakpoint.

Enable
Breakpoints

Switches from normal mode to debugging mode.

Disable
Breakpoints

Switches back from debugging mode to normal mode and
resumes the script.

Set
Permissions

Sets permission levels to Protected, View Only, or
Unprotected and allows you to set a password for the script.

Using the Tools Panel

At the bottom of the window, the Tools panel shows the scripting data. For more
information, see the Debugging Scripts section.

Tab Window Display

Console Script errors are printed here.
Print statements embedded in the script also print here.

Globals Selected global variables are displayed.
To select a global variable for display, select Click to add new watch
variable at the bottom of the Tools panel.

Call Stack Displays the call tree for the currently executing function.

Locals Local variables in the current function’s scope are displayed.

Resources Upload, insert, and manage images here.
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Using the Status Bar

The status bar at the bottom of the window shows basic script data, as described in
this example:

stopwatch, 1.1, 4:1, Running

• Name of the document that the script application is attached to (stopwatch)

• Problem and page number (1.1)

• Script line and character, (4:1 describing line 4 and character 1)

• Operational state of the script (Running). Note the possible states:

- Normal mode: Running, Paused, or Error
- Debugging mode: Running (debugging), Paused, or Error

Inserting New Scripts

To insert a new script application and script, follow these steps.

1. Open the document where you want to insert the script. It can be a new or existing
document.

2. Click Insert > Script Editor > Insert Script.

A script application is inserted, and the Script Title dialog box opens.

Note: The TI-Nspire™ CX Student Software and the TI-Nspire™ CX CAS Student
Software open automatically within the Documents Workspace.

3. Type a script title. (The maximum number of characters is 32.)

4. Click OK.

The Script Editor window opens showing a blank script.

5. Type your text in the script lines.

Note: Some nonstandard UTF-8 wide characters may not be displayed correctly.
For these characters, it is highly recommended that you use the string.uchar
function.

6. When the script is complete, click Set Script to execute it.

• In a TI-Nspire™ document, the script application is inserted in a new page.
When the page containing the script application is active, the Documents
Toolbox is empty.

• In a PublishView™ document, a frame containing the script application is added
to the active page. You can move or size this frame just as you would any other
PublishView™ object, and you can add other PublishView™ objects to the page.

7. To view the script application, click Focus Script.

Zooming Text in the Script Editor

You can adjust the size of the text in your script and in any of the tool panels.



Menu Method

1. Click in the area of the text to zoom.

2. On the Viewmenu, select Zoom, and then select Zoom In, Zoom Out, or Restore.

Note that the menu also displays keyboard shortcuts for the Zoom commands.

Mouse Method

1. Postion the mouse pointer over the area to zoom.

2. Hold Ctrl, and roll the mouse wheel forward or back.

Editing Scripts

To edit an existing script, follow these steps.

1. Open the TI-Nspire™ or PublishView™ document that contains the script. The page
containing the script must be active.

2. Select the page and the work area that contains the script.

3. Click Insert > Script Editor > Edit Script.

The Script Editor opens showing the script. If the selected work area on the page
does not contain a script, Edit Script is dimmed.

If the script is password protected, the Password Protected dialog box opens
prompting for a password.

4. Make any desired changes.

• To designate comments, use double hyphens (--) at the start of each comment
line.

• To change the title, click Edit > Set Script Title or right-click the title and click
Set Script Title.

Notes:

• Some nonstandard UTF-8 characters may not be displayed correctly. For these
characters, it is highly recommended that you use the string.uchar function.

• The print function may yield unexpected results for non–UTF-8 characters.
• Some nonprintable characters returned by the on.save function will be

discarded.

5. To execute the script, click Set Script.

Any errors are displayed in the Console area in the Tools panel.

6. To view the script application (running script), click Focus Script.

Changing View Options

To change viewing options:
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▶ To clear the scripting data in the Tools panel and restore the editor defaults, click
View > Restore Editor to Defaults.

▶ To view the script title in the document and before each print statement in the
Console, click View > Title in Document View.

▶ To hide or show toolbar labels, click View > Toolbar Text Labels.

▶ To show or hide the Tools panel or its areas, click View > Tools Panel and click the
appropriate option.

▶ To create tab groups when multiple scripts are open, right-click one of the titles
and click New Horizontal Group or New Vertical Group.

Setting Minimum API Level

Each release of the T-Nspire™ software includes API support for a specific set of Lua
scripting features. Setting the minimum API level for a script lets you specify a
minimum set of features that you require for your script.

If a user tries to run the script on a system that does not meet the script's minimum
API level, a message notifies the user and prevents the script from running.

To Set the Minimum API Level for a Script:

1. Determine the minimum level that you want your script to require.

- Setting the level too low for the script's feature set can result in a script error
on older software.

- Setting the level too high can result in the script refusing to start on older
software that supports the feature set.

2. On the Script Editor File menu, select Set Minimum API Level.

3. In the dialog box, type the minimum level using the format major.minor. For
example, you might type 2.3.

This API level or higher will be required for running the script.

Saving Script Applications

Clicking Set Script resets (updates) a script application in a TI-Nspire™ or PublishView™
document. However, the script and script application are not saved until you save the
document. If you close the document or close the TI-Nspire™ software without saving,
work on the script is lost.

To ensure the script application is saved after all work is complete, follow these steps.

1. From the Script Editor window, click Set Script to reset (update) the script
application in the document.

2. From an open document, click File > Save Document to save changes to the
TI-Nspire™ or PublishView™ document.

Note: To ensure work is backed up, set the script and save the document frequently.



Managing Images

To insert an image into a script application, follow these steps.

Add an Image to Resources

1. Click the Resource tab.

2. Click the button.

3. Click on an image file name.

4. Click Open.

5. Accept the default image name or rename the image by typing a new name into
the box. (Ex: newimage)

6. Click OK.

Note: You will see the image thumbnail in the bottom-right corner of your screen.
Your image file name will appear in a list of images at the bottom-left of your
screen.

7. Right-click an image name to Rename, Copy Name, Preview, or Remove the
image. You may also click the button to remove an image.

AddMultiple Images to Resources

1. Click the Resource tab.

2. Click the button.

3. Select Comma Separated Values (*.csv) from the Files of Type menu.

4. Select your .csv file.

Note: The .csv format consists of two comma-separated columns. The first column
is the local name of the image resource used in the code. The second column is the
absolute path to the image on the current system.

Example for Windows:

bridge,C:\images\bridge.jpg

house,C:\images\house.jpg

5. Click Open.

6. Right-click an image name to Rename, Copy Name, Preview, or Remove the
image. You may also click the button to remove an image.

Create a Script to Call Up an Image

1. Type a script in the script line box as follows:

myimage = image.new(_R.IMG.img_1)
function on.paint (gc)
  gc:drawImage (myimage, 30, 30)
end
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Note:Replace img_1 (above) with the name of your image.

2. Click Set Script to save the script. You will see your image in the Document Preview
screen.

3. Click Focus Script to set the focus to the page in the document where you want to
attach the script application.

Note: A TI-Nspire document sets the focus to the page; A PublishView™ document
sets the focus to the frame on the page.

Create a Script to Call Up Multiple Images

1. Type a script in the script line box as follows:

myimg = { }
for name, data in pairs (_R.IMG)

myimg [name] = image.new(data)
end
function on.paint (gc)

gc:drawImage (myimg[imagename], 30, 30)
end

2. Click Set Script to save the script. You will see your image in the Document Preview
screen.

3. Click Focus Script to set the focus to the page in the document where you want to
attach the script application.

Note: A TI-Nspire document sets the focus to the page; A PublishView™ document
sets the focus to the frame on the page.

Setting Script Permissions

You can set permission levels for a script and specify a password to protect a script.
Follow these steps.

1. In the Script Editor window, click File > Set Permissions.

The Set Permissions dialog box opens.

2. In the Permissions Level area, select the appropriate security level:

• Protected. The script can be run, but not viewed or edited.
• View only. The script can be viewed, but not edited.
• Unprotected. The script can be viewed and edited.

3. To secure a script, designate a password in the Security area.

Note: Use caution when setting passwords because they cannot be recovered.

4. Click OK.

The next time you click Insert > Script Editor > Edit Script, a Password Protected dialog
box opens prompting for the password. Choose one of these options:



• To edit the script, enter the password and click OK.

• To view the script only, do not enter the password and click View.

Debugging Scripts

You can debug your script to investigate runtime errors and trace the execution flow.
While debugging, data is displayed in the Tools panel.

▶ To enable debugging mode or disable it and return to normal mode, click Debug >
Enable Breakpoints or Disable Breakpoints.

Note: Disabling breakpoints always resumes the script execution.

▶ While debugging, click Step Into and Step Over as appropriate. See the Exploring
the Script Editor Interface section.

▶ To set breakpoints, double-click in the space to the far left of the line number.
Breakpoints are disabled until you click EnableBreakpoints.

▶ Note these factors when debugging:

• Breakpoints in coroutines are not supported.
• If a breakpoint is set in a function that is a callback, the debugger may not stop

at the breakpoint.
• The debugger may not stop at functions such as on.save, on.restore, and

on.destroy.

On the toolbar, Step Into and Step Over are enabled when breakpoints are enabled.

▶ To suspend and resume the script execution, click Suspend Script and Resume
Script. When the script resumes, it runs until the next breakpoint is encountered or
to the end of the script. A script can be suspended in normal mode or debugging
mode.
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Using the Help Menu
Use the Help menu to find useful information to help you use the software more
productively. You can:

• Open the PDF help file (press F1 or click Help).

• Open the web-based help file (press F2 or click Online Help).

• Activate your software license.

• Register your TI product.

• Explore TI resources such as Activities Exchange, where you can find lessons,
quizzes, and other instructive activities shared by educators.

• Explore online troubleshooting.

• Check for updates to the software or updates to operating systems for TI-Nspire™
handhelds and the TI-Nspire™ Lab Cradle.

• Check to see which version of the software you are using.

Activating Your Software License
1. Ensure that your computer is connected to the Internet.

2. From the Help menu, select Activate to open the Texas Instruments Activation
Wizard.

3. Click Activate your License, and then click Next.

The Complete Software Activation dialog box opens.

4. Complete the name and email fields, and then select the region where you live if
different from the default entry. If you want to receive emails from TI about
updates, support, and promotions, ensure the check box is selected.

5. Click Next.
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The Activate your software dialog box opens.

6. Type the license number.

7. Click Next.

The License Agreement dialog box opens.

8. In the Country field, select your country from the drop-down list if it is different
from the default entry.

9. Review the license agreement, and then select to accept the agreement.

10. Click Activate. The license number is validated against the TI database to ensure it
is valid.

If the license number is valid, the Successful Activation dialog box opens. If the
license number is not valid, check to make sure the numbers are entered correctly.
If the problem persists, contact TI Support.



11. Click Next to continue, or select Finish to complete the installation with default
settings.

12. When prompted, click OK to accept the default location for your TI-Nspire™ folder.
If needed, navigate to the location on your computer where you want to store your
TI-Nspire™ documents and files.

13. Select whether or not to replace any documents that have the same name.

The software launches and the Welcome Screen opens.

Registering Your Product
1. Ensure that your computer is connected to the Internet.

2. From the Help menu, select Register to access the TI Product Registration site.

3. Follow the instructions on the website.

Downloading the Latest Guidebook
1. Ensure that your computer is connected to the Internet.

2. From the Help menu, select Download latest Guidebook.

The Education Technology website opens with the Guidebooks tab active.

3. Click the title of the Guidebook that you want to download.

A PDF version of the Guidebook opens on your desktop.

Exploring TI Resources

The Help menu also provides links to TI resources and websites.

▶ Select Help > Visit education.ti.com to access the Texas Instruments Education
Technology website.
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▶ Select Help > Visit Activities Exchange to access the Texas Instruments Activities
Exchange, site, a forum where you can browse by subject to find ready-to-use math
and science learning activities appropriate for middle grades through college.

Note: Activities available for download may vary depending on your geographical
region.

▶ Select Help > Explore Online Troubleshooting to access the TI Knowledge Base
where you can find general information, troubleshooting help, product usage tips,
and information specific to TI products.

Updating the TI-Nspire™ Software

Update the Software

1. Ensure that your computer is connected to the Internet.

2. Close any open documents.

3. From the Help menu, select Check for Upgrades and Notifications.

• If your software is current, a confirmation message appears.
• If your software is not current, you are prompted to update.

4. Click Update to download and install the update, or click Close to cancel.

A progress indicator shows the download progress. If you receive a connection
error, check your Internet connection and try again.

Note for users updating TI-Nspire™ Navigator™ Teacher Software or TI-Nspire™
Navigator™ NC Teacher Software: Your portfolio and class records reside on your
computer as a database. Because the new software might have features that are not
supported in the old database structure, the old data might need to be converted.
When conversion is necessary, a Database Update tool helps you make a backup of the
old database. The tool appears during the first startup of the updated software.

Manage Automatic Checking

Automatic checking uses the Internet to check for upgrades each time you open the
TI-Nspire™ software. If your system is not up-to-date, you receive a notification. You
can turn automatic checking on or off.

1. From the Help menu, select Check for Upgrades and Notifications.

2. Check or clear the Automatically check for updates check box.

3. Click Close.

Updating the OS on a Connected Handheld

Note: To avoid losing unsaved data, close all documents on the handheld before
updating its operating system.

1. Ensure that your computer is connected to the Internet.



2. In the Documents Toolbox, click the Content Explorer tab to show connected
handhelds.

3. Select the handheld that you are updating.

4. From the Help menu, select Check for OS Updates.

• If the operating system is current, a confirmation message appears.

• If the operating system is not current, the TI-Nspire™ software prompts you to
install the latest OS now. If the updated OS file is not already available on your
computer, you can choose a location for it.

5. Click Continue and follow the prompts to install the OS on the handheld, or click
Close to cancel.

When the update is complete, the handheld restarts automatically.

Viewing Software Version and Legal Information
1. From the Help menu, select About TI-Nspire™ <Product Name>Software.

Note: You do not need an Internet connection to open this screen.
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2. Click OK to close the window.

Helping Improve the Product

This product includes a feature that can help TI improve the product by automatically
collecting anonymous information about product usage and reliability.

Note: Depending on how your software was installed, you might see a product
improvement screen the first time you start the software. You also can access the
feature manually.

1. From the Help menu, select Product Improvements.

2. Read the information on the screen, and click one of the buttons:

- To allow information to be collected, click Yes, I want to help.
- To prevent collection, click No thanks.



General Information

Texas Instruments Support and Service

General Information: North and South America

Home Page: education.ti.com
KnowledgeBase and e-mail inquiries: education.ti.com/support
Phone: (800) TI-CARES / (800) 842-2737

For North and South America and U.S.
Territories

International contact information: education.ti.com/support/worldwide

For Technical Support

Knowledge Base and support by e-mail: education.ti.com/support or
ti-cares@ti.com

Phone (not toll-free): (972) 917-8324

For Product (Hardware) Service

Customers in the U.S., Canada, Mexico, and U.S. territories: Always contact Texas
Instruments Customer Support before returning a product for service.

For All Other Countries:

For general information

For more information about TI products and services, contact TI by e-mail or visit the
TI Internet address.

E-mail inquiries: ti-cares@ti.com
Home Page: education.ti.com

Service and Warranty Information

For information about the length and terms of the warranty or about product service,
refer to the warranty statement enclosed with this product or contact your local Texas
Instruments retailer/distributor.
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This guidebook applies to TI-Nspire™ software version 4.5. To obtain the latest version
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Important Information

Except as otherwise expressly stated in the License that accompanies a program, Texas
Instruments makes no warranty, either express or implied, including but not limited to
any implied warranties of merchantability and fitness for a particular purpose,
regarding any programs or book materials and makes such materials available solely
on an "as-is" basis. In no event shall Texas Instruments be liable to anyone for special,
collateral, incidental, or consequential damages in connection with or arising out of the
purchase or use of these materials, and the sole and exclusive liability of Texas
Instruments, regardless of the form of action, shall not exceed the amount set forth in
the license for the program. Moreover, Texas Instruments shall not be liable for any
claim of any kind whatsoever against the use of these materials by any other party.

QR Codeë is a registered trademark of DENSO WAVE INCORPORATED.

© 2011 - 2017 Texas Instruments Incorporated
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What's New

What's New in Version 4.5

Unit Conversions

• Unit conversions are now available.

• A Unit Conversion Assistant has been added that allows the user to automatically
generate unit conversion statements without having to type each unit.

Constants and Values

• Scientific constants are now available.

• New scientific constants have been added.

• Values for scientific constants have been updated.

Program Editor

• The following enhancements have been made to the Program Editor to reduce the
number of steps to run a program or function and avoid potential syntax errors
caused by the location of the cursor.

- Added a Run item to the Check Syntax & Store menu. This automatically inserts
a new Calculator application (if one doesn't exist) and pastes the name of the
current program or function into the Calculator.

- When creating a new program or function, the cursor now defaults to the first
blank line instead of inside the parentheses.

- When editing inside a quotes template such as Disp or Send commands,
pressing the Enter key will now create a new line instead of remaining inside
the template.

Programming Updates

• DispAt - Allows the user to create a dashboard-like display of data from a loop
rather than a long and growing list. This also reduces the amount of history stored
which will improve the overall performance of programs that run for long periods
of time.

To report issues and help us improve our apps, please email us at ti-cares@ti.com.

What's New 1
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Getting Started
The TI-Nspire™ App for iPad® enables you to use the TI-Nspire™ Student Software or
TI-Nspire™ CAS Student Software on an iPad®.

What You Can Do

You can use the TI-Nspire™ App for iPad® and TI-Nspire™ CAS App for iPad® to:

• Perform calculations

• Work with variables

• Import images (photos)

• Respond to questions

• Perform graphing and geometry functions

• Create lists and spreadsheets

• Analyze data

What You Must Know

Accessing Online Help

The TI-Nspire™ App for iPad® includes online help, which opens in the Safari browser.

▶ To access the online help from within the app, tap Settings , and then tap Online
Help.

Using the TI-Nspire™ Home Screen

By default, the TI-Nspire™ Home screen contains two pre-loaded folders (Math and
Simulations), and three Getting Started documents: Getting Started with the
TI-Nspire™ App, Getting Started with Data and Statistics, and Getting Started with
Graphs. All folders and documents that you create are added to the TI-Nspire™ Home
screen.

Getting Started 2
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Note: TI-Nspire™ App for iPad® supports only TI-Nspire™ documents.

To return to the TI-Nspire™ Home screen from any other screen within the application,
tap Home .

About Folders

The default Math and Science folders and any folder you create are yellow. You can:

• Change folder names

• Add documents to these folders or delete documents from these folders

• Delete the folders

Folders that have been synchronized with Dropbox are blue. Once a folder is
synchronized with drop box, you cannot delete it. You can, however, synchronize them
with your Dropbox account, add or delete documents, and select to show or hide them
on the Home screen.

Accessing Settings
1. From the TI-Nspire™ Home screen, tap Settings  .

2. Tap the option names to:

• Online Help. Open the TI-Nspire™ online help.
• ShowMyLib Folder. Select to show or hide the MyLib folder.
• Show Touch. Select to show or hide touches to the screen.
• Dropbox Account. Synchronize folders and documents to your Dropbox account.
• Export to PDF - Header Title. Change the default title for exported PDFs.
• Reset Content. Deletes all user-created TI-Nspire™ documents and folders,

clears the Clipboard, and restores the factory default documents. Warning: You
cannot undo this action. For details, refer to Resetting TI-Nspire™ Content .

• About. Read information about the app, and check the version of the app.



• Privacy Policy. Open the Texas Instruments Online Privacy Policy.

3. Tap Done to return to the TI-Nspire™ Home screen.

Managing Folders

In the TI-Nspire™ App for iPad®, management of folders is completed on the Home
screen.

Opening Folders

▶ Tap the folder icon to open a folder.

• When you open a folder, all documents within the folder are displayed.

• Tap a document icon to open a document within the folder.

• Tap the folder to close the folder without opening any of the documents.

Adding New Folders

1. Tap New, and then tap Folder.

2. To name the folder, tap the default name assigned to the folder.

3. Type a new name and tap return.

Getting Started 4
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Note: Folders can contain documents, but cannot contain sub-folders.

Creating a Folder with Existing Documents

You can also create a new folder by dragging one document onto another document.

1. Tap Edit.

2. Drag one document onto another document to create a new folder that contains
both documents.

3. Tap Done.

4. Rename the folder if needed.

Renaming Folders

1. Tap the default name under the folder.

The keyboard opens.

2. Type a new name, and then tap return.

The new name is displayed and the keyboard closes.

Note: To return to the TI-Nspire™ Home screen without renaming the item, tap a blank
area on the screen.

Deleting Folders

Before you delete a folder, remember that folders may contain several documents. You
may want to verify the folder contents before you delete it.

1. Tap Edit.

2. Tap on the folder you want to delete.

• Tap Delete to delete the folder.

• Tap Cancel to cancel the delete.

3. Tap Done.

Managing Documents

In the TI-Nspire™ App for iPad®, organizing and managing documents is completed on
the Home screen.



Opening a Document

▶ Tap the document icon.

The document opens to the last problem and page you were working on.

Adding New Documents

1. Tap New.

2. Tap an application name.

A new document opens with the selected application as the first page. The new
document is assigned a default name.

Renaming Documents

1. Tap the default name under the document to open the keyboard.

2. Type a new name, and then tap return.

The new name is displayed and the keyboard closes.
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Moving Documents to an Existing Folder

1. Tap Edit.

2. Drag the document on top of the folder.

3. Tap Done.

Deleting Documents

Before you delete a document, remember that the document may contain several
problems and pages. You may want to verify all the contents before you delete the
document.

1. Tap Edit.

2. Tap on the document you want to delete.

3. When the Alert message is displayed:

• Tap Delete to delete the document.

• Tap Cancel to cancel the delete.

4. Tap Done.

Selecting a Preferred Language

The TI-Nspire™ App for iPad® is available in several languages. To select a preferred
language:

1. From the iPad® Home screen, tap Settings > International > Language.

2. Tap a language name to select it.

The app changes to the selected language.

Note: The TI-Nspire™ App for iPad® is not available in all languages listed in the
iPad® settings. If you select a language that is not supported, the keyboard
supports the text, but the TI-Nspire™ app runs in English.

Selecting an International Keyboard

International keyboards can be used in the TI-Nspire™ App for iPad®. To select an
another keyboard:

▶ From the iPad® Home screen, tap Settings > International > Keyboards.

After you select an additional keyboard from the iPad® settings, the Native iPad®
Keyboard displays a Globe key to enable you to choose from the different

keyboards.



Using TI-Nspire™ App for iPad® Keyboards

The TI-Nspire™ App for iPad® has two keyboards: the Native iPad® Keyboard and the
TI-Nspire™ Keyboard.

▶ To type text and numbers, tap to show the Native iPad® Keyboard, which
is the standard alpha-numeric keyboard.

Note: This keyboard changes when you select language options.

▶ To insert common TI-Nspire™ functions, templates, and math expressions, tap
to show the TI-Nspire™ Keyboard.

Accessing Alternate Functions

On the TI-Nspire™ Keyboard, many keys have alternate functions related to the symbol
marked on the key. Keys with alternate functions are shown with a colored stripe on
top.

Example of alternate functions.

Stripe indicates that alternate functions are available.

▶ To access an alternate function, touch and hold the key, and then slide your finger
to the desired function.

Two recently added alternate functions are circled below.
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Using Custom TI Keyboard for Dialog

Every dialog inside the application has a custom keyboard available.

Example:

Go to Graphs > Tools > Window/Zoom > Window Settings.

The Window Settings dialog appears.

Tap in any field.

The custom keyboard for dialog is available.

Note: The following keys are not available.

• Chem Box

• Math box

• Variable Keys

• Arrow Up

• Arrow Down

Resetting TI-Nspire™ Content

The Reset Content option gives you a way to prepare an iPad® for a test or quiz by
removing all user-created TI-Nspire™ documents and folders.

WARNING: You cannot undo this action.

Resetting Content does the following:

• Permanently deletes all user-created TI-Nspire™ files and folders.

• Restores the factory pre-loaded documents and MyLib folder.
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• Clears the Clipboard to prevent the pasting of unauthorized information.

• Logs out of Dropbox and does not retain the Dropbox ID.

To Reset Content:

1. From the TI-Nspire™ Home screen, tap Settings  .

2. Tap Reset Content.

An alert message appears.

3. To proceed with the reset, tap Reset.

After the reset is complete, the TI-Nspire™ Home Screen reappears.

Scanning a QR Code® with the Camera

A QR Code® is an image that stores information, such as the address of a web site or
TI-Nspire™ document, as a pattern of small squares.



Webaddress http://education.ti.com stored as aQR Code®.

Typically, the QR Code® image is printed or projected so that you can extract the
information using your device camera. TI-Nspire™ App for iPad® supports QR Code®
scanning with the camera.

Note: You can use the App to scan a QR Code® embedded on a Notes page without
using the camera. For details, refer to Using a Displayed QR Code®.

To Scan a QR Code® with the Camera:

1. Start on the Home Screen of the App.

2. Tap the scanning tool on the toolbar.

3. The scanner window appears with the camera active and ready to scan.

4. Aim the camera at the QR Code®. Scanning occurs automatically.

- If the target is a TI-Nspire™ document (.tns file), the App automatically
downloads and opens it.

- Otherwise, the App opens your web browser to resolve the target.

Getting Started 12
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Working with Documents
All work created using TI-Nspire™ applications is stored in a TI-Nspire™ document (.tns
file), which you can share with others.

A document consists of one or more problems and each problem contains one or more
pages. A single page is displayed in the work area. All work occurs in the applications
within pages.

When you add a new document, the selected application is the first page of the
document.

The TI-Nspire™ Toolbar.

Page Sorter.

Document toolbar.

Document work area. This example shows the Lists & Spreadsheet work area.

What You Must Know

You add, rename, duplicate, and delete documents from the TI-Nspire™ Home screen.
See Getting Started with the TI-Nspire™ App for iPad® for information about adding,
renaming, and deleting documents.

Documents can reside on the TI-Nspire™ Home screen as a single document, or reside
in folders with other documents. There are different types of folders:

Working with Documents 14
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• Dropbox folders - These are folders that have been synchronized with Dropbox. You
cannot delete these folders. You can, however, synchronize them with your
Dropbox account, add or delete documents, and select to show or hide them from
the TI-Nspire™ Home screen.

• Created folders - These are folders you create. You can edit and delete these
folders, and add or delete documents.

• MyLib folder - The MyLib folder contains library documents. This folder is shown if
you have chosen to show it in Settings  menu.

Note: In the TI-Nspire™ App for iPad®, folders can contain documents, but cannot
contain sub-folders.

Exploring the TI-Nspire™ Toolbar

The TI-Nspire™ Toolbar contains tools available for use in open documents.

Home. Return to the TI-Nspire™ Home screen.

Add. Add a new page or problem to a document.

Name Document Name. The name of the active document.

Open In. Show all apps that can open a TI-Nspire™ document.

Share. Share the active document using Export to PDF or Email Document.

Settings. Apply document settings for the active document or to all
documents.

Help. Access Online Help or the PDF Guidebook.

Exploring the TI-Nspire™ Page Sorter

The TI-Nspire™ Page Sorter contains tools available for use in open documents.

RAD Angle Mode. Shows an abbreviation of the angle mode (degrees, radians, or
gradients) in effect.

PageSort. Hide or show the Page Sorter.

Utilities. Access utilities for the active application (symbols, catalog, etc.).



Undo/Redo. Undo or Redo the last action. Tap to Undo. Touch and hold to
display Redo option.

Camera. Take a photo, add a photo, or insert an existing photo in a
document.

Note: You can insert photos in the Graphs, Geometry, Data & Statistics,
and Notes applications.
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Using TI-Nspire™ Page Sorter

The TI-Nspire™ Page Sorter contains tools available for use in open documents.

Hide or Show Pages

To show or hide pages in an open document:

1. Tap the Page Sorter icon to show pages.

Note: All pages in the document will slide open from the right.

2. Tap the Page Sorter icon or anywhere on the screen to hide the pages.

Move a Page

▶ Press and hold a page to move to a different position.

Page Options

1. Double tap on a page to see available options.

- Cut

- Copy

- Delete



Hide or Show Problem

1. Tap once on the problem name to show all pages.

2. Tap once to on the problem name to hide all pages.

Rename a Problem

1. Tap twice on the problem name.

2. The keyboard appears.

3. Type the new problem name.

4. Tap on the dismiss key to hide (or dismiss) the keyboard.

Switch Pages

To switch to the previous page, or switch to the next page, swipe from the edge of a
page.
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Note: The "Swipe from the edges to navigate pages." dialogue box will appear after a
new installation or after an app update.

Exploring the Document Work Area

The document work area consists of the application toolbar, the open document, and
the page sorter.

From open documents on the work area, you can add, delete, and rearrange pages in
documents, and you can rename problems.



Page Sorter. Displays thumbnail sketches of all pages in all
problems in the current document. Swipe up or down to view
pages off the screen.

Application. Icon indicates which application is active in the work
area.

Calculator

 Graphs

 Geometry

Lists & Spreadsheet

Data & Statistics

Notes

1.2 Problem/Page Number. Displays the problem number followed by
the page number.

Tools. Opens the tools menu for the active application.

Tools Search allows you to search options and menus. It is available
across all applications in the
TI-Nspire™ App.
Warning: Tools Search will allow you to search for menu items, but
not for command names.

Inspector. Tap to change the properties of a selected item.

Settings. Tap to change the Graphs & Geometry settings.

History. In the Graphs application, shows the history of the defined
functions.
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Show/Hide. In the Graphs application, shows or hides the keyboard.

Opening a New Document
1. On the TI-Nspire™ Home screen, tap New.

The New menu opens.

2. Tap an application name.

A new document opens with the selected application as the first page. The new
document is assigned a default name.

Saving Changes to Documents

When you tap Home from an active document, the TI-Nspire™ App gives the following
options:

• If you added a new document:

- Tap Keep Changes to save and name the document.
- Tap Discard Changes to close the document without saving it.

• If you are working on an existing document and make changes:

- Tap Keep Changes to save as a new document.
- Tap Discard Changes to close the document without keeping any changes you

made. The name of the document is also unchanged.

• If you open an existing document but do not make any changes, the app does not
ask you to keep any changes.

Adding Pages to Documents
1. In the page sorter, tap the page in the problem where you want to add another

page.

2. Tap Add.

The New Page menu opens.

3. Tap the type of application you want to add to the document.

A new page is added to the document beneath the current page.

Note: To move a page, touch and hold the page, and then drag it to another
position.

Adding Problems to Documents
1. From an active document, tap Add.



2. Tap Problem.

3. Tap the type of problem you want to add to the document.

A new problem is added beneath the current problem in the page sorter.

Note: To rename the problem, double-tap the problem name, type the new name,
and then tap return.

Deleting Pages from Documents
1. In the page sorter, tap the page you want to delete to select it.

2. Tap the page again to open the context menu.

3. Tap Delete.

• To delete the page, tap Delete Problem Page.
• To cancel the delete, tap anywhere outside of the Confirm Delete box.

Copying and Pasting Pages in Documents

You can cut, copy, and paste pages from documents to other places in the active
document or in another document.

Copying or Cutting Pages

1. In the page sorter, tap the page you want to cut or copy.

2. Tap again to open the context menu.

3. Tap cut or copy.

Pasting Pages to Another Location

1. Tap the page in the page sorter where you want to paste.

2. Tap again to open the context menu, and then tap paste.

The page is pasted beneath the selected page in the problem.
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Changing Document Settings

Document settings control how all numbers, including elements or matrices and lists,
are displayed in TI-Nspire™ documents. You can change the default settings at any
time, and you can specify settings for a specific document.

Complete the following steps to customize the settings that are applied to your
document.

1. Create a new document or open an existing document.

2. Tap Settings  .

When you open Document Settings the first time, the default settings are
displayed.

3. Tap the menu name to open the menu and view the available values for each
setting.

.

Field Value

Display Digits • Float
• Float1 - Float12
• Fix0 - Fix12

Angle • Radian
• Degree
• Gradian

Exponential Format • Normal
• Scientific
• Engineering

Real or Complex Format • Real
• Rectangular
• Polar

Calculation Mode • Auto
• CAS: Exact
• Approximate

Note: Auto mode shows an answer that is not a
whole number as a fraction except when a decimal is
used in the problem. Exact mode (CAS) shows an
answer that is not a whole number as a fraction or in
symbolic form, except when a decimal is used in the
problem.



Field Value

Vector Format • Rectangular
• Cylindrical
• Spherical

Base • Decimal
• Hex
• Binary

Unit System (CAS) • SI
• Eng/U.S.

4. Select the desired settings.

5. Choose one of the following options:

• To apply the customized settings to ALL documents, tapMake Default.
• To apply the settings to the open document only, tap Done.
• To restore default settings, tap Restore.

Sharing Documents

Sharing Documents Using Dropbox

You can synchronize documents to your Dropbox account and share those documents
on your iPad® mobile digital device, computer, and other devices.

1. On the TI-Nspire™ Home screen, tap Settings  .

2. Log in to the Dropbox account, or if you already logged in, tap Dropbox Account.

The Dropbox Home folder is automatically synchronized when you log in. To
synchronize other folders, you must add them first. After folders are added, they
are automatically synchronized the next time you log in.

Note: To perform a manual synchronization at any time, tap Re-sync Folders.

Sending Documents Using Email

To send a document using email, you must have an email account set up on your iPad®.

1. Open the document you want to send.

2. Tap Share  .

3. Tap Email Document.
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The app opens your default email client, with the document as an attachment.

4. Enter the email address and tap Send.

Exporting a Document as a PDF

To export a document as a PDF, tap Share  .

1. Tap Export As PDF.

The app opens a screen showing the PDF.

2. Tap Open In .

The toolbar may hide after a few seconds. Tap the screen to show the toolbar.

3. Tap any of the icons to indicate where you want to export the PDF.

Receiving Documents

If you have an email account set up on your iPad®, you can receive documents that the
teacher sends, work on those documents, and send them back to the teacher.

To receive a document by email:

1. Tap the icon of the attached document in the email.

2. Depending on which app you installed, tap Open In TI-Nspire™ or tap Open In
TI-Nspire™ CAS.

The document opens in the TI-Nspire™ App for iPad®.



Working with Photos in Documents
Photos can be used in the TI-Nspire™ App for iPad® for reference, assessment, and
instructional purposes.

What You Can Do

Add photos to the following TI-Nspire™ applications:

• Graphs

• Geometry

• Data & Statistics

• Notes

What You Must Know
• In the Graphs, Geometry, and Data & Statistics applications, photos are set in the

background behind the axis and other objects. In the Notes application, the photo is
set at the cursor location inline with the text (in the foreground).

• You can take a photo and add it to your document, or you can use a photo that is
already stored in the photo albums. The TI-Nspire™ software automatically creates
a photo album named TI-Nspire™ Photos and stores it in the iPad® photo albums.
You can also use other photo albums that you create on the iPad®.

Taking Photos
1. Open the document to the page where you want to add a photo.

2. Tap Camera .

3. Aim the iPad® viewfinder at the object you want to capture.

4. Tap Take Photo.

When you take the photo, a preview is displayed.

• To discard the photo and take a different one, tap Retake.
• To insert the photo in the document, tap Use.

The photo is inserted into the active document and added to the Camera Roll
album.

Adding Existing Photos to Documents
1. Open the document to the page where you want to add a photo.

2. Tap Camera .

3. Tap Add Photo.

4. Tap the album where the photo resides.

5. Tap a thumbnail of the photo you want to insert.
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The photo is inserted into the active document.

Copying and Pasting Photos in the Notes Application

You can copy and paste photos in the Notes application.

▶ To copy a photo, tap the photo to open the context menu, and then tap Copy.

▶ To paste a photo, tap the area in the document where you want to insert the
photo, and then tap Paste.

Resizing Photos

You can resize photos in all applications that use photos.

1. Select the photo.

• In the Graphs, Geometry, and Data & Statistics applications, tap the Tools icon 
and go to Actions > Select Photo.

• In the Notes application, tap the photo to select it.

2. Drag a corner of the photo to resize it.

Deleting Photos

You can delete photos from within the open document.

1. Select the photo.

• In the Graphs, Geometry, and Data & Statistics applications, tap Tools and
go to Actions > Select Photo.

• In the Notes application, tap the photo to select it.

2. Tap the photo to open the context menu.

3. Tap Delete.

Capturing Screens

You can capture a page instead of the whole App screen.

1. Tap Camera .

2. Tap Send Page to Photos.

The screen will turn white for a second.

The image is saved to the Photos Main Library.



Calculator Application
The Calculator application enables you to enter and evaluate math expressions. You
can define variables, functions, and programs in Calculator. When you define or edit a
variable, function, or program, it becomes available to other applications—such as
Graphs or Geometry—that are part of the same problem.

What You Can Do

The Calculator Tools menu provides the tools you need to:

• Complete actions.

• Work with numbers.

• Work with math functions such as algebraic expressions, calculus problems,
probability, and statistics.

• Work with matrices and vectors.

• Create and solve financial equations.

• Define and edit functions, variables, and programs.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know

Deferring Evaluation

You don't have to complete and evaluate an expression as soon as you enter it. You can
enter part of an expression, leave the page to check work on another page, and then
come back to the page to the complete the expression at a later time.

Forcing a Decimal Approximation

To force a decimal approximation in a result, complete one of the following actions:

▶ Touch and hold ENTER, and then slide to select to evaluate the expression.

▶ Include a decimal in the expression.

▶ Wrap the expression in the approx() function.
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Accessing Calculator History Items

You cannot edit an expression if the result has been calculated. However, you can copy
the expression from the history and paste it into the entry line.

Copying History Items

1. Drag the work area up or down to find the expression or result you want to copy.

2. Tap the expression to select it and open the context menu.

3. Tap Paste History to copy the expression into the active entry line.

Copying Part of an Expression

1. Tap the expression to select it.

2. Drag the handles to highlight the part of the expression you want to copy.

3. Tap Paste History or tap ENTER to copy the selected item to the active entry line.

Clearing Calculator History

When you clear the history, all variables and functions defined in the history retain
their current values. To clear all items in the Calculator history:

1. Tap Tools and go to Actions.

2. Tap Clear History to remove all expressions and results from the history.

Note: If you clear the history by mistake, touch and hold , and then tap Undo to
restore the history items.

Adding a Calculator Page

To open a new document or add a page to an existing document with the Calculator
application active:

1. From the TI-Nspire™ Toolbar, tap Add.

• If this is a new document, the Add Document menu opens.
• If adding a page to an existing document, the Add Page to Document menu

opens.

2. Tap Calculator .

The Calculator application is added to the document. By default, the TI-Nspire™
Keyboard is shown and the cursor is in the entry line.



Entry line. Type or insert a math expression in the entry line. Tap ENTER to
evaluate the expression.

You can also insert functions, symbols, templates, or expressions from Utilities
.

Note: If the keyboard is hidden, tap the entry line to show it.

Calculator work area. As you evaluate expressions, both the expression and
result are saved in Calculator history. To distinguish between each saved
expression and result, every other entry line is shaded. To view entry lines that
are hidden, drag the work area up or down to scroll.

Entering Simple Math Expressions

Note: To enter a negative number, tap instead of the minus sign.

Suppose you want to evaluate .

1. Tap an entry line in the Calculator work area.

2. Tap to begin the expression.
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3. Tap to return the cursor to the baseline.
4. To complete the expression:

Tap .

5. Tap ENTER to evaluate the expression.

The expression is displayed in standard mathematical notation, and result is
displayed on the right side of the entry line. If a result does not fit on the same line
with the expression, it is displayed on the next line.

The expression and the result are added to the Calculator history.

Inserting Symbols, Functions, Commands, and Templates

System functions and commands, symbols, and expression templates are stored in
Utilities. To access Utilities, tap .



Utilities menus open to the last menu used. For example, if Symbols was the last
menu accessed, it opens by default the next time you tap .

To insert a symbol

1. Tap Symbols to open the Symbols palette.

2. Tap a symbol to insert it into the entry line.

Note: Drag the list of symbols up and down to view all available symbols.

To insert an item from the catalog

1. Tap Catalog to view the list of available functions and commands.

2. Tap a function name to select it, and then tap Done to insert it into the entry line.

• Flick the list of Catalog items up or down to view all items in the list.

• Type the first letter(s) of a function name in the search field to jump to entries
that begin with that letter. To return to the top of the list, clear the search
field.

• To access the Tools Wizard, tap to hide keyboard.

• If a Catalog function requires a defined variable, you must define the variable
before you can insert the Catalog item.

To insert a math operator

1. TapMath Operators to view the list of operator types.

2. Tap a category name to open the list of available operators.

3. Tap an operator name, and then tap Done to insert it into the entry line.

Using Wizards

Some functions in the Catalog have a wizard that prompts you for each argument.
Functions that have wizard support are identified with the wand symbol ( ).

To enable wizards

1. Tap to hide the TI-Nspire™ keyboard if it is showing.

2. Tap Utilities , and then go to Catalog. By default, the Tools Wizard is OFF.
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3. Slide the button to the right to enable the Tools Wizard.

4. Select the function you want to insert. (The function must have wizard support.)

5. Tap Done.

The wizard opens and prompts for each argument before the function is inserted
into the entry line.

6. Enter the arguments needed for the selected function.

Note: If the keyboard is needed to complete an entry, it opens when you tap the
field.

7. Tap OK as needed to complete entries in each prompt for the selected function.

The selected function is inserted into the Calculator entry line.

Note: If a Catalog function requires a defined variable, you must define the variable
before you can insert the Catalog item.



Using an Expression Template

Suppose you want to evaluate :

1. Tap the entry line to show the keyboard.

2. Tap .

The algebraic sum template is inserted into the entry line. Small blocks represent
elements that you can enter.

Note: The blue line on the top of this key indicates this key has alternate functions.
Touch and hold the key to access the alternate function.

3. Use the arrow keys (or tap each element) to move the cursor to each element's
position and enter a value or expression in each position.

4. Tap ENTER to evaluate the expression.

Using the Unit Conversion Assistant

In any application where math input is allowed, you can generate unit conversions
using the Unit Conversion Assistant. This can help reduce syntax errors by
automatically entering the units for you.
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Example: Convert 528 minutes to hours. The desired expression is 528•_min►_hr.

1. Tap on the entry line.

2. Tap Utilities , then tap Unit Conversions.

3. Tap Conversion Assistant, then tap Done.

The Unit Conversion Assistant dialog box displays:

4. Tap the Category list and select Time. Then tap < Unit Conversion Assistant.

5. Tap the From list and select min (minute). Then tap < Unit Conversion Assistant.



Note: You can select Use existing unit at the bottom of the list if you have already
entered a unit. In this example, you might have already entered 528•_min.

6. Tap the To list and select hr (hour). Then tap < Unit Conversion Assistant.

7. Tap OK to paste _min►_hr to the entry line.

8. Tap enter to evaluate the expression.

Note:

• The last Category, From, and To selections will be retained until the language is
changed, or the app is uninstalled or upgraded.

• Inserting a conversion into a Notes text field will automatically create a Math Box.

• Inserting a conversion into an empty line in the Calculator will automatically insert
Ans before the conversion.

Conversion Categories

The following table lists categories that are available in the Unit Conversion Assistant.
When the units are pasted to the entry line, underscores (_) are added before the
name of each unit to differentiate them from other variables. For example:

• _cm►_m

• _km/_hr►_m/_s

• _¡C►_¡F

Categories

• Length
• Area
• Volume
• Time
• Velocity

• Mass
• Force
• Energy
• Power
• Pressure
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• Temperature



Variables Overview
A variable is a defined value that can be used multiple times in a problem. You can
define a value or function as a variable within each application. Within a problem,
variables are shared by TI-Nspire™ applications. For example, you can create a variable
in Calculator, and then use or modify that variable in Graphs, Geometry, or Lists
& Spreadsheet within the same problem.

Each variable has a name and definition. The definition can be changed, and when you
change the definition, all occurrences of the variable in the problem are updated to use
the new definition. In the TI-Nspire™ software, a variable has four attributes:

• Name - User-defined name assigned when the variable is created.

• Location - Variables are stored in memory.

• Value - Number, text, mathematical expression, or function.

• Type - Type of data that can be stored as a variable.

Variables created with the Local command within a user-defined function or program
are not accessible outside of that function or program.

Using Variables in a Problem

• When first created, a variable is available only to the problem where it is defined.

• A variable can be used multiple times in applications that are part of the same
problem.

• If the value of the variable is changed in the original application, the change is
reflected in all applications where the variable is used.

• A variable is not available to other problems or documents until you define the
variable as a library object and copy it to a library folder. See Libraries for more
information.

Defining Variables

Any portion or attribute of an object or function created within an application can be
stored as a variable. Examples of attributes that can become variables include the:

• Area of a rectangle

• Radius of a circle

• Value contained in a spreadsheet cell

• Contents of a row or column in a spreadsheet

• Function expression

When you create a variable, it is stored in memory.

Types of Variables

You can store the data types listed in the following table as variables.
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Data type Examples

Expression 2.54 1.25E6 2p (x-2)2

List {2, 4, 6, 8} {1, 1, 2} {"red", "blue", "green"}

Matrix This can be entered as: [1,2,3;3,6,9]

Character string "Hello" "xmin/10" "The answer is:"

Function, program myfunc( arg ) ellipse( x, y, r1, r2)

Measurement area perimeter length slope angle

Naming Variables and Functions

Names for variables and functions that you create must meet the following naming
rules.

Note: If you create a variable with the same name as one used for statistical analysis
or by the Finance functions, an error condition could occur. When you enter the name
of a variable that is already in use in the current problem, the entry is shown in bold.

• Variable names must be in one of the forms xxx or xxx.yyy. The xxx part can have
1 to 16 characters. The yyy part, if used, can have 1 to 15 characters. You cannot
start or end the variable name with a period (.).

• Characters can consist of letters, digits, and the underscore character (_). Letters
can be U.S. or Greek letters (but not Π or π), accented letters, and international
characters.

• Do not use c or n from the symbol palette to construct a variable name such as c1
or n12. These may appear to be letters, but they are treated internally as special
symbols.

• You can use uppercase or lowercase letters. The names AB22, Ab22, aB22, and
ab22 all refer to the same variable.

• You cannot use a digit as the first character of xxx or yyy.
• When entering a subscript, you can use digits zero through 9, U.S. letters, a

through z, Latin and Greek letters (but not π) as subscripts (for example, a
2
, q

a
, or

h
2
o). To enter a subscript while typing a variable name, touch and hold , and

then slide to select .

• Do not use spaces.

• If you want a variable to be treated as a complex number, use an underscore as the
last character of the name.



• CAS: If you want a variable to be treated as a type of unit (such as _m or _ft), use
an underscore as the first character of the name. You cannot use any other
underscores in the name.

• You cannot use an underscore as the first character of a name.

• You cannot use a pre-assigned variable, function, or command name, such as Ans,
min, or tan.

• Library documents and library objects are subject to additional naming restrictions.
For more information, see Libraries.

Creating Variables in Calculator

When creating a variable, use the following conventions. As alternatives to using →
(store), you can use ":=" or the Define command. All of the following statements are
equivalent.

5+83→num

num:= 5+83

Define num=5+83

To Create a Variable in the Calculator Application

1. Tap the Calculator entry line to show the keyboard.

2. Touch and hold to show the alternate functions, and then slide to the desired

function.

3. Enter the value for the variable (a number, text, mathematical expression, or
function).

4. Tap ENTER.
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Note: Use the right, left, up, and down arrows to move the cursor within the
expression or function. Make sure the cursor is positioned correctly in the entry line
before tapping ENTER to create the variable.

Entering Multiple Variables on the Entry Line

To enter several variables on a single line, separate them with a colon (:). Only the
result of the last expression is shown.

Creating Variables in Graphs

In the Graphs application, functions defined on the entry line are automatically stored
as variables.

In this example, f1(x)=x3 is automatically stored as a variable definition named f1,
which you can use in other applications in the problem, including a table in the Lists
& Spreadsheet application.

When you tap ENTER, the equation is graphed, and the variable is defined. Tap to

see the list of defined variables.

Creating a Variable from a Geometry Value

In this example, the area of the triangle will be the value for a variable named
"triangle."

1. Tap the value you want to store to select it, and then tap it again to open the
context menu.



2. Tap Store.

var := appears before the selected value. This is the default name.

.

3. Replace the default name var with the variable name you want to give the value.

4. Tap ENTER.

The value is saved to that variable name, and the stored value or its name appears
in bold text to indicate that it is a stored value.
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Creating Variables in Lists & Spreadsheet

Naming a list at the top of a Lists & Spreadsheet column or creating a variable from a
cell value automatically stores that value as a list variable. After defining the variable,
you can link to it from the Graphs, Geometry, Calculator, and Data & Statistics
applications as well as from other Lists & Spreadsheet pages within the current
problem.

Note: When naming variables, use a name that does not exist in the current problem.

Creating a Variable from a Column Name

1. Tap the column's name cell (the top cell of the column).

2. Type a name for the list variable, and then tap return.

3. Create elements in the list. For example, type data into each cell or use a formula
to generate a column of data.

Notes:

• Lists can contain empty elements (denoted by an underscore ("_").

• You can refer to a specific element in a named list from the Calculator application.
Use the list name and the element's position within the list. In a list named
Heights, for example, refer to the first element as Heights[1]. The expression
Heights[2] refers to the second elements, and so on.

Creating a Variable from a Cell Value

You can share a cell value with other TI-Nspire™ applications. When defining or
referring to a shared cell in Lists & Spreadsheet, precede the name with an apostrophe
(').



1. Tap the cell that contains the value you want to share, and then tap again to open
the context menu.

2. Tap Store.

A formula is inserted into the cell with var as a placeholder for the variable name.

3. Replace the letters "var" with a name for the variable.

4. Tap return.

The value is now available as a variable in other applications within the same
problem.

Adjusting Variable Values with a Slider

A slider control lets you interactively adjust or animate the value of a numeric variable.
You can insert sliders in the Graphs, Geometry, Notes, and Data & Statistics
applications.
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Horizontal slider for adjusting variable v1.

Minimized vertical slider for adjusting variable v2.

Note: TI-Nspire™ version 4.2 or higher is required for opening .tns files containing
sliders on Notes pages.

Inserting a Slider Manually

1. From a Graphs, Geometry, or Data & Statistics page, select Actions > Insert Slider.
—or—
From a Notes page, make sure the cursor is not in a math box or chem box, and
then select Insert > Insert Slider.

The Slider Settings screen opens.



2. Enter the desired values, and tap OK.

The slider is displayed. On a Graphs, Geometry, or Data & Statistics page, handles
are displayed to let you move or stretch the slider.

To remove the handles and use the slider, tap an empty
space in the work area. You can show the handles
anytime by selectingMove from the slider's context
menu. 

3. To adjust the variable, slide the pointer (or tap the arrows on a minimized slider).

Working with the Slider

Use the options on the context menu to move or delete the slider, and to start or stop
its animation. You can also change the slider's settings. To open the context menu:

1. Touch and hold the slider.

The context menu opens.

2. Tap an option to select it.
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Automatic Sliders in Graphs

Sliders can be created for you automatically in the Graphs application and in the
analytic window of the Geometry application. You are offered automatic sliders when
you define certain functions, equations, or sequences that refer to undefined variables.

Linking a Lists & Spreadsheet Cell or Column to a Variable

When you link a cell or column to a variable, Lists & Spreadsheet updates the values to
reflect the current value of the variable. The variable can be any variable in the current
problem and can be defined in Graphs, Geometry, Calculator, or any instance of Lists
& Spreadsheet.

Notes:

• You cannot link to the same variable multiple times on the same page.

• Do not link a cell to a system variable. Doing so could prevent the variable from
being updated by the system. System variables include ans, StatMatrix, and
statistics results (such as RegEqn, dfError, and Resid).

Linking a Cell Value to an Existing Variable

1. In a Lists & Spreadsheet page, tap the cell that you want to link to a variable. This
should be an empty cell and the cell cannot be in a list that is already defined as a
variable.

2. Tap the cell again to open the context menu.



3. Tap Link.

4. Tap the name of the variable to insert it into the cell.

The value of the variable is displayed in the cell.

Linking a Column to an Existing List Variable

To view or edit values in a list variable, link a column to the list variable. The list can be
any shared list in the current problem and can be defined in Graphs, Geometry,
Calculator, or any instance of Lists & Spreadsheet.

After you link a column to a list, changes you make to the list in other applications are
automatically updated in Lists & Spreadsheet.

1. Tap the column formula cell (the second cell from the top) that you want to link to
a variable.

2. Type the name of the list variable that you want to link to, and then tap return.

—OR—

To view the list of available variables:

▶ Tap on the TI-Nspire™ Keyboard, and then tap a variable name.
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The column shows the list elements.

Locking and Unlocking Variables

Locking a variable protects it from modification or deletion, and prevents unintended
changes to a defined variable. For example, you may want to lock variables that define
time or altitude to ensure integrity.

You cannot lock the following variables:

• System variable ans
• stat. and tvm. variable groups

Locking Variables

1. Go to the Calculator application, and tap the entry line to show the keyboard.

2. Tap Tools .

3. Go to Actions, and then tap Lock.

4. Tap Lock Variable to select the function and insert it into the entry line.

5. Tap , and then tap the variable name you want to lock.

Note: You can also type the variable name in the entry line.

6. Tap ENTER.

The result Done indicates the variable is locked.



Locked variables display a lock icon on the variable menu list.

Note: The Lock command clears the Redo/Undo history when applied to unlocked
variables.

Unlocking Variables

To modify or delete a locked variable, you must unlock the variable.

1. Tap Tools and go to Actions > Lock.

2. Tap Unlock Variable to enter the function into the entry line.

3. Tap , and then tap the locked variable name.

4. Press ENTER to remove the locked status.

The result Done indicates the variable is now unlocked.
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Graphs Application
The Graphs application lets you create, manipulate, analyze, and trace graphs of
mathematical relations.

What You Can Do

• Define and explore functions and other relations, such as inequalities, parametrics,
polars, sequences, and differential equation solutions.

• Graph and explore linear and conic equations analytically in a two-dimensional
coordinate system. Analyze lines, circles, ellipses, parabolas, hyperbolas, and
general conic equations.

• Animate points on objects or graphs and explore their behavior.

• Define relations to share with other applications, such as Calculator or Notes.

• Link to data created by other applications.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know

Finding Hidden Objects in the Graphs or Geometry Application

You can hide graphs, geometric objects, text, labels, measurements, and individual axis
end-values.

To temporarily view hidden graphs or objects or to restore them as shown objects, tap
Tools and go to Actions > Hide/Show. Tap a graph or object to toggle its Hide/Show
state.

Changing the Appearance of a Graph or Object

1. Tap the graph or object that you want to change.

2. Tap the Inspector   to display a list of the object's attributes.
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Note: The list of attributes is different for different types of objects.

3. Select the items to change. Changes are applied as you select them.

Animating a Point on a Graph or Object

1. Tap the point.

2. Tap Inspector to display the point's attributes.

3. Drag the Animation Speed slider to set the speed and start the animation.

Inserting a Background Photo

The Insert Photo tool lets you insert a photo as a background for any Graphs or
Geometry page.

Adding Text to the Graphs or Geometry Work Area

1. Tap Tools and go to Actions > Text.

The Text tool  appears in the application Toolbar.

2. Tap the location for the text.

3. Type the text in the box that appears, and then tap return.



4. To edit the text, double-tap it.

Adding a Graphs Page

To get started with the Graphs application, add a Graphs page to an existing
document.

Tap Add, and then tap .

A new Graphs page appears, showing the Graphs Toolbar, entry line, and work area.

Graphs Toolbar

• Tap Tools to create and explore graphs.

• Tap Inspector to change the appearance of a graph.
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• Tap to change the settings used by the Geometry and Graphs
applications.

• Tap to view or edit an expression from the graph history.

• Tap to hide or show the keyboard and the entry line.

Entry line. Lets you define the relations that you want to graph. The default
graph type is Function, so the form f1(x)= is displayed initially. You can
define 99 relations of each type.

Graphs Work Area

• Shows graphs of relations that you define on the entry line.

• Shows points, lines, and shapes that you create with geometry tools.

• Pinch to zoom, drag to pan (affects only those objects created in the
Graphs application).

Graphing Functions
1. In the Graphing view, tap Tools and go to Graph Entry/Edit > Function.

2. Type an expression for the function.

3. Tap ENTER to graph the function.



Manipulating a Function by Dragging

Linear
Function

• To translate, grab near the middle of the graph, and then drag.

• To rotate, grab near the ends of the graph, and then drag.

Quadratic
Function

• To translate, grab near the vertex of the graph, and then drag.

• To stretch, grab away from the vertex of the graph, and then drag.

Sine or
Cosine
Function

• To translate, grab near the axis of vertical symmetry of the graph, and
then drag.

• To stretch, grab away from the axis of vertical symmetry of the graph,
and then drag.

Finding Points of Interest on a Function Graph

▶ Create a point on the graph, and then drag the point to quickly identify maximums,
minimums, and zeros.

Temporary signposts appear as you drag through the points of interest.

▶ For other points of interest, tap Tools , select Analyze Graph, and select the type
of analysis, such as Integral. The application prompts you to choose a graph and
define the boundaries.

Graphing Linear and Conic Equations
1. In the Graphing view, tap Tools and go to Graph Entry/Edit > Equation.

2. Tap the type of equation (Line, Parabola, Circle, Ellipse, Hyperbola, or Conic).
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3. Tap the specific template for the equation. For example, tap y=a•x2+b•x+c to
define a parabola.

The entry line includes a symbol to indicate the type of equation.

4. Type the coefficients into the equation template.

5. Tap ENTER.

Graphing Relations

Relation graphing is available on Graphs pages and in the Analytic Window of
Geometry pages.

You can define relations using ≤, <, =, >, or ≥. The inequality operator (≠) is not
supported in relation graphing.

Relation type Examples

Equations and inequalities
equivalent to
y = f(x)

• y = sqrt(x)
• y-sqrt(x) = 1/2
• -2*y-sqrt(x) = 1/2
• y-sqrt(x) ≥ 1/2
• -2*y-sqrt(x) ≥ 1/2

Equations and inequalities
equivalent to
x = g(y)

• x = sin(y)
• x-sin(y) = 1/2
• x-sin(y) ≥ 1/2

Polynomial equations and
inequalities

• x^2+y^2 = 5
• x^2-y^2 ≥ 1/2+y



Relation type Examples

• x3+y3-6*x*y=0

The above relations on domains
restricted by rectangles

• y=sin(x) and
-2π<x≤2π

• y≤x2|y ≥ -2 and 0 ≤ x ≤ 3
• {x2+y2≤3, y ≥ 0 and x ≤ 0

To Graph a Relation:

1. From the Graph Entry/Edit menu, select Relation.

2. Type an expression for the relation. You can touch and hold the "greater than" key 
to select one of the relation operators.

3. Press Enter to graph the relation.

Tips for Graphing Relations

▶ You can quickly define a relation from the Function entry line. Position the cursor to
the immediate right of the = sign, and then tap the backspace key  .

A small menu appears with the relation operators and a Relation option. Choosing
from the menu places the cursor in the Relation entry line.

▶ You can type a relation as text on a Graphs page and then drag the text object over
either axis. The relation is graphed and added to the relation history.
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Warning and Error Message

Error Condition Additional Information

Relation input not supported Relation input not supported
Note: The following relation inputs are
supported:
• Relations using ≤, <, =, >, or ≥.
• Polynomial relations in x and y
• Relations equivalent to y=f(x) or x=g(y) or

corresponding inequalities
• The above relations on domains

restricted by rectangles

Domain Restrictions not
supported for certain classes of
relations equivalent to y=f(x) or
x=g(y) or corresponding
inequalities.

• Relations equivalent to y=f(x) and
corresponding inequalities can only have
constraints on x

• For example: y=√(x) and 0≤x≤1 will work
but y=√(x) and 0≤y≤1 will not

• Relations equivalent to x=g(y) and
corresponding inequalities can only have
constraints on y

• For example: x=sin(y)|−1≤y≤1 will work
but x=sin(y)|−1≤x≤1 will not

Graphing Parametric Equations
1. In the Graphing view, tap Tools and go to Graph Entry/Edit > Parametric.

2. Type expressions for xn(t) and yn(t).

3. (Optional) Edit the default values for tmin, tmax, and tstep.
4. Tap ENTER.



Graphing Polar Equations
1. In the Graphing view, tap Tools and go to Graph Entry/Edit > Polar.

2. Type an expression for rn(θ).
3. (Optional) Edit the default values for θmin, θmax, and θstep.

4. Tap ENTER.

Graphs Application 60



61 Graphs Application

Using the Text Tool to Graph Equations
1. In the Graphs application, tap Tools and go to Actions > Text.

2. Tap the work area to place the text box and display the keyboard.

3. Type an "x=" or "y=" equation, such as x=sin(y)*2, or type an inequality, such as
x<2*sin(y), and tap ENTER.

4. Drag the text object to either axis to graph the equation.



Graphing a Scatter Plot
1. In the Graphs application, tap Tools and go to Graph Entry/Edit > Scatter Plot.

2. Use one of the following methods to specify two lists to plot as x and y.

- Tap to select a list variable that you have defined in the current problem.

- Type the name of an existing list variable, such as v1.
- Type the list elements directly (for example, type {1,2,3}.

3. Tap ENTER to plot the data, and then zoom the work area to view the plotted data.

Plotting Sequences

Defining a Sequence

1. In the Graphing view, tap Tools and go to Graph Entry/Edit > Sequence >
Sequence.

2. Type the expression to define the sequence. Update the independent variable field
to m+1, m+2, etc., if necessary.

3. Type an initial term. If the sequence expression references more than one prior
term, such as u1(n-1) and u1(n-2), (or u1(n) and u1(n+1)), separate the terms with
commas.
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4. Tap ENTER.

Defining a Custom Sequence

A custom sequence plot shows the relationship between two sequences by plotting
one on the x axis and the other on the y axis.

This example simulates the Predator-Prey model from biology.

1. Use the relations shown here to define two sequences: one for a rabbit population,
and another for a fox population. Replace the default sequence names with rabbit
and fox.

.05 = the growth rate of rabbits if there are no foxes

.001 = the rate at which foxes can kill rabbits

.0002 = the growth rate of foxes if there are rabbits

.03 = the death rate of foxes if there are no rabbits

Note: If you want to see the plots of the two sequences, zoom the window to the
Zoom - Fit setting.

2. Tap Tools and go to Graph Entry/Edit > Sequence > Custom.



3. Specify the rabbit and fox sequences to plot on the x and y axes, respectively.

4. Tap ENTER to create the custom plot.

5. Zoom the window to the Zoom - Fit setting.

6. Explore the custom plot by dragging the point that represents the initial term.
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Graphing Differential Equations

ODE entry line:
• y1 ODE identifier
• Expression k·y1 defines the relation
• Fields (1,1) for specifying initial condition
• Buttons for adding initial conditions and setting plot

parameters

Slider added for adjusting coefficient k of the ODE

Slope field

A solution curve passing through the initial condition

To Graph a Differential Equation:

1. In the Graphing view, tap Tools and go to Graph Entry/Edit > Diff Eq.

The ODE is automatically assigned an identifier, such as “y1.”

2. Move to the relation field and enter the expression that defines the relation. For
example, you might enter -y1+0.1*y1*y2.



3. Enter the initial condition for the independent value x
0
and for y1

0
.

Note: The x
0
value(s) are common to all the ODEs in a problem but can be entered

or modified only in the first ODE.

4. Tap Edit Parameters to set the plot parameters. Select a numerical Solution
Method, and then set any additional parameters. You can change these parameters
anytime.

5. Tap OK.

6. Zoom the window as necessary to view the graph.

Viewing Tables in the Graphs Application

Tap Tools and go to Table > Split-screen Table.

The table is displayed with columns of values for the currently defined relations.
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To remove the table, tap Tools and go to Table > Remove Table.

Note: For details about using tables, see Working with Tables.

Accessing the Graph History

For each problem, the Graphs application automatically stores a history of defined
relations, such as functions f1 through f99 and sequences u1 through u99. You can view
and edit these items.

Viewing the History of the Current Relation Type

1. Tap History  at the right end of the Graphs toolbar to show the history of the
current relation type (for example, f for Functions).

2. In the History list, tap the name of the relation, and then tap Done to show the
relation in the entry line.

3. Use the up and down arrow keys to scroll through the defined relations.

Viewing the History of other Relation Types

1. In the Graphing view, tap Tools , go to Graph Entry/Edit, and tap the relation
type. For example, tap Polar to show an entry line for the next available Polar
relation.



2. Use the up and down arrow keys to scroll through the defined relations.

Customizing the Graphs Work Area

Note: Rescaling in the Graphs application affects only the graphs, plots, and objects
that reside in the Graphing view. It has no effect on objects in the underlying Plane
Geometry view.

Zooming/Rescaling Manually

▶ To rescale the x and y axes proportionally, pinch the work area.

▶ To rescale only one axis, tap Tools , select Actions > Constrained Movement, and
then drag along the axis.

Zooming to predefined settings

▶ Tap Tools , select Window/Zoom, and select one of the predefined Zoom
settings. The initial setting is Zoom - Standard.

Displaying the Grid

1. In the Graphs application, tap Tools and go to View > Grid.

2. Tap Dot Grid, Lined Grid, or (if the grid is already displayed) No Grid.

Changing the Appearance of the Grid

1. In the Graphs application, tap Tools and go to Actions > Select Grid.

The grid will flash.

2. Tap the Inspector to show a list of attributes that you can change.

Changing the Appearance of the Graph Axes

1. Tap either axis to select the axes.

2. Tap the Inspector to show a list of attributes that you can change.
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3. Select the items to change. Changes are applied as you select them.

Tracing Graphs or Plots
1. In the Graphing view, tap Tools and go to Trace > Graph Trace.

The Graph Trace tool appears in the Graphs toolbar, the trace cursor appears, and
the cursor coordinates are displayed in the lower right corner.

2. Explore a graph or plot:

- Tap a point on a graph or plot to move the trace cursor to that point.

- Tap or on the Graph Trace tool to step the cursor along the current
graph or plot. The screen pans automatically to keep the cursor in view.

- Double-tap the trace cursor to enter a specific independent value.
- Tap and hold the trace cursor to create a persistent point.

3. To stop tracing, tap the X on the Graph Trace tool.



Introduction to Geometric Objects

Geometry tools are accessible in both the Graphs and Geometry applications. You can
use these tools to draw and investigate objects such as points, lines, and shapes.

• The Graphing view shows the Graphs work area superimposed on the Geometry
work area. You can select, measure, and alter objects in both work areas.

• The Plane Geometry view shows only the objects created in the Geometry
application.

Objects Created in the Graphs Application

Points, lines, and shapes created in the Graphs application are analytic objects.

• All points that define these objects reside on the x,y graph plane. Objects created
here are visible only in the Graphs application. Changing the axes scale affects the
appearance of the objects.

• You can display and edit the coordinates of any point on an object.

• You can display the equation of a line, tangent line, circle shape, or geometric conic
created in the Graphs application.

The circle arc andpolygonwere created in the Geometry application. The sinewave and
conicwere created in the Graphs application.
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Objects Created in the Geometry Application

Points, lines, and shapes created in the Geometry application are not analytic objects.

• Points that define these objects do not reside on the graph plane. Objects created
here are visible in both the Graphs and Geometry applications, but they are
unaffected by changes to the Graphs x,y axes.

• You cannot obtain the coordinates of an object’s points.

• You cannot display the equation of a geometric object created in the Geometry
application

Labeling (Identifying) the Coordinates of a Point

The Graphs application can identify and label the coordinates of any existing point,
provided the point was created in the Graphs application.

1. Tap the point to select it, and then tap it again to show its context menu.



2. Tap Coordinates.

If you move the point to a different location, the coordinates follow the point and
update automatically.

Bounded Area (Area Between Curves)

Note: To avoid unexpected results when using this feature, make sure the
document setting for "Real or Complex Format" is set to Real.

You can use the Graphs application to access the area between curves.

When you calculate the area between curves, each curve must be:

• A function with respect to x.

- or -

• An equation in the form y=, including y= equations defined through a text box or a
conic equation template.

Defining Bounded Area (Area Between Curves)

1. Open a new Graphs page.

2. Tap sin and x, then tap ENTER.
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3. Tap .

4. Tap cos and x, then tap ENTER.

For this example the graph now shows f1(x)=sin(x) and f2(x)=cos(x) function(s).

5. Tap Tools and go to Analyze Graph > Bounded Area.

The Bounded Area tool appears in the application Toolbar. You are
prompted to set the lower and upper bounds.

6. Tap or drag two points to define the bounds.

The area becomes shaded, and the area value is displayed. The value is always
non-negative, regardless of the interval direction.

Working With Shaded Areas

As you change the bounds or redefine the curves, the shading and the area value are



updated .

• To change the lower or upper bound, drag it or type new coordinates for it. You
cannot move a bound that resides on an intersection. However, the point moves
automatically as you edit or manipulate the curves.

• To redefine a curve, either manipulate it by dragging or edit its expression in the
entry line.

Note: If an endpoint resided originally on an intersection, and the redefined
functions no longer intersect, the shading and area value disappear. If you redefine
the function(s) so that there is an intersection point, the shading and area value
reappear.

• To delete or hide an area, tap to select the bounded area, then tap again to see the
context menu. From the context menu, you may delete the bounded area.

• To change the color and other attributes, tap the Object Inspector once the shaded
region is selected.

Displaying the Equation of a Geometric Object

You can display the equation of a geometric line, tangent line, circle shape, or
geometric conic, provided the object was constructed in the Graphs application and can
be converted faithfully to a template-based conic.

1. Tap the object to select it, and then tap it again to show its context menu.

2. Tap Equation to display the equation as a Text object.
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Using the Calculate Tool

The Calculate tool is available in the Graphs and Geometry applications. It lets you
evaluate a math expression you have entered as a text object. You can edit an
evaluated expression, and then re-evaluate it.

Entering the Expression

1. Tap Tools and go to Actions > Text.

2. Tap the work area to place the text box and display the keyboard.

3. Type the expression, such as (1/4)2*2, and tap ENTER.

Note: Do not include variables in the expression.

Calculating the Result

1. Tap Tools and go to Actions > Calculate.

The Calculate tool appears in the toolbar, and a prompt asks you to select an
expression to calculate.

2. Tap the text object to evaluate the expression.



Creating Shapes Using Gestures (MathDraw)

The MathDraw tool lets you use touchscreen gestures to create points, lines, circles,
and other shapes.

• MathDraw is available in Geometry and Graphing.

• Graphing view when the x scale and y scale are identical. This avoids non-circular
ellipses and non-square rectangles appearing as circles and squares.

Note: MathDraw is not available in the 3D Graphing.

Activating MathDraw

1. Tap Add, and then tap .

2. Tap Tools .

3. Tap Actions menu, select MathDraw.

The MathDraw tool appears in the application Toolbar. You can begin
using the tool.

Canceling MathDraw

▶ When you have finished using the MathDraw tool, tap the X on the tool.

Creating Points

To create a labeled point, tap in an open area.

• If the point is close to an existing line, segment, ray, geometric conic (including
circles), or polygon, the point snaps to that object. You can also place a point on the
intersection of any two of those types of objects.

• If the point is close to a visible grid location in a Graphs view or Geometry view, it
snaps to the grid.

Drawing Lines and Segments

To create a line or segment, touch the initial position, and then drag to the end
position.

• If the drawn line passes near an existing point, the line snaps to the point.

• If the drawn line starts close to an existing point and ends next to another existing
point , it becomes a segment defined by those points.

• If the drawn line is nearly parallel or perpendicular to an existing line, segment, or
side of a polygon, it aligns to that object.
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Note: The default tolerance for detecting parallel/perpendicular lines is 12.5
degrees. This tolerance can be redefined using a variable named
ti_gg_fd.angle_tol. You can change the tolerance in the current problem by setting
this variable in the calculator app to a value in the range 0 through 45 (0=no
parallel/perpendicular detection).

Drawing Circles and Ellipses

To create a circle or ellipse, use the touchscreen to draw the approximate shape.

• If the drawn shape is sufficiently circular, a circle is created.

• If the shape is elongated, an ellipse is created.

• If the virtual center of the drawn shape is near an existing point, the circle or
ellipse is centered on that point.

Drawing Triangles

To create a triangle, draw a triangle-like shape.

• If a drawn vertex is close to an existing point, the vertex snaps to the point.

Drawing Rectangles and Squares

To create a rectangle or square, use the touchscreen to draw the perimeter.

• If the drawn shape is nearly square, a square is created.

• If the drawn shape is elongated, a rectangle is created.

• If the center of a square is close to an existing point, the square snaps to that
point.

Drawing Polygons

To create a polygon, tap a succession of existing points, ending on the first point you
tapped.

Using MathDraw to Create Equations

In the Graphs view, MathDraw attempts to recognize certain gestures as functions for
analytic parabolas.



Note: The default step value for quantization of the parabola coefficients is 1/32. The
denominator of this fraction can be redefined using a variable named ti_gg_fd.par_
quant. You can change the step value in the current problem by setting this variable to
a value greater or equal to 2. A value of 2, for example, produces a step value of 0.5.

Using MathDraw to Measure an Angle

To measure the angle between two existing lines, use the touchscreen to draw a circle
arc from one of the lines to the other.

• If the intersection point between the two lines does not exist, it is created and
labeled.

• The angle is not a directed angle.

Using MathDraw to Find a Mid-point

To create a point midway between two points, tap point 1, point 2, and then point 1
again.

Using MathDraw to Erase

To erase objects, use the touchscreen to drag left and right, similar to the motion of
erasing a whiteboard.

• The erasure area is the bounding rectangle of the erasure gesture.

• All point objects and their dependents inside the erasure area are removed.
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Sticky Tool in Geometry and Graphing

Sticky Tool is available in Geometry and Graphing.

Note: In the Graphs application, go to Tools > Geometry.

When a Geometry tool has the capability to remain active, it will display a lock
element along with the tool icon.

Lock Element icon

Unlocked/Single-use icon Locked/Multi-use icon

Note: All tools will open in the default or unlocked/single-use state. The icon will

appear to the left of the tool.

Unlocked/Single-use Locked/Multi-use

Default State

Opening a tool will always be in the default unlocked/single-use state). This applies to
scenarios like closing a tool, or switching to a new tool.

Geometry and Graphing tools that are sticky

The following tools will have the "sticky" feature:

• All items under "Points & Lines"

• All items under "Shapes"

• All items under "Measurement"

• All items under "Construction"

• All items under "Transformation"

Locking or Unlocking a tool

Tap the unlocked/single-use icon to lock a tool for locked/multi-use.

Note: The tool is now in a locked/multi-use state.



Tap the X to close the tool.

-or-

Tap the unlocked/single-use state.

Note: The user can also toggle between icon.
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3D Graphing
The 3D Graphing view lets you create and explore three-dimensional graphs.

What You Can Do

• Create and edit 3D functions of the form z(x,y).

• Create and edit 3D parametric plots.

• Show and hide selected graphs.

• Set the background color and apply wire and surface colors to graphs.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

Selecting the 3D Graphing View

The 3D Graphing View is available on any Graphs page .

▶ Tap Tools and go to View > 3D Graphing.

3D Graphs Toolbar

• Tap Tools to create and explore 3D graphs.

• Tap Inspector to change the appearance of a graph or the 3D box.

• Tap  to view or edit an expression from the 3D graph history.
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• Tap  to hide or show the keyboard and the entry line.

Entry line. Lets you define 3D graphs. The default graph type is 3D Function,
indicated by z1(x,y)=.

3D Graphs Work Area. Shows a 3D box containing graphs that you define. Pinch
to zoom the area, drag to rotate the box.

Graphing 3D Functions
1. In the 3D Graphing view, tap Tools and go to 3D Graph Entry/Edit > Function.

The keyboard and the entry line appear.

2. Enter the expression that defines the graph. You can type the expression or build it
using expression templates.

3. Tap ENTER to create the graph and hide the entry line and keyboard. You can show
the entry line and keyboard anytime by tapping on the Graphs Toolbar.

Graphing 3D Parametric Equations
1. In the 3D Graphing view, tap Tools and go to 3D Graph Entry/Edit > Parametric.



The keyboard and the entry line appear.

2. Type the equations that define the graph.

3. (Optional) Tap to set the 3D plotting parameters tmin, tmax, umin, and umax.

4. Tap ENTER to draw the graph and hide the entry line and keyboard. You can show
the entry line and keyboard anytime by tapping on the Graphs Toolbar.
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Zooming and Rotating the 3D View

Zooming

▶ Pinch the work area to zoom in or out.

Rotating Manually

▶ Drag in any direction to rotate all objects in 3D Graphing view.

Rotating Automatically

1. Tap Tools and go to Actions > Auto Rotation.

The Auto Rotation tool appears, and the graph rotates continuously
around the z axis.

2. To stop the rotation, tap X on the tool.

Editing a 3D Graph
1. Double-tap the graph or its label to display the expression in the entry line. As an

alternative, you can use the graph history to show the expression.

2. Modify the existing expression, or type a new expression in the entry line.

3. Tap ENTER to draw the edited graph.

Changing the Appearance of a 3D Graph
1. Tap the graph to select it.

2. Tap Inspector .



3. Select the items to change. Changes are applied as you select them.

Showing or Hiding a Graph’s Label

1. Tap the graph to select it, and then tap it again to show its context menu.

2. Tap Hide Label or Show Label.

Showing and Hiding 3D Graphs
1. In the 3D Graphing view, tap Tools and go to Actions > Hide/Show.

The Hide/Show tool appears, and all hidden items are displayed in gray.

2. Tap a graph to change its hide/show state.

3. To apply the changes, tap X on the tool.

Note: If you want to show or hide only the graph's label, see Showing or Hiding a
Graph’s Label.
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Customizing the 3D Viewing Environment

Changing the Background Color

1. Tap the 3D box to select it.

Note: If the box is hidden, tap Tools and go to View > Show Box.

2. Tap Inspector .

3. Tap Fill Color, and then select a color to apply it to the background.

Changing the 3D Projection

1. Tap the and go to View.

2. Tap Orthographic Projection or Perspective View.



Showing or Hiding the Box, Axes, and Legend

1. Tap Tools and go to View.

2. Tap the name of the element to show or hide.

Changing the 3D Aspect Ratio

1. Tap Tools and go to Range/Zoom > Aspect Ratio.

2. Enter values for the x, y, and z axes. The default value for each axis is 1.

Changing the Range of the 3D Box

▶ Tap Tools and go to Range/Zoom > Range Settings.
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Geometry Application
The Geometry application lets you create, manipulate, measure, transform, and
animate geometric objects.

What You Can Do

• Create and explore points and lines, such as line segments, vectors, and circle arcs.

• Create and explore geometric shapes, such as circles, ellipses, polygons, and
conics.

• Animate any point created as a point on an object or graph.

• Explore object transformations, including symmetry, reflection, translation,
rotation, and dilation.

• Create geometric constructions, such as bisectors, parallels, perpendiculars, loci,
and circles drawn with a compass.

• Hide an object or change its line color, line style, or fill color.

• Measure lengths, angles, perimeters, areas, and slopes.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know

Finding Hidden Objects in the Graphs or Geometry Application

You can hide graphs, geometric objects, text, labels, measurements, and individual axis
end-values.

To temporarily view hidden graphs or objects or to restore them as shown objects, tap
Tools and go to Actions > Hide/Show. Tap a graph or object to toggle its Hide/Show
state.

Changing the Appearance of a Graph or Object

1. Tap the graph or object that you want to change.

2. Tap the Inspector   to display a list of the object's attributes.
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Note: The list of attributes is different for different types of objects.

3. Select the items to change. Changes are applied as you select them.

Animating a Point on a Graph or Object

1. Tap the point.

2. Tap Inspector to display the point's attributes.

3. Drag the Animation Speed slider to set the speed and start the animation.

Inserting a Background Photo

The Insert Photo tool lets you insert a photo as a background for any Graphs or
Geometry page.

Adding Text to the Graphs or Geometry Work Area

1. Tap Tools and go to Actions > Text.

The Text tool  appears in the application Toolbar.

2. Tap the location for the text.

3. Type the text in the box that appears, and then tap return.



4. To edit the text, double-tap it.

Adding a Geometry Page

To get started with the Geometry application, add a Geometry page to an existing
document.

Tap Add, and then tap .

A new Geometry page appears, showing the Geometry Toolbar and work area.

Geometry Toolbar

• Tap Tools to create and explore Geometry objects.

• Tap Inspector to change the appearance of a selected item such as a
geometric shape.

• Tap Graphs & Geometry Settings to change the settings used by the
Geometry and Graphs applications.

Geometry work area. Geometry objects that you create are displayed here. Drag
to pan the work area.
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Introduction to Geometric Objects

Geometry tools are accessible in both the Graphs and Geometry applications. You can
use these tools to draw and investigate objects such as points, lines, and shapes.

• The Graphing view shows the Graphs work area superimposed on the Geometry
work area. You can select, measure, and alter objects in both work areas.

• The Plane Geometry view shows only the objects created in the Geometry
application.

Objects Created in the Graphs Application

Points, lines, and shapes created in the Graphs application are analytic objects.

• All points that define these objects reside on the x,y graph plane. Objects created
here are visible only in the Graphs application. Changing the axes scale affects the
appearance of the objects.

• You can display and edit the coordinates of any point on an object.

• You can display the equation of a line, tangent line, circle shape, or geometric conic
created in the Graphs application.

The circle arc andpolygonwere created in the Geometry application. The sinewave and
conicwere created in the Graphs application.



Objects Created in the Geometry Application

Points, lines, and shapes created in the Geometry application are not analytic objects.

• Points that define these objects do not reside on the graph plane. Objects created
here are visible in both the Graphs and Geometry applications, but they are
unaffected by changes to the Graphs x,y axes.

• You cannot obtain the coordinates of an object’s points.

• You cannot display the equation of a geometric object created in the Geometry
application

Creating Geometric Objects

You can create objects in both the Geometry and Graphs applications.

Creating Points and Lines

1. Tap Tools , select Points and Lines, and select the type of object, such as
Segment. (In the Graphs application, go to Geometry > Points and Lines > Segment.)

2. Tap existing points or locations on the work area to define the object. For example,
tap two objects when creating Intersection points.

As you create the object, a tool is shown in the application Toolbar (for example,
Segment ). To cancel, tap the X on the tool.
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Creating Geometric Shapes

1. Tap Tools , select Shapes, and select the type of object, such as Polygon. (In the
Graphs application, go to Geometry > Shapes > Polygon.)

2. Tap existing points or locations on the work area to define the object. For example,
tap two locations to define the center and radius of a circle.

As you create a shape, a tool is shown in the application Toolbar (for example, Polygon
). To cancel the shape, tap the X on the tool.

Measuring and Transforming Geometric Objects

Measuring Objects

1. Tap Tools , select Measurement, and select the type of measurement, such as
Length. (In the Graphs application, go to Geometry > Measurement> Length.)

2. Tap the object you want to measure.

Measurement Type Use to Measure...

Length • Length of a segment, circle
arc, or vector

• Distance Between Two
Points, a Point and a Line, or
a Point and a Circle

• Circumference of a Circle or
Ellipse or the Perimeter of a
Polygon, Rectangle, or
Triangle

• A side of a triangle,
rectangle, or polygon. You
must tap two points to
measure a side. Tapping the
side measures the entire
length of the object's
perimeter.

Area Area of a Circle, Ellipse,
Polygon, Rectangle, or Triangle



Measurement Type Use to Measure...

Slope Slope of a Line, Ray, Segment, or
Vector

Angle Angles in the range from 0° to
180° (0 radians to π radians in
the Graphs application)

Directed Angle Directed angles in the range from
0° to 360° (0 radians to 2π
radians) and from -360° to 0° (-2π
radians to 0 radians).

Transforming Objects

1. Tap Tools , select Transformation, and select the type of transformation, such as
Symmetry. (In the Graphs application, go to Geometry > Transformation >
Symmetry.)

2. Tap the object you want to transform.

3. Tap a location, existing point, or other object to create the transformation.

Exploring with Construction Tools

To add a construction, tap Tools , select Construction, and select the type of
construction, such as Parallel. (In the Graphs application, go to Geometry >
Construction > Parallel.)
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While a construction is in progress, a tool appears in the application Toolbar (for
example, Parallel ). To cancel, tap the X on the tool.

Construction Type Description

Midpoint Bisects a segment or sets a midpoint
between any two points. The points can be
on a single object, on separate objects, or on
the work area.

Parallel Line Creates a parallel line with respect to any
existing line. The existing line can be a
Graphs axis or any side of a triangle, square,
rectangle, or polygon.

Perpendicular Line Creates a line that is perpendicular to a
reference line. The reference can be an axis,
an existing line, a segment, or one side of a
triangle, rectangle, or polygon.

Perpendicular Bisector Creates a perpendicular bisector on a
segment, on one side of a triangle, rectangle,
or polygon, or between any two points.



Construction Type Description

Angle Bisector Creates an angle bisector. The points of the
angle can be on existing objects, or they can
be locations on the work area.

Locus Lets you explore the range of motion of one
object with respect to another object as
constrained by a shared point.

Compass Operates similarly to a geometric compass
used for drawing circles on paper.
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Using the Calculate Tool

The Calculate tool is available in the Graphs and Geometry applications. It lets you
evaluate a math expression you have entered as a text object. You can edit an
evaluated expression, and then re-evaluate it.

Entering the Expression

1. Tap Tools and go to Actions > Text.

2. Tap the work area to place the text box and display the keyboard.

3. Type the expression, such as (1/4)2*2, and tap ENTER.

Note: Do not include variables in the expression.

Calculating the Result

1. Tap Tools and go to Actions > Calculate.

The Calculate tool appears in the toolbar, and a prompt asks you to select an
expression to calculate.

2. Tap the text object to evaluate the expression.

Creating Shapes Using Gestures (MathDraw)

The MathDraw tool lets you use touchscreen gestures to create points, lines, circles,
and other shapes.

• MathDraw is available in Geometry and Graphing.

• Graphing view when the x scale and y scale are identical. This avoids non-circular
ellipses and non-square rectangles appearing as circles and squares.

Note: MathDraw is not available in the 3D Graphing.

Activating MathDraw

1. Tap Add, and then tap .

2. Tap Tools .

3. Tap Actions menu, select MathDraw.



The MathDraw tool appears in the application Toolbar. You can begin
using the tool.

Canceling MathDraw

▶ When you have finished using the MathDraw tool, tap the X on the tool.

Creating Points

To create a labeled point, tap in an open area.

• If the point is close to an existing line, segment, ray, geometric conic (including
circles), or polygon, the point snaps to that object. You can also place a point on the
intersection of any two of those types of objects.

• If the point is close to a visible grid location in a Graphs view or Geometry view, it
snaps to the grid.

Drawing Lines and Segments

To create a line or segment, touch the initial position, and then drag to the end
position.

• If the drawn line passes near an existing point, the line snaps to the point.

• If the drawn line starts close to an existing point and ends next to another existing
point , it becomes a segment defined by those points.

• If the drawn line is nearly parallel or perpendicular to an existing line, segment, or
side of a polygon, it aligns to that object.

Note: The default tolerance for detecting parallel/perpendicular lines is 12.5
degrees. This tolerance can be redefined using a variable named
ti_gg_fd.angle_tol. You can change the tolerance in the current problem by setting
this variable in the calculator app to a value in the range 0 through 45 (0=no
parallel/perpendicular detection).

Drawing Circles and Ellipses

To create a circle or ellipse, use the touchscreen to draw the approximate shape.

• If the drawn shape is sufficiently circular, a circle is created.

• If the shape is elongated, an ellipse is created.

• If the virtual center of the drawn shape is near an existing point, the circle or
ellipse is centered on that point.
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Drawing Triangles

To create a triangle, draw a triangle-like shape.

• If a drawn vertex is close to an existing point, the vertex snaps to the point.

Drawing Rectangles and Squares

To create a rectangle or square, use the touchscreen to draw the perimeter.

• If the drawn shape is nearly square, a square is created.

• If the drawn shape is elongated, a rectangle is created.

• If the center of a square is close to an existing point, the square snaps to that
point.

Drawing Polygons

To create a polygon, tap a succession of existing points, ending on the first point you
tapped.

Using MathDraw to Create Equations

In the Graphs view, MathDraw attempts to recognize certain gestures as functions for
analytic parabolas.

Note: The default step value for quantization of the parabola coefficients is 1/32. The
denominator of this fraction can be redefined using a variable named ti_gg_fd.par_
quant. You can change the step value in the current problem by setting this variable to
a value greater or equal to 2. A value of 2, for example, produces a step value of 0.5.

Using MathDraw to Measure an Angle

To measure the angle between two existing lines, use the touchscreen to draw a circle
arc from one of the lines to the other.

• If the intersection point between the two lines does not exist, it is created and
labeled.

• The angle is not a directed angle.

Using MathDraw to Find a Mid-point

To create a point midway between two points, tap point 1, point 2, and then point 1
again.



Using MathDraw to Erase

To erase objects, use the touchscreen to drag left and right, similar to the motion of
erasing a whiteboard.

• The erasure area is the bounding rectangle of the erasure gesture.

• All point objects and their dependents inside the erasure area are removed.
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Sticky Tool in Geometry and Graphing

Sticky Tool is available in Geometry and Graphing.

Note: In the Graphs application, go to Tools > Geometry.

When a Geometry tool has the capability to remain active, it will display a lock
element along with the tool icon.

Lock Element icon

Unlocked/Single-use icon Locked/Multi-use icon

Note: All tools will open in the default or unlocked/single-use state. The icon will

appear to the left of the tool.

Unlocked/Single-use Locked/Multi-use

Default State

Opening a tool will always be in the default unlocked/single-use state). This applies to
scenarios like closing a tool, or switching to a new tool.

Geometry and Graphing tools that are sticky

The following tools will have the "sticky" feature:

• All items under "Points & Lines"

• All items under "Shapes"

• All items under "Measurement"

• All items under "Construction"

• All items under "Transformation"

Locking or Unlocking a tool

Tap the unlocked/single-use icon to lock a tool for locked/multi-use.

Note: The tool is now in a locked/multi-use state.



Tap the X to close the tool.

-or-

Tap the unlocked/single-use state.

Note: The user can also toggle between icon.
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Lists & Spreadsheet Application
The Lists & Spreadsheet application provides a place to work with tabular data.

What You Can Do

• Define a column based on the contents of another column.

• Work with variables created in the Graphs & Geometry and Calculator applications.

• Plot table data using the Data & Statistics application.

• Generate a table of values for a function or plot.

• Perform statistical analysis on lists of data.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know

Typing a Cell Reference in a Formula

Absolute references include the $ symbol before the column letter and before the row
number, and always refer to the cell in a specific position in the spreadsheet. Relative
references include only the cell’s column letter and row number, and describe where a
cell is in relation to other cells of the spreadsheet.

1. Double-tap the cell, and type the formula.

2. Move to the appropriate position in the formula, and type the cell reference.

Use the format for a relative reference (B3), absolute reference ($B$2), or range of
cells (A1:A4).

Linking a Cell Value to a Variable

1. In a Lists & Spreadsheet page, tap the cell that you want to link to a variable, and
then tap the cell again to open the context menu.

2. Tap Link, and then tap the name of the variable to insert it into the cell.
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Linking a Column to a Variable

1. Tap the column formula cell (the second cell from the top) that you want to link to
a variable.

2. Type the name of the list variable that you want to link to, and then tap return.

Note: To view a list of available variables, tap var on the TI-Nspire™ Keyboard.

Adding a Lists & Spreadsheet Page

To get started with the Lists & Spreadsheet application, add a Lists & Spreadsheet
page to an existing document.

▶ Tap Add, and then tap .

A blank Lists & Spreadsheet page is displayed.

Column and row reference cell

Column name cell for defining a column as a list variable

Column formula cell for generating a column of data

Body cells

Working with Data

Generating Columns of Data

You can create a column of values based on the contents of another column or on any
of several types of sequential data.



Column formula based on a variable

Column formula based on another column

Column formula that generates a sequence

Creating Values Based on Another Column

1. Tap the column formula cell (the second cell from the top) of the column where
you want to use a formula.

2. Type the expression for the formula after the = and tap ENTER.

Note: Use brackets ([]) after any column letter you include in the formula.

Generating a Column of Random Numbers

1. Tap the column formula cell (the second cell from the top) of the column.

2. Tap Tools and go to Data > Random > Integer to insert the randint() function.

3. The app inserts the randint() function in the formula cell.

4. Type 1,6,20, and then tap ENTER.

Note: The numbers given are for illustrative purposes only, and will generate a
column of 20 random integers in the range, 1 through 6.

Generating a Numerical Sequence:

1. Tap any cell in the column in which you want to generate the sequence.

2. Tap Tools and go to Data > Generate Sequence.

3. Type the Formula that will be applied to the column values.
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4. Type any starting numbers required by the sequence in the Initial Terms field and
separate them with commas.

5. Type a starting value for the independent variable (n0), a maximum number of
values to be generated (nMax), and the step value (nStep).

Note: Type a maximum value for the sequence in the Ceiling Value field, if desired.

6. Tap OK.

Graphing Spreadsheet Data

Creating a Scatter Plot with Quick Graph

1. Name both of the columns to declare them as lists, and then select both columns.

2. Tap Tools and go to Data > Quick Graph.

A Data & Statistics application is added to the page with the plotted data.

Creating a Summary Plot

Note: In this example, you create a summary table from raw data, and then use the
table to generate a summary plot.

1. Create a list that holds the category identifiers. For this example, name the list
“color” and type strings for eye color.

2. Create the summary list. For this example, name the list “counts” and type the
total count for each of the eye colors.

3. Select either list.

4. Tap Tools and go to Data > Summary Plot.

5. If necessary, change the lists for X List and Summary List.

6. In the Display On field, select how to display the summary plot in the Data &
Statistics application, and then tap OK.

Capturing Data from Graphs or Geometry

1. Clear the columns you plan to use for the captured data.

2. Ensure that the data values you want to capture are linked to variable names.

3. Tap the column formula cell (the second cell from the top) of the column in which
you want to capture the values.

4. Tap Tools and go to Data > Data Capture > Automatic.



A capture expression is inserted.

5. Replace the letters “var” with the name of the variable to capture.

Note: You can also select the variable name from the Variables menu by tapping
var, and then tapping the desired variable.

Using Table Data for Statistical Analysis

Tools on the Statistics menu provide access to wizards that help you perform statistical
analyses on the data in table columns. You specify the location of the data, and the
Lists & Spreadsheet application stores the results in two columns: one for the result
names, and one for the corresponding values.

Statistical Calculations and Results

You can perform statistical calculations to analyze data.

Performing Statistical Calculations

Note: The following example fits a y=mx+b linear regression model to two lists.

1. Tap the column formula cell (second cell from the top) in column A.

2. Tap Tools and go to Statistics > Stat Calculations > Linear Regression (mx+b) to
choose the regression model.
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3. Tap next to the Y List box to display a named list. Tap the name of the list for
the Y List.

4. To store the regression equation in a specified variable, replace Save RegEqn To
with the name of the variable.

5. Tap the 1st Result Column box and type c[] as the column letter for the first result
column.

6. Tap OK.

Note: The results are linked to the source data.

Storing Statistical Results

The Lists & Spreadsheet application stores statistical results using a variable-group
name with the format stat.nnn, where nnn is the result name (for example,
stat.RegEqn and stat.Resid). If you want to use a custom variable group instead of the
standard name, edit the formula in the column formula cell. You could use the
following formula to store the results in the variable groupMystatsB.

=LinRegMx(a[],b[],1 ): CopyVar Stat., MystatsB.

Later, you could view the results by entering the following expression in the Calculator
application or in another column of the Lists & Spreadsheet application:

MystatsB.results

Distributions

Calculating a Distribution

Example: Calculate a distribution to fit the Normal Pdf distribution model.



1. Enter the X values of the data in column A.

2. Tap the top cell of column A and enter a name, such as DD1, for the X values.

3. Tap the column formula cell (second cell from the top) in column B.

4. Tap Tools and go to Statistics > Distributions > Normal Pdf.

The Normal Pdf dialog box opens and displays fields for entering the arguments for
the calculation.

5. Tap each field and provide:.

- X Value: To use the list that you defined in step 2, tap the arrow and select the
list name.

- Mean (μ): Type a value or select a variable that contains the mean.

- Standard Deviation (σ): Type a value or select a variable that contains the
standard deviation.

6. (Optional) Select the Draw option to see the distribution plotted in
Data & Statistics.

Note: The Draw option is not available for all distributions.

7. Tap OK.

Lists & Spreadsheet populates column B with the results. The results are plotted in
Data & Statistics.

Note: The results are linked to the source data. For example, if you change a value
in Column A, the result updates automatically.
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Supported Distribution Functions

The following distributions are available from the Lists & Spreadsheet application. For
more information regarding these functions, see the TI-Nspire™ Reference Guide.

• To return a single distribution result based on a single value, type the function in a
single cell.

• To return a list of distribution results based on a list of values, type the function in
a column formula cell. In this case, you specify a list (column) that contains the
values. For each value in the list, the distribution returns a corresponding result.

Note: For distribution functions that support the draw option (normPDF, t PDF,
χ² Pdf, and F Pdf), the option is available only if you type the distribution function
in a formula cell.

Normal Pdf (normPdf)

Computes the probability density function (pdf) for the normal distribution at a
specified x value. The defaults are mean μ=0 and standard deviation σ=1. The
probability density function (pdf) is:

This distribution is used to determine the probability of the occurrence of a certain
value in a normal distribution. The draw option is available when Normal PDF is
invoked from a formula cell.

When you access distributions from the formula cell, you must select a valid list from
the drop-down list to avoid unexpected results. If accessed from a cell, you must
specify a number for the x-value. The distribution returns the probability that the value
you specify will occur.

Normal Cdf (normCdf)

Computes the normal distribution probability between Lower Bound and
Upper Bound for the specified mean, μ (default=0) and the standard deviation, s

(default=1). You can click the Draw (Shade area) check box to shade the area between
the lower and upper bounds. Changes to the initial Lower Bound andUpper Bound
automatically update the distribution.



This distribution is useful in determining the probability of an occurrence of any value
between the lower and upper bounds in the normal distribution. It is equivalent to
finding the area under the specified normal curve between the bounds.

Inverse Normal (invNorm)

Computes the inverse cumulative normal distribution function for a given area under
the normal distribution curve specified by mean, μ, and standard deviation, s.

This distribution is useful in determining the x-value of data in the area from 0 to x<1
when the percentile is known.

t Pdf (tPdf)

Computes the probability density function (pdf) for the t-distribution at a specified x
value. df (degrees of freedom) must be > 0. The probability density function (pdf) is:

This distribution is useful in determining the probability of the occurrence of a value
when the population standard deviation is not known and the sample size is small. The
draw option is available when t Pdf is invoked from a formula cell.

t Cdf (tCdf)

Computes the Student-t distribution probability between Lower Bound and
Upper Bound for the specified df (degrees of freedom). You can click the Draw (Shade
area) check box to shade the area between the bounds. Changes to the initial
Lower Bound andUpper Bound automatically update the distribution.

This distribution is useful in determining the probability of the occurrence of a value
within an interval defined by the lower and upper bound for a normally distributed
population when the population standard deviation is not known.

Inverse t (invt)

Computes the inverse cumulative t-distribution probability function specified by
Degrees of Freedom, df, for a given area under the curve.

This distribution is useful in determining the probability of an occurrence of data in the
area from 0 to x<1. This function is used when the population mean and/or population
standard deviation is not known.
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c2 Pdf (c2 Pdf())

Computes the probability density function (pdf) for the c2 (chi-square) distribution at a
specified x value. df (degrees of freedom) must be an integer > 0. The probability
density function (pdf) is:

This distribution is useful in determining the probability of the occurrence of a given
value from a population with a c2 distribution. The draw option is available when c2

Pdf is invoked from a formula cell.

c2 Cdf (c2 Cdf())

Computes the c2 (chi-square) distribution probability between lowBound and upBound
for the specified df (degrees of freedom). You can click the Draw Shade area check box
to shade the area between the lower and upper bounds. Changes to the initial
lowBound and upBound automatically update the distribution.

This distribution is useful in determining the probability of the occurrence of value
within given boundaries of a population with a c2 distribution.

F Pdf (F Pdf())

Computes the probability density function (pdf) for the F distribution at a specified x
value. numerator df (degrees of freedom) and denominator df must be integers > 0.
The probability density function (pdf) is:

where n = numerator degrees of freedom
d = denominator degrees of freedom

This distribution is useful in determining the probability that two samples have the
same variance. The draw option is available when F Pdf is invoked from a formula cell.

F Cdf (F Cdf())

Computes the F distribution probability between lowBound and upBound for the
specified dfnumer (degrees of freedom) and dfDenom. You can click the Draw (Shade
area) check box to shade the area between the lower and upper bounds. Changes to
the initial lowBound and upBound automatically update the distribution.

This distribution is useful in determining the probability that a single observation falls
within the range between the lower bound and upper bound.



Binomial Pdf (binomPdf())

Computes a probability at x for the discrete binomial distribution with the specified
numtrials and probability of success (p) on each trial. The x parameter can be an
integer or a list of integers. 0{p{1 must be true. numtrials must be an integer > 0. If
you do not specify x, a list of probabilities from 0 to numtrials is returned. The
probability density function (pdf) is:

where n = numtrials

This distribution is useful in determining the probability of success in a success/failure
trial, at trial n. For example, you could use this distribution to predict the probability of
getting heads in a coin toss on the fifth toss.

Binomial Cdf (binomCdf())

Computes a cumulative probability for the discrete binomial distribution with n number
of trials and probability p of success on each trial.

This distribution is useful in determining the probability of a success on one trial before
all trials are completed. For example, if heads is a successful coin toss and you plan to
toss the coin 10 times, this distribution would predict the chance of obtaining heads at
least once in the 10 tosses.

Inverse Binomial (invBinom())

Given the number of trials (NumTrials) and the probability of success of each trial
(Prob), this function returns the minimum number of successes, k, such that the value,
k, is greater than or equal to the given cumulative probability (CumulativeProb).

This distribution is useful in determining the upper bound input of the binomial cdf. For
example, if you flip a coin 10 times, and you want the probability of getting x heads or
less to be greater than 75%, this distribution will help determine what x should be.

Inverse Binomial with respect to N (invBinomN())

Given the probability of success of each trial (Prob), and the number of successes
(NumSuccess), this function returns the minimum number of trials, N, such that the
value, N, is less than or equal to the given cumulative probability (CumulativeProb).

This distribution is useful in determining the number of trials of the binomial cdf. For
example, if you flip a coin several times and you want the number of heads to be 6 or
less with a probability of less than 25%, this distribution will help determine how many
times to flip the coin.
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Poisson Pdf (poissPdf())

Computes a probability at x for the discrete Poisson distribution with the specified
mean, μ, which must be a real number > 0. x can be an integer or a list of integers.
The probability density function (pdf) is:

This distribution is useful in determining the probability of obtaining a certain number
of successes before a trial begins. For example, you could use this calculation to
predict the number of heads that would occur in eight tosses of a coin.

Poisson Cdf (poissCdf())

Computes a cumulative probability for the discrete Poisson distribution with specified
mean, x.

This distribution is useful in determining the probability that a certain number of
successes occur between the upper and lower bounds of a trial. For example, you could
use this calculation to predict the number of heads displayed between coin toss #3 and
toss #8.

Geometric Pdf (geomPdf())

Computes a probability at x, the number of the trial on which the first success occurs,
for the discrete geometric distribution with the specified probability of success p. 0{p
{1 must be true. x can be an integer or a list of integers. The probability density
function (pdf) is:

This distribution is useful in determining the likeliest number of trials before a success
is obtained. For example, you could use this calculation to predict the number of coin
tosses that would be made before a heads resulted.

Geometric Cdf (geomCdf())

Computes a cumulative geometric probability from lowBound to upBound with the
specified probability of success, p.

This distribution is useful in determining the probability associated with the first
success occurring during trials 1 through n. For example, you could use this calculation
to determine the probability that heads display on toss #1, #2, #3, ..., #n.

Working with Tables

You can change the table of plots values using the tools on the Table menu.



▶ To remove a column from the table, click any cell, and then tap Tools and go to
Table > Delete Column.

▶ To display the list of plots, tap the drop-down arrow on the top cell of a column.
Select an empty column, (unless you are replacing values already displayed), and
then tap a function in the list to add its values to the column.

▶ To change the expression that defines a plot, tap the formula cell and edit the
expression.

Manual Data Capture

You can use Lists & Spreadsheet application to capture information about objects in
the TI-Nspire™ Apps for iPad®. For example, you could track changes of the position of
a point on a graph in the Graphs & Geometry application.

The ability to capture data manually is not limited to Graphs & Geometry. This function
could work for any other application in the same problem.

Capturing Data Manually

1. Tap the column formula cell (the second cell from the top) of the column in which
you want to capture the values.

Note: Captured values replace values in the column.

2. Tap Tools and go to Data > Data Capture >Manual.

A capture expression is inserted into the column formula cell with "var" as a
placeholder for the name of the variable you are capturing.
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3. Replace the letters “var” with the name of the variable to capture from
Graphs & Geometry. For example, type a or to view a list of available variables, tap
var on the TI-Nspire™ Keyboard.

The formula cell now contains an expression similar to =capture(a,0).



Note: The argument “0” tells Lists & Spreadsheet that you want to trigger each
capture manually.

4. Tap Enter.

5. From the Graphs & Geometry application, move the point to a different location
where x coordinate of the point is stored in a variable (a, in this example)
referenced in the data capture expression.

6. Tap .

The current a value is stored in the Lists & Spreadsheet application configured to
capture the variable a.

See Using Variables for more information on adding and using variables.
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Data & Statistics Application
The Data & Statistics Application enables teachers and students to create graphical
displays and perform analysis on data stored in lists. Defining (or naming) sets of data
using the Lists & Spreadsheet Application is the starting point for plotting and
analyzing data.

What You Can Do

• Work with sets of data in different types of plots.

• Work with sets of data in different types of charts.

• Manipulate variables to explore and visualize data relationships.

• Explore central tendency and other statistical summary techniques.

• Fit functions to data.

• Create regression lines for scatter plots.

• Graph hypothesis tests and results (z- and t-tests) based on summary statistics
definitions or data.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know

Plotting Variables

• Lists created in Lists & Spreadsheet can be accessed as a variable.

• Variables must be named before they can be used in Data & Statistics.

• Tap the Add Variable field located in the center of the x-axis or y-axis to choose a
defined variable name.

• The default plot for one variable is a dot chart. The data points in the default
caseplot reposition to represent the elements of the selected variable.

• The default plot for two variables is a scatter plot. The data points shift to
represent the elements of both variables on a scatter plot.

Rescaling the Axes

Pinch or spread either the horizontal or vertical axis to modify its scale.
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-OR-

Drag either axis to shift the axis while retaining its scale.

To restore the original size and location of the plotted data, tap Tools > Window/Zoom
> Zoom-Data.

Plotting a Value

When you plot a value on an existing plot, it is displayed as a vertical line in the work
area. You can plot a single number or any expression that evaluates to a number. If the
value is dependent on the data, the line updates to reflect changes made when you
drag a point or make changes in the Lists & Spreadsheet application. The plotted value
must be in the domain of the axis.

To plot a value:

1. Tap Tools , go to Analyze, and then tap Plot Value.

2. Type the value you want to plot, and then tap ENTER.

Plotting a Function

Use Plot Function to graph a function for comparison to an existing plot. To plot a
function:

1. Create or open a problem that includes variables that are plotted in a Data
& Statistics work area. Ensure the work area contains both a horizontal axis and a
vertical axis.

2. Tap Tools , go to Analyze, and then tap Plot Function.

3. Type the function in the entry field and tap return.

Note: You can rename the function by typing over f1(x): with another name.

Adding a Data & Statistics Page

To get started with the Data & Statistics application, add a Data & Statistics page to an
existing document that contains a Lists & Spreadsheet page.

1. Tap Add, and then tap .

The Data & Statistics page shows the default case plot.



2. Tap the add variable region on each axis to view defined variables.

3. Tap the variable name to add it to the selected axis to create a dot plot (frequency
plot).
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Working with Plots

Dot Plots

• Dot plots are also known
as frequency plots, and
represent one-variable
numerical data.

• Dot plots are the default
plot type for numerical
data.

• One dot represents each
value in the list.

• Each dot is displayed on
the axis at a point that
corresponds to the value.

Box Plots

• Box plots are used to plot
one-variable numerical
data in a modified box.

• "Whiskers" extend from
each end of the box.

• Box plots are used to
compare two or more sets
of data that use the same
scale.



Histograms

• A histogram plots one-
variable numerical data
and depicts the
distribution of data.

• The number of bins
displayed depends on the
number of data points and
how the points are
distributed.

• A value that occurs on the
edge of a bin is counted in
the bin to its right.

Normal Probability Plots

Shows one set of numerical data
against the corresponding
quartile (z) of the standard
normal distribution.
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Scatter Plots

• Shows the relationship
between two sets of
numerical data.

• You also plot a scatter plot
using the Quick Graph tool
in the Lists & Spreadsheet
application.

X-Y Line Plots

• This plot is a type of
scatter plot in which data
points are plotted and
connected in order of
appearance in the two
variables.

• An X-Y line plot depicts the
relationship between two
sets of data.

• The left-most column of
data is represented on the
horizontal axis.

Exploring and Analyzing Plotted Data

• Drag a point to move it. As you move a point, the values associated with the point
change in the work area and in the list of variables.

• To change a variable on an axis, tap the Add Variable region, and then tap another
variable name.

• From the Tools menu:

- Tap Plot Type to select another supported plot type.

- Tap Plot Properties to clear all variables or to modify properties such as add
and remove X and Y variables, add a summary list, or force a categorical X.

- Tap Actions to insert text or sliders. You can also select all points in the plot.



- Tap Analyze to choose analysis options such as add a moveable line, plot a
value or function, or activate the Graph Trace tool.

Working with Charts

Dot Charts

• The default plot type for
categorical data is the dot
chart.

• When one variable is
plotted, the value of each
cell is represented as one
dot.

• The dots are stacked at the
point on the axis that
corresponds to the cell
value.

Bar Charts

• Bar charts display
categorical data.

• The length of the bar
represents the number of
cases in the category.
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Pie Charts

A pie chart represents
categorical data in a circular
layout and uses a proportioned
segment for each category.

Exploring and Analyzing Data Plotted in a Chart

• Drag a point to move it. as you move a point, the values associated with it change
in the work area and in the list of variables.

• From the Tools menu:

- Tap Plot Type to choose another supported plot type.

- Tap Plot Properties to clear all variables, or to modify applicable properties
such as add and remove X and Y variables, add a summary list, and force a
categorical X.

- Tap Actions to insert text and sliders. You can also select all points in the plot.

- Tap Analyze to choose applicable analysis options such as adding a moveable
line, plotting a value or function, or activating the Graph Trace tool.

Adding Color to Plots and Charts
1. Tap a plot or chart object to select it.

Note: To select all points in a plot, tap Tools > Actions > Select All Points.

2. Tap Inspector , and then tap Fill Color.

3. Tap a color to select it.



Notes Application
The Notes application enables you to create and share documents.

What You Can Do

• Create study notes to reinforce learning and review for exams.

• Share a Notes document with others and use text formatting options so that each
person's entries and comments appear in a different color or font.

• Create and evaluate math expressions.

• Create correctly formatted chemical formulas and equations.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know

Deactivating a Selected Expression or Box

Note: You can also activate and deactivate a selected expression or box by selecting
Tools > Actions > Activate (Deactivate) All.

1. Tap the expression or box you want to select, and then tap again.

2. Tap Select.

The selected text or item closest to the cursor is highlighted and the handles are
active.
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3. Drag the handles to highlight the expression, math box, or chem box you want to
select.

4. Tap Tools and go to Actions.

5. Tap Deactivate Selection.

Activating a Selected Item

1. Tap the expression or box you want to select.

2. Tap Select.

3. Drag the handles to select the portion of the expression or text you want to
activate.

4. Tap Tools and go to Actions.

5. Tap Activate Selection.

Formatting Text in Notes

1. Tap the text you want to format, and than tap it again to open the context menu.

2. On the context menu, tap Select.

Drag the handles to select additional text, or tap Select All to select all of the text.

3. Tap Inspector .



4. Select the formatting you want to apply. Changes are applied as you select them.

Inserting Comments, Shapes, and Calculations

Inserting Comments

You can insert Teacher or Review comments into a Notes page. Comments are labeled
to make them easy to distinguish from the original text.

1. Tap the Notes work area where you want to insert a comment.

2. Tap Tools and go to Insert.

3. Tap Comment.

4. Tap Teacher or Reviewer to choose the comment type.

5. Type the comment text inside the comment box.

The comment text appears in bold formatting.
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6. If needed, select the text and tap Inspector to apply formatting to the

comment text.

Inserting Geometric Shape Symbols

Use geometric shapes to designate selected text as a geometric object such as an
angle, circle, or line segment.

1. Tap the work area where you want to insert the shape, or select the text that you
want designate as a shape.

2. Tap Tools and go to Insert.

3. Tap Shape.

4. Tap the shape name (such as segment or ray) to insert it before the selected item.

Inserting Calculations

1. Tap the Notes work area to place your cursor where you want to insert the math
expression.

2. Tap Tools and go to Calculations.



3. Tap the type of calculation you want to insert, and then tap the function name to
insert the expression.

Working with Math Boxes

Inserting a Math Box

1. Tap the Notes work area to place your cursor where you want to insert the math
box.

2. Tap Tools and go to Insert.

3. TapMath Box. If you are using an external keyboard, press " + M.

4. Type the expression inside the math box. You can also insert a function, command,
symbol or expression template by tapping Utilities to access Catalog, Symbols,
Math Operators, and Libraries.

5. Tap ENTER to evaluate the expression.

Converting Selected Items to Math Boxes

1. Select the text, or combination of text and existing math boxes, that you want to
evaluate.
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2. Tap Tools and go to Insert.

3. Tap Convert to Math Box.

Inserting Chemical Equations

Use chemical equation boxes (chem boxes) to type chemical formulas and equations
such as:

CH
4
 + 2O

2
→ CO

2
 + 2H

2
O. Equations in a chem box cannot be evaluated or

balanced.

Entering a Chemical Equation

1. Position the cursor on the page where you want the equation.

2. Tap Tools and go to Insert.

3. Tap Chem Box.

An empty chemical equation box is added to the page.

4. Type the equation in the box. For example, to represent sulphuric acid, type
h2so4, capitalizing the O manually.

5. To exit the chem box, tap outside the box.

Using Math Actions 

Math Actions are available on Notes and Calculator pages.



When you display the context menu for a selected expression or equation, the menu
may include a Math Actions submenu that lists the available actions. Each action might
prompt you for any needed parameters.

The specific math actions listed depend on:

• The type of expression or relation.

• The operating system in use (numeric or CAS).

Example of Math Actions in Notes

1. Insert a math box, and type the equation x2+3x+1=0, but don't press Enter yet.

Numeric OS CAS OS

2. Tap the equation to display its context menu, and select Math Actions.

Numeric OS CAS OS

3. Select the action to perform:

- Solve Numerically for numeric OS.
- Solve for CAS OS.

You are prompted to enter parameters. For example, Numeric Solve prompts for
the variable of interest, initial guess, lower bound, and upper bound.

4. Type a value for each parameter. When options are available, you can tap an arrow
to make a selection.

Numeric OS CAS OS
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5. Tap OK to construct the completed expression and place it in the math box.

Numeric OS CAS OS

6. Press Enter to complete the action.

Numeric OS CAS OS

7. As a further exploration, select x2+3·x+1. Do not include the "=0" portion.

Numeric OS CAS OS

8. Display the context menu for the selected text, select Math Actions >
Find Roots of Polynomial, and press Enter to complete the action.

The action and its result are shown in a new math box.

Numeric OS CAS OS

Tips for Using Math Actions in Notes

▶ For a previously evaluated expression, tap the expression to display its context
menu.

When you select an action, it replaces the expression.

▶ For a displayed result, tap the result to display its context menu.

When you select an action, it appears in a new math box.

▶ For a portion of an expression or result, select the portion, and then display the
context menu.

When you select an action, it appears in a new math box.

Graphing from Notes and Calculator 

You can graph a function or relation directly from its context menu. This feature is
available for many functions and relations on Notes and Calculator pages.



If page layout options allow, the graph appears on the same page as the function or
relation. Otherwise, the graph appears on a separate Graphs page.

The type of graph created depends on the type of function or relation.

Example of Graphing from Notes

This example uses a Notes page to explore a quadratic function interactively.

1. Insert a math box on a new Notes page, and enter the following function
definition:

Define f1(x)=x2-1·x-4

2. Tap the expression to display its context menu.
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3. Select Graph.

The graph appears. The graph and the math box are linked so that any adjustment
to one affects the other.

4. Explore the relationship between the defined function and its graph:

- Drag the ends or center of the graph to manipulate it, and observe the changes
to the function definition.

—or—

- Edit the defined function in the math box, and observe the changes to the
graph.



Using a Displayed QR Code®

A QR Code® is an image that stores information, such as the address of a web site or
TI-Nspire™ document, as a pattern of small squares.

Webaddress http://education.ti.com stored as aQR Code®.

Authors of TI-Nspire™ documents can insert or paste a QR Code® on any Notes page.
Users viewing the document with TI-Nspire™ App for iPad® can tell the app to scan the
code directly from the page and link to its associated target. Lua scripts can also
display a QR Code® that you can scan within the App.

Note: You can scan a QR Code® from printed materials or projected images by using
your device camera. For details, refer to Scanning a QR Code® with the Camera.

Scanning a QR Code® on a Notes Page or Lua Script

Use this procedure to scan a displayed QR Code® and link to its target:

1. If necessary in Notes, scroll to ensure that only one code image is visible on your
screen.
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Note: The image must be entirely visible; the software will scan only the displayed
region of the page.

2. Tap the Camera in the toolbar, and select Scan QR Code® from Page.

- If the target is a TI-Nspire™ document (.tns file), the App automatically
downloads the document, saves and closes your current document, and opens
the downloaded document.

- Otherwise, the App opens your web browser to resolve the target.

How to Insert a QR Code® on a Notes Page

You can add QR Code® images to a Notes page. One image per page is best for reliable
scanning.

1. Generate the image, using an online code generator or a code-generator app. You
will need to supply the target URL.

2. Copy the generated image to the Clipboard, or save it as a photo.

3. Display your Notes page and use the method that applies for adding the image:

- If you copied the image to the Clipboard, press and hold the location on the
page, and select Paste.

- If you saved the image as a photo, position the text cursor on the page, tap the
Camera in the toolbar, and select Insert Photo.

The QR Code® appears on the Notes page with resizing handles.

Note: For optimal scanning, you should not resize or reshape the image.



4. (Optional) add a tip for users of your document who might not know how to use
the code.

5. Make sure the code is valid by testing it with the Scan QR Code® from Page feature.
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Question Documents Overview
The TI-Nspire™ App for iPad® enables you to receive question documents sent by your
teacher via email. The question document may contain multiple pages and can contain
any TI-Nspire™ application. When you tap question, the icon changes to show you
which application is active.

What You Can Do

When you receive a question document from your teacher, you can:

• Open the document and answer the questions.

• Show your work if requested by the teacher.

• Check your answers if the teacher permits.

• Email the document with your responses back to the teacher.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know

Inserting Math Boxes and Chem Boxes

You can insert a math expression box or chemical equation box in any area of the
response that allows text. Use expression boxes to type properly formatted math
expressions. Use chem boxes to type properly formatted chemical formulas or
equations. To insert an expression or chem box:

1. Tap the answer area to place the cursor where you want to place the box.

2. Tap Tools , and then tap Insert.

3. Tap Expression Box to insert a math expression box.
-or-
Tap Chem Box to insert a chemical equation box.

4. Type the expression in the box.
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5. Tap ENTER to complete the expression.

Responding to Questions

Teachers may send you any of the following types of questions. Tap a question type
name to see how to respond to the question.

Note: You may need to scroll to see the entire question. All parts of the question may
not be visible on the page, and parts of a question may be hidden behind a graph or
image.

Multiple Choice Questions

• Tap the option or options next to the
response you want to select.

• Choices with next to them indicate
that there is only one correct answer.

• Choices with next to them indicate
that there may be more than one
correct answer.

Open Response Questions

Type a response.



Equation Questions

Type a response.

If a graph is included in the
question, the graph updates as
you type the answer. Any
functions entered show up on
the graph, and the cursor
remains in the answer box.

You cannot manipulate the
graph.

Expression Questions

Type a response.

• If the teacher wants you to
show your work, the
response area has sections
for you to enter the steps
and a final answer.

• If the response type is
Number, your response
must be in the form of a
number.

• If the response type is
Expression, your response
must be in the form of an
expression, for example: x
+ 1.
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Coordinate Points: (x,y) Questions

Type an answer in the x-field
box, and then type an answer in
the y-field box.

As you enter values, the points
update on the graph work area.

Coordinate Points: Drop Points Questions

• Tap a location on the
graph work area to drop a
point at that location.

• To move a point, touch and
hold the point, and drag it
to the new location.

Lists Questions

Type an answer in the desired
cell. Continue to type answers
in different cells until you are
finished.

The behavior closely matches
the behavior of the Lists
& Spreadsheet application, with
the following exceptions. In a
Lists question, you cannot:

• Add, insert, or delete



columns

• Change the header row

• Enter formulas

• Switch to Table

• Create plots

Chemistry Questions

Type a response.

There is no need to insert a
Chem box. Chemistry response
areas are automatically
formatted to accept properly
formatted chemical formulas or
equations.

Image: Label Questions

1. Tap a label on the image.

2. Type a response in the
label field.
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Image: Point on Questions

Tap the option or options next
to the answer you want to
select.

Showing Your Work, Checking Answers, and Clearing Answers

Showing Your Work

The teacher may ask you to show work for your response. If so, the teacher provides
the starting equation, and the response area has sections for entering your steps and
for the final answer.

Checking Answers

If the teacher enables self-check on a question, the Check Answer option becomes



available after you answer the question. To check your answer:

▶ Tap Tools and go to Check Answer.

• If your answer is correct, a confirmation message is displayed. When you close the
message:

- A check mark is displayed next to the answer for multiple-choice questions.

- The correct answer or suggested answer is displayed below the student
response for all other question types.

• If your answer is incorrect, tap Try Again or Show Correct Answer.

Clearing Answers

After you answer a question, you may decide you want to change the answer before
you submit it.

1. Tap Tools .

2. Tap Clear Answers.

• Current Question clears answers for the active question.

• Document clears answers for all questions in the active document.

Submitting Responses

When you finish answering all the questions in the document, save the document and
send it back to the teacher.

1. From the open question document, tap Share .

2. Tap Email Document.

Your default email client opens with the document as an attachment.

3. Type the email address and tap Send.
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Widgets
All work that you create and save using TI-Nspire™ applications is stored as a
document, which you can share with others using TI-Nspire™ software and with those
using handhelds. You save these TI-Nspire™ documents as .tns files.

A Widget is a .tns document that is stored in your MyWidgets folder.

You can use Widgets to:

• Easily access text files

• Insert and run scripts (such as Stopwatch)

• Quickly insert a saved problem into a document

When you add a Widget, TI-Inspire™ CX extracts only the first page of the selected .tns
file, and inserts it into your open document.

Creating a Widget

A document is regarded as a Widget when it is saved or copied to the designated
MyWidgets folder.

If the folder has been inadvertently deleted, you must create it before attempting to
use a Widget.

Note: When you add a Widget, TI-Nspire™ App for iPad® extracts only the first page of
the selected .tns file, and inserts it into your open document.

Showing the MyWidgets folder

To show the MyWidgets folder on the TI-Nspire™ App for iPad® homepage:

1. Tap Settings Icon

2. Swipe toggle switch to the right to turn on ShowMyLib & MyWidgets folders.

Adding a Widget to a Document
1. Open a document.

2. Tap Add > Widget.
Note: You will see a submenu showing a list of preloaded layouts and widgets. The
Stopwatch Widget and Widget layouts are preloaded. Any .tns file saved to your
MyWidgets folder will show up in this list.

3. Tap on the Widget you wish to add to your document.

Saving a Widget

When you save a .tns document, it will appear on the TI-Nspire™ App for iPad®
homepage. To add this as a Widget:

▶ Tap and drag the document into your MyWidgets folder.
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Libraries Overview
A library is a TI-Nspire™ document that contains a collection of variables, functions,
and/or programs that have been defined as library objects.

What You Can Do

• Create library documents for storing user-defined variables, functions, or programs.

• Use defined library objects in any TI-Nspire™ document.

• Add library objects to the Catalog.

• Update or refresh libraries so that objects are available to all documents.

• Create shortcuts to library objects.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know
• Library documents are stored in the MyLib folder, which is located on the

TI-Nspire™ Home screen.

• By default, the MyLib folder is shown on the TI-Nspire™ Home screen when you
install the application. To hide the folder, tap Settings > Preferences, and then
select OFF.

• The TI-Nspire™ App installation includes a library document that contains Linear
Algebraic functions. The library is named linalg or linalgcas.

• If you delete or overwrite an installed library, you can restore it by reinstalling the
TI-Nspire™ App.

• Reinstalling the TI-Nspire™ App replaces all libraries in the default MyLib folder. If
you change an object in an included library or replace an included library document
with your own document of the same name, reinstalling overwrites your changes.

• Library objects are global in nature and accessible from any TI-Nspire™ document.

• Library objects can be public or private. If designated as public, the library object is
accessible via Utilities > Libraries.

• You can use the libshortcut() command to define shortcuts to library objects.
Defining a shortcut creates a variable group in the current problem that contains
references to all the objects in the specified library document. You can choose to
include or exclude private library objects.
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Creating Library Documents

A document is regarded as a library when it is placed in the MyLib folder on the
TI-Nspire™ Home screen.

1. Open a new TI-Nspire™ document and choose the Calculator application.

2. Name the document.

• Library document names must be a valid variable name, and they must not
contain a period or begin with an underscore.

• A library document name must be between 1 and 16 characters long.

3. Drag the document to the MyLib folder.

4. Add library functions or programs to the document as needed.

Adding Objects to a Library Document

You can define functions or programs in the Program Editor, or by using the Define
command in Calculator to define variables, functions, or programs. Library objects
must reside in the first problem of a library document.

Defining a Function or Program Using Program Editor

1. Tap Tools and go to Functions & Programs.

2. Tap Program Editor > New.

3. Type the name of the library object.

• Library object names must be a valid variable name, and they must not contain
a period or begin with an underscore.

• A library object name must be between 1 and 15 characters long.

4. Select the type: function or program.

5. Set the library access.

• Tap LibPriv to make the function or program accessible from any document
but not visible in the Catalog.

• Tap LibPub (Show in Catalog) to make the function or program accessible
from any document and visible in the Catalog.

6. Tap OK.

7. Type the information needed to complete the function or program in the template.

8. Store the library object.

a) In Program Editor, tap Tools > Check Syntax & Store.



b) Tap Check Syntax & Store.

If no errors are present, the new library object is successfully stored.

9. Refresh the libraries to include the new library object in the Libraries menu.

Defining a Library Object in the Calculator Application

1. From an open Calculator document, tap Tools and go to Actions.

2. Tap Library.

3. Select Define LibPriv or Define LibPub.

4. Type the information needed to complete the function or program in the template.

5. Refresh the libraries to include the new library object in the Libraries menu.

Private and Public Library Objects

When defining a new library object, you choose whether if is private (LibPriv) or public
(LibPub). Anytime you are in the same problem where an object is defined, you can
access it by entering its short name (the name given when using the Define command
to create an object). This is true for all defined objects, including private, public, and
non-library objects. For example:

Define Command Object Type Short Name

Define a=5 Non-library a
Define LibPriv b=(1,2,3) Private Library b
Define LibPub func1 (x)=x^2 + 1 Public Library func1

Private Library Objects

A Private library object does not appear in the Utilities, but you can access it by typing
its name. Typically, private library objects are used as building blocks that perform
basic, low-level tasks and are called upon by public programs or functions.

Public Library Objects

A Public library object appears in Utilities > Libraries after you refresh the libraries. You
can access a public library object through the Utilities menu or by typing its name.
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In library programs and functions defined as public, a comment line (©) immediately
following the Prgm or Func line is automatically displayed as help in the Catalog. You
could, for example, show a syntax reminder there.

▶ To enter a comment line, tap Tools and go to Actions > Insert Comment.

Accessing Library Objects

To use a library object in any TI-Nspire™ document, type the object's long name. The
long name consists of the name of the object library document followed by a backslash
"\" followed by the name of the object. For example, if the library document name is
"lib1" and the object name is "func1," type lib1\func1.

Using a Public Library Object

1. Open the TI-Nspire™ application where you want to use the variable, function, or
program.

Note: All applications can evaluate functions, but only the Calculator and Notes
applications can run programs.

2. Tap Utilities and go to Libraries.

3. Tap the name of the object you want to use.

Note: If you do not see the object, refresh the libraries.

4. If arguments are required, type them inside the parentheses.

5. Tap return to insert the object into the document.

Using a Private Library Object

1. Open the TI-Nspire™ application where you want to use the variable, function, or
program.

Note: All applications can evaluate functions, but only the Calculator and Notes
applications can run programs.

2. Type the name of the object, such as lib1\func1 ().

In the case of a function or program, always follow the name with parentheses.

3. If arguments are required, type them inside the parentheses.

4. Tap return to insert the object into the document.



Viewing Arguments

If you cannot remember the exact name or the order of arguments required for a
private library object, you can:

▶ Open the library document that contains the object to view the arguments and
other information.
—or—

▶ Type getVarInfo [library name string] in any open document to view a list defined
variables in an object.
—or—

▶ Access the arguments and help through the Utilities menu.

a) Tap Utilities > Libraries.

b) Tap the name of the library you want to open.

c) Tap the name of the function you want to view.

Refreshing Libraries

When you create new library objects, you must refresh the libraries so that the objects
are available to all documents.

1. Tap Utilities .

2. Tap Libraries.
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3. Tap Refresh .

The Libraries are updated to include all new and edited library objects.



Program Editor Overview
The Program Editor enables you to define, edit, and manage user-defined functions
and programs.

What You Can Do

• Use programming templates and dialog boxes to define function and programs
with the correct syntax.

• Enter multiple-line programming statements without using a special key sequence
to add each line.

• Create private and public library objects such as variables, functions, and programs.

Tools Search

Tools Search allows you to search options and menus. It is available across all
applications in the TI-Nspire™ App.

Warning: Tools Search will allow you to search for menu items, but not for command
names.

What You Must Know

A program defined in the Program Editor is similar to functions built into the
TI-Nspire™ software, but there are some differences:

• Functions must return a result, which can be graphed or entered in a table.
Programs do not return a result.

• You can use a function, but not a program, within an expression. For example, 3 x
func1(3) is valid, but not 3 x prog1(3).

• You can only run programs from the Calculator and Notes applications. You can
evaluate functions in Calculator, Notes, Lists & Spreadsheet, Graphs, Geometry,
and Data & Statistics.

• A function can refer to any variable; however, it can store a value to a local variable
only. Programs can store to local and global variables.

Note: Arguments used to pass values to a function are automatically treated as
local variables. If you want to store to any other variables, you must define them as
Local from within the function.

• A function cannot call a program as a subroutine, but it can call another user-
defined function.

• You cannot define a program within a function.

• A function cannot define a global function, but it can define a local function.
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Accessing the Program Editor

Program Editor is accessible from the Calculator application.

1. Open a document with the Calculator application active.

2. Tap Tools and go to Functions and Programs.

3. Tap Program Editor.

Options enable you to define a new program, open an existing program, or import
a program from the Library.

4. Tap an option, complete the required information, and then tap OK.

The Program Editor opens with the selected template active on the right side of
the screen.

Calculator work area. Tap the left side of the screen to return to and work
in the Calculator application.



Program Editor work area. This is the default work area when Program
Editor opens. If the Program Editor is not active, tap the right side of the
screen.

Status line. Shows the line number information and the name of the
function or program being defined or edited. An asterisk (*) indicates that
this function has been changed since the last time syntax was checked and
the function was stored.

Defining a New Program or Function

From the Calculator application:

1. Tap Tools and go to Functions & Programs.

2. Tap Program Editor, and then tap New.

3. Type a name for the new function or program.

Note: Program and function names cannot contain spaces.

4. Select the Type (Program or Function).

5. Set the Library Access:

• Choose the default None to use the function or program only in the current
document or problem.

• Tap LibPriv to make the function or program accessible from any document
but not visible in the Catalog.

• Tap LibPub (Show in Catalog) to make the function or program accessible
from any document and visible in the Catalog.

6. Tap OK.

The Program Editor opens with a template matching the selections you made.

Program Editor Overview 162



163 Program Editor Overview

Entering Lines into a Function or Program

The Program Editor does not execute the commands or evaluate expressions as you
type them. They are executed only when you evaluate the function or run the program.

• When arguments are required, type parameters in the parentheses that follow the
program name. Separate parameters with a comma.

• Type the lines of statements that make up your function or program between the
Func and EndFunc (or Prgm or EndPrgm) lines.

• You can either type the names of the function and commands, or insert them from
the Catalog.

• If a line is longer than the width of the screen, scroll to view the entire statement.

• After typing each line, tap return to insert a new blank line.

• Tap the right, left, up, and down arrows to scroll through the function or program.

Checking Syntax

To check the function or program for correct syntax:

1. Make sure the Program Editor is active.

2. Tap Tools and go to Check Syntax and Store.

3. Tap Check Syntax.



If the syntax checker finds any errors, it displays an error message and positions
the cursor near the first error.

Storing a Function or Program

You must store a function or program to make it accessible. The Program Editor
automatically checks the syntax before storing. An asterisk (*) before the program or
function name indicates that it has not been stored. To store a function or program:

1. From the Program Editor, tap Tools and go to Check Syntax and Store.

2. Tap Check Syntax & Store.

Program Editor checks for syntax errors and stores the program.

• If no syntax errors are found, the message "stored successfully" is displayed in
the status line after the program or function name.

• If syntax errors are found, an error message is displayed and the cursor is
positioned near the first error.

• If the function or program is defined as a library object, you must also save the
document in the designated library folder and refresh libraries to make the
function or program accessible to other documents.
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Running Programs and Evaluating Functions

After defining and storing a program or function, you can use it from an application. All
the applications can evaluate functions, but only the Calculator and Notes applications
can run programs.

The program statements are executed in sequential order (although some commands
alter the program flow). The output, if any, is displayed in the application’s work area.

• Program execution continues until it reaches the last statement or a Stop
command.

• Function execution continues until it reaches a Return command.

Running a Program or Function from the Program Editor

1. Make sure you have defined a program or function and the Program Editor is the
active work area.

2. Tap Tools and select Check Syntax & Store > Run.

This will automatically:

• check the syntax and store the program or function,
• paste the program or function name on the first available line of the Calculator

page.



3. If the program or function requires you to supply one or more arguments, type the
values or variable names inside the parentheses.

4. Tap [ENTER].

Note: You can also run a program or function in Calculator or Notes applications by
typing the name of the program with parentheses and any required arguments and
tapping [ENTER].

Opening Functions or Programs for Editing

Note: You cannot modify a locked program or function. To unlock the object, go to a
Calculator page and use the Unlock command.

Opening a Function or Program in Calculator

1. Tap Tools and go to Functions & Programs.

2. Tap Program Editor, and then tap Open.

The list of defined functions and programs available to the current problem opens.

3. Tap the function or program name to open it in Program Editor.
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Opening a Function or Program in Program Editor

1. Tap Tools and go to Actions.

2. Tap Open.

3. Tap the function or program name to open it in Program Editor.

Note: To close the function or program, tap Tools > Actions > Close. The program or
function closes and the Calculator page becomes active.

Importing Programs

You can import a function or program defined as a library object into a Program Editor
within the current problem. The imported copy is not locked, even if the original is
locked.

Importing a Program from a Library

1. From the Program Editor, tap Tools and go to Actions.

2. Tap Import.

3. In the Library field, tap , and then tap the library name you want to import.

4. In the Name field, tap , and then select the name of the object.

5. If you want the imported object to have a different name, type the name in the
Import As field.

6. Tap OK.

Importing a Program from Calculator

1. Tap Tools and go to Functions & Programs.

2. Tap Program Editor, and then tap Import.

3. In the Library field, tap , and then tap the library name you want to import.

4. In the Name field, tap , and then select the name of the object.



5. If you want the imported object to have a different name, type the name in the
Import As field.

6. Tap OK.

The program opens in Program Editor.

Using Sensor Data in Programs

You can access sensor data from all connected sensor probes through your TI-Basic
program by using this command:

RefreshProbeVars statusVar
• You must first launch the Vernier DataQuest™ application, or you will receive an

error.

Note: The Vernier DataQuest™ application will auto-launch when you connect a
sensor or a lab cradle to the TI-Nspire™ software or handheld.

• The RefreshProbeVars command will be valid only when Vernier DataQuest™ is in

'meter' mode.
• statusVar is an optional parameter that indicates the status of the command.

These are the statusVar values:

StatusVar
Value

Status

statusVar
=0

Normal (continue with the program)

statusVar
=1

The Vernier DataQuest™ application is in data collection mode.
Note: The Vernier DataQuest™ application must be in meter mode for

this command to work.

statusVar
=2

The Vernier DataQuest™ application is not launched.

statusVar
=3

The Vernier DataQuest™ application is launched, but you have not
connected any probes.
Note: The RefreshProbeVars command will almost always return
statusVar=3 in the iOS, even if you have already launched the Vernier
DataQuest™ application

• Your TI-Basic program will read directly from Vernier DataQuest™ variables in the
symbol table.

• The meter.time variable shows the last value of the variable; it does not update
automatically. If no data collection has occurred, meter.time will be 0 (zero).

Program Editor Overview 168



169 Program Editor Overview

• Use of variable names without corresponding probes being physically attached will
result in a "Variable not defined" error.

• The RefreshProbeVars command will be a NOP (null command) on iOS.

Collecting Sensor Data using RefreshProbeVars
1. Launch the Vernier DataQuest™ application.

2. Connect the sensor(s) you need to collect the data.

3. Run the program you wish to use to collect data in the calculator application.

4. Manipulate the sensors and collect the data.

Note: You may create a program to interact with the TI-Innovator Hub usingb> Hub
> Send. (See Example 2, below.) This is optional.

Example 1

Define temp()=
Prgm
© Check if system is ready
RefreshProbeVars status
If status=0 Then
Disp "ready"
For n,1,50
RefreshProbeVars status
temperature:=meter.temperature
Disp "Temperature: ",temperature
If temperature>30 Then
Disp "Too hot"
EndIf
© Wait for 1 second between samples
Wait 1
EndFor
Else
Disp "Not ready. Try again later"
EndIf
EndPrgm

Example 2- with TI-Innovator™ Hub

Define tempwithhub()=
Prgm
© Check if system is ready
RefreshProbeVars status
If status=0 Then
Disp "ready"
For n,1,50
RefreshProbeVars status
temperature:=meter.temperature
Disp "Temperature: ",temperature
If temperature>30 Then
Disp "Too hot"
© Play a tone on the Hub
Send "SET SOUND 440 TIME 2"
EndIf



© Wait for 1 second between samples
Wait 1
EndFor
Else
Disp "Not ready. Try again later"
EndIf
EndPrgm
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General Information

Texas Instruments Support and Service

General Information: North and South America

Home Page: education.ti.com

KnowledgeBase and e-mail inquiries: education.ti.com/support

Phone: (800) TI-CARES / (800) 842-2737
For North and South America and U.S.
Territories

International contact information: education.ti.com/support/worldwide

For Technical Support

Knowledge Base and support by e-mail: education.ti.com/support or
ti-cares@ti.com

Phone (not toll-free): (972) 917-8324

For Product (Hardware) Service

Customers in the U.S., Canada, Mexico, and U.S. territories: Always contact Texas
Instruments Customer Support before returning a product for service.

For All Other Countries:

For general information

For more information about TI products and services, contact TI by e-mail or visit the
TI Internet address.

E-mail inquiries: ti-cares@ti.com

Home Page: education.ti.com

Service and Warranty Information

For information about the length and terms of the warranty or about product service,
refer to the warranty statement enclosed with this product or contact your local Texas
Instruments retailer/distributor.
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Expression Templates
Expression templates give you an easy way to enter math expressions in standard
mathematical notation. When you insert a template, it appears on the entry line with
small blocks at positions where you can enter elements. A cursor shows which element
you can enter.

Position the cursor on each element, and type a value or expression for the element.

Fraction template /p keys

Note: See also / (divide), page 212.

Example:

Exponent template l key

Note: Type the first value, pressl, and
then type the exponent. To return the cursor
to the baseline, press right arrow (¢).

Note: See also ^ (power), page 213.

Example:

Square root template /q keys

Note: See also √() (square root), page
223.

Example:

Nth root template /l keys

Note: See also root(), page 154.

Example:
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Nth root template /l keys

e exponent template u keys

Natural exponential e raised to a power

Note: See also e^(), page 57.

Example:

Log template /s key

Calculates log to a specified base. For a
default of base 10, omit the base.

Note: See also log(), page 107.

Example:

Piecewise template (2-piece) Catalog >

Lets you create expressions and conditions
for a two-piece piecewise function. To add
a piece, click in the template and repeat the
template.

Note: See also piecewise(), page 133.

Example:



Piecewise template (N-piece) Catalog >
Lets you create expressions and conditions
for an N-piece piecewise function. Prompts
for N.

Note: See also piecewise(), page 133.

Example:

See the example for Piecewise template (2-
piece).

System of 2 equations template Catalog >

Creates a system of two equations. To add
a row to an existing system, click in the
template and repeat the template.

Note: See also system(), page 182.

Example:

System of N equations template Catalog >
Lets you create a system of N equations.
Prompts for N.

Note: See also system(), page 182.

Example:

See the example for Systemof equations
template (2-equation).

Absolute value template Catalog >

Note: See also abs(), page 8.
Example:
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Absolute value template Catalog >

dd°mm’ss.ss’’ template Catalog >

Lets you enter angles in dd°mm’ss.ss’’
format, where dd is the number of decimal
degrees, mm is the number of minutes, and
ss.ss is the number of seconds.

Example:

Matrix template (2 x 2) Catalog >

Creates a 2 x 2 matrix.

Example:

Matrix template (1 x 2) Catalog >

.
Example:

Matrix template (2 x 1) Catalog >
Example:

Matrix template (m x n) Catalog >
The template appears after you are
prompted to specify the number of rows
and columns.

Example:



Matrix template (m x n) Catalog >

Note: If you create a matrix with a large
number of rows and columns, it may take a
few moments to appear.

Sum template (Σ) Catalog >

Note: See also Σ() (sumSeq), page 224.

Example:

Product template (Π) Catalog >

Note: See alsoΠ() (prodSeq), page 223.

Example:

First derivative template Catalog >

The first derivative template can also be
used to calculate first derivative at a point.

Note: See also d() (derivative), page 221.

Example:
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Second derivative template Catalog >

The second derivative template can also be
used to calculate second derivative at a
point.

Note: See also d() (derivative), page 221.

Example:

Nth derivative template Catalog >

The nth derivative template can be used to
calculate the nth derivative.

Note: See also d() (derivative), page 221.

Example:

Definite integral template Catalog >

Note: See also∫() integral(), page 221.

Example:

Indefinite integral template Catalog >

Note: See also ∫() integral(), page 221.

Example:

Limit template Catalog >
Example:



Limit template Catalog >
Use − or (−) for left hand limit. Use + for
right hand limit.

Note: See also limit(), page 6.
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Alphabetical Listing
Items whose names are not alphabetic (such as +, !, and >) are listed at the end of this
section, page 210. Unless otherwise specified, all examples in this section were
performed in the default reset mode, and all variables are assumed to be undefined.

A

abs() Catalog >
abs(Expr1) ⇒ expression

abs(List1) ⇒ list
abs(Matrix1) ⇒ matrix

Returns the absolute value of the
argument.

Note: See also Absolute value template,
page 3.

If the argument is a complex number,
returns the number’s modulus.

Note: All undefined variables are treated as
real variables.

amortTbl() Catalog >
amortTbl(NPmt,N,I,PV, [Pmt], [FV],
[PpY], [CpY], [PmtAt], [roundValue]) ⇒
matrix

Amortization function that returns a matrix
as an amortization table for a set of TVM
arguments.

NPmt is the number of payments to be
included in the table. The table starts with
the first payment.

N, I, PV, Pmt, FV, PpY, CpY, and PmtAt
are described in the table of TVM
arguments, page 195.

• If you omit Pmt, it defaults to
Pmt=tvmPmt
(N,I,PV,FV,PpY,CpY,PmtAt).

• If you omit FV, it defaults to FV=0.
• The defaults for PpY, CpY, and PmtAt

are the same as for the TVM functions.



amortTbl() Catalog >
roundValue specifies the number of
decimal places for rounding. Default=2.

The columns in the result matrix are in this
order: Payment number, amount paid to
interest, amount paid to principal, and
balance.

The balance displayed in row n is the
balance after payment n.

You can use the output matrix as input for
the other amortization functions ΣInt() and
ΣPrn(), page 225, and bal(), page 17.

and Catalog >
BooleanExpr1 and BooleanExpr2 ⇒
Boolean expression

BooleanList1 and BooleanList2 ⇒
Boolean list

BooleanMatrix1 and BooleanMatrix2 ⇒
Boolean matrix

Returns true or false or a simplified form of
the original entry.

Integer1 andInteger2 ⇒ integer

Compares two real integers bit-by-bit using
an and operation. Internally, both integers
are converted to signed, 64-bit binary
numbers. When corresponding bits are
compared, the result is 1 if both bits are 1;
otherwise, the result is 0. The returned
value represents the bit results, and is
displayed according to the Base mode.

You can enter the integers in any number
base. For a binary or hexadecimal entry, you
must use the 0b or 0h prefix, respectively.
Without a prefix, integers are treated as
decimal (base 10).

InHex basemode:

Important: Zero, not the letter O.

In Bin basemode:

InDec basemode:

Note: A binary entry canhave up to 64 digits
(not counting the 0bprefix). A hexadecimal
entry canhave up to 16 digits.
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angle() Catalog >
angle(Expr1) ⇒ expression

Returns the angle of the argument,
interpreting the argument as a complex
number.

Note: All undefined variables are treated as
real variables.

InDegree anglemode:

InGradian anglemode:

In Radian anglemode:

angle(List1) ⇒ list
angle(Matrix1) ⇒ matrix

Returns a list or matrix of angles of the
elements in List1 orMatrix1, interpreting
each element as a complex number that
represents a two-dimensional rectangular
coordinate point.

ANOVA Catalog >
ANOVA List1,List2[,List3,...,List20][,Flag]

Performs a one-way analysis of variance for
comparing the means of two to 20
populations. A summary of results is stored
in the stat.results variable. (page 177)

Flag=0 for Data, Flag=1 for Stats

Output variable Description

stat.F Value of the F statistic

stat.PVal Smallest level of significance atwhich the null hypothesis canbe rejected

stat.df Degrees of freedomof the groups

stat.SS Sumof squares of the groups

stat.MS Mean squares for the groups



Output variable Description

stat.dfError Degrees of freedomof the errors

stat.SSError Sumof squares of the errors

stat.MSError Mean square for the errors

stat.sp Pooled standarddeviation

stat.xbarlist Meanof the input of the lists

stat.CLowerList 95%confidence intervals for themeanof each input list

stat.CUpperList 95%confidence intervals for themeanof each input list

ANOVA2way Catalog >
ANOVA2way List1,List2[,List3,…,List10]
[,levRow]

Computes a two-way analysis of variance for
comparing the means of two to 10
populations. A summary of results is stored
in the stat.results variable. (See page 177.)

LevRow=0 for Block

LevRow=2,3,...,Len-1, for Two Factor,
where Len=length(List1)=length(List2) = …
= length(List10) and Len / LevRow Î 
{2,3,…}

Outputs: Block Design

Output variable Description

stat.F F statistic of the column factor

stat.PVal Smallest level of significance atwhich the null hypothesis canbe rejected

stat.df Degrees of freedomof the column factor

stat.SS Sumof squares of the column factor

stat.MS Mean squares for column factor

stat.FBlock F statistic for factor

stat.PValBlock Least probability atwhich the null hypothesis canbe rejected

stat.dfBlock Degrees of freedom for factor

stat.SSBlock Sumof squares for factor
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Output variable Description

stat.MSBlock Mean squares for factor

stat.dfError Degrees of freedomof the errors

stat.SSError Sumof squares of the errors

stat.MSError Mean squares for the errors

stat.s Standarddeviationof the error

COLUMN FACTOR Outputs

Output variable Description

stat.Fcol F statistic of the column factor

stat.PValCol Probability value of the column factor

stat.dfCol Degrees of freedomof the column factor

stat.SSCol Sumof squares of the column factor

stat.MSCol Mean squares for column factor

ROW FACTOR Outputs

Output variable Description

stat.FRow F statistic of the row factor

stat.PValRow Probability value of the row factor

stat.dfRow Degrees of freedomof the row factor

stat.SSRow Sumof squares of the row factor

stat.MSRow Mean squares for row factor

INTERACTION Outputs

Output variable Description

stat.FInteract F statistic of the interaction

stat.PValInteract Probability value of the interaction

stat.dfInteract Degrees of freedomof the interaction

stat.SSInteract Sumof squares of the interaction

stat.MSInteract Mean squares for interaction

ERROR Outputs



Output variable Description

stat.dfError Degrees of freedomof the errors

stat.SSError Sumof squares of the errors

stat.MSError Mean squares for the errors

s Standarddeviationof the error

Ans /v keys
Ans ⇒ value

Returns the result of the most recently
evaluated expression.

approx() Catalog >
approx(Expr1) ⇒ expression

Returns the evaluation of the argument as
an expression containing decimal values,
when possible, regardless of the current
Auto or Approximate mode.

This is equivalent to entering the argument
and pressing/·.

approx(List1) ⇒ list
approx(Matrix1) ⇒ matrix

Returns a list or matrix where each
element has been evaluated to a decimal
value, when possible.

►approxFraction() Catalog >
Expr►approxFraction([Tol]) ⇒
expression

List►approxFraction([Tol]) ⇒ list

Matrix►approxFraction([Tol]) ⇒ matrix

Returns the input as a fraction, using a
tolerance of Tol. If Tol is omitted, a
tolerance of 5.E-14 is used.
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►approxFraction() Catalog >
Note: You can insert this function from the
computer keyboard by typing
@>approxFraction(...).

approxRational() Catalog >
approxRational(Expr[, Tol]) ⇒ expression

approxRational(List[, Tol]) ⇒ list

approxRational(Matrix[, Tol]) ⇒ matrix

Returns the argument as a fraction using a
tolerance of Tol. If Tol is omitted, a
tolerance of 5.E-14 is used.

arccos() See cos⁻¹(), page 31.

arccosh() See cosh⁻¹(), page 32.

arccot() See cot⁻¹(), page 33.

arccoth() See coth⁻¹(), page 34.

arccsc() See csc⁻¹(), page 37.

arccsch() See csch⁻¹(), page 37.



arcLen() Catalog >
arcLen(Expr1,Var,Start,End) ⇒
expression

Returns the arc length of Expr1 from
Start to End with respect to variable Var.

Arc length is calculated as an integral
assuming a function mode definition.

arcLen(List1,Var,Start,End) ⇒ list

Returns a list of the arc lengths of each
element of List1 from Start to End with
respect to Var.

arcsec() See sec⁻¹(), page 158.

arcsech() See sech⁻¹(), page 158.

arcsin() See sin⁻¹(), page 168.

arcsinh() See sinh⁻¹(), page 169.

arctan() See tan⁻¹(), page 183.

arctanh() See tanh⁻¹(), page 185.

augment() Catalog >
augment(List1, List2) ⇒ list
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augment() Catalog >
Returns a new list that is List2 appended to
the end of List1.
augment(Matrix1,Matrix2) ⇒ matrix

Returns a new matrix that is Matrix2
appended toMatrix1. When the “,”
character is used, the matrices must have
equal row dimensions, andMatrix2 is
appended toMatrix1 as new columns.
Does not alterMatrix1 orMatrix2.

avgRC() Catalog >
avgRC(Expr1, Var [=Value] [, Step]) ⇒
expression

avgRC(Expr1, Var [=Value] [, List1]) ⇒
list

avgRC(List1, Var [=Value] [, Step]) ⇒
list

avgRC(Matrix1, Var [=Value] [, Step]) ⇒
matrix

Returns the forward-difference quotient
(average rate of change).

Expr1 can be a user-defined function name
(see Func).

When Value is specified, it overrides any
prior variable assignment or any current “|”
substitution for the variable.

Step is the step value. If Step is omitted, it
defaults to 0.001.

Note that the similar function centralDiff()
uses the central-difference quotient.



B

bal() Catalog >
bal(NPmt,N,I,PV ,[Pmt], [FV], [PpY],
[CpY], [PmtAt], [roundValue]) ⇒ value

bal(NPmt,amortTable) ⇒ value

Amortization function that calculates
schedule balance after a specified payment.

N, I, PV, Pmt, FV, PpY, CpY, and PmtAt
are described in the table of TVM
arguments, page 195.

NPmt specifies the payment number after
which you want the data calculated.

N, I, PV, Pmt, FV, PpY, CpY, and PmtAt
are described in the table of TVM
arguments, page 195.

• If you omit Pmt, it defaults to
Pmt=tvmPmt
(N,I,PV,FV,PpY,CpY,PmtAt).

• If you omit FV, it defaults to FV=0.
• The defaults for PpY, CpY, and PmtAt

are the same as for the TVM functions.

roundValue specifies the number of
decimal places for rounding. Default=2.

bal(NPmt,amortTable) calculates the
balance after payment number NPmt,
based on amortization table amortTable.
The amortTable argument must be a
matrix in the form described under
amortTbl(), page 8.

Note: See also ΣInt() and ΣPrn(), page 225.

►Base2 Catalog >
Integer1►Base2⇒ integer

Note: You can insert this operator from the
computer keyboard by typing @>Base2.
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►Base2 Catalog >
Converts Integer1 to a binary number.
Binary or hexadecimal numbers always
have a 0b or 0h prefix, respectively. Use a
zero, not the letter O, followed by b or h.

0b binaryNumber
0h hexadecimalNumber
A binary number can have up to 64 digits. A
hexadecimal number can have up to 16.

Without a prefix, Integer1 is treated as
decimal (base 10). The result is displayed in
binary, regardless of the Base mode.

Negative numbers are displayed in “two's
complement” form. For example,

⁻1 is displayed as
0hFFFFFFFFFFFFFFFF  in Hex base mode
0b111...111 (64  1’s)  in Binary base mode

⁻263 is displayed as
0h8000000000000000  in Hex base mode
0b100...000 (63 zeros)  in Binary base mode

If you enter a decimal integer that is
outside the range of a signed, 64-bit binary
form, a symmetric modulo operation is
used to bring the value into the appropriate
range. Consider the following examples of
values outside the range.

263 becomes ⁻263 and is displayed as
0h8000000000000000  in Hex base mode
0b100...000 (63 zeros)  in Binary base mode

264 becomes 0 and is displayed as
0h0  in Hex base mode
0b0  in Binary base mode

⁻263− 1 becomes 263 − 1 and is displayed
as
0h7FFFFFFFFFFFFFFF  in Hex base mode
0b111...111 (64  1’s)  in Binary base mode

►Base10 Catalog >
Integer1►Base10⇒ integer



►Base10 Catalog >
Note: You can insert this operator from the
computer keyboard by typing @>Base10.

Converts Integer1 to a decimal (base 10)
number. A binary or hexadecimal entry
must always have a 0b or 0h prefix,
respectively.

0b binaryNumber
0h hexadecimalNumber

Zero, not the letter O, followed by b or h.

A binary number can have up to 64 digits. A
hexadecimal number can have up to 16.

Without a prefix, Integer1 is treated as
decimal. The result is displayed in decimal,
regardless of the Base mode.

►Base16 Catalog >
Integer1►Base16⇒ integer

Note: You can insert this operator from the
computer keyboard by typing @>Base16.

Converts Integer1 to a hexadecimal
number. Binary or hexadecimal numbers
always have a 0b or 0h prefix, respectively.

0b binaryNumber
0h hexadecimalNumber

Zero, not the letter O, followed by b or h.

A binary number can have up to 64 digits. A
hexadecimal number can have up to 16.

Without a prefix, Integer1 is treated as
decimal (base 10). The result is displayed in
hexadecimal, regardless of the Base mode.

If you enter a decimal integer that is too
large for a signed, 64-bit binary form, a
symmetric modulo operation is used to
bring the value into the appropriate range.
For more information, see►Base2, page
17.
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binomCdf() Catalog >
binomCdf(n,p) ⇒ list

binomCdf(n,p,lowBound,upBound) ⇒
number if lowBound and upBound are
numbers, list if lowBound and upBound are
lists

binomCdf(n,p,upBound)for P(0≤X≤upBound)
⇒ number if upBound is a number, list if
upBound is a list

Computes a cumulative probability for the
discrete binomial distribution with n number
of trials and probability p of success on each
trial.

For P(X ≤ upBound), set lowBound=0

binomPdf() Catalog >
binomPdf(n,p) ⇒ list

binomPdf(n,p,XVal) ⇒ number if XVal is a
number, list if XVal is a list

Computes a probability for the discrete
binomial distribution with n number of trials
and probability p of success on each trial.

C

Catalog >
ceiling(Expr1) ⇒ integer

Returns the nearest integer that is ≥ the
argument.

The argument can be a real or a complex
number.

Note: See also floor().

ceiling(List1) ⇒ list
ceiling(Matrix1) ⇒ matrix

Returns a list or matrix of the ceiling of
each element.



centralDiff() Catalog >
centralDiff(Expr1,Var [=Value][,Step]) ⇒
expression

centralDiff(Expr1,Var [,Step])|Var=Value
⇒ expression

centralDiff(Expr1,Var [=Value][,List]) ⇒
list

centralDiff(List1,Var [=Value][,Step]) ⇒
list

centralDiff(Matrix1,Var [=Value][,Step])
⇒ matrix

Returns the numerical derivative using the
central difference quotient formula.

When Value is specified, it overrides any
prior variable assignment or any current “|”
substitution for the variable.

Step is the step value. If Step is omitted, it
defaults to 0.001.

When using List1 orMatrix1, the operation
gets mapped across the values in the list or
across the matrix elements.

Note: See also avgRC() and d().

cFactor() Catalog >
cFactor(Expr1[,Var]) ⇒ expression
cFactor(List1[,Var]) ⇒ list
cFactor(Matrix1[,Var]) ⇒ matrix

cFactor(Expr1) returns Expr1 factored with
respect to all of its variables over a
common denominator.

Expr1 is factored as much as possible
toward linear rational factors even if this
introduces new non-real numbers. This
alternative is appropriate if you want
factorization with respect to more than one
variable.
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cFactor() Catalog >
cFactor(Expr1,Var) returns Expr1 factored
with respect to variable Var.

Expr1 is factored as much as possible
toward factors that are linear in Var, with
perhaps non-real constants, even if it
introduces irrational constants or
subexpressions that are irrational in other
variables.

The factors and their terms are sorted with
Var as the main variable. Similar powers of
Var are collected in each factor. Include
Var if factorization is needed with respect
to only that variable and you are willing to
accept irrational expressions in any other
variables to increase factorization with
respect to Var. There might be some
incidental factoring with respect to other
variables.

For the Auto setting of the Auto or
Approximate mode, including Var also
permits approximation with floating-point
coefficients where irrational coefficients
cannot be explicitly expressed concisely in
terms of the built-in functions. Even when
there is only one variable, including Var
might yield more complete factorization.

Note: See also factor().

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

char() Catalog >
char(Integer) ⇒ character

Returns a character string containing the
character numbered Integer from the
handheld character set. The valid range for
Integer is 0–65535.



charPoly() Catalog >
charPoly(squareMatrix,Var) ⇒
polynomial expression

charPoly(squareMatrix,Expr) ⇒
polynomial expression

charPoly(squareMatrix1,Matrix2) ⇒
polynomial expression

Returns the characteristic polynomial of
squareMatrix. The characteristic
polynomial of n×nmatrix A, denoted by pA(λ), is the polynomial defined by

pA(λ) = det(λ•I−A)

where I denotes the n×n identity matrix.

squareMatrix1 and squareMatrix2must
have the equal dimensions.

χ22way Catalog >
χ22way obsMatrix

chi22way obsMatrix

Computes a χ2 test for association on the
two-way table of counts in the observed
matrix obsMatrix. A summary of results is
stored in the stat.results variable. (page
177)

For information on the effect of empty
elements in a matrix, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.χ2 Chi square stat: sum (observed - expected)2/expected

stat.PVal Smallest level of significance atwhich the null hypothesis canbe rejected

stat.df Degrees of freedom for the chi square statistics

stat.ExpMat Matrix of expectedelemental count table, assuming null hypothesis

stat.CompMat Matrix of elemental chi square statistic contributions

Alphabetical Listing 23



24 Alphabetical Listing

χ2Cdf() Catalog >
χ2Cdf(lowBound,upBound,df) ⇒ number if
lowBound and upBound are numbers, list if
lowBound and upBound are lists

chi2Cdf(lowBound,upBound,df) ⇒ number
if lowBound and upBound are numbers, list
if lowBound and upBound are lists

Computes the χ2 distribution probability
between lowBound and upBound for the
specified degrees of freedom df.

For P(X ≤ upBound), set lowBound = 0.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

χ2GOF Catalog >
χ2GOF obsList,expList,df

chi2GOF obsList,expList,df

Performs a test to confirm that sample data
is from a population that conforms to a
specified distribution. obsList is a list of
counts and must contain integers. A
summary of results is stored in the
stat.results variable. (See page 177.)

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.χ2 Chi square stat: sum((observed - expected)2/expected

stat.PVal Smallest level of significance atwhich the null hypothesis canbe rejected

stat.df Degrees of freedom for the chi square statistics

stat.CompList Elemental chi square statistic contributions

χ2Pdf() Catalog >
χ2Pdf(XVal,df) ⇒ number if XVal is a
number, list if XVal is a list



χ2Pdf() Catalog >
chi2Pdf(XVal,df) ⇒ number if XVal is a
number, list if XVal is a list

Computes the probability density function
(pdf) for the χ2 distribution at a specified
XVal value for the specified degrees of
freedom df.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

ClearAZ Catalog >
ClearAZ

Clears all single-character variables in the
current problem space.

If one or more of the variables are locked,
this command displays an error message
and deletes only the unlocked variables. See
unLock, page 197.

ClrErr Catalog >
ClrErr

Clears the error status and sets system
variable errCode to zero.

The Else clause of the Try...Else...EndTry
block should use ClrErr or PassErr. If the
error is to be processed or ignored, use
ClrErr. If what to do with the error is not
known, use PassErr to send it to the next
error handler. If there are no more pending
Try...Else...EndTry error handlers, the error
dialog box will be displayed as normal.

Note: See also PassErr, page 132, and Try,
page 191.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product guidebook.

For anexample of ClrErr, See Example 2
under the Try command, page 191.
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colAugment() Catalog >
colAugment(Matrix1,Matrix2) ⇒ matrix

Returns a new matrix that is Matrix2
appended toMatrix1. The matrices must
have equal column dimensions, and
Matrix2 is appended toMatrix1 as new
rows. Does not alterMatrix1 orMatrix2.

colDim() Catalog >
colDim(Matrix) ⇒ expression

Returns the number of columns contained
inMatrix.

Note: See also rowDim().

colNorm() Catalog >
colNorm(Matrix) ⇒ expression

Returns the maximum of the sums of the
absolute values of the elements in the
columns inMatrix.

Note: Undefined matrix elements are not
allowed. See also rowNorm().

comDenom() Catalog >
comDenom(Expr1[,Var]) ⇒ expression
comDenom(List1[,Var]) ⇒ list
comDenom(Matrix1[,Var]) ⇒ matrix

comDenom(Expr1) returns a reduced ratio
of a fully expanded numerator over a fully
expanded denominator.



comDenom() Catalog >
comDenom(Expr1,Var) returns a reduced
ratio of numerator and denominator
expanded with respect to Var. The terms
and their factors are sorted with Var as the
main variable. Similar powers of Var are
collected. There might be some incidental
factoring of the collected coefficients.
Compared to omitting Var, this often saves
time, memory, and screen space, while
making the expression more
comprehensible. It also makes subsequent
operations on the result faster and less
likely to exhaust memory.

If Var does not occur in Expr1, comDenom
(Expr1,Var) returns a reduced ratio of an
unexpanded numerator over an unexpanded
denominator. Such results usually save even
more time, memory, and screen space.
Such partially factored results also make
subsequent operations on the result much
faster and much less likely to exhaust
memory.

Even when there is no denominator, the
comden function is often a fast way to
achieve partial factorization if factor() is
too slow or if it exhausts memory.

Hint: Enter this comden() function definition
and routinely try it as an alternative to
comDenom() and factor().

completeSquare () Catalog >
completeSquare(ExprOrEqn, Var) ⇒
expression or equation

completeSquare(ExprOrEqn, Var^Power)
⇒ expression or equation

completeSquare(ExprOrEqn, Var1, Var2
[,...]) ⇒ expression or equation

completeSquare(ExprOrEqn, {Var1, Var2
[,...]}) ⇒ expression or equation

Converts a quadratic polynomial expression
of the form a•x2+b•x+c into the form a•(x-h)
2+k
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completeSquare () Catalog >
- or -

Converts a quadratic equation of the form
a•x2+b•x+c=d into the form a•(x-h)2=k

The first argument must be a quadratic
expression or equation in standard form
with respect to the second argument.

The Second argument must be a single
univariate term or a single univariate term
raised to a rational power, for example
x, y2, or z(1/3).

The third and fourth syntax attempt to
complete the square with respect to
variables Var1, Var2 [,… ]).

conj() Catalog >
conj(Expr1) ⇒ expression

conj(List1) ⇒ list

conj(Matrix1) ⇒ matrix

Returns the complex conjugate of the
argument.

Note: All undefined variables are treated as
real variables.

constructMat() Catalog >
constructMat
(Expr,Var1,Var2,numRows,numCols) ⇒
matrix

Returns a matrix based on the arguments.

Expr is an expression in variables Var1 and
Var2. Elements in the resulting matrix are
formed by evaluating Expr for each
incremented value of Var1 and Var2.

Var1 is automatically incremented from 1
through numRows. Within each row, Var2
is incremented from 1 through numCols.



CopyVar Catalog >
CopyVar Var1, Var2

CopyVar Var1., Var2.

CopyVar Var1, Var2 copies the value of
variable Var1 to variable Var2, creating
Var2 if necessary. Variable Var1must have
a value.

If Var1 is the name of an existing user-
defined function, copies the definition of
that function to function Var2. Function
Var1must be defined.

Var1must meet the variable-naming
requirements or must be an indirection
expression that simplifies to a variable
name meeting the requirements.

CopyVar Var1., Var2. copies all members
of the Var1. variable group to the Var2.
group, creating Var2. if necessary.

Var1. must be the name of an existing
variable group, such as the statistics stat.nn
results, or variables created using the
LibShortcut() function. If Var2. already
exists, this command replaces all members
that are common to both groups and adds
the members that do not already exist. If
one or more members of Var2. are locked,
all members of Var2. are left unchanged.

corrMat() Catalog >
corrMat(List1,List2[,…[,List20]])

Computes the correlation matrix for the
augmented matrix [List1, List2, ..., List20].

►cos Catalog >
Expr►cos

Note: You can insert this operator from the
computer keyboard by typing @>cos.

Represents Expr in terms of cosine. This is
a display conversion operator. It can be
used only at the end of the entry line.
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►cos Catalog >
►cos reduces all powers of
    sin(...) modulo 1−cos(...)^2
so that any remaining powers of cos(...)
have exponents in the range (0, 2). Thus,
the result will be free of sin(...) if and only
if sin(...) occurs in the given expression only
to even powers.

Note: This conversion operator is not
supported in Degree or Gradian Angle
modes. Before using it, make sure that the
Angle mode is set to Radians and that Expr
does not contain explicit references to
degree or gradian angles.

cos() µ key
cos(Expr1) ⇒ expression

cos(List1) ⇒ list

cos(Expr1) returns the cosine of the
argument as an expression.

cos(List1) returns a list of the cosines of all
elements in List1.

Note: The argument is interpreted as a
degree, gradian or radian angle, according
to the current angle mode setting. You can
use °, G, or r to override the angle mode
temporarily.

InDegree anglemode:

InGradian anglemode:

In Radian anglemode:

cos(squareMatrix1) ⇒ squareMatrix

Returns the matrix cosine of
squareMatrix1. This is not the same as
calculating the cosine of each element.

In Radian anglemode:



cos() µ key
When a scalar function f(A) operates on
squareMatrix1 (A), the result is calculated
by the algorithm:

Compute the eigenvalues (λ
i
) and

eigenvectors (Vi) of A.

squareMatrix1must be diagonalizable.
Also, it cannot have symbolic variables that
have not been assigned a value.

Form the matrices:

Then A = X B X⁻¹ and f(A) = X f(B) X⁻¹. For
example, cos(A) = X cos(B) X⁻¹ where:

cos(B) =

All computations are performed using
floating-point arithmetic.

cos⁻¹() µ key
cos⁻¹(Expr1) ⇒ expression

cos⁻¹(List1) ⇒ list

cos⁻¹(Expr1) returns the angle whose
cosine is Expr1 as an expression.

cos⁻¹(List1) returns a list of the inverse
cosines of each element of List1.

Note: The result is returned as a degree,
gradian or radian angle, according to the
current angle mode setting.

Note: You can insert this function from the
keyboard by typing arccos(...).

InDegree anglemode:

InGradian anglemode:

In Radian anglemode:
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cos⁻¹() µ key
cos⁻¹(squareMatrix1) ⇒ squareMatrix

Returns the matrix inverse cosine of
squareMatrix1. This is not the same as
calculating the inverse cosine of each
element. For information about the
calculation method, refer to cos().

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.

In Radian anglemode andRectangular
Complex Format:

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

cosh() Catalog >
cosh(Expr1) ⇒ expression

cosh(List1) ⇒ list

cosh(Expr1) returns the hyperbolic cosine
of the argument as an expression.

cosh(List1) returns a list of the hyperbolic
cosines of each element of List1.

InDegree anglemode:

cosh(squareMatrix1) ⇒ squareMatrix

Returns the matrix hyperbolic cosine of
squareMatrix1. This is not the same as
calculating the hyperbolic cosine of each
element. For information about the
calculation method, refer to cos().

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.

In Radian anglemode:

cosh⁻¹() Catalog >
cosh⁻¹(Expr1) ⇒ expression

cosh⁻¹(List1) ⇒ list

cosh⁻¹(Expr1) returns the inverse
hyperbolic cosine of the argument as an
expression.



cosh⁻¹() Catalog >
cosh⁻¹(List1) returns a list of the inverse
hyperbolic cosines of each element of
List1.

Note: You can insert this function from the
keyboard by typing arccosh(...).

cosh⁻¹(squareMatrix1) ⇒ squareMatrix

Returns the matrix inverse hyperbolic
cosine of squareMatrix1. This is not the
same as calculating the inverse hyperbolic
cosine of each element. For information
about the calculation method, refer to cos
().

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.

In Radian anglemode and InRectangular
Complex Format:

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

cot() µ key
cot(Expr1) ⇒ expression

cot(List1) ⇒ list

Returns the cotangent of Expr1 or returns a
list of the cotangents of all elements in
List1.

Note: The argument is interpreted as a
degree, gradian or radian angle, according
to the current angle mode setting. You can
use °, G, or r to override the angle mode
temporarily.

InDegree anglemode:

InGradian anglemode:

In Radian anglemode:

cot⁻¹() µ key
cot⁻¹(Expr1) ⇒ expression

cot⁻¹(List1) ⇒ list

Returns the angle whose cotangent is
Expr1 or returns a list containing the
inverse cotangents of each element of
List1.

InDegree anglemode:

InGradian anglemode:
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cot⁻¹() µ key
Note: The result is returned as a degree,
gradian or radian angle, according to the
current angle mode setting.

Note: You can insert this function from the
keyboard by typing arccot(...).

In Radian anglemode:

coth() Catalog >
coth(Expr1) ⇒ expression

coth(List1) ⇒ list

Returns the hyperbolic cotangent of Expr1
or returns a list of the hyperbolic
cotangents of all elements of List1.

coth⁻¹() Catalog >
coth⁻¹(Expr1) ⇒ expression

coth⁻¹(List1) ⇒ list

Returns the inverse hyperbolic cotangent of
Expr1 or returns a list containing the
inverse hyperbolic cotangents of each
element of List1.

Note: You can insert this function from the
keyboard by typing arccoth(...).

count() Catalog >
count(Value1orList1 [,Value2orList2
[,...]]) ⇒ value

Returns the accumulated count of all
elements in the arguments that evaluate to
numeric values.

Each argument can be an expression, value,
list, or matrix. You can mix data types and
use arguments of various dimensions.

For a list, matrix, or range of cells, each
element is evaluated to determine if it
should be included in the count.

In the last example, only 1/2 and3+4*i are
counted. The remaining arguments,
assuming x is undefined, do not evaluate to
numeric values.



count() Catalog >
Within the Lists & Spreadsheet application,
you can use a range of cells in place of any
argument.

Empty (void) elements are ignored. For
more information on empty elements, see
page 236.

countif() Catalog >
countif(List,Criteria) ⇒ value

Returns the accumulated count of all
elements in List that meet the specified
Criteria.

Criteria can be:

• A value, expression, or string. For
example, 3 counts only those elements in
List that simplify to the value 3.

• A Boolean expression containing the
symbol ? as a placeholder for each
element. For example, ?<5 counts only
those elements in List that are less than
5.

Within the Lists & Spreadsheet application,
you can use a range of cells in place of List.

Empty (void) elements in the list are
ignored. For more information on empty
elements, see page 236.

Note: See also sumIf(), page 181, and
frequency(), page 75.

Counts the number of elements equal to 3.

Counts the number of elements equal to
“def.”

Counts the number of elements equal to x;
this example assumes the variable x is
undefined.

Counts 1 and3.

Counts 3, 5, and7.

Counts 1, 3, 7, and9.
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cPolyRoots() Catalog >
cPolyRoots(Poly,Var) ⇒ list

cPolyRoots(ListOfCoeffs) ⇒ list

The first syntax, cPolyRoots(Poly,Var),
returns a list of complex roots of
polynomial Poly with respect to variable
Var.

Poly must be a polynomial in one variable.

The second syntax, cPolyRoots
(ListOfCoeffs), returns a list of complex
roots for the coefficients in ListOfCoeffs.

Note: See also polyRoots(), page 137.

crossP() Catalog >
crossP(List1, List2) ⇒ list

Returns the cross product of List1 and
List2 as a list.

List1 and List2must have equal
dimension, and the dimension must be
either 2 or 3.

crossP(Vector1, Vector2) ⇒ vector

Returns a row or column vector (depending
on the arguments) that is the cross product
of Vector1 and Vector2.

Both Vector1 and Vector2must be row
vectors, or both must be column vectors.
Both vectors must have equal dimension,
and the dimension must be either 2 or 3.

csc() µ key
csc(Expr1) ⇒ expression

csc(List1) ⇒ list

Returns the cosecant of Expr1 or returns a
list containing the cosecants of all elements
in List1.

InDegree anglemode:

InGradian anglemode:



csc() µ key

In Radian anglemode:

csc⁻¹() µ key
csc⁻¹(Expr1) ⇒expression

csc⁻¹(List1) ⇒ list

Returns the angle whose cosecant is Expr1
or returns a list containing the inverse
cosecants of each element of List1.

Note: The result is returned as a degree,
gradian or radian angle, according to the
current angle mode setting.

Note: You can insert this function from the
keyboard by typing arccsc(...).

InDegree anglemode:

InGradian anglemode:

In Radian anglemode:

csch() Catalog >
csch(Expr1) ⇒ expression

csch(List1) ⇒ list

Returns the hyperbolic cosecant of Expr1 or
returns a list of the hyperbolic cosecants of
all elements of List1.

csch⁻¹() Catalog >
csch⁻¹(Expr1) ⇒ expression

csch⁻¹(List1) ⇒ list

Returns the inverse hyperbolic cosecant of
Expr1 or returns a list containing the
inverse hyperbolic cosecants of each
element of List1.

Note: You can insert this function from the
keyboard by typing arccsch(...).
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cSolve() Catalog >
cSolve(Equation, Var) ⇒ Boolean
expression

cSolve(Equation, Var=Guess) ⇒ Boolean
expression

cSolve(Inequality, Var) ⇒ Boolean
expression

Returns candidate complex solutions of an
equation or inequality for Var. The goal is
to produce candidates for all real and non-
real solutions. Even if Equation is real,
cSolve() allows non-real results in Real
result Complex Format.

Although all undefined variables that do not
end with an underscore (_) are processed
as if they were real, cSolve() can solve
polynomial equations for complex solutions.

cSolve() temporarily sets the domain to
complex during the solution even if the
current domain is real. In the complex
domain, fractional powers having odd
denominators use the principal rather than
the real branch. Consequently, solutions
from solve() to equations involving such
fractional powers are not necessarily a
subset of those from cSolve().

cSolve() starts with exact symbolic
methods. cSolve() also uses iterative
approximate complex polynomial factoring,
if necessary.

Note: See also cZeros(), solve(), and zeros().

Note: If Equation is non-polynomial with
functions such as abs(), angle(), conj(), real
(), or imag(), you should place an
underscore (press/_) at the end of
Var. By default, a variable is treated as a
real value.

InDisplay Digits mode of Fix 2:

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

If you use var_ , the variable is treated as
complex.



cSolve() Catalog >
You should also use var_ for any other
variables in Equation that might have
unreal values. Otherwise, you may receive
unexpected results.

cSolve(Eqn1andEqn2 [and…],
VarOrGuess1, VarOrGuess2 [, … ]) ⇒
Boolean expression

cSolve(SystemOfEqns, VarOrGuess1,
VarOrGuess2 [, …]) ⇒
Boolean expression

Returns candidate complex solutions to the
simultaneous algebraic equations, where
each varOrGuess specifies a variable that
you want to solve for.

Optionally, you can specify an initial guess
for a variable. Each varOrGuess must have
the form:

variable
– or –
variable = real or non-real number

For example, x is valid and so is x=3+i.
If all of the equations are polynomials and
if you do NOT specify any initial guesses,
cSolve() uses the lexical
Gröbner/Buchberger elimination method to
attempt to determine all complex solutions.

Note: The following examples use an
underscore (press/_) so that the
variables will be treated as complex.

Complex solutions can include both real and
non-real solutions, as in the example to the
right.

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

Simultaneous polynomial equations can
have extra variables that have no values,
but represent given numeric values that
could be substituted later.

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.
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cSolve() Catalog >
You can also include solution variables that
do not appear in the equations. These
solutions show how families of solutions
might contain arbitrary constants of the
form ck, where k is an integer suffix from 1
through 255.

For polynomial systems, computation time
or memory exhaustion may depend strongly
on the order in which you list solution
variables. If your initial choice exhausts
memory or your patience, try rearranging
the variables in the equations and/or
varOrGuess list.

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

If you do not include any guesses and if any
equation is non-polynomial in any variable
but all equations are linear in all solution
variables, cSolve() uses Gaussian
elimination to attempt to determine all
solutions.

If a system is neither polynomial in all of its
variables nor linear in its solution variables,
cSolve() determines at most one solution
using an approximate iterative method. To
do so, the number of solution variables
must equal the number of equations, and
all other variables in the equations must
simplify to numbers.

A non-real guess is often necessary to
determine a non-real solution. For
convergence, a guess might have to be
rather close to a solution.

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

CubicReg Catalog >
CubicReg X, Y[, [Freq] [, Category,
Include]]

Computes the cubic polynomial regression
y=a•x3+b•x2+c•x+d on lists X and Y with
frequency Freq. A summary of results is
stored in the stat.results variable. (See page
177.)



CubicReg Catalog >
All the lists must have equal dimension
except for Include.

X and Y are lists of independent and
dependent variables.

Freq is an optional list of frequency values.
Each element in Freq specifies the
frequency of occurrence for each
corresponding X and Y data point. The
default value is 1. All elements must be
integers ≥ 0.

Category is a list of category codes for the
corresponding X and Y data.

Include is a list of one or more of the
category codes. Only those data items
whose category code is included in this list
are included in the calculation.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output
variable Description

stat.RegEqn Regressionequation: a•x3+b•x2+c•x+d

stat.a, stat.b,
stat.c, stat.d

Regression coefficients

stat.R2 Coefficient of determination

stat.Resid Residuals from the regression

stat.XReg List of data points in themodifiedX List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.YReg List of data points in themodifiedY List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.FreqReg List of frequencies corresponding to stat.XReg and stat.YReg

cumulativeSum() Catalog >
cumulativeSum(List1) ⇒ list

Returns a list of the cumulative sums of the
elements in List1, starting at element 1.
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cumulativeSum() Catalog >
cumulativeSum(Matrix1) ⇒ matrix

Returns a matrix of the cumulative sums of
the elements inMatrix1. Each element is
the cumulative sum of the column from top
to bottom.

An empty (void) element in List1 or
Matrix1 produces a void element in the
resulting list or matrix. For more
information on empty elements, see page
236.

Cycle Catalog >
Cycle

Transfers control immediately to the next
iteration of the current loop (For, While, or
Loop).

Cycle is not allowed outside the three
looping structures (For, While, or Loop).

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

Function listing that sums the integers from1
to 100 skipping 50.

►Cylind Catalog >
Vector►Cylind

Note: You can insert this operator from the
computer keyboard by typing @>Cylind.

Displays the row or column vector in
cylindrical form [r,∠θ, z].

Vector must have exactly three elements.
It can be either a row or a column.

cZeros() Catalog >
cZeros(Expr, Var) ⇒ list InDisplay Digits mode of Fix 3:



cZeros() Catalog >
Returns a list of candidate real and non-real
values of Var that make Expr=0. cZeros()
does this by computing
exp►list(cSolve(Expr=0,Var),Var).
Otherwise, cZeros() is similar to zeros().

Note: See also cSolve(), solve(), and zeros().

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

Note: If Expr is non-polynomial with
functions such as abs(), angle(), conj(), real
(), or imag(), you should place an
underscore (press/_) at the end of
Var. By default, a variable is treated as a
real value. If you use var_ , the variable is
treated as complex.

You should also use var_ for any other
variables in Expr that might have unreal
values. Otherwise, you may receive
unexpected results.

cZeros({Expr1, Expr2 [, … ] },
{VarOrGuess1,VarOrGuess2 [, … ] }) ⇒
matrix

Returns candidate positions where the
expressions are zero simultaneously. Each
VarOrGuess specifies an unknown whose
value you seek.

Optionally, you can specify an initial guess
for a variable. Each VarOrGuess must have
the form:

variable
– or –
variable = real or non-real number

For example, x is valid and so is x=3+i.
If all of the expressions are polynomials and
you do NOT specify any initial guesses,
cZeros() uses the lexical
Gröbner/Buchberger elimination method to
attempt to determine all complex zeros.

Note: The following examples use an
underscore _ (press/_) so that the
variables will be treated as complex.
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cZeros() Catalog >
Complex zeros can include both real and
non-real zeros, as in the example to the
right.

Each row of the resulting matrix represents
an alternate zero, with the components
ordered the same as the VarOrGuess list.
To extract a row, index the matrix by [row].

Extract row2:

Simultaneous polynomials can have extra
variables that have no values, but represent
given numeric values that could be
substituted later.

You can also include unknown variables that
do not appear in the expressions. These
zeros show how families of zeros might
contain arbitrary constants of the form ck,
where k is an integer suffix from 1 through
255.

For polynomial systems, computation time
or memory exhaustion may depend strongly
on the order in which you list unknowns. If
your initial choice exhausts memory or your
patience, try rearranging the variables in
the expressions and/or VarOrGuess list.
If you do not include any guesses and if any
expression is non-polynomial in any variable
but all expressions are linear in all
unknowns, cZeros() uses Gaussian
elimination to attempt to determine all
zeros.



cZeros() Catalog >
If a system is neither polynomial in all of its
variables nor linear in its unknowns, cZeros
() determines at most one zero using an
approximate iterative method. To do so, the
number of unknowns must equal the
number of expressions, and all other
variables in the expressions must simplify
to numbers.

A non-real guess is often necessary to
determine a non-real zero. For
convergence, a guess might have to be
rather close to a zero.

D

dbd() Catalog >
dbd(date1,date2) ⇒ value

Returns the number of days between date1
and date2 using the actual-day-count
method.

date1 and date2 can be numbers or lists of
numbers within the range of the dates on
the standard calendar. If both date1 and
date2 are lists, they must be the same
length.

date1 and date2must be between the
years 1950 through 2049.

You can enter the dates in either of two
formats. The decimal placement
differentiates between the date formats.

MM.DDYY (format used commonly in the
United States)
DDMM.YY (format use commonly in
Europe)

►DD Catalog >
Expr1►DD ⇒ valueList1
►DD ⇒ listMatrix1
►DD ⇒ matrix

InDegree anglemode:
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►DD Catalog >
Note: You can insert this operator from the
computer keyboard by typing @>DD.

Returns the decimal equivalent of the
argument expressed in degrees. The
argument is a number, list, or matrix that is
interpreted by the Angle mode setting in
gradians, radians or degrees. InGradian anglemode:

In Radian anglemode:

►Decimal Catalog >
Expression1►Decimal ⇒ expression

List1►Decimal ⇒ expression

Matrix1►Decimal ⇒ expression

Note: You can insert this operator from the
computer keyboard by typing @>Decimal.

Displays the argument in decimal form.
This operator can be used only at the end of
the entry line.

Define Catalog >
Define Var = Expression
Define Function(Param1, Param2, ...) =
Expression

Defines the variable Var or the user-
defined function Function.

Parameters, such as Param1, provide
placeholders for passing arguments to the
function. When calling a user-defined
function, you must supply arguments (for
example, values or variables) that
correspond to the parameters. When called,
the function evaluates Expression using
the supplied arguments.



Define Catalog >
Var and Function cannot be the name of a
system variable or built-in function or
command.

Note: This form of Define is equivalent to
executing the expression: expression→
Function(Param1,Param2).
Define Function(Param1, Param2, ...) =
Func
     Block
EndFunc

Define Program(Param1, Param2, ...) =
Prgm
     Block
EndPrgm

In this form, the user-defined function or
program can execute a block of multiple
statements.

Block can be either a single statement or a
series of statements on separate lines.
Block also can include expressions and
instructions (such as If, Then, Else, and For).

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

Note: See also Define LibPriv, page 47, and
Define LibPub, page 48.

Define LibPriv Catalog >
Define LibPriv Var = Expression
Define LibPriv Function(Param1, Param2,
...) = Expression

Define LibPriv Function(Param1, Param2,
...) = Func
     Block
EndFunc

Define LibPriv Program(Param1, Param2,
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Define LibPriv Catalog >
...) = Prgm
     Block
EndPrgm

Operates the same as Define, except defines
a private library variable, function, or
program. Private functions and programs do
not appear in the Catalog.

Note: See also Define, page 46, and Define
LibPub, page 48.

Define LibPub Catalog >
Define LibPub Var = Expression
Define LibPub Function(Param1, Param2,
...) = Expression

Define LibPub Function(Param1, Param2,
...) = Func
     Block
EndFunc

Define LibPub Program(Param1, Param2,
...) = Prgm
     Block
EndPrgm

Operates the same as Define, except defines
a public library variable, function, or
program. Public functions and programs
appear in the Catalog after the library has
been saved and refreshed.

Note: See also Define, page 46, and Define
LibPriv, page 47.

deltaList() See ΔList(), page 104.

deltaTmpCnv() See ΔtmpCnv(), page 190.



DelVar Catalog >
DelVar Var1[, Var2] [, Var3] ...

DelVar Var.

Deletes the specified variable or variable
group from memory.

If one or more of the variables are locked,
this command displays an error message
and deletes only the unlocked variables. See
unLock, page 197.

DelVar Var. deletes all members of the
Var. variable group (such as the statistics
stat.nn results or variables created using
the LibShortcut() function). The dot (.) in
this form of the DelVar command limits it
to deleting a variable group; the simple
variable Var is not affected.

delVoid() Catalog >
delVoid(List1) ⇒ list

Returns a list that has the contents of List1
with all empty (void) elements removed.

For more information on empty elements,
see page 236.

derivative() See d(), page 221.

deSolve() Catalog >
deSolve(1stOr2ndOrderODE, Var,
depVar) ⇒ a general solution

Returns an equation that explicitly or
implicitly specifies a general solution to the
1st- or 2nd-order ordinary differential
equation (ODE). In the ODE:

• Use a prime symbol (pressº) to denote

Alphabetical Listing 49



50 Alphabetical Listing

deSolve() Catalog >
the 1st derivative of the dependent
variable with respect to the independent
variable.

• Use two prime symbols to denote the
corresponding second derivative.

The prime symbol is used for derivatives
within deSolve() only. In other cases, use d
().

The general solution of a 1st-order equation
contains an arbitrary constant of the form
ck, where k is an integer suffix from 1
through 255. The solution of a 2nd-order
equation contains two such constants.

Apply solve() to an implicit solution if you
want to try to convert it to one or more
equivalent explicit solutions.

When comparing your results with textbook
or manual solutions, be aware that different
methods introduce arbitrary constants at
different points in the calculation, which
may produce different general solutions.

deSolve(1stOrderODE and initCond, Var,
depVar) ⇒ a particular solution

Returns a particular solution that satisfies
1stOrderODE and initCond. This is usually
easier than determining a general solution,
substituting initial values, solving for the
arbitrary constant, and then substituting
that value into the general solution.

initCond is an equation of the form:

depVar (initialIndependentValue) =
initialDependentValue

The initialIndependentValue and
initialDependentValue can be variables
such as x0 and y0 that have no stored
values. Implicit differentiation can help
verify implicit solutions.



deSolve() Catalog >
deSolve(2ndOrderODE and initCond1 and
initCond2, Var, depVar)
⇒ particular solution

Returns a particular solution that satisfies
2nd Order ODE and has a specified value
of the dependent variable and its first
derivative at one point.

For initCond1, use the form:

depVar (initialIndependentValue) =
initialDependentValue

For initCond2, use the form:

depVar (initialIndependentValue) =
initial1stDerivativeValue
deSolve(2ndOrderODE and bndCond1 and
bndCond2, Var, depVar)
⇒ a particular solution

Returns a particular solution that satisfies
2ndOrderODE and has specified values at
two different points.

det() Catalog >
det(squareMatrix[, Tolerance]) ⇒
expression

Returns the determinant of squareMatrix.

Optionally, any matrix element is treated as
zero if its absolute value is less than
Tolerance. This tolerance is used only if the
matrix has floating-point entries and does
not contain any symbolic variables that
have not been assigned a value. Otherwise,
Tolerance is ignored.

• If you use/· or set the Auto or
Approximate mode to Approximate,
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det() Catalog >
computations are done using floating-
point arithmetic.

• If Tolerance is omitted or not used, the
default tolerance is calculated as:
5E⁻14 •max(dim(squareMatrix))
•rowNorm(squareMatrix)

diag() Catalog >
diag(List) ⇒ matrix
diag(rowMatrix) ⇒ matrix
diag(columnMatrix) ⇒ matrix

Returns a matrix with the values in the
argument list or matrix in its main
diagonal.

diag(squareMatrix) ⇒ rowMatrix

Returns a row matrix containing the
elements from the main diagonal of
squareMatrix.

squareMatrix must be square.

dim() Catalog >
dim(List) ⇒ integer

Returns the dimension of List.
dim(Matrix) ⇒ list

Returns the dimensions of matrix as a two-
element list {rows, columns}.

dim(String) ⇒ integer

Returns the number of characters contained
in character string String.



Disp  Catalog >
Disp exprOrString1 [, exprOrString2] ...

Displays the arguments in the Calculator
history. The arguments are displayed in
succession, with thin spaces as separators.

Useful mainly in programs and functions to
ensure the display of intermediate
calculations.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

DispAt Catalog >
DispAt int,expr1 [,expr2 ...] ...

DispAt allows you to specify the line
where the specified expression or string
will be displayed on the screen.

The line number can be specified as an
expression.

Please note that the line number is not
for the entire screen but for the area
immediately following the
command/program.

This command allows dashboard-like
output from programs where the value
of an expression or from a sensor
reading is updated on the same line.

DispAtand Disp can be used within the
same program.

Note: The maximum number is set to 8
since that matches a screen-full of lines
on the handheld screen - as long as the
lines don't have 2D math expressions.
The exact number of lines depends on
the content of the displayed
information.

Example

Illustrative examples:
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DispAt Catalog >

Define z()=
Prgm
For n,1,3
DispAt 1,"N: ",n
Disp "Hello"
EndFor
EndPrgm

Output
z()

Iteration 1:
Line 1: N:1

Line 2: Hello

Iteration 2:
Line 1: N:2

Line 2: Hello
Line 3: Hello

Iteration 3:
Line 1: N:3

Line 2: Hello
Line 3: Hello
Line 4: Hello

Define z1()=
Prgm
For n,1,3
DispAt 1,"N: ",n
EndFor

For n,1,4
Disp "Hello"
EndFor
EndPrgm

z1()
Line 1: N:3

Line 2: Hello
Line 3: Hello
Line 4: Hello
Line 5: Hello

Error conditions:

Error Message Description
DispAt line number must be between 1 and 8 Expression evaluates the line number

outside the range 1-8 (inclusive)

Too few arguments The function or command is missing one
or more arguments.

No arguments Same as current 'syntax error' dialog

Too many arguments Limit argument. Same error as Disp.

Invalid data type First argument must be a number.

Void: DispAt void "Hello World" Datatype error is thrown



Error Message Description
for the void (if the callback is defined)

Conversion operator: DispAt 2_ft @> _m,
"Hello World"

CAS: Datatype Error is thrown (if the
callback is defined)
Numeric: Conversion will be evaluated
and if the result is a valid argument,
DispAt print the string at the result line.

►DMS Catalog >
Expr ►DMS

List ►DMS

Matrix ►DMS

Note: You can insert this operator from the
computer keyboard by typing @>DMS.

Interprets the argument as an angle and
displays the equivalent DMS
(DDDDDD°MM'SS.ss'') number. See °, ', ''
on page 228 for DMS (degree, minutes,
seconds) format.

Note:►DMS will convert from radians to
degrees when used in radian mode. If the
input is followed by a degree symbol ° , no
conversion will occur. You can use►DMS
only at the end of an entry line.

InDegree anglemode:

domain() Catalog >
domain(Expr1, Var) ⇒ expression

Returns the domain of Expr1 with respect
to Var.

domain() can be used to examine domains
of functions. It is restricted to real and
finite domain.

This functionality has limitations due to
shortcomings of computer algebra
simplification and solver algorithms.
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domain() Catalog >
Certain functions cannot be used as
arguments for domain(), regardless of
whether they appear explicitly or within
user-defined variables and functions. In the
following example, the expression cannot
be simplified because ∫() is a disallowed
function.

dominantTerm() Catalog >
dominantTerm(Expr1, Var [, Point]) ⇒
expression

dominantTerm(Expr1, Var [, Point]) |
Var>Point ⇒ expression

dominantTerm(Expr1, Var [, Point]) |
Var<Point ⇒ expression

Returns the dominant term of a power
series representation of Expr1 expanded
about Point. The dominant term is the one
whose magnitude grows most rapidly near
Var = Point. The resulting power of (Var −
Point) can have a negative and/or
fractional exponent. The coefficient of this
power can include logarithms of (Var −
Point) and other functions of Var that are
dominated by all powers of (Var − Point)
having the same exponent sign.

Point defaults to 0. Point can be ∞ or −∞,
in which cases the dominant term will be
the term having the largest exponent of
Var rather than the smallest exponent of
Var.

dominantTerm(…) returns “dominantTerm
(…)” if it is unable to determine such a
representation, such as for essential
singularities such as sin(1/z) at z=0, e−1/z
at z=0, or ez at z = ∞ or −∞.



dominantTerm() Catalog >
If the series or one of its derivatives has a
jump discontinuity at Point, the result is
likely to contain sub-expressions of the
form sign(…) or abs(…) for a real expansion
variable or (-1)floor(…angle(…)…) for a complex
expansion variable, which is one ending
with “_”. If you intend to use the dominant
term only for values on one side of Point,
then append to dominantTerm(...) the
appropriate one of “| Var > Point”, “| Var
< Point”, “| “Var ≥ Point”, or “Var ≤
Point” to obtain a simpler result.

dominantTerm() distributes over 1st-
argument lists and matrices.

dominantTerm() is useful when you want to
know the simplest possible expression that
is asymptotic to another expression as
Var→Point. dominantTerm() is also useful
when it isn’t obvious what the degree of
the first non-zero term of a series will be,
and you don’t want to iteratively guess
either interactively or by a program loop.

Note: See also series(), page 161.

dotP() Catalog >
dotP(List1, List2) ⇒ expression

Returns the “dot” product of two lists.

dotP(Vector1, Vector2) ⇒ expression

Returns the “dot” product of two vectors.

Both must be row vectors, or both must be
column vectors.

E

e^() u key
e^(Expr1) ⇒ expression

Returns e raised to the Expr1 power.

Note: See also e exponent template, page
2.
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e^() u key

Note: Pressingu to display e^( is different
from pressing the characterE on the
keyboard.

You can enter a complex number in reiθ
polar form. However, use this form in
Radian angle mode only; it causes a
Domain error in Degree or Gradian angle
mode.

e^(List1) ⇒ list

Returns e raised to the power of each
element in List1.
e^(squareMatrix1) ⇒ squareMatrix

Returns the matrix exponential of
squareMatrix1. This is not the same as
calculating e raised to the power of each
element. For information about the
calculation method, refer to cos().

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.

eff() Catalog >
eff(nominalRate,CpY) ⇒ value

Financial function that converts the nominal
interest rate nominalRate to an annual
effective rate, given CpY as the number of
compounding periods per year.

nominalRate must be a real number, and
CpY must be a real number > 0.

Note: See also nom(), page 124.

eigVc() Catalog >
eigVc(squareMatrix) ⇒ matrix In Rectangular Complex Format:



eigVc() Catalog >
Returns a matrix containing the
eigenvectors for a real or complex
squareMatrix, where each column in the
result corresponds to an eigenvalue. Note
that an eigenvector is not unique; it may be
scaled by any constant factor. The
eigenvectors are normalized, meaning that:

if V = [x1, x2, … , xn]

then x1
2 + x2

2 + … + xn
2 = 1

squareMatrix is first balanced with
similarity transformations until the row and
column norms are as close to the same
value as possible. The squareMatrix is then
reduced to upper Hessenberg form and the
eigenvectors are computed via a Schur
factorization.

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

eigVl() Catalog >
eigVl(squareMatrix) ⇒ list

Returns a list of the eigenvalues of a real or
complex squareMatrix.

squareMatrix is first balanced with
similarity transformations until the row and
column norms are as close to the same
value as possible. The squareMatrix is then
reduced to upper Hessenberg form and the
eigenvalues are computed from the upper
Hessenberg matrix.

In Rectangular complex formatmode:

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

Else See If, page 87.
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ElseIf Catalog >
If BooleanExpr1 Then
     Block1
ElseIf BooleanExpr2 Then
     Block2
⋮
ElseIf BooleanExprN Then
     BlockN
EndIf
⋮

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

EndFor See For, page 73.

EndFunc See Func, page 76.

EndIf See If, page 87.

EndLoop See Loop, page 111.

EndPrgm See Prgm, page 138.

EndTry See Try, page 191.

EndWhile See While, page 201.



euler () Catalog >
euler(Expr, Var, depVar, {Var0, VarMax},
depVar0, VarStep [, eulerStep]) ⇒ matrix

euler(SystemOfExpr, Var, ListOfDepVars,
{Var0, VarMax},      ListOfDepVars0,
VarStep [, eulerStep]) ⇒ matrix

euler(ListOfExpr, Var, ListOfDepVars,
{Var0, VarMax}, ListOfDepVars0,
VarStep [, eulerStep]) ⇒ matrix

Uses the Euler method to solve the system

with depVar(Var0)=depVar0 on the
interval [Var0,VarMax]. Returns a matrix
whose first row defines the Var output
values and whose second row defines the
value of the first solution component at the
corresponding Var values, and so on.

Expr is the right-hand side that defines the
ordinary differential equation (ODE).

SystemOfExpr is the system of right-hand
sides that define the system of ODEs
(corresponds to order of dependent
variables in ListOfDepVars).

ListOfExpr is a list of right-hand sides that
define the system of ODEs (corresponds to
the order of dependent variables in
ListOfDepVars).

Var is the independent variable.

ListOfDepVars is a list of dependent
variables.

{Var0, VarMax} is a two-element list that
tells the function to integrate from Var0 to
VarMax.

ListOfDepVars0 is a list of initial values
for dependent variables.

Differential equation:
y'=0.001*y*(100-y) and y(0)=10

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

Compare above resultwithCAS exact
solutionobtainedusing deSolve() and
seqGen():

Systemof equations:

with y1(0)=2 and y2(0)=5
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euler () Catalog >
VarStep is a nonzero number such that sign
(VarStep) = sign(VarMax-Var0) and
solutions are returned at Var0+i•VarStep
for all i=0,1,2,… such that Var0+i•VarStep
is in [var0,VarMax] (there may not be a
solution value at VarMax).

eulerStep is a positive integer (defaults to
1) that defines the number of euler steps
between output values. The actual step size
used by the euler method is
VarStep  ⁄ eulerStep.

eval () Hub Menu
eval(Expr) ⇒string

eval() is valid only in the TI-Innovator™ Hub
Command argument of programming
commands Get, GetStr, and Send. The
software evaluates expression Expr and
replaces the eval() statement with the
result as a character string.

The argument Expr must simplify to a real
number.

Set the blue element of the RGB LED to half
intensity.

Reset the blue element to OFF.

eval() argumentmust simplify to a real
number.

Program to fade-in the redelement

Execute the program.



eval () Hub Menu
Although eval() does not display its result,
you can view the resulting Hub command
string after executing the command by
inspecting any of the following special
variables.

iostr.SendAns
iostr.GetAns
iostr.GetStrAns

Note: See also Get (page 78), GetStr (page
85), and Send (page 159).

exact() Catalog >
exact(Expr1 [, Tolerance]) ⇒ expression
exact(List1 [, Tolerance]) ⇒ list
exact(Matrix1 [, Tolerance]) ⇒ matrix

Uses Exact mode arithmetic to return,
when possible, the rational-number
equivalent of the argument.

Tolerance specifies the tolerance for the
conversion; the default is 0 (zero).

Exit Catalog >
Exit

Exits the current For, While, or Loop block.

Exit is not allowed outside the three looping
structures (For, While, or Loop).

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

Function listing:
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►exp Catalog >
Expr►exp

Represents Expr in terms of the natural
exponential e. This is a display conversion
operator. It can be used only at the end of
the entry line.

Note: You can insert this operator from the
computer keyboard by typing @>exp.

exp() u key
exp(Expr1) ⇒ expression

Returns e raised to the Expr1 power.

Note: See also e exponent template, page
2.

You can enter a complex number in reiθ
polar form. However, use this form in
Radian angle mode only; it causes a
Domain error in Degree or Gradian angle
mode.

exp(List1) ⇒ list

Returns e raised to the power of each
element in List1.
exp(squareMatrix1) ⇒ squareMatrix

Returns the matrix exponential of
squareMatrix1. This is not the same as
calculating e raised to the power of each
element. For information about the
calculation method, refer to cos().

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.

exp►list() Catalog >
exp►list(Expr,Var) ⇒ list



exp►list() Catalog >
Examines Expr for equations that are
separated by the word “or,” and returns a
list containing the right-hand sides of the
equations of the form Var=Expr. This
gives you an easy way to extract some
solution values embedded in the results of
the solve(), cSolve(), fMin(), and fMax()
functions.

Note: exp►list() is not necessary with the
zeros() and cZeros() functions because they
return a list of solution values directly.

You can insert this function from the
keyboard by typing exp@>list(...).

expand() Catalog >
expand(Expr1 [, Var]) ⇒ expression
expand(List1 [,Var]) ⇒ list
expand(Matrix1 [,Var]) ⇒ matrix

expand(Expr1) returns Expr1 expanded
with respect to all its variables. The
expansion is polynomial expansion for
polynomials and partial fraction expansion
for rational expressions.

The goal of expand() is to transform Expr1
into a sum and/or difference of simple
terms. In contrast, the goal of factor() is to
transform Expr1 into a product and/or
quotient of simple factors.

expand(Expr1,Var) returns Expr1
expanded with respect to Var. Similar
powers of Var are collected. The terms and
their factors are sorted with Var as the
main variable. There might be some
incidental factoring or expansion of the
collected coefficients. Compared to
omitting Var, this often saves time,
memory, and screen space, while making
the expression more comprehensible.
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expand() Catalog >
Even when there is only one variable, using
Var might make the denominator
factorization used for partial fraction
expansion more complete.

Hint: For rational expressions, propFrac() is
a faster but less extreme alternative to
expand().

Note: See also comDenom() for an
expanded numerator over an expanded
denominator.

expand(Expr1,[Var]) also distributes
logarithms and fractional powers
regardless of Var. For increased
distribution of logarithms and fractional
powers, inequality constraints might be
necessary to guarantee that some factors
are nonnegative.

expand(Expr1, [Var]) also distributes
absolute values, sign(), and exponentials,
regardless of Var.

Note: See also tExpand() for trigonometric
angle-sum and multiple-angle expansion.

expr() Catalog >
expr(String) ⇒ expression

Returns the character string contained in
String as an expression and immediately
executes it.

ExpReg Catalog >
ExpReg X, Y [, [Freq] [, Category,
Include]]

Computes the exponential regression y = a•
(b)x on lists X and Y with frequency Freq. A
summary of results is stored in the
stat.results variable. (See page 177.)



ExpReg Catalog >
All the lists must have equal dimension
except for Include.

X and Y are lists of independent and
dependent variables.

Freq is an optional list of frequency values.
Each element in Freq specifies the
frequency of occurrence for each
corresponding X and Y data point. The
default value is 1. All elements must be
integers ≥ 0.

Category is a list of category codes for the
corresponding X and Y data.

Include is a list of one or more of the
category codes. Only those data items
whose category code is included in this list
are included in the calculation.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output
variable Description

stat.RegEqn Regressionequation: a•(b)x

stat.a, stat.b Regression coefficients

stat.r2 Coefficient of linear determination for transformeddata

stat.r Correlation coefficient for transformeddata (x, ln(y))

stat.Resid Residuals associatedwith the exponentialmodel

stat.ResidTrans Residuals associatedwith linear fit of transformeddata

stat.XReg List of data points in themodifiedX List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.YReg List of data points in themodifiedY List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.FreqReg List of frequencies corresponding to stat.XReg and stat.YReg

Alphabetical Listing 67



68 Alphabetical Listing

F

factor() Catalog >
factor(Expr1[, Var]) ⇒ expression
factor(List1[,Var]) ⇒ list
factor(Matrix1[,Var]) ⇒ matrix

factor(Expr1) returns Expr1 factored with
respect to all of its variables over a
common denominator.

Expr1 is factored as much as possible
toward linear rational factors without
introducing new non-real subexpressions.
This alternative is appropriate if you want
factorization with respect to more than one
variable.

factor(Expr1,Var) returns Expr1 factored
with respect to variable Var.

Expr1 is factored as much as possible
toward real factors that are linear in Var,
even if it introduces irrational constants or
subexpressions that are irrational in other
variables.

The factors and their terms are sorted with
Var as the main variable. Similar powers of
Var are collected in each factor. Include
Var if factorization is needed with respect
to only that variable and you are willing to
accept irrational expressions in any other
variables to increase factorization with
respect to Var. There might be some
incidental factoring with respect to other
variables.

For the Auto setting of the Auto or
Approximate mode, including Var permits
approximation with floating-point
coefficients where irrational coefficients
cannot be explicitly expressed concisely in
terms of the built-in functions. Even when
there is only one variable, including Var
might yield more complete factorization.

Note: See also comDenom() for a fast way
to achieve partial factoring when factor() is
not fast enough or if it exhausts memory.



factor() Catalog >
Note: See also cFactor() for factoring all the
way to complex coefficients in pursuit of
linear factors.

factor(rationalNumber) returns the rational
number factored into primes. For
composite numbers, the computing time
grows exponentially with the number of
digits in the second-largest factor. For
example, factoring a 30-digit integer could
take more than a day, and factoring a 100-
digit number could take more than a
century.

To stop a calculation manually,

• Handheld: Hold down thec key and
press· repeatedly.

• Windows®: Hold down the F12 key and
press Enter repeatedly.

• Macintosh®: Hold down the F5 key and
press Enter repeatedly.

• iPad®: The app displays a prompt. You
can continue waiting or cancel.

If you merely want to determine if a
number is prime, use isPrime() instead. It is
much faster, particularly if rationalNumber
is not prime and if the second-largest factor
has more than five digits.

FCdf() Catalog >
FCdf
(lowBound,upBound,dfNumer,dfDenom) ⇒
number if lowBound and upBound are
numbers, list if lowBound and upBound are
lists

FCdf
(lowBound,upBound,dfNumer,dfDenom) ⇒
number if lowBound and upBound are
numbers, list if lowBound and upBound are
lists
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FCdf() Catalog >
Computes the F distribution probability
between lowBound and upBound for the
specified dfNumer (degrees of freedom) and
dfDenom.

For P(X ≤ upBound), set lowBound = 0.

Fill Catalog >
Fill Expr, matrixVar⇒ matrix

Replaces each element in variable
matrixVar with Expr.

matrixVar must already exist.

Fill Expr, listVar⇒ list

Replaces each element in variable listVar
with Expr.

listVar must already exist.

FiveNumSummary Catalog >
FiveNumSummary X[,[Freq]
[,Category,Include]]

Provides an abbreviated version of the 1-
variable statistics on list X. A summary of
results is stored in the stat.results variable.
(See page 177.)

X represents a list containing the data.

Freq is an optional list of frequency values.
Each element in Freq specifies the
frequency of occurrence for each
corresponding X and Y data point. The
default value is 1.

Category is a list of numeric category codes
for the corresponding X data.

Include is a list of one or more of the
category codes. Only those data items
whose category code is included in this list
are included in the calculation.



FiveNumSummary Catalog >
An empty (void) element in any of the lists
X, Freq, or Category results in a void for
the corresponding element of all those lists.
For more information on empty elements,
see page 236.

Output variable Description

stat.MinX Minimumof x values.

stat.Q1X 1stQuartile of x.

stat.MedianX Medianof x.

stat.Q3X 3rdQuartile of x.

stat.MaxX Maximumof x values.

floor() Catalog >
floor(Expr1) ⇒ integer

Returns the greatest integer that is ≤ the
argument. This function is identical to int().

The argument can be a real or a complex
number.

floor(List1) ⇒ list
floor(Matrix1) ⇒ matrix

Returns a list or matrix of the floor of each
element.

Note: See also ceiling() and int().

fMax() Catalog >
fMax(Expr, Var) ⇒ Boolean expression
fMax(Expr, Var,lowBound)

fMax(Expr, Var,lowBound,upBound)

fMax(Expr, Var) |
lowBound≤Var≤upBound

Returns a Boolean expression specifying
candidate values of Var that maximize
Expr or locate its least upper bound.
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fMax() Catalog >
You can use the constraint (“|”) operator to
restrict the solution interval and/or specify
other constraints.

For the Approximate setting of the Auto or
Approximate mode, fMax() iteratively
searches for one approximate local
maximum. This is often faster, particularly
if you use the “|” operator to constrain the
search to a relatively small interval that
contains exactly one local maximum.

Note: See also fMin() andmax().

fMin() Catalog >
fMin(Expr, Var) ⇒ Boolean expression

fMin(Expr, Var,lowBound)

fMin(Expr, Var,lowBound,upBound)

fMin(Expr, Var) |
lowBound≤Var≤upBound

Returns a Boolean expression specifying
candidate values of Var that minimize
Expr or locate its greatest lower bound.

You can use the constraint (“|”) operator to
restrict the solution interval and/or specify
other constraints.

For the Approximate setting of the Auto or
Approximate mode, fMin() iteratively
searches for one approximate local
minimum. This is often faster, particularly
if you use the “|” operator to constrain the
search to a relatively small interval that
contains exactly one local minimum.

Note: See also fMax() andmin().



For Catalog >
For Var, Low, High [, Step]
     Block
EndFor

Executes the statements in Block
iteratively for each value of Var, from Low
toHigh, in increments of Step.

Var must not be a system variable.

Step can be positive or negative. The
default value is 1.

Block can be either a single statement or a
series of statements separated with the “:”
character.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

format() Catalog >
format(Expr[, formatString]) ⇒ string

Returns Expr as a character string based on
the format template.

Expr must simplify to a number.

formatString is a string and must be in the
form: “F[n]”, “S[n]”, “E[n]”, “G[n][c]”,
where [ ] indicate optional portions.

F[n]: Fixed format. n is the number of digits
to display after the decimal point.

S[n]: Scientific format. n is the number of
digits to display after the decimal point.

E[n]: Engineering format. n is the number
of digits after the first significant digit. The
exponent is adjusted to a multiple of three,
and the decimal point is moved to the right
by zero, one, or two digits.
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format() Catalog >
G[n][c]: Same as fixed format but also
separates digits to the left of the radix into
groups of three. c specifies the group
separator character and defaults to a
comma. If c is a period, the radix will be
shown as a comma.

[Rc]: Any of the above specifiers may be
suffixed with the Rc radix flag, where c is a
single character that specifies what to
substitute for the radix point.

fPart() Catalog >
fPart(Expr1) ⇒ expression
fPart(List1) ⇒ list
fPart(Matrix1) ⇒ matrix

Returns the fractional part of the argument.

For a list or matrix, returns the fractional
parts of the elements.

The argument can be a real or a complex
number.

FPdf() Catalog >
FPdf(XVal,dfNumer,dfDenom) ⇒ number
if XVal is a number, list if XVal is a list

Computes the F distribution probability at
XVal for the specified dfNumer (degrees of
freedom) and dfDenom.

freqTable►list() Catalog >
freqTable►list(List1,freqIntegerList) ⇒
list

Returns a list containing the elements from
List1 expanded according to the
frequencies in freqIntegerList. This
function can be used for building a
frequency table for the Data & Statistics
application.

List1 can be any valid list.



freqTable►list() Catalog >
freqIntegerList must have the same
dimension as List1 and must contain non-
negative integer elements only. Each
element specifies the number of times the
corresponding List1 element will be
repeated in the result list. A value of zero
excludes the corresponding List1 element.

Note: You can insert this function from the
computer keyboard by typing
freqTable@>list(...).

Empty (void) elements are ignored. For
more information on empty elements, see
page 236.

frequency() Catalog >
frequency(List1,binsList) ⇒ list

Returns a list containing counts of the
elements in List1. The counts are based on
ranges (bins) that you define in binsList.

If binsList is {b(1), b(2), …, b(n)}, the
specified ranges are {?≤b(1), b(1)<?≤b
(2),…,b(n-1)<?≤b(n), b(n)>?}. The resulting
list is one element longer than binsList.

Each element of the result corresponds to
the number of elements from List1 that
are in the range of that bin. Expressed in
terms of the countIf() function, the result is
{ countIf(list, ?≤b(1)), countIf(list, b(1)<?≤b
(2)), …, countIf(list, b(n-1)<?≤b(n)), countIf
(list, b(n)>?)}.

Elements of List1 that cannot be “placed in
a bin” are ignored. Empty (void) elements
are also ignored. For more information on
empty elements, see page 236.

Within the Lists & Spreadsheet application,
you can use a range of cells in place of both
arguments.

Note: See also countIf(), page 35.

Explanationof result:

2 elements fromDatalist are≤2.5

4 elements fromDatalist are >2.5 and≤4.5

3 elements fromDatalist are >4.5

The element “hello” is a string and cannot be
placed in any of the definedbins.
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FTest_2Samp Catalog >
FTest_2Samp List1,List2[,Freq1[,Freq2
[,Hypoth]]]

FTest_2Samp List1,List2[,Freq1[,Freq2
[,Hypoth]]]

(Data list input)

FTest_2Samp sx1,n1,sx2,n2[,Hypoth]

FTest_2Samp sx1,n1,sx2,n2[,Hypoth]

(Summary stats input)

Performs a two-sample F test. A summary
of results is stored in the stat.results
variable. (See page 177.)

For H
a
: σ1 > σ2, set Hypoth>0

For H
a
: σ1 ≠ σ2 (default), set Hypoth =0

For H
a
: σ1 < σ2, set Hypoth<0

For information on the effect of empty
elements in a list, see Empty (Void)
Elements, page 236.

Output variable Description

stat.F CalculatedF statistic for the data sequence

stat.PVal Smallest level of significance atwhich the null hypothesis canbe rejected

stat.dfNumer numerator degrees of freedom= n1-1

stat.dfDenom denominator degrees of freedom= n2-1

stat.sx1, stat.sx2 Sample standarddeviations of the data sequences inList 1 andList 2

stat.x1_bar
stat.x2_bar

Samplemeans of the data sequences inList 1 andList 2

stat.n1, stat.n2 Size of the samples

Func Catalog >
Func
     Block
EndFunc

Template for creating a user-defined
function.

Define a piecewise function:



Func Catalog >
Block can be a single statement, a series
of statements separated with the “:”
character, or a series of statements on
separate lines. The function can use the
Return instruction to return a specific result.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

Result of graphing g(x)

G

gcd() Catalog >
gcd(Number1, Number2) ⇒ expression

Returns the greatest common divisor of the
two arguments. The gcd of two fractions is
the gcd of their numerators divided by the
lcm of their denominators.

In Auto or Approximate mode, the gcd of
fractional floating-point numbers is 1.0.

gcd(List1, List2) ⇒ list

Returns the greatest common divisors of
the corresponding elements in List1 and
List2.
gcd(Matrix1, Matrix2) ⇒ matrix

Returns the greatest common divisors of
the corresponding elements inMatrix1 and
Matrix2.

geomCdf() Catalog >
geomCdf(p,lowBound,upBound) ⇒ number
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geomCdf() Catalog >
if lowBound and upBound are numbers, list
if lowBound and upBound are lists

geomCdf(p,upBound)for P(1≤X≤upBound)
⇒ number if upBound is a number, list if
upBound is a list

Computes a cumulative geometric
probability from lowBound to upBound with
the specified probability of success p.

For P(X ≤ upBound), set lowBound = 1.

geomPdf() Catalog >
geomPdf(p,XVal) ⇒ number if XVal is a
number, list if XVal is a list

Computes a probability at XVal, the number
of the trial on which the first success occurs,
for the discrete geometric distribution with
the specified probability of success p.

Get Hub Menu
Get [promptString,] var[, statusVar]

Get [promptString,] func(arg1, ...argn)
[, statusVar]

Programming command: Retrieves a value
from a connected TI-Innovator™ Hub and
assigns the value to variable var.

The value must be requested:

• In advance, through a Send "READ ..."
command.

— or —

• By embedding a "READ ..." request as
the optional promptString argument.
This method lets you use a single
command to request the value and
retrieve it.

Example: Request the current value of the
hub's built-in light-level sensor. UseGet to
retrieve the value andassign it to variable
lightval.

Embed the READ requestwithin theGet
command.



Get Hub Menu
Implicit simplification takes place. For
example, a received string of "123" is
interpreted as a numeric value. To preserve
the string, use GetStr instead of Get.

If you include the optional argument
statusVar, it is assigned a value based on
the success of the operation. A value of
zero means that no data was received.

In the second syntax, the func() argument
allows a program to store the received
string as a function definition. This syntax
operates as if the program executed the
command:

     Define func(arg1, ...argn) = received
string

The program can then use the defined
function func().

Note: You can use the Get command within
a user-defined program but not within a
function.

Note: See also GetStr, page 85 and Send,
page 159.

getDenom() Catalog >
getDenom(Expr1) ⇒ expression

Transforms the argument into an
expression having a reduced common
denominator, and then returns its
denominator.

getKey() Catalog >
getKey([0|1]) ⇒ returnString

Description:getKey() - allows a TI-Basic
program to get keyboard input -
handheld, desktop and emulator on
desktop.

Example:

Example:
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getKey() Catalog >
• keypressed := getKey() will return a

key or an empty string if no key has
been pressed. This call will return
immediately.

• keypressed := getKey(1) will wait till
a key is pressed. This call will pause
execution of the program till a key is
pressed.

Handling of key presses:

Handheld Device/Emulator
Key Desktop Return Value

Esc Esc "esc"

Touchpad - Top click n/a "up"

On n/a "home"

Scratchapps n/a "scratchpad"

Touchpad - Left click n/a "left"

Touchpad - Center click n/a "center"

Touchpad - Right click n/a "right"

Doc n/a "doc"

Tab Tab "tab"

Touchpad - Bottom click Down Arrow "down"

Menu n/a "menu"

Ctrl Ctrl no return

Shift Shift no return

Var n/a "var"

Del n/a "del"

= = "="

trig n/a "trig"

0 through 9 0-9 "0" ... "9"



Handheld Device/Emulator
Key Desktop Return Value

Templates n/a "template"

Catalog n/a "cat"

^ ^ "^"

X^2 n/a "square"

/ (division key) / "/"

* (multiply key) * "*"

e^x n/a "exp"

10^x n/a "10power"

+ + "+"

- - "-"

( ( "("

) ) ")"

. . "."

(-) n/a "-" (negate sign)

Enter Enter "enter"

ee n/a "E" (scientific notation E)

a - z a-z alpha = letter pressed (lower
case)
("a" - "z")

shift a-z shift a-z alpha = letter pressed
"A" - "Z"

Note: ctrl-shift works to lock
caps

?! n/a "?!"

pi n/a "pi"

Flag n/a no return

, , ","

Return n/a "return"
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Handheld Device/Emulator
Key Desktop Return Value

Space Space " " (space)

Inaccessible Special Character Keys like
@,!,^, etc.

The character is returned

n/a Function Keys No returned character

n/a Special desktop control keys No returned character

Inaccessible Other desktop keys that are
not available on the
calculator while getkey() is
waiting for a keystroke. ({,
},;, :, ...)

Same character you get in
Notes (not in a math box)

Note: It is important to note that the presence of getKey() in a program changes how
certain events are handled by the system. Some of these are described below.
Terminate program and Handle event - Exactly as if the user were to break out of program
by pressing the ON key
"Support" below means - System works as expected - program continues to run.

Event Device Desktop - TI-Nspire™
Student Software

Quick Poll Terminate program,
handle event

Same as the handheld (TI-
Nspire™ Student Software,
TI-Nspire™ Navigator™ NC
Teacher Software-only)

Remote file mgmt

(Incl. sending 'Exit Press 2
Test' file from another
handheld or desktop-
handheld)

Terminate program,
handle event

Same as the handheld.
(TI-Nspire™ Student
Software, TI-Nspire™
Navigator™ NC Teacher
Software-only)

End Class Terminate program,
handle event

Support
(TI-Nspire™ Student
Software, TI-Nspire™
Navigator™ NC Teacher
Software-only)

Event Device Desktop - TI-Nspire™ All
Versions

TI-Innovator™ Hub
connect/disconnect

Support - Can successfully
issue commands to the TI-
Innovator™ Hub. After you

Same as the handheld



exit the program the TI-
Innovator™ Hub is still
working with the
handheld.

getLangInfo() Catalog >
getLangInfo() ⇒ string

Returns a string that corresponds to the
short name of the currently active
language. You can, for example, use it in a
program or function to determine the
current language.

English = “en”
Danish = “da”
German = “de”
Finnish = “fi”
French = “fr”
Italian = “it”
Dutch = “nl”
Belgian Dutch = “nl_BE”
Norwegian = “no”
Portuguese = “pt”
Spanish = “es”
Swedish = “sv”

getLockInfo() Catalog >
getLockInfo(Var) ⇒ value

Returns the current locked/unlocked state
of variable Var.

value =0: Var is unlocked or does not exist.

value =1: Var is locked and cannot be
modified or deleted.

See Lock, page 107, and unLock, page 197.
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getMode() Catalog >
getMode(ModeNameInteger) ⇒ value

getMode(0) ⇒ list

getMode(ModeNameInteger) returns a
value representing the current setting of
theModeNameInteger mode.

getMode(0) returns a list containing
number pairs. Each pair consists of a mode
integer and a setting integer.

For a listing of the modes and their
settings, refer to the table below.

If you save the settings with getMode(0) →
var, you can use setMode(var) in a function
or program to temporarily restore the
settings within the execution of the
function or program only. See setMode(),
page 162.

Mode
Name

Mode
Integer Setting Integers

Display
Digits

1 1=Float, 2=Float1, 3=Float2, 4=Float3, 5=Float4, 6=Float5,
7=Float6, 8=Float7, 9=Float8, 10=Float9, 11=Float10,
12=Float11, 13=Float12, 14=Fix0, 15=Fix1, 16=Fix2,
17=Fix3, 18=Fix4, 19=Fix5, 20=Fix6, 21=Fix7, 22=Fix8,
23=Fix9, 24=Fix10, 25=Fix11, 26=Fix12

Angle 2 1=Radian, 2=Degree, 3=Gradian

Exponential
Format

3 1=Normal, 2=Scientific, 3=Engineering

Real or
Complex

4 1=Real, 2=Rectangular, 3=Polar

Auto or
Approx.

5 1=Auto, 2=Approximate, 3=Exact

Vector
Format

6 1=Rectangular, 2=Cylindrical, 3=Spherical

Base 7 1=Decimal, 2=Hex, 3=Binary

Unit
system

8 1=SI, 2=Eng/US



getNum() Catalog >
getNum(Expr1) ⇒ expression

Transforms the argument into an
expression having a reduced common
denominator, and then returns its
numerator.

GetStr Hub Menu
GetStr [promptString,] var[, statusVar]

GetStr [promptString,] func(arg1, ...argn)
[, statusVar]

Programming command: Operates
identically to the Get command, except that
the retrieved value is always interpreted as
a string. By contrast, the Get command
interprets the response as an expression
unless it is enclosed in quotation marks ("").

Note: See also Get, page 78 and Send, page
159.

For examples, seeGet.

getType() Catalog >
getType(var) ⇒ string

Returns a string that indicates the data type
of variable var.

If var has not been defined, returns the
string "NONE".

Alphabetical Listing 85



86 Alphabetical Listing

getVarInfo() Catalog >
getVarInfo() ⇒ matrix or string

getVarInfo(LibNameString) ⇒ matrix or
string

getVarInfo() returns a matrix of information
(variable name, type, library accessibility,
and locked/unlocked state) for all variables
and library objects defined in the current
problem.

If no variables are defined, getVarInfo()
returns the string "NONE".

getVarInfo(LibNameString)returns a matrix
of information for all library objects defined
in library LibNameString. LibNameString
must be a string (text enclosed in quotation
marks) or a string variable.

If the library LibNameString does not exist,
an error occurs.

Note the example, in which the result of
getVarInfo() is assigned to variable vs.
Attempting to display row 2 or row 3 of vs
returns an “Invalid list or matrix” error
because at least one of elements in those
rows (variable b, for example) revaluates to
a matrix.

This error could also occur when using Ans
to reevaluate a getVarInfo() result.

The system gives the above error because
the current version of the software does not
support a generalized matrix structure
where an element of a matrix can be either
a matrix or a list.



Goto Catalog >
Goto labelName

Transfers control to the label labelName.

labelName must be defined in the same
function using a Lbl instruction.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

►Grad Catalog >
Expr1►Grad⇒ expression

Converts Expr1 to gradian angle measure.

Note: You can insert this operator from the
computer keyboard by typing @>Grad.

InDegree anglemode:

In Radian anglemode:

I

identity() Catalog >
identity(Integer) ⇒ matrix

Returns the identity matrix with a
dimension of Integer.

Integer must be a positive integer.

If Catalog >
If BooleanExpr

Statement

If BooleanExpr Then
Block

EndIf
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If Catalog >
If BooleanExpr evaluates to true, executes
the single statement Statement or the block
of statements Block before continuing
execution.

If BooleanExpr evaluates to false,
continues execution without executing the
statement or block of statements.

Block can be either a single statement or a
sequence of statements separated with the
“:” character.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

If BooleanExpr Then
       Block1
Else
       Block2
EndIf

If BooleanExpr evaluates to true, executes
Block1 and then skips Block2.

If BooleanExpr evaluates to false, skips
Block1 but executes Block2.

Block1 and Block2 can be a single
statement.

If BooleanExpr1 Then
       Block1
ElseIf BooleanExpr2 Then
       Block2
⋮
ElseIf BooleanExprN Then
       BlockN
EndIf

Allows for branching. If BooleanExpr1
evaluates to true, executes Block1. If
BooleanExpr1 evaluates to false, evaluates
BooleanExpr2, and so on.



ifFn() Catalog >
ifFn(BooleanExpr,Value_If_true [,Value_
If_false [,Value_If_unknown]]) ⇒
expression, list, or matrix

Evaluates the boolean expression
BooleanExpr (or each element from
BooleanExpr ) and produces a result based
on the following rules:

• BooleanExpr can test a single value, a
list, or a matrix.

• If an element of BooleanExpr evaluates
to true, returns the corresponding
element from Value_If_true.

• If an element of BooleanExpr evaluates
to false, returns the corresponding
element from Value_If_false. If you
omit Value_If_false, returns undef.

• If an element of BooleanExpr is neither
true nor false, returns the corresponding
element Value_If_unknown. If you omit
Value_If_unknown, returns undef.

• If the second, third, or fourth argument
of the ifFn() function is a single
expression, the Boolean test is applied to
every position in BooleanExpr.

Note: If the simplified BooleanExpr
statement involves a list or matrix, all other
list or matrix arguments must have the
same dimension(s), and the result will have
the same dimension(s).

Test value of 1 is less than2.5, so its
corresponding

Value_If_True element of 5 is copied to
the result list.

Test value of 2 is less than2.5, so its
corresponding

Value_If_True element of 6 is copied to
the result list.

Test value of 3 is not less than2.5, so its
corresponding Value_If_False element of
10 is copied to the result list.

Value_If_true is a single value and
corresponds to any selectedposition.

Value_If_false is not specified. Undef is
used.

One element selected fromValue_If_true.
One element selected fromValue_If_
unknown.

imag() Catalog >
imag(Expr1) ⇒ expression

Returns the imaginary part of the
argument.
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imag() Catalog >
Note: All undefined variables are treated as
real variables. See also real(), page 147

imag(List1) ⇒ list

Returns a list of the imaginary parts of the
elements.

imag(Matrix1) ⇒ matrix

Returns a matrix of the imaginary parts of
the elements.

impDif() Catalog >
impDif(Equation, Var, dependVar[,Ord])
⇒ expression

where the order Ord defaults to 1.

Computes the implicit derivative for
equations in which one variable is defined
implicitly in terms of another.

Indirection See #(), page 226.

inString() Catalog >
inString(srcString, subString[, Start]) ⇒
integer

Returns the character position in string
srcString at which the first occurrence of
string subString begins.

Start, if included, specifies the character
position within srcString where the search
begins. Default = 1 (the first character of
srcString).

If srcString does not contain subString or
Start is > the length of srcString, returns
zero.



int() Catalog >
int(Expr) ⇒ integer

int(List1) ⇒ list
int(Matrix1) ⇒ matrix

Returns the greatest integer that is less
than or equal to the argument. This
function is identical to floor().

The argument can be a real or a complex
number.

For a list or matrix, returns the greatest
integer of each of the elements.

intDiv() Catalog >
intDiv(Number1, Number2) ⇒ integer
intDiv(List1, List2) ⇒ list
intDiv(Matrix1,Matrix2) ⇒ matrix

Returns the signed integer part of
(Number1 ÷ Number2).

For lists and matrices, returns the signed
integer part of (argument 1 ÷ argument 2)
for each element pair.

integral See ∫(), page 221.

interpolate () Catalog >
interpolate(xValue, xList, yList,
yPrimeList) ⇒ list

This function does the following:

Differential equation:
y'=-3•y+6•t+5 and y(0)=5

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.
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interpolate () Catalog >
Given xList, yList=f(xList), and
yPrimeList=f'(xList) for some unknown
function f, a cubic interpolant is used to
approximate the function f at xValue. It is
assumed that xList is a list of
monotonically increasing or decreasing
numbers, but this function may return a
value even when it is not. This function
walks through xList looking for an interval
[xList[i], xList[i+1]] that contains xValue.
If it finds such an interval, it returns an
interpolated value for f(xValue); otherwise,
it returns undef.

xList, yList, and yPrimeList must be of
equal dimension ≥ 2 and contain
expressions that simplify to numbers.

xValue can be an undefined variable, a
number, or a list of numbers.

Use the interpolate() function to calculate the
function values for the xvaluelist:

invχ2() Catalog >
invχ2(Area,df)

invChi2(Area,df)

Computes the Inverse cumulative χ2 (chi-
square) probability function specified by
degree of freedom, df for a given Area
under the curve.

invF() Catalog >
invF(Area,dfNumer,dfDenom)

invF(Area,dfNumer,dfDenom)

computes the Inverse cumulative F
distribution function specified by dfNumer
and dfDenom for a given Area under the
curve.



invBinom() Catalog >
invBinom
(CumulativeProb,NumTrials,Prob,
OutputForm)⇒scalar or matrix

Inverse binomial. Given the number of trials
(NumTrials) and the probability of success
of each trial (Prob), this function returns
the minimum number of successes, k, such
that the value, k, is greater than or equal to
the given cumulative probability
(CumulativeProb).

OutputForm=0, displays result as a scalar
(default).

OutputForm=1, displays result as a matrix.

Example: Mary andKevin are playing a dice
game. Mary has to guess themaximum
number of times 6 shows up in 30 rolls. If the
number 6 shows up thatmany times or less,
Mary wins. Furthermore, the smaller the
number that she guesses, the greater her
winnings. What is the smallest number Mary
can guess if shewants the probability of
winning to be greater than77%?

invBinomN() Catalog >
invBinomN(CumulativeProb,Prob,
NumSuccess,OutputForm)⇒scalar or
matrix

Inverse binomial with respect to N. Given
the probability of success of each trial
(Prob), and the number of successes
(NumSuccess), this function returns the
minimum number of trials, N, such that the
value, N, is less than or equal to the given
cumulative probability (CumulativeProb).

OutputForm=0, displays result as a scalar
(default).

OutputForm=1, displays result as a matrix.

Example: Monique is practicing goal shots
for netball. She knows fromexperience that
her chance ofmaking any one shot is 70%.
She plans to practice until she scores 50
goals. Howmany shots must she attempt to
ensure that the probability ofmaking at least
50 goals is more than0.99?

invNorm() Catalog >
invNorm(Area[,μ[,σ]])

Computes the inverse cumulative normal
distribution function for a given Area under
the normal distribution curve specified by μ
and σ.

invt() Catalog >
invt(Area,df)
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invt() Catalog >
Computes the inverse cumulative student-t
probability function specified by degree of
freedom, df for a given Area under the
curve.

iPart() Catalog >
iPart(Number) ⇒ integer
iPart(List1) ⇒ list
iPart(Matrix1) ⇒ matrix

Returns the integer part of the argument.

For lists and matrices, returns the integer
part of each element.

The argument can be a real or a complex
number.

irr() Catalog >
irr(CF0,CFList [,CFFreq]) ⇒ value

Financial function that calculates internal
rate of return of an investment.

CF0 is the initial cash flow at time 0; it
must be a real number.

CFList is a list of cash flow amounts after
the initial cash flow CF0.

CFFreq is an optional list in which each
element specifies the frequency of
occurrence for a grouped (consecutive) cash
flow amount, which is the corresponding
element of CFList. The default is 1; if you
enter values, they must be positive integers
< 10,000.

Note: See alsomirr(), page 116.

isPrime() Catalog >
isPrime(Number) ⇒ Boolean constant
expression



isPrime() Catalog >
Returns true or false to indicate if number
is a whole number ≥ 2 that is evenly
divisible only by itself and 1.

If Number exceeds about 306 digits and has
no factors ≤1021, isPrime(Number) displays
an error message.

If you merely want to determine if Number
is prime, use isPrime() instead of factor(). It
is much faster, particularly if Number is not
prime and has a second-largest factor that
exceeds about five digits.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

Function to find the next prime after a
specifiednumber:

isVoid() Catalog >
isVoid(Var) ⇒ Boolean constant
expression
isVoid(Expr) ⇒ Boolean constant
expression
isVoid(List) ⇒ list of Boolean constant
expressions

Returns true or false to indicate if the
argument is a void data type.

For more information on void elements, see
page 236.
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L

Lbl Catalog >
Lbl labelName

Defines a label with the name labelName
within a function.

You can use a Goto labelName instruction
to transfer control to the instruction
immediately following the label.

labelName must meet the same naming
requirements as a variable name.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

lcm() Catalog >
lcm(Number1, Number2) ⇒ expression
lcm(List1, List2) ⇒ list
lcm(Matrix1,Matrix2) ⇒ matrix

Returns the least common multiple of the
two arguments. The lcm of two fractions is
the lcm of their numerators divided by the
gcd of their denominators. The lcm of
fractional floating-point numbers is their
product.

For two lists or matrices, returns the least
common multiples of the corresponding
elements.

left() Catalog >
left(sourceString[, Num]) ⇒ string

Returns the leftmost Num characters
contained in character string sourceString.

If you omit Num, returns all of
sourceString.
left(List1[, Num]) ⇒ list



left() Catalog >
Returns the leftmost Num elements
contained in List1.

If you omit Num, returns all of List1.
left(Comparison) ⇒ expression

Returns the left-hand side of an equation or
inequality.

libShortcut() Catalog >
libShortcut(LibNameString,
ShortcutNameString
[, LibPrivFlag]) ⇒ list of variables

Creates a variable group in the current
problem that contains references to all the
objects in the specified library document
libNameString. Also adds the group
members to the Variables menu. You can
then refer to each object using its
ShortcutNameString.

Set LibPrivFlag=0 to exclude private
library objects (default)
Set LibPrivFlag=1 to include private
library objects

To copy a variable group, see CopyVar on
page 29.
To delete a variable group, see DelVar on
page 49.

This example assumes a properly stored and
refreshed library document named linalg2
that contains objects definedas clearmat,
gauss1, andgauss2.

limit() or lim() Catalog >
limit(Expr1, Var, Point [,Direction]) ⇒
expression
limit(List1, Var, Point [, Direction]) ⇒
list
limit(Matrix1, Var, Point [, Direction]) ⇒
matrix

Returns the limit requested.

Note: See also Limit template, page 6.

Direction: negative=from left,
positive=from right, otherwise=both. (If
omitted, Direction defaults to both.)
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limit() or lim() Catalog >
Limits at positive ∞ and at negative ∞ are
always converted to one-sided limits from
the finite side.

Depending on the circumstances, limit()
returns itself or undef when it cannot
determine a unique limit. This does not
necessarily mean that a unique limit does
not exist. undef means that the result is
either an unknown number with finite or
infinite magnitude, or it is the entire set of
such numbers.

limit() uses methods such as L’Hopital’s
rule, so there are unique limits that it
cannot determine. If Expr1 contains
undefined variables other than Var, you
might have to constrain them to obtain a
more concise result.

Limits can be very sensitive to rounding
error. When possible, avoid the
Approximate setting of the Auto or
Approximate mode and approximate
numbers when computing limits.
Otherwise, limits that should be zero or
have infinite magnitude probably will not,
and limits that should have finite non-zero
magnitude might not.

LinRegBx Catalog >
LinRegBx X,Y[,[Freq][,Category,Include]]

Computes the linear regression y = a+b•x on
lists X and Y with frequency Freq. A
summary of results is stored in the
stat.results variable. (See page 177.)

All the lists must have equal dimension
except for Include.

X and Y are lists of independent and
dependent variables.



LinRegBx Catalog >
Freq is an optional list of frequency values.
Each element in Freq specifies the
frequency of occurrence for each
corresponding X and Y data point. The
default value is 1. All elements must be
integers ≥ 0.

Category is a list of category codes for the
corresponding X and Y data.

Include is a list of one or more of the
category codes. Only those data items
whose category code is included in this list
are included in the calculation.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output
variable Description

stat.RegEqn Regression Equation: a+b•x

stat.a, stat.b Regression coefficients

stat.r2 Coefficient of determination

stat.r Correlation coefficient

stat.Resid Residuals from the regression

stat.XReg List of data points in themodifiedX List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.YReg List of data points in themodifiedY List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.FreqReg List of frequencies corresponding to stat.XReg and stat.YReg

LinRegMx Catalog >
LinRegMx X,Y[,[Freq][,Category,Include]]

Computes the linear regression y = m•x+b on
lists X and Y with frequency Freq. A
summary of results is stored in the
stat.results variable. (See page 177.)

All the lists must have equal dimension
except for Include.

Alphabetical Listing 99



100 Alphabetical Listing

LinRegMx Catalog >
X and Y are lists of independent and
dependent variables.

Freq is an optional list of frequency values.
Each element in Freq specifies the
frequency of occurrence for each
corresponding X and Y data point. The
default value is 1. All elements must be
integers ≥ 0.

Category is a list of category codes for the
corresponding X and Y data.

Include is a list of one or more of the
category codes. Only those data items
whose category code is included in this list
are included in the calculation.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output
variable Description

stat.RegEqn Regression Equation: y =m•x+b

stat.m,
stat.b

Regression coefficients

stat.r2 Coefficient of determination

stat.r Correlation coefficient

stat.Resid Residuals from the regression

stat.XReg List of data points in themodifiedX List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.YReg List of data points in themodifiedY List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.FreqReg List of frequencies corresponding to stat.XReg and stat.YReg

LinRegtIntervals Catalog >
LinRegtIntervals X,Y[,F[,0[,CLev]]]

For Slope. Computes a level C confidence
interval for the slope.

LinRegtIntervals X,Y[,F[,1,Xval[,CLev]]]



LinRegtIntervals Catalog >
For Response. Computes a predicted y-value,
a level C prediction interval for a single
observation, and a level C confidence
interval for the mean response.

A summary of results is stored in the
stat.results variable. (See page 177.)

All the lists must have equal dimension.

X and Y are lists of independent and
dependent variables.

F is an optional list of frequency values.
Each element in F specifies the frequency of
occurrence for each corresponding X and Y
data point. The default value is 1. All
elements must be integers ≥ 0.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.RegEqn Regression Equation: a+b•x

stat.a, stat.b Regression coefficients

stat.df Degrees of freedom

stat.r2 Coefficient of determination

stat.r Correlation coefficient

stat.Resid Residuals from the regression

For Slope type only

Output variable Description

[stat.CLower, stat.CUpper] Confidence interval for the slope

stat.ME Confidence intervalmargin of error

stat.SESlope Standard error of slope

stat.s Standard error about the line

For Response type only

Output variable Description

[stat.CLower, stat.CUpper] Confidence interval for themean response

Alphabetical Listing 101



102 Alphabetical Listing

Output variable Description

stat.ME Confidence intervalmargin of error

stat.SE Standard error ofmean response

[stat.LowerPred,
stat.UpperPred]

Prediction interval for a single observation

stat.MEPred Prediction intervalmargin of error

stat.SEPred Standard error for prediction

stat.y a + b•XVal

LinRegtTest Catalog >
LinRegtTest X,Y[,Freq[,Hypoth]]

Computes a linear regression on the X and Y
lists and a t test on the value of slope β and
the correlation coefficient ρ for the equation
y=α+βx. It tests the null hypothesis H

0
:β=0

(equivalently, ρ=0) against one of three
alternative hypotheses.

All the lists must have equal dimension.

X and Y are lists of independent and
dependent variables.

Freq is an optional list of frequency values.
Each element in Freq specifies the
frequency of occurrence for each
corresponding X and Y data point. The
default value is 1. All elements must be
integers ≥ 0.

Hypoth is an optional value specifying one
of three alternative hypotheses against
which the null hypothesis (H

0
:β=ρ=0) will be

tested.

For H
a
: β≠0 and ρ≠0 (default), set Hypoth=0

For H
a
: β<0 and ρ<0, set Hypoth<0

For H
a
: β>0 and ρ>0, set Hypoth>0

A summary of results is stored in the
stat.results variable. (See page 177.)

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.



Output variable Description

stat.RegEqn Regressionequation: a + b•x

stat.t t-Statistic for significance test

stat.PVal Smallest level of significance atwhich the null hypothesis canbe rejected

stat.df Degrees of freedom

stat.a, stat.b Regression coefficients

stat.s Standard error about the line

stat.SESlope Standard error of slope

stat.r2 Coefficient of determination

stat.r Correlation coefficient

stat.Resid Residuals from the regression

linSolve() Catalog >
linSolve( SystemOfLinearEqns, Var1,
Var2, ...) ⇒ list

linSolve(LinearEqn1 and LinearEqn2 and
..., Var1, Var2, ...) ⇒ list

linSolve({LinearEqn1, LinearEqn2, ...},
Var1, Var2, ...) ⇒ list

linSolve(SystemOfLinearEqns, {Var1,
Var2, ...}) ⇒ list

linSolve(LinearEqn1 and LinearEqn2 and
..., {Var1, Var2, ...}) ⇒ list

linSolve({LinearEqn1, LinearEgn2, ...},
{Var1, Var2, ...}) ⇒ list

Returns a list of solutions for the variables
Var1, Var2, ...

The first argument must evaluate to a
system of linear equations or a single linear
equation. Otherwise, an argument error
occurs.

For example, evaluating linSolve(x=1
and x=2,x) produces an “Argument
Error” result.
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ΔList() Catalog >
ΔList(List1) ⇒ list

Note: You can insert this function from the
keyboard by typing deltaList(...).

Returns a list containing the differences
between consecutive elements in List1.
Each element of List1 is subtracted from
the next element of List1. The resulting list
is always one element shorter than the
original List1.

list►mat() Catalog >
list►mat(List [, elementsPerRow]) ⇒
matrix

Returns a matrix filled row-by-row with the
elements from List.

elementsPerRow, if included, specifies the
number of elements per row. Default is the
number of elements in List (one row).

If List does not fill the resulting matrix,
zeros are added.

Note: You can insert this function from the
computer keyboard by typing list@>mat
(...).

►ln Catalog >
Expr►ln⇒ expression

Causes the input Expr to be converted to an
expression containing only natural logs (ln).

Note: You can insert this operator from the
computer keyboard by typing @>ln.

ln() /u keys
ln(Expr1) ⇒ expression

ln(List1) ⇒ list
If complex formatmode is Real:



ln() /u keys
Returns the natural logarithm of the
argument.

For a list, returns the natural logarithms of
the elements.

If complex formatmode is Rectangular:

ln(squareMatrix1) ⇒ squareMatrix

Returns the matrix natural logarithm of
squareMatrix1. This is not the same as
calculating the natural logarithm of each
element. For information about the
calculation method, refer to cos() on.

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.

In Radian anglemode andRectangular
complex format:

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

LnReg Catalog >
LnReg X, Y[, [Freq] [, Category, Include]]

Computes the logarithmic regression y =
a+b•ln(x) on lists X and Y with frequency
Freq. A summary of results is stored in the
stat.results variable. (See page 177.)

All the lists must have equal dimension
except for Include.

X and Y are lists of independent and
dependent variables.

Freq is an optional list of frequency values.
Each element in Freq specifies the
frequency of occurrence for each
corresponding X and Y data point. The
default value is 1. All elements must be
integers ≥ 0.

Category is a list of category codes for the
corresponding X and Y data.

Alphabetical Listing 105



106 Alphabetical Listing

LnReg Catalog >
Include is a list of one or more of the
category codes. Only those data items
whose category code is included in this list
are included in the calculation.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output
variable Description

stat.RegEqn Regressionequation: a+b•ln(x)

stat.a, stat.b Regression coefficients

stat.r2 Coefficient of linear determination for transformeddata

stat.r Correlation coefficient for transformeddata (ln(x), y)

stat.Resid Residuals associatedwith the logarithmicmodel

stat.ResidTrans Residuals associatedwith linear fit of transformeddata

stat.XReg List of data points in themodifiedX List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.YReg List of data points in themodifiedY List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.FreqReg List of frequencies corresponding to stat.XReg and stat.YReg

Local Catalog >
Local Var1[, Var2] [, Var3] ...

Declares the specified vars as local
variables. Those variables exist only during
evaluation of a function and are deleted
when the function finishes execution.

Note: Local variables save memory because
they only exist temporarily. Also, they do
not disturb any existing global variable
values. Local variables must be used for For
loops and for temporarily saving values in a
multi-line function since modifications on
global variables are not allowed in a
function.



Local Catalog >
Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

Lock Catalog >
LockVar1[, Var2] [, Var3] ...
LockVar.

Locks the specified variables or variable
group. Locked variables cannot be modified
or deleted.

You cannot lock or unlock the system
variable Ans, and you cannot lock the
system variable groups stat. or tvm.

Note: The Lock command clears the
Undo/Redo history when applied to
unlocked variables.

See unLock, page 197, and getLockInfo(),
page 83.

log() /s keys
log(Expr1[,Expr2]) ⇒ expression

log(List1[,Expr2]) ⇒ list

Returns the base-Expr2 logarithm of the
first argument.

Note: See also Log template, page 2.

For a list, returns the base-Expr2 logarithm
of the elements.

If the second argument is omitted, 10 is
used as the base.

If complex formatmode is Real:

If complex formatmode is Rectangular:
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log() /s keys
log(squareMatrix1[,Expr]) ⇒
squareMatrix

Returns the matrix base-Expr logarithm of
squareMatrix1. This is not the same as
calculating the base-Expr logarithm of
each element. For information about the
calculation method, refer to cos().

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.

If the base argument is omitted, 10 is used
as base.

In Radian anglemode andRectangular
complex format:

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

►logbase Catalog >
Expr►logbase(Expr1) ⇒ expression

Causes the input Expression to be simplified
to an expression using base Expr1.

Note: You can insert this operator from the
computer keyboard by typing @>logbase
(...).

Logistic Catalog >
Logistic X, Y[, [Freq] [, Category, Include]]

Computes the logistic regression y = (c/
(1+a•e-bx)) on lists X and Y with frequency
Freq. A summary of results is stored in the
stat.results variable. (See page 177.)

All the lists must have equal dimension
except for Include.

X and Y are lists of independent and
dependent variables.

Freq is an optional list of frequency values.
Each element in Freq specifies the
frequency of occurrence for each
corresponding X and Y data point. The
default value is 1. All elements must be
integers ≥ 0.



Logistic Catalog >
Category is a list of category codes for the
corresponding X and Y data.

Include is a list of one or more of the
category codes. Only those data items
whose category code is included in this list
are included in the calculation.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output
variable Description

stat.RegEqn Regressionequation: c/(1+a•e-bx)

stat.a,
stat.b, stat.c

Regression coefficients

stat.Resid Residuals from the regression

stat.XReg List of data points in themodifiedX List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.YReg List of data points in themodifiedY List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.FreqReg List of frequencies corresponding to stat.XReg and stat.YReg

LogisticD Catalog >
LogisticD X, Y [, [Iterations] , [Freq] [,
Category, Include] ]

Computes the logistic regression y = (c/
(1+a•e-bx)+d) on lists X and Y with frequency
Freq, using a specified number of
Iterations. A summary of results is stored in
the stat.results variable. (See page 177.)

All the lists must have equal dimension
except for Include.

X and Y are lists of independent and
dependent variables.
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LogisticD Catalog >
Freq is an optional list of frequency values.
Each element in Freq specifies the
frequency of occurrence for each
corresponding X and Y data point. The
default value is 1. All elements must be
integers ≥ 0.

Category is a list of category codes for the
corresponding X and Y data.

Include is a list of one or more of the
category codes. Only those data items
whose category code is included in this list
are included in the calculation.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output
variable Description

stat.RegEqn Regressionequation: c/(1+a•e-bx)+d)

stat.a, stat.b,
stat.c, stat.d

Regression coefficients

stat.Resid Residuals from the regression

stat.XReg List of data points in themodifiedX List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.YReg List of data points in themodifiedY List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.FreqReg List of frequencies corresponding to stat.XReg and stat.YReg



Loop Catalog >
Loop
     Block
EndLoop

Repeatedly executes the statements in
Block. Note that the loop will be executed
endlessly, unless a Goto or Exit instruction
is executed within Block.

Block is a sequence of statements
separated with the “:” character.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

LU Catalog >
LU Matrix, lMatrix, uMatrix, pMatrix
[,Tol]

Calculates the Doolittle LU (lower-upper)
decomposition of a real or complex matrix.
The lower triangular matrix is stored in
lMatrix, the upper triangular matrix in
uMatrix, and the permutation matrix
(which describes the row swaps done
during the calculation) in pMatrix.

lMatrix•uMatrix = pMatrix•matrix

Optionally, any matrix element is treated as
zero if its absolute value is less than Tol.
This tolerance is used only if the matrix has
floating-point entries and does not contain
any symbolic variables that have not been
assigned a value. Otherwise, Tol is ignored.

• If you use/· or set the Auto or
Approximate mode to Approximate,
computations are done using floating-
point arithmetic.

• If Tol is omitted or not used, the default
tolerance is calculated as:
5E⁻14•max(dim(Matrix))•rowNorm
(Matrix)
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LU Catalog >
The LU factorization algorithm uses partial
pivoting with row interchanges.

M

mat►list() Catalog >
mat►list(Matrix) ⇒ list

Returns a list filled with the elements in
Matrix. The elements are copied from
Matrix row by row.

Note: You can insert this function from the
computer keyboard by typing mat@>list
(...).

max() Catalog >
max(Expr1, Expr2) ⇒ expression

max(List1, List2) ⇒ list
max(Matrix1,Matrix2) ⇒ matrix

Returns the maximum of the two
arguments. If the arguments are two lists
or matrices, returns a list or matrix
containing the maximum value of each pair
of corresponding elements.

max(List) ⇒ expression

Returns the maximum element in list.
max(Matrix1) ⇒ matrix

Returns a row vector containing the
maximum element of each column in
Matrix1.



max() Catalog >
Empty (void) elements are ignored. For
more information on empty elements, see
page 236.

Note: See also fMax() and min().

mean() Catalog >
mean(List[, freqList]) ⇒ expression

Returns the mean of the elements in List.

Each freqList element counts the number
of consecutive occurrences of the
corresponding element in List.
mean(Matrix1[, freqMatrix]) ⇒ matrix

Returns a row vector of the means of all
the columns inMatrix1.

Each freqMatrix element counts the
number of consecutive occurrences of the
corresponding element inMatrix1.

Empty (void) elements are ignored. For
more information on empty elements, see
page 236.

In Rectangular vector format:

median() Catalog >
median(List[, freqList]) ⇒ expression

Returns the median of the elements in List.

Each freqList element counts the number
of consecutive occurrences of the
corresponding element in List.
median(Matrix1[, freqMatrix]) ⇒ matrix

Returns a row vector containing the
medians of the columns inMatrix1.

Each freqMatrix element counts the
number of consecutive occurrences of the
corresponding element inMatrix1.
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median() Catalog >
Notes:

• All entries in the list or matrix must
simplify to numbers.

• Empty (void) elements in the list or
matrix are ignored. For more information
on empty elements, see page 236.

MedMed Catalog >
MedMed X,Y [, Freq] [, Category, Include]]

Computes the median-median line y =
(m•x+b) on lists X and Y with frequency
Freq. A summary of results is stored in the
stat.results variable. (See page 177.)

All the lists must have equal dimension
except for Include.

X and Y are lists of independent and
dependent variables.

Freq is an optional list of frequency values.
Each element in Freq specifies the
frequency of occurrence for each
corresponding X and Y data point. The
default value is 1. All elements must be
integers ≥ 0.

Category is a list of category codes for the
corresponding X and Y data.

Include is a list of one or more of the
category codes. Only those data items
whose category code is included in this list
are included in the calculation.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output
variable Description

stat.RegEqn Median-median line equation: m•x+b

stat.m,
stat.b

Model coefficients



Output
variable Description

stat.Resid Residuals from themedian-median line

stat.XReg List of data points in themodifiedX List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.YReg List of data points in themodifiedY List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.FreqReg List of frequencies corresponding to stat.XReg and stat.YReg

mid() Catalog >
mid(sourceString, Start[, Count]) ⇒
string

Returns Count characters from character
string sourceString, beginning with
character number Start.

If Count is omitted or is greater than the
dimension of sourceString, returns all
characters from sourceString, beginning
with character number Start.

Count must be ≥ 0. If Count = 0, returns an
empty string.

mid(sourceList, Start [, Count]) ⇒ list

Returns Count elements from sourceList,
beginning with element number Start.

If Count is omitted or is greater than the
dimension of sourceList, returns all
elements from sourceList, beginning with
element number Start.

Count must be ≥ 0. If Count = 0, returns an
empty list.

mid(sourceStringList, Start[, Count]) ⇒
list

Returns Count strings from the list of
strings sourceStringList, beginning with
element number Start.
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min() Catalog >
min(Expr1, Expr2) ⇒ expression

min(List1, List2) ⇒ list
min(Matrix1, Matrix2) ⇒ matrix

Returns the minimum of the two
arguments. If the arguments are two lists
or matrices, returns a list or matrix
containing the minimum value of each pair
of corresponding elements.

min(List) ⇒ expression

Returns the minimum element of List.
min(Matrix1) ⇒ matrix

Returns a row vector containing the
minimum element of each column in
Matrix1.

Note: See also fMin() andmax().

mirr() Catalog >
mirr
(financeRate,reinvestRate,CF0,CFList
[,CFFreq])

Financial function that returns the modified
internal rate of return of an investment.

financeRate is the interest rate that you
pay on the cash flow amounts.

reinvestRate is the interest rate at which
the cash flows are reinvested.

CF0 is the initial cash flow at time 0; it
must be a real number.

CFList is a list of cash flow amounts after
the initial cash flow CF0.

CFFreq is an optional list in which each
element specifies the frequency of
occurrence for a grouped (consecutive) cash
flow amount, which is the corresponding
element of CFList. The default is 1; if you
enter values, they must be positive integers
< 10,000.



mirr() Catalog >
Note: See also irr(), page 94.

mod() Catalog >
mod(Expr1, Expr2) ⇒ expression

mod(List1, List2) ⇒ list
mod(Matrix1,Matrix2) ⇒ matrix

Returns the first argument modulo the
second argument as defined by the
identities:

mod(x,0) = x
mod(x,y) = x − y floor(x/y)

When the second argument is non-zero, the
result is periodic in that argument. The
result is either zero or has the same sign as
the second argument.

If the arguments are two lists or two
matrices, returns a list or matrix containing
the modulo of each pair of corresponding
elements.

Note: See also remain(), page 150

mRow() Catalog >
mRow(Expr,Matrix1, Index) ⇒ matrix

Returns a copy of Matrix1 with each
element in row Index of Matrix1multiplied
by Expr.

mRowAdd() Catalog >
mRowAdd(Expr,Matrix1, Index1, Index2)
⇒ matrix

Returns a copy of Matrix1 with each
element in row Index2 of Matrix1 replaced
with:

Expr • row Index1 + row Index2
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MultReg Catalog >
MultReg Y, X1[,X2[,X3,…[,X10]]]

Calculates multiple linear regression of list Y
on lists X1, X2, …, X10. A summary of
results is stored in the stat.results variable.
(See page 177.)

All the lists must have equal dimension.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.RegEqn Regression Equation: b0+b1•x1+b2•x2+ ...

stat.b0, stat.b1, ... Regression coefficients

stat.R2 Coefficient ofmultiple determination

stat.yList yList = b0+b1•x1+ ...

stat.Resid Residuals from the regression

MultRegIntervals Catalog >
MultRegIntervals Y, X1[, X2[, X3,…[,
X10]]], XValList[, CLevel]

Computes a predicted y-value, a level C
prediction interval for a single observation,
and a level C confidence interval for the
mean response.

A summary of results is stored in the
stat.results variable. (See page 177.)

All the lists must have equal dimension.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.RegEqn Regression Equation: b0+b1•x1+b2•x2+ ...

stat.y A point estimate: y = b0 + b1 • xl + ... for XValList

stat.dfError Error degrees of freedom



Output variable Description

stat.CLower, stat.CUpper Confidence interval for a mean response

stat.ME Confidence intervalmargin of error

stat.SE Standard error ofmean response

stat.LowerPred,
stat.UpperrPred

Prediction interval for a single observation

stat.MEPred Prediction intervalmargin of error

stat.SEPred Standard error for prediction

stat.bList List of regression coefficients, {b0,b1,b2,...}

stat.Resid Residuals from the regression

MultRegTests Catalog >
MultRegTests Y, X1[, X2[, X3,…[, X10]]]

Multiple linear regression test computes a
multiple linear regression on the given data
and provides the global F test statistic and t
test statistics for the coefficients.

A summary of results is stored in the
stat.results variable. (See page 177.)

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Outputs

Output
variable Description

stat.RegEqn Regression Equation: b0+b1•x1+b2•x2+ ...

stat.F GlobalF test statistic

stat.PVal P-value associatedwith globalF statistic

stat.R2 Coefficient ofmultiple determination

stat.AdjR2 Adjusted coefficient ofmultiple determination

stat.s Standarddeviationof the error

stat.DW Durbin-Watson statistic; used to determinewhether first-order auto correlation is
present in themodel

Alphabetical Listing 119



120 Alphabetical Listing

Output
variable Description

stat.dfReg Regressiondegrees of freedom

stat.SSReg Regression sumof squares

stat.MSReg Regressionmean square

stat.dfError Error degrees of freedom

stat.SSError Error sumof squares

stat.MSError Error mean square

stat.bList {b0,b1,...} List of coefficients

stat.tList List of t statistics, one for each coefficient in the bList

stat.PList List P-values for each t statistic

stat.SEList List of standard errors for coefficients in bList

stat.yList yList = b0+b1•x1+ . . .

stat.Resid Residuals from the regression

stat.sResid Standardized residuals; obtainedby dividing a residual by its standarddeviation

stat.CookDist Cook’s distance; measure of the influence of anobservationbasedon the residual
and leverage

stat.Leverage Measure of how far the values of the independent variable are from their mean
values

N

nand /= keys
BooleanExpr1 nand BooleanExpr2 returns
Boolean expression
BooleanList1 nand BooleanList2 returns
Boolean list
BooleanMatrix1 nand BooleanMatrix2
returns Boolean matrix

Returns the negation of a logical and
operation on the two arguments. Returns
true, false, or a simplified form of the
equation.

For lists and matrices, returns comparisons
element by element.



nand /= keys
Integer1 nand Integer2⇒ integer

Compares two real integers bit-by-bit using
a nand operation. Internally, both integers
are converted to signed, 64-bit binary
numbers. When corresponding bits are
compared, the result is 1 if both bits are 1;
otherwise, the result is 0. The returned
value represents the bit results, and is
displayed according to the Base mode.

You can enter the integers in any number
base. For a binary or hexadecimal entry, you
must use the 0b or 0h prefix, respectively.
Without a prefix, integers are treated as
decimal (base 10).

nCr() Catalog >
nCr(Expr1, Expr2) ⇒ expression

For integer Expr1 and Expr2 with Expr1 ≥
Expr2 ≥ 0, nCr() is the number of
combinations of Expr1 things taken Expr2
at a time. (This is also known as a binomial
coefficient.) Both arguments can be
integers or symbolic expressions.

nCr(Expr, 0) ⇒ 1

nCr(Expr, negInteger) ⇒ 0

nCr(Expr, posInteger) ⇒ Expr•(Expr−1) ...
(Expr−posInteger+1) / posInteger!

nCr(Expr, nonInteger) ⇒ expression! /
((Expr−nonInteger)!•nonInteger!)

nCr(List1, List2) ⇒ list

Returns a list of combinations based on the
corresponding element pairs in the two
lists. The arguments must be the same size
list.

nCr(Matrix1,Matrix2) ⇒ matrix
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nCr() Catalog >
Returns a matrix of combinations based on
the corresponding element pairs in the two
matrices. The arguments must be the same
size matrix.

nDerivative() Catalog >
nDerivative(Expr1,Var=Value[,Order])
⇒ value

nDerivative(Expr1,Var[,Order])
|Var=Value⇒ value

Returns the numerical derivative calculated
using auto differentiation methods.

When Value is specified, it overrides any
prior variable assignment or any current “|”
substitution for the variable.

Order of the derivative must be 1 or 2.

newList() Catalog >
newList(numElements) ⇒ list

Returns a list with a dimension of
numElements. Each element is zero.

newMat() Catalog >
newMat(numRows, numColumns) ⇒
matrix

Returns a matrix of zeros with the
dimension numRows by numColumns.

nfMax() Catalog >
nfMax(Expr, Var) ⇒ value
nfMax(Expr, Var, lowBound) ⇒ value
nfMax(Expr, Var, lowBound, upBound) ⇒
value
nfMax(Expr, Var) |
lowBound≤Var≤upBound⇒ value



nfMax() Catalog >
Returns a candidate numerical value of
variable Var where the local maximum of
Expr occurs.

If you supply lowBound and upBound, the
function looks in the closed interval
[lowBound,upBound] for the local
maximum.

Note: See also fMax() and d().

nfMin() Catalog >
nfMin(Expr, Var) ⇒ value
nfMin(Expr, Var, lowBound) ⇒ value
nfMin(Expr, Var, lowBound, upBound) ⇒
value
nfMin(Expr, Var) |
lowBound≤Var≤upBound⇒ value

Returns a candidate numerical value of
variable Var where the local minimum of
Expr occurs.

If you supply lowBound and upBound, the
function looks in the closed interval
[lowBound,upBound] for the local
minimum.

Note: See also fMin() and d().

nInt() Catalog >
nInt(Expr1, Var, Lower, Upper) ⇒
expression

If the integrand Expr1 contains no variable
other than Var, and if Lower andUpper
are constants, positive ∞, or negative ∞,
then nInt() returns an approximation of ∫
(Expr1, Var, Lower, Upper). This
approximation is a weighted average of
some sample values of the integrand in the
interval Lower<Var<Upper.

Alphabetical Listing 123



124 Alphabetical Listing

nInt() Catalog >
The goal is six significant digits. The
adaptive algorithm terminates when it
seems likely that the goal has been
achieved, or when it seems unlikely that
additional samples will yield a worthwhile
improvement.

A warning is displayed (“Questionable
accuracy”) when it seems that the goal has
not been achieved.

Nest nInt() to do multiple numeric
integration. Integration limits can depend
on integration variables outside them.

Note: See also ∫(), page 221.

nom() Catalog >
nom(effectiveRate,CpY) ⇒ value

Financial function that converts the annual
effective interest rate effectiveRate to a
nominal rate, given CpY as the number of
compounding periods per year.

effectiveRate must be a real number, and
CpY must be a real number > 0.

Note: See also eff(), page 58.

nor /= keys
BooleanExpr1 nor BooleanExpr2 returns
Boolean expression
BooleanList1 nor BooleanList2 returns
Boolean list
BooleanMatrix1 nor BooleanMatrix2
returns Boolean matrix

Returns the negation of a logical or
operation on the two arguments. Returns
true, false, or a simplified form of the
equation.

For lists and matrices, returns comparisons
element by element.



nor /= keys
Integer1 nor Integer2⇒ integer

Compares two real integers bit-by-bit using
a nor operation. Internally, both integers
are converted to signed, 64-bit binary
numbers. When corresponding bits are
compared, the result is 1 if both bits are 1;
otherwise, the result is 0. The returned
value represents the bit results, and is
displayed according to the Base mode.

You can enter the integers in any number
base. For a binary or hexadecimal entry, you
must use the 0b or 0h prefix, respectively.
Without a prefix, integers are treated as
decimal (base 10).

norm() Catalog >
norm(Matrix) ⇒ expression

norm(Vector) ⇒ expression

Returns the Frobenius norm.

normalLine() Catalog >
normalLine(Expr1,Var,Point) ⇒
expression

normalLine(Expr1,Var=Point) ⇒
expression

Returns the normal line to the curve
represented by Expr1 at the point specified
in Var=Point.

Make sure that the independent variable is
not defined. For example, If f1(x):=5 and
x:=3, then normalLine(f1(x),x,2) returns
“false.”
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normCdf() Catalog >
normCdf(lowBound,upBound[,μ[,σ]]) ⇒
number if lowBound and upBound are
numbers, list if lowBound and upBound are
lists

Computes the normal distribution probability
between lowBound and upBound for the
specified μ (default=0) and σ (default=1).

For P(X ≤ upBound), set lowBound = ⁻∞.

normPdf() Catalog >
normPdf(XVal[,μ[,σ]]) ⇒ number if XVal is
a number, list if XVal is a list

Computes the probability density function
for the normal distribution at a specified
XVal value for the specified μ and σ.

not Catalog >
not BooleanExpr⇒ Boolean expression

Returns true, false, or a simplified form of
the argument.

not Integer1⇒ integer

Returns the one’s complement of a real
integer. Internally, Integer1 is converted to
a signed, 64-bit binary number. The value of
each bit is flipped (0 becomes 1, and vice
versa) for the one’s complement. Results
are displayed according to the Base mode.

You can enter the integer in any number
base. For a binary or hexadecimal entry, you
must use the 0b or 0h prefix, respectively.
Without a prefix, the integer is treated as
decimal (base 10).

If you enter a decimal integer that is too
large for a signed, 64-bit binary form, a
symmetric modulo operation is used to
bring the value into the appropriate range.
For more information, see►Base2, page
17.

InHex basemode:

Important: Zero, not the letter O.

In Bin basemode:

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

Note: A binary entry canhave up to 64 digits
(not counting the 0bprefix). A hexadecimal
entry canhave up to 16 digits.



nPr() Catalog >
nPr(Expr1, Expr2) ⇒ expression

For integer Expr1 and Expr2 with Expr1 ≥
Expr2 ≥ 0, nPr() is the number of
permutations of Expr1 things taken Expr2
at a time. Both arguments can be integers
or symbolic expressions.

nPr(Expr, 0⇒ 1

nPr(Expr, negInteger) ⇒ 1 / ((Expr+1)•
(Expr+2) ... (expression−negInteger))

nPr(Expr, posInteger) ⇒ Expr•(Expr−1) ...
(Expr−posInteger+1)

nPr(Expr, nonInteger) ⇒ Expr! /
(Expr−nonInteger)!
nPr(List1, List2) ⇒ list

Returns a list of permutations based on the
corresponding element pairs in the two
lists. The arguments must be the same size
list.

nPr(Matrix1,Matrix2) ⇒ matrix

Returns a matrix of permutations based on
the corresponding element pairs in the two
matrices. The arguments must be the same
size matrix.

npv() Catalog >
npv(InterestRate,CFO,CFList[,CFFreq])

Financial function that calculates net
present value; the sum of the present
values for the cash inflows and outflows. A
positive result for npv indicates a profitable
investment.

InterestRate is the rate by which to
discount the cash flows (the cost of money)
over one period.

CF0 is the initial cash flow at time 0; it
must be a real number.

CFList is a list of cash flow amounts after
the initial cash flow CF0.
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npv() Catalog >
CFFreq is a list in which each element
specifies the frequency of occurrence for a
grouped (consecutive) cash flow amount,
which is the corresponding element of
CFList. The default is 1; if you enter
values, they must be positive integers <
10,000.

nSolve() Catalog >
nSolve(Equation,Var[=Guess]) ⇒ number
or error_string

nSolve(Equation,Var[=Guess],lowBound)
⇒ number or error_string

nSolve(Equation,Var
[=Guess],lowBound,upBound) ⇒ number
or error_string

nSolve(Equation,Var[=Guess]) |
lowBound≤Var≤upBound⇒ number or
error_string

Iteratively searches for one approximate
real numeric solution to Equation for its
one variable. Specify the variable as:

variable
– or –
variable = real number

For example, x is valid and so is x=3.

Note: If there aremultiple solutions, you can
use a guess to help find a particular solution.

nSolve() is often much faster than solve() or
zeros(), particularly if the “|” operator is
used to constrain the search to a small
interval containing exactly one simple
solution.

nSolve() attempts to determine either one
point where the residual is zero or two
relatively close points where the residual
has opposite signs and the magnitude of
the residual is not excessive. If it cannot
achieve this using a modest number of
sample points, it returns the string “no
solution found.”



nSolve() Catalog >
Note: See also cSolve(), cZeros(), solve(),
and zeros().

O

OneVar Catalog >
OneVar [1,]X[,[Freq][,Category,Include]]

OneVar [n,]X1,X2[X3[,…[,X20]]]

Calculates 1-variable statistics on up to 20
lists. A summary of results is stored in the
stat.results variable. (See page 177.)

All the lists must have equal dimension
except for Include.

Freq is an optional list of frequency values.
Each element in Freq specifies the
frequency of occurrence for each
corresponding X and Y data point. The
default value is 1. All elements must be
integers ≥ 0.

Category is a list of numeric category codes
for the corresponding X values.

Include is a list of one or more of the
category codes. Only those data items
whose category code is included in this list
are included in the calculation.

An empty (void) element in any of the lists
X, Freq, or Category results in a void for
the corresponding element of all those lists.
An empty element in any of the lists X1
through X20 results in a void for the
corresponding element of all those lists. For
more information on empty elements, see
page 236.

Output variable Description

stat.v Meanof x values

stat.Σx Sumof x values

stat.Σx2 Sumof x2 values
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Output variable Description

stat.sx Sample standarddeviationof x

stat.σx Population standarddeviationof x

stat.n Number of data points

stat.MinX Minimumof x values

stat.Q1X 1stQuartile of x

stat.MedianX Medianof x

stat.Q3X 3rdQuartile of x

stat.MaxX Maximumof x values

stat.SSX Sumof squares of deviations from themeanof x

or Catalog >
BooleanExpr1 or BooleanExpr2 returns
Boolean expression
BooleanList1 or BooleanList2 returns
Boolean list
BooleanMatrix1 or BooleanMatrix2
returns Boolean matrix

Returns true or false or a simplified form of
the original entry.

Returns true if either or both expressions
simplify to true. Returns false only if both
expressions evaluate to false.

Note: See xor.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

Integer1 or Integer2⇒ integer InHex basemode:

Important: Zero, not the letter O.

In Bin basemode:



or Catalog >
Compares two real integers bit-by-bit using
an or operation. Internally, both integers
are converted to signed, 64-bit binary
numbers. When corresponding bits are
compared, the result is 1 if either bit is 1;
the result is 0 only if both bits are 0. The
returned value represents the bit results,
and is displayed according to the Base
mode.

You can enter the integers in any number
base. For a binary or hexadecimal entry, you
must use the 0b or 0h prefix, respectively.
Without a prefix, integers are treated as
decimal (base 10).

If you enter a decimal integer that is too
large for a signed, 64-bit binary form, a
symmetric modulo operation is used to
bring the value into the appropriate range.
For more information, see►Base2, page
17.

Note: See xor.

Note: A binary entry canhave up to 64 digits
(not counting the 0bprefix). A hexadecimal
entry canhave up to 16 digits.

ord() Catalog >
ord(String) ⇒ integer
ord(List1) ⇒ list

Returns the numeric code of the first
character in character string String, or a list
of the first characters of each list element.

P

P►Rx() Catalog >
P►Rx(rExpr, θExpr) ⇒ expression
P►Rx(rList, θList) ⇒ list
P►Rx(rMatrix, θMatrix) ⇒ matrix

Returns the equivalent x-coordinate of the
(r, θ) pair.

In Radian anglemode:
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P►Rx() Catalog >
Note: The θ argument is interpreted as
either a degree, gradian or radian angle,
according to the current angle mode. If the
argument is an expression, you can use °, G,
or r to override the angle mode setting
temporarily.

Note: You can insert this function from the
computer keyboard by typing P@>Rx(...).

P►Ry() Catalog >
P►Ry(rExpr, θExpr) ⇒ expression

P►Ry(rList, θList) ⇒ list
P►Ry(rMatrix, θMatrix) ⇒ matrix

Returns the equivalent y-coordinate of the
(r, θ) pair.

Note: The θ argument is interpreted as
either a degree, radian or gradian angle,
according to the current angle mode. If the
argument is an expression, you can use °, G,
or r to override the angle mode setting
temporarily.

Note: You can insert this function from the
computer keyboard by typing P@>Ry(...).

In Radian anglemode:

PassErr Catalog >
PassErr

Passes an error to the next level.

If system variable errCode is zero, PassErr
does not do anything.

The Else clause of the Try...Else...EndTry
block should use ClrErr or PassErr. If the
error is to be processed or ignored, use
ClrErr. If what to do with the error is not
known, use PassErr to send it to the next
error handler. If there are no more pending
Try...Else...EndTry error handlers, the error
dialog box will be displayed as normal.

For anexample of PassErr, See Example 2
under the Try command, page 191.



PassErr Catalog >
Note: See also ClrErr, page 25, and Try, page
191.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product guidebook.

piecewise() Catalog >
piecewise(Expr1[, Cond1[, Expr2 [, Cond2
[, … ]]]])

Returns definitions for a piecewise function
in the form of a list. You can also create
piecewise definitions by using a template.

Note: See also Piecewise template, page 3.

poissCdf() Catalog >
poissCdf(λ,lowBound,upBound) ⇒ number
if lowBound and upBound are numbers, list
if lowBound and upBound are lists

poissCdf(λ,upBound)for P(0≤X≤upBound) ⇒
number if upBound is a number, list if
upBound is a list

Computes a cumulative probability for the
discrete Poisson distribution with specified
mean λ.

For P(X ≤ upBound), set lowBound=0

poissPdf() Catalog >
poissPdf(λ,XVal) ⇒ number if XVal is a
number, list if XVal is a list

Computes a probability for the discrete
Poisson distribution with the specified mean
λ.
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►Polar Catalog >
Vector►Polar

Note: You can insert this operator from the
computer keyboard by typing @>Polar.

Displays vector in polar form [r∠θ]. The
vector must be of dimension 2 and can be a
row or a column.

Note:►Polar is a display-format
instruction, not a conversion function. You
can use it only at the end of an entry line,
and it does not update ans.

Note: See also►Rect, page 147.

complexValue►Polar

Displays complexVector in polar form.

• Degree angle mode returns (r∠θ).
• Radian angle mode returns reiθ.

complexValue can have any complex form.
However, an reiθ entry causes an error in
Degree angle mode.

Note: You must use the parentheses for an
(r∠θ) polar entry.

In Radian anglemode:

InGradian anglemode:

InDegree anglemode:

polyCoeffs() Catalog >
polyCoeffs(Poly [,Var]) ⇒ list

Returns a list of the coefficients of
polynomial Poly with respect to variable
Var.

Poly must be a polynomial expression in
Var. We recommend that you do not omit
Var unless Poly is an expression in a single
variable.

Expands the polynomial and selects x for the
omittedVar.



polyCoeffs() Catalog >

polyDegree() Catalog >
polyDegree(Poly [,Var]) ⇒ value

Returns the degree of polynomial
expression Poly with respect to variable
Var. If you omit Var, the polyDegree()
function selects a default from the
variables contained in the polynomial Poly.

Poly must be a polynomial expression in
Var. We recommend that you do not omit
Var unless Poly is an expression in a single
variable.

Constant polynomials

The degree canbe extractedeven though
the coefficients cannot. This is because the
degree canbe extractedwithout expanding
the polynomial.

polyEval() Catalog >
polyEval(List1, Expr1) ⇒ expression
polyEval(List1, List2) ⇒ expression

Interprets the first argument as the
coefficient of a descending-degree
polynomial, and returns the polynomial
evaluated for the value of the second
argument.
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polyGcd() Catalog >
polyGcd(Expr1,Expr2) ⇒ expression

Returns greatest common divisor of the
two arguments.

Expr1 and Expr2must be polynomial
expressions.

List, matrix, and Boolean arguments are not
allowed.

polyQuotient() Catalog >
polyQuotient(Poly1,Poly2 [,Var]) ⇒
expression

Returns the quotient of polynomial Poly1
divided by polynomial Poly2 with respect to
the specified variable Var.

Poly1 and Poly2must be polynomial
expressions in Var. We recommend that
you do not omit Var unless Poly1 and
Poly2 are expressions in the same single
variable.

polyRemainder() Catalog >
polyRemainder(Poly1,Poly2 [,Var]) ⇒
expression

Returns the remainder of polynomial Poly1
divided by polynomial Poly2 with respect to
the specified variable Var.

Poly1 and Poly2must be polynomial
expressions in Var. We recommend that
you do not omit Var unless Poly1 and
Poly2 are expressions in the same single
variable.



polyRemainder() Catalog >

polyRoots() Catalog >
polyRoots(Poly,Var) ⇒ list

polyRoots(ListOfCoeffs) ⇒ list

The first syntax, polyRoots(Poly,Var),
returns a list of real roots of polynomial
Poly with respect to variable Var. If no real
roots exist, returns an empty list: { }.

Poly must be a polynomial in one variable.

The second syntax, polyRoots
(ListOfCoeffs), returns a list of real roots
for the coefficients in ListOfCoeffs.

Note: See also cPolyRoots(), page 36.

PowerReg Catalog >
PowerReg X,Y[, Freq][, Category, Include]]

Computes the power regressiony = (a•(x)b)
on lists X and Y with frequency Freq. A
summary of results is stored in the
stat.results variable. (See page 177.)

All the lists must have equal dimension
except for Include.

X and Y are lists of independent and
dependent variables.

Freq is an optional list of frequency values.
Each element in Freq specifies the
frequency of occurrence for each
corresponding X and Y data point. The
default value is 1. All elements must be
integers ≥ 0.
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PowerReg Catalog >
Category is a list of category codes for the
corresponding X and Y data.

Include is a list of one or more of the
category codes. Only those data items
whose category code is included in this list
are included in the calculation.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output
variable Description

stat.RegEqn Regressionequation: a•(x)b

stat.a, stat.b Regression coefficients

stat.r2 Coefficient of linear determination for transformeddata

stat.r Correlation coefficient for transformeddata (ln(x), ln(y))

stat.Resid Residuals associatedwith the power model

stat.ResidTrans Residuals associatedwith linear fit of transformeddata

stat.XReg List of data points in themodifiedX List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.YReg List of data points in themodifiedY List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.FreqReg List of frequencies corresponding to stat.XReg and stat.YReg

Prgm Catalog >
Prgm
     Block
EndPrgm

Template for creating a user-defined
program. Must be used with the Define,
Define LibPub, or Define LibPriv command.

Block can be a single statement, a series
of statements separated with the “:”
character, or a series of statements on
separate lines.

Calculate GCDanddisplay intermediate
results.



Prgm Catalog >
Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

prodSeq() See Π (), page 223.

Product (PI) See Π (), page 223.

product() Catalog >
product(List[, Start[, End]]) ⇒ expression

Returns the product of the elements
contained in List. Start and End are
optional. They specify a range of elements.

product(Matrix1[, Start[, End]]) ⇒ matrix

Returns a row vector containing the
products of the elements in the columns of
Matrix1. Start and end are optional. They
specify a range of rows.

Empty (void) elements are ignored. For
more information on empty elements, see
page 236.

propFrac() Catalog >
propFrac(Expr1[, Var]) ⇒ expression

propFrac(rational_number) returns
rational_number as the sum of an integer
and a fraction having the same sign and a
greater denominator magnitude than
numerator magnitude.
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propFrac() Catalog >
propFrac(rational_expression,Var) returns
the sum of proper ratios and a polynomial
with respect to Var. The degree of Var in
the denominator exceeds the degree of Var
in the numerator in each proper ratio.
Similar powers of Var are collected. The
terms and their factors are sorted with Var
as the main variable.

If Var is omitted, a proper fraction
expansion is done with respect to the most
main variable. The coefficients of the
polynomial part are then made proper with
respect to their most main variable first
and so on.

For rational expressions, propFrac() is a
faster but less extreme alternative to
expand().

You can use the propFrac() function to
represent mixed fractions and demonstrate
addition and subtraction of mixed fractions.

Q

QR Catalog >
QR Matrix, qMatrix, rMatrix[, Tol]

Calculates the Householder QR factorization
of a real or complex matrix. The resulting Q
and R matrices are stored to the specified
Matrix. The Q matrix is unitary. The R
matrix is upper triangular.

Optionally, any matrix element is treated as
zero if its absolute value is less than Tol.
This tolerance is used only if the matrix has
floating-point entries and does not contain
any symbolic variables that have not been
assigned a value. Otherwise, Tol is ignored.

• If you use/· or set the Auto or
Approximate mode to Approximate,

The floating-point number (9.) inm1 causes
results to be calculated in floating-point
form.



QR Catalog >
computations are done using floating-
point arithmetic.

• If Tol is omitted or not used, the default
tolerance is calculated as:
5E−14 •max(dim(Matrix)) •rowNorm
(Matrix)

The QR factorization is computed
numerically using Householder
transformations. The symbolic solution is
computed using Gram-Schmidt. The
columns in qMatName are the orthonormal
basis vectors that span the space defined by
matrix.

QuadReg Catalog >
QuadReg X,Y[, Freq][, Category, Include]]

Computes the quadratic polynomial
regression y=a•x2+b•x+c on lists X and Y
with frequency Freq. A summary of results
is stored in the stat.results variable. (See
page 177.)

All the lists must have equal dimension
except for Include.

X and Y are lists of independent and
dependent variables.

Freq is an optional list of frequency values.
Each element in Freq specifies the
frequency of occurrence for each
corresponding X and Y data point. The
default value is 1. All elements must be
integers ≥ 0.

Category is a list of category codes for the
corresponding X and Y data.
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QuadReg Catalog >
Include is a list of one or more of the
category codes. Only those data items
whose category code is included in this list
are included in the calculation.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output
variable

Description

stat.RegEqn Regressionequation: a•x2+b•x+c

stat.a,
stat.b, stat.c

Regression coefficients

stat.R2 Coefficient of determination

stat.Resid Residuals from the regression

stat.XReg List of data points in themodifiedX List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.YReg List of data points in themodifiedY List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.FreqReg List of frequencies corresponding to stat.XReg and stat.YReg

QuartReg Catalog >
QuartReg X,Y[, Freq][, Category, Include]]

Computes the quartic polynomial regression
y = a•x4+b•x3+c• x2+d•x+e on lists X and Y
with frequency Freq. A summary of results
is stored in the stat.results variable. (See
page 177.)

All the lists must have equal dimension
except for Include.

X and Y are lists of independent and
dependent variables.

Freq is an optional list of frequency values.
Each element in Freq specifies the
frequency of occurrence for each
corresponding X and Y data point. The
default value is 1. All elements must be
integers ≥ 0.



QuartReg Catalog >
Category is a list of category codes for the
corresponding X and Y data.

Include is a list of one or more of the
category codes. Only those data items
whose category code is included in this list
are included in the calculation.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.RegEqn Regressionequation: a•x4+b•x3+c• x2+d•x+e

stat.a, stat.b,
stat.c, stat.d,
stat.e

Regression coefficients

stat.R2 Coefficient of determination

stat.Resid Residuals from the regression

stat.XReg List of data points in themodifiedX List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.YReg List of data points in themodifiedY List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.FreqReg List of frequencies corresponding to stat.XReg and stat.YReg

R

R►Pθ() Catalog >
R►Pθ (xExpr, yExpr) ⇒ expression

R►Pθ (xList, yList) ⇒ list
R►Pθ (xMatrix, yMatrix) ⇒ matrix

Returns the equivalent θ-coordinate of the
(x,y) pair arguments.

Note: The result is returned as a degree,
gradian or radian angle, according to the
current angle mode setting.

Note: You can insert this function from the
computer keyboard by typing R@>Ptheta
(...).

InDegree anglemode:

InGradian anglemode:

In Radian anglemode:
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R►Pθ() Catalog >

R►Pr() Catalog >
R►Pr (xExpr, yExpr) ⇒ expression

R►Pr (xList, yList) ⇒ list
R►Pr (xMatrix, yMatrix) ⇒ matrix

Returns the equivalent r-coordinate of the
(x,y) pair arguments.

Note: You can insert this function from the
computer keyboard by typing R@>Pr(...).

In Radian anglemode:

►Rad Catalog >
Expr1►Rad⇒ expression
Converts the argument to radian angle
measure.

Note: You can insert this operator from the
computer keyboard by typing @>Rad.

InDegree anglemode:

InGradian anglemode:

rand() Catalog >
rand() ⇒ expression
rand(#Trials) ⇒ list

rand() returns a random value between 0
and 1.

rand(#Trials) returns a list containing
#Trials random values between 0 and 1.

Set the random-number seed.



randBin() Catalog >
randBin(n, p) ⇒ expression
randBin(n, p, #Trials) ⇒ list

randBin(n, p) returns a random real number
from a specified Binomial distribution.

randBin(n, p, #Trials) returns a list
containing #Trials random real numbers
from a specified Binomial distribution.

randInt() Catalog >
randInt
(lowBound,upBound)
⇒ expression
randInt
(lowBound,upBound
,#Trials) ⇒ list

randInt
(lowBound,upBound)
returns a random
integer within the
range specified by
lowBound and
upBound integer
bounds.

randInt
(lowBound,upBound
,#Trials) returns a
list containing
#Trials random
integers within the
specified range.

randMat() Catalog >
randMat(numRows, numColumns) ⇒
matrix

Returns a matrix of integers between -9
and 9 of the specified dimension.

Both arguments must simplify to integers. Note: The values in this matrix will change
each time youpress·.
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randNorm() Catalog >
randNorm(μ, σ) ⇒ expression
randNorm(μ, σ, #Trials) ⇒ list

randNorm(μ, σ) returns a decimal number
from the specified normal distribution. It
could be any real number but will be heavily
concentrated in the interval [μ−3•σ, μ+3•σ].

randNorm(μ, σ, #Trials) returns a list
containing #Trials decimal numbers from
the specified normal distribution.

randPoly() Catalog >
randPoly(Var, Order) ⇒ expression

Returns a polynomial in Var of the
specifiedOrder. The coefficients are
random integers in the range −9 through 9.
The leading coefficient will not be zero.

Order must be 0–99.

randSamp() Catalog >
randSamp(List,#Trials[,noRepl]) ⇒ list

Returns a list containing a random sample
of #Trials trials from List with an option
for sample replacement (noRepl=0), or no
sample replacement (noRepl=1). The
default is with sample replacement.

RandSeed Catalog >
RandSeed Number

If Number = 0, sets the seeds to the factory
defaults for the random-number generator.
If Number ≠ 0, it is used to generate two
seeds, which are stored in system variables
seed1 and seed2.



real() Catalog >
real(Expr1) ⇒ expression

Returns the real part of the argument.

Note: All undefined variables are treated as
real variables. See also imag(), page 89.

real(List1) ⇒ list

Returns the real parts of all elements.

real(Matrix1) ⇒ matrix

Returns the real parts of all elements.

►Rect Catalog >
Vector►Rect

Note: You can insert this operator from the
computer keyboard by typing @>Rect.

Displays Vector in rectangular form [x, y,
z]. The vector must be of dimension 2 or 3
and can be a row or a column.

Note:►Rect is a display-format instruction,
not a conversion function. You can use it
only at the end of an entry line, and it does
not update ans.

Note: See also►Polar, page 134.

complexValue►Rect

Displays complexValue in rectangular form
a+bi. The complexValue can have any
complex form. However, an reiθ entry
causes an error in Degree angle mode.

Note: You must use parentheses for an
(r∠θ) polar entry.

In Radian anglemode:

InGradian anglemode:

InDegree anglemode:

Note: To type∠ , select it from the symbol
list in the Catalog.
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ref() Catalog >
ref(Matrix1[, Tol]) ⇒ matrix

Returns the row echelon form of Matrix1.

Optionally, any matrix element is treated as
zero if its absolute value is less than Tol.
This tolerance is used only if the matrix has
floating-point entries and does not contain
any symbolic variables that have not been
assigned a value. Otherwise, Tol is ignored.

• If you use/· or set the Auto or
Approximate mode to Approximate,
computations are done using floating-
point arithmetic.

• If Tol is omitted or not used, the default
tolerance is calculated as:
5E−14 •max(dim(Matrix1)) •rowNorm
(Matrix1)

Avoid undefined elements inMatrix1. They
can lead to unexpected results.

For example, if a is undefined in the
following expression, a warning message
appears and the result is shown as:

The warning appears because the
generalized element 1/a would not be valid
for a=0.

You can avoid this by storing a value to a
beforehand or by using the constraint (“|”)
operator to substitute a value, as shown in
the following example.

Note: See also rref(), page 157.



RefreshProbeVars Catalog >
RefreshProbeVars

Allows you to access sensor data from all
connected sensor probes in your TI-Basic
program.

StatusVar
Value Status

statusVar
=0

Normal (continue with the
program)

statusVar
=1

The Vernier DataQuest™
application is in data collection
mode.
Note: The Vernier DataQuest™
application must be in meter
mode for this command to work.

statusVar
=2

The Vernier DataQuest™
application is not launched.

statusVar
=3

The Vernier DataQuest™
application is launched, but you
have not connected any probes.

Example

Define temp()=

Prgm

© Check if system is ready

RefreshProbeVars status

If status=0 Then

Disp "ready"

For n,1,50

RefreshProbeVars status

temperature:=meter.temperature

Disp "Temperature:
",temperature

If temperature>30 Then

Disp "Too hot"

EndIf

© Wait for 1 second between
samples

Wait 1

EndFor

Else

Disp "Not ready. Try again
later"

EndIf

EndPrgm

Note: This can also be used with TI-
Innovator™ Hub.
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remain() Catalog >
remain(Expr1, Expr2) ⇒ expression

remain(List1, List2) ⇒ list
remain(Matrix1,Matrix2) ⇒ matrix

Returns the remainder of the first
argument with respect to the second
argument as defined by the identities:

remain(x,0)   x
remain(x,y)   x−y•iPart(x/y)
As a consequence, note that remain(−x,y) −
remain(x,y). The result is either zero or it
has the same sign as the first argument.

Note: See alsomod(), page 117.

Request Catalog >
Request promptString, var[, DispFlag
[, statusVar]]

Request promptString, func(arg1, ...argn)
[, DispFlag [, statusVar]]

Programming command: Pauses the
program and displays a dialog box
containing the message promptString and
an input box for the user’s response.

When the user types a response and clicks
OK, the contents of the input box are
assigned to variable var.

If the user clicks Cancel, the program
proceeds without accepting any input. The
program uses the previous value of var if
var was already defined.

The optional DispFlag argument can be
any expression.

• IfDispFlag is omitted or evaluates to 1,
the prompt message and user’s response
are displayed in the Calculator history.

• IfDispFlag evaluates to 0, the prompt
and response are not displayed in the
history.

Define a program:

Define request_demo()=Prgm
    Request “Radius: ”,r
    Disp “Area = “,pi*r2
EndPrgm

Run the programand type a response:

request_demo()

Result after selecting OK:

Radius: 6/2
Area= 28.2743



Request Catalog >
The optional statusVar argument gives the
program a way to determine how the user
dismissed the dialog box. Note that
statusVar requires the DispFlag argument.

• If the user clicked OK or pressed Enter or
Ctrl+Enter, variable statusVar is set to a
value of 1.

• Otherwise, variable statusVar is set to a
value of 0.

The func() argument allows a program to
store the user’s response as a function
definition. This syntax operates as if the
user executed the command:

     Define func(arg1, ...argn) = user’s
response

The program can then use the defined
function func(). The promptString should
guide the user to enter an appropriate
user’s response that completes the
function definition.

Note: You can use the Request command
within a user-defined program but not
within a function.

To stop a program that contains a Request
command inside an infinite loop:

• Handheld: Hold down thec key and
press· repeatedly.

• Windows®: Hold down the F12 key and
press Enter repeatedly.

• Macintosh®: Hold down the F5 key and
press Enter repeatedly.

• iPad®: The app displays a prompt. You
can continue waiting or cancel.

Note: See also RequestStr, page 151.

Define a program:

Define polynomial()=Prgm
    Request "Enter a polynomial in
x:",p(x)
    Disp "Real roots are:",polyRoots
(p(x),x)
EndPrgm

Run the programand type a response:

polynomial()

Result after entering x^3+3x+1 and selecting
OK:

Real roots are: {-0.322185}

RequestStr Catalog >
RequestStr promptString, var[, DispFlag] Define a program:
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RequestStr Catalog >
Programming command: Operates
identically to the first syntax of the Request
command, except that the user’s response
is always interpreted as a string. By
contrast, the Request command interprets
the response as an expression unless the
user encloses it in quotation marks (““).

Note: You can use the RequestStr command
within a user-defined program but not
within a function.

To stop a program that contains a
RequestStr command inside an infinite loop:

• Handheld: Hold down thec key and
press· repeatedly.

• Windows®: Hold down the F12 key and
press Enter repeatedly.

• Macintosh®: Hold down the F5 key and
press Enter repeatedly.

• iPad®: The app displays a prompt. You
can continue waiting or cancel.

Note: See also Request, page 150.

Define requestStr_demo()=Prgm
    RequestStr “Your name:”,name,0
    Disp “Response has “,dim(name),”
characters.”
EndPrgm

Run the programand type a response:

requestStr_demo()

Result after selecting OK (Note that the
DispFlag argumentof 0 omits the prompt
and response from the history):

requestStr_demo()

Response has 5 characters.

Return Catalog >
Return [Expr]

Returns Expr as the result of the function.
Use within a Func...EndFunc block.

Note: Use Return without an argument
within a Prgm...EndPrgm block to exit a
program.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

right() Catalog >
right(List1[, Num]) ⇒ list



right() Catalog >
Returns the rightmost Num elements
contained in List1.

If you omit Num, returns all of List1.
right(sourceString[, Num]) ⇒ string

Returns the rightmost Num characters
contained in character string sourceString.

If you omit Num, returns all of
sourceString.
right(Comparison) ⇒ expression

Returns the right side of an equation or
inequality.

rk23 () Catalog >
rk23(Expr, Var, depVar, {Var0, VarMax},
depVar0, VarStep [, diftol]) ⇒ matrix

rk23(SystemOfExpr, Var, ListOfDepVars,
{Var0, VarMax}, ListOfDepVars0,
VarStep[, diftol]) ⇒ matrix

rk23(ListOfExpr, Var, ListOfDepVars,
{Var0, VarMax}, ListOfDepVars0,
VarStep[, diftol]) ⇒ matrix

Uses the Runge-Kutta method to solve the
system

with depVar(Var0)=depVar0 on the
interval [Var0,VarMax]. Returns a matrix
whose first row defines the Var output
values as defined by VarStep. The second
row defines the value of the first solution
component at the corresponding Var
values, and so on.

Expr is the right hand side that defines the
ordinary differential equation (ODE).

SystemOfExpr is a system of right-hand
sides that define the system of ODEs
(corresponds to order of dependent
variables in ListOfDepVars).

Differential equation:

y'=0.001*y*(100-y) and y(0)=10

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

Same equationwithdiftol set to 1.E−6

Compare above resultwithCAS exact
solutionobtainedusing deSolve() and
seqGen():

System of equations:
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rk23 () Catalog >
ListOfExpr is a list of right-hand sides that
define the system of ODEs (corresponds to
order of dependent variables in
ListOfDepVars).

Var is the independent variable.

ListOfDepVars is a list of dependent
variables.

{Var0, VarMax} is a two-element list that
tells the function to integrate from Var0 to
VarMax.

ListOfDepVars0 is a list of initial values
for dependent variables.

If VarStep evaluates to a nonzero number:
sign(VarStep) = sign(VarMax-Var0) and
solutions are returned at Var0+i*VarStep
for all i=0,1,2,… such that Var0+i*VarStep
is in [var0,VarMax] (may not get a solution
value at VarMax).

if VarStep evaluates to zero, solutions are
returned at the "Runge-Kutta" Var values.

diftol is the error tolerance (defaults to
0.001).

with y1(0)=2 and y2(0)=5

root() Catalog >
root(Expr) ⇒ root
root(Expr1, Expr2) ⇒ root

root(Expr) returns the square root of Expr.

root(Expr1, Expr2) returns the Expr2 root
of Expr1. Expr1 can be a real or complex
floating point constant, an integer or
complex rational constant, or a general
symbolic expression.

Note: See also Nth root template, page 1.

rotate() Catalog >
rotate(Integer1[,#ofRotations]) ⇒ integer In Bin basemode:



rotate() Catalog >
Rotates the bits in a binary integer. You can
enter Integer1 in any number base; it is
converted automatically to a signed, 64-bit
binary form. If the magnitude of Integer1 is
too large for this form, a symmetric modulo
operation brings it within the range. For
more information, see►Base2, page 17.

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

If #ofRotations is positive, the rotation is to
the left. If #ofRotations is negative, the
rotation is to the right. The default is −1
(rotate right one bit).

For example, in a right rotation:

InHex basemode:

Each bit rotates right.

0b00000000000001111010110000110101

Rightmost bit rotates to leftmost.

produces:

0b10000000000000111101011000011010

The result is displayed according to the
Base mode.

Important: To enter a binary or
hexadecimal number, always use the 0bor
0hprefix (zero, not the letter O).

rotate(List1[,#ofRotations]) ⇒ list

Returns a copy of List1 rotated right or left
by #of Rotations elements. Does not alter
List1.

If #ofRotations is positive, the rotation is to
the left. If #of Rotations is negative, the
rotation is to the right. The default is −1
(rotate right one element).

InDec basemode:

rotate(String1[,#ofRotations]) ⇒ string

Returns a copy of String1 rotated right or
left by #ofRotations characters. Does not
alter String1.

If #ofRotations is positive, the rotation is to
the left. If #ofRotations is negative, the
rotation is to the right. The default is −1
(rotate right one character).
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round() Catalog >
round(Expr1[, digits]) ⇒ expression

Returns the argument rounded to the
specified number of digits after the decimal
point.

digits must be an integer in the range 0–
12. If digits is not included, returns the
argument rounded to 12 significant digits.

Note: Display digits mode may affect how
this is displayed.

round(List1[, digits]) ⇒ list

Returns a list of the elements rounded to
the specified number of digits.

round(Matrix1[, digits]) ⇒ matrix

Returns a matrix of the elements rounded
to the specified number of digits.

rowAdd() Catalog >
rowAdd(Matrix1, rIndex1, rIndex2) ⇒
matrix

Returns a copy of Matrix1 with row
rIndex2 replaced by the sum of rows
rIndex1 and rIndex2.

rowDim() Catalog >
rowDim(Matrix) ⇒ expression

Returns the number of rows inMatrix.

Note: See also colDim(), page 26.

rowNorm() Catalog >
rowNorm(Matrix) ⇒ expression

Returns the maximum of the sums of the
absolute values of the elements in the rows
inMatrix.

Note: All matrix elements must simplify to
numbers. See also colNorm(), page 26.



rowSwap() Catalog >
rowSwap(Matrix1, rIndex1, rIndex2) ⇒
matrix

Returns Matrix1 with rows rIndex1 and
rIndex2 exchanged.

rref() Catalog >
rref(Matrix1[, Tol]) ⇒ matrix

Returns the reduced row echelon form of
Matrix1.

Optionally, any matrix element is treated as
zero if its absolute value is less than Tol.
This tolerance is used only if the matrix has
floating-point entries and does not contain
any symbolic variables that have not been
assigned a value. Otherwise, Tol is ignored.

• If you use/· or set the Auto or
Approximate mode to Approximate,
computations are done using floating-
point arithmetic.

• If Tol is omitted or not used, the default
tolerance is calculated as:
5E−14 •max(dim(Matrix1)) •rowNorm
(Matrix1)

Note: See also ref(), page 148.

S

sec() µ key
sec(Expr1) ⇒ expression

sec(List1) ⇒ list

Returns the secant of Expr1 or returns a
list containing the secants of all elements
in List1.

InDegree anglemode:
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sec() µ key
Note: The argument is interpreted as a
degree, gradian or radian angle, according
to the current angle mode setting. You can
use °, G, or r to override the angle mode
temporarily.

sec⁻¹() µ key
sec⁻¹(Expr1) ⇒ expression

sec⁻¹(List1) ⇒ list

Returns the angle whose secant is Expr1 or
returns a list containing the inverse secants
of each element of List1.

Note: The result is returned as a degree,
gradian, or radian angle, according to the
current angle mode setting.

Note: You can insert this function from the
keyboard by typing arcsec(...).

InDegree anglemode:

InGradian anglemode:

In Radian anglemode:

sech() Catalog >
sech(Expr1) ⇒ expression

sech(List1) ⇒ list

Returns the hyperbolic secant of Expr1 or
returns a list containing the hyperbolic
secants of the List1 elements.

sech⁻¹() Catalog >
sech⁻¹(Expr1) ⇒ expression

sech⁻¹(List1) ⇒ list

Returns the inverse hyperbolic secant of
Expr1 or returns a list containing the
inverse hyperbolic secants of each element
of List1.

Note: You can insert this function from the
keyboard by typing arcsech(...).

In Radian angle andRectangular complex
mode:



Send Hub Menu
Send exprOrString1 [, exprOrString2] ...

Programming command: Sends one or
more TI-Innovator™ Hub commands to a
connected hub.

exprOrStringmust be a valid TI-Innovator™
Hub Command. Typically, exprOrString
contains a "SET ..." command to control a
device or a "READ ..." command to request
data.

The arguments are sent to the hub in
succession.

Note: You can use the Send command
within a user-defined program but not
within a function.

Note: See also Get (page 78), GetStr (page
85), and eval() (page 62).

Example: Turnon the blue element of the
built-in RGB LED for 0.5 seconds.

Example: Request the current value of the
hub's built-in light-level sensor. A Get
command retrieves the value andassigns it
to variable lightval.

Example: Senda calculated frequency to the
hub's built-in speaker. Use special variable
iostr.SendAns to show the hub command
with the expressionevaluated.

seq() Catalog >
seq(Expr, Var, Low, High[, Step]) ⇒ list

Increments Var from Low throughHigh by
an increment of Step, evaluates Expr, and
returns the results as a list. The original
contents of Var are still there after seq() is
completed.

The default value for Step = 1. Note: To force anapproximate result,

Handheld: Press/·.
Windows®: Press Ctrl+Enter.
Macintosh®: Press “+Enter.
iPad®: Holdenter, and select .
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seqGen() Catalog >
seqGen(Expr, Var, depVar, {Var0,
VarMax}[, ListOfInitTerms

[, VarStep[, CeilingValue]]]) ⇒ list

Generates a list of terms for sequence
depVar(Var)=Expr as follows: Increments
independent variable Var from Var0
through VarMax by VarStep, evaluates
depVar(Var) for corresponding values of
Var using the Expr formula and
ListOfInitTerms, and returns the results as
a list.

seqGen(ListOrSystemOfExpr, Var,
ListOfDepVars, {Var0, VarMax} [
,MatrixOfInitTerms[, VarStep[,
CeilingValue]]]) ⇒ matrix

Generates a matrix of terms for a system
(or list) of sequences ListOfDepVars(Var)
=ListOrSystemOfExpr as follows:
Increments independent variable Var from
Var0 through VarMax by VarStep,
evaluates ListOfDepVars(Var) for
corresponding values of Var using
ListOrSystemOfExpr formula and
MatrixOfInitTerms, and returns the results
as a matrix.

The original contents of Var are unchanged
after seqGen() is completed.

The default value for VarStep = 1.

Generate the first 5 terms of the sequence u
(n) = u(n-1)2/2, withu(1)=2 andVarStep=1.

Example inwhichVar0=2:

Example inwhich initial term is symbolic:

Systemof two sequences:

Note: The Void (_) in the initial termmatrix
above is used to indicate that the initial term
for u1(n) is calculatedusing the explicit
sequence formula u1(n)=1/n.

seqn() Catalog >
seqn(Expr(u, n[, ListOfInitTerms[, nMax[,
CeilingValue]]]) ⇒ list

Generate the first 6 terms of the sequence u
(n) = u(n-1)/2, withu(1)=2.



seqn() Catalog >
Generates a list of terms for a sequence u
(n)=Expr(u, n) as follows: Increments n
from 1 through nMax by 1, evaluates u(n)
for corresponding values of n using the
Expr(u, n) formula and ListOfInitTerms,
and returns the results as a list.

seqn(Expr(n[, nMax[, CeilingValue]]) ⇒
list

Generates a list of terms for a non-
recursive sequence u(n)=Expr(n) as
follows: Increments n from 1 through nMax
by 1, evaluates u(n) for corresponding
values of n using the Expr(n) formula, and
returns the results as a list.

If nMax is missing, nMax is set to 2500

If nMax=0, nMax is set to 2500

Note: seqn() calls seqGen( ) with n0=1 and
nstep =1

series() Catalog >
series(Expr1, Var, Order[, Point]) ⇒
expression

series(Expr1, Var, Order[, Point]) |
Var>Point⇒ expression

series(Expr1, Var, Order[, Point]) |
Var<Point⇒ expression

Returns a generalized truncated power
series representation of Expr1 expanded
about Point through degree Order. Order
can be any rational number. The resulting
powers of (Var − Point) can include
negative and/or fractional exponents. The
coefficients of these powers can include
logarithms of (Var − Point) and other
functions of Var that are dominated by all
powers of (Var − Point) having the same
exponent sign.
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series() Catalog >
Point defaults to 0. Point can be ∞ or −∞,
in which cases the expansion is through
degree Order in 1/(Var − Point).

series(...) returns “series(...)” if it is unable
to determine such a representation, such as
for essential singularities such as sin(1/z)
at z=0, e−1/z at z=0, or ez at z = ∞ or −∞.

If the series or one of its derivatives has a
jump discontinuity at Point, the result is
likely to contain sub-expressions of the
form sign(…) or abs(…) for a real expansion
variable or (-1)floor(…angle(…)…) for a complex
expansion variable, which is one ending
with “_”. If you intend to use the series only
for values on one side of Point, then
append the appropriate one of “| Var >
Point”, “| Var < Point”, “| “Var ≥ Point”,
or “Var ≤ Point” to obtain a simpler result.

series() can provide symbolic
approximations to indefinite integrals and
definite integrals for which symbolic
solutions otherwise can't be obtained.

series() distributes over 1st-argument lists
and matrices.

series() is a generalized version of taylor().

As illustrated by the last example to the
right, the display routines downstream of
the result produced by series(...) might
rearrange terms so that the dominant term
is not the leftmost one.

Note: See also dominantTerm(), page 56.

setMode() Catalog >
setMode(modeNameInteger,
settingInteger) ⇒ integer
setMode(list) ⇒ integer list

Valid only within a function or program.

Display approximate value of π using the
default setting for Display Digits, and then
display π with a setting of Fix2. Check to see
that the default is restored after the
programexecutes.



setMode() Catalog >
setMode(modeNameInteger,
settingInteger) temporarily sets mode
modeNameInteger to the new setting
settingInteger, and returns an integer
corresponding to the original setting of that
mode. The change is limited to the duration
of the program/function’s execution.

modeNameInteger specifies which mode
you want to set. It must be one of the mode
integers from the table below.

settingInteger specifies the new setting for
the mode. It must be one of the setting
integers listed below for the specific mode
you are setting.

setMode(list) lets you change multiple
settings. list contains pairs of mode
integers and setting integers. setMode(list)
returns a similar list whose integer pairs
represent the original modes and settings.

If you have saved all mode settings with
getMode(0)→var, you can use setMode
(var) to restore those settings until the
function or program exits. See getMode(),
page 84.

Note: The current mode settings are passed
to called subroutines. If any subroutine
changes a mode setting, the mode change
will be lost when control returns to the
calling routine.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

Mode
Name

Mode
Integer Setting Integers

Display
Digits

1 1=Float, 2=Float1, 3=Float2, 4=Float3, 5=Float4, 6=Float5,
7=Float6, 8=Float7, 9=Float8, 10=Float9, 11=Float10,
12=Float11, 13=Float12, 14=Fix0, 15=Fix1, 16=Fix2,
17=Fix3, 18=Fix4, 19=Fix5, 20=Fix6, 21=Fix7, 22=Fix8,
23=Fix9, 24=Fix10, 25=Fix11, 26=Fix12
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Mode
Name

Mode
Integer Setting Integers

Angle 2 1=Radian, 2=Degree, 3=Gradian

Exponential
Format

3 1=Normal, 2=Scientific, 3=Engineering

Real or
Complex

4 1=Real, 2=Rectangular, 3=Polar

Auto or
Approx.

5 1=Auto, 2=Approximate, 3=Exact

Vector
Format

6 1=Rectangular, 2=Cylindrical, 3=Spherical

Base 7 1=Decimal, 2=Hex, 3=Binary

Unit
system

8 1=SI, 2=Eng/US

shift() Catalog >
shift(Integer1[,#ofShifts]) ⇒ integer

Shifts the bits in a binary integer. You can
enter Integer1 in any number base; it is
converted automatically to a signed, 64-bit
binary form. If the magnitude of Integer1 is
too large for this form, a symmetric modulo
operation brings it within the range. For
more information, see►Base2, page 17.

If #ofShifts is positive, the shift is to the
left. If #ofShifts is negative, the shift is to
the right. The default is −1 (shift right one
bit).

In a right shift, the rightmost bit is dropped
and 0 or 1 is inserted to match the leftmost
bit. In a left shift, the leftmost bit is
dropped and 0 is inserted as the rightmost
bit.

For example, in a right shift:

Each bit shifts right.

0b0000000000000111101011000011010

Inserts 0 if leftmost bit is 0,
or 1 if leftmost bit is 1.

produces:

In Bin basemode:

InHex basemode:

Important: To enter a binary or
hexadecimal number, always use the 0bor
0hprefix (zero, not the letter O).



shift() Catalog >
0b00000000000000111101011000011010

The result is displayed according to the
Base mode. Leading zeros are not shown.

shift(List1[,#ofShifts]) ⇒ list

Returns a copy of List1 shifted right or left
by #ofShifts elements. Does not alter List1.

If #ofShifts is positive, the shift is to the
left. If #ofShifts is negative, the shift is to
the right. The default is −1 (shift right one
element).

Elements introduced at the beginning or
end of list by the shift are set to the symbol
“undef”.

InDec basemode:

shift(String1[,#ofShifts]) ⇒ string

Returns a copy of String1 shifted right or
left by #ofShifts characters. Does not alter
String1.

If #ofShifts is positive, the shift is to the
left. If #ofShifts is negative, the shift is to
the right. The default is −1 (shift right one
character).

Characters introduced at the beginning or
end of string by the shift are set to a space.

sign() Catalog >
sign(Expr1) ⇒ expression

sign(List1) ⇒ list
sign(Matrix1) ⇒ matrix

For real and complex Expr1, returns
Expr1/abs(Expr1) when Expr1≠ 0.

Returns 1 if Expr1 is positive. Returns −1 if
Expr1is negative.

sign(0) represents the unit circle in the
complex domain.

For a list or matrix, returns the signs of all
the elements.

If complex formatmode is Real:
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simult() Catalog >
simult(coeffMatrix, constVector[, Tol]) ⇒
matrix

Returns a column vector that contains the
solutions to a system of linear equations.

Note: See also linSolve(), page 103.

coeffMatrix must be a square matrix that
contains the coefficients of the equations.

constVector must have the same number
of rows (same dimension) as coeffMatrix
and contain the constants.

Optionally, any matrix element is treated as
zero if its absolute value is less than Tol.
This tolerance is used only if the matrix has
floating-point entries and does not contain
any symbolic variables that have not been
assigned a value. Otherwise, Tol is ignored.

• If you set the Auto or Approximate mode
to Approximate, computations are done
using floating-point arithmetic.

• If Tol is omitted or not used, the default
tolerance is calculated as:
5E−14 •max(dim(coeffMatrix))
•rowNorm(coeffMatrix)

Solve for x and y:
x + 2y = 1
3x + 4y =−1

The solution is x=−3 and y=2.

Solve:
ax + by = 1
cx + dy = 2

simult(coeffMatrix, constMatrix[, Tol]) ⇒
matrix

Solves multiple systems of linear equations,
where each system has the same equation
coefficients but different constants.

Each column in constMatrix must contain
the constants for a system of equations.
Each column in the resulting matrix
contains the solution for the corresponding
system.

Solve:
  x + 2y = 1
3x + 4y =−1

  x + 2y = 2
3x + 4y =−3

For the first system, x=−3 and y=2. For the
second system, x=−7 and y=9/2.

►sin Catalog >
Expr►sin

Note: You can insert this operator from the
computer keyboard by typing @>sin.



►sin Catalog >
Represents Expr in terms of sine. This is a
display conversion operator. It can be used
only at the end of the entry line.

►sin reduces all powers of
    cos(...) modulo 1−sin(...)^2
so that any remaining powers of sin(...)
have exponents in the range (0, 2). Thus,
the result will be free of cos(...) if and only
if cos(...) occurs in the given expression only
to even powers.

Note: This conversion operator is not
supported in Degree or Gradian Angle
modes. Before using it, make sure that the
Angle mode is set to Radians and that Expr
does not contain explicit references to
degree or gradian angles.

sin() µ key
sin(Expr1) ⇒ expression

sin(List1) ⇒ list

sin(Expr1) returns the sine of the argument
as an expression.

sin(List1) returns a list of the sines of all
elements in List1.

Note: The argument is interpreted as a
degree, gradian or radian angle, according
to the current angle mode. You can use °, g,
or r to override the angle mode setting
temporarily.

InDegree anglemode:

InGradian anglemode:

In Radian anglemode:

sin(squareMatrix1) ⇒ squareMatrix In Radian anglemode:
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sin() µ key
Returns the matrix sine of squareMatrix1.
This is not the same as calculating the sine
of each element. For information about the
calculation method, refer to cos().

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.

sin⁻¹() µ key
sin⁻¹(Expr1) ⇒ expression

sin⁻¹(List1) ⇒ list

sin⁻¹(Expr1) returns the angle whose sine
is Expr1 as an expression.

sin⁻¹(List1) returns a list of the inverse
sines of each element of List1.

Note: The result is returned as a degree,
gradian or radian angle, according to the
current angle mode setting.

Note: You can insert this function from the
keyboard by typing arcsin(...).

InDegree anglemode:

InGradian anglemode:

In Radian anglemode:

sin⁻¹(squareMatrix1) ⇒ squareMatrix

Returns the matrix inverse sine of
squareMatrix1. This is not the same as
calculating the inverse sine of each
element. For information about the
calculation method, refer to cos().

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.

In Radian anglemode andRectangular
complex formatmode:

sinh() Catalog >
sinh(Expr1) ⇒ expression

sinh(List1) ⇒ list

sinh (Expr1) returns the hyperbolic sine of
the argument as an expression.



sinh() Catalog >
sinh (List1) returns a list of the hyperbolic
sines of each element of List1.
sinh(squareMatrix1) ⇒ squareMatrix

Returns the matrix hyperbolic sine of
squareMatrix1. This is not the same as
calculating the hyperbolic sine of each
element. For information about the
calculation method, refer to cos().

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.

In Radian anglemode:

sinh⁻¹() Catalog >
sinh⁻¹(Expr1) ⇒ expression

sinh⁻¹(List1) ⇒ list

sinh⁻¹(Expr1) returns the inverse hyperbolic
sine of the argument as an expression.

sinh⁻¹(List1) returns a list of the inverse
hyperbolic sines of each element of List1.

Note: You can insert this function from the
keyboard by typing arcsinh(...).

sinh⁻¹(squareMatrix1) ⇒ squareMatrix

Returns the matrix inverse hyperbolic sine
of squareMatrix1. This is not the same as
calculating the inverse hyperbolic sine of
each element. For information about the
calculation method, refer to cos().

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.

In Radian anglemode:

SinReg Catalog >
SinReg X, Y[, [Iterations],[Period][,
Category, Include]]

Computes the sinusoidal regression on lists
X and Y. A summary of results is stored in
the stat.results variable. (See page 177.)
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SinReg Catalog >
All the lists must have equal dimension
except for Include.

X and Y are lists of independent and
dependent variables.

Iterations is a value that specifies the
maximum number of times (1 through 16) a
solution will be attempted. If omitted, 8 is
used. Typically, larger values result in better
accuracy but longer execution times, and
vice versa.

Period specifies an estimated period. If
omitted, the difference between values in X
should be equal and in sequential order. If
you specify Period, the differences between
x values can be unequal.

Category is a list of category codes for the
corresponding X and Y data.

Include is a list of one or more of the
category codes. Only those data items
whose category code is included in this list
are included in the calculation.

The output of SinReg is always in radians,
regardless of the angle mode setting.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output
variable Description

stat.RegEqn Regression Equation: a•sin(bx+c)+d

stat.a, stat.b,
stat.c, stat.d

Regression coefficients

stat.Resid Residuals from the regression

stat.XReg List of data points in themodifiedX List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.YReg List of data points in themodifiedY List actually used in the regressionbasedon
restrictions ofFreq, Category List, and Include Categories

stat.FreqReg List of frequencies corresponding to stat.XReg and stat.YReg



solve() Catalog >
solve(Equation, Var) ⇒ Boolean
expression
solve(Equation, Var=Guess) ⇒ Boolean
expression
solve(Inequality, Var) ⇒ Boolean
expression

Returns candidate real solutions of an
equation or an inequality for Var. The goal
is to return candidates for all solutions.
However, there might be equations or
inequalities for which the number of
solutions is infinite.

Solution candidates might not be real finite
solutions for some combinations of values
for undefined variables.

For the Auto setting of the Auto or
Approximate mode, the goal is to produce
exact solutions when they are concise, and
supplemented by iterative searches with
approximate arithmetic when exact
solutions are impractical.

Due to default cancellation of the greatest
common divisor from the numerator and
denominator of ratios, solutions might be
solutions only in the limit from one or both
sides.

For inequalities of types ≥, ≤, <, or >,
explicit solutions are unlikely unless the
inequality is linear and contains only Var.
For the Exact mode, portions that cannot be
solved are returned as an implicit equation
or inequality.

Use the constraint (“|”) operator to restrict
the solution interval and/or other variables
that occur in the equation or inequality.
When you find a solution in one interval,
you can use the inequality operators to
exclude that interval from subsequent
searches.

In Radian anglemode:
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solve() Catalog >
false is returned when no real solutions are
found. true is returned if solve() can
determine that any finite real value of Var
satisfies the equation or inequality.

Since solve() always returns a Boolean
result, you can use “and,” “or,” and “not” to
combine results from solve() with each
other or with other Boolean expressions.

Solutions might contain a unique new
undefined constant of the form nj with j
being an integer in the interval 1–255. Such
variables designate an arbitrary integer.

In Radian anglemode:

In Real mode, fractional powers having odd
denominators denote only the real branch.
Otherwise, multiple branched expressions
such as fractional powers, logarithms, and
inverse trigonometric functions denote only
the principal branch. Consequently, solve()
produces only solutions corresponding to
that one real or principal branch.

Note: See also cSolve(), cZeros(), nSolve(),
and zeros().

solve(Eqn1 and Eqn2[and …],
VarOrGuess1, VarOrGuess2[, …])
⇒ Boolean expression

solve(SystemOfEqns, VarOrGuess1,
VarOrGuess2[, …])
⇒ Boolean expression

solve({Eqn1, Eqn2 [,...]}
{VarOrGuess1,VarOrGuess2 [, … ]})
⇒ Boolean expression

Returns candidate real solutions to the
simultaneous algebraic equations, where
each VarOrGuess specifies a variable that
you want to solve for.



solve() Catalog >
You can separate the equations with the
and operator, or you can enter a
SystemOfEqns using a template from the
Catalog. The number of VarOrGuess
arguments must match the number of
equations. Optionally, you can specify an
initial guess for a variable. Each
VarOrGuess must have the form:

variable
– or –
variable = real or non-real number

For example, x is valid and so is x=3.

If all of the equations are polynomials and
if you do NOT specify any initial guesses,
solve() uses the lexical Gröbner/Buchberger
elimination method to attempt to
determine all real solutions.

For example, suppose you have a circle of
radius r at the origin and another circle of
radius r centered where the first circle
crosses the positive x-axis. Use solve() to
find the intersections.

As illustrated by r in the example to the
right, simultaneous polynomial equations
can have extra variables that have no
values, but represent given numeric values
that could be substituted later.

You can also (or instead) include solution
variables that do not appear in the
equations. For example, you can include z
as a solution variable to extend the previous
example to two parallel intersecting
cylinders of radius r.

The cylinder solutions illustrate how
families of solutions might contain arbitrary
constants of the form ck, where k is an
integer suffix from 1 through 255.

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.
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solve() Catalog >
For polynomial systems, computation time
or memory exhaustion may depend strongly
on the order in which you list solution
variables. If your initial choice exhausts
memory or your patience, try rearranging
the variables in the equations and/or
varOrGuess list.
If you do not include any guesses and if any
equation is non-polynomial in any variable
but all equations are linear in the solution
variables, solve() uses Gaussian elimination
to attempt to determine all real solutions.

If a system is neither polynomial in all of its
variables nor linear in its solution variables,
solve() determines at most one solution
using an approximate iterative method. To
do so, the number of solution variables
must equal the number of equations, and
all other variables in the equations must
simplify to numbers.

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

Each solution variable starts at its guessed
value if there is one; otherwise, it starts at
0.0.

Use guesses to seek additional solutions
one by one. For convergence, a guess may
have to be rather close to a solution.

SortA Catalog >
SortA List1[, List2] [, List3]...
SortA Vector1[, Vector2] [, Vector3]...

Sorts the elements of the first argument in
ascending order.

If you include additional arguments, sorts
the elements of each so that their new
positions match the new positions of the
elements in the first argument.

All arguments must be names of lists or
vectors. All arguments must have equal
dimensions.



SortA Catalog >
Empty (void) elements within the first
argument move to the bottom. For more
information on empty elements, see page
236.

SortD Catalog >
SortD List1[, List2][, List3]...
SortD Vector1[,Vector2][,Vector3]...

Identical to SortA, except SortD sorts the
elements in descending order.

Empty (void) elements within the first
argument move to the bottom. For more
information on empty elements, see page
236.

►Sphere Catalog >
Vector►Sphere

Note: You can insert this operator from the
computer keyboard by typing @>Sphere.

Displays the row or column vector in
spherical form [ρ∠θ∠φ].

Vector must be of dimension 3 and can be
either a row or a column vector.

Note:►Sphere is a display-format
instruction, not a conversion function. You
can use it only at the end of an entry line.

Note: To force anapproximate result,

Handheld: Press/·.
Windows®: Press Ctrl+Enter.
Macintosh®: Press “+Enter.
iPad®: Holdenter, and select .

Press ·
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►Sphere Catalog >

sqrt() Catalog >
sqrt(Expr1) ⇒ expression

sqrt(List1) ⇒ list

Returns the square root of the argument.

For a list, returns the square roots of all the
elements in List1.

Note: See also Square root template, page
1.



stat.results Catalog >
stat.results

Displays results from a statistics
calculation.

The results are displayed as a set of name-
value pairs. The specific names shown are
dependent on the most recently evaluated
statistics function or command.

You can copy a name or value and paste it
into other locations.

Note: Avoid defining variables that use the
same names as those used for statistical
analysis. In some cases, an error condition
could occur. Variable names used for
statistical analysis are listed in the table
below.

stat.a
stat.AdjR²
stat.b
stat.b0
stat.b1
stat.b2
stat.b3
stat.b4
stat.b5
stat.b6
stat.b7
stat.b8
stat.b9
stat.b10
stat.bList
stat.χ²
stat.c
stat.CLower
stat.CLowerList
stat.CompList
stat.CompMatrix
stat.CookDist
stat.CUpper

stat.dfDenom
stat.dfBlock
stat.dfCol
stat.dfError
stat.dfInteract
stat.dfReg
stat.dfNumer
stat.dfRow
stat.DW
stat.e
stat.ExpMatrix
stat.F
stat.FBlock
stat.Fcol
stat.FInteract
stat.FreqReg
stat.Frow
stat.Leverage
stat.LowerPred
stat.LowerVal
stat.m
stat.MaxX
stat.MaxY

stat.MedianY
stat.MEPred
stat.MinX
stat.MinY
stat.MS
stat.MSBlock
stat.MSCol
stat.MSError
stat.MSInteract
stat.MSReg
stat.MSRow
stat.n
Stat.Ç
stat.Ç1
stat.Ç2
stat.ÇDiff
stat.PList
stat.PVal
stat.PValBlock
stat.PValCol
stat.PValInteract
stat.PValRow
stat.Q1X

stat.Q3X
stat.Q3Y
stat.r
stat.r²
stat.RegEqn
stat.Resid
stat.ResidTrans
stat.σx
stat.σy
stat.σx1
stat.σx2
stat.Σx
stat.Σx²
stat.Σxy
stat.Σy
stat.Σy²
stat.s
stat.SE
stat.SEList
stat.SEPred
stat.sResid
stat.SEslope
stat.sp

stat.SSBlock
stat.SSCol
stat.SSX
stat.SSY
stat.SSError
stat.SSInteract
stat.SSReg
stat.SSRow
stat.tList
stat.UpperPred
stat.UpperVal
stat.v
stat.v1
stat.v2
stat.vDiff
stat.vList
stat.XReg
stat.XVal
stat.XValList
stat.w

stat.y

stat.yList
stat.YReg
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stat.CUpperList
stat.d

stat.ME
stat.MedianX

stat.Q1Y stat.SS

Note: Each time the Lists & Spreadsheet application calculates statistical results, it
copies the “stat.” group variables to a “stat#.” group, where # is a number that is
incremented automatically. This lets you maintain previous results while
performing multiple calculations.

stat.values Catalog >
stat.values

Displays a matrix of the values calculated for
the most recently evaluated statistics
function or command.

Unlike stat.results, stat.values omits the
names associated with the values.

You can copy a value and paste it into other
locations.

See the stat.results example.

stDevPop() Catalog >
stDevPop(List [, freqList]) ⇒ expression

Returns the population standard deviation
of the elements in List.

Each freqList element counts the number
of consecutive occurrences of the
corresponding element in List.

Note:List must have at least two elements.
Empty (void) elements are ignored. For
more information on empty elements, see
page 236.

In Radian angle andauto modes:

stDevPop(Matrix1[, freqMatrix]) ⇒
matrix

Returns a row vector of the population
standard deviations of the columns in
Matrix1.

Each freqMatrix element counts the
number of consecutive occurrences of the
corresponding element inMatrix1.



stDevPop() Catalog >
Note:Matrix1must have at least two rows.
Empty (void) elements are ignored. For
more information on empty elements, see
page 236.

stDevSamp() Catalog >
stDevSamp(List[, freqList]) ⇒ expression

Returns the sample standard deviation of
the elements in List.

Each freqList element counts the number
of consecutive occurrences of the
corresponding element in List.

Note:List must have at least two elements.
Empty (void) elements are ignored. For
more information on empty elements, see
page 236.

stDevSamp(Matrix1[, freqMatrix]) ⇒
matrix

Returns a row vector of the sample
standard deviations of the columns in
Matrix1.

Each freqMatrix element counts the
number of consecutive occurrences of the
corresponding element inMatrix1.

Note:Matrix1must have at least two rows.
Empty (void) elements are ignored. For
more information on empty elements, see
page 236.

Stop Catalog >
Stop

Programming command: Terminates the
program.

Stop is not allowed in functions.

Alphabetical Listing 179



180 Alphabetical Listing

Stop Catalog >
Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

Store See→(store), page 233.

string() Catalog >
string(Expr) ⇒ string

Simplifies Expr and returns the result as a
character string.

subMat() Catalog >
subMat(Matrix1[, startRow][, startCol][,
endRow][, endCol]) ⇒ matrix

Returns the specified submatrix of Matrix1.

Defaults: startRow=1, startCol=1,
endRow=last row, endCol=last column.

Sum (Sigma) See Σ(), page 224.

sum() Catalog >
sum(List[, Start[, End]]) ⇒ expression

Returns the sum of all elements in List.

Start and End are optional. They specify a
range of elements.

Any void argument produces a void result.
Empty (void) elements in List are ignored.
For more information on empty elements,
see page 236.



sum() Catalog >
sum(Matrix1[, Start[, End]]) ⇒ matrix

Returns a row vector containing the sums
of all elements in the columns inMatrix1.

Start and End are optional. They specify a
range of rows.

Any void argument produces a void result.
Empty (void) elements inMatrix1 are
ignored. For more information on empty
elements, see page 236.

sumIf() Catalog >
sumIf(List,Criteria[, SumList]) ⇒ value

Returns the accumulated sum of all
elements in List that meet the specified
Criteria. Optionally, you can specify an
alternate list, sumList, to supply the
elements to accumulate.

List can be an expression, list, or matrix.
SumList, if specified, must have the same
dimension(s) as List.

Criteria can be:

• A value, expression, or string. For
example, 34 accumulates only those
elements in List that simplify to the
value 34.

• A Boolean expression containing the
symbol ? as a placeholder for each
element. For example, ?<10 accumulates
only those elements in List that are less
than 10.

When a List element meets the Criteria,
the element is added to the accumulating
sum. If you include sumList, the
corresponding element from sumList is
added to the sum instead.

Within the Lists & Spreadsheet application,
you can use a range of cells in place of List
and sumList.
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sumIf() Catalog >
Empty (void) elements are ignored. For
more information on empty elements, see
page 236.

Note: See also countIf(), page 35.

sumSeq() See Σ(), page 224.

system() Catalog >
system(Eqn1[, Eqn2[, Eqn3[, ...]]])

system(Expr1[, Expr2[, Expr3[, ...]]])

Returns a system of equations, formatted
as a list. You can also create a system by
using a template.

Note: See also System of equations, page 3.

T

T (transpose) Catalog >
Matrix1T ⇒ matrix

Returns the complex conjugate transpose of
Matrix1.

Note: You can insert this operator from the
computer keyboard by typing @t.

tan() µ key
tan(Expr1) ⇒ expression

tan(List1) ⇒ list

tan(Expr1) returns the tangent of the
argument as an expression.

tan(List1) returns a list of the tangents of
all elements in List1.

InDegree anglemode:



tan() µ key
Note: The argument is interpreted as a
degree, gradian or radian angle, according
to the current angle mode. You can use °, g
or r to override the angle mode setting
temporarily.

InGradian anglemode:

In Radian anglemode:

tan(squareMatrix1) ⇒ squareMatrix

Returns the matrix tangent of
squareMatrix1. This is not the same as
calculating the tangent of each element.
For information about the calculation
method, refer to cos().

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.

In Radian anglemode:

tan⁻¹() µ key
tan⁻¹(Expr1) ⇒ expression

tan⁻¹(List1) ⇒ list

tan⁻¹(Expr1) returns the angle whose
tangent is Expr1 as an expression.

tan⁻¹(List1) returns a list of the inverse
tangents of each element of List1.

Note: The result is returned as a degree,
gradian or radian angle, according to the
current angle mode setting.

Note: You can insert this function from the
keyboard by typing arctan(...).

InDegree anglemode:

InGradian anglemode:

In Radian anglemode:

tan⁻¹(squareMatrix1) ⇒ squareMatrix In Radian anglemode:
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tan⁻¹() µ key
Returns the matrix inverse tangent of
squareMatrix1. This is not the same as
calculating the inverse tangent of each
element. For information about the
calculation method, refer to cos().

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.

tangentLine() Catalog >
tangentLine(Expr1,Var,Point) ⇒
expression

tangentLine(Expr1,Var=Point) ⇒
expression

Returns the tangent line to the curve
represented by Expr1 at the point specified
in Var=Point.

Make sure that the independent variable is
not defined. For example, If f1(x):=5 and
x:=3, then tangentLine(f1(x),x,2) returns
“false.”

tanh() Catalog >
tanh(Expr1) ⇒ expression

tanh(List1) ⇒ list

tanh(Expr1) returns the hyperbolic tangent
of the argument as an expression.

tanh(List1) returns a list of the hyperbolic
tangents of each element of List1.
tanh(squareMatrix1) ⇒ squareMatrix

Returns the matrix hyperbolic tangent of
squareMatrix1. This is not the same as
calculating the hyperbolic tangent of each
element. For information about the
calculation method, refer to cos().

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.

In Radian anglemode:



tanh⁻¹() Catalog >
tanh⁻¹(Expr1) ⇒ expression

tanh⁻¹(List1) ⇒ list

tanh⁻¹(Expr1) returns the inverse
hyperbolic tangent of the argument as an
expression.

tanh⁻¹(List1) returns a list of the inverse
hyperbolic tangents of each element of
List1.

Note: You can insert this function from the
keyboard by typing arctanh(...).

In Rectangular complex format:

tanh⁻¹(squareMatrix1) ⇒ squareMatrix

Returns the matrix inverse hyperbolic
tangent of squareMatrix1. This is not the
same as calculating the inverse hyperbolic
tangent of each element. For information
about the calculation method, refer to cos
().

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.

In Radian anglemode andRectangular
complex format:

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

taylor() Catalog >
taylor(Expr1, Var, Order[, Point]) ⇒
expression

Returns the requested Taylor polynomial.
The polynomial includes non-zero terms of
integer degrees from zero throughOrder in
(Var minus Point). taylor() returns itself if
there is no truncated power series of this
order, or if it would require negative or
fractional exponents. Use substitution
and/or temporary multiplication by a power
of (Var minus Point) to determine more
general power series.

Point defaults to zero and is the expansion
point.
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tCdf() Catalog >
tCdf(lowBound,upBound,df) ⇒ number if
lowBound and upBound are numbers, list if
lowBound and upBound are lists

Computes the Student-t distribution
probability between lowBound and upBound
for the specified degrees of freedom df.

For P(X ≤ upBound), set lowBound = ⁻∞.

tCollect() Catalog >
tCollect(Expr1) ⇒ expression

Returns an expression in which products
and integer powers of sines and cosines are
converted to a linear combination of sines
and cosines of multiple angles, angle sums,
and angle differences. The transformation
converts trigonometric polynomials into a
linear combination of their harmonics.

Sometimes tCollect() will accomplish your
goals when the default trigonometric
simplification does not. tCollect() tends to
reverse transformations done by tExpand().
Sometimes applying tExpand() to a result
from tCollect(), or vice versa, in two
separate steps simplifies an expression.

tExpand() Catalog >
tExpand(Expr1) ⇒ expression

Returns an expression in which sines and
cosines of integer-multiple angles, angle
sums, and angle differences are expanded.
Because of the identity (sin(x))2+(cos(x))
2=1, there are many possible equivalent
results. Consequently, a result might differ
from a result shown in other publications.

Sometimes tExpand() will accomplish your
goals when the default trigonometric
simplification does not. tExpand() tends to
reverse transformations done by tCollect().
Sometimes applying tCollect() to a result
from tExpand(), or vice versa, in two
separate steps simplifies an expression.



tExpand() Catalog >
Note: Degree-mode scaling by π/180
interferes with the ability of tExpand() to
recognize expandable forms. For best
results, tExpand() should be used in Radian
mode.

Text Catalog >
TextpromptString[, DispFlag]

Programming command: Pauses the
program and displays the character string
promptString in a dialog box.

When the user selects OK, program
execution continues.

The optional flag argument can be any
expression.

• IfDispFlag is omitted or evaluates to 1,
the text message is added to the
Calculator history.

• IfDispFlag evaluates to 0, the text
message is not added to the history.

If the program needs a typed response from
the user, refer to Request, page 150, or
RequestStr, page 151.

Note: You can use this command within a
user-defined program but not within a
function.

Define a program that pauses to display
eachof five randomnumbers in a dialog
box.

Within the Prgm...EndPrgm template,
complete each line by pressing@ instead
of·. On the computer keyboard, hold
downAlt andpress Enter.

Define text_demo()=Prgm
  For i,1,5
    strinfo:=”Random number “ &
string(rand(i))
    Text strinfo
  EndFor
EndPrgm

Run the program:

text_demo()

Sample of one dialog box:

Then See If, page 87.

tInterval Catalog >
tInterval List[, Freq[, CLevel]]

(Data list input)
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tInterval Catalog >
tInterval v, sx, n[, CLevel]

(Summary stats input)

Computes a t confidence interval. A
summary of results is stored in the
stat.results variable. (See page 177.)

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.CLower, stat.CUpper Confidence interval for anunknownpopulationmean

stat.v Samplemeanof the data sequence from the normal randomdistribution

stat.ME Margin of error

stat.df Degrees of freedom

stat.σx Sample standarddeviation

stat.n Lengthof the data sequencewith samplemean

tInterval_2Samp Catalog >
tInterval_2Samp List1,List2[,Freq1[,Freq2
[,CLevel[,Pooled]]]]

(Data list input)

tInterval_2Samp v1,sx1,n1,v2,sx2,n2
[,CLevel[,Pooled]]

(Summary stats input)

Computes a two-sample t confidence
interval. A summary of results is stored in
the stat.results variable. (See page 177.)

Pooled=1 pools variances; Pooled=0 does
not pool variances.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.



Output variable Description

stat.CLower,
stat.CUpper

Confidence interval containing confidence level probability of distribution

stat.v1-v2 Samplemeans of the data sequences from the normal random
distribution

stat.ME Margin of error

stat.df Degrees of freedom

stat.v1, stat.v2 Samplemeans of the data sequences from the normal random
distribution

stat.σx1, stat.σx2 Sample standarddeviations for List 1 and List 2

stat.n1, stat.n2 Number of samples in data sequences

stat.sp The pooled standarddeviation. CalculatedwhenPooled = YES

tmpCnv() Catalog >
tmpCnv(Expr_°tempUnit, _°tempUnit2)
⇒ expression _°tempUnit2

Converts a temperature value specified by
Expr from one unit to another. Valid
temperature units are:

_°C Celsius
_°F Fahrenheit
_°K Kelvin
_°R Rankine

To type °, select it from the Catalog
symbols.

to type _ , press/_.

For example, 100_°C converts to 212_°F.

To convert a temperature range, use
ΔtmpCnv() instead.

Note: You canuse the Catalog to select
temperature units.
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ΔtmpCnv() Catalog >
ΔtmpCnv(Expr_°tempUnit, _°tempUnit2)
⇒ expression _°tempUnit2

Note: You can insert this function from the
keyboard by typing deltaTmpCnv(...).

Converts a temperature range (the
difference between two temperature
values) specified by Expr from one unit to
another. Valid temperature units are:

_°C Celsius
_°F Fahrenheit
_°K Kelvin
_°R Rankine

To enter °, select it from the Symbol
Palette or type @d.

To type _ , press/_.

1_°C and 1_°K have the same magnitude,
as do 1_°F and 1_°R. However, 1_°C is 9/5
as large as 1_°F.

For example, a 100_°C range (from 0_°C to
100_°C) is equivalent to a 180_°F range.

To convert a particular temperature value
instead of a range, use tmpCnv().

Note: You canuse the Catalog to select
temperature units.

tPdf() Catalog >
tPdf(XVal,df) ⇒ number if XVal is a
number, list if XVal is a list

Computes the probability density function
(pdf) for the Student-t distribution at a
specified x value with specified degrees of
freedom df.

trace() Catalog >
trace(squareMatrix) ⇒ expression

Returns the trace (sum of all the elements
on the main diagonal) of squareMatrix.



Try Catalog >
Try
     block1
Else
     block2
EndTry

Executes block1 unless an error occurs.
Program execution transfers to block2 if an
error occurs in block1. System variable
errCode contains the error code to allow
the program to perform error recovery. For
a list of error codes, see “Error codes and
messages,” page 251.

block1 and block2 can be either a single
statement or a series of statements
separated with the “:” character.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

To see the commands Try, ClrErr, and
PassErr in operation, enter the eigenvals()
program shown at the right. Run the
program by executing each of the following
expressions.

Note: See also ClrErr, page 25, and PassErr,
page 132.

Define eigenvals(a,b)=Prgm
© Programeigenvals(A,B) displays
eigenvalues of A•B

Try
    Disp "A= ",a
    Disp "B= ",b
    Disp " "

    Disp "Eigenvalues of A•B are:",eigVl(a*b)

Else
    If errCode=230 Then
        Disp "Error: Product of A•B must be a
squarematrix"
        ClrErr
    Else
        PassErr
    EndIf
EndTry

EndPrgm
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tTest Catalog >
tTest μ0,List[,Freq[,Hypoth]]

(Data list input)

tTest μ0,v,sx,n,[Hypoth]

(Summary stats input)

Performs a hypothesis test for a single
unknown population mean μ when the
population standard deviation σ is unknown.
A summary of results is stored in the
stat.results variable. (See page 177.)

Test H
0
: μ = μ0, against one of the

following:

For H
a
: μ < μ0, set Hypoth<0

For H
a
: μ ≠ μ0 (default), set Hypoth=0

For H
a
: μ > μ0, set Hypoth>0

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.t (v −μ0) / (stdev / sqrt(n))

stat.PVal Smallest level of significance atwhich the null hypothesis canbe rejected

stat.df Degrees of freedom

stat.v Samplemeanof the data sequence inList

stat.sx Sample standarddeviationof the data sequence

stat.n Size of the sample

tTest_2Samp Catalog >
tTest_2Samp List1,List2[,Freq1[,Freq2
[,Hypoth[,Pooled]]]]

(Data list input)

tTest_2Samp v1,sx1,n1,v2,sx2,n2[,Hypoth
[,Pooled]]

(Summary stats input)



tTest_2Samp Catalog >
Computes a two-sample t test. A summary
of results is stored in the stat.results
variable. (See page 177.)

Test H
0
: μ1 = μ2, against one of the

following:

For H
a
: μ1< μ2, set Hypoth<0

For H
a
: μ1≠ μ2 (default), set Hypoth=0

For H
a
: μ1> μ2, set Hypoth>0

Pooled=1 pools variances
Pooled=0 does not pool variances

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.t Standardnormal value computed for the difference ofmeans

stat.PVal Smallest level of significance atwhich the null hypothesis canbe rejected

stat.df Degrees of freedom for the t-statistic

stat.v1, stat.v2 Samplemeans of the data sequences inList 1 andList 2

stat.sx1, stat.sx2 Sample standarddeviations of the data sequences inList 1 andList 2

stat.n1, stat.n2 Size of the samples

stat.sp The pooled standarddeviation. CalculatedwhenPooled=1.

tvmFV() Catalog >
tvmFV(N,I,PV,Pmt,[PpY],[CpY],[PmtAt])
⇒ value

Financial function that calculates the future
value of money.

Note: Arguments used in the TVM functions
are described in the table of TVM
arguments, page 195. See also amortTbl(),
page 8.

tvmI() Catalog >
tvmI(N,PV,Pmt,FV,[PpY],[CpY],[PmtAt])
⇒ value
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tvmI() Catalog >
Financial function that calculates the
interest rate per year.

Note: Arguments used in the TVM functions
are described in the table of TVM
arguments, page 195. See also amortTbl(),
page 8.

tvmN() Catalog >
tvmN(I,PV,Pmt,FV,[PpY],[CpY],[PmtAt])
⇒ value

Financial function that calculates the
number of payment periods.

Note: Arguments used in the TVM functions
are described in the table of TVM
arguments, page 195. See also amortTbl(),
page 8.

tvmPmt() Catalog >
tvmPmt(N,I,PV,FV,[PpY],[CpY],[PmtAt])
⇒ value

Financial function that calculates the
amount of each payment.

Note: Arguments used in the TVM functions
are described in the table of TVM
arguments, page 195. See also amortTbl(),
page 8.

tvmPV() Catalog >
tvmPV(N,I,Pmt,FV,[PpY],[CpY],[PmtAt])
⇒ value

Financial function that calculates the
present value.

Note: Arguments used in the TVM functions
are described in the table of TVM
arguments, page 195. See also amortTbl(),
page 8.



TVM
argument*

Description Data type

N Number of payment periods real number

I Annual interest rate real number

PV Present value real number

Pmt Payment amount real number

FV Future value real number

PpY Payments per year, default=1 integer > 0

CpY Compounding periods per year, default=1 integer > 0

PmtAt Payment due at the endor beginning of eachperiod,
default=end

integer (0=end,
1=beginning)

* These time-value-of-money argument names are similar to the TVM variable names
(such as tvm.pv and tvm.pmt) that are used by the Calculator application’s finance
solver. Financial functions, however, do not store their argument values or results to
the TVM variables.

TwoVar Catalog >
TwoVar X, Y[, [Freq][, Category, Include]]

Calculates the TwoVar statistics. A summary
of results is stored in the stat.results
variable. (See page 177.)

All the lists must have equal dimension
except for Include.

X and Y are lists of independent and
dependent variables.

Freq is an optional list of frequency values.
Each element in Freq specifies the
frequency of occurrence for each
corresponding X and Y data point. The
default value is 1. All elements must be
integers ≥ 0.

Category is a list of numeric category codes
for the corresponding X and Y data.

Include is a list of one or more of the
category codes. Only those data items
whose category code is included in this list
are included in the calculation.
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TwoVar Catalog >
An empty (void) element in any of the lists
X, Freq, or Category results in a void for
the corresponding element of all those lists.
An empty element in any of the lists X1
through X20 results in a void for the
corresponding element of all those lists. For
more information on empty elements, see
page 236.

Output variable Description

stat.v Meanof x values

stat.Σx Sumof x values

stat.Σx2 Sumof x2 values

stat.sx Sample standarddeviationof x

stat.σx Population standarddeviationof x

stat.n Number of data points

stat.w Meanof y values

stat.Σy Sumof y values

stat.Σy2 Sumof y2 values

stat.sy Sample standarddeviationof y

stat.σy Population standarddeviationof y

stat.Σxy Sumof x•y values

stat.r Correlation coefficient

stat.MinX Minimumof x values

stat.Q1X 1stQuartile of x

stat.MedianX Medianof x

stat.Q3X 3rdQuartile of x

stat.MaxX Maximumof x values

stat.MinY Minimumof y values

stat.Q1Y 1stQuartile of y

stat.MedY Medianof y

stat.Q3Y 3rdQuartile of y



Output variable Description

stat.MaxY Maximumof y values

stat.Σ(x-v)2 Sumof squares of deviations from themeanof x

stat.Σ(y-w)2 Sumof squares of deviations from themeanof y

U

unitV() Catalog >
unitV(Vector1) ⇒ vector

Returns either a row- or column-unit vector,
depending on the form of Vector1.

Vector1must be either a single-row matrix
or a single-column matrix.

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

unLock Catalog >
unLock Var1[, Var2] [, Var3] ...
unLock Var.

Unlocks the specified variables or variable
group. Locked variables cannot be modified
or deleted.

See Lock, page 107, and getLockInfo(), page
83.
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V

varPop() Catalog >
varPop(List[, freqList]) ⇒ expression

Returns the population variance of List.

Each freqList element counts the number
of consecutive occurrences of the
corresponding element in List.

Note: List must contain at least two
elements.

If an element in either list is empty (void),
that element is ignored, and the
corresponding element in the other list is
also ignored. For more information on
empty elements, see page 236.

varSamp() Catalog >
varSamp(List[, freqList]) ⇒ expression

Returns the sample variance of List.

Each freqList element counts the number
of consecutive occurrences of the
corresponding element in List.

Note: List must contain at least two
elements.

If an element in either list is empty (void),
that element is ignored, and the
corresponding element in the other list is
also ignored. For more information on
empty elements, see page 236.

varSamp(Matrix1[, freqMatrix]) ⇒
matrix

Returns a row vector containing the sample
variance of each column inMatrix1.

Each freqMatrix element counts the
number of consecutive occurrences of the
corresponding element inMatrix1.



varSamp() Catalog >
If an element in either matrix is empty
(void), that element is ignored, and the
corresponding element in the other matrix
is also ignored. For more information on
empty elements, see page 236.

Note:Matrix1must contain at least two
rows.

W

Wait Catalog >
Wait timeInSeconds

Suspends execution for a period of
timeInSeconds seconds.

Wait is particularly useful in a program that
needs a brief delay to allow requested data
to become available.

The argument timeInSeconds must be an
expression that simplifies to a decimal value
in the range 0 through 100. The command
rounds this value up to the nearest 0.1
seconds.

To cancel a Wait that is in progress,

• Handheld: Hold down thec key and
press· repeatedly.

• Windows®: Hold down the F12 key and
press Enter repeatedly.

• Macintosh®: Hold down the F5 key and
press Enter repeatedly.

• iPad®: The app displays a prompt. You can
continue waiting or cancel.

Note: You can use the Wait command within
a user-defined program but not within a
function.

To wait 4 seconds:

Wait 4

To wait 1/2 second:

Wait 0.5

To wait 1.3 seconds using the variable
seccount:
seccount:=1.3
Wait seccount

This example switches a green LEDon for
0.5 seconds and then switches it off.

Send "SET GREEN 1 ON"
Wait 0.5
Send "SET GREEN 1 OFF" 
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warnCodes () Catalog >
warnCodes(Expr1, StatusVar) ⇒
expression

Evaluates expression Expr1, returns the
result, and stores the codes of any
generated warnings in the StatusVar list
variable. If no warnings are generated, this
function assigns StatusVar an empty list.

Expr1 can be any valid TI-Nspire™ or
TI-Nspire™ CAS math expression. You
cannot use a command or assignment as
Expr1.

StatusVar must be a valid variable name.

For a list of warning codes and associated
messages, see page 251.

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

when() Catalog >
when(Condition, trueResult [, falseResult]
[, unknownResult]) ⇒ expression

Returns trueResult, falseResult, or
unknownResult, depending on whether
Condition is true, false, or unknown.
Returns the input if there are too few
arguments to specify the appropriate result.

Omit both falseResult and unknownResult
to make an expression defined only in the
region where Condition is true.
Use an undef falseResult to define an
expression that graphs only on an interval.

when() is helpful for defining recursive
functions.



While Catalog >
While Condition
     Block
EndWhile

Executes the statements in Block as long
as Condition is true.

Block can be either a single statement or a
sequence of statements separated with the
“:” character.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

X

xor Catalog >
BooleanExpr1 xor BooleanExpr2 returns
Boolean expressionBooleanList1
xor BooleanList2 returns Boolean
listBooleanMatrix1
xor BooleanMatrix2 returns Boolean
matrix

Returns true if BooleanExpr1 is true and
BooleanExpr2 is false, or vice versa.

Returns false if both arguments are true or
if both are false. Returns a simplified
Boolean expression if either of the
arguments cannot be resolved to true or
false.

Note: See or, page 130.

Integer1 xor Integer2⇒ integer

Compares two real integers bit-by-bit using
an xor operation. Internally, both integers
are converted to signed, 64-bit binary
numbers. When corresponding bits are
compared, the result is 1 if either bit (but
not both) is 1; the result is 0 if both bits are
0 or both bits are 1. The returned value
represents the bit results, and is displayed
according to the Base mode.

InHex basemode:

Important: Zero, not the letter O.

In Bin basemode:
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xor Catalog >
You can enter the integers in any number
base. For a binary or hexadecimal entry, you
must use the 0b or 0h prefix, respectively.
Without a prefix, integers are treated as
decimal (base 10).

If you enter a decimal integer that is too
large for a signed, 64-bit binary form, a
symmetric modulo operation is used to
bring the value into the appropriate range.
For more information, see►Base2, page
17.

Note: See or, page 130.

Note: A binary entry canhave up to 64 digits
(not counting the 0bprefix). A hexadecimal
entry canhave up to 16 digits.

Z

zeros() Catalog >
zeros(Expr, Var) ⇒ list

zeros(Expr, Var=Guess) ⇒ list

Returns a list of candidate real values of
Var that make Expr=0. zeros() does this by
computing exp►list(solve
(Expr=0,Var),Var).
For some purposes, the result form for
zeros() is more convenient than that of
solve(). However, the result form of zeros()
cannot express implicit solutions, solutions
that require inequalities, or solutions that
do not involve Var.

Note: See also cSolve(), cZeros(), and solve
().

zeros({Expr1, Expr2},
{VarOrGuess1, VarOrGuess2 [, … ]}) ⇒
matrix

Returns candidate real zeros of the
simultaneous algebraic expressions, where
each VarOrGuess specifies an unknown
whose value you seek.

Optionally, you can specify an initial guess
for a variable. Each VarOrGuess must have
the form:



zeros() Catalog >
variable
– or –
variable = real or non-real number

For example, x is valid and so is x=3.

If all of the expressions are polynomials and
if you do NOT specify any initial guesses,
zeros() uses the lexical Gröbner/Buchberger
elimination method to attempt to
determine all real zeros.

For example, suppose you have a circle of
radius r at the origin and another circle of
radius r centered where the first circle
crosses the positive x-axis. Use zeros() to
find the intersections.

As illustrated by r in the example to the
right, simultaneous polynomial expressions
can have extra variables that have no
values, but represent given numeric values
that could be substituted later.

Each row of the resulting matrix represents
an alternate zero, with the components
ordered the same as the varOrGuess list.
To extract a row, index the matrix by [row].

Extract row2:

You can also (or instead) include unknowns
that do not appear in the expressions. For
example, you can include z as an unknown
to extend the previous example to two
parallel intersecting cylinders of radius r.
The cylinder zeros illustrate how families of
zeros might contain arbitrary constants in
the form ck, where k is an integer suffix
from 1 through 255.

For polynomial systems, computation time
or memory exhaustion may depend strongly
on the order in which you list unknowns. If
your initial choice exhausts memory or your
patience, try rearranging the variables in
the expressions and/or varOrGuess list.
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zeros() Catalog >
If you do not include any guesses and if any
expression is non-polynomial in any variable
but all expressions are linear in the
unknowns, zeros() uses Gaussian
elimination to attempt to determine all real
zeros.

If a system is neither polynomial in all of its
variables nor linear in its unknowns, zeros()
determines at most one zero using an
approximate iterative method. To do so, the
number of unknowns must equal the
number of expressions, and all other
variables in the expressions must simplify
to numbers.

Each unknown starts at its guessed value if
there is one; otherwise, it starts at 0.0.

Use guesses to seek additional zeros one by
one. For convergence, a guess may have to
be rather close to a zero.

zInterval Catalog >
zInterval σ,List[,Freq[,CLevel]]

(Data list input)

zInterval σ,v,n [,CLevel]

(Summary stats input)

Computes a z confidence interval. A
summary of results is stored in the
stat.results variable. (See page 177.)

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.CLower, stat.CUpper Confidence interval for anunknownpopulationmean

stat.x Samplemeanof the data sequence from the normal randomdistribution

stat.ME Margin of error

stat.sx Sample standarddeviation



Output variable Description

stat.n Lengthof the data sequencewith samplemean

stat.σ Knownpopulation standarddeviation for data sequenceList

zInterval_1Prop Catalog >
zInterval_1Prop x,n [,CLevel]

Computes a one-proportion z confidence
interval. A summary of results is stored in
the stat.results variable. (See page 177.)

x is a non-negative integer.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.CLower, stat.CUpper Confidence interval containing confidence level probability of distribution

stat.Ç The calculatedproportionof successes

stat.ME Margin of error

stat.n Number of samples in data sequence

zInterval_2Prop Catalog >
zInterval_2Prop x1,n1,x2,n2[,CLevel]

Computes a two-proportion z confidence
interval. A summary of results is stored in
the stat.results variable. (See page 177.)

x1 and x2 are non-negative integers.

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.CLower, stat.CUpper Confidence interval containing confidence level probability of distribution

stat.Ç Diff The calculateddifference betweenproportions

stat.ME Margin of error
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Output variable Description

stat.Ç1 First sample proportion estimate

stat.Ç2 Second sample proportion estimate

stat.n1 Sample size in data sequence one

stat.n2 Sample size in data sequence two

zInterval_2Samp Catalog >
zInterval_2Samp σ1,σ2 ,List1,List2[,Freq1[,Freq2,[CLevel]]]

(Data list input)

zInterval_2Samp σ1,σ2,v1,n1,v2,n2[,CLevel]

(Summary stats input)

Computes a two-sample z confidence
interval. A summary of results is stored in
the stat.results variable. (See page 177.)

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.CLower,
stat.CUpper

Confidence interval containing confidence level probability of distribution

stat.x1-x2 Samplemeans of the data sequences from the normal random
distribution

stat.ME Margin of error

stat.x1, stat.x2 Samplemeans of the data sequences from the normal random
distribution

stat.σx1, stat.σx2 Sample standarddeviations for List 1 andList 2

stat.n1, stat.n2 Number of samples in data sequences

stat.r1, stat.r2 Knownpopulation standarddeviations for data sequenceList 1 andList
2

zTest Catalog >
zTest μ0,σ,List,[Freq[,Hypoth]]



zTest Catalog >
(Data list input)

zTest μ0,σ,v,n[,Hypoth]

(Summary stats input)

Performs a z test with frequency freqlist. A
summary of results is stored in the
stat.results variable. (See page 177.)

Test H
0
: μ = μ0, against one of the

following:

For H
a
: μ < μ0, set Hypoth<0

For H
a
: μ ≠ μ0 (default), set Hypoth=0

For H
a
: μ > μ0, set Hypoth>0

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.z (x −μ0) / (σ / sqrt(n))

stat.P Value Least probability atwhich the null hypothesis canbe rejected

stat.x Samplemeanof the data sequence inList

stat.sx Sample standarddeviationof the data sequence. Only returned forData input.

stat.n Size of the sample

zTest_1Prop Catalog >

Output variable Description

stat.p0 Hypothesizedpopulationproportion

stat.z Standardnormal value computed for the proportion

stat.PVal Smallest level of significance atwhich the null hypothesis canbe rejected

stat.Ç Estimated sample proportion

stat.n Size of the sample

zTest_2Prop Catalog >
zTest_2Prop x1,n1,x2,n2[,Hypoth]
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zTest_2Prop Catalog >
Computes a two-proportion z test. A
summary of results is stored in the
stat.results variable. (See page 177.)

x1 and x2 are non-negative integers.

Test H
0
: p1 = p2, against one of the

following:

For H
a
: p1 > p2, set Hypoth>0

For H
a
: p1 ≠ p2 (default), set Hypoth=0

For H
a
: p < p0, set Hypoth<0

For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.z Standardnormal value computed for the difference of proportions

stat.PVal Smallest level of significance atwhich the null hypothesis canbe rejected

stat.Ç1 First sample proportion estimate

stat.Ç2 Second sample proportion estimate

stat.Ç Pooled sample proportion estimate

stat.n1, stat.n2 Number of samples taken in trials 1 and2

zTest_2Samp Catalog >
zTest_2Samp σ1,σ2 ,List1,List2[,Freq1[,Freq2[,Hypoth]]]

(Data list input)

zTest_2Samp σ1,σ2,v1,n1,v2,n2[,Hypoth]

(Summary stats input)

Computes a two-sample z test. A summary
of results is stored in the stat.results
variable. (See page 177.)

Test H
0
: μ1 = μ2, against one of the

following:

For H
a
: μ1 < μ2, set Hypoth<0

For H
a
: μ1 ≠ μ2 (default), set Hypoth=0

For H
a
: μ1 > μ2, Hypoth>0



zTest_2Samp Catalog >
For information on the effect of empty
elements in a list, see “Empty (Void)
Elements,” page 236.

Output variable Description

stat.z Standardnormal value computed for the difference ofmeans

stat.PVal Smallest level of significance atwhich the null hypothesis canbe rejected

stat.x1, stat.x2 Samplemeans of the data sequences inList1 andList2

stat.sx1, stat.sx2 Sample standarddeviations of the data sequences inList1 andList2

stat.n1, stat.n2 Size of the samples
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+ (add) + key
Expr1 + Expr2⇒ expression

Returns the sum of the two arguments.

List1 + List2⇒ list

Matrix1 +Matrix2⇒ matrix

Returns a list (or matrix) containing the
sums of corresponding elements in List1
and List2 (orMatrix1 andMatrix2).

Dimensions of the arguments must be
equal.

Expr + List1⇒ list

List1 + Expr⇒ list

Returns a list containing the sums of Expr
and each element in List1.
Expr +Matrix1⇒ matrix

Matrix1 + Expr⇒ matrix

Returns a matrix with Expr added to each
element on the diagonal of Matrix1.
Matrix1must be square.

Note: Use .+ (dot plus) to add an expression
to each element.

− (subtract) - key
Expr1 − Expr2⇒ expression

Returns Expr1minus Expr2.

List1 −List2⇒ list

Matrix1 −Matrix2 ⇒ matrix



− (subtract) - key
Subtracts each element in List2 (or
Matrix2) from the corresponding element
in List1 (orMatrix1), and returns the
results.

Dimensions of the arguments must be
equal.

Expr − List1⇒ list

List1 − Expr⇒ list

Subtracts each List1 element from Expr or
subtracts Expr from each List1 element,
and returns a list of the results.

Expr −Matrix1⇒ matrix

Matrix1 − Expr⇒ matrix

Expr −Matrix1 returns a matrix of Expr
times the identity matrix minus
Matrix1.  Matrix1must be square.

Matrix1 − Expr returns a matrix of Expr
times the identity matrix subtracted from
Matrix1.  Matrix1must be square.

Note: Use .− (dot minus) to subtract an
expression from each element.

• (multiply) r key
Expr1•Expr2⇒ expression

Returns the product of the two arguments.

List1•List2⇒ list

Returns a list containing the products of the
corresponding elements in List1 and List2.

Dimensions of the lists must be equal.

Matrix1•Matrix2⇒ matrix

Returns the matrix product of Matrix1 and
Matrix2.

The number of columns inMatrix1must
equal the number of rows inMatrix2.
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• (multiply) r key
Expr •List1⇒ list

List1•Expr⇒ list

Returns a list containing the products of
Expr and each element in List1.

Expr •Matrix1⇒ matrix

Matrix1•Expr⇒ matrix

Returns a matrix containing the products of
Expr and each element inMatrix1.

Note: Use .•(dot multiply) to multiply an
expression by each element.

⁄ (divide) p key
Expr1 ⁄ Expr2⇒ expression

Returns the quotient of Expr1 divided by
Expr2.

Note: See also Fraction template, page 1.

List1 ⁄ List2⇒ list

Returns a list containing the quotients of
List1 divided by List2.

Dimensions of the lists must be equal.

Expr ⁄ List1⇒ list

List1 ⁄ Expr⇒ list

Returns a list containing the quotients of
Expr divided by List1 orList1 divided by
Expr.
Matrix1 ⁄ Expr⇒ matrix

Returns a matrix containing the quotients
of Matrix1 ⁄ Expr.

Matrix1 ⁄ Value⇒ matrix



⁄ (divide) p key
Note: Use . ⁄ (dot divide) to divide an
expression by each element.

^ (power) l key
Expr1 ^ Expr2⇒ expression

List1 ^ List2⇒ list

Returns the first argument raised to the
power of the second argument.

Note: See also Exponent template, page 1.

For a list, returns the elements in List1
raised to the power of the corresponding
elements in List2.

In the real domain, fractional powers that
have reduced exponents with odd
denominators use the real branch versus
the principal branch for complex mode.

Expr ^ List1⇒ list

Returns Expr raised to the power of the
elements in List1.
List1 ^ Expr⇒ list

Returns the elements in List1 raised to the
power of Expr.
squareMatrix1 ^ integer⇒ matrix

Returns squareMatrix1 raised to the
integer power.

squareMatrix1must be a square matrix.

If integer = −1, computes the inverse
matrix.
If integer < −1, computes the inverse
matrix to an appropriate positive power.
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x2 (square) q key
Expr12⇒ expression

Returns the square of the argument.

List12 ⇒ list

Returns a list containing the squares of the
elements in List1.

squareMatrix12 ⇒ matrix

Returns the matrix square of
squareMatrix1. This is not the same as
calculating the square of each element. Use
.^2 to calculate the square of each element.

.+ (dot add) ^+ keys
Matrix1 .+Matrix2⇒ matrix

Expr .+Matrix1⇒ matrix

Matrix1.+Matrix2 returns a matrix that is
the sum of each pair of corresponding
elements inMatrix1 andMatrix2.

Expr .+ Matrix1 returns a matrix that is
the sum of Expr and each element in
Matrix1.

.⁻(dot subt.) ^- keys
Matrix1 .−Matrix2⇒ matrix

Expr .−Matrix1⇒matrix

Matrix1.− Matrix2 returns a matrix that is
the difference between each pair of
corresponding elements inMatrix1 and
Matrix2.

Expr .− Matrix1 returns a matrix that is
the difference of Expr and each element in
Matrix1.

.



.•(dot mult.) ^r keys
Matrix1 .• Matrix2⇒ matrix

Expr .• Matrix1⇒ matrix

Matrix1.• Matrix2 returns a matrix that is
the product of each pair of corresponding
elements inMatrix1 andMatrix2.

Expr .• Matrix1 returns a matrix
containing the products of Expr and each
element inMatrix1.

. ⁄ (dot divide) ^p keys
Matrix1. ⁄Matrix2⇒ matrix

Expr . ⁄Matrix1⇒ matrix

Matrix1 . ⁄Matrix2 returns a matrix that is
the quotient of each pair of corresponding
elements inMatrix1 andMatrix2.

Expr . ⁄ Matrix1 returns a matrix that is
the quotient of Expr and each element in
Matrix1.

.^ (dot power) ^l keys
Matrix1 .^Matrix2⇒ matrix

Expr . ^Matrix1⇒ matrix

Matrix1.^ Matrix2 returns a matrix where
each element inMatrix2 is the exponent
for the corresponding element inMatrix1.

Expr .^ Matrix1 returns a matrix where
each element inMatrix1 is the exponent
for Expr.

− (negate) v key
−Expr1 ⇒ expression

−List1⇒ list

−Matrix1⇒ matrix
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− (negate) v key
Returns the negation of the argument.

For a list or matrix, returns all the elements
negated.

If the argument is a binary or hexadecimal
integer, the negation gives the two’s
complement.

In Bin base mode:

Important: Zero, not the letter O.

To see the entire result, press£ and then
use ¡ and ¢ to move the cursor.

% (percent) /k keys
Expr1% ⇒ expression

List1% ⇒ list

Matrix1% ⇒ matrix

Returns

For a list or matrix, returns a list or matrix
with each element divided by 100.

Note: To force anapproximate result,

Handheld: Press/·.
Windows®: Press Ctrl+Enter.
Macintosh®: Press “+Enter.
iPad®: Holdenter, and select .

= (equal) = key
Expr1=Expr2⇒ Boolean expression

List1=List2⇒ Boolean list

Matrix1=Matrix2⇒ Boolean matrix

Returns true if Expr1 is determined to be
equal to Expr2.

Returns false if Expr1 is determined to not
be equal to Expr2.

Anything else returns a simplified form of
the equation.

For lists and matrices, returns comparisons
element by element.

Example function that uses math test
symbols: =, ≠, <, ≤, >, ≥

Result of graphing g(x)



= (equal) = key
Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

≠ (not equal) /= keys
Expr1≠Expr2⇒ Boolean expression

List1≠List2⇒ Boolean list

Matrix1≠Matrix2⇒ Boolean matrix

Returns true if Expr1 is determined to be
not equal to Expr2.

Returns false if Expr1 is determined to be
equal to Expr2.

Anything else returns a simplified form of
the equation.

For lists and matrices, returns comparisons
element by element.

Note: You can insert this operator from the
keyboard by typing /=

See “=” (equal) example.

< (less than) /= keys
Expr1<Expr2⇒ Boolean expression

List1<List2⇒ Boolean list

Matrix1<Matrix2⇒ Boolean matrix

Returns true if Expr1 is determined to be
less than Expr2.

Returns false if Expr1 is determined to be
greater than or equal to Expr2.

See “=” (equal) example.

Symbols 217



218 Symbols

< (less than) /= keys
Anything else returns a simplified form of
the equation.

For lists and matrices, returns comparisons
element by element.

≤ (less or equal) /= keys
Expr1≤Expr2⇒ Boolean expression

List1≤List2⇒ Boolean list

Matrix1 ≤Matrix2⇒ Boolean matrix

Returns true if Expr1 is determined to be
less than or equal to Expr2.

Returns false if Expr1 is determined to be
greater than Expr2.

Anything else returns a simplified form of
the equation.

For lists and matrices, returns comparisons
element by element.

Note: You can insert this operator from the
keyboard by typing <=

See “=” (equal) example.

> (greater than) /= keys
Expr1>Expr2⇒ Boolean expression

List1>List2⇒ Boolean list

Matrix1>Matrix2⇒ Boolean matrix

Returns true if Expr1 is determined to be
greater than Expr2.

Returns false if Expr1 is determined to be
less than or equal to Expr2.

Anything else returns a simplified form of
the equation.

For lists and matrices, returns comparisons
element by element.

See “=” (equal) example.



≥ (greater or equal) /= keys
Expr1≥Expr2⇒ Boolean expression

List1≥List2⇒ Boolean list

Matrix1 ≥Matrix2⇒ Boolean matrix

Returns true if Expr1 is determined to be
greater than or equal to Expr2.

Returns false if Expr1 is determined to be
less than Expr2.

Anything else returns a simplified form of
the equation.

For lists and matrices, returns comparisons
element by element.

Note: You can insert this operator from the
keyboard by typing >=

See “=” (equal) example.

⇒ (logical implication) /= keys
BooleanExpr1⇒ BooleanExpr2 returns
Boolean expression

BooleanList1⇒ BooleanList2 returns
Boolean list

BooleanMatrix1⇒ BooleanMatrix2
returns Boolean matrix

Integer1⇒ Integer2 returns Integer

Evaluates the expression not <argument1>
or <argument2> and returns true, false, or a
simplified form of the equation.

For lists and matrices, returns comparisons
element by element.

Note: You can insert this operator from the
keyboard by typing =>
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⇔ (logical double implication, XNOR) /= keys
BooleanExpr1⇔ BooleanExpr2 returns
Boolean expression

BooleanList1⇔ BooleanList2 returns
Boolean list

BooleanMatrix1⇔ BooleanMatrix2
returns Boolean matrix

Integer1⇔ Integer2 returns Integer

Returns the negation of an XOR Boolean
operation on the two arguments. Returns
true, false, or a simplified form of the
equation.

For lists and matrices, returns comparisons
element by element.

Note: You can insert this operator from the
keyboard by typing <=>

! (factorial) º key
Expr1! ⇒ expression

List1! ⇒ list

Matrix1! ⇒ matrix

Returns the factorial of the argument.

For a list or matrix, returns a list or matrix
of factorials of the elements.

& (append) /k keys
String1 & String2⇒ string

Returns a text string that is String2
appended to String1.



d() (derivative) Catalog >
d(Expr1, Var[, Order]) ⇒ expression

d(List1, Var[, Order]) ⇒ list

d(Matrix1,Var[, Order]) ⇒ matrix

Returns the first derivative of the first
argument with respect to variable Var.

Order, if included, must be an integer. If
the order is less than zero, the result will be
an anti-derivative.

Note: You can insert this function from the
keyboard by typing derivative(...).

d() does not follow the normal evaluation
mechanism of fully simplifying its
arguments and then applying the function
definition to these fully simplified
arguments. Instead, d() performs the
following steps:

1. Simplify the second argument only to
the extent that it does not lead to a
non-variable.

2. Simplify the first argument only to the
extent that it does recall any stored
value for the variable determined by
step 1.

3. Determine the symbolic derivative of
the result of step 2 with respect to the
variable from step 1.

If the variable from step 1 has a stored
value or a value specified by the constraint
(“|”) operator, substitute that value into
the result from step 3.

Note: See also First derivative,  page 5;
Second derivative,  page 6; or
Nth derivative,  page 6.

∫() (integral) Catalog >
∫(Expr1, Var[,Lower,Upper]) ⇒
expression

∫(Expr1,Var[,Constant]) ⇒ expression

Symbols 221



222 Symbols

∫() (integral) Catalog >
Returns the integral of Expr1 with respect
to the variable Var from Lower toUpper.

Note: See also Definite or Indefinite integral
template, page 6.

Note: You can insert this function from the
keyboard by typing integral(...).

If Lower andUpper are omitted, returns an
anti-derivative. A symbolic constant of
integration is omitted unless you provide
the Constant argument.

Equally valid anti-derivatives might differ by
a numeric constant. Such a constant might
be disguised—particularly when an anti-
derivative contains logarithms or inverse
trigonometric functions. Moreover,
piecewise constant expressions are
sometimes added to make an anti-
derivative valid over a larger interval than
the usual formula.

∫() returns itself for pieces of Expr1 that it
cannot determine as an explicit finite
combination of its built-in functions and
operators.

When you provide Lower andUpper, an
attempt is made to locate any
discontinuities or discontinuous derivatives
in the interval Lower < Var < Upper and to
subdivide the interval at those places.

For the Auto setting of the Auto or
Approximate mode, numerical integration is
used where applicable when an anti-
derivative or a limit cannot be determined.

For the Approximate setting, numerical
integration is tried first, if applicable. Anti-
derivatives are sought only where such
numerical integration is inapplicable or
fails.

Note: To force anapproximate result,

Handheld: Press/·.
Windows®: Press Ctrl+Enter.
Macintosh®: Press “+Enter.
iPad®: Holdenter, and select .



∫() (integral) Catalog >

∫() can be nested to do multiple integrals.
Integration limits can depend on integration
variables outside them.

Note: See also nInt(), page 123.

√() (square root) /q keys
√(Expr1) ⇒ expression

√(List1) ⇒ list

Returns the square root of the argument.

For a list, returns the square roots of all the
elements in List1.

Note: You can insert this function from the
keyboard by typing sqrt(...)

Note: See also Square root template, page
1.

Π() (prodSeq) Catalog >
Π(Expr1, Var, Low, High) ⇒ expression

Note: You can insert this function from the
keyboard by typing prodSeq(...).

Evaluates Expr1 for each value of Var from
Low toHigh, and returns the product of the
results.

Note: See also Product template (Π), page
5.
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Π() (prodSeq) Catalog >
Π(Expr1, Var, Low, Low−1) ⇒ 1

Π(Expr1, Var, Low, High) ⇒ 1/Π(Expr1,
Var, High+1, Low−1) if High < Low−1

The product formulas used are derived from
the following reference:

Ronald L. Graham, Donald E. Knuth, and
Oren Patashnik. Concrete Mathematics: A
Foundation for Computer Science.
Reading, Massachusetts: Addison-Wesley,
1994.

Σ() (sumSeq) Catalog >
Σ(Expr1, Var, Low, High) ⇒ expression

Note: You can insert this function from the
keyboard by typing sumSeq(...).

Evaluates Expr1 for each value of Var from
Low toHigh, and returns the sum of the
results.

Note: See also Sum template, page 5.

Σ(Expr1, Var, Low, Low−1) ⇒ 0

Σ(Expr1, Var, Low, High) ⇒ μ

Σ(Expr1, Var, High+1, Low−1) if High <
Low−1

The summation formulas used are derived
from the following reference:

Ronald L. Graham, Donald E. Knuth, and
Oren Patashnik. Concrete Mathematics: A
Foundation for Computer Science.
Reading, Massachusetts: Addison-Wesley,
1994.



ΣInt() Catalog >
ΣInt(NPmt1, NPmt2, N, I, PV ,[Pmt], [FV],
[PpY], [CpY], [PmtAt], [roundValue])
⇒  value

ΣInt(NPmt1,NPmt2,amortTable) ⇒ value

Amortization function that calculates the
sum of the interest during a specified range
of payments.

NPmt1 and NPmt2 define the start and end
boundaries of the payment range.

N, I, PV, Pmt, FV, PpY, CpY, and PmtAt
are described in the table of TVM
arguments, page 195.

• If you omit Pmt, it defaults to
Pmt=tvmPmt
(N,I,PV,FV,PpY,CpY,PmtAt).

• If you omit FV, it defaults to FV=0.
• The defaults for PpY, CpY, and PmtAt

are the same as for the TVM functions.

roundValue specifies the number of
decimal places for rounding. Default=2.

ΣInt(NPmt1,NPmt2,amortTable) calculates
the sum of the interest based on
amortization table amortTable. The
amortTable argument must be a matrix in
the form described under amortTbl(), page
8.

Note: See also ΣPrn(), below, and Bal(),
page 17.

ΣPrn() Catalog >
ΣPrn(NPmt1, NPmt2, N, I, PV, [Pmt],
[FV], [PpY], [CpY], [PmtAt],
[roundValue]) ⇒ value

ΣPrn(NPmt1, NPmt2, amortTable) ⇒
value

Amortization function that calculates the
sum of the principal during a specified
range of payments.
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ΣPrn() Catalog >
NPmt1 and NPmt2 define the start and end
boundaries of the payment range.

N, I, PV, Pmt, FV, PpY, CpY, and PmtAt
are described in the table of TVM
arguments, page 195.

• If you omit Pmt, it defaults to
Pmt=tvmPmt
(N,I,PV,FV,PpY,CpY,PmtAt).

• If you omit FV, it defaults to FV=0.
• The defaults for PpY, CpY, and PmtAt

are the same as for the TVM functions.

roundValue specifies the number of
decimal places for rounding. Default=2.

ΣPrn(NPmt1,NPmt2,amortTable)
calculates the sum of the principal paid
based on amortization table amortTable.
The amortTable argument must be a
matrix in the form described under
amortTbl(), page 8.

Note: See also ΣInt(), above, and Bal(),
page 17.

# (indirection) /k keys
# varNameString

Refers to the variable whose name is
varNameString. This lets you use strings to
create variable names from within a
function.

Creates or refers to the variable xyz .

Returns the value of the variable (r) whose
name is stored in variable s1.



E (scientific notation) i key
mantissaEexponent

Enters a number in scientific notation. The
number is interpreted as
mantissa × 10exponent.

Hint: If you want to enter a power of 10
without causing a decimal value result, use
10^integer.

Note: You can insert this operator from the
computer keyboard by typing @E. for
example, type 2.3@E4 to enter 2.3E4.

g (gradian) ¹ key
Expr1g ⇒ expression

List1g ⇒ list

Matrix1g ⇒ matrix

This function gives you a way to specify a
gradian angle while in the Degree or Radian
mode.

In Radian angle mode, multiplies Expr1 by
π/200.

In Degree angle mode, multiplies Expr1 by
g/100.

In Gradian mode, returns Expr1 unchanged.

Note: You can insert this symbol from the
computer keyboard by typing @g.

InDegree, Gradianor Radianmode:

r(radian) ¹ key
Expr1r ⇒expression

List1r ⇒ list

Matrix1r ⇒ matrix

InDegree, Gradianor Radian anglemode:

Symbols 227



228 Symbols

r(radian) ¹ key
This function gives you a way to specify a
radian angle while in Degree or Gradian
mode.

In Degree angle mode, multiplies the
argument by 180/π.

In Radian angle mode, returns the
argument unchanged.

In Gradian mode, multiplies the argument
by 200/π.

Hint: Use r if you want to force radians in a
function definition regardless of the mode
that prevails when the function is used.

Note: You can insert this symbol from the
computer keyboard by typing @r.

° (degree) ¹ key
Expr1°⇒expression

List1°⇒ list

Matrix1°⇒ matrix

This function gives you a way to specify a
degree angle while in Gradian or Radian
mode.

In Radian angle mode, multiplies the
argument by π/180.

In Degree angle mode, returns the
argument unchanged.

In Gradian angle mode, multiplies the
argument by 10/9.

Note: You can insert this symbol from the
computer keyboard by typing @d.

InDegree, Gradianor Radian anglemode:

In Radian anglemode:

Note: To force anapproximate result,

Handheld: Press/·.
Windows®: Press Ctrl+Enter.
Macintosh®: Press “+Enter.
iPad®: Holdenter, and select .

°, ', '' (degree/minute/second) /k keys
dd°mm'ss.ss'' ⇒ expression InDegree anglemode:



°, ', '' (degree/minute/second) /k keys
dd A positive or negative number
mm A non-negative number
ss.ss A non-negative number

Returns dd+(mm/60)+(ss.ss/3600).

This base-60 entry format lets you:

• Enter an angle in
degrees/minutes/seconds without regard
to the current angle mode.

• Enter time as hours/minutes/seconds.

Note: Follow ss.ss with two apostrophes
(''), not a quote symbol (").

∠ (angle) /k keys
[Radius,∠θ_Angle] ⇒ vector
(polar input)

[Radius,∠θ_Angle,Z_Coordinate] ⇒
vector
(cylindrical input)

[Radius,∠θ_Angle,∠θ_Angle] ⇒ vector
(spherical input)

Returns coordinates as a vector depending
on the Vector Format mode setting:
rectangular, cylindrical, or spherical.

Note: You can insert this symbol from the
computer keyboard by typing @<.

In Radianmode andvector format set to:
rectangular

cylindrical

spherical

(Magnitude∠Angle) ⇒ complexValue
(polar input)

Enters a complex value in (r∠θ) polar
form. The Angle is interpreted according to
the current Angle mode setting.

In Radian anglemode andRectangular
complex format:

Note: To force anapproximate result,

Handheld: Press/·.
Windows®: Press Ctrl+Enter.
Macintosh®: Press “+Enter.
iPad®: Holdenter, and select .
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∠ (angle) /k keys

' (prime) º key
variable '
variable ' '

Enters a prime symbol in a differential
equation. A single prime symbol denotes a
1st-order differential equation, two prime
symbols denote a 2nd-order, and so on.

_ (underscore as an empty element)
See “Empty (Void) Elements,”

page 236.

_ (underscore as unit designator) /_ keys
Expr_Unit

Designates the units for an Expr. All unit
names must begin with an underscore.

You can use pre-defined units or create your
own units. For a list of pre-defined units,
open the Catalog and display the Unit
Conversions tab. You can select unit names
from the Catalog or type the unit names
directly.

Note: You can find the conversion symbol,

►, in the Catalog. Click , and then click
MathOperators.

Variable_

When Variable has no value, it is treated
as though it represents a complex number.
By default, without the _ , the variable is
treated as real.

If Variable has a value, the _ is ignored and
Variable retains its original data type.

Note: You can store a complex number to a
variable without
using _ . However, for best results in
calculations such as cSolve() and cZeros(),
the _ is recommended.

Assuming z is undefined:



► (convert) /k keys

Expr_Unit1►_Unit2⇒ Expr_Unit2

Converts an expression from one unit to
another.

The _ underscore character designates the
units. The units must be in the same
category, such as Length or Area.

For a list of pre-defined units, open the
Catalog and display the Unit Conversions
tab:

• You can select a unit name from the list.
• You can select the conversion operator,

►, from the top of the list.

You can also type unit names manually. To
type “_” when typing unit names on the
handheld, press/_.

Note: To convert temperature units, use
tmpCnv() and ΔtmpCnv(). The► conversion
operator does not handle temperature
units.

10^() Catalog >
10^ (Expr1) ⇒ expression

10^ (List1) ⇒ list

Returns 10 raised to the power of the
argument.

For a list, returns 10 raised to the power of
the elements in List1.
10^(squareMatrix1) ⇒ squareMatrix

Returns 10 raised to the power of
squareMatrix1. This is not the same as
calculating 10 raised to the power of each
element. For information about the
calculation method, refer to cos().

squareMatrix1must be diagonalizable. The
result always contains floating-point
numbers.
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^⁻¹ (reciprocal) Catalog >
Expr1 ^⁻¹⇒ expression

List1 ^⁻¹⇒ list

Returns the reciprocal of the argument.

For a list, returns the reciprocals of the
elements in List1.
squareMatrix1 ^⁻¹⇒ squareMatrix

Returns the inverse of squareMatrix1.

squareMatrix1must be a non-singular
square matrix.

| (constraint operator) /k keys
Expr | BooleanExpr1[and
BooleanExpr2]...

Expr | BooleanExpr1[ orBooleanExpr2]...

The constraint (“|”) symbol serves as a
binary operator. The operand to the left of |
is an expression. The operand to the right of
| specifies one or more relations that are
intended to affect the simplification of the
expression. Multiple relations after | must
be joined by logical “and” or “or” operators.

The constraint operator provides three basic
types of functionality:

• Substitutions
• Interval constraints
• Exclusions

Substitutions are in the form of an equality,
such as x=3 or y=sin(x). To be most
effective, the left side should be a simple
variable. Expr | Variable = value will
substitute value for every occurrence of
Variable in Expr.



| (constraint operator) /k keys
Interval constraints take the form of one or
more inequalities joined by logical “and” or
“or” operators. Interval constraints also
permit simplification that otherwise might
be invalid or not computable.

Exclusions use the “not equals” (/= or ≠)
relational operator to exclude a specific
value from consideration. They are used
primarily to exclude an exact solution when
using cSolve(), cZeros(), fMax(), fMin(),
solve(), zeros(), and so on.

→ (store) /h key
Expr → Var

List→ Var

Matrix→ Var

Expr→ Function(Param1,...)

List→ Function(Param1,...)

Matrix→ Function(Param1,...)

If the variable Var does not exist, creates it
and initializes it to Expr, List, orMatrix.

If the variable Var already exists and is not
locked or protected, replaces its contents
with Expr, List, orMatrix.
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→ (store) /h key
Hint: If you plan to do symbolic
computations using undefined variables,
avoid storing anything into commonly used,
one-letter variables such as a, b, c, x, y, z,
and so on.

Note: You can insert this operator from the
keyboard by typing =: as a shortcut. For
example, type pi/4 =: myvar.

:= (assign) /t keys
Var := Expr

Var := List

Var :=Matrix

Function(Param1,...) := Expr

Function(Param1,...) := List

Function(Param1,...) :=Matrix

If variable Var does not exist, creates Var
and initializes it to Expr, List, orMatrix.

If Var already exists and is not locked or
protected, replaces its contents with Expr,
List, orMatrix.

Hint: If you plan to do symbolic
computations using undefined variables,
avoid storing anything into commonly used,
one-letter variables such as a, b, c, x, y, z,
and so on.



© (comment) /k keys
© [text]

© processes text as a comment line,
allowing you to annotate functions and
programs that you create.

© can be at the beginning or anywhere in
the line. Everything to the right of ©, to the
end of the line, is the comment.

Note for entering the example: For
instructions on entering multi-line program
and function definitions, refer to the
Calculator section of your product
guidebook.

0b, 0h 0B keys,0H keys
0b binaryNumber
0h hexadecimalNumber

Denotes a binary or hexadecimal number,
respectively. To enter a binary or hex
number, you must enter the 0b or 0h prefix
regardless of the Base mode. Without a
prefix, a number is treated as decimal
(base 10).

Results are displayed according to the Base
mode.

InDec basemode:

In Bin basemode:

InHex basemode:
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Empty (Void) Elements
When analyzing real-world data, you might not always have a complete data set.
TI-Nspire™ CAS Software allows empty, or void, data elements so you can proceed
with the nearly complete data rather than having to start over or discard the
incomplete cases.

You can find an example of data involving empty elements in the Lists & Spreadsheet
chapter, under “Graphing spreadsheet data.”

The delVoid() function lets you remove empty elements from a list. The isVoid()
function lets you test for an empty element. For details, see delVoid(), page 49, and
isVoid(), page 95.

Note: To enter an empty element manually in a math expression, type “_” or the
keyword void. The keyword void is automatically converted to a “_” symbol when
the expression is evaluated. To type “_” on the handheld, press/_.

Calculations involving void elements
The majority of calculations involving a void
input will produce a void result. See special
cases below.

List arguments containing void elements
The following functions and commands
ignore (skip) void elements found in list
arguments.

count, countIf, cumulativeSum,
freqTable►list, frequency, max, mean,
median, product, stDevPop, stDevSamp,
sum, sumIf, varPop, and varSamp, as well as
regression calculations, OneVar, TwoVar,
and FiveNumSummary statistics, confidence
intervals, and stat tests

SortA and SortDmove all void elements
within the first argument to the bottom.



List arguments containing void elements

In regressions, a void in an X or Y list
introduces a void for the corresponding
element of the residual.

An omitted category in regressions
introduces a void for the corresponding
element of the residual.

A frequency of 0 in regressions introduces a
void for the corresponding element of the
residual.
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Shortcuts for Entering Math Expressions
Shortcuts let you enter elements of math expressions by typing instead of using the
Catalog or Symbol Palette. For example, to enter the expression √6, you can type sqrt
(6) on the entry line. When you press·, the expression sqrt(6) is changed to
√6. Some shortcuts are useful from both the handheld and the computer keyboard.
Others are useful primarily from the computer keyboard.

From the Handheld or Computer Keyboard

To enter this: Type this shortcut:

π pi

θ theta

∞ infinity

≤ <=

≥ >=

≠ /=

⇒ (logical implication) =>

⇔ (logical double implication, XNOR) <=>

→ (store operator) =:

| | (absolute value) abs(...)

√() sqrt(...)

d() derivative(...)

∫() integral(...)

Σ() (Sum template) sumSeq(...)

Π() (Product template) prodSeq(...)

sin⁻¹(), cos⁻¹(), ... arcsin(...), arccos(...), ...

ΔList() deltaList(...)

ΔtmpCnv() deltaTmpCnv(...)

From the Computer Keyboard

To enter this: Type this shortcut:

c1, c2, ... (constants) @c1, @c2, ...



To enter this: Type this shortcut:

n1, n2, ... (integer constants) @n1, @n2, ...

i (imaginary constant) @i

e (natural log base e) @e

E (scientific notation) @E
T (transpose) @t
r (radians) @r

° (degrees) @d
g (gradians) @g

∠ (angle) @<

► (conversion) @>

►Decimal,►approxFraction(), and
so on.

@>Decimal, @>approxFraction(), and
so on.
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EOS™ (Equation Operating System) Hierarchy
This section describes the Equation Operating System (EOS™) that is used by the
TI-Nspire™ CAS math and science learning technology. Numbers, variables, and
functions are entered in a simple, straightforward sequence. EOS™ software evaluates
expressions and equations using parenthetical grouping and according to the priorities
described below.

Order of Evaluation

Level Operator

1 Parentheses ( ), brackets [ ], braces { }

2 Indirection (#)

3 Function calls

4 Post operators: degrees-minutes-seconds (°,',"), factorial (!), percentage
(%), radian (r), subscript ([ ]), transpose (T)

5 Exponentiation, power operator (^)

6 Negation (⁻)

7 String concatenation (&)

8 Multiplication (•), division (/)

9 Addition (+), subtraction (-)

10 Equality relations: equal (=), not equal (≠ or /=),
less than (<), less than or equal (≤ or <=), greater than (>), greater than or
equal (≥ or >=)

11 Logical not

12 Logical and

13 Logical or

14 xor, nor, nand

15 Logical implication (⇒ )

16 Logical double implication, XNOR (⇔ )

17 Constraint operator (“|”)

18 Store (→)

Parentheses, Brackets, and Braces

All calculations inside a pair of parentheses, brackets, or braces are evaluated first. For
example, in the expression 4(1+2), EOS™ software first evaluates the portion of the
expression inside the parentheses, 1+2, and then multiplies the result, 3, by 4.



The number of opening and closing parentheses, brackets, and braces must be the
same within an expression or equation. If not, an error message is displayed that
indicates the missing element. For example, (1+2)/(3+4 will display the error message
“Missing ).”

Note: Because the TI-Nspire™ CAS software allows you to define your own functions, a
variable name followed by an expression in parentheses is considered a “function call”
instead of implied multiplication. For example a(b+c) is the function a evaluated by
b+c. To multiply the expression b+c by the variable a, use explicit multiplication: a•
(b+c).

Indirection

The indirection operator (#) converts a string to a variable or function name. For
example, #(“x”&”y”&”z”) creates the variable name xyz. Indirection also allows the
creation and modification of variables from inside a program. For example, if 10→r
and “r”→s1, then #s1=10.

Post Operators

Post operators are operators that come directly after an argument, such as 5!, 25%, or
60°15' 45". Arguments followed by a post operator are evaluated at the fourth priority
level. For example, in the expression 4^3!, 3! is evaluated first. The result, 6, then
becomes the exponent of 4 to yield 4096.

Exponentiation

Exponentiation (^) and element-by-element exponentiation (.^) are evaluated from
right to left. For example, the expression 2^3^2 is evaluated the same as 2^(3^2) to
produce 512. This is different from (2^3)^2, which is 64.

Negation

To enter a negative number, pressv followed by the number. Post operations and
exponentiation are performed before negation. For example, the result of −x2 is a
negative number, and −92 = −81. Use parentheses to square a negative number such
as (−9)2 to produce 81.

Constraint (“|”)

The argument following the constraint (“|”) operator provides a set of constraints that
affect the evaluation of the argument preceding the operator.
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Constants and Values
The following table lists the constants and their values that are available when
performing unit conversions. They can be typed in manually or selected from the
Constants list in Utilities > Unit Conversions (Handheld: Pressk 3).

Constant Name Value

_c Speedof light 299792458 _m/_s

_Cc Coulombconstant 8987551787.3682 _m/_F

_Fc Faraday constant 96485.33289 _coul/_mol

_g Accelerationof gravity 9.80665 _m/_s2

_Gc Gravitational constant 6.67408E-11 _m3/_kg/_s2

_h Planck's constant 6.626070040E-34 _J _s

_k Boltzmann's constant 1.38064852E-23 _J/_¡K

_m0 Permeability of a vacuum 1.2566370614359E-6 _N/_A2

_mb Bohr magneton 9.274009994E-24 _J _m2/_Wb

_Me Electron restmass 9.10938356E-31 _kg

_Mm Muonmass 1.883531594E-28 _kg

_Mn Neutron restmass 1.674927471E-27 _kg

_Mp Proton restmass 1.672621898E-27 _kg

_Na Avogadro's number 6.022140857E23 /_mol

_q Electron charge 1.6021766208E-19 _coul

_Rb Bohr radius 5.2917721067E-11 _m

_Rc Molar gas constant 8.3144598 _J/_mol/_¡K

_Rdb Rydberg constant 10973731.568508/_m

_Re Electron radius 2.8179403227E-15 _m

_u Atomicmass 1.660539040E-27 _kg

_Vm Molar volume 2.2413962E-2 _m3/_mol

_H0 Permittivity of a vacuum 8.8541878176204E-12 _F/_m

_s Stefan-Boltzmann constant 5.670367E-8 _W/_m2/_¡K4

_f0 Magnetic flux quantum 2.067833831E-15 _Wb



Error Codes and Messages
When an error occurs, its code is assigned to variable errCode. User-defined programs
and functions can examine errCode to determine the cause of an error. For an
example of using errCode, See Example 2 under the Try command, page 191.

Note: Some error conditions apply only to TI-Nspire™ CAS products, and some apply
only to TI-Nspire™ products.

Error
code Description

10 A functiondid not return a value

20 A test did not resolve to TRUE or FALSE.

Generally, undefined variables cannot be compared. For example, the test If a<bwill cause
this error if either a or b is undefinedwhen the If statement is executed.

30 Argument cannot be a folder name.

40 Argument error

50 Argumentmismatch

Two or more arguments must be of the same type.

60 Argumentmust be a Booleanexpressionor integer

70 Argumentmust be a decimal number

90 Argumentmust be a list

100 Argumentmust be amatrix

130 Argumentmust be a string

140 Argumentmust be a variable name.

Make sure that the name:
• does not begin with a digit
• does not contain spaces or special characters
• does not use underscore or period in invalid manner
• does not exceed the length limitations

See the Calculator section in the documentation for more details.

160 Argumentmust be anexpression

165 Batteries too low for sending or receiving

Install newbatteries before sending or receiving.

170 Bound

The lower boundmust be less than the upper bound to define the search interval.
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Error
code Description

180 Break

Thed orc key was pressedduring a long calculationor during programexecution.

190 Circular definition

This message is displayed to avoid running out ofmemory during infinite replacement of
variable values during simplification. For example, a+1->a, where a is anundefined variable,
will cause this error.

200 Constraint expression invalid

For example, solve(3x^2-4=0,x) | x<0 or x>5wouldproduce this error message because the
constraint is separatedby “or” insteadof “and.”

210 InvalidData type

Anargument is of thewrong data type.

220 Dependent limit

230 Dimension

A list or matrix index is not valid. For example, if the list {1,2,3,4} is stored in L1, then L1[5] is a
dimensionerror because L1 only contains four elements.

235 Dimension Error. Not enoughelements in the lists.

240 Dimensionmismatch

Two or more arguments must be of the same dimension. For example, [1,2]+[1,2,3] is a
dimensionmismatchbecause thematrices contain a different number of elements.

250 Divide by zero

260 Domain error

Anargumentmust be in a specifieddomain. For example, rand(0) is not valid.

270 Duplicate variable name

280 Else andElseIf invalid outside of If...EndIf block

290 EndTry is missing thematching Else statement

295 Excessive iteration

300 Expected2 or 3-element list or matrix

310 The first argumentof nSolvemust be anequation in a single variable. It cannot contain a non-
valued variable other than the variable of interest.

320 First argumentof solve or cSolvemust be anequationor inequality

For example, solve(3x^2-4,x) is invalid because the first argument is not anequation.



Error
code Description

345 Inconsistent units

350 Index out of range

360 Indirection string is not a valid variable name

380 UndefinedAns

Either the previous calculationdid not create Ans, or no previous calculationwas entered.

390 Invalid assignment

400 Invalid assignment value

410 Invalid command

430 Invalid for the currentmode settings

435 Invalid guess

440 Invalid impliedmultiply

For example, x(x+1) is invalid; whereas, x*(x+1) is the correct syntax. This is to avoid
confusionbetween impliedmultiplication and function calls.

450 Invalid in a functionor current expression

Only certain commands are valid in a user-defined function.

490 Invalid in Try..EndTry block

510 Invalid list or matrix

550 Invalid outside functionor program

A number of commands are not valid outside a functionor program. For example, Local
cannot be usedunless it is in a functionor program.

560 Invalid outside Loop..EndLoop, For..EndFor, or While..EndWhile blocks

For example, the Exit command is valid only inside these loopblocks.

565 Invalid outside program

570 Invalid pathname

For example, \var is invalid.

575 Invalid polar complex

580 Invalid program reference

Programs cannot be referencedwithin functions or expressions such as 1+p(x) where p is a
program.
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Error
code Description

600 Invalid table

605 Invalid use of units

610 Invalid variable name in a Local statement

620 Invalid variable or functionname

630 Invalid variable reference

640 Invalid vector syntax

650 Link transmission

A transmissionbetween two units was not completed. Verify that the connecting cable is
connected firmly to bothends.

665 Matrix not diagonalizable

670 LowMemory

1. Delete some data in this document

2. Save and close this document

If 1 and2 fail, pull out and re-insert batteries

672 Resource exhaustion

673 Resource exhaustion

680 Missing (

690 Missing )

700 Missing “

710 Missing ]

720 Missing }

730 Missing start or endof block syntax

740 Missing Then in the If..EndIf block

750 Name is not a functionor program

765 No functions selected

780 No solution found

800 Non-real result

For example, if the software is in the Real setting, √(-1) is invalid.



Error
code Description

To allow complex results, change the “Real or Complex”Mode Setting to RECTANGULAR or
POLAR.

830 Overflow

850 Programnot found

A program reference inside another program couldnot be found in the providedpathduring
execution.

855 Rand type functions not allowed in graphing

860 Recursion too deep

870 Reservedname or systemvariable

900 Argument error

Median-medianmodel could not be applied to data set.

910 Syntax error

920 Text not found

930 Too fewarguments

The functionor command is missing one or more arguments.

940 Too many arguments

The expressionor equation contains anexcessive number of arguments and cannot be
evaluated.

950 Too many subscripts

955 Too many undefined variables

960 Variable is not defined

No value is assigned to variable. Use one of the following commands:
• sto→
• :=
• Define

to assign values to variables.

965 UnlicensedOS

970 Variable in use so references or changes are not allowed

980 Variable is protected

990 Invalid variable name

Make sure that the name does not exceed the length limitations
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Error
code Description

1000 Windowvariables domain

1010 Zoom

1020 Internal error

1030 Protectedmemory violation

1040 Unsupported function. This function requires Computer Algebra System. Try TI-Nspire™
CAS.

1045 Unsupportedoperator. This operator requires Computer Algebra System. Try TI-Nspire™
CAS.

1050 Unsupported feature. This operator requires Computer Algebra System. Try TI-Nspire™
CAS.

1060 Input argumentmust be numeric. Only inputs containing numeric values are allowed.

1070 Trig function argument too big for accurate reduction

1080 Unsupporteduse of Ans.This applicationdoes not support Ans.

1090 Function is not defined. Use one of the following commands:
• Define
• :=
• sto→

to define a function.

1100 Non-real calculation

For example, if the software is in the Real setting, √(-1) is invalid.

To allow complex results, change the “Real or Complex”Mode Setting to RECTANGULAR or
POLAR.

1110 Invalid bounds

1120 No sign change

1130 Argument cannot be a list or matrix

1140 Argument error

The first argumentmust be a polynomial expression in the secondargument. If the second
argument is omitted, the software attempts to select a default.

1150 Argument error

The first two arguments must be polynomial expressions in the third argument. If the third
argument is omitted, the software attempts to select a default.

1160 Invalid library pathname



Error
code Description

A pathnamemust be in the form xxx\yyy, where:
• The xxx part can have 1 to 16 characters.
• The yyy part can have 1 to 15 characters.

See the Library section in the documentation for more details.

1170 Invalid use of library pathname
• A value cannot be assigned to a pathname using Define, :=, or sto→.
• A pathname cannot be declared as a Local variable or be used as a

parameter in a function or program definition.

1180 Invalid library variable name.

Make sure that the name:
• Does not contain a period
• Does not begin with an underscore
• Does not exceed 15 characters

See the Library section in the documentation for more details.

1190 Library document not found:
• Verify library is in the MyLib folder.
• Refresh Libraries.

See the Library section in the documentation for more details.

1200 Library variable not found:
• Verify library variable exists in the first problem in the library.
• Make sure library variable has been defined as LibPub or LibPriv.
• Refresh Libraries.

See the Library section in the documentation for more details.

1210 Invalid library shortcut name.

Make sure that the name:
• Does not contain a period
• Does not begin with an underscore
• Does not exceed 16 characters
• Is not a reserved name

See the Library section in the documentation for more details.

1220 Domain error:

The tangentLine andnormalLine functions support real-valued functions only.

1230 Domain error.
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Error
code Description

Trigonometric conversionoperators are not supported inDegree or Gradian anglemodes.

1250 Argument Error

Use a systemof linear equations.

Example of a systemof two linear equations with variables x and y:

  3x+7y=5

  2y-5x=-1

1260 Argument Error:

The first argumentof nfMinor nfMaxmust be anexpression in a single variable. It cannot
contain a non-valued variable other than the variable of interest.

1270 Argument Error

Order of the derivativemust be equal to 1 or 2.

1280 Argument Error

Use a polynomial in expanded form inone variable.

1290 Argument Error

Use a polynomial in one variable.

1300 Argument Error

The coefficients of the polynomialmust evaluate to numeric values.

1310 Argument error:

A function couldnot be evaluated for one or more of its arguments.

1380 Argument error:

Nested calls to domain() function are not allowed.



Warning Codes and Messages
You can use the warnCodes() function to store the codes of warnings generated by
evaluating an expression. This table lists each numeric warning code and its associated
message. For an example of storing warning codes, see warnCodes(), page 200.

Warning
code Message

10000 Operationmight introduce false solutions.

10001 Differentiating anequationmay produce a false equation.

10002 Questionable solution

10003 Questionable accuracy

10004 Operationmight lose solutions.

10005 cSolvemight specify more zeros.

10006 Solvemay specify more zeros.

10007 More solutionsmay exist. Try specifying appropriate lower andupper bounds and/or a
guess.

Examples using solve():
• solve(Equation, Var=Guess)|lowBound<Var<upBound
• solve(Equation, Var)|lowBound<Var<upBound
• solve(Equation, Var=Guess)

10008 Domainof the resultmight be smaller than the domainof the input.

10009 Domainof the resultmight be larger than the domainof the input.

10012 Non-real calculation

10013 ∞^0 or undef^0 replacedby 1

10014 undef^0 replacedby 1

10015 1^∞ or 1^undef replacedby 1

10016 1^undef replacedby 1

10017 Overflow replacedby∞ or −∞

10018 Operation requires and returns 64 bit value.

10019 Resource exhaustion, simplificationmight be incomplete.

10020 Trig function argument too big for accurate reduction.

10021 Input contains anundefinedparameter.

Resultmight not be valid for all possible parameter values.
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Warning
code Message

10022 Specifying appropriate lower andupper boundsmight produce a solution.

10023 Scalar has beenmultipliedby the identity matrix.

10024 Result obtainedusing approximate arithmetic.

10025 Equivalence cannot be verified in EXACTmode.

10026 Constraintmight be ignored. Specify constraint in the form "\" 'VariableMathTestSymbol
Constant' or a conjunct of these forms, for example 'x<3 and x>-12'
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-

-, subtract 210

!

!, factorial 220

"

", second notation 228

#

#, indirection 226
#, indirection operator 241

%

%, percent 216

&

&, append 220

*

*, multiply 211

.

.-, dot subtraction 214

.*, dot multiplication 215

./, dot division 215

.^, dot power 215

.+, dot addition 214

/

/, divide 212

:

:=, assign 234

^

^⁻¹, reciprocal 232

^, power 213

_

_, unit designation 230

|

|, constraint operator 232

′

′minute notation 228
′, prime 230

+

+, add 210

=

≠, not equal 217
≤, less than or equal 218
≥, greater than or equal 219
>, greater than 218
=, equal 216

∏

∏, product 223

∑

∑( ), sum 224
∑Int( ) 225
∑Prn( ) 225

√

√, square root 223

∠

∠ (angle) 229

∫

∫, integral 221
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►

►, convert units 231
►approxFraction( ) 13
►Base10, display as decimal integer 18
►Base16, display as hexadecimal 19
►Base2, display as binary 17
►cos, display in terms of cosine 29
►Cylind, display as cylindrical vector 42
►DD, display as decimal angle 45
►Decimal, display result as decimal 46
►DMS, display as

degree/minute/second 55
►exp, display in terms of e 64
►Grad, convert to gradian angle 87
►Polar, display as polar vector 134
►Rad, convert to radian angle 144
►Rect, display as rectangular vector 147
►sin, display in terms of sine 166
►Sphere, display as spherical vector 175

⇒

⇒ , logical implication 219, 238

→

→, store variable 233

⇔

⇔ , logical double implication 220, 238

©

©, comment 235

°

°, degree notation 228
°, degrees/minutes/seconds 228

0

0b, binary indicator 235
0h, hexadecimal indicator 235

1

10^( ), power of ten 231

2

2-sample F Test 76

A

abs( ), absolute value 8
absolute value

template for 3-4
add, + 210
amortization table, amortTbl( ) 8, 17
amortTbl( ), amortization table 8, 17
and, Boolean operator 9
angle( ), angle 10
angle, angle( ) 10
ANOVA, one-way variance analysis 10
ANOVA2way, two-way variance

analysis 11
Ans, last answer 13
answer (last), Ans 13
append, & 220
approx( ), approximate 13-14
approximate, approx( ) 13-14
approxRational( ) 14
arc length, arcLen( ) 15
arccos(), cos⁻¹() 14
arccosh(), cosh⁻¹() 14
arccot(), cot⁻¹() 14
arccoth(), coth⁻¹() 14
arccsc(), csc⁻¹() 14
arccsch(), csch⁻¹() 14
arcLen( ), arc length 15
arcsec(), sec⁻¹() 15
arcsech(), csech⁻¹() 15
arcsin(), sin⁻¹() 15
arcsinh(), sinh⁻¹() 15
arctan(), tan⁻¹() 15
arctanh(), tanh⁻¹() 15
arguments in TVM functions 195
augment( ), augment/concatenate 15
augment/concatenate, augment( ) 15
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average rate of change, avgRC( ) 16
avgRC( ), average rate of change 16

B

binary
display, ►Base2 17
indicator, 0b 235

binomCdf( ) 20, 93
binomPdf( ) 20
Boolean operators

⇒ 219, 238
⇔ 220
and 9
nand 120
nor 124
not 126
or 130
xor 201

C

Cdf( ) 69
ceiling( ), ceiling 20
ceiling, ceiling( ) 20-21, 36
centralDiff( ) 21
cFactor( ), complex factor 21
char( ), character string 22
character string, char( ) 22
characters

numeric code, ord( ) 131
string, char( ) 22

charPoly( ) 23
χ²2way 23
clear

error, ClrErr 25
ClearAZ 25
ClrErr, clear error 25
colAugment 26
colDim( ), matrix column dimension 26
colNorm( ), matrix column norm 26
combinations, nCr( ) 121
comDenom( ), common

denominator 26
comment, © 235

common denominator, comDenom
( ) 26

completeSquare( ), complete square 27
complex

conjugate, conj( ) 28
factor, cFactor( ) 21
solve, cSolve( ) 38
zeros, cZeros( ) 42

conj( ), complex conjugate 28
constant

in solve( ) 172
constants

in cSolve( ) 40
in cZeros( ) 44
in deSolve( ) 50
in solve( ) 173
in zeros( ) 203
shortcuts for 238

constraint operator "|" 232
constraint operator, order of

evaluation 240
construct matrix, constructMat( ) 28
constructMat( ), construct matrix 28
convert

►Grad 87
►Rad 144
units 231

copy variable or function, CopyVar 29
correlation matrix, corrMat( ) 29
corrMat( ), correlation matrix 29
cos⁻¹, arccosine 31
cos( ), cosine 30
cosh⁻¹( ), hyperbolic arccosine 32
cosh( ), hyperbolic cosine 32
cosine

display expression in terms of 29
cosine, cos( ) 30
cot⁻¹( ), arccotangent 33
cot( ), cotangent 33
cotangent, cot( ) 33
coth⁻¹( ), hyperbolic arccotangent 34
coth( ), hyperbolic cotangent 34
count days between dates, dbd( ) 45
count items in a list conditionally , 35
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countif( )
count items in a list, count( ) 34
count( ), count items in a list 34
countif( ), conditionally count items

in a list 35
cPolyRoots() 36
cross product, crossP( ) 36
crossP( ), cross product 36
csc⁻¹( ), inverse cosecant 37
csc( ), cosecant 36
csch⁻¹( ), inverse hyperbolic cosecant 37
csch( ), hyperbolic cosecant 37
cSolve( ), complex solve 38
cubic regression, CubicReg 40
CubicReg, cubic regression 40
cumulative sum, cumulativeSum( ) 41
cumulativeSum( ), cumulative sum 41
cycle, Cycle 42
Cycle, cycle 42
cylindrical vector display, ►Cylind 42
cZeros( ), complex zeros 42

D

d( ), first derivative 221
days between dates, dbd( ) 45
dbd( ), days between dates 45
decimal

angle display, ►DD 45
integer display, ►Base10 18

Define 46
Define LibPriv 47
Define LibPub 48
define, Define 46
Define, define 46
defining

private function or program 47
public function or program 48

definite integral
template for 6

degree notation, ° 228
degree/minute/second display,

►DMS 55
degree/minute/second notation 228

delete
void elements from list 49

deleting
variable, DelVar 49

deltaList() 48
deltaTmpCnv() 48
DelVar, delete variable 49
delVoid( ), remove void elements 49
denominator 26
derivative or nth derivative

template for 6
derivative() 49
derivatives

first derivative, d( ) 221
numeric derivative, nDeriv( ) 122-123
numeric derivative, nDerivative( 

) 122
deSolve( ), solution 49
det( ), matrix determinant 51
diag( ), matrix diagonal 52
dim( ), dimension 52
dimension, dim( ) 52
Disp, display data 53, 159
DispAt 53
display as

binary, ►Base2 17
cylindrical vector, ►Cylind 42
decimal angle, ►DD 45
decimal integer, ►Base10 18
degree/minute/second, ►DMS 55
hexadecimal, ►Base16 19
polar vector, ►Polar 134
rectangular vector, ►Rect 147
spherical vector, ►Sphere 175

display data, Disp 53, 159
distribution functions

binomCdf( ) 20, 93
binomPdf( ) 20
invNorm( ) 93
invt( ) 93
Invχ²( ) 92
normCdf( ) 126
normPdf( ) 126
poissCdf( ) 133
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poissPdf( ) 133
tCdf( ) 186
tPdf( ) 190
χ²2way( ) 23
χ²Cdf( ) 24
χ²GOF( ) 24
χ²Pdf( ) 24

divide, / 212
domain function, domain( ) 55
domain( ), domain function 55
dominant term, dominantTerm( ) 56
dominantTerm( ), dominant term 56
dot

addition, .+ 214
division, ./ 215
multiplication, .* 215
power, .^ 215
product, dotP( ) 57
subtraction, .- 214

dotP( ), dot product 57

E

e exponent
template for 2

e to a power, e^( ) 57, 64
e, display expression in terms of 64
E, exponent 227
e^( ), e to a power 57
eff( ), convert nominal to effective

rate 58
effective rate, eff( ) 58
eigenvalue, eigVl( ) 59
eigenvector, eigVc( ) 58
eigVc( ), eigenvector 58
eigVl( ), eigenvalue 59
else if, ElseIf 60
else, Else 87
ElseIf, else if 60
empty (void) elements 236
end

for, EndFor 73
function, EndFunc 76
if, EndIf 87

loop, EndLoop 111
program, EndPrgm 138
try, EndTry 191
while, EndWhile 201

end function, EndFunc 76
end if, EndIf 87
end loop, EndLoop 111
end while, EndWhile 201
EndTry, end try 191
EndWhile, end while 201
EOS (Equation Operating System) 240
equal, = 216
Equation Operating System (EOS) 240
error codes and messages 243, 251
errors and troubleshooting

clear error, ClrErr 25
pass error, PassErr 132

euler( ), Euler function 61
evaluate polynomial, polyEval( ) 135
evaluation, order of 240
exact( ), exact 63
exact, exact( ) 63
exclusion with "|" operator 232
exit, Exit 63
Exit, exit 63
exp( ), e to a power 64
exp►list( ), expression to list 64
expand( ), expand 65
expand, expand( ) 65
exponent, E 227
exponential regession, ExpReg 66
exponents

template for 1
expr( ), string to expression 66, 108
ExpReg, exponential regession 66
expressions

expression to list, exp►list( ) 64
string to expression, expr( ) 66, 108

F

factor( ), factor 68
factor, factor( ) 68
factorial, ! 220
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Fill, matrix fill 70
financial functions, tvmFV( ) 193
financial functions, tvmI( ) 193
financial functions, tvmN( ) 194
financial functions, tvmPmt( ) 194
financial functions, tvmPV( ) 194
first derivative

template for 5
FiveNumSummary 70
floor( ), floor 71
floor, floor( ) 71
fMax( ), function maximum 71
fMin( ), function minimum 72
For 73
for, For 73
For, for 73
format string, format( ) 73
format( ), format string 73
fpart( ), function part 74
fractions

propFrac 139
template for 1

freqTable( ) 74
frequency( ) 75
Frobenius norm, norm( ) 125
Func, function 76
Func, program function 76
functions

maximum, fMax( ) 71
minimum, fMin( ) 72
part, fpart( ) 74
program function, Func 76
user-defined 46

functions and variables
copying 29

G

g, gradians 227
gcd( ), greatest common divisor 77
geomCdf( ) 77
geomPdf( ) 78
Get 78
get/return

denominator, getDenom( ) 79

number, getNum( ) 85
variables injformation,

getVarInfo( ) 83, 86
getDenom( ), get/return

denominator 79
getKey() 79
getLangInfo( ), get/return language

information 83
getLockInfo( ), tests lock status of

variable or variable group 83
getMode( ), get mode settings 84
getNum( ), get/return number 85
GetStr 85
getType( ), get typeof variable 85
getVarInfo( ), get/return variables

information 86
go to, Goto 87
Goto, go to 87
gradian notation, g 227
greater than or equal, ≥ 219
greater than, > 218
greatest common divisor, gcd( ) 77
groups, locking and unlocking 107, 197
groups, testing lock status 83

H

hexadecimal
display, ►Base16 19
indicator, 0h 235

hyperbolic
arccosine, cosh⁻¹( ) 32
arcsine, sinh⁻¹( ) 169
arctangent, tanh⁻¹( ) 185
cosine, cosh( ) 32
sine, sinh( ) 168
tangent, tanh( ) 184

I

identity matrix, identity( ) 87
identity( ), identity matrix 87
if, If 87
If, if 87
ifFn( ) 89
imag( ), imaginary part 89
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imaginary part, imag( ) 89
ImpDif( ), implicit derivative 90
implicit derivative, Impdif( ) 90
indefinite integral

template for 6
indirection operator (#) 241
indirection, # 226
input, Input 90
Input, input 90
inString( ), within string 90
int( ), integer 91
intDiv( ), integer divide 91
integer divide, intDiv( ) 91
integer part, iPart( ) 94
integer, int( ) 91
integral, ∫ 221
interpolate( ), interpolate 91
inverse cumulative normal

distribution (invNorm(  ) 93
inverse, ^⁻¹ 232
invF( ) 92
invNorm( ), inverse cumulative

normal distribution) 93
invt( ) 93
Invχ²( ) 92
iPart( ), integer part 94
irr( ), internal rate of return

internal rate of return, irr( ) 94
isPrime( ), prime test 94
isVoid( ), test for void 95

L

label, Lbl 96
language

get language information 83
Lbl, label 96
lcm, least common multiple 96
least common multiple, lcm 96
left( ), left 96
left, left( ) 96
length of string 52
less than or equal, ≤ 218
LibPriv 47

LibPub 48
library

create shortcuts to objects 97
libShortcut( ), create shortcuts to

library objects 97
limit

lim( ) 97
limit( ) 97
template for 6

limit( ) or lim( ), limit 97
linear regression, LinRegAx 99
linear regression, LinRegBx 98, 100
LinRegBx, linear regression 98
LinRegMx, linear regression 99
LinRegtIntervals, linear regression 100
LinRegtTest 102
linSolve() 103
Δlist( ), list difference 104
list to matrix, list►mat( ) 104
list, conditionally count items in 35
list, count items in 34
list►mat( ), list to matrix 104
lists

augment/concatenate,
augment( ) 15

cross product, crossP( ) 36
cumulative sum,

cumulativeSum( ) 41
differences in a list, Δlist( ) 104
dot product, dotP( ) 57
empty elements in 236
expression to list, exp►list( ) 64
list to matrix, list►mat( ) 104
matrix to list, mat►list( ) 112
maximum, max( ) 112
mid-string, mid( ) 115
minimum, min( ) 116
new, newList( ) 122
product, product( ) 139
sort ascending, SortA 174
sort descending, SortD 175
summation, sum( ) 180-181

ln( ), natural logarithm 104
LnReg, logarithmic regression 105
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local variable, Local 106
local, Local 106
Local, local variable 106
Lock, lock variable or variable group 107
locking variables and variable groups 107
Log

template for 2
logarithmic regression, LnReg 105
logarithms 104
logical double implication,⇔ 220
logical implication,⇒ 219, 238
logistic regression, Logistic 108
logistic regression, LogisticD 109
Logistic, logistic regression 108
LogisticD, logistic regression 109
loop, Loop 111
Loop, loop 111
LU, matrix lower-upper

decomposition 111

M

mat►list( ), matrix to list 112
matrices

augment/concatenate,
augment( ) 15

column dimension, colDim( ) 26
column norm, colNorm( ) 26
cumulative sum,

cumulativeSum( ) 41
determinant, det( ) 51
diagonal, diag( ) 52
dimension, dim( ) 52
dot addition, .+ 214
dot division, ./ 215
dot multiplication, .* 215
dot power, .^ 215
dot subtraction, .- 214
eigenvalue, eigVl( ) 59
eigenvector, eigVc( ) 58
filling, Fill 70
identity, identity( ) 87
list to matrix, list►mat( ) 104
lower-upper decomposition, LU 111
matrix to list, mat►list( ) 112

maximum, max( ) 112
minimum, min( ) 116
new, newMat( ) 122
product, product( ) 139
QR factorization, QR 140
random, randMat( ) 145
reduced row echelon form, rref( 

) 157
row addition, rowAdd( ) 156
row dimension, rowDim( ) 156
row echelon form, ref( ) 148
row multiplication and addition,

mRowAdd( ) 117
row norm, rowNorm( ) 156
row operation, mRow( ) 117
row swap, rowSwap( ) 157
submatrix, subMat( ) 180, 182
summation, sum( ) 180-181
transpose, T 182

matrix (1 × 2)
template for 4

matrix (2 × 1)
template for 4

matrix (2 × 2)
template for 4

matrix (m ×n)
template for 4

matrix to list, mat►list( ) 112
max( ), maximum 112
maximum, max( ) 112
mean( ), mean 113
mean, mean( ) 113
median( ), median 113
median, median( ) 113
medium-medium line regression,

MedMed 114
MedMed, medium-medium line

regression 114
mid-string, mid( ) 115
mid( ), mid-string 115
min( ), minimum 116
minimum, min( ) 116
minute notation, ′ 228
mirr( ), modified internal rate of

return 116
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mixed fractions, using propFrac(›
with 139

mod( ), modulo 117
mode settings, getMode( ) 84
modes

setting, setMode( ) 162
modified internal rate of return, mirr

( ) 116
modulo, mod( ) 117
mRow( ), matrix row operation 117
mRowAdd( ), matrix row

multiplication and addition 117
Multiple linear regression t test 119
multiply, * 211
MultReg 118
MultRegIntervals( ) 118
MultRegTests( ) 119

N

nand, Boolean operator 120
natural logarithm, ln( ) 104
nCr( ), combinations 121
nDerivative( ), numeric derivative 122
negation, entering negative numbers 241
net present value, npv( ) 127
new

list, newList( ) 122
matrix, newMat( ) 122

newList( ), new list 122
newMat( ), new matrix 122
nfMax( ), numeric function

maximum 122
nfMin( ), numeric function minimum 123
nInt( ), numeric integral 123
nom ), convert effective to nominal

rate 124
nominal rate, nom( ) 124
nor, Boolean operator 124
norm( ), Frobenius norm 125
normal distribution probability,

normCdf( ) 126
normal line, normalLine( ) 125
normalLine( ) 125
normCdf( ) 126

normPdf( ) 126
not equal, ≠ 217
not, Boolean operator 126
nPr( ), permutations 127
npv( ), net present value 127
nSolve( ), numeric solution 128
nth root

template for 1
numeric

derivative, nDeriv( ) 122-123
derivative, nDerivative( ) 122
integral, nInt( ) 123
solution, nSolve( ) 128

O

objects
create shortcuts to library 97

one-variable statistics, OneVar 129
OneVar, one-variable statistics 129
operators

order of evaluation 240
or (Boolean), or 130
or, Boolean operator 130
ord( ), numeric character code 131

P

P►Rx( ), rectangular x coordinate 131
P►Ry( ), rectangular y coordinate 132
pass error, PassErr 132
PassErr, pass error 132
Pdf( ) 74
percent, % 216
permutations, nPr( ) 127
piecewise function (2-piece)

template for 2
piecewise function (N-piece)

template for 3
piecewise( ) 133
poissCdf( ) 133
poissPdf( ) 133
polar

coordinate, R►Pr( ) 144
coordinate, R►Pθ( ) 143
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vector display, ►Polar 134
polyCoef( ) 134
polyDegree( ) 135
polyEval( ), evaluate polynomial 135
polyGcd( ) 136
polynomials

evaluate, polyEval( ) 135
random, randPoly( ) 146

PolyRoots() 137
power of ten, 10^( ) 231
power regression,

PowerReg 137, 150-151, 187
power, ^ 213
PowerReg, power regression 137
Prgm, define program 138
primenumber test, isPrime( ) 94
prime, ′ 230
probability densiy, normPdf( ) 126
prodSeq() 139
product( ), product 139
product, ∏( ) 223

template for 5
product, product( ) 139
programming

define program, Prgm 138
display data, Disp 53, 159
pass error, PassErr 132

programs
defining private library 47
defining public library 48

programs and programming
clear error, ClrErr 25
display I/O screen, Disp 53, 159
end program, EndPrgm 138
end try, EndTry 191
try, Try 191

proper fraction, propFrac 139
propFrac, proper fraction 139

Q

QR factorization, QR 140
QR, QR factorization 140
quadratic regression, QuadReg 141
QuadReg, quadratic regression 141

quartic regression, QuartReg 142
QuartReg, quartic regression 142

R

R, radian 227
R►Pr( ), polar coordinate 144
R►Pθ( ), polar coordinate 143
radian, R 227
rand( ), random number 144
randBin, random number 145
randInt( ), random integer 145
randMat( ), random matrix 145
randNorm( ), random norm 146
random

matrix, randMat( ) 145
norm, randNorm( ) 146
number seed, RandSeed 146
polynomial, randPoly( ) 146

random sample 146
randPoly( ), random polynomial 146
randSamp( ) 146
RandSeed, random number seed 146
real( ), real 147
real, real( ) 147
reciprocal, ^⁻¹ 232
rectangular-vector display, ►Rect 147
rectangular x coordinate, P►Rx( ) 131
rectangular y coordinate, P►Ry( ) 132
reduced row echelon form, rref( ) 157
ref( ), row echelon form 148
RefreshProbeVars 149
regressions

cubic, CubicReg 40
exponential, ExpReg 66
linear regression, LinRegAx 99
linear regression, LinRegBx 98, 100
logarithmic, LnReg 105
Logistic 108
logistic, Logistic 109
medium-medium line, MedMed 114
MultReg 118
power regression,

PowerReg 137, 150-151, 187
quadratic, QuadReg 141
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quartic, QuartReg 142
sinusoidal, SinReg 169

remain( ), remainder 150
remainder, remain( ) 150
remove

void elements from list 49
Request 150
RequestStr 151
result

display in terms of cosine 29
display in terms of e 64
display in terms of sine 166

result values, statistics 178
results, statistics 177
return, Return 152
Return, return 152
right( ), right 152
right, right( ) 27, 61, 91, 152-153
rk23( ), RungeKutta function 153
rotate( ), rotate 154
rotate, rotate( ) 154
round( ), round 156
round, round( ) 156
row echelon form, ref( ) 148
rowAdd( ), matrix row addition 156
rowDim( ), matrix row dimension 156
rowNorm( ), matrix row norm 156
rowSwap( ), matrix row swap 157
rref( ), reduced row echelon form 157

S

sec⁻¹( ), inverse secant 158
sec( ), secant 157
sech⁻¹( ), inverse hyperbolic secant 158
sech( ), hyperbolic secant 158
second derivative

template for 6
second notation, " 228
seq( ), sequence 159
seqGen( ) 160
seqn( ) 160
sequence, seq( ) 159-160
series( ), series 161

series, series( ) 161
set

mode, setMode( ) 162
setMode( ), set mode 162
settings, get current 84
shift( ), shift 164
shift, shift( ) 164
sign( ), sign 165
sign, sign( ) 165
simult( ), simultaneous equations 166
simultaneous equations, simult( ) 166
sin⁻¹( ), arcsine 168
sin( ), sine 167
sine

display expression in terms of 166
sine, sin( ) 167
sinh⁻¹( ), hyperbolic arcsine 169
sinh( ), hyperbolic sine 168
SinReg, sinusoidal regression 169
sinusoidal regression, SinReg 169
solution, deSolve( ) 49
solve( ), solve 171
solve, solve( ) 171
SortA, sort ascending 174
SortD, sort descending 175
sorting

ascending, SortA 174
descending, SortD 175

spherical vector display, ►Sphere 175
sqrt( ), square root 176
square root

template for 1
square root, √( ) 176, 223
standard deviation, stdDev( ) 178-179, 198
stat.results 177
stat.values 178
statistics

combinations, nCr( ) 121
factorial, ! 220
mean, mean( ) 113
median, median( ) 113
one-variable statistics, OneVar 129
permutations, nPr( ) 127
random norm, randNorm( ) 146
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random number seed,
RandSeed 146

standard deviation, stdDev
( ) 178-179, 198

two-variable results, TwoVar 195
variance, variance( ) 198

stdDevPop( ), population standard
deviation 178

stdDevSamp( ), sample standard
deviation 179

Stop command 179
store variable (→) 233
storing

symbol, & 234
string

dimension, dim( ) 52
length 52

string( ), expression to string 180
strings

append, & 220
character code, ord( ) 131
character string, char( ) 22
expression to string, string( ) 180
format, format( ) 73
formatting 73
indirection, # 226
left, left( ) 96
mid-string, mid( ) 115
right, right( ) 27, 61, 91, 152-153
rotate, rotate( ) 154
shift, shift( ) 164
string to expression, expr( ) 66, 108
using to create variable names 241
within, InString 90

student-t distribution probability,
tCdf( ) 186

student-t probability density, tPdf( ) 190
subMat( ), submatrix 180, 182
submatrix, subMat( ) 180, 182
substitution with "|" operator 232
subtract, - 210
sum of interest payments 225
sum of principal payments 225
sum( ), summation 180

sum, ∑( ) 224
template for 5

sumIf( ) 181
summation, sum( ) 180
sumSeq() 182
system of equations (2-equation)

template for 3
system of equations (N-equation)

template for 3

T

t test, tTest 192
T, transpose 182
tan⁻¹( ), arctangent 183
tan( ), tangent 182
tangent line, tangentLine( ) 184
tangent, tan( ) 182
tangentLine( ) 184
tanh⁻¹( ), hyperbolic arctangent 185
tanh( ), hyperbolic tangent 184
Taylor polynomial, taylor( ) 185
taylor( ), Taylor polynomial 185
tCdf( ), studentt distribution

probability 186
tCollect( ), trigonometric collection 186
templates

absolute value 3-4
definite integral 6
derivative or nth derivative 6
e exponent 2
exponent 1
first derivative 5
fraction 1
indefinite integral 6
limit 6
Log 2
matrix (1 × 2) 4
matrix (2 × 1) 4
matrix (2 × 2) 4
matrix (m ×n) 4
nth root 1
piecewise function (2-piece) 2
piecewise function (N-piece) 3
product, ∏( ) 5
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second derivative 6
square root 1
sum, ∑( ) 5
system of equations (2-

equation) 3
system of equations (N-

equation) 3
test for void, isVoid( ) 95
Test_2S, 2-sample F test 76
tExpand( ), trigonometric expansion 186
Text command 187
time value ofmoney, FutureValue 193
time value ofmoney, Interest 193
time value ofmoney, number of

payments 194
time value ofmoney, payment

amount 194
time value ofmoney, present value 194
tInterval, t confidence interval 187
tInterval_2Samp, twosample t

confidence interval 188
ΔtmpCnv() 190
tmpCnv() 189-190
tPdf( ), student probability density 190
trace( ) 190
transpose, T 182
trigonometric collection, tCollect( ) 186
trigonometric expansion, tExpand( ) 186
Try, error handling command 191
tTest, t test 192
tTest_2Samp, two-sample t test 192
TVMarguments 195
tvmFV( ) 193
tvmI( ) 193
tvmN( ) 194
tvmPmt( ) 194
tvmPV( ) 194
two-variable results, TwoVar 195
TwoVar, two-variable results 195

U

underscore, _ 230
unit vector, unitV( ) 197

units
convert 231

unitV( ), unit vector 197
unLock, unlock variable or variable

group 197
unlocking variables and variable

groups 197
user-defined functions 46
user-defined functions and

programs 47-48

V

variable
creating name from a character

string 241
variable and functions

copying 29
variables

clear all single-letter 25
delete, DelVar 49
local, Local 106

variables, locking and unlocking 83, 107, 197
variance, variance( ) 198
varPop( ) 198
varSamp( ), sample variance 198
vectors

cross product, crossP( ) 36
cylindrical vector display,

►Cylind 42
dot product, dotP( ) 57
unit, unitV( ) 197

void elements 236
void elements, remove 49
void, test for 95

W

Wait command 199
warnCodes( ), Warning codes 200
warning codes and messages 251
when( ), when 200
when, when( ) 200
while, While 201
While, while 201
with, | 232
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within string, inString( ) 90

X

x², square 214
XNOR 220
xor, Boolean exclusive or 201

Z

zeroes( ), zeroes 202
zeroes, zeroes( ) 202
zInterval, z confidence interval 204
zInterval_1Prop, one-proportion z

confidence interval 205
zInterval_2Prop, two-proportion z

confidence interval 205
zInterval_2Samp, two-sample z

confidence interval 206
zTest 206
zTest_1Prop, one-proportion z test 207
zTest_2Prop, two-proportion z test 207
zTest_2Samp, two-sample z test 208

Χ

χ²Cdf( ) 24
χ²GOF 24
χ²Pdf( ) 24
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